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What's New

What's New in TI-SmartView™ CE Software v5.4.0
TI-SmartView™ CE 83 What's New

e TI-83 Premium CE default emulator state updated.

Python

0S v5.4.0

Python App v5.4.0

EasyData v5.3.6 (minor fix)

Transformation Graphing App v5.3.1 (minor fix)
Tl-Innovator™ Hub App v5.4.0 (menu updates)

e Python App v5.4.0 for the TI-83 Premium CE Edition Python

TI-SmartView™ CE v5.4.0 emulates the TI-Python experience as if using the

TI-83 Premium CE Edition Python calculator.

Run the Python App v5.4.0 in the CE emulator to use File Manager, Editor and

the Shell.

For any computer/TI-Python experience: After creating a Python program on
the computer, please validate your program runs on the calculator in the TI-

Python experience. Modify the program as needed.

Send *.py programs to the CE Emulator Explorer to convert and send your
programs as PY AppVars for use when Python App is running on the CE

emulator.

calculator files to the computer or to the emulator.

What is your CE calculator experience for TI-Python?
e TI-83 Premium CE Edition Python v5.4.0 or higher

Python App v5.4.0 (Python App)

e TI-83 Premium CE v5.4.0 or higher

For more information about the new and updated functionality, go to

TI-Python Adapter App v5.3.5 (PyAdaptr App)
TI-Python Adapter connected

education.ti.com/83ceupdate.

Always quit an App before switching to Emulator Explorer to send
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Introduction to TI-SmartView™ CE Software

The TI-SmartView™ CE software allows you to display a Tl graphing calculator for your
entire classroom. Two workspaces are included to help enhance your classroom

presentations.

&

o

Calculator Emulator Workspace

Allows you to:

Display a Full Emulator View or a Keypad with Large
Display Screen View. With optional views to open or
close.

Key Press History

— Displays images of keys pressed so students can
follow along with the keys pressed.

View3™
— Teacher controlled update of up to three

additional emulated screens such as Graph, Table
and Equation for multiple representations.

Calculate and Graph

— Same experience as on physical graphing
calculator.

Drag and Drop any emulated screen to your class
presentation software.**

— Build out your lessons with screens created
during your class.

Press emulator keys using a Remote Keypad!

— Run SmartPad™ CE App*** on your TI-83
Premium CE connected to the computer with your
USB cable. When the TI-SmartView™ CE window
is in focus on your computer, your calculator
becomes a Remote Keypad.

Launch a separate Screen Capture Window

— Capture and save emulator screens as computer
files similar to TI Connect™ CE Screen Capture
which captures screens from the graphing
calculator

**Software such as Microsoft™ Office or other presentation software supported.
***SmartPad™ CE App for TI-83 Premium CE comes pre-loaded on the calculator. If
not on your TI-83 Premium CE, SmartPad CE App is also available to load to your
calculator at education.ti.com/83ceupdate.

Note: The Large Display Screen is not touch enabled. Use emulator keys as on the

calculator.
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Calculator Emulator screen
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Emulator Explorer Workspace

Allows you to:

e Add single or multiple files to the emulator to set up for your
classes:

— Drag selected calculator files and/or your images (jpg,
png, etc.) from your computer to your emulator for quick
emulator setup even during class instruction.

e Save files from the emulator to save or share to your students
calculators:

— Drag selected calculator files to your computer to save
files from a class presentation.

—  Tip: Once files are saved to your computer, you can drag
those files to multiple connected student calculators using
Tl Connect™ CE Calculator Explorer for classroom sharing.
Tl Connect™ CE is free at education.ti.com/downloads.

Emulator Explorer default screen
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D Nederlan  Application Flash 7o Archive

@ Deutsch Application Flash asko Archive

@ Franais Application Flash 5060 Archive

@ python Application Flash 3250 Archive

@ AppVar Python 830 Mémoire RAM

@ AppVar Python 3990 Mémoire RAM

@ AReTRl AppVar Python 3670 Mémoire RAM

@ vk AppVar Python 2500 Mémoire RAM
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Using the TI-SmartView™ CE Calculator Emulator

Workspace

The TI-SmartView™ CE Calculator Emulator workspace contains tools you can use to

input calculations, plot variables, and display graphs, tables, and lists.
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Parts of the TI-SmartView™ CE Software Workspace

o

Fichier Modifier Afficher Actions Ressources Aide

Menu Bar - Use these menus to perform all emulator functions, including:

e File - file management e Actions - such as screen capture

Resources - menu to find links to free
resources from Tl for teachers and
students.

e View - change the displays ¢ Help - Help and links

e Edit - include copy key as
font

Note: You can complete most of the actions in these menus by clicking icons in
the toolbar.

Toolbar- Use these toolbar icons to:

e Select a different calculator model

. Togglae displays of Large Display Screen, Key Press History on or off, and,
View>™

e Capture current emulator screen

Workspace Panel - Use this panel to navigate between the Calculator Emulator
workspace and the Emulator Explorer workspace.

Choose Emulator and Tool Bar Positions

3
e Emulator position Left/Right @ - to switch between left and right hand
display of the graphing calculator screen. This is convenient when projecting
an Interactive White Board.

e Tool Bar Top/Bottom (2 to toggle the tool bar between the top and the
bottom of the screen. This is convenient when projecting an Interactive White
Board.

Note: You can change the visual layout and/or position of elements to optimize
access especially when using an Interactive White Board.

Emulator Panel - Use this panel to use the full emulator or the emulator keypad
only view.

Large Display Screen Panel/Key Press History Panel - Use this panel to display a
large version of the calculator screen and/or to display key press history.

You have the following display options:

e Large Display Screen only e Key Press History only
* Llarge Display Screen + Key Press | Hide panel
History P

o

View3™ Panel - Use this panel to show three additional screens simultaneously.
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(This panel is hidden by default. Click m to show the View3™ Panel.)
You can select any three of the following screens:

e Equation o List e  Window
(Y= editor) (Stat List editor)

e Table e Stat Plot e [Blank]

e Graph

@ Resize Panels - Click and drag the vertical bar at the side of a panel to resize it.

Using the TI-SmartView™ CE Emulator Keyboard
The mouse takes the place of your finger pressing keys on the computer keyboard.

Click the keys on the TI-SmartView™ CE emulator as you would press the keys on the
graphing calculator.

@
&

A
oy
1. Click the arrow keys <2 on the emulator keyboard to move the cursor to the

desired setting.
précéd

entrer

2. Click to select it.

You must first place the keyboard in its alpha typing mode to type text using the
computer keyboard.

By default, the graphing calculator keyboard is in its normal mode, in which keys are

simply shortcuts to graphing calculator keys.
tests A

For example, pressing [ A ] on your computer keyboard is the same as clicking math

on the graphing calculator. In this mode, you cannot enter the letters A through Z on
the graphing calculator screen by typing these letters on your computer keyboard.

worr A

To enter a letter or other alpha character, first click m on the graphing calculator
keyboard (or press [ F7 ] on your computer keyboard) to put the graphing calculator in
alpha mode. For example, typing [ F7 1 [ A ] on your computer keyboard enters an A on
the graphing calculator screen. After you type the character, the keyboard returns to its
normal mode.

You can lock the alpha key to type more than one character in succession.
To lock the alpha key:
warr A

> Click w m on the graphing calculator keyboard or press [ F6 ] [ F7 ] on
your computer keyboard.

To return to the normal mode:

» Clickor press [ F7].

Using the TI-SmartView™ CE Calculator Emulator Workspace 7



In alpha typing mode, pressing [ 0 ] through [ 9 ] on your computer keyboard act as
shortcuts to the alpha functions associated with these keys on the graphing calculator
keyboard. Pressing [ 1] enters Y (the alpha character associated with [1]) on the
graphing calculator screen. To type a number, be sure the keyboard is not in the alpha
typing mode. These keys do enter the digits 0 through 9 in the normal mode.

You can hold down an arrow key to scroll the cursor continuously.

When you use an arrow key to move the cursor, you can hold down the key to scroll the
cursor continuously, instead of having to press the key repeatedly. In the key press

5 =

history, the icon for a repeating arrow key has a clock symbol Gs attached to it.

Pressing an arrow key multiple times in a row displays an arrow with a repeat
counter.

When you press an arrow key multiple times in a row, one arrow key is displayed in the

% =

key press history; this arrow key @ has a number attached to it that shows the
number of times the arrow key was pressed.

Tip: When tracing along graphs or using Cabri™ Jr App to draw geometric shapes, the
computer keyboard arrows may give you smoother continual action as opposed to
using a mouse to click on the emulator arrows.

Dragging and Dropping a Screen to Another Application

You can drag and drop and paste any TI-SmartView™ CE screen into another
application.

The TI-SmartView™ CE screens that you can drag and paste include the following:

e The screen above the keyboard in the Emulator Panel

e Large Screen

o View3™ panel screens

Note: You can drag a View3™ screen into Screen Capture and use Screen Capture as
a history of important screens during a class session.

e Saved or unsaved screen captures

8 Using the TI-SmartView™ CE Calculator Emulator Workspace



Connecting a Calculator as a Remote Keypad

The SmartPad™ CE App is available for the TI-83 Premium CE.

To use the TI-83 Premium CE as a remote keypad for TI-SmartView™ CE:

1. SmartPad™ CE App for TI-83 Premium CE comes pre-loaded on the calculator. If not
on your TI-83 Premium CE, SmartPad CE App is also available to load to your
calculator at education.ti.com/83ceupdate.

2. Connect your TI-83 Premium CE to your computer using a USB Computer cable
which came with your calculator.

3. Launch TI-SmartView™ CE. Make sure the TI-SmartView™ CE window is in focus by
clicking on the TI-SmartView™ CE window.

4. Run SmartPad™ CE App on your TI-83 Premium CE. Press [apps] and select
SmartPad™ CE from the Apps menu. Read the information on the splash screen.

SmartPad™ CE SmartPad™ CE
for TI-SmartView™ CE for TI-SmartView™ CE
... JINSTIE@ UNPLUG USB CABLE EDIESE UNPLUG USE CRBLE
COMPUTER WINDOM OF EMULATOR COMPUTER WMINDOM OF EHULATOR
HUST BE SELECTED MUST BE SELECTED
oo O PRESS EULRTOR KEYS e TO PRESS EMULATOR KEVS =~~~

5. Press keys on the calculator's keypad which remotely press the emulator keypad on
the TI-SmartView™ CE.

6. Disconnect USB cable from calculator to stop the App and remote keypad feature.

7. Reconnecting the USB cable and running the App again may be needed if the
remote keypad connectivity is no longer responding.

Notes:

The TI-83 Premium CE running the SmartPad™ CE App will not display the
calculations or graphs. The calculator becomes a remote USB keypad for the
emulator only.

The TI-83 Premium CE will remain a remote keypad when the TI-SmartView™ CE
window is in focus. Click on the TI-SmartView™ CE window prior to pressing keys
on the calculator.

The TI SilverLink cable is not supported in TI-SmartView™ CE.

Using the TI-SmartView™ CE Calculator Emulator Workspace 9
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USB Computer Cable

You must use the USB Computer Cable that comes with your TI-83 Premium CE or
TI-83 Plus.fr graphing calculator. Other Tl Connectivity Cables are not supported.

Additional information on connectivity

e Emulator Link Menu - No Send/Receive

The Link feature, liink] on the emulators is disabled. To link files between a
connected calculator and an emulator, please use Calculator Explorer in Tl
Connect™ CE and Emulator Explorer in TI-SmartView™ CE.

Drag calculator or emulator files to the computer first when transferring between
Emulator Explorer in TI-SmartView™ CE and Calculator Explorer in TI Connect™ CE.

e TISilverLink cable
The TI SilverLink cable is not supported in TI-SmartView™ CE.
® Bringing a calculator out of a EXAM MODE setting
TI-SmartView™ CE will not transfer a file to a connected calculator.
To quit EXAM MODE setting, please use one of these methods.
- Connect a CE to Tl Connect CE v5.4.0 or higher

- Select Actions > Quit Exam Mode on Connected CE Calculators
- Send a file between two calculators

- Connect to Tl Connect CE v5.4.0 or higher and send a file to a connected
calculator(s)

10 Using the TI-SmartView™ CE Calculator Emulator Workspace



Resetting the Emulator
To reset the emulator:
1. Click Actions.

2. Click Reset Emulator.
3. Click Reset.

ENE x|

Réinitialiser I'émulateur ?

Réinitialiser 'émulateur écrasera tout le contenu de
état de 'émulateur actuel, y compris tous les
&léments des mémoires RAM et Archive,

Souhaitez-vous réinitialiser I'émulateur ?

ANNULER REINITIALISER

Resetting the emulator:

e Overwrites the current emulator state

e Returns the TI-SmartView™ CE Software to the factory-default setting
e C(lears keypress history

Update Emulator OS

In the future, if there is a CE calculator OS update but TI-SmartView™ CE emulator is
not updated, then the Emulator can be updated with Actions > Update Emulator OS....
TI-SmartView™ CE will require a special emulator state file to update the Emulator OS
available at education.ti.com/83ceupdate. This file will be different than the file you
use to update the calculator OS.

Using the TI-SmartView™ CE Calculator Emulator Workspace 11
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Saving and Loading a CE Emulator State

When you save the CE emulator state, a file is created that stores the emulator
settings with all of the changes that you have made.

For example, you might want to set up a class presentation by entering functions in the
Y= editor and changing Window and Zoom settings. When you save your changes in an
emulator state file, you simply load the file to show your presentation. If you want to
create different presentations for different classes, you can create multiple emulator
state files.

Note: The key press history, screen capture shots, the emulator view, and the emulator
size are not saved in the emulator state file. Please take note the CE Emulator state
files may be large. Contact your IT department if your storage capacity is an issue.

Saving the CE Emulator State

Managing, saving and loading an emulator state file is only available for the CE
emulator. The TI-83 Premium CE Emulator State file can only be loaded on the TI-83
Premium CE emulator.

1. Click Actions > Save Emulator State....

[ TI-SmartView™ CE pour la famille TI-83

Fichier Modifier Afficher Actions Ressources Aide

LOTT AUTO REEL RAD MP n
Effectuer une capture décran curlT
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quiter
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verA  échanger

Mettre 3 jour '0S de Fémulateur...
XTan

. Réinitialiser émulateur
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(] e o D
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o su TL UL
Tl X L1 Y12 Z13 @ mém

ME E-
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2. Inthe dialog box:
a) Navigate to the folder in which you want to store the CE emulator state file.
b) Type a file name. Use a name that describes the CE emulator state.
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The CE emulator state files will have a pre-configured filename TI83PCE Emulator
State_0OS x-x-x_date.s83 where the file extension, *.s83 indicates that the file is a
TI-83 Premium CE emulator state created by the TI-SmartView™ CE software. A CE
emulator state file created in TI-SmartView™ CE v5.4.0 or higher will not load on
previous versions of TI-SmartView™ CE.

c) Click Save.
Loading an CE Emulator State

Because CE emulator state files are specific to each calculator model, you can only
load an emulator state file for the active calculator model.

1. Click Actions > Load Emulator State.

[ TI-SmartView™ CE pour la famille TI-83

Fichier Modifier Afficher Actions Ressources Aide

- o . 0TT AUTO REEL RAD MP n

p—y ot
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Enregistrer Iétat de Fémulateur...

qitter

m Chargez tétat de lémulateur..

verrA  échanger

] e

tests A x' B 1

] e [

. E apps F [jdo G

angle D H
[Z]

v 1 EE J K} Le L
CEOMOIE
(w7 ][s ][ ] (5]
o* s Yi w

Mettre & jour [0S de lémulateur...

Réinitialiser fémulateur

2. In the dialog box:
a) Navigate to the folder that contains the emulator state file.

Note: Only the CE emulator state files for the active calculator model will be
displayed.

b) Click the CE emulator state name to highlight it.

c) Click Open.

Using the TI-SmartView™ CE Calculator Emulator Workspace 13



Choosing a Display Option

You can customize your display to show or hide optional panels and change the type of
information displayed in each one. By default, the TI-SmartView™ CE software displays
the calculator emulator workspace in large screen mode.

Displaying the Calculator Screen

1. Click E to view the calculator 2. Click E again to show the

screen above the keyboard in the calculator screen in the Large
Emulator Panel. Display Panel.

B St e pour s e 183 B

NORMAL FLOTT AUTO REEL RAD MP n

Choosing an Emulator Type

Click the down arrow on . to choose an emulator type.

+/  TI-83 Premium CE

TI-82 Advanced / TI-83 Plus.fr
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Each emulator type displays its relevant calculator model.

TI-83 Premium CE TI-82 Advanced | TI-83 Plus .ir
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Changing the Calculator Faceplate

To change the faceplate:

1. Click View.

2. Hover over Calculator Faceplate.

3. Click on a calculator faceplate name.

Light Outline
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Showing or Hiding the Key Press History

Click “a to show or hide key press history.
Click CLEAR in the panel next to Key Press History to clear the history.

Historique des touches o 3] EFFACER

5 U T3 v 9
1 w

(s J[=][ e ]

Click here and drag to resize the @ Click here to clear the
Key Press History panel. Key Press History.

When you press clear, you will see this information box:

E Historique des touches \E\' [=] '@

Etes-vous certain de voul oir supprimer 'historigue ?
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Copying the Key Press History to Another Application

You can copy all or only a selected portion of the key press history to another
L2 Z

application such as a word processor. You can copy the key graphics @ as they are

shown in the key press history panel, or you can copy the key presses as font text

characters (5] [=] [6].

Note: When you copy keys as font text characters, those characters use the
TI83PremiumCEKeys font. This font is installed on your computer automatically when
you install the TI- SmartView™ CE software.

Copying Keys as Graphics or Font Characters

1. Select the key(s) you want to copy.
To select keys in the Key Press History Panel, use one of the following methods:

Key Method

— Asingle key: Click on a key.

—  Multiple keys: Click on a key.
Press and hold Ctrl on your computer
keyboard.
Click other keys to select multiple keys.

—  Multiple keys in a sequence: Click on a key.
Press and hold Shift on your computer
keyboard.

Press another key.

Note: This allows you to select those
two keys plus all of the keys in
between them.

—  All keys: Click on a key.
Right click.
Click Select All.

Note: This is what a key looks like before and after you select it.

Before: After:

L2 Z L2 Z

2] 2]

2. Right-click the selected key(s).
3. Click Copy (to copy keys as graphics).

-or-

Click Copy As Font (to copy keys as font characters). (5] (=] (6].

Using the TI-SmartView™ CE Calculator Emulator Workspace
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4. Switch to another application.

5. Paste the keys at the appropriate location.
Note:

* You can also drag the selected keys as graphics to the other application.
* You can re-size the key graphics after you paste them into a new application.

e Insome applications, the characters pasted as a font may be shown in the font
that is in effect at that location, so they may not look anything like graphing
calculator keys. If necessary, apply the TI83PremiumCEKeys font to the characters.
See the help file for the application you are using for details on how to apply a font
to the characters.

Displaying the View3™ Panel

CIickm to display the View3™ panel.

Click the title bar of each screen to choose from these display options:

— Equation — List .

(Y= editor) (Stat List editor) Window
— Table — Stat Plot — [Blank]
— Graph

3. Click the in the green bar at the top of the View3™ panel to refresh the View3™

screens. This updates the view for your students during investigations.

Update detected Updating or cancel No update detected

4. View content in the selected screens, or repeat step 2 to change the screen type.

18 Using the TI-SmartView™ CE Calculator Emulator Workspace



Changing the Size of the TI-SmartView™ CE Screen

Click and drag the edge of a panel to change the size of the Emulator Panel, the Large

Display Screen, or the View3™ Panel.
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Note: All of these are left/right actions except the Key Press History which is pull up or

down to size.

Emulator and Toolbar positions

Emulator position Left/Right - to switch between left and right hand
@ﬂ display of the graphing calculator screen. This is convenient when
projecting an Interactive White Board.

Tool Bar Top/Bottom - to toggle the tool bar between the top and the
E bottom of the screen. This is convenient when projecting an Interactive
White Board.

Using the TI-SmartView™ CE Calculator Emulator Workspace
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Always in Front

Select this option in the View Menu to keep the TI-SmartView™ CE windows in front of
any other computer software window open. Similar to having the calculator sitting on

your desk on top of your papers! Position the window on your computer desktop where
it is best to remain "Always in Front."

To turn off "Always in Front," deselect the menu item in the View menu. There is no
toolbar icon for this feature and no indicator other than the menu check mark when
active.

Notes:

The TI-SmartView™ CE Emulator Workspace window and Screen Capture windows will
both be "Always in Front" and toggle in front depending on their position.

"Always in Front" is not recommended when in full screen since all other windows will
be behind the full screen of TI-SmartView™ CE.
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Using Screen Capture

You can capture the current graphing calculator screens using the TI-SmartView™ CE
screen capture tool.

To use screen capture:

> CIick on the toolbar.

This window appears:

|5 Capture d'écran de TI-SmartView™ CE

Modifier Afficher

*Capturer 1 @

"8cos(X)Y2
.. Fait,
"L 1XE-31aY2

Fait,
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Parts of the Screen Capture Workspace

1

Capture Click here to take an emulator screen capture.
Actions > Capture Screen

Note: A border is automatically added to each image when
you capture it, but you can remove the border by clicking View
> Hide Screen Capture Borders. (If you have multiple images,
this removes the border from every image.)

With screen capture you can:

e capture up to 44 screens at a time, (to capture additional
images, delete images from the Screen Capture window)

e automatically store screen captures in memory until you
close the main TI-SmartView™ CE window.
Closing Screen Capture gives a prompt to save your screen

captures. You can start a new Screen Capture session during
a TI-SmartView™ CE session.

@ Save Click here to save selected screen captures.
File > Save As

9 Copy Click here to copy selected screen captures to the clipboard.
Edit > Copy

o Delete Click here to delete selected screen captures.
Edit > Delete

@ Resize Slide the dot along the bar to adjust the current screen

capture preview size.
View > Scale Screen Captures
Note: Screens save at the percentage in view.

6/

Rename Rename a screen capture by highlighting the title and typing
in a new name.

o

View View screen captures here.

Dragging and Dropping a Screen to Another Application

You
app

The

can drag and drop and paste any TI-SmartView™ CE screen into another
lication.

TI-SmartView™ CE screens that you can drag and paste include the following:

The screen above the keyboard in the Emulator Panel

Large Screen

View3™ panel screens

Note: You can drag a View3™ screen into Screen Capture and use Screen Capture as

a history of important screens during a class session.

Saved or unsaved screen captures

22

Using Screen Capture



Using TI-SmartView™ CE Emulator Explorer Workspace

Emulator Explorer workspace allows you to manage emulator files, add content from
your computer to your emulator, and send selected content to your computer.

[ TI-Smartview™ CE pour la famille TI-83 - o X

Fichier Modifier Afficher Actions Ressources Aide

y=i
@ TI-83 Premium CE  RAM: 147 ko disponibles.
Now Tvee e EMPLACEMENT
IE]

@ Hub Application Flash 6ko Archive

@ Probsim Application Flash 71ko Archive

@ easypata Application Flash 167k0 Archive

@ celsheet Application Flash 1230 Archive

@ Transfrm Application Flash 28ko Archive

@ cabrir Application Flash 1020 Archive

@ Pperiodic Application Flash 46ko Archive

@ scools Application Flash sako Archive

@ conics Application Flash 42ko Archive

@ Pysmiz Application Flash s8ko Archive

@ inequalz Application Flash 44ko Archive

@ svenska Application Flash 47ko Archive

@ Espafiol Application Flash 46ko Archive

@ sortug Application Flash Stko Archive

@ Nederlan Application Flash 47k0 Archive

@ Deutsch Application Flash 46ko Archive

@ Francais Application Flash soko Archive

@ python Application Flash 3200 Archive

@ AREDEF AppVar Python 830 Mémoire RAM
@ ARERECT  AppVar Python 3990 Mémoire RAM
@ ARETRI AppVar Python 3670 Mémoire RAM
@ oK AppVar Python 2500 Mémoire RAM
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Parts of the TI-SmartView™ Emulator Main Workspace

= @ c
o 6 0O

Add calculator files from computer to emulator.

i

Send selected calculator files to computer.

Delete selected calculator files.

Refresh the view of the emulator's contents.

Note: When changing the workspace to Emulator Explorer, refresh the
view of the emulator files to update any changes made in the emulator.

OO o

Copying Emulator Files to the Computer

You can copy most data, files, and programs from your emulator to your computer as a
backup, to send to others, or to free up emulator memory.

To copy a file from the emulator to the computer

1. Click on the file name to select it.

|
2. CIick.

_Or‘_
Drag and drop the file into a folder on your computer or onto your desktop.

To copy a file from the computer to the emulator

K.
Click .

Navigate to the desired file on your computer.

Note: You can also drag your images (.jpg, .png, etc.) to convert to
emulator/calculator Background Images as well.

3. Click on the file to select it.
4. Click Open.

Deleting Emulator Files
You can delete data, files, and programs from your emulator.

To delete files from the emulator

1. Click on the file name to select it.
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2. Press .

Computer Keyboard Shortcuts

You can use your computer keyboard to press a key instead of pressing that key on the
TI-SmartView™ CE keyboard image.

For example:

If you want to enter the "log" function on the emulator keypad, use the table below to
find the computer key to press.

(o)

[M]

> Press [N] on your computer keyboard (and notice that the emulator key upper left
is the alpha letter N.)

Note: In some instances, pressing the computer keyboard key will display the key
on the emulator. The Key Press History icon may not display until the next key
press.
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Compatibility with Graphing Calculators

Please refer to the TI-83 Premium CE Getting Started Guide for compatibility with
graphing calculators.

Note: In general, TI-83 Premium CE graphing calculator files are compatible with other
TI-82 Advanced and TI-83 Plus.fr models.

Apps, Operating Systems and some data files with unsupported numeric types do not
share between models.

Tl-Basic programs may need to be modified to correctly display on the high resolution
color screen models.
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The Python Experience

Using TI-SmartView™ CE to Demonstrate the Python Experience

L4 Update TI-SmartView™ CE pour Ia 5 TI-SmartView™ CE pour la famille TI-83 - [m] x
famille TI-83 v5.4.0 or higher at e ——
education.ti.com/83ceupdate

e Launch TI-SmartView™ CE v5.4.0.

e Run the Python App on the g 9 Toxas Insmrovents TI-83 Prefmim
TI-83 Premium CE emulator. &

e Python App offers
— File Manager

— Editor
— Execution of your Python program
in the Shell

e SmartPad CE App will remotely press T e ) ) s

the keypad when the Python App is itler insérer

running. m Lﬁ“’“ [I"“""' O O
* You can send your computer *.py files - XTan| [ stats |
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Note: Please quit Python App before switching to Emulator Explorer to send/receive PY
AppVars. If the Python App is left running, any updates to a program in the Python
Editor are not yet updated in Emulator Explorer workspace.

*Note: The emulator name remains TI-83 Premium CE without the Edition Python
designation but runs the Python App. No TI-Python Adapter is needed.

Reminder: For any computer/TI-Python experience: After creating a Python program on
the computer, please validate your program runs on the calculator in the TI-Python
experience. Modify the program as needed.

Note: To break a running Python program, such as if a program is in a continuous loop,
press [on]. Press [Tools] ([zoom]) > 6:New Shell as an alternate method to halt a running
program.

28 The Python Experience


https://education.ti.com/83ceupdate

Data Collection Using Vernier EasyData® App on the TI-
83 Premium CE Emulator

Vernier EasyData® CE App allows you to use Data Collection on the TI-83 Premium CE
emulator. The Vernier EasyData® CE App for TI-83 Premium CE comes pre-loaded on

the emulator in TI-SmartView™ CE. This App allows you to collect single sensor data

similar to using the App on the calculator.

Tips:

e Make sure you are familiar with collecting data using the EasyData® App on the
calculator prior to using TI-SmartView™ CE to collect data.

e Make sure you are familiar with the EasyData® CE App menu (File>New) or the
Scan shortcut key feature. You will use these features in the emulator to connect a
sensor to the emulator while the sensor is connected to the computer.

Using Vernier Sensors with TI-SmartView™ CE and EasyData® CE
App

If you already use Vernier sensors with the TI-8x family calculator with a mini-USB
port, the sensor connects to the mini-USB port on the calculator.

Vernier sensors used with the TI-8x family (mini-USB) need the appropriate adapter to
connect (USB) to the computer for data collections demonstrations.

Adapters

Connect Sensor Type to Computer

Name Adapter Description
Easy to Go! Use this adapter to connect an EasyTemp or
EasyLink™ adapter to a computer for data
collection. See more
—
Gollink Use this single-channel interface adaptor to

connect most Vernier sensorsto your
computer. See more

Go!Motion to Use this cable to connect a Go!Motion or CBR
Computer 2to acomputer. Itisincluded with
Cable Go!Motion. See more
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Connect Sensor Type to Calculator

Name Adapter Description

EasyLink™ Use this adapter to link Vernier sensors to your Tl-

EdSyLink ‘\ 83 Premium CE graphing calculator. EasyLink™ is a

" | single-channelinterface that plugs into the USB
port of a TI-83 Premium CE graphing calculator or
TI-Nspire™ Handheld. See more

Go'lto Easy Use this adapter to connect a Go!Temp or
Adapter GolLink™* to the USB port of a TI-Nspire™
(mini USB) n handheld or TI-83 Premium CE graphing
calculator. See more

=
Go!Motion Use this 72" cable to connect a Go!Motion or CBR
to 2to the USB port of a TI-Nspire™ handheld or TI-
Calculator @ 83 Premium CE graphing calculator. The cable has
Mini-USB ﬁ £ a USB Mini-A plug that connects to the calculator
port v 5 and a standard-B USB plug that connects to the

Go!Motion or CBR 2. The cableisincluded with a
CBR 2. Seemore

If Using for Classroom Demonstrations

Data collection using the EasyData® App is only supported on the TI-83 Premium CE
emulator for classroom demonstration purposes. If your class is using any TI-8x Family
calculator running the latest Vernier EasyData® App for that calculator, the
demonstration of data collection using TI-SmartView™ CE and the TI-83 Premium CE
will be parallel to the calculator experience on TI-8x Family calculators.

Single Sensors Data Collection

Single-sensor data collection is supported in the TI-83 Premium CE emulator (similar to
the TI-83 Premium CE calculator).

If a sensor is supported using the EasyData® App on the calculator via mini-USB, the
emulator in TI-SmartView™ CE provides a demonstration tool for data collection
similar to the experience on the calculator.

e CBR 2™ (Calculator-Based Ranger™) is supported with the USB cable.
e (CBL 2™ (Calculator-Based Laboratory™ system) is not supported.

e The latest Vernier EasyData® CE App for TI-83 Premium CE comes pre-loaded in the
emulator.

e Older versions of the App are blocked in Emulator Explorer for the best data
collection experience.
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Using TI-SmartView™ CE to Demonstrate Data Collection

1.

Launch TI-SmartView™ CE.

Tip: If you are running any other computer software that also collects data using
Vernier USB sensors, we recommend that you close all other data collecting
software so TI-SmartView™ CE recognizes the single sensor for your data collection
session. Otherwise, your computer operating system will “decide” which sensors it
will recognize. You may not see your sensor connect to TI-SmartView™ CE until you
close other software.

b
Click the down arrow on . to choose an emulator type.

+  TI-83 Premium CE

TI-82 Advanced / TI-83 Plus.fr

Connect one sensor to your computer via standard USB.

Advanced Feature: You can have several sensors connected to your computer ports.
You can use the TI-SmartView™ CE Actions menu (Actions>Select Data Collection
Sensor) to switch between sensors. Use the EasyData® CE App menu (File>New) to
connect the new sensor to the emulator.

Run the EasyData® CE App on the TI-83 Premium CE emulator.

Note: The latest Vernier EasyData App for the TI-83 Premium CE emulator (v 5.2 or
higher) comes pre-loaded in TI-SmartView™ CE (v 5.2 or higher).

EasyData® launches on the emulator. You should see the name of the sensor (or
link connection) on the splash screen. The sensor name will then appear in the
meter screen similar to the calculator experience.

If EasyData® App does not recognize the sensor connected to the computer, use
either Scan or File>New in the EasyData® App on the emulator to connect the
sensor.

Use EasyData® App features as on the CE emulator to collect and analyze the data.

When data collection is complete, QUIT the EasyData® App in the emulator to
continue to use TI-SmartView™ CE.

e Data from the data collection experiment is stored to lists in the emulator
when quitting the EasyData® CE App.

* You may leave the sensor plugged into your computer as needed.
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While EasyData® CE App is running on the CE emulator you may do the following:

Switch You may switch emulators while EasyData® is running;

Emulator however, the data experiment will stop and the sensor will

Workspace disconnect from the CE emulator running the EasyData®
App. When you return to the CE emulator, you will need to
reconnect the sensor to EasyData® CE App using either
File>New or the “Scan” shortcut key in the EasyData® App
and begin a new data collection experiment. Previous
experiment data may or may not be stored. Always “QUIT”
the EasyData® CE App to store experiment data to the
emulator lists.

View>™ and  View>™ is not available (disabled) for all Apps other than
Apps the Inequality Graphing App.
View3™ only displays screens from the ™ Operating System
and does not display App screens. We recommend that you
keep View3™ closed when not using this feature or if the
feature is disabled as when most Apps are running on the
emulator.
Switch to If EasyData® is running in the CE emulator and if you need
Emulator to use Emulator Explorer, please quit the EasyData® App
Explorer and then use Emulator Explorer.
Workspace
Capture You can capture EasyData® CE App screens while running
Screens an experiment using Screen Capture.
Close and You may close TI-SmartView™ CE while EasyData® is
Re-open running; however, the data experiment will stop and the
TI- sensor will disconnect from the CE emulator running the
SmartView™ EasyData® App. When you return to the CE emulator, you
CE will need to reconnect the sensor to the EasyData® CE App

using either File>New or the “Scan” shortcut key in the
EasyData® App and begin a new data collection
experiment. Previous experiment data may or may not be
stored. Always “QUIT” the EasyData® CE App to store
experiment data to the emulator lists.

Additional help

If you need additional help using the EasyData® App with the calculator to collect data,
please see http://www?2.vernier.com/manuals/easydata guidebook.pdf for details.

32 Data Collection Using Vernier EasyData® App on the TI-83 Premium CE Emulator


http://www2.vernier.com/manuals/easydata_guidebook.pdf

General Information
Online Help

education.ti.com/eguide

Select your country for more product information.

Contact Tl Support

education.ti.com/ti-cares

Select your country for technical and other support resources.
Service and Warranty Information

education.ti.com/warranty

Select your country for information about the length and terms of the warranty or
about product service.

Limited Warranty. This warranty does not affect your statutory rights.
Updates

education.ti.com/83ceupdate
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