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Introduction to the TI Connect™ 4.0 
software

The TI Connect™ software makes exchanging information between your 
TI graphing calculator and personal computer quick and easy. You can 
use TI Connect™ software to take a screen capture and convert and send 
images. You can also transfer, back up, update, create, and access device 
content. 

The TI Connect™ software includes the TI DeviceExplorer, Backup, 
Restore, TI ScreenCapture, TI DataEditor, TI DeviceInformation, 
Explore My TI Data, and Send To TI Device tools. This complete package 
of tools will help you to effectively use your TI graphing calculator with 
your computer.

The TI Connect™ window
The TI Connect™ window contains various tools you can use to exchange 
information between your device and computer. 

Window 
control 
buttons

Resource 
buttons

Tools screen
User buttons



2  Introduction to the TI Connect™ 4.0 software

Parts of the TI Connect™ window

Tools screen – shortcuts to the tools that are available in the 
TI Connect™ software. 

Resource buttons – connect to the education.ti.com to search for 
resources or check for software updates for your device.

Window control buttons – minimize and close the TI Connect™ 
software home screen.

User buttons – change your settings and access the TI Connect™ help.

Software tools on the Home screen
The TI Connect™ Home screen provides a group of tools that come with 
the TI Connect™ software. Each tool can help you use your TI graphing 
calculator with your computer. 

There are three different types of tools on the Home screen:

App tools – run in their own windows separate from the TI Connect™ 
window and do not require the TI Connect™ window to be open in 
order to run (include TI DeviceExplorer, TI ScreenCapture, TI DataEditor, 
and TI DeviceInfo, and Send To TI Device tools)

Home tools – run directly from the Home screen (includes Backup and 
Restore tools)

Plug-in tool – uses the Windows® Explorer software on your computer 
to run, for example My TI Data is a plug-in tool and uses Windows® 
Explorer software to run.
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The TI Connect™ software tools

TI DeviceExplorer – Display all files on the TI graphing calculator and 
transfer device files between a TI graphing calculator and a computer.

TI ScreenCapture – Capture, convert, and send images to your TI 
graphing calculator.

Backup – Backup the files of TI graphing calculators.

Restore – Restore files to backed-up TI graphing calculators.

TI DataEditor – Create and manipulate data variables.

TI DeviceInfo – Find information about connected TI graphing 
calculators.

Explore My TI Data – Open Windows® Explorer to work with device 
and group files.

Send To TI Device – Browse for a TI graphing calculator file stored on 
your computer and send to the connected TI graphing calculator.
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Opening and closing the TI Connect™ software
You can open the TI Connect™ software from your desktop or from a 
TI Connect™ tool. You can close the TI Connect™ software from the 
TI Connect™ window. 

To open the TI Connect™ software from your desktop
You can open the TI Connect™ software in either of the following ways:

 Double-click the TI Connect™ desktop icon.

 Click Start > Programs (or All Programs) > TI Tools > TI Connect.

To open the TI Connect™ software from a tool
You can open the TI Connect™ software from TI DeviceExplorer, TI 
ScreenCapture, and TI DataEditor.

 Click Tools > TI Connect™Home or click .

To close the TI Connect™ software or tools

 Click .

Using Send To TI Device
You can use Send To TI Device to send files to your graphing calculator.

 Click Send To TI Device desktop icon.

 Click Browse.

 Select files to send to the graphing calculator.

 Click Send to Device.
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Note: If no USB port displays when you select Send To TI Device, unplug 
and replug your USB cable from the computer; turn the graphing 
calculator on, and click the Refresh button. 
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Using TI DeviceExplorer

TI DeviceExplorer is a tool in the TI Connect™ software that you can use 
to access, change, and update the contents of your TI graphing 
calculator. 

TI DeviceExplorer window
The TI DeviceExplorer window lists all of the files on the connected TI 
graphing calculators, as well as buttons and menus you can use to work 
with these files.

Parts of the TI DeviceExplorer main window

Directory – A list of the connected device’s contents. It varies depending 
on the device type and the files on the device.

Menu bar – Menus at the top of the window that you can use to tell the 
program what actions you want to perform.

Menu bar

Status bar

Directory

Toolbar



8  Using TI DeviceExplorer

Status bar – Part of the TI DeviceExplorer main window that indicates 
the state of the current operation in TI DeviceExplorer.

Toolbar – A set of buttons on the TI DeviceExplorer window that 
provides shortcuts to the TI DeviceExplorer tools.

Changing the selected device type
The TI Connect™ software lets you have multiple devices connected at 
once. However, the software can only work with one device at a time. 
When you want to use a device different from the currently selected one, 
you must change the selected device type. The device type you select 
becomes the default device for all TI Connect™ tools. It remains the 
default until you change the selected device type again.

Before you begin
Make sure the device you want to select is properly connected to the 
computer.

To change the selected device type
1. Click Actions > Select Device.

2. When the device you want appears in the dialog box, click it.

3. Click Select.

Note: If no USB port displays when you select Send To TI Device, unplug 
and replug your USB cable from the computer; turn the graphing 
calculator on, and click the Refresh button. 
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Compatibility with graphing calculators

Note: Not all TI-84 Plus C Silver Edition graphing calculator files are 
compatible with other TI-84 Plus Family graphing calculator files because 
of the high resolution of the TI-84 Plus C Silver Edition color screen. In 
general, numeric files (not limited to lists, variables, matrices, and 
functions) are shared between these graphing calculators but Apps are 
not shared between these graphing calculators even if they have the 
same title. When not compatible, the computer file extensions for the 
TI-84 Plus C Silver Edition are different from a similar variable from the 
TI-84 Plus/TI-84 Plus Silver Edition graphing calculators.

File Type Link from 
TI-84 to 

TI-84 Plus C

Link from 
TI-84 Plus C to 

TI-84

84P 
computer 
file type

84PC 
computer 
file type

Operating 
System

No No 8xu 8cu

Apps No No 8xk 8ck

AppVar* Yes Yes 8xv 8xv

Programs - 
TI Basic*

Yes Yes 8xp 8xp

Assembly 
Programs*

Yes No 8xp 8xp

Pictures No No 8xi 8ci

Background 
Images

N/A No N/A 8ca

Group Files Yes Yes 8xg 8cg

User Zoom Yes Yes 8xz 8xz

String Yes Yes 8xs 8xs

Table Yes Yes 8xt 8xt

Function 
file

Yes Yes 8xy 8xy

GDB* Yes Yes 8xd 8xd

List Yes Yes 8xl 8xl

Matrix Yes Yes 8xm 8xm

Number Yes Yes 8xn 8xn
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* Programs created using commands available only in the latest OS 
version will not transfer to graphing calculators with an earlier OS 
version.

* App Vars and Programs should be reviewed for use after the transfer 
between the TI-84 Plus Family and the TI-84 Plus C Silver Edition graphing 
calculators. Some App Vars may not setup an App as expected. Some 
Programs will need to be modified due to the difference in screen 
resolution and new commands.

** You may receive a version error if you used DOT-THIN line style. 
Change the line style to avoid the error.

Complex Yes Yes 8xc 8xc

Window 
Setup

Yes Yes 8xw 8xs

Certificate No No 8xq 8cq

Backup No No 8xb 8cb

File Type Link from 
TI-84 to 

TI-84 Plus C

Link from 
TI-84 Plus C to 

TI-84

84P 
computer 
file type

84PC 
computer 
file type
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Working with device files

The TI DeviceExplorer tool helps you to work with device files on your TI 
graphing calculator and your computer. With this tool, you can exchange 
information between your device and computer and manage the files on 
your device.

Copying device files to the computer
You can copy files on your TI graphing calculator to folders on your 
computer.

Warning: Do not disconnect a TI Connectivity cable during a transfer.

To copy device files to the computer
1. Navigate to the device file you want to copy.

2. Click the device file and drag the file to the location on your 
computer where you want to copy the device file, or Click File > 
Copy to PC.

3. Navigate to the location where you want to copy the device file.

4. Click Select.

Moving device files to the computer
You can move most data, files, and programs from the device to the 
computer. By doing this, you can create more memory on your device 
without deleting its contents. However, if your device is at or near its 
memory limit, you may not want to move your device files. You cannot 
move device files back to your device if it runs out of memory.

Warning: Do not disconnect a TI Connectivity cable during a transfer.



12  Working with device files

To move files from the device to the computer
1. Navigate to the file you want to move.

2. Click the file.

3. Click File > Move to PC.

4. Navigate to the location where you want to move the file.

5. Click Select.

Creating group files from device files
A group file is a file that stores one or more device files on your 
computer. By creating group files using TI DeviceExplorer, you can send a 
large number of files to your computer at once and store them together.

To create group files
1. In the TI DeviceExplorer main window, display all of the files you 

want in the group file.

2. Press and hold Ctrl, then click each file.

3. Click File > Create Group.
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4. If necessary, navigate to the location where you want to save the file.

5. Type a file name for the group file.

6. Click Save.

Note: You can open a TI Group File (*.tig) similar to opening a .zip file on 
your computer using Windows® 7 or higher.
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Using the TI ScreenCapture window

The TI ScreenCapture window displays your captured screens, provides 
tools for you to work with the captured screens, and is the location to 
convert and send your images to a connected graphing calculator. When 
you open TI ScreenCapture and a supported graphing calculator is 
connected, you can capture screens or open an image to send or save 
that image as the appropriate graphing calculator file.

Parts of the TI ScreenCapture window

Menu bar – Menus at the top of the window that you can use to tell the 
program what actions you want to perform.

TI Connect™ toolbar – A set of buttons on the TI ScreenCapture 
window that provide shortcuts to the TI Connect™ tools.

Standard toolbar – A set of buttons on the TI ScreenCapture window 
that provide access to the TI ScreenCapture tools.

Captured screen or Image – A screen captured from a connected TI 
graphing calculator or an image display in the TI ScreenCapture main 
viewing area.

Main viewing area – Part of the TI ScreenCapture window where you 
can view and edit images.

Menu bar

Main  
viewing 
area

Captured screens 
or images

Status  
bar

TI Connect  
toolbar
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Status bar – Part of the TI ScreenCapture window that indicates the 
state of the current operation in TI ScreenCapture.

Changing the selected device type
The TI Connect™ software lets you have multiple devices connected at 
once. However, the software can only work with one device at a time. 
When you want to use a device different from the currently selected one, 
you must change the selected device type. The device type you select 
becomes the default device for all TI Connect™ tools. It remains the 
default until you change the selected device type again.

To change the selected device type
1. Click Actions > Select Device.

2. Click the device you want.

3. Click Select.

Note: If no USB port displays when you select Send To TI Device, unplug 
and replug your USB cable from the computer; turn the graphing 
calculator on, and click the Refresh button. 
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Capturing and using images

In TI ScreenCapture, you can capture screens from your device and view 
them as images. The TI ScreenCapture tool gives you two ways to capture 
screens. You can capture screens by opening TI ScreenCapture or at any 
time while you are using the TI ScreenCapture tool. 

Before you begin
• Make sure TI ScreenCapture is set to the correct device type.

• Make sure your device is turned on and securely connected to the 
computer.

To capture device screens by opening TI ScreenCapture
1. On your device, display the screen you want to capture.

2. On the TI Connect Home screen, click TI ScreenCapture.

-or-

From a TI Connect™ tool, click .

The TI ScreenCapture tool opens. The software connects to the 
device, captures the device screen, and shows the image in 
TI ScreenCapture’s main viewing area.

To capture device screens from TI ScreenCapture
1. On your device, display the screen you want to capture.

2. In TI ScreenCapture, click Actions > Get Screen or click .

TI ScreenCapture connects to the device, captures the screen, and 
opens the image in the main viewing area.

Notes:

• You can set a default size for your screen captures. Click View > 
Default Screen Size and select 100%, 200%, or 300%.

• When you capture TI-84 Plus family device screens, TI ScreenCapture 
shows the screen capture at the 200% size and 100% for the TI-84 
Plus C Silver Edition graphing calculator.

• When the connected device is a TI-84 Plus C Silver Edition graphing 
calculator, you can capture, resize, save, and print color screens from 
that device.
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Saving images as files from the TI-84 Plus family
TI ScreenCapture lets you save newly captured or existing images from 
your TI-84 Plus family devices. You can save images as BMP, JPEG, TIF, GIF, 
PNG, or TI image files. 

Note: TI image files cannot accurately support rotated, resized, or 
bordered images. If you save a rotated/resized/bordered image as a TI 
image file, the software attempts to convert it into a format that your 
device can support. This format may look different from what you 
originally created.

To save existing image files
1. Click the image.

2. Click File > Save or click .

To save new screen captures as BMP, PNG, TIF, GIF, or JPEG 
files
1. Click the image.

2. Click File > Save As or click .

3. If necessary, navigate to a different save location.

4. Accept the default file name or type a new file name.
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5. From the Save as type drop-down list, select from BMP (*.bmp), 
TIF (*.tif), PNG (*.png), GIF (*.gif), or JPEG (*.jpg) (.bmp is the 
default file type).

6. Click Save.

Note: Screen Captures can also be saved as TI Picture file types for the TI-
73, TI-83, TI-83/84Plus, TI-86, TI-89, TI-92, TI-92 Plus, Voyage 200™, 
and TI-84 Plus C. You will be prompted for Pic Var names and 
RAM/Archive storage locations on your device. While saving a Screen 
Capture is allowed for the TI-84 Plus C, the Image Var file type is the size 
of the graph area and not the full screen capture size so the resulting 
saved image will be skewed.

Sending images to connected devices
You can send images to your connected device. These images can be BMP, 
JPEG, PNG, PNG, TIFF, GIF, Picture or Background graphing calculator 
images depending on your device. Do not send flipped, rotated, or 
resized images, as they become distorted when you try to view them on a 
device.

Warning: Do not disconnect a TI Connectivity cable during a transfer.

To send images to connected devices
1. If you have not already done so, capture the image or open the image 

file.

2. Click the image’s window.

3. Click Actions > Send To Device or click .
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Note: The Send Picture dialog box varies with device type.

4. In the Device File Name field, select or type a device file name.

5. In the Memory Location field, click RAM or Archive.

Note: The TI-73, TI-83, and TI-92 devices do not have Archive memory. 
These devices store files sent to Archive in RAM.

6. For TI-89 Family, TI-92 Plus, and Voyage 200™ device types, accept the 
device directory or type a different one.

7. Click OK.

The transferring window opens as TI ScreenCapture sends the image 
to the connected device.

Before you view the sent file on your device
In the Y= Editor, either turn off the functions or delete the functions. If 
you do not, the device superimposes a graph over the image when you 
try to view it.

Copying images into computer applications
Using TI ScreenCapture, you can copy images into computer applications. 
This feature lets you use device images in your documents.

Note: You may want to edit your image before you copy it to the 
computer application. You can flip, rotate, resize, or add a border to your 
image. 

To copy images into computer applications
1. If you have not already done so, open or capture the image.
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2. Click the image.

3. Click Edit > Copy or click .

TI ScreenCapture puts a copy of the image onto the clipboard.

4. Open the computer application.

5. In the computer application, place your cursor at the insertion point.

6. Click Edit > Paste.

Dragging and dropping images to computer 
applications
Using TI ScreenCapture, you can drag and drop captured images into 
computer applications such as Microsoft® Word or Microsoft® 
PowerPoint®. This feature lets you use device images in your documents.

To drag and drop images into computer applications
1. If you have not already done so, open or capture the image.

2. Click the image while holding down the left key on your mouse and 
drag the image to an open computer application such as Microsoft 
Word.

Note: The dragged screen will also be available on Clipboard.

Opening image files
You can have images open from new screen captures, saved image files, 
or any combination. The images open in the TI ScreenCapture window 
do not have to be the same data type.

To open image files

1. Click File > Open Image or click .
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2. If necessary, navigate to the file location.

3. Click the file.

4. Click Open.
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Converting and Sending Image Vars to a 
TI-84 Plus C

The TI-84 Plus C has the ability to display background images (Image 
Vars) as well as the familiar Pic Vars functionality of the TI-84 Plus. These 
variables display in the graph area. TI-84 Plus C Image and Pic Vars will 
not link to a TI-84 Plus given the difference in the screen resolution of 
the two graphing calculators.

Image Vars
A TI-84 Plus C Image Var is created by converting your picture (gif, tif, 
png, jpg, or bmp) to 83 x 133 pixels (width by height) using the TI 
Connect™ software. You can then send the Image Var to your 
TI-84 Plus C or save it to your computer as an *.8ca file. An Image Var can 
also be loaded into the TI-84 Plus C emulator view in TI-SmartView™ 
software.

Your picture may not display in the graph area as expected given the 
conversion to the pixel dimensions of 83 x 133. The conversion to the 
Image Var uses 16-bit color.

On the TI-84 Plus C, an Image Var displays as the background in the 
graph area only. An Image Var will display scaled for the MODE screen 
settings of Full, Horizontal, and Graph-Table preserving any 
mathematical modeling done on an Image Var. Image Vars cannot be 
edited while working on the TI-84 Plus C. Image Vars run and are stored 
in Archive memory.

Note: A screen capture of the graph area includes the full screen of the 
TI-84 Plus C, status bar, graph border, and the graph area. TI Connect™ 
software allows you to crop the graph size area only to create an Image 
Var if desired.

Pic Vars
Pic Vars are created and modified on the TI-84 Plus C. Pic Vars are 266 x 
166 pixels and use the 15 colors available on the TI-84 Plus C. Pic Vars 
display as an overlay on the graph screen area exactly as on the TI-84 
Plus. Pics Vars display from the upper left hand corner of the graph area 
and do not scale for the MODE screen settings Full, Horizontal, and 
Graph-Table. Pic Vars can be opened to view in the TI Connect™ Screen 
Capture software. They can be saved as computer files with the file 
extension *.8ci. Pic Vars run and are stored in Archive memory. Note that 
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Pic Vars on the TI-84 Plus run and are stored in RAM memory but also can 
be stored in Archive memory. Please note this difference when clearing 
RAM.

Note: TI Connect™ software will not convert a Pic Var (*.8ci) to an Image 
Var (*.8ca).

Creating and Sending Image Vars to your 
TI-84 Plus C
Background Image Vars are created, sent, or saved using either:

• TI Connect™ software for the Mac® using Device Explorer or 
Create a Group

• TI Connect™ software for the PC using Device Explorer or Screen 
Capture

Creating and Sending an Image Var to a 
Connected TI-84 Plus C
The following steps show you how to create an Image Var if you have a 
TI-84 Plus C graphing calculator connected to your computer. You can 
create the Image Var, save it to your computer, and display it in the graph 
area of the TI-84 Plus C.

1. Choose the image you want to convert. Allowed picture file types are 
tif, gif, png, jpg, or bmp.

2. Open TI Connect™ software.

3. Using the USB Computer Cable, connect the TI-84 Plus C to the 
computer. Turn on the TI-84 Plus C.

4. Open Device Explorer.

5. Drag the picture to the Device Explorer.
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6. Select an Image# name from the drop-down menu, such as Image0 - 
Image9. This will be the name of the image on the TI-84 Plus C.

Note: Since this Image# name is internal to the conversion process, it 
is important to remember what Image# name you assigned. It is 
recommended that you keep this information in the filename so you 
know where the Image Var will be stored on the TI-84 Plus C if you 
send or share this file in the future.

7. Click OK.

You can preview the Image Var, save it on your computer, and display it 
in the graph area of the TI-84 Plus C.

• To preview the Image Var:

– On a PC, open Background and double-click the Image#. The 
Image Var preview opens in the Screen Capture window.

– On a Mac®, expand the calculator directory and double-click the 
Image#. The Image Var preview opens in a Preview window.

• To save the Image Var on your computer, drag the Image# from the TI 
Connect™ Device Explorer to your desktop, or to the folder where 
you want to save it.

• To display your new Image Var in the graph area of the TI-84 Plus C, 
press y ., change the Background setting to the Image# 

you just sent to the device (example: Image5), and press s. 
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TI Connect™ software for the PC: Creating an 
Image Var Without a Connected Device
The following steps show you how to create an Image Var if you do not 
have a TI-84 Plus C graphing calculator connected to your PC. You can 
create the Image Var, save it to your computer, and load it into 
TI-SmartView™ software to view.

1. Choose the image you want to convert. Allowed picture file types are 
tif, gif, png, jpg, or bmp.

2. Open TI Connect™ software.

3. Open Screen Capture.

4. Drag the picture to Screen Capture.

5. Click File > Save As.

6. Choose the directory where you want to save the file.

7. Choose TI-84 Plus C Image (.8ca) as the file type.

8. Click Save.

9. Select an Image# name from the drop-down menu, such as Image0 - 
Image9. This will be the name of the image on the TI-84 Plus C.

Note: Since this Image# name is internal to the conversion process, it 
is important to remember what Image# name you assigned. It is 
recommended that you keep this information in the filename so you 
know where the Image Var will be stored on the TI-84 Plus C if you 
send or share this file in the future.

10. Click OK to convert the image to a TI-84 Plus C (.8ca) file.

See the steps below for loading the Image Var into the TI-SmartView™ 
software.

TI Connect™ software for the Mac®: Creating an 
Image Var Without a Connected Device
The following steps show you how to create an Image Var if you do not 
have a TI-84 Plus C graphing calculator connected to your Mac®. The 
Create a group feature is used to convert an image without a 
connected device. You can create the Image Var, save it to your computer, 
and load it into TI-SmartView™ software to view.

1. Choose the image you want to convert. Allowed picture file types are 
tif, gif, png, jpg, or bmp.

2. Open TI Connect™ software.
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3. Click the Create drop-down menu at the bottom of the TI Connect™ 
window and choose Create a group.

4. Drag the picture from your desktop to the Group window.

5. Select the calculator you want to use.

6. Select an Image# name from the drop-down menu, such as Image0 - 
Image9. This will be the name of the image on the TI-84 Plus C.

Note: Since this Image# name is internal to the conversion process, it 
is important to remember what Image# name you assigned. It is 
recommended that you keep this information in the filename so you 
know where the Image Var will be stored on the TI-84 Plus C if you 
send or share this file in the future.

7. Click OK to convert the image to a TI-84 Plus C (.8ca) file.

8. To save the Image Var on your computer, drag the Image# from the 
Group window to your desktop, or to the folder where you want to 
save it. 

See the steps below for loading the Image Var into the TI-SmartView™ 
software.

Loading an Image Var into the TI-SmartView™ 
software for the TI-84 Plus C Emulator View
Once your create and save an Image Var (.8ca) file using TI Connect™ 
software, you can load that file into the TI-84 Plus C emulator view in TI-
SmartView™ software, similar to any calculator file.

1. Select File > Load File in TI-SmartView™ software.

2. Select All Calculator Files (*.8c?).

3. Locate your Image Var. Remember that the internal image name of 
Image# is in the file. In this example, the file was named 
BRIDGE_IMAGE5.8ca. You will receive no prompt to pick a new 
Image# calculator name.

4. Select Open and the file will load to the emulator.

5. To display your new Image Var in the graph area of the TI-84 Plus C 
emulator, press y ., change the Background setting to 
the Image# you just sent to the device (example: Image5), and press 
s. 
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Using TI DataEditor

TI DataEditor is a tool in the TI Connect™ software that you can use to 
work with data variables for your TI graphing calculator. With TI 
DataEditor, you can create number, list, and matrix variables. Once you 
create these variables, you can use the tool to edit them and share them 
with your device and computer.

TI DataEditor window
The TI DataEditor window shows the data variables you create and open, 
as well as tools for you to work with these data variables. The window 
has three modes: Number Editor, List Editor, and Matrix Editor. By 
default, the window opens to the last mode you worked in. The example 
below shows the Matrix Editor mode.

Parts of the TI DataEditor window

Menu bar – Menus at the top of the window that you can use to tell the 
program what actions you want to perform.

Standard toolbar – A set of buttons on the TI DataEditor window that 
provide shortcuts to the TI DataEditor tools.

Menu bar

Standard toolbar

Main viewing area

Variable bar

TI Connect™ toolbar

Status bar
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TI Connect™ toolbar – A set of buttons on the TI DataEditor window 
that provide shortcuts to the TI Connect™ tools.

Main viewing area – Part of the TI DataEditor window where you can 
view and edit any variables you have open.

Variable bar – Three large buttons (Number, List, and Matrix) at the 
bottom of the screen that you can use to select the variable type you 
want to view or edit.

Status bar – Part of the TI DataEditor window that indicates the state of 
the current operation in TI DataEditor.
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Working with data variables

In TI DataEditor, you can work with number, list, and matrix variables. 
Each data variable has its own variable editor that you can use to 
perform the various functions available in TI Data Editor. These variable 
editors include the Number Editor, the List Editor, and the Matrix Editor.

Creating data variables
You can use TI DataEditor to create number, list, and matrix data 
variables. When you create data variables, you can use any of the 
following types of data:

• numbers 0 through 9

• “+” or “-” in front of the numbers

• “e” or “E” for exponential format

• “i” for complex numbers

• decimal point for floating point numbers

TI DataEditor does not let you create data variables that contain no data 
or non-numeric data.

To create number variables
1. Click File > New > Number.

2. Type data in the cell.

3. Press Enter.

4. (Optional) Save the number variable.

To create list variables
1. Click File > New > List.
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2. Type data in the cell.

3. Press Enter.

4. Repeat steps 2 and 3 for each list element (cell) you need.

5. (Optional) Save the list variable.

To create matrix variables
1. Click File > New > Matrix.

2. Click File > Properties or click .
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Note: The variable properties dialog box varies depending on device 
type. Select the TI-83 Plus\TI-84 Plus Family as the Device Type for the 
TI-84 Plus C since Number, Matrix, and List are common files in this 
family of devices.

3. Select a device type.

4. If necessary, change the number of rows or columns.

5. Select or type a variable name.

6. Click OK.

7. Type data in the selected cell.

8. Press Enter.

9. Repeat steps 8 and 9 for each cell in the matrix variable.

10. (Optional) Save the matrix variable.

Saving data variables
After you edit or create data variables, you may want to save them. You 
can save new data variables and existing data variables.

Note: If you save numeric data for the TI-89, TI-89 Titanium, TI-92, and 
TI-92 Plus devices or the Voyage™ 200 Personal Learning Tool (PLT), TI 
DataEditor converts it to floating point format.
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To save existing data variables
1. Click the data variable you want to save.

2. Click File > Save or click .

For files opened from TI DeviceExplorer, a dialog box opens asking if 
you want to save the file back to the device. Click Yes to save the data 
variable to the device or No to save the data variable to the 
computer.

To save new data variables
1. Click the data variable you want to save.

2. Click File > Save or click .

Note: The Variable Properties window varies depending on device 
and variable type.

3. Click a device type.

4. Select or type a variable name.

5. Click OK.
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6. If necessary, navigate to a new save location.

7. Type a file name.

8. Click Save.

Sending data variables to devices
You can send the data variables you create to connected TI graphing 
calculators. TI DataEditor provides three options for doing this, including 
sending selected data variables, sending all open data variables, and 
sending all open number, list, or matrix variables.

Warning: Do not disconnect a TI Connectivity cable during a transfer.

Before you start
Make sure each data variable has a name. To name a data variable, click 
File > Properties.

To send selected data variables
1. Open the data variable you want to send.

2. If you have multiple devices connected, select the device to which you 
want to send the file. 

3. Click the data variable name.

4. Click Actions > Send Selected Items or click .
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To send all open data variables
1. Open the data variables you want to send.

2. If you have multiple devices connected, select the device to which you 
want to send the file. 

3. Click Actions > Send All Open Items.

To send all open number, list, or matrix variables
1. Open the data variables you want to send.

2. If you have multiple devices connected, select the device to which you 
want to send the file.

3. Depending on the data variable type, do one of the following:

• Click Actions > Send All Numbers.

• Click Actions > Send All Lists.

• Click Actions > Send Matrix.

Notes:

• File transfers may fail when you use TI DataEditor to send an 
unnamed data variable to your device.

• TI DataEditor has special features for canceling a send.

• If you send data variables that you open from TI DeviceExplorer, you 
may receive an Out of Memory error. When you open variables in TI 
DataEditor their size becomes larger. This means that you cannot send 
them back to a device that was at its memory limit.

• If you send data variables to the TI-89, TI-89 Titanium, TI-92, and 
TI-92 Plus devices or the Voyage™ 200 PLT, TI DataEditor converts 
them into floating point format.

Exporting data variables
TI DataEditor has several methods for exporting your data variables into 
spreadsheet programs. You can export data variables by copying them 
into spreadsheets or creating exportable files. In addition, you can use 
Special List Export to export list variables.

Note: The recommended way to export variables is to copy them.

To export data variables by copying them
1. Click the data variable name.

2. Click Edit > Copy.

TI DataEditor copies the data variable contents to the clipboard.
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3. Open the spreadsheet to which you want to copy the data variable.

4. Click the location in the spreadsheet where you want to insert the 
data variable.

5. Click Edit > Paste.

To export data variables as files
1. Click the data variable name.

2. Click File > Export.

3. If necessary, navigate to the location where you want to save the file.

4. Type a file name or accept the default.

5. Click Save.

To export multiple list variables as a single-list file
1. If you have not already done so, open the list variables you want to 

export.

2. Click File > Special List Export.
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3. If necessary, navigate to the location where you want to save the file.

4. Type a file name or accept the default.

5. Click Save.

Importing spreadsheet data into data variables
You can import data from Excel Comma Separated (*.csv) and Text (*.txt) 
files. They must contain only numeric data. 

Rules for importing
When you import files, the software uses the following rules:

• If the file contains exactly one number, TI DataEditor imports it as a 
number variable.

• If the file contains exactly one column of numbers, TI DataEditor 
imports it as a list variable.

• TI DataEditor imports all other files as matrix variables.

To import spreadsheet data into data variables
1. Click File > Import.
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2. If necessary, navigate to the directory that contains your spreadsheet 
files.

3. Click the spreadsheet file you want import.

4. Click Open.
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Updating device operating systems

TI Connect™ software includes a link to the TI OS Downloader tool. TI OS 
Downloader lets you download operating systems for TI graphing 
calculators and data collection devices.

Updating TI graphing calculator operating 
systems

Before you begin
• Backup your device files (RAM, Archive, and Apps).

• Make sure your device is turned on and securely connected to the 
computer.

• If you have multiple devices connected with USB computer cables or 
USB Silver Edition cables, disconnect all of them except the one you 
intend to update.

Warning: Do not disconnect a TI Connectivity cable during a transfer.

To update TI graphing calculator operating systems with TI 
OS Downloader
1. Click Tools > TI OS Downloader.

2. If necessary, select the correct communication settings from the 
Device, Cable Type, and or Port drop-down lists.

3. Click Next.
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Note: The instructions in the Ready to download field vary with 
device.

4. If necessary, click Open  and navigate to the OS File location.

5. Remove the batteries from the device and then reinstall them.

6. Turn on the device.

7. If you are updating a TI-89, TI-89 Titanium, TI-92 Plus or 
Voyage™ 200 PLT, follow the instructions on the device.

8. Click Start Download.

The Transferring window opens as TI OS Downloader downloads the 
operating system to the connected device. When the download 
finishes, the TI OS Downloader dialog box opens saying that the 
download is complete and TI OS Downloader will now close.

9. Click OK.

Notes: 

• Downloading an operating system to a device may result in a loss of 
device data. After you download the device operating system, you 
may need to use a backup file of the device to restore data (RAM, 
Archive, and Apps).

• File transfers may fail when you use the black link cable to connect a 
TI-92 device to a computer running Windows® 2000. This is not a 
problem with the TI-92 Plus, the Voyage™ 200 PLT, or the TI-92 with 
the upgraded RAM module.
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Updating data collection device operating 
systems
You can use the following steps to download operating systems to your 
CBL 2 and LabPro devices.

Before you begin
• Make sure your device is turned on and securely connected to the 

computer.

• If you have multiple devices connected with USB computer cables or 
USB Silver Edition cables, disconnect all of them except the one you 
intend to update.

To update data collection device operating systems
1. Click Tools > TI OS Downloader.

2. If necessary, select the correct communication settings from the 
Device, Cable Type, and/or Port drop-down lists.

3. Click Next.

The fields in the TI OSDownloader dialog box change to “Locate OS 
File” and “Ready to download.”
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4. If necessary, click Open  and navigate to the OS File location.

5. Click Start Download.

The Transferring window opens as TI OS Downloader downloads the 
operating system to the connected device. When the download 
finishes, the TI OS Downloader dialog box opens saying that the 
download is complete and TI OS Downloader will now close.

6. Click OK.
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Using TI DeviceInformation

TI DeviceInformation gives you the ability to quickly find information 
about your TI graphing calculator. You can find general device 
information, installed application information, and device ID 
information.

TI DeviceInformation window
The TI DeviceInformation window displays the general information, 
installed applications, and ID List for the connected TI graphing 
calculator.

Menu bar
Tabs

Main  
viewing  
area

Parts of the TI DeviceInformation window

Menu bar – Menus at the top of the window that you can use to tell the 
program what actions you want to perform.

Tabs – Parts of the main window that let you change the information 
the window displays. There are three tabs: General Information, Installed 
Applications, and ID List. Each tab contains different information about 
the connected device.

Main viewing area – Part of the main window where you can view the 
general information, device information, and ID List.

TI DeviceInformation tabs
The TI DeviceInformation window has three different tabs: General 
Information, Installed Applications, and ID List. Each tab provides 
different information about the connected device.
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General Information tab
Under the general information tab, you can find the device type, device 
ID, OS version, BIOS version, language, total RAM, RAM available, and 
battery status. The software may not be able to find all of the general 
information for each device.

Installed Applications tab
Under the Installed Applications tab, you can find a list of the 
applications installed on the connected device.

ID List tab
Under the ID List tab, you can find the ID on your device.
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Changing the selected device type
The TI Connect™ software lets you have multiple devices connected at 
the same time. However, the software can only work with one device at a 
time. When you want to use a device different from the one you 
currently have selected, you must change the selected device type. The 
device type you select becomes the default device for all TI Connect™ 
tools. It remains the default until you change the selected device type 
again.

To change the selected device type
1. Click Actions > Select Device.

The Select TI Device dialog box opens. The software determines which 
devices you have connected and displays them in the dialog box.

2. When the device you want appears in the list, click it.

3. Click Select.
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Note: You can select a device (perform steps 2 and 3) as soon as the 
device you want appears in the dialog box. You do not have to wait for 
the software to find all connected devices.

Note: If no USB port displays when you select Send To TI Device, unplug 
and replug your USB cable from the computer; turn the graphing 
calculator on, and click the Refresh button. 
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Using device information files

Device information files are an easy way to keep track of your device’s 
contents. These files store all of the available device information, 
including general information, installed applications, and ID Lists. You 
can create device information files with the information gathered from 
any TI graphing calculator and open the files whenever necessary.

Creating device information files
Creating a device information file gives you the ability to view 
information about your device at any time, even when your device is not 
connected to the computer. You can create a device information file by 
saving the information you find in TI DeviceInformation.

To create device information files
1. Click File > Save Info File.

2. If necessary, navigate to the location where you want to save the file.

3. Type a file name for the device information file.

4. Click Save.
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Legal Information

Important Information
Texas Instruments makes no warranty, either express or implied, 
including but not limited to any implied warranties of merchantability 
and fitness for a particular purpose, regarding any programs or book 
materials and makes such materials available solely on an "as-is" basis. In 
no event shall Texas Instruments be liable to anyone for special, 
collateral, incidental, or consequential damages in connection with or 
arising out of the purchase or use of these materials, and the sole and 
exclusive liability of Texas Instruments, regardless of the form of action, 
shall not exceed the purchase price of this product. Moreover, Texas 
Instruments shall not be liable for any claim of any kind whatsoever 
against the use of these materials by any other party.

Graphing product applications (Apps) are licensed. See the terms of the 
license agreement for this product.

© 2006 - 2012 Texas Instruments Incorporated

Texas Instruments (TI) Support and Service

TI Product and 
Services 
Information

For more information about TI products and 
services, contact TI by e-mail or visit the TI 
Internet address.

E-mail: ti-cares@ti.com

Internet: education.ti.com

Service and 
Warranty 
Information

For information about the length and terms of 
the warranty or about product service, refer to 
the warranty statement enclosed with this 
product or contact your local Texas Instruments 
retailer/distributor.

mailto:ti-cares@ti.com
http://education.ti.com
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