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Getting Started
The TI-Nspire™ App for iPad® enables you to use the TI-Nspire™ Student Software or TI-
Nspire™ CAS Student Software on an iPad®.

What You Can Do

You can use the TI-Nspire™ App for iPad® and TI-Nspire™ CAS App for iPad® to:

• Perform calculations

• Work with variables

• Import images (photos)

• Respond to questions

• Perform graphing and geometry functions

• Create lists and spreadsheets

• Analyse data

What You Must Know
Initial Launch

When you open the TI-Nspire™ App for iPad® for the first time after installation, you
will be prompted to allow access to your photos for saving screenshots and inserting
photos.

If you choose Select Photos, only those photos you select in your Photos library can be
inserted into a document. Selecting Allow Access to All Photos is recommended if you
have a large number photos on your iPad®.

Accessing Online Help

The TI-Nspire™ App for iPad® includes online help, which opens in the Safari browser.

▶ To access the online help from within the app, tap Help , and then tap Online
Help.

Using the TI-Nspire™ Home Screen
When the app is first installed, a TI-Nspire or TI-Nspire CAS folder is created in the On
My iPad location. It contains four pre-loaded folders (Math, MyLib, MyWidgets, and
Simulations), and three Getting Started documents: Getting Started with the TI-Nspire™
App, Getting Started with Data and Statistics, and Getting Started with Graphs.

The Home screen uses much of the same functionality as the iPad® Files app such as
Recents, Locations, Tags, and file/folder management. Recommended locations to
store .tns files are On My iPad and iCloud Drive.
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2 Getting Started

Note: TI-Nspire™ App for iPad® supports only .tns documents.

To return to the TI-Nspire™ Home screen from any other screen within the application,
tap < Home.

Accessing Settings
1. From the TI-Nspire™ Home screen, tap Settings .

2. Tap the option names to:

• Show Touch. Select to show or hide touches to the screen.
• Export to PDF - Header Title. Change the default title for exported PDFs.
• Reset Content. Deletes all user-created TI-Nspire™ documents and folders,

clears the Clipboard, and restores the factory default documents.Warning: You
cannot undo this action. For details, refer to Resetting TI-Nspire™ Content.

• About. Read information about the app, and check the version of the app.
• Privacy Policy. Open the Texas Instruments Online Privacy Policy.



3. Tap Done to return to the TI-Nspire™ Home screen.

Managing Documents

Opening a Document

▶ Tap the document icon.

The document opens on the first page.

Adding New Documents

1. Tap New in the toolbar or tap the Create Document icon if displayed (folder
view).

2. Tap an application name.

A new document opens with the selected application as the first page. The new
document is assigned a default name.

Renaming Documents

1. Tap the default name under the document to open the keyboard.

2. Type a new name, and then tap done.

The new name is displayed and the keyboard closes.

Using TI-Nspire™ App for iPad® Keyboards
The TI-Nspire™ App for iPad® has two keyboards: the Native iPad® Keyboard and the TI-
Nspire™ Keyboard.

▶ To type text and numbers, tap in the workspace to show the Native iPad® Keyboard,
which is the standard alpha-numeric keyboard.
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4 Getting Started

Note: This keyboard changes when you select language options.

▶ To insert common TI-Nspire™ functions, templates, and mathematical expressions,
tap to show the TI-Nspire™ Keyboard.

Accessing Alternative Functions

On the TI-Nspire™ Keyboard, many keys have alternate functions related to the symbol
marked on the key. Keys with alternative functions are shown with a coloured stripe on
top.

Example of alternative functions.

Stripe indicates that alternative functions are
available.

▶ To access an alternative function, touch and hold the key, and then slide your finger
to the desired function.

Using Custom TI Keyboard for Dialogue
Every dialogue inside the application has a custom keyboard available.



Example:

Go to Graphs > Tools > Window/Zoom > Window Settings.

TheWindow Settings dialogue appears.

Tap in any field.

The custom keyboard for dialogue is available.

Note: The following keys are not available.

• Chem Box

• Maths box

• Variable Keys

• Arrow Up

• Arrow Down

Resetting TI-Nspire™ Content

WARNING: You cannot undo this action.

Resetting Content does the following:

• Permanently deletes all user-created content from the app folder in the On My iPad
location.

• Restores the factory pre-loaded documents and MyLib folder.

• Clears the Clipboard to prevent the pasting of unauthorised information.
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6 Getting Started

To Reset Content:

1. From the TI-Nspire™ Home screen, tap Settings .

2. Tap Reset Content.

An alert message appears.

3. To proceed with the reset, tap Reset.

After the reset is complete, the TI-Nspire™ Home Screen reappears.



Working with Documents
All work created using TI-Nspire™ applications is stored in a TI-Nspire™ document (.tns
file), which you can share with others.

A document consists of one or more problems and each problem contains one or more
pages. A single page is displayed in the work area. All work occurs in the applications
within pages.

When you add a new document, the selected application is the first page of the
document.

The TI-Nspire™ Toolbar.

Page Sorter.

Document toolbar.

Document work area. This example shows the Lists & Spreadsheet work area.

Exploring the TI-Nspire™ Toolbar
The TI-Nspire™ Toolbar contains tools available for use in open documents.

Home. Return to the TI-Nspire™ Home screen.

Add. Add a new page or problem to a document.

Undo. Undo the previous action.

Redo. Redo the last action.

Clear Document Contents. Clears all problems and apps from document.

Document Document Name. The name of the active document.

More. Exports all viewable problems and pages in the active document
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8 Working with Documents

to a PDF using the Export to PDF option. (see Sharing Documents for
more information)

Settings. Apply document settings for the active document or to all
documents.

Help. Access Online Help or the PDF Guidebook.

Exploring the TI-Nspire™ Page Sorter
The TI-Nspire™ Page Sorter contains tools available for use in open documents.

RAD Angle Mode. Shows an abbreviation of the angle mode (degrees, radians, or
gradients) in effect.

PageSort. Hide or show the Page Sorter.

Utilities. Access utilities for the active application (symbols, catalogue, etc.).

Insert Photo. Send the current page to the iPad® Photos app, take a photo,
add an existing photo in a document, scan a QR Code®.

Note: You can insert photos in the Graphs, Geometry, Data & Statistics,
and Notes applications. Scanning a QR Code® is only available in the
Notes application.

Using TI-Nspire™ Page Sorter
The TI-Nspire™ Page Sorter contains tools available for use in open documents.

Hide or Show Pages

To show or hide pages in an open document:

1. Tap the Page Sorter icon to show pages.

Note: All pages in the document will slide open from the right.



2. Tap the Page Sorter icon or anywhere on the screen to hide the pages.

Move a Page

▶ Press and hold a page to move to a different position.

Page Options

▶ Double tap on a page to see available options.

- Cut

- Copy

- Delete

Hide or Show Problem

1. Tap once on the problem name to show all pages.

2. Tap once on the problem name to hide all pages.

Rename a Problem

1. Tap twice on the problem name.
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10 Working with Documents

2. The keyboard appears.

3. Type the new problem name.

4. Tap on the dismiss key to hide (or dismiss) the keyboard.

Exploring the Document Work Area
The document work area consists of the application toolbar, the open document, and
the page sorter.

From open documents on the work area, you can add, delete and rearrange pages in
documents, and you can rename problems.



Page Sorter. Displays thumbnail sketches of all pages in all
problems in the current document. Swipe up or down to view
pages off the screen.

Application. The document toolbar colour indicates which
application is active in the work area.

   Calculator

   Graphs

   Geometry

   Lists & Spreadsheet

   Data & Statistics

   Notes

1.2 Problem/Page Number. Displays the problem number followed
by the page number.
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12 Working with Documents

Tools. Opens the tools menu for the active application.

Tools Search allows you to search options and menus. It is
available across all applications in the
TI-Nspire™ App.
Warning: Tools Search will allow you to search for menu items,
but not for command names.

Inspector. Tap to change the properties of a selected item.

Settings. Tap to change the Graphs & Geometry settings.

History. In the Graphs application, shows the history of the
defined functions.

Show/Hide. In the Graphs application, shows or hides the
keyboard.

Opening a New Document
1. On the TI-Nspire™ Home screen, tap New .

The Newmenu opens.

2. Tap an application name.

A new document opens with the selected application as the first page. The new
document is assigned a default name.

Saving Changes to Documents
When you tap < Home from an active document, the TI-Nspire™ App automatically
saves the document even if no changes were made.

WARNING: You cannot undo any changes to a document once you navigate to the
Home screen.

Note: If you added a new document but did not rename it before adding pages, it will
save with the default name ("Document"). You can then rename the document on the
Home screen as needed.

Adding Pages to Documents
1. In the page sorter, tap the page in the problem where you want to add another

page.

2. Tap New Page .

The New Page menu opens.



3. Tap the type of application you want to add to the document.

A new page is added to the document beneath the current page.

Note: To move a page, touch and hold the page, and then drag it to another
position.

Adding Problems to Documents
1. From an active document, tap New Page .

2. Tap Problem.

3. Tap the type of problem you want to add to the document.

A new problem is added beneath the current problem in the page sorter.

Note: To rename the problem, double-tap the problem name, type the new name,
and then tap return.

Deleting Pages from Documents
1. Tap to open the page sorter.

2. Double-tap the page you want to delete to open the context menu.

3. Tap Delete.

Copying and Pasting Pages in Documents
You can cut, copy, and paste pages from documents to other places in the active
document or in another document.

Copying or Cutting Pages

1. Tap to open the page sorter.

2. Double-tap the page you want to cut or copy to open the context menu.
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14 Working with Documents

3. Tap Cut or Copy.

Pasting Pages to Another Location

1. Double-tap the page in the page sorter where you want to paste to open the
context menu.

2. Tap Paste.

The page is pasted beneath the selected page in the problem.

Changing Document Settings
Document settings control how all numbers, including elements or matrices and lists,
are displayed in TI-Nspire™ documents. You can change the default settings at any
time, and you can specify settings for a specific document.

Complete the following steps to customise the settings that are applied to your
document.

1. Create a new document or open an existing document.

2. Tap Settings .

When you open Document Settings the first time, the default settings are
displayed.

3. Tap the menu name to open the menu and view the available values for each
setting.

Field Value

Display Digits • Float
• Float1 - Float12
• Fix0 - Fix12

Angle • Radian
• Degree
• Gradian

Exponential Format • Normal
• Scientific
• Engineering

Real or Complex Format • Real
• Rectangular
• Polar

Calculation Mode • Auto
• Exact
• Approximate



Field Value

Note: Auto mode shows an answer that is not a
whole number as a fraction except when a decimal is
used in the problem. Exact mode (CAS) shows an
answer that is not a whole number as a fraction or in
symbolic form, except when a decimal is used in the
problem.

CAS Mode • On
• Exact Arithmetic
• Off

Note: This option is only available on CAS software.

Vector Format • Rectangular
• Cylindrical
• Spherical

Base • Decimal
• Hex
• Binary

Unit System (CAS) • SI
• Eng/US

Note: This option is only available on CAS handhelds
and software.

4. Select the desired settings.

5. Choose one of the following options:

• To apply the customized settings to ALL documents, tapMake Default.
• To apply the settings to the open document only, tap Done.
• To restore default settings, tap Restore.

Sharing Documents

Sharing a Document from the Home Screen

To share a document from the Home screen:

1. Tap the document and hold until the context menu displays.

2. Tap Share .

3. Tap the icon of the app or location where you want to share the .tns file.
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16 Working with Documents

Exporting a Document as a PDF

To export a document as a PDF from within the document:

1. TapMore .

2. Tap Export to PDF.

The app opens a screen showing the PDF.

3. Tap Share .

4. Tap the icon of the app or location where you want to share the PDF.

Receiving Documents
If you have an email account set up on your iPad®, you can receive documents that the
teacher sends, work on those documents, and send them back to the teacher.

To receive a document by email:

1. Tap the icon of the attached document in the email.

2. Tap Save to Files .

3. Choose the preferred location on your iPad® to save the document (On My iPad,
iCloud Drive, etc.).

4. Tap Save.



Working with Photos in Documents
Photos can be used in the TI-Nspire™ App for iPad® for reference, assessment and
instructional purposes.

What You Can Do

Add photos to the following TI-Nspire™ applications:

• Graphs

• Geometry

• Data & Statistics

• Notes

What You Must Know
• In the Graphs, Geometry, and Data & Statistics applications, photos are set in the

background behind the axis and other objects. In the Notes application, the photo
is set at the cursor location inline with the text (in the foreground).

• You can take a photo and add it to your document, or you can use a photo that is
already stored in the photo albums. The TI-Nspire™ software automatically creates
a photo album named TI-Nspire™ Photos HD and stores it in the iPad® photo
albums. You can also use other photo albums that you create on the iPad®.

Taking Photos
1. Open the document to the page where you want to add a photo.

2. Tap Insert Photo .

3. Tap Take Photo.

4. Aim the iPad® viewfinder at the object you want to capture.

When you take the photo, a preview is displayed.

• To discard the photo and take a different one, tap Retake.
• To insert the photo in the document, tap Use Photo.

The photo is inserted into the active document and added to the TI-Nspire™ Photos
HD album.

Adding Existing Photos to Documents
1. Open the document to the page where you want to add a photo.

If you are working in a Notes page, the photo will be inserted where the cursor is
located.

2. Tap Insert Photo .

3. Tap Add Photo.

4. Tap the album where the photo resides.

Working with Photos in Documents 17



18 Working with Photos in Documents

5. Tap a thumbnail of the photo you want to insert.

The photo is inserted into the active document.

More Information

Adding photos will depend on the current level of access you have selected in the iPad®
settings:

• Selected Photos - Allows access to photos that were previously selected (see section
below).

• All Photos - Allows access to all photos on your iPad®.

• None - The Add Photo option will not be available.

Selected Photos

• If you tap a photo that was not selected previously, a prompt will appear with
Select More Photos and Keep Current Selection. This prompt only appears on the
first attempt to add a photo after the option has been selected in the iPad®
settings.

• You can see which photos have already been selected with the Select More Photos
from the example mentioned above, or by going to TI-Nspire CAS > Photos >
Selected Photos in the iPad® settings. Those photos will have a blue tick .

Copying and Pasting Photos in the Notes Application
You can copy and paste photos in the Notes application.

▶ To copy a photo, tap the photo to select it, tap it again to open the context menu,
and then tap Copy.

▶ To paste a photo, double-tap the area in the document where you want to insert
the photo, and then tap Paste.

Resizing Photos
You can resize photos in all applications that use photos.

1. Select the photo.

• In the Graphs, Geometry and Data & Statistics applications, tap the Tools icon 
and go to Actions > Select Photo.

• In the Notes application, tap the photo to select it.

2. Drag a corner of the photo to resize it.

Deleting Photos
Delete photos from within the open document.

1. Select the photo.

• In the Graphs, Geometry and Data & Statistics applications, tap Tools and go
to Actions > Select Photo.

• In the Notes application, tap the photo to select it.



2. Tap the photo to open the context menu.

3. Tap Delete.

Capturing Screens
You can capture a page instead of the whole App screen.

1. Tap Insert Photo .

2. Tap Send Page to Photos.

The screen will turn white for a second.

The image is saved to the Library in Photos.

Working with Photos in Documents 19



20 Calculator Application

Calculator Application
The Calculator application enables you to enter and evaluate maths expressions. You
can define variables, functions and programs in Calculator. When you define or edit a
variable, function or program, it becomes available to other applications—such as
Graphs or Geometry—that are part of the same problem.

What You Can Do

The Calculator Tools menu provides the tools you need to:

• Complete actions.

• Work with numbers.

• Work with maths functions such as algebraic expressions, calculus problems,
probability and statistics.

• Work with matrices and vectors.

• Create and solve financial equations.

• Define and edit functions, variables and programs.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know
Deferring Evaluation

You do not have to complete and evaluate an expression as soon as you enter it. You
can enter part of an expression, leave the page to check work on another page, and
then come back to the page to the complete the expression at a later time.

Forcing a Decimal Approximation

To force a decimal approximation in a result, complete one of the following actions:

▶ Touch and hold enter, and then slide to select to evaluate the expression.

▶ Include a decimal in the expression.

▶ Wrap the expression in the approx() function.



Accessing Calculator History Items

You cannot edit an expression if the result has been calculated. However, you can copy
the expression from the history and paste it into the entry line.

Copying History Items

1. Drag the work area up or down to find the expression or result you want to copy.

2. Tap the expression to select it and open the context menu.

3. Tap Paste History to copy the expression into the active entry line.

Copying Part of an Expression

1. Tap the expression to select it.

2. Drag the handles to highlight the part of the expression you want to copy.

3. Tap Paste History or tap enter to copy the selected item to the active entry line.

Clearing Calculator History

When you clear the history, all variables and functions defined in the history retain
their current values. To clear all items in the Calculator history:

1. Tap Tools and go to Actions.

2. Tap Clear History to remove all expressions and results from the history.

Note: If you clear the history by mistake, tap to restore the history items.

Adding a Calculator Page
To open a new document or add a page to an existing document with the Calculator
application active:

1. From the TI-Nspire™ Toolbar, tap .

• If this is a new document, the Newmenu opens.
• If adding a page to an existing document, the New Pagemenu opens.

2. Tap Calculator .

The Calculator application is added to the document. By default, the TI-Nspire™
Keyboard is shown and the cursor is in the entry line.
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22 Calculator Application

Entry line. Type or insert a mathematical expression in the entry line. Tap
enter to evaluate the expression.

You can also insert functions, symbols, templates, or expressions from
Utilities .
Note: If the keyboard is hidden, tap the entry line to show it.

Calculator work area. As you evaluate expressions, both the expression and
result are saved in Calculator history. To distinguish between each saved
expression and result, every other entry line is shaded. To view entry lines
that are hidden, drag the work area up or down to scroll.

Entering Simple Maths Expressions

Note: To enter a negative number, tap instead of the minus sign.

Suppose you want to evaluate .

1. Tap an entry line in the Calculator work area.

2. Tap to begin the expression.



3. Tap to return the cursor to the baseline.

4. To complete the expression:

Tap

5. Tap enter to evaluate the expression.

The expression is displayed in standard mathematical notation, and result is
displayed on the right side of the entry line. If a result does not fit on the same line
with the expression, it is displayed on the next line.

The expression and the result are added to the Calculator history.

Inserting Symbols, Functions, Commands, and Templates
System functions and commands, symbols, and expression templates are stored in
Utilities. To access Utilities, tap .

Utilities menus open to the last menu used. For example, if Symbols was the last menu
accessed, it opens by default the next time you tap .

To insert a symbol

1. Tap Symbols to open the Symbols palette.

2. Tap a symbol to insert it into the entry line.

Calculator Application 23



24 Calculator Application

Note: Drag the list of symbols up and down to view all available symbols.

To insert an item from the catalogue

1. Tap Catalogue to view the list of available functions and commands.

2. Tap a function name to select it, and then tap Done to insert it into the entry line.

• Flick the list of Catalogue items up or down to view all items in the list.

• Type the first letter(s) of a function name in the search field to jump to entries
that begin with that letter. To return to the top of the list, clear the search field.

• To access the Tools Wizard, tap to hide keyboard.

• If a Catalogue function requires a defined variable, you must define the variable
before you can insert the Catalogue item.

To insert a maths operator

1. TapMaths Operators to view the list of operator types.

2. Tap a category name to open the list of available operators.

3. Tap an operator name, and then tap Done to insert it into the entry line.

Using Wizards
Some functions in the Catalogue have a wizard that prompts you for each argument.
Functions that have wizard support are identified with the wand symbol .

To enable wizards

1. Tap to hide the TI-Nspire™ keyboard if it is showing.

2. Tap Utilities , and then go to Catalogue. By default, the Tools Wizard is OFF.



3. Slide the button to the right to enable the Tools Wizard.

4. Select the function you want to insert. (The function must have wizard support.)

5. Tap Done.

The wizard opens and prompts for each argument before the function is inserted
into the entry line.

6. Enter the arguments needed for the selected function.

Note: If the keyboard is needed to complete an entry, it opens when you tap the
field.

7. Tap OK as needed to complete entries in each prompt for the selected function.

The selected function is inserted into the Calculator entry line.

Note: If a Catalogue function requires a defined variable, you must define the
variable before you can insert the Catalogue item.

Using an Expression Template

Suppose you want to evaluate :
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1. Tap the entry line to show the keyboard.

2. Tap .

The algebraic sum template is inserted into the entry line. Small blocks represent
elements that you can enter.

Note: The blue line on the top of this key indicates this key has alternate functions.
Touch and hold the key to access the alternate function.

3. Use the arrow keys (or tap each element) to move the cursor to each element's
position and enter a value or expression in each position.

4. Tap enter to evaluate the expression.

Using the Unit Conversion Assistant
In any application where maths input is allowed, you can generate unit conversions
using the Unit Conversion Assistant. This can help reduce syntax errors by automatically
entering the units for you.

Example: Convert 528 minutes to hours. The desired expression is 528•_min►_hr.

1. Tap on the entry line.

2. Tap Utilities , then tap Unit Conversions.



3. Tap Conversion Assistant, then tap Done.

The Unit Conversion Assistant dialogue box displays:

4. Tap the Category list and select Time. Then tap < Unit Conversion Assistant.

5. Tap the From list and selectmin (minute). Then tap < Unit Conversion Assistant.
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Note: You can select Use existing unit at the bottom of the list if you have already
entered a unit. In this example, you might have already entered 528•_min.

6. Tap the To list and select hr (hour). Then tap < Unit Conversion Assistant.

7. Tap OK to paste _min►_hr to the entry line.

8. Tap enter to evaluate the expression.

Note:

• The last Category, From, and To selections will be retained until the language is
changed, or the app is uninstalled or upgraded.

• Inserting a conversion into a Notes text field will automatically create a maths Box.

• Inserting a conversion into an empty line in the Calculator will automatically insert
Ans before the conversion.

Conversion Categories
The following table lists categories that are available in the Unit Conversion Assistant.
When the units are pasted to the entry line, underscores (_) are added before the
name of each unit to differentiate them from other variables. For example:

• _cm►_m

• _km/_hr►_m/_s

• _¡C►_¡F

Categories

• Length
• Area
• Volume
• Time

• Velocity
• Temperature
• Mass
• Force

• Energy
• Power
• Pressure



Variables Overview
A variable is a defined value that can be used multiple times in a problem. You can
define a value or function as a variable within each application. Within a problem,
variables are shared by TI-Nspire™ applications. For example, you can create a variable
in Calculator, and then use or modify that variable in Graphs, Geometry or Lists
& Spreadsheet within the same problem.

Each variable has a name and definition. The definition can be changed, and when you
change the definition, all occurrences of the variable in the problem are updated to use
the new definition. In the TI-Nspire™ software, a variable has four attributes:

• Name - User-defined name assigned when the variable is created.

• Location - Variables are stored in memory.

• Value - Number, text, mathematical expression or function.

• Type - Type of data that can be stored as a variable.

Variables created with the Local command within a user-defined function or program
are not accessible outside of that function or program.

Using Variables in a Problem

• When first created, a variable is available only to the problem where it is defined.

• A variable can be used multiple times in applications that are part of the same
problem.

• If the value of the variable is changed in the original application, the change is
reflected in all applications where the variable is used.

• A variable is not available to other problems or documents until you define the
variable as a library object and copy it to a library folder. See Libraries for more
information.

Defining Variables
Any portion or attribute of an object or function created within an application can be
stored as a variable. Examples of attributes that can become variables include the:

• Area of a rectangle

• Radius of a circle

• Value contained in a spreadsheet cell

• Contents of a row or column in a spreadsheet

• Function expression

When you create a variable, it is stored in memory.

Types of Variables

You can store the data types listed in the following table as variables.
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Data type Examples

Expression 2.54 1.25E6 2p xmin/10 2+3i (x-
2)2

List {2, 4, 6,
8}

{1, 1, 2} {"red", "blue", "green"}

Matrix This can be entered as: [1,2,3;3,6,9]

Character
string

"Hello" "xmin/10" "The answer is:"

Function,
program

myfunc( arg ) ellipse( x, y, r1, r2)

Measuremen
t

area perimeter length slope angle

Naming Variables and Functions
Names for variables and functions that you create must meet the following naming
rules.

Note: If you create a variable with the same name as one used for statistical analysis or
by the Finance functions, an error condition could occur. When you enter the name of
a variable that is already in use in the current problem, the entry is shown in bold.

• Variable names must be in one of the forms xxx or xxx.yyy. The xxx part can have 1
to 16 characters. The yyy part, if used, can have 1 to 15 characters. You cannot
start or end the variable name with a period (.).

• Characters can consist of letters, digits and the underscore character (_). Letters
can be U.S. or Greek letters (but not ∏ or π), accented letters and international
characters.

• Do not use c or n from the symbol palette to construct a variable name such as c1
or n12. These may appear to be letters, but they are treated internally as special
symbols.

• You can use uppercase or lowercase letters. The names AB22, Ab22, aB22 and
ab22 all refer to the same variable.

• You cannot use a digit as the first character of xxx or yyy.
• When entering a subscript, you can use digits zero through 9, U.S. letters, a through

z, Latin and Greek letters (but not π) as subscripts (for example, a2, qa or h2o). To



enter a subscript while typing a variable name, touch and hold , and then slide

to select .

• Do not use spaces.

• If you want a variable to be treated as a complex number, use an underscore as the
last character of the name.

• CAS: If you want a variable to be treated as a type of unit (such as _m or _ft), use an
underscore as the first character of the name. You cannot use any other
underscores in the name.

• You cannot use an underscore as the first character of a name.

• You cannot use a pre-assigned variable, function or command name, such as Ans,
min or tan.

• Library documents and library objects are subject to additional naming restrictions.
For more information, see Libraries.

Creating Variables in Calculator
When creating a variable, use the following conventions. As alternatives to using→
(store), you can use ":=" or the Define command. All of the following statements are
equivalent.

5+83→num

num:= 5+83

Define num=5+83

To Create a Variable in the Calculator Application

1. Tap the Calculator entry line to show the keyboard.

2. Touch and hold to show the alternate functions, and then slide to the desired

function.

3. Enter the value for the variable (a number, text, mathematical expression, or
function).
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4. Tap enter.

Note: Use the right, left, up, and down arrows to move the cursor within the
expression or function. Make sure the cursor is positioned correctly in the entry line
before tapping enter to create the variable.

Entering Multiple Variables on the Entry Line

To enter several variables on a single line, separate them with a colon (:). Only the
result of the last expression is shown.

Creating Variables in Graphs
In the Graphs application, functions defined on the entry line are automatically stored
as variables.

In this example, f1(x)=x3 is automatically stored as a variable definition named f1, which
you can use in other applications in the problem, including a table in the Lists
& Spreadsheet application.

When you tap enter, the equation is graphed, and the variable is defined. Tap to

see the list of defined variables.

Creating a Variable from a Geometry Value
In this example, the area of the triangle will be the value for a variable named
"triangle."

1. Tap the value you want to store to select it, and then tap it again to open the
context menu.



2. Tap Store.

var := appears before the selected value. This is the default name.

.

3. Replace the default name var with the variable name you want to give the value.

4. Tap enter.

The value is saved to that variable name, and the stored value or its name appears
in bold text to indicate that it is a stored value.
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Creating Variables in Lists & Spreadsheet
Naming a list at the top of a Lists & Spreadsheet column or creating a variable from a
cell value automatically stores that value as a list variable. After defining the variable,
you can link to it from the Graphs, Geometry, Calculator, and Data & Statistics
applications as well as from other Lists & Spreadsheet pages within the current
problem.

Note:When naming variables, use a name that does not exist in the current problem.

Creating a Variable from a Column Name

1. Tap the column's name cell (the top cell of the column).

2. Type a name for the list variable, and then tap return.

3. Create elements in the list. For example, type data into each cell or use a formula
to generate a column of data.

Notes:

• Lists can contain empty elements (denoted by an underscore ("_").

• You can refer to a specific element in a named list from the Calculator application.
Use the list name and the element's position within the list. In a list named Heights,
for example, refer to the first element as Heights[1]. The expression Heights[2]
refers to the second elements, and so on.

Creating a Variable from a Cell Value

You can share a cell value with other TI-Nspire™ applications. When defining or
referring to a shared cell in Lists & Spreadsheet, precede the name with an apostrophe
(').

1. Tap the cell that contains the value you want to share, and then tap again to open
the context menu.



2. Tap Store.

A formula is inserted into the cell with var as a placeholder for the variable name.

3. Replace the letters "var" with a name for the variable.

4. Tap return.

The value is now available as a variable in other applications within the same
problem.

Adjusting Variable Values with a Slider
A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes, and Data & Statistics
applications.
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Horizontal slider for adjusting variable a.

Minimized vertical slider for adjusting variable b.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

From a Graphs, Geometry, or Data & Statistics page, select Actions > Insert Slider.

– OR –

From a Notes page, make sure the cursor is not in a math box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.

2. Enter the desired values, and tap OK.



The slider is displayed. On a Graphs, Geometry, or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, tap an empty
space in the work area. You can show the handles
anytime by selectingMove from the slider's context
menu.

3. To adjust the variable, slide the pointer (or tap the arrows on a minimised slider).

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings. To open the context menu:

1. Touch and hold the slider.

The context menu opens.

2. Tap an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations, or sequences that refer to undefined variables.

Linking a Lists & Spreadsheet Cell or Column to a Variable
When you link a cell or column to a variable, Lists & Spreadsheet updates the values to
reflect the current value of the variable. The variable can be any variable in the current
problem and can be defined in Graphs, Geometry, Calculator, or any instance of Lists
& Spreadsheet.

Notes:
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• You cannot link to the same variable multiple times on the same page.

• Do not link a cell to a system variable. Doing so could prevent the variable from
being updated by the system. System variables include ans, StatMatrix, and
statistics results (such as RegEqn, dfError, and Resid).

Linking a Cell Value to an Existing Variable

1. In a Lists & Spreadsheet page, tap the cell that you want to link to a variable. This
should be an empty cell and the cell cannot be in a list that is already defined as a
variable.

2. Tap the cell again to open the context menu.

3. Tap Link.

4. Tap the name of the variable to insert it into the cell.

The value of the variable is displayed in the cell.



Linking a Column to an Existing List Variable

To view or edit values in a list variable, link a column to the list variable. The list can be
any shared list in the current problem and can be defined in Graphs, Geometry,
Calculator, or any instance of Lists & Spreadsheet.

After you link a column to a list, changes you make to the list in other applications are
automatically updated in Lists & Spreadsheet.

1. Tap the column formula cell (the second cell from the top) that you want to link to
a variable.

2. Type the name of the list variable that you want to link to, and then tap return.

– OR –

To view the list of available variables:

▶ Tap on the TI-Nspire™ Keyboard, and then tap a variable name.

The column shows the list elements.

Locking and Unlocking Variables
Locking a variable protects it from modification or deletion, and prevents unintended
changes to a defined variable. For example, you may want to lock variables that define
time or altitude to ensure integrity.

You cannot lock the following variables:

• System variable ans
• stat. and tvm. variable groups

Locking Variables

1. Go to the Calculator application, and tap the entry line to show the keyboard.

2. Tap Tools .
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3. Go to Actions, and then tap Lock.

4. Tap Lock Variable to select the function and insert it into the entry line.

5. Tap , and then tap the variable name you want to lock.

Note: You can also type the variable name in the entry line.

6. Tap enter.

The result Done indicates the variable is locked.

Locked variables display a lock icon on the variable menu list.

Note: The Lock command clears the Redo/Undo history when applied to unlocked
variables.

Unlocking Variables

To modify or delete a locked variable, you must unlock the variable.

1. Tap Tools and go to Actions > Lock.

2. Tap Unlock Variable to enter the function into the entry line.



3. Tap , and then tap the locked variable name.

4. Press enter to remove the locked status.

The result Done indicates the variable is now unlocked.
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Graphs Application
The Geometry application lets you create, manipulate, analyse and trace graphs of
mathematical relations.

What You Can Do

• Define and explore functions and other relations, such as inequalities, parametrics,
polars, sequences and differential equation solutions.

• Graph and explore linear and conic equations analytically in a two-dimensional
coordinate system. Analyse lines, circles, ellipses, parabolas, hyperbolas and
general conic equations.

• Animate points on objects or graphs and explore their behaviour.

• Define relations to share with other applications, such as Calculator or Notes.

• Link to data created by other applications.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know
Finding Hidden Objects in the Graphs or Geometry Application

You can hide graphs, geometric objects, text, labels, measurements, and individual axis
end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects, tap
Tools and go to Actions > Hide/Show. Tap a graph or object to toggle its Hide/Show
state.

Changing the Appearance of a Graph or Object

1. Tap the graph or object that you want to change.

2. Tap the Inspector to display a list of the object's attributes.



Note: The list of attributes is different for different types of objects.

3. Select the items to change. Changes are applied as you select them.

Animating a Point on a Graph or Object

1. Tap the point.

2. Tap Inspector to display the point's attributes.

3. Drag the Animation Speed slider to set the speed and start the animation.

Inserting a Background Photo

The Insert Photo tool lets you insert a photo as a background for any Graphs or
Geometry page.

Adding Text to the Graphs or Geometry Work Area

1. Tap Tools and go to Actions > Text.

The Text tool appears in the application Toolbar.

2. Tap the location for the text.

3. Type the text in the box that appears, and then tap return.
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4. To edit the text, double-tap it.

Adding a Graphs Page
To get started with the Graphs application, add a Graphs page to an existing document.

Tap Add, and then tap .

A new Graphs page appears, showing the Graphs Toolbar, entry line, and work area.

Graphs Toolbar

• Tap Tools to create and explore graphs.

• Tap Inspector to change the appearance of a graph.

• Tap to change the settings used by the Geometry and Graphs



applications.

• Tap to view or edit an expression from the graph history.

• Tap to hide or show the keyboard and the entry line.

Entry line. Lets you define the relations that you want to graph. The
default graph type is Function, so the form f1(x)= is displayed initially.
You can define 99 relations of each type.

Graphs Work Area

• Shows graphs of relations that you define on the entry line.

• Shows points, lines, and shapes that you create with geometry
tools.

• Pinch to zoom, drag to pan (affects only those objects created in
the Graphs application).

Graphing Functions
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Function.

2. Type an expression for the function.

3. Tap enter to graph the function.
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Manipulating a Function by Dragging

Linear
Function

• To translate, grab near the middle of the graph, and then drag.

• To rotate, grab near the ends of the graph, and then drag.

Quadratic
Function

• To translate, grab near the vertex of the graph, and then drag.

• To stretch, grab away from the vertex of the graph, and then drag.

Sine or
Cosine
Function

• To translate, grab near the axis of vertical symmetry of the graph,
and then drag.

• To stretch, grab away from the axis of vertical symmetry of the
graph, and then drag.

Finding Points of Interest on a Function Graph

▶ Create a point on the graph, and then drag the point to quickly identify maximums,
minimums, and zeroes.

Temporary signposts appear as you drag through the points of interest.

▶ For other points of interest, tap Tools , select Analyse Graph, and select the type
of analysis, such as Integral. The application prompts you to choose a graph and
define the boundaries.

Note: For information about path plots, see Exploring Graphs with Path Plot.

Exploring Graphs with Path Plot
Path Plot lets you animate function, parametric, and polar equation plots in real time to
analyse how they are plotted and not just the final plot.



Changing the Path Plot Settings

1. In the Graphing view, tap Tools and go to Trace > Path Plot > Path Set-up.

2. Select the settings you want to use.

- Graph Type: Selects Function, Parametric, or Polar as the graph type.
- Path Step: Sets the increment of the independent variable at which values are

plotted.
- Show Future Path: Toggles the display of all future points for each function past

the starting or current point of the graph. You can also toggle this when viewing
the graph with the Up/Down arrow keys.

- Show Point Coordinates: Toggles the display of the coordinates for recorded
trace points.

Enabling Path Plot

1. Enter your equation(s).

2. From the Tracemenu, select Path Plot > Function/Parametric/Polar.

3. Navigate through the animation by:

- using the Play/Pause/Reset Animation icons
- using the Left/Right arrow keys
- entering a number to jump to that point

Graphing Linear and Conic Equations
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Equation.

2. Tap the type of equation (Line, Parabola, Circle, Ellipse, Hyperbola, or Conic).

3. Tap the specific template for the equation. For example, tap y=a•x2+b•x+c to
define a parabola.

The entry line includes a symbol to indicate the type of equation.
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4. Type the coefficients into the equation template.

5. Tap enter.

Graphing Relations
Relation graphing is available on Graphs pages and in the Analytic Window of Geometry
pages.

You can define relations using ≤, <, =, >, or ≥. The inequality operator (≠) is not
supported in relation graphing.

Relation type Examples

Equations and inequalities
equivalent to
y = f(x)

• y = sqrt(x)
• y-sqrt(x) = 1/2
• -2*y-sqrt(x) = 1/2
• y-sqrt(x) ≥ 1/2
• -2*y-sqrt(x) ≥ 1/2

Equations and inequalities
equivalent to
x = g(y)

• x = sin(y)
• x-sin(y) = 1/2
• x-sin(y) ≥ 1/2

Polynomial equations and
inequalities

• x^2+y^2 = 5
• x^2-y^2 ≥ 1/2+y
• x3+y3-6*x*y=0

The above relations on domains
restricted by rectangles

• y=sin(x) and -2π<x≤2π
• y≤x2|y ≥ -2 and 0 ≤ x ≤ 3



Relation type Examples

• {x2+y2≤3, y ≥ 0 and x ≤ 0

To Graph a Relation:

1. From the Graph Entry/Editmenu, select Relation.

2. Type an expression for the relation. You can touch and hold the "greater than" key 
to select one of the relation operators.

3. Press enter to graph the relation.

Tips for Graphing Relations

▶ You can quickly define a relation from the Function entry line. Position the cursor to
the immediate right of the = sign, and then tap the backspace key  .

A small menu appears with the relation operators and a Relation option. Choosing
from the menu places the cursor in the Relation entry line.

▶ You can type a relation as text on a Graphs page and then drag the text object over
either axis. The relation is graphed and added to the relation history.

Warning and Error Message

Error Condition Additional Information

Relation input not supported Relation input not supported
Note: The following relation inputs are
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Error Condition Additional Information

supported:
• Relations using ≤, <, =, >, or ≥.
• Polynomial relations in x and y
• Relations equivalent to y=f(x) or x=g(y) or

corresponding inequalities
• The above relations on domains restricted

by rectangles

Domain Restrictions not
supported for certain classes of
relations equivalent to y=f(x) or
x=g(y) or corresponding
inequalities.

• Relations equivalent to y=f(x) and
corresponding inequalities can only have
constraints on x

• For example: y=√(x) and 0≤x≤1 will work
but y=√(x) and 0≤y≤1 will not

• Relations equivalent to x=g(y) and
corresponding inequalities can only have
constraints on y

• For example: x=sin(y)|−1≤y≤1 will work
but x=sin(y)|−1≤x≤1 will not

Graphing Parametric Equations
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Parametric.

2. Type expressions for xn(t) and yn(t).

3. (Optional) Edit the default values for tmin, tmax, and tstep.
4. Tap enter.



Note: For information about path plots, see Exploring Graphs with Path Plot.

Graphing Polar Equations
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Polar.

2. Type an expression for rn(θ).
3. (Optional) Edit the default values for θmin, θmax, and θstep.

4. Tap enter.
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Note: For information about path plots, see Exploring Graphs with Path Plot.

Using the Text Tool to Graph Equations
1. In the Graphs application, tap Tools and go to Actions > Text.

2. Tap the work area to place the text box and display the keyboard.

3. Type an "x=" or "y=" equation, such as x=sin(y)*2, or type an inequality, such as
x<2*sin(y), and tap enter.

4. Drag the text object to either axis to graph the equation.



Graphing a Scatter Plot
1. In the Graphs application, tap Tools and go to Graph Entry/Edit > Scatter Plot.

2. Use one of the following methods to specify two lists to plot as x and y.

- Tap to select a list variable that you have defined in the current problem.

- Type the name of an existing list variable, such as v1.
- Type the list elements directly (for example, type {1,2,3}.

3. Tap enter to plot the data, and then zoom the work area to view the plotted data.

Plotting Sequences
Defining a Sequence

1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Sequence >
Sequence.

2. Type the expression to define the sequence. Update the independent variable field
to m+1, m+2, etc., if necessary.

3. Type an initial term. If the sequence expression references more than one prior
term, such as u1(n-1) and u1(n-2), (or u1(n) and u1(n+1)), separate the terms
with commas.
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4. Tap enter.

Defining a Custom Sequence

A custom sequence plot shows the relationship between two sequences by plotting
one on the x axis and the other on the y axis.

This example simulates the Predator-Prey model from biology.

1. Use the relations shown here to define two sequences: one for a rabbit population,
and another for a fox population. Replace the default sequence names with rabbit
and fox.

.05 = the growth rate of rabbits if there are no foxes

.001 = the rate at which foxes can kill rabbits

.0002 = the growth rate of foxes if there are rabbits

.03 = the death rate of foxes if there are no rabbits

Note: If you want to see the plots of the two sequences, zoom the window to the
Zoom - Fit setting.

2. Tap Tools and go to Graph Entry/Edit > Sequence > Custom.

3. Specify the rabbit and fox sequences to plot on the x and y axes, respectively.



4. Tap enter to create the custom plot.

5. Zoom the window to the Zoom - Fit setting.

6. Explore the custom plot by dragging the point that represents the initial term.

Graphing Differential Equations
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ODE entry line:
• y1 ODE identifier
• Expression k·y1 defines the relation
• Fields (1,1) for specifying initial condition
• Buttons for adding initial conditions and setting plot parameters

Slider added for adjusting coefficient k of the ODE

Slope field

A solution curve passing through the initial condition

To Graph a Differential Equation:

1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Diff Eq.

The ODE is automatically assigned an identifier, such as “y1.”

2. Move to the relation field and enter the expression that defines the relation. For
example, you might enter -y1+0.1*y1*y2.

3. Enter the initial condition for the independent value x0 and for y10.

Note: The x0 value(s) are common to all the ODEs in a problem but can be entered
or modified only in the first ODE.

4. Tap Edit Parameters to set the plot parameters. Select a numerical Solution
Method, and then set any additional parameters. You can change these parameters
anytime.



5. Tap OK.

6. Zoom the window as necesssary to view the graph.

Viewing Tables in the Graphs Application

Tap Tools and go to Table > Split-screen Table.

The table is displayed with columns of values for the currently defined relations.
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To remove the table, tap Tools and go to Table > Remove Table.

Note: For details about using tables, see Working with Tables.

Accessing the Graph History
For each problem, the Graphs application automatically stores a history of defined
relations, such as functions f1 through f99 and sequences u1 through u99. You can view
and edit these items.

Viewing the History of the Current Relation Type

1. Tap History  at the right end of the Graphs toolbar to show the history of the
current relation type (for example, f for Functions).

2. In the History list, tap the name of the relation, and then tap Done to show the
relation in the entry line.

3. Use the up and down arrow keys to scroll through the defined relations.

Viewing the History of other Relation Types

1. In the Graphing view, tap Tools , go to Graph Entry/Edit, and tap the relation
type. For example, tap Polar to show an entry line for the next available Polar
relation.

2. Use the up and down arrow keys to scroll through the defined relations.

Customising the Graphs Work Area
Note: Rescaling in the Graphs application affects only the graphs, plots, and objects
that reside in the Graphing view. It has no effect on objects in the underlying Plane
Geometry view.

Zooming/Rescaling Manually

▶ To rescale the x and y axes proportionally, pinch the work area.



▶ To rescale only one axis, tap Tools , select Actions > Constrained Movement, and
then drag along the axis.

Zooming to predefined settings

▶ Tap Tools , selectWindow/Zoom, and select one of the predefined Zoom
settings. The initial setting is Zoom - Standard.

Displaying the Grid

1. In the Graphs application, tap Tools and go to View > Grid.

2. Tap Dot Grid, Lined Grid, or (if the grid is already displayed) No Grid.

Changing the Appearance of the Grid

1. In the Graphs application, tap Tools and go to Actions > Select Grid.

The grid will flash.

2. Tap the Inspector to show a list of attributes that you can change.

Changing the Appearance of the Graph Axes

1. Tap either axis to select the axes.

2. Tap the Inspector to show a list of attributes that you can change.

3. Select the items to change. Changes are applied as you select them.

Multiple Tick Mark Labels

Multiple labels are only displayed if they fit both horizontally and vertically on the axes.
Rescale the Axes if necessary by pinching or spreading either the horizontal or vertical
axis to modify its scale.
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– OR –

Drag either axis to shift the axis while retaining its scale.

To restore the original size and location of the plotted data, tap Tools > Window / Zoom
> Zoom-Data.

Exact Arithmetic and CAS Only: You can change the tick mark labels to display multiples
of Pi, radical numbers, and other exact values by editing the XScale or YScale values in
theWindow / Zoom > Settings.

Note: pi/2 will be converted to p/2 after clicking OK.



Note: For information about path plots, see Exploring Graphs with Path Plot.

Tracing Graphs or Plots
1. In the Graphing view, tap Tools and go to Trace > Graph Trace.

The Graph Trace tool appears in the Graphs toolbar, the trace cursor appears, and
the cursor coordinates are displayed in the lower right corner.

2. Explore a graph or plot:

- Tap a point on a graph or plot to move the trace cursor to that point.

- Tap or on the Graph Trace tool to step the cursor along the current
graph or plot. The screen pans automatically to keep the cursor in view.

- Double-tap the trace cursor to enter a specific independent value.
- Tap and hold the trace cursor to create a persistent point.

3. To stop tracing, tap the X on the Graph Trace tool.

Graphs Application 61



62 Graphs Application

Introduction to Geometric Objects
Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape or geometric conic
created in the Graphs application.

The circle arc and polygon were created in the Geometry application. The sine wave and
conic were created in the Graphs application.



Objects Created in the Geometry Application

Points, lines and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application

Creating Geometric Objects
You can create objects in both the Geometry and Graphs applications.

Creating Points and Lines

1. Tap Tools , select Points and Lines, and select the type of object, such as Segment.
(In the Graphs application, go to Geometry > Points and Lines > Segment.)

2. Tap existing points or locations on the work area to define the object. For example,
tap two objects when creating Intersection points.

As you create the object, a tool is shown in the application Toolbar (for example,

Segment ). To cancel, tap the X on the tool.
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Creating Geometric Shapes

1. Tap Tools , select Shapes, and select the type of object, such as Polygon. (In the
Graphs application, go to Geometry > Shapes > Polygon.)

2. Tap existing points or locations on the work area to define the object. For example,
tap two locations to define the centre and radius of a circle.

As you create a shape, a tool is shown in the application Toolbar (for example, Polygon

). To cancel the shape, tap the X on the tool.

Measuring and Transforming Geometric Objects
Measuring Objects

1. Tap Tools , selectMeasurement, and select the type of measurement, such as
Length. (In the Graphs application, go to Geometry > Measurement > Length.)

2. Tap the object you want to measure.

Measurement Type Use to Measure...

Length • Length of a segment,
circle arc, or vector

• Distance Between Two
Points, a Point and a Line,
or a Point and a Circle

• Circumference of a Circle
or Ellipse or the
Perimeter of a Polygon,
Rectangle, or Triangle

• A side of a triangle,
rectangle, or polygon.
You must tap two points
to measure a side.
Tapping the side
measures the entire
length of the object's
perimeter.

Area Area of a Circle, Ellipse,
Polygon, Rectangle, or
Triangle



Measurement Type Use to Measure...

Slope Slope of a Line, Ray, Segment,
or Vector

Angle Angles in the range from 0° to
180° (0 radians to π radians in
the Graphs application)

Directed Angle Directed angles in the range
from 0° to 360° (0 radians to
2π radians) and from -360° to
0° (-2π radians to 0 radians).

Transforming Objects

1. Tap Tools , select Transformation, and select the type of transformation, such as
Symmetry. (In the Graphs application, go to Geometry > Transformation >
Symmetry.)

2. Tap the object you want to transform.

3. Tap a location, existing point, or other object to create the transformation.

Exploring with Construction Tools

To add a construction, tap Tools , select Construction, and select the type of
construction, such as Parallel. (In the Graphs application, go to Geometry > Construction
> Parallel.)
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While a construction is in progress, a tool appears in the application Toolbar (for

example, Parallel ). To cancel, tap the X on the tool.

Construction Type Description

Midpoint Bisects a segment or sets a midpoint
between any two points. The points can
be on a single object, on separate objects
or on the work area.

Parallel Line Creates a parallel line with respect to any
existing line. The existing line can be a
Graphs axis or any side of a triangle,
square, rectangle or polygon.

Perpendicular Line Creates a line that is perpendicular to a
reference line. The reference can be an
axis, an existing line, a segment or one
side of a triangle, rectangle or polygon.

Perpendicular Bisector Creates a perpendicular bisector on a
segment, on one side of a triangle,
rectangle or polygon or between any two
points.



Construction Type Description

Angle Bisector Creates an angle bisector. The points of
the angle can be on existing objects, or
they can be locations on the work area.

Locus Lets you explore the range of motion of
one object with respect to another object
as constrained by a shared point.

Compass Operates similarly to a geometric compass
used for drawing circles on paper.
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Labeling (Identifying) the Coordinates of a Point
The Graphs application can identify and label the coordinates of any existing point,
provided the point was created in the Graphs application.

1. Tap the point to select it, and then tap it again to show its context menu.

2. Tap Coordinates.

If you move the point to a different location, the coordinates follow the point and
update automatically.

Bounded Area (Area Between Curves)
Note: To avoid unexpected results when using this feature, make sure the
document setting for "Real or Complex Format" is set to Real.

You can use the Graphs application to access the area between curves.



When you calculate the area between curves, each curve must be:

• A function with respect to x.

– OR –

• An equation in the form y=, including y= equations defined through a text box or a
conic equation template.

Defining Bounded Area (Area Between Curves)

1. Open a new Graphs page.

2. Tap sin and x, then tap enter.

3. Tap .

4. Tap cos and x, then tap enter.

For this example the graph now shows f1(x)=sin(x) and f2(x)=cos(x) function(s).

5. Tap Tools and go to Analyse Graph > Bounded Area.

The Bounded Area tool appears in the application Toolbar. You are
prompted to set the lower and upper bounds.

6. Tap or drag two points to define the bounds.
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The area becomes shaded, and the area value is displayed. The value is always non-
negative, regardless of the interval direction.

Working With Shaded Areas

As you change the bounds or redefine the curves, the shading and the area value are
updated.

• To change the lower or upper bound, drag it or type new coordinates for it. You
cannot move a bound that resides on an intersection. However, the point moves
automatically as you edit or manipulate the curves.

• To redefine a curve, either manipulate it by dragging or edit its expression in the
entry line.

Note: If an endpoint resided originally on an intersection, and the redefined
functions no longer intersect, the shading and area value disappear. If you redefine
the function(s) so that there is an intersection point, the shading and area value
reappear.

• To delete or hide an area, tap to select the bounded area, then tap again to see the
context menu. From the context menu, you may delete the bounded area.

• To change the colour and other attributes, tap the Object Inspector once the
shaded region is selected.

Displaying the Equation of a Geometric Object
You can display the equation of a geometric line, tangent line, circle shape or geometric
conic, provided the object was constructed in the Graphs application and can be
converted faithfully to a template-based conic.

1. Tap the object to select it, and then tap it again to show its context menu.



2. Tap Equation to display the equation as a Text object.

Using the Calculate Tool
The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a maths expression you have entered as a text object. You can edit an
evaluated expression, and then re-evaluate it.

Entering the Expression

1. Tap Tools and go to Actions > Text.

2. Tap the work area to place the text box and display the keyboard.

3. Type the expression, such as (1/4)2*2, and tap enter.

Note: Do not include variables in the expression.
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Calculating the Result

1. Tap Tools and go to Actions > Calculate.

The Calculate tool appears in the toolbar, and a prompt asks you to select an
expression to calculate.

2. Tap the text object to evaluate the expression.

Creating Shapes Using Gestures (MathDraw)
The MathDraw tool lets you use touchscreen gestures to create points, lines, circles
and other shapes.

• MathDraw is available in Geometry and Graphing.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

Note:MathDraw is not available in the 3D Graphing.

Activating MathDraw

1. Tap Add, and then tap .

2. Tap Tools .

3. Tap Actionsmenu, selectMathDraw.

The MathDraw tool appears in the application Toolbar. You can begin
using the tool.

Cancelling MathDraw

▶ When you have finished using the MathDraw tool, tap the X on the tool.

Creating Points

To create a labelled point, tap in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles) or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.

• If the point is close to a visible grid location in a Graphs view or Geometry view, it
snaps to the grid.



Drawing Lines and Segments

To create a line or segment, touch the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment or
side of a polygon, it aligns to that object.

Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named
ti_gg_fd.angle_tol. You can change the tolerance in the current problem by setting
this variable in the calculator app to a value in the range 0 through 45 (0=no
parallel/perpendicular detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen to draw the approximate shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual centre of the drawn shape is near an existing point, the circle or ellipse
is centred on that point.

Drawing Triangles

To create a triangle, draw a triangle-like shape.

• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.

• If the centre of a square is close to an existing point, the square snaps to that point.
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Drawing Polygons

To create a polygon, tap a succession of existing points, ending on the first point you
tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognise certain gestures as functions for
analytic parabolas.

Note: The default step value for quantisation of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen to draw a circle
arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labelled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap point 1, point 2 and then point 1
again.

Using MathDraw to Erase

To erase objects, use the touchscreen to drag left and right, similar to the motion of
erasing a whiteboard.

• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.

Sticky Tool in Geometry and Graphing
Sticky Tool is available in Geometry and Graphing.

Note: In the Graphs application, go to Tools > Geometry.

When a Geometry tool has the capability to remain active, it will display a lock element
along with the tool icon.



Lock Element icon

Unlocked/Single-use icon Locked/Multi-use icon

Note: All tools will open in the default or unlocked/single-use state. The icon will

appear to the left of the tool.

Unlocked/Single-use Locked/Multi-use

Default State

Opening a tool will always be in the default unlocked/single-use state). This applies to
scenarios like closing a tool, or switching to a new tool.

Geometry and Graphing tools that are sticky

The following tools will have the "sticky" feature:

• All items under "Points & Lines"

• All items under "Shapes"

• All items under "Measurement"

• All items under "Construction"

• All items under "Transformation"

Locking or Unlocking a tool

Tap the unlocked/single-use icon to lock a tool for locked/multi-use.

Note: The tool is now in a locked/multi-use state.

Tap the X to close the tool.

– OR –

Tap the unlocked/single-use state.

Note: The user can also toggle between icon.
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3D Graphing
The 3D Graphing view lets you create and explore three-dimensional graphs.

What You Can Do

• Create and edit 3D functions of the form z(x,y).

• Create and edit 3D parametric plots.

• Show and hide selected graphs.

• Set the background colour and apply wire and surface colours to graphs.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

Selecting the 3D Graphing View

The 3D Graphing View is available on any Graphs page .

▶ Tap Tools and go to View > 3D Graphing.

3D Graphs Toolbar

• Tap Tools to create and explore 3D graphs.



• Tap Inspector to change the appearance of a graph or the 3D box.

• Tap  to view or edit an expression from the 3D graph history.

• Tap  to hide or show the keyboard and the entry line.

Entry line. Lets you define 3D graphs. The default graph type is 3D Function,
indicated by z1(x,y)=.

3D Graphs Work Area. Shows a 3D box containing graphs that you define.
Pinch to zoom the area, drag to rotate the box.

Graphing 3D Functions
1. In the 3D Graphing view, tap Tools and go to 3D Graph Entry/Edit > Function.

The keyboard and the entry line appear.

2. Enter the expression that defines the graph. You can type the expression or build it
using expression templates.

3. Tap enter to create the graph and hide the entry line and keyboard. You can show
the entry line and keyboard anytime by tapping on the Graphs Toolbar.
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Graphing 3D Parametric Equations
1. In the 3D Graphing view, tap Tools and go to 3D Graph Entry/Edit > Parametric.

The keyboard and the entry line appear.

2. Type the equations that define the graph.

3. (Optional) Tap to set the 3D plotting parameters tmin, tmax, umin, and umax.

4. Tap enter to draw the graph and hide the entry line and keyboard. You can show
the entry line and keyboard anytime by tapping on the Graphs Toolbar.



Zooming and Rotating the 3D View
Zooming

▶ Pinch the work area to zoom in or out.

Rotating Manually

▶ Drag in any direction to rotate all objects in 3D Graphing view.

Rotating Automatically

1. Tap Tools and go to Actions > Auto Rotation.

The Auto Rotation tool appears, and the graph rotates
continuously around the z axis.

2. To stop the rotation, tap X on the tool.

Editing a 3D Graph
1. Double-tap the graph or its label to display the expression in the entry line. As an

alternative, you can use the graph history to show the expression.

2. Modify the existing expression, or type a new expression in the entry line.

3. Tap enter to draw the edited graph.
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Changing the Appearance of a 3D Graph
1. Tap the graph to select it.

2. Tap Inspector .

3. Select the items to change. Changes are applied as you select them.

Showing or Hiding a Graph’s Label

1. Tap the graph to select it, and then tap it again to show its context menu.

2. Tap Hide Label or Show Label.

Showing and Hiding 3D Graphs
1. In the 3D Graphing view, tap Tools and go to Actions > Hide/Show.

The Hide/Show tool appears, and all hidden items are displayed in gray.

2. Tap a graph to change its hide/show state.

3. To apply the changes, tap X on the tool.



Note: If you want to show or hide only the graph's label, see Showing or Hiding a
Graph’s Label.

Customising the 3D Viewing Environment

Changing the Background Colour

1. Tap the 3D box to select it.

Note: If the box is hidden, tap Tools and go to View > Show Box.

2. Tap Inspector .

3. Tap Fill Colour, and then select a colour to apply it to the background.

Changing the 3D Projection

1. Tap the and go to View.

2. Tap Orthographic Projection or Perspective View.
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Showing or Hiding the Box, Axes, and Legend

1. Tap Tools and go to View.

2. Tap the name of the element to show or hide.

Changing the 3D Aspect Ratio

1. Tap Tools and go to Range/Zoom > Aspect Ratio.

2. Enter values for the x, y, and z axes. The default value for each axis is 1.

Changing the Range of the 3D Box

▶ Tap Tools and go to Range/Zoom > Range Settings.



Geometry Application
The Geometry application lets you create, manipulate, measure, transform, and
animate geometric objects.

What You Can Do

• Create and explore points and lines, such as line segments, vectors, and circle arcs.

• Create and explore geometric shapes, such as circles, ellipses, polygons, and conics.

• Animate any point created as a point on an object or graph.

• Explore object transformations, including symmetry, reflection, translation,
rotation, and dilation.

• Create geometric constructions, such as bisectors, parallels, perpendiculars, loci,
and circles drawn with a compass.

• Hide an object or change its line color, line style, or fill color.

• Measure lengths, angles, perimeters, areas, and slopes.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know
Finding Hidden Objects in the Graphs or Geometry Application

You can hide graphs, geometric objects, text, labels, measurements, and individual axis
end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects, tap
Tools and go to Actions > Hide/Show. Tap a graph or object to toggle its Hide/Show
state.

Changing the Appearance of a Graph or Object

1. Tap the graph or object that you want to change.

2. Tap the Inspector to display a list of the object's attributes.
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Note: The list of attributes is different for different types of objects.

3. Select the items to change. Changes are applied as you select them.

Animating a Point on a Graph or Object

1. Tap the point.

2. Tap Inspector to display the point's attributes.

3. Drag the Animation Speed slider to set the speed and start the animation.

Inserting a Background Photo

The Insert Photo tool lets you insert a photo as a background for any Graphs or
Geometry page.

Adding Text to the Graphs or Geometry Work Area

1. Tap Tools and go to Actions > Text.

The Text tool appears in the application Toolbar.

2. Tap the location for the text.

3. Type the text in the box that appears, and then tap return.



4. To edit the text, double-tap it.

Adding a Geometry Page
To get started with the Geometry application, add a Geometry page to an existing
document.

Tap Add, and then tap .

A new Geometry page appears, showing the Geometry Toolbar and work area.

Geometry Toolbar

• Tap Tools to create and explore Geometry objects.

• Tap Inspector to change the appearance of a selected item such as
a geometric shape.

• Tap Graphs & Geometry Settings to change the settings used by the
Geometry and Graphs applications.

Geometry work area. Geometry objects that you create are displayed here.
Drag to pan the work area.
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Introduction to Geometric Objects
Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape or geometric conic
created in the Graphs application.

The circle arc and polygon were created in the Geometry application. The sine wave and
conic were created in the Graphs application.



Objects Created in the Geometry Application

Points, lines and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application

Creating Geometric Objects
You can create objects in both the Geometry and Graphs applications.

Creating Points and Lines

1. Tap Tools , select Points and Lines, and select the type of object, such as Segment.
(In the Graphs application, go to Geometry > Points and Lines > Segment.)

2. Tap existing points or locations on the work area to define the object. For example,
tap two objects when creating Intersection points.

As you create the object, a tool is shown in the application Toolbar (for example,

Segment ). To cancel, tap the X on the tool.

Geometry Application 87



88 Geometry Application

Creating Geometric Shapes

1. Tap Tools , select Shapes, and select the type of object, such as Polygon. (In the
Graphs application, go to Geometry > Shapes > Polygon.)

2. Tap existing points or locations on the work area to define the object. For example,
tap two locations to define the centre and radius of a circle.

As you create a shape, a tool is shown in the application Toolbar (for example, Polygon

). To cancel the shape, tap the X on the tool.

Measuring and Transforming Geometric Objects
Measuring Objects

1. Tap Tools , selectMeasurement, and select the type of measurement, such as
Length. (In the Graphs application, go to Geometry > Measurement > Length.)

2. Tap the object you want to measure.

Measurement Type Use to Measure...

Length • Length of a segment,
circle arc, or vector

• Distance Between Two
Points, a Point and a Line,
or a Point and a Circle

• Circumference of a Circle
or Ellipse or the
Perimeter of a Polygon,
Rectangle, or Triangle

• A side of a triangle,
rectangle, or polygon.
You must tap two points
to measure a side.
Tapping the side
measures the entire
length of the object's
perimeter.

Area Area of a Circle, Ellipse,
Polygon, Rectangle, or
Triangle



Measurement Type Use to Measure...

Slope Slope of a Line, Ray, Segment,
or Vector

Angle Angles in the range from 0° to
180° (0 radians to π radians in
the Graphs application)

Directed Angle Directed angles in the range
from 0° to 360° (0 radians to
2π radians) and from -360° to
0° (-2π radians to 0 radians).

Transforming Objects

1. Tap Tools , select Transformation, and select the type of transformation, such as
Symmetry. (In the Graphs application, go to Geometry > Transformation >
Symmetry.)

2. Tap the object you want to transform.

3. Tap a location, existing point, or other object to create the transformation.

Exploring with Construction Tools

To add a construction, tap Tools , select Construction, and select the type of
construction, such as Parallel. (In the Graphs application, go to Geometry > Construction
> Parallel.)
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While a construction is in progress, a tool appears in the application Toolbar (for

example, Parallel ). To cancel, tap the X on the tool.

Construction Type Description

Midpoint Bisects a segment or sets a midpoint
between any two points. The points can
be on a single object, on separate objects
or on the work area.

Parallel Line Creates a parallel line with respect to any
existing line. The existing line can be a
Graphs axis or any side of a triangle,
square, rectangle or polygon.

Perpendicular Line Creates a line that is perpendicular to a
reference line. The reference can be an
axis, an existing line, a segment or one
side of a triangle, rectangle or polygon.

Perpendicular Bisector Creates a perpendicular bisector on a
segment, on one side of a triangle,
rectangle or polygon or between any two
points.



Construction Type Description

Angle Bisector Creates an angle bisector. The points of
the angle can be on existing objects, or
they can be locations on the work area.

Locus Lets you explore the range of motion of
one object with respect to another object
as constrained by a shared point.

Compass Operates similarly to a geometric compass
used for drawing circles on paper.
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Using the Calculate Tool
The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a maths expression you have entered as a text object. You can edit an
evaluated expression, and then re-evaluate it.

Entering the Expression

1. Tap Tools and go to Actions > Text.

2. Tap the work area to place the text box and display the keyboard.

3. Type the expression, such as (1/4)2*2, and tap enter.

Note: Do not include variables in the expression.

Calculating the Result

1. Tap Tools and go to Actions > Calculate.

The Calculate tool appears in the toolbar, and a prompt asks you to select an
expression to calculate.

2. Tap the text object to evaluate the expression.

Creating Shapes Using Gestures (MathDraw)
The MathDraw tool lets you use touchscreen gestures to create points, lines, circles
and other shapes.

• MathDraw is available in Geometry and Graphing.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

Note:MathDraw is not available in the 3D Graphing.

Activating MathDraw

1. Tap Add, and then tap .

2. Tap Tools .

3. Tap Actionsmenu, selectMathDraw.

The MathDraw tool appears in the application Toolbar. You can begin
using the tool.



Cancelling MathDraw

▶ When you have finished using the MathDraw tool, tap the X on the tool.

Creating Points

To create a labelled point, tap in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles) or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.

• If the point is close to a visible grid location in a Graphs view or Geometry view, it
snaps to the grid.

Drawing Lines and Segments

To create a line or segment, touch the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment or
side of a polygon, it aligns to that object.

Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named
ti_gg_fd.angle_tol. You can change the tolerance in the current problem by setting
this variable in the calculator app to a value in the range 0 through 45 (0=no
parallel/perpendicular detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen to draw the approximate shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual centre of the drawn shape is near an existing point, the circle or ellipse
is centred on that point.

Drawing Triangles

To create a triangle, draw a triangle-like shape.
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• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.

• If the centre of a square is close to an existing point, the square snaps to that point.

Drawing Polygons

To create a polygon, tap a succession of existing points, ending on the first point you
tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognise certain gestures as functions for
analytic parabolas.

Note: The default step value for quantisation of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen to draw a circle
arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labelled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap point 1, point 2 and then point 1
again.

Using MathDraw to Erase

To erase objects, use the touchscreen to drag left and right, similar to the motion of
erasing a whiteboard.



• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.

Sticky Tool in Geometry and Graphing
Sticky Tool is available in Geometry and Graphing.

Note: In the Graphs application, go to Tools > Geometry.

When a Geometry tool has the capability to remain active, it will display a lock element
along with the tool icon.

Lock Element icon

Unlocked/Single-use icon Locked/Multi-use icon

Note: All tools will open in the default or unlocked/single-use state. The icon will

appear to the left of the tool.

Unlocked/Single-use Locked/Multi-use

Default State

Opening a tool will always be in the default unlocked/single-use state). This applies to
scenarios like closing a tool, or switching to a new tool.

Geometry and Graphing tools that are sticky

The following tools will have the "sticky" feature:

• All items under "Points & Lines"

• All items under "Shapes"

• All items under "Measurement"

• All items under "Construction"

• All items under "Transformation"
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Locking or Unlocking a tool

Tap the unlocked/single-use icon to lock a tool for locked/multi-use.

Note: The tool is now in a locked/multi-use state.

Tap the X to close the tool.

– OR –

Tap the unlocked/single-use state.

Note: The user can also toggle between icon.



Lists & Spreadsheet Application
The Lists & Spreadsheet application provides a place to work with tabular data.

What You Can Do

• Define a column based on the contents of another column.

• Work with variables created in the Graphs & Geometry and Calculator applications.

• Plot table data using the Data & Statistics application.

• Generate a table of values for a function or plot.

• Perform statistical analysis on lists of data.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Typing a Cell Reference in a Formula

Absolute references include the $ symbol before the column letter and before the row
number, and always refer to the cell in a specific position in the spreadsheet. Relative
references include only the cell’s column letter and row number, and describe where a
cell is in relation to other cells of the spreadsheet.

1. Double-tap the cell, and type the formula.

2. Move to the appropriate position in the formula, and type the cell reference.

Use the format for a relative reference (B3), absolute reference ($B$2) or range of
cells (A1:A4).

Linking a Cell Value to a Variable

1. In a Lists & Spreadsheet page, tap the cell that you want to link to a variable, and
then tap the cell again to open the context menu.

2. Tap Link, and then tap the name of the variable to insert it into the cell.
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Linking a Column to a Variable

1. Tap the column formula cell (the second cell from the top) that you want to link to
a variable.

2. Type the name of the list variable that you want to link to, and then tap return.

Note: To view a list of available variables, tap var on the TI-Nspire™ Keyboard.

Adding a Lists & Spreadsheet Page
To get started with the Lists & Spreadsheet application, add a Lists & Spreadsheet page
to an existing document.

▶ Tap Add, and then tap .

A blank Lists & Spreadsheet page is displayed.

Column and row reference cell

Column name cell for defining a column as a list variable

Column formula cell for generating a column of data

Body cells

Working with Data

Generating Columns of Data

You can create a column of values based on the contents of another column or on any
of several types of sequential data.



Column formula based on a variable

Column formula based on another column

Column formula that generates a sequence

Creating Values Based on Another Column

1. Tap the column formula cell (the second cell from the top) of the column where
you want to use a formula.

2. Type the expression for the formula after the = and tap enter.

Note: Use brackets ([]) after any column letter you include in the formula.

Generating a Column of Random Numbers

1. Tap the column formula cell (the second cell from the top) of the column.

2. Tap Tools and go to Data > Random > Integer to insert the randint() function.

3. The app inserts the randint() function in the formula cell.

4. Type 1,6,20, and then tap enter.

Note: The numbers given are for illustrative purposes only, and will generate a
column of 20 random integers in the range, 1 through 6.

Generating a Numerical Sequence

1. Tap any cell in the column in which you want to generate the sequence.

2. Tap Tools and go to Data > Generate Sequence.

3. Type the Formula that will be applied to the column values.
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4. Type any starting numbers required by the sequence in the Initial Terms field and
separate them with commas.

5. Type a starting value for the independent variable (n0), a maximum number of
values to be generated (nMax), and the step value (nStep).

Note: Type a maximum value for the sequence in the Ceiling Value field, if desired.

6. Tap OK.

Graphing Spreadsheet Data

Creating a Scatter Plot with Quick Graph

1. Name both of the columns to declare them as lists, and then select both columns.

2. Tap Tools and go to Data > Quick Graph.

A Data & Statistics application is added to the page with the plotted data.

Creating a Summary Plot

Note: In this example, you create a summary table from raw data, and then use the
table to generate a summary plot.

1. Create a list that holds the category identifiers. For this example, name the list
“colour” and type strings for eye colour.

2. Create the summary list. For this example, name the list “counts” and type the total
count for each of the eye colours.

3. Select either list.

4. Tap Tools and go to Data > Summary Plot.

5. If necessary, change the lists for X List and Summary List.

6. In the Display On field, select how to display the summary plot in the Data &
Statistics application, and then tap OK.

Capturing Data from Graphs or Geometry

1. Clear the columns you plan to use for the captured data.

2. Ensure that the data values you want to capture are linked to variable names.

3. Tap the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

4. Tap Tools and go to Data > Data Capture > Automatic.



A capture expression is inserted.

5. Replace the letters “var” with the name of the variable to capture.

Note: You can also select the variable name from the Variables menu by tapping
var, and then tapping the desired variable.

Using Table Data for Statistical Analysis

Tools on the Statistics menu provide access to wizards that help you perform statistical
analyses on the data in table columns. You specify the location of the data, and the
Lists & Spreadsheet application stores the results in two columns: one for the result
names, and one for the corresponding values.

Statistical Calculations and Results
You can perform statistical calculations to analyse data.

Performing Statistical Calculations

Note: The following example fits a y=mx+b linear regression model to two lists.

1. Tap the column formula cell (second cell from the top) in column A.

2. Tap Tools and go to Statistics > Stat Calculations > Linear Regression (mx+b) to
choose the regression model.
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3. Tap next to the Y List box to display a named list. Tap the name of the list for the
Y List.

4. To store the regression equation in a specified variable, replace Save RegEqn To
with the name of the variable.

5. Tap the 1st Result Column box and type c[] as the column letter for the first result
column.

6. Tap OK.

Note: The results are linked to the source data.

Storing Statistical Results

The Lists & Spreadsheet application stores statistical results using a variable-group
name with the format stat.nnn, where nnn is the result name (for example, stat.RegEqn
and stat.Resid). If you want to use a custom variable group instead of the standard
name, edit the formula in the column formula cell. You could use the following formula
to store the results in the variable groupMystatsB.

=LinRegMx(a[],b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression in the Calculator
application or in another column of the Lists & Spreadsheet application:

MystatsB.results

Distributions

Calculating a Distribution

Example: Calculate a distribution to fit the Normal Pdf distribution model.

1. Enter the X values of the data in column A.



2. Tap the top cell of column A and enter a name, such as DD1, for the X values.

3. Tap the column formula cell (second cell from the top) in column B.

4. Tap Tools and go to Statistics > Distributions > Normal Pdf.

The Normal Pdf dialogue box opens and displays fields for entering the arguments
for the calculation.

5. Tap each field and provide:.

- X Value: To use the list that you defined in step 2, tap the arrow and select the
list name.

- Mean (μ): Type a value or select a variable that contains the mean.

- Standard Deviation (σ): Type a value or select a variable that contains the
standard deviation.

6. (Optional) Select the Draw option to see the distribution plotted in
Data & Statistics.

Note: The Draw option is not available for all distributions.

7. Tap OK.

Lists & Spreadsheet populates column B with the results. The results are plotted in
Data & Statistics.

Note: The results are linked to the source data. For example, if you change a value
in Column A, the result updates automatically.
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Supported Distribution Functions

The following distributions are available from the Lists & Spreadsheet application. For
more information regarding these functions, see the TI-Nspire™ Reference Guide.

• To return a single distribution result based on a single value, type the function in a
single cell.

• To return a list of distribution results based on a list of values, type the function in a
column formula cell. In this case, you specify a list (column) that contains the
values. For each value in the list, the distribution returns a corresponding result.

Note: For distribution functions that support the draw option (normPDF, t PDF,
χ² Pdf, and F Pdf), the option is available only if you type the distribution function in
a formula cell.

Normal Pdf (normPdf)

Computes the probability density function (pdf) for the normal distribution at a
specified x value. The defaults are mean μ=0 and standard deviation σ=1. The
probability density function (pdf) is:

This distribution is used to determine the probability of the occurrence of a certain
value in a normal distribution. The draw option is available when Normal PDF is invoked
from a formula cell.

When you access distributions from the formula cell, you must select a valid list from
the drop-down list to avoid unexpected results. If accessed from a cell, you must
specify a number for the x-value. The distribution returns the probability that the value
you specify will occur.

Normal Cdf (normCdf)

Computes the normal distribution probability between Lower Bound and
Upper Bound for the specified mean, μ (default=0) and the standard deviation, s

(default=1). You can click the Draw (Shade area) check box to shade the area between
the lower and upper bounds. Changes to the initial Lower Bound and Upper Bound
automatically update the distribution.



This distribution is useful in determining the probability of an occurrence of any value
between the lower and upper bounds in the normal distribution. It is equivalent to
finding the area under the specified normal curve between the bounds.

Inverse Normal (invNorm)

Computes the inverse cumulative normal distribution function for a given area under
the normal distribution curve specified by mean, μ, and standard deviation, s.

This distribution is useful in determining the x-value of data in the area from 0 to x<1
when the percentile is known.

t Pdf (tPdf)

Computes the probability density function (pdf) for the t-distribution at a specified x
value. df (degrees of freedom) must be > 0. The probability density function (pdf) is:

This distribution is useful in determining the probability of the occurrence of a value
when the population standard deviation is not known and the sample size is small. The
draw option is available when t Pdf is invoked from a formula cell.

t Cdf (tCdf)

Computes the Student-t distribution probability between Lower Bound and
Upper Bound for the specified df (degrees of freedom). You can click the Draw (Shade
area) check box to shade the area between the bounds. Changes to the initial
Lower Bound and Upper Bound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of a value
within an interval defined by the lower and upper bound for a normally distributed
population when the population standard deviation is not known.

Inverse t (invt)

Computes the inverse cumulative t-distribution probability function specified by
Degrees of Freedom, df, for a given area under the curve.

This distribution is useful in determining the probability of an occurrence of data in the
area from 0 to x<1. This function is used when the population mean and/or population
standard deviation is not known.
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c2 Pdf (c2 Pdf())

Computes the probability density function (pdf) for the c2 (chi-square) distribution at a
specified x value. df (degrees of freedom) must be an integer > 0. The probability
density function (pdf) is:

This distribution is useful in determining the probability of the occurrence of a given
value from a population with a c2 distribution. The draw option is available when c2

Pdf is invoked from a formula cell.

c2 Cdf (c2 Cdf())

Computes the c2 (chi-square) distribution probability between lowBound and
upBound for the specified df (degrees of freedom). You can click the Draw Shade area
check box to shade the area between the lower and upper bounds. Changes to the
initial lowBound and upBound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of value
within given boundaries of a population with a c2 distribution.

F Pdf (F Pdf())

Computes the probability density function (pdf) for the F distribution at a specified x
value. numerator df (degrees of freedom) and denominator dfmust be integers > 0.
The probability density function (pdf) is:

where n = numerator degrees of freedom
d = denominator degrees of freedom

This distribution is useful in determining the probability that two samples have the
same variance. The draw option is available when F Pdf is invoked from a formula cell.

F Cdf (F Cdf())

Computes the F distribution probability between lowBound and upBound for the
specified dfnumer (degrees of freedom) and dfDenom. You can click the Draw (Shade
area) check box to shade the area between the lower and upper bounds. Changes to
the initial lowBound and upBound automatically update the distribution.



This distribution is useful in determining the probability that a single observation falls
within the range between the lower bound and upper bound.

Binomial Pdf (binomPdf())

Computes a probability at x for the discrete binomial distribution with the specified
numtrials and probability of success (p) on each trial. The x parameter can be an
integer or a list of integers. 0{p{1 must be true. numtrialsmust be an integer > 0. If
you do not specify x, a list of probabilities from 0 to numtrials is returned. The
probability density function (pdf) is:

where n = numtrials

This distribution is useful in determining the probability of success in a success/failure
trial, at trial n. For example, you could use this distribution to predict the probability of
getting heads in a coin toss on the fifth toss.

Binomial Cdf (binomCdf())

Computes a cumulative probability for the discrete binomial distribution with n number
of trials and probability p of success on each trial.

This distribution is useful in determining the probability of a success on one trial before
all trials are completed. For example, if heads is a successful coin toss and you plan to
toss the coin 10 times, this distribution would predict the chance of obtaining heads at
least once in the 10 tosses.

Inverse Binomial (invBinom())

Given the number of trials (NumTrials) and the probability of success of each trial
(Prob), this function returns the minimum number of successes, k, such that the value,
k, is greater than or equal to the given cumulative probability (CumulativeProb).

This distribution is useful in determining the upper bound input of the binomial cdf. For
example, if you flip a coin 10 times, and you want the probability of getting x heads or
less to be greater than 75%, this distribution will help determine what x should be.

Inverse Binomial with respect to N (invBinomN())

Given the probability of success of each trial (Prob), and the number of successes
(NumSuccess), this function returns the minimum number of trials, N, such that the
value, N, is less than or equal to the given cumulative probability (CumulativeProb).
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This distribution is useful in determining the number of trials of the binomial cdf. For
example, if you flip a coin several times and you want the number of heads to be 6 or
less with a probability of less than 25%, this distribution will help determine how many
times to flip the coin.

Poisson Pdf (poissPdf())

Computes a probability at x for the discrete Poisson distribution with the specified
mean, μ, which must be a real number > 0. x can be an integer or a list of integers. The
probability density function (pdf) is:

This distribution is useful in determining the probability of obtaining a certain number
of successes before a trial begins. For example, you could use this calculation to predict
the number of heads that would occur in eight tosses of a coin.

Poisson Cdf (poissCdf())

Computes a cumulative probability for the discrete Poisson distribution with specified
mean, x.

This distribution is useful in determining the probability that a certain number of
successes occur between the upper and lower bounds of a trial. For example, you could
use this calculation to predict the number of heads displayed between coin toss No.3
and toss No.8.

Geometric Pdf (geomPdf())

Computes a probability at x, the number of the trial on which the first success occurs,
for the discrete geometric distribution with the specified probability of success p. 0{p
{1 must be true. x can be an integer or a list of integers. The probability density
function (pdf) is:

This distribution is useful in determining the likeliest number of trials before a success
is obtained. For example, you could use this calculation to predict the number of coin
tosses that would be made before a heads resulted.

Geometric Cdf (geomCdf())

Computes a cumulative geometric probability from lowBound to upBound with the
specified probability of success, p.



This distribution is useful in determining the probability associated with the first
success occurring during trials 1 through n. For example, you could use this calculation
to determine the probability that heads display on toss No.1, No.2, No.3, ..., No.n.

Working with Tables
You can change the table of plots values using the tools on the Tablemenu.

▶ To remove a column from the table, click any cell, and then tap Tools and go to
Table > Delete Column.

▶ To display the list of plots, tap the drop-down arrow on the top cell of a column.
Select an empty column, (unless you are replacing values already displayed), and
then tap a function in the list to add its values to the column.

▶ To change the expression that defines a plot, tap the formula cell and edit the
expression.

Manual Data Capture
You can use Lists & Spreadsheet application to capture information about objects in the
TI-Nspire™ Apps for iPad®. For example, you could track changes of the position of a
point on a graph in the Graphs & Geometry application.

The ability to capture data manually is not limited to Graphs & Geometry. This function
could work for any other application in the same problem.

Capturing Data Manually

1. Tap the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

Note: Captured values replace values in the column.

2. Tap Tools and go to Data > Data Capture > Manual.

A capture expression is inserted into the column formula cell with "var" as a
placeholder for the name of the variable you are capturing.
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3. Replace the letters “var” with the name of the variable to capture from
Graphs & Geometry. For example, type a or to view a list of available variables, tap
var on the TI-Nspire™ Keyboard.

The formula cell now contains an expression similar to =capture(a,0).



Note: The argument “0” tells Lists & Spreadsheet that you want to trigger each
capture manually.

4. Tap enter.

5. From the Graphs & Geometry application, move the point to a different location
where x coordinate of the point is stored in a variable (a, in this example)
referenced in the data capture expression.

6. Tap .

The current a value is stored in the Lists & Spreadsheet application configured to
capture the variable a.

See Using Variables for more information on adding and using variables.
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Data & Statistics Application
The Data & Statistics Application enables teachers and students to create graphical
displays and perform analysis on data stored in lists. Defining (or naming) sets of data
using the Lists & Spreadsheet Application is the starting point for plotting and analyzing
data.

What You Can Do

• Work with sets of data in different types of plots.

• Work with sets of data in different types of charts.

• Manipulate variables to explore and visualize data relationships.

• Explore central tendency and other statistical summary techniques.

• Fit functions to data.

• Create regression lines for scatter plots.

• Graph hypothesis tests and results (z- and t-tests) based on summary statistics
definitions or data.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Plotting Variables

• Lists created in Lists & Spreadsheet can be accessed as a variable.

• Variables must be named before they can be used in Data & Statistics.

• Tap the Add Variable field located in the centre of the x-axis or y-axis to choose a
defined variable name.

• The default plot for one variable is a dot chart. The data points in the default
caseplot reposition to represent the elements of the selected variable.

• The default plot for two variables is a scatter plot. The data points shift to represent
the elements of both variables on a scatter plot.



Rescaling the Axes

Pinch or spread either the horizontal or vertical axis to modify its scale.

– OR –

Drag either axis to shift the axis while retaining its scale.

To restore the original size and location of the plotted data, tap Tools > Window/Zoom
> Zoom-Data.

Plotting a Value

When you plot a value on an existing plot, it is displayed as a vertical line in the work
area. You can plot a single number or any expression that evaluates to a number. If the
value is dependent on the data, the line updates to reflect changes made when you
drag a point or make changes in the Lists & Spreadsheet application. The plotted value
must be in the domain of the axis.

To plot a value:

1. Tap Tools , go to Analyze, and then tap Plot Value.

2. Type the value you want to plot, and then tap enter.

Plotting a Function

Use Plot Function to graph a function for comparison to an existing plot. To plot a
function:

1. Create or open a problem that includes variables that are plotted in a Data
& Statistics work area. Ensure the work area contains both a horizontal axis and a
vertical axis.

2. Tap Tools , go to Analyse, and then tap Plot Function.

3. Type the function in the entry field and tap return.

Note: You can rename the function by typing over f1(x): with another name.

Adding a Data & Statistics Page
To get started with the Data & Statistics application, add a Data & Statistics page to an
existing document that contains a Lists & Spreadsheet page.

1. Tap Add, and then tap .

The Data & Statistics page shows the default case plot.
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2. Tap the add variable region on each axis to view defined variables.

3. Tap the variable name to add it to the selected axis to create a dot plot (frequency
plot).

Working with Plots

Dot Plots

• Dot plots are also known as frequency plots, and
represent one-variable numerical data.

• Dot plots are the default plot type for numerical
data.

• One dot represents each value in the list.

• Each dot is displayed on the axis at a point that
corresponds to the value.



Box Plots

• Box plots are used to plot one-variable numerical
data in a modified box.

• "Whiskers" extend from each end of the box.

• Box plots are used to compare two or more sets of
data that use the same scale.

Histograms

• A histogram plots one-variable numerical data and
depicts the distribution of data.

• The number of bins displayed depends on the
number of data points and how the points are
distributed.

• A value that occurs on the edge of a bin is counted
in the bin to its right.

Normal Probability Plots

Shows one set of numerical data against the corresponding
quartile (z) of the standard normal distribution.

Scatter Plots

• Shows the relationship between two sets of
numerical data.

• You also plot a scatter plot using the Quick Graph
tool in the Lists & Spreadsheet application.

X-Y Line Plots

• This plot is a type of scatter plot in which data
points are plotted and connected in order of
appearance in the two variables.

• An X-Y line plot depicts the relationship between
two sets of data.
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• The left-most column of data is represented on the
horizontal axis.

Exploring and Analyzing Plotted Data

• Drag a point to move it. As you move a point, the values associated with the point
change in the work area and in the list of variables.

• To change a variable on an axis, tap the Add Variable region, and then tap another
variable name.

• From the Tools menu:

- Tap Plot Type to select another supported plot type.

- Tap Plot Properties to clear all variables or to modify properties such as add and
remove X and Y variables, add a summary list or force a categorical X.

- Tap Actions to insert text or sliders. You can also select all points in the plot.

- Tap Analyse to choose analysis options such as add a moveable line, plot a
value or function, or activate the Graph Trace tool.

Working with Charts

Dot Charts

• The default plot type for categorical data is the dot
chart.

• When one variable is plotted, the value of each cell
is represented as one dot.

• The dots are stacked at the point on the axis that
corresponds to the cell value.

Bar Charts

• Bar charts display categorical data.

• The length of the bar represents the number of
cases in the category.



Pie Charts

A pie chart represents categorical data in a circular layout
and uses a proportioned segment for each category.

Exploring and Analyzing Data Plotted in a Chart

• Drag a point to move it. as you move a point, the values associated with it change
in the work area and in the list of variables.

• From the Tools menu:

- Tap Plot Type to choose another supported plot type.

- Tap Plot Properties to clear all variables, or to modify applicable properties such
as add and remove X and Y variables, add a summary list, and force a
categorical X.

- Tap Actions to insert text and sliders. You can also select all points in the plot.

- Tap Analyse to choose applicable analysis options such as adding a moveable
line, plotting a value or function, or activating the Graph Trace tool.

Adding Colour to Plots and Charts
1. Tap a plot or chart object to select it.

Note: To select all points in a plot, tap Tools > Actions > Select All Points.

2. Tap Inspector , and then tap Fill Color.

3. Tap a colour to select it.
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Notes Application
The Notes application enables you to create and share documents.

What You Can Do

• Create study notes to reinforce learning and review for exams.

• Share a Notes document with others and use text formatting options so that each
person's entries and comments appear in a different colour or font.

• Create and evaluate maths expressions.

• Create correctly formatted chemical formulas and equations.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Deactivating a Selected Expression or Box

Note: You can also activate and deactivate a selected expression or box by selecting
Tools > Actions > Activate (Deactivate) All.

1. Tap the expression or box you want to select, and then tap again.

2. Tap Select.

The selected text or item closest to the cursor is highlighted and the handles are
active.



3. Drag the handles to highlight the expression, maths box or chem box you want to
select.

4. Tap Tools and go to Actions.

5. Tap Deactivate Selection.

Activating a Selected Item

1. Tap the expression or box you want to select.

2. Tap Select.

3. Drag the handles to select the portion of the expression or text you want to
activate.

4. Tap Tools and go to Actions.

5. Tap Activate Selection.

Formatting Text in Notes

1. Tap the text you want to format, and than tap it again to open the context menu.

2. On the context menu, tap Select.

Drag the handles to select additional text, or tap Select All to select all of the text.

3. Tap Inspector .

Notes Application 119



120 Notes Application

4. Select the formatting you want to apply. Changes are applied as you select them.

Inserting Comments, Shapes and Calculations

Inserting Comments

You can insert Teacher or Review comments into a Notes page. Comments are labeled
to make them easy to distinguish from the original text.

1. Tap the Notes work area where you want to insert a comment.

2. Tap Tools and go to Insert.

3. Tap Comment.

4. Tap Teacher or Reviewer to choose the comment type.

5. Type the comment text inside the comment box.

The comment text appears in bold formatting.



6. If needed, select the text and tap Inspector to apply formatting to the comment
text.

Inserting Geometric Shape Symbols

Use geometric shapes to designate selected text as a geometric object such as an angle,
circle or line segment.

1. Tap the work area where you want to insert the shape, or select the text that you
want designate as a shape.

2. Tap Tools and go to Insert.

3. Tap Shape.

4. Tap the shape name (such as segment or ray) to insert it before the selected item.

Inserting Calculations

1. Tap the Notes work area to place your cursor where you want to insert the maths
expression.
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2. Tap Tools and go to Calculations.

3. Tap the type of calculation you want to insert, and then tap the function name to
insert the expression.

Working with Maths Boxes

Inserting a Maths Box

1. Tap the Notes work area to place your cursor where you want to insert the maths
box.

2. Tap Tools and go to Insert.

3. TapMaths Box. If you are using an external keyboard, press " + M.

4. Type the expression inside the maths box. You can also insert a function, command,
symbol or expression template by tapping Utilities to access Catalogue,
Symbols, Maths Operators and Libraries.

5. Tap enter to evaluate the expression.



Converting Selected Items to Maths Boxes

1. Select the text, or combination of text and existing maths boxes, that you want to
evaluate.

2. Tap Tools and go to Insert.

3. Tap Convert to Maths Box.

Inserting Chemical Equations
Use chemical equation boxes (chem boxes) to type chemical formulas and equations
such as:

CH4 + 2O2→ CO2 + 2H2O. Equations in a chem box cannot be evaluated or
balanced.

Entering a Chemical Equation

1. Position the cursor on the page where you want the equation.

2. Tap Tools and go to Insert.

3. Tap Chem Box.

An empty chemical equation box is added to the page.

4. Type the equation in the box. For example, to represent sulphuric acid, type
h2so4, capitalizing the O manually.

5. To exit the chem box, tap outside the box.
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Using Maths Actions 
Maths Actions are available on Notes and Calculator pages.

When you display the context menu for a selected expression or equation, the menu
may include aMaths Actions submenu that lists the available actions. Each action might
prompt you for any needed parameters.

The specific maths actions listed depend on:

• The type of expression or relation.

• The operating system in use (numeric or CAS).

Example of Maths Actions in Notes

1. Insert a maths box, and type the equation x2+3x+1=0, but don't press enter yet.

Numeric OS CAS OS

2. Tap the equation to display its context menu, and selectMaths Actions.

Numeric OS CAS OS

3. Select the action to perform:

- Solve Numerically for numeric OS.
- Solve for CAS OS.

You are prompted to enter parameters. For example, Numeric Solve prompts for
the variable of interest, initial guess, lower bound and upper bound.

4. Type a value for each parameter. When options are available, you can tap an arrow
to make a selection.



Numeric OS CAS OS

5. Tap OK to construct the completed expression and place it in the maths box.

Numeric OS CAS OS

6. Press enter to complete the action.

Numeric OS CAS OS

7. As a further exploration, select x2+3·x+1. Do not include the "=0" portion.

Numeric OS CAS OS

8. Display the context menu for the selected text, selectMaths Actions >
Find Roots of Polynomial, and press Enter to complete the action.

The action and its result are shown in a new maths box.

Numeric OS CAS OS

Tips for Using Maths Actions in Notes

▶ For a previously evaluated expression, tap the expression to display its context
menu.

When you select an action, it replaces the expression.

▶ For a displayed result, tap the result to display its context menu.

When you select an action, it appears in a new maths box.
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▶ For a portion of an expression or result, select the portion, and then display the
context menu.

When you select an action, it appears in a new maths box.

Graphing from Notes and Calculator 
You can graph a function or relation directly from its context menu. This feature is
available for many functions and relations on Notes and Calculator pages.

If page layout options allow, the graph appears on the same page as the function or
relation. Otherwise, the graph appears on a separate Graphs page.

The type of graph created depends on the type of function or relation.

Example of Graphing from Notes

This example uses a Notes page to explore a quadratic function interactively.

1. Insert a maths box on a new Notes page, and enter the following function
definition:

Define f1(x)=x2-1·x-4



2. Tap the expression to display its context menu.

3. Select Graph.

The graph appears. The graph and the maths box are linked so that any adjustment
to one affects the other.

4. Explore the relationship between the defined function and its graph:

- Drag the ends or centre of the graph to manipulate it, and observe the changes
to the function definition.

– OR –

- Edit the defined function in the maths box, and observe the changes to the
graph.
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Using a Displayed QR Code®
A QR Code® is an image that stores information, such as the address of a website or TI-
Nspire™ document, as a pattern of small squares.

Web address http://education.ti.com stored as a QR Code®.

Authors of TI-Nspire™ documents can insert or paste a QR Code® on any Notes page.
Users viewing the document with TI-Nspire™ App for iPad® can tell the app to scan the
code directly from the page and link to its associated target. Lua scripts can also display
a QR Code® that you can scan within the App.

Scanning a QR Code® on a Notes Page or Lua Script

Use this procedure to scan a displayed QR Code® and link to its target:

1. If necessary in Notes, scroll to ensure that only one code image is visible on your
screen.

Note: The image must be entirely visible; the software will scan only the displayed
region of the page.



2. Tap the Camera in the toolbar, and select Scan QR Code® from page.

- If the target is a TI-Nspire™ document (.tns file), the App automatically
downloads the document, saves and closes your current document, and opens
the downloaded document.

- Otherwise, the App opens your web browser to resolve the target.

How to Insert a QR Code® on a Notes Page

You can add QR Code® images to a Notes page. One image per page is best for reliable
scanning.

1. Generate the image, using an online code generator or a code-generator app. You
will need to supply the target URL.

2. Copy the generated image to the Clipboard, or save it as a photo.

3. Display your Notes page and use the method that applies for adding the image:

- If you copied the image to the Clipboard, press and hold the location on the
page, and select Paste.

- If you saved the image as a photo, position the text cursor on the page, tap the
Camera in the toolbar, and select Insert Photo.

The QR Code® appears on the Notes page with resizing handles.

Note: For optimal scanning, you should not resize or reshape the image.
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4. (Optional) add a tip for users of your document who might not know how to use
the code.

5. Make sure the code is valid by testing it with the Scan QR Code® from page feature.



Question Documents Overview
The TI-Nspire™ App for iPad® enables you to receive question documents sent by your
teacher via email. The question document may contain multiple pages and can contain
any TI-Nspire™ application. When you tap question, the icon changes to show you
which application is active.

What You Can Do

When you receive a question document from your teacher, you can:

• Open the document and answer the questions.

• Show your work if requested by the teacher.

• Check your answers if the teacher permits.

• Email the document with your responses back to the teacher.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know
Inserting Maths Boxes and Chem Boxes

You can insert a maths expression box or chemical equation box in any area of the
response that allows text. Use expression boxes to type properly formatted maths
expressions. Use chem boxes to type properly formatted chemical formulas or
equations.

To insert an expression or chem box:

1. Tap the answer area to place the cursor where you want to place the box.

2. Tap Tools , and then tap Insert.

3. Tap Expression Box to insert a maths expression box.

– OR –

Tap Chem Box to insert a chemical equation box.
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4. Type the expression in the box.

5. Tap enter to complete the expression.

Responding to Questions
Teachers may send you any of the following types of questions. Tap a question type
name to see how to respond to the question.

Note: You may need to scroll to see the entire question. All parts of the question may
not be visible on the page, and parts of a question may be hidden behind a graph or
image.

Multiple Choice Questions

• Tap the option or options next to
the response you want to select.

• Choices with next to them
indicate that there is only one
correct answer.

• Choices with next to them
indicate that there may be more
than one correct answer.

Open Response Questions

Type a response.



Equation Questions

Type a response.

If a graph is included in the
question, the graph updates
as you type the answer. Any
functions entered show up
on the graph, and the cursor
remains in the answer box.

You cannot manipulate the
graph.

Expression Questions

Type a response.

• If the teacher wants
you to show your work,
the response area has
sections for you to
enter the steps and a
final answer.

• If the response type is
Number, your response
must be in the form of
a number.

• If the response type is
Expression, your
response must be in
the form of an
expression, for
example: x + 1.
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Coordinate Points: (x,y) Questions

Type an answer in the x-field
box, and then type an
answer in the y-field box.

As you enter values, the
points update on the graph
work area.

Coordinate Points: Drop Points Questions

• Tap a location on the
graph work area to
drop a point at that
location.

• To move a point, touch
and hold the point, and
drag it to the new
location.

Lists Questions

Type an answer in the
desired cell. Continue to
type answers in different
cells until you are finished.

The behaviour closely
matches the behaviour of
the Lists & Spreadsheet
application, with the
following exceptions. In a
Lists question, you cannot:



• Add, insert, or delete
columns

• Change the header row

• Enter formulas

• Switch to Table

• Create plots

Chemistry Questions

Type a response.

There is no need to insert a
Chem box. Chemistry
response areas are
automatically formatted to
accept properly formatted
chemical formulas or
equations.

Image: Label Questions

1. Tap a label on the
image.

2. Type a response in the
label field.
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Image: Point on Questions

Tap the option or options
next to the answer you want
to select.

Showing Your Work, Checking Answers, and Clearing Answers

Showing Your Work

The teacher may ask you to show work for your response. If so, the teacher provides
the starting equation, and the response area has sections for entering your steps and
for the final answer.



Checking Answers

If the teacher enables self-check on a question, the Check Answer option becomes
available after you answer the question. To check your answer:

▶ Tap Tools and go to Check Answer.

• If your answer is correct, a confirmation message is displayed. When you close the
message:

- A check mark is displayed next to the answer for multiple-choice questions.

- The correct answer or suggested answer is displayed below the student
response for all other question types.

• If your answer is incorrect, tap Try Again or Show Correct Answer.

Clearing Answers

After you answer a question, you may decide you want to change the answer before
you submit it.

1. Tap Tools .

2. Tap Clear Answers.

• Current Question clears answers for the active question.

• Document clears answers for all questions in the active document.

Submitting Responses
When you finish answering all the questions in the document, save the document and
send it back to the teacher.

1. From the open question document, tap Share .

2. Tap Email Document.

Your default email client opens with the document as an attachment.

3. Type the email address and tap Send.
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Widgets
All work that you create and save using TI-Nspire™ applications is stored as a
document, which you can share with others using TI-Nspire™ software and with those
using handhelds. You save these TI-Nspire™ documents as .tns files.

A Widget is a .tns document that is stored in your MyWidgets folder.

You can use Widgets to:

• Easily access text files

• Insert and run scripts (such as Stopwatch)

• Quickly insert a saved problem into a document

When you add a Widget, TI-Inspire™ CX extracts only the first page of the selected .tns
file, and inserts it into your open document.

Creating a Widget
A document is regarded as a Widget when it is saved or copied to the designated
MyWidgets folder.

If the folder has been inadvertently deleted, you must create it before attempting to
use a Widget.

Note:When you add a Widget, TI-Nspire™ App for iPad® extracts only the first page of
the selected .tns file, and inserts it into your open document.

Showing the MyWidgets folder

To show the MyWidgets folder on the TI-Nspire™ App for iPad® homepage:

1. Tap Settings Icon.

2. Swipe toggle switch to the right to turn on Show MyLib & MyWidgets folders.

Adding a Widget to a Document
1. Open a document.

2. Tap Add > Widget.

Note: You will see a submenu showing a list of preloaded layouts and widgets. The
Stopwatch Widget and Widget layouts are preloaded. Any .tns file saved to your
MyWidgets folder will show up in this list.

3. Tap on the Widget you wish to add to your document.

Saving a Widget
When you save a .tns document, it will appear on the TI-Nspire™ App for iPad®
homepage. To add this as a Widget:

▶ Tap and drag the document into your MyWidgets folder.



Libraries Overview
A library is a TI-Nspire™ document that contains a collection of variables, functions
and/or programs that have been defined as library objects.

What You Can Do

• Create library documents for storing user-defined variables, functions or programs.

• Use defined library objects in any TI-Nspire™ document.

• Add library objects to the Catalogue.

• Update or refresh libraries so that objects are available to all documents.

• Create shortcuts to library objects.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know
• Library documents are stored in theMyLib folder, which is located on the TI-

Nspire™ Home screen.

• By default, the MyLib folder is shown on the TI-Nspire™ Home screen when you
install the application. To hide the folder, tap Settings > Preferences, and then
select OFF.

• The TI-Nspire™ App installation includes a library document that contains Linear
Algebraic functions. The library is named linalg or linalgcas.

• If you delete or overwrite an installed library, you can restore it by reinstalling the
TI-Nspire™ App.

• Reinstalling the TI-Nspire™ App replaces all libraries in the defaultMyLib folder. If
you change an object in an included library or replace an included library document
with your own document of the same name, reinstalling overwrites your changes.

• Library objects are global in nature and accessible from any TI-Nspire™ document.

• Library objects can be public or private. If designated as public, the library object is
accessible via Utilities > Libraries.

• You can use the libshortcut() command to define shortcuts to library objects.
Defining a shortcut creates a variable group in the current problem that contains
references to all the objects in the specified library document. You can choose to
include or exclude private library objects.
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Creating Library Documents
A document is regarded as a library when it is placed in the MyLib folder on the TI-
Nspire™ Home screen.

1. Open a new TI-Nspire™ document and choose the Calculator application.
2. Name the document.

• Library document names must be a valid variable name, and they must not
contain a period or begin with an underscore.

• A library document name must be between 1 and 16 characters long.

3. Drag the document to theMyLib folder.

4. Add library functions or programs to the document as needed.

Adding Objects to a Library Document
You can define functions or programs in the Program Editor, or by using the Define
command in Calculator to define variables, functions, or programs. Library objects must
reside in the first problem of a library document.

Defining a Function or Program Using Program Editor

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor > New.

3. Type the name of the library object.

• Library object names must be a valid variable name, and they must not contain
a period or begin with an underscore.

• A library object name must be between 1 and 15 characters long.

4. Select the type: function or program.

5. Set the library access.

• Tap LibPriv to make the function or program accessible from any
document but not visible in the Catalogue.

• Tap LibPub (Show in Catalogue) to make the function or program
accessible from any document and visible in the Catalogue.

6. Tap OK.

7. Type the information needed to complete the function or program in the template.

8. Store the library object.



a) In Program Editor, tap Tools > Check Syntax & Store.

b) Tap Check Syntax & Store.

If no errors are present, the new library object is successfully stored.

9. Refresh the libraries to include the new library object in the Libraries menu.

Defining a Library Object in the Calculator Application

1. From an open Calculator document, tap Tools and go to Actions.

2. Tap Library.

3. Select Define LibPriv or Define LibPub.

4. Type the information needed to complete the function or program in the template.

5. Refresh the libraries to include the new library object in the Libraries menu.

Private and Public Library Objects
When defining a new library object, you choose whether if is private (LibPriv) or public
(LibPub). Anytime you are in the same problem where an object is defined, you can
access it by entering its short name (the name given when using the Define command
to create an object). This is true for all defined objects, including private, public and
non-library objects. For example:

Define Command Object Type Short Name

Define a=5 Non-library a
Define LibPriv b=(1,2,3) Private Library b
Define LibPub func1 (x)=x^2 + 1 Public Library func1

Private Library Objects

A Private library object does not appear in the Utilities, but you can access it by typing
its name. Typically, private library objects are used as building blocks that perform
basic, low-level tasks and are called upon by public programs or functions.

Public Library Objects

A Public library object appears in Utilities > Libraries after you refresh the libraries. You
can access a public library object through the Utilities menu or by typing its name.

Libraries Overview 141



142 Libraries Overview

In library programs and functions defined as public, a comment line (©) immediately
following the Prgm or Func line is automatically displayed as help in the Catalogue. You
could, for example, show a syntax reminder there.

▶ To enter a comment line, tap Tools and go to Actions > Insert Comment.

Accessing Library Objects
To use a library object in any TI-Nspire™ document, type the object's long name. The
long name consists of the name of the object library document followed by a backslash
"\" followed by the name of the object. For example, if the library document name is
"lib1" and the object name is "func1," type lib1\func1.

Using a Public Library Object

1. Open the TI-Nspire™ application where you want to use the variable, function, or
program.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

2. Tap Utilities and go to Libraries.

3. Tap the name of the object you want to use.

Note: If you do not see the object, refresh the libraries.

4. If arguments are required, type them inside the parentheses.

5. Tap return to insert the object into the document.

Using a Private Library Object

1. Open the TI-Nspire™ application where you want to use the variable, function, or
program.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

2. Type the name of the object, such as lib1\func1 ().

In the case of a function or program, always follow the name with parentheses.

3. If arguments are required, type them inside the parentheses.

4. Tap return to insert the object into the document.



Viewing Arguments

If you cannot remember the exact name or the order of arguments required for a
private library object, you can:

▶ Open the library document that contains the object to view the arguments and
other information.

– OR –

▶ Type getVarInfo [library name string] in any open document to view a list defined
variables in an object.

– OR –

▶ Access the arguments and help through the Utilities menu.

a) Tap Utilities > Libraries.

b) Tap the name of the library you want to open.

c) Tap the name of the function you want to view.

Refreshing Libraries
When you create new library objects, you must refresh the libraries so that the objects
are available to all documents.

1. Tap Utilities .

2. Tap Libraries.

3. Tap Refresh .

The Libraries are updated to include all new and edited library objects.
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Program Editor Overview
The Program Editor enables you to define, edit and manage user-defined functions and
programs.

What You Can Do

• Use programming templates and dialogue boxes to define function and programs
with the correct syntax.

• Enter multiple-line programming statements without using a special key sequence
to add each line.

• Create private and public library objects such as variables, functions and programs.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know
A program defined in the Program Editor is similar to functions built into the TI-Nspire™
software, but there are some differences:

• Functions must return a result, which can be graphed or entered in a table.
Programs do not return a result.

• You can use a function, but not a program, within an expression. For example, 3 x
func1(3) is valid, but not 3 x prog1(3).

• You can only run programs from the Calculator and Notes applications. You can
evaluate functions in Calculator, Notes, Lists & Spreadsheet, Graphs, Geometry,
and Data & Statistics.

• A function can refer to any variable; however, it can store a value to a local variable
only. Programs can store to local and global variables.

Note: Arguments used to pass values to a function are automatically treated as
local variables. If you want to store to any other variables, you must define them as
Local from within the function.

• A function cannot call a program as a subroutine, but it can call another user-
defined function.

• You cannot define a program within a function.

• A function cannot define a global function, but it can define a local function.



Accessing the Program Editor
Program Editor is accessible from the Calculator application.

1. Open a document with the Calculator application active.

2. Tap Tools and go to Functions and Programs.

3. Tap Program Editor.

Options enable you to define a new program, open an existing program, or import
a program from the Library.

4. Tap an option, complete the required information, and then tap OK.

The Program Editor opens with the selected template active on the right side of the
screen.

Calculator work area. Tap the left side of the screen to return to and
work in the Calculator application.

Program Editor work area. This is the default work area when Program
Editor opens. If the Program Editor is not active, tap the right side of
the screen.

Status line. Shows the line number information and the name of the
function or program being defined or edited. An asterisk (*) indicates
that this function has been changed since the last time syntax was
checked and the function was stored.

Defining a New Program or Function
From the Calculator application:

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor, and then tap New.
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3. Type a name for the new function or program.

Note: Program and function names cannot contain spaces.

4. Select the Type (Program or Function).

5. Set the Library Access:

• Choose the default None to use the function or program only in the current
document or problem.

• Tap LibPriv to make the function or program accessible from any document
but not visible in the Catalog.

• Tap LibPub (Show in Catalog) to make the function or program accessible
from any document and visible in the Catalog.

6. Tap OK.

The Program Editor opens with a template matching the selections you made.

Entering Lines into a Function or Program
The Program Editor does not execute the commands or evaluate expressions as you
type them. They are executed only when you evaluate the function or run the program.

• When arguments are required, type parameters in the parentheses that follow the
program name. Separate parameters with a comma.

• Type the lines of statements that make up your function or program between the
Func and EndFunc (or Prgm or EndPrgm) lines.



• You can either type the names of the function and commands, or insert them from
the Catalogue.

• If a line is longer than the width of the screen, scroll to view the entire statement.

• After typing each line, tap return to insert a new blank line.

• Tap the right, left, up, and down arrows to scroll through the function or program.

Checking Syntax
To check the function or program for correct syntax:

1. Make sure the Program Editor is active.

2. Tap Tools and go to Check Syntax and Store.

3. Tap Check Syntax.

If the syntax checker finds any errors, it displays an error message and positions the
cursor near the first error.

Storing a Function or Program
You must store a function or program to make it accessible. The Program Editor
automatically checks the syntax before storing. An asterisk (*) before the program or
function name indicates that it has not been stored. To store a function or program:

1. From the Program Editor, tap Tools and go to Check Syntax and Store.
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2. Tap Check Syntax & Store.

Program Editor checks for syntax errors and stores the program.

• If no syntax errors are found, the message "stored successfully" is displayed in
the status line after the program or function name.

• If syntax errors are found, an error message is displayed and the cursor is
positioned near the first error.

• If the function or program is defined as a library object, you must also save the
document in the designated library folder and refresh libraries to make the
function or program accessible to other documents.

Running Programmes and Evaluating Functions
After defining and storing a programme or function, you can use it from an application.
All the applications can evaluate functions, but only the Calculator and Notes
applications can run programmes.

The programme statements are executed in sequential order (although some
commands alter the program flow). The output, if any, is displayed in the application’s
work area.

• Programme execution continues until it reaches the last statement or a Stop
command.

• Function execution continues until it reaches a Return command.

Running a Programme or Function from the Programme Editor

1. Make sure you have defined a programme or function and the Programme Editor is
the active work area.

2. Tap Tools and select Check Syntax & Store > Run.

This will automatically:



• check the syntax and store the programme or function,
• paste the programme or function name on the first available line of the

Calculator page.

3. If the programme or function requires you to supply one or more arguments, type
the values or variable names inside the parentheses.

4. Tap enter.

Note: You can also run a programme or function in Calculator or Notes applications by
typing the name of the programme with parentheses and any required arguments and
tapping enter.

Opening Functions or Programs for Editing
Note: You cannot modify a locked program or function. To unlock the object, go to a
Calculator page and use the Unlock command.

Opening a Function or Program in Calculator

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor, and then tap Open.

The list of defined functions and programs available to the current problem opens.

3. Tap the function or program name to open it in Program Editor.
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Opening a Function or Program in Program Editor

1. Tap Tools and go to Actions.

2. Tap Open.

3. Tap the function or program name to open it in Program Editor.

Note: To close the function or program, tap Tools > Actions > Close. The program or
function closes and the Calculator page becomes active.

Importing Programs
You can import a function or program defined as a library object into a Program Editor
within the current problem. The imported copy is not locked, even if the original is
locked.

Importing a Program from a Library

1. From the Program Editor, tap Tools and go to Actions.

2. Tap Import.

3. In the Library field, tap , and then tap the library name you want to import.

4. In the Name field, tap , and then select the name of the object.

5. If you want the imported object to have a different name, type the name in the
Import As field.

6. Tap OK.

Importing a Program from Calculator

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor, and then tap Import.

3. In the Library field, tap , and then tap the library name you want to import.



4. In the Name field, tap , and then select the name of the object.

5. If you want the imported object to have a different name, type the name in the
Import As field.

6. Tap OK.

The program opens in Program Editor.
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Using Test Mode
The guidelines for many international, national, and state assessments allow or require
students to use TI-Nspire™ App for iPad® when taking an exam. Test Mode enables you
to quickly prepare the software for exams where use of applications, programmes, and
other files is restricted.

Test Mode can be configured by tapping the Lock icon and using either the Choose
Test Mode Restrictions or Enter Test Code option. When the software is in Test Mode,
students cannot access pre-existing folders or documents. After the exam, these
documents and features can be easily restored for classroom use.

Note: To find out if your state allows TI-Nspire™ technology, see the State/Province
Information website at education.ti.com/go/testprep.

Preparing the iPad® for Test Mode
Before entering Test Mode, make sure that TI-Nspire™ has access to Photos and
Bluetooth.

• Photos = All Photos or Selected Photos

• Bluetooth = On

You must then change the following settings on the iPad®:

• Aeroplane Mode = On

• Wi-Fi = Off

• Bluetooth = Off

To enable Aeroplane Mode while in the App:

1. Swipe down from the top-right corner of the iPad® screen to open the Control
Centre.

2. Tap the Aeroplane Mode icon.

https://education.ti.com/go/testprep


The Aeroplane Mode, AirDrop, Wi-Fi, and Bluetooth icons will change to indicate
that they have been disabled.

Aeroplane Mode can also be enabled from the iPad settings.

To enable Aeroplane Mode in the iPad® Settings:

1. On the iPad® Home screen, tap Settings .

2. Go to Aeroplane Mode and tap the toggle switch .

The switch will turn green and the Wi-Fi and Bluetooth options will change to 'Off'.

In order to save the Test Mode Summary at the end of the test session, the App will
need to access your photos.

To validate or change the access to your photos:

1. On the iPad® Home screen, tap Settings .

2. Go to TI-Nspire > Photos or TI-Nspire CAS > Photos.

3. Tap All Photos or Selected Photos if it is not already selected.
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More Information

If you tap Test Mode before turning Aeroplane Mode on or allowing access to your
photos, you will be prompted to make the necessary changes before entering Test
Mode.

Entering Test Mode by Choosing Restrictions
Note: This applies to the TI-Nspire™ App for iPad® and the TI-Nspire™ CAS App for
iPad® except where noted. If you already have a test code, you can use the Enter Test
Code method.

1. Tap Test Mode and then Choose Test Mode Restrictions.

This will open the Test Mode Restrictions dialogue box.

2. Select the Default Angle you wish to use. Available units are Degree and Radian.

3. Select the CAS Mode you wish to use. (TI-Nspire™ CAS App for iPad® only)

• On enables CAS functions and symbol manipulation.
• Exact Arithmetic enables exact results in terms of stacked fractions, p, and

radicals ‡.
• Off disables CAS and exact results.

4. Tap the toggle switch to enable or disable each restriction as needed.

The Test Code will automatically update based on your selections.

Note: For a detailed list of restrictions, refer to Understanding Test Mode
Restrictions.

5. Tap Next.

6. On the Confirm App Self-Lock prompt, tap Yes.



• Pre-existing clipboard data is deleted.
• A green title bar indicates that the software is in Test Mode. It displays the Exit

icon, Undo/Redo icons, Clear Document icon, the CAS or Exact Arithmetic mode
status (when appropriate), Test Code, time elapsed while in the test session,
the Test Mode Information icon, and the Settings icon.

Entering Test Mode with a Test Code
Note: This applies to the TI-Nspire™ App for iPad® and the TI-Nspire™ CAS App for
iPad® except where noted. If you do not know the test code, you can obtain it by using
the Choose Restrictions method.

1. Tap Test Mode and then Enter Test Code.

This will open the Test Mode dialogue box with the TI Factory Default Code 0001-
6382 entered by default.
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2. Enter your eight-digit test code.

If the code is valid, a green tickmark will display.

When the code is validated, it is stored and will be displayed when the Enter Test
code dialogue is invoked again.

The same test codes are used for both the TI-Nspire™ App for iPad® and the TI-
Nspire™ CAS App for iPad®, as well as TI-Nspire™ CX II handhelds and desktop
software. The CAS and Exact Arithmetic Mode settings are ignored when
appropriate.

3. Tap Next.

The Summary screen displays so you can review the restrictions. Tap Back if you
need to enter a different code.

4. Tap Next.

5. On the Confirm App Self-Lock prompt, tap Yes.



• Pre-existing clipboard data is deleted.
• A green title bar indicates that the software is in Test Mode. It displays the Exit

icon, Undo/Redo icons, Clear Document icon, the CAS or Exact Arithmetic mode
status (when appropriate), Test Code, time elapsed while in the test session,
the Test Mode Information icon, and the Settings icon.

Test Code Examples

TI Factory Default Restrictions

• Default Angle = Degree

• CAS Mode = Off

• Numerical Solver and Sliders are enabled
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Minimum Restrictions

• Default Angle = Degree

• CAS Mode = On

• All restrictions off

Maximum Restrictions

• Default Angle = Degree

• CAS Mode = Off

• All restrictions on



Note:Maximum restrictions Test Code will change if additional restrictions are added in
the future.

Reviewing Test Mode Restrictions
You can review the restrictions in effect when the app is in Test Mode. You cannot
change the restrictions while in the testing session. You must exit Test Mode and re-
enter it with new restrictions.

To review the current restrictions:

1. Tap the information icon in the Test Mode bar.

The Test Mode Information dialogue opens which displays the following:

• Press-to-Test code
• Session ID
• Time in Test Mode
• Default Angle
• CAS Mode
• TI-Nspire™ App for iPad® version
• Restrictions
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2. Tap Done to return to the current test session.

Working with a Document in Test Mode
While in Test Mode, you will only see a default document created during the test
session. You cannot open documents that were created before entering Test Mode.

Creating a New Document

1. Tap New in the toolbar.

2. Select an application to add to the document.

Based on the restrictions that were enabled manually, or set by a test code:

• the restricted functionality is disabled,

• the appropriate menu items are removed,



• an error message is displayed when you try to execute restricted functions by
typing them or pasting from the Catalogue.

Exiting Test Mode
When you exit Test Mode, the temporary document created during the session is
deleted and TI-Nspire™ document settings are restored to their state before you
entered Test Mode.

To exit Test Mode:

1. Tap the < Exit button on the Test Mode title bar.

2. On the Exit Test Mode prompt, tap Yes.

The Test Mode Summary dialogue opens which displays the following:

• Press-to-Test code
• Date
• Time in Test Mode
• Start Time and End Time
• Session ID
• App Version
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3. Tap Done.

The Test Mode Summary dialogue will be saved to your iPad® Photos album.

Understanding Test Mode Restrictions
By default, all restrictions are disabled when you enter a Test Mode session with the
exception of Numerical Solver and Sliders.

• Enabling a restriction allows its associated features to be used during the session.

• Disabling a restriction disables or limits its associated features during the session.

Restricting Geometry Functions

When you choose to limit geometry functions, all items on theMeasurement,
Construction and Transformationmenus are disabled.



Disabling Function and Conic Grab and Move, and Change of Equation Form

• You cannot move any function or conic in Graphs or Geometry. For example, if you
have graphed y=x3, you can select the function but you cannot move or
manipulate it by dragging.

• You cannot access the attribute that toggles the displayed form of a second degree
polynomial relation between Standard and Expanded.

• Disabling function and conic grab and move does not apply to lines and functions in
Data & Statistics.

• Disabling function grab and move does not restrict sliders in the Graphs and
Geometry applications.

• You can still grab the coordinate plane and move it around.

Disabling Vector Functions

When vector functions are disabled, students cannot calculate the following functions:

• Unit vector [unitV(]

• Cross product [crossP(]

• Dot product [dotP(]

• Eigenvector [eigVc(]

• Eigenvalue [eigVl(]

Disabling the “isPrime” Function

The isPrime( function determines if a number is a prime number (a whole number
greater than two that is evenly divisible only by itself and one). Disabling this function
prevents students from selecting the isPrime( command in the Catalogue and from
selecting Test > IsPrime in Maths Operators. If a student manually enters the isPrime(
function, submitting the expression results in an error message.

Disabling Differential Equation Functionality

The Differential Equation graph type is disabled in the Graphs and Geometry
applications. Users cannot manually type and graph a differential equation.

Related maths functions rk23(, euler(, and deSolve( are also disabled.
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Disabling Inequality Graphing

When inequality graphing is disabled, students cannot graph inequalities with <, >, ≤,
and ≥ or grab and drag inequalities to a graph in the Graphs and Geometry
applications.

Disabling 3D Graphing

When this feature is disabled, students cannot use the 3D Graphing view.

Disabling Implicit Graphing, Conic Templates, Conic Analysis, and Geometric Conics

When these features are disabled, students cannot graph equations in terms of
x = ay + c or ax + by = c. Conic templates are not available, and students cannot
analyse conics or graph the geometric conic of an ellipse, parabola, hyperbola or conic
by five points.

Disabling Trigonometric Functions

Disabling trigonometric functions prevents students from using the following functions
in calculations and graphing.

csc sec cot

csc-1, arccsc sec-1, arcsec cot-1, arccot

csch sech coth

csch-1, arccsch sech-1, arcsech coth-1, arccoth

• Attempting to evaluate any of these functions results in an error message.

• Students cannot select the disabled functions from the Catalog.

Disabling the logbx Template and Summation Functions

Students cannot use the logbx (convert to logbase) and log(a, b) commands and
templates, including logbx templates.

• Only calculations in log10 format are accepted.

• If a student manually enters log(a,b) or >logbase( into an expression, attempting to
evaluate the expression results in an error message.

• Students are allowed to enter log(a), log(a,10) and log(a,10.).



Students are also prevented from using summation functions and templates. The ∑(
and sumSeq( functions are disabled.

Disabling Polynomial Root Finder and Simultaneous Equation Solver

The polyRoots(, cPolyRoots(, solve(, simult(, zeros(, and cZeros( functions are disabled.
Attempting to evaluate any of these functions results in an error message.

Note:When the polynomial tools are disabled, students cannot use Find Roots of
Polynomial, Real Roots of Polynomial or Complex Roots of Polynomial.

The linSolve( and simult( functions are disabled in menus and in the Catalogue.
Attempting to evaluate either of these functions results in an error message.

Disabling Numerical Solver

The nSolve( is disabled in menus and in the Catalogue. Attempting to evaluate either of
these functions results in an error message.

Disabling Sliders

When this feature is disabled, students cannot insert or create sliders in the Graphs,
Geometry, Data & Statistics, and Notes applications.
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General Information
Online Help
education.ti.com/eguide

Select your country for more product information.

Contact TI Support
education.ti.com/ti-cares

Select your country for technical and other support resources.

Service and Warranty Information
education.ti.com/warranty

Select your country for information about the length and terms of the warranty or
about product service.

Limited Warranty. This warranty does not affect your statutory rights.

Texas Instruments Incorporated

12500 TI Blvd.

Dallas, TX 75243

https://education.ti.com/eguide
https://education.ti.com/ti-cares
https://education.ti.com/warranty
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