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Getting Started with TI-Nspire™ CX Student Software
TI-Nspire™ CX Student Software enables students to use PC and Mac® computers to
perform the same functions as on a handheld. This document covers:

• TI-Nspire™ CX Student Software

• TI-Nspire™ CX CAS Student Software

Note:When there are differences between the software, those differences are
described.

Selecting the Handheld Type
When you launch the software for the first time, you will see the Handheld Type
selection dialog box:

Click the image of the handheld type you want to use then click Next to apply that
selection and open the software.

To change the handheld type after the first launch:

1. Click File > Settings > Handheld Type and select the type you want.

The Handheld Type confirmation dialog box opens.

2. Click Cancel to continue your work.

—or—
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2 Getting Started with TI-Nspire™ CX Student Software

Click Quit Now to close the software immediately. You will be prompted to save any
open documents. When you restart the software, the new handheld type will be
applied.

Exploring the Documents Workspace
Use the menu options and toolbar options in the workspace to create or edit TI-
Nspire™ documents and work with applications and problems. The tools in the
workspace are specific to working with open documents.

Note: Although not labeled, the Documents Workspace is the default workspace in the
TI-Nspire™ CX Student Software. Throughout the documentation and help, the area
where you work with documents is referred to as the Documents Workspace.

À Toolbar. Contains short-cuts to frequently performed tasks such as creating new
documents, opening existing documents, saving documents, inserting applications,
inserting variables and taking screen captures. The cut, copy and paste icons are also
located in the toolbar. At the right side, a Document Preview button lets you select
Handheld or Computer preview.

Á Documents Toolbox. Contains tools needed to work with TI-Nspire™ documents. Use
these tools to open the application menus, use the page sorter to view TI-Nspire™
documents, open the TI-SmartView™ emulator, open Content Explorer, insert utilities
such as maths templates and the symbols from the catalogue.

Â Toolbox pane. Options for the selected tool are displayed in this area. For example,
click the Document Tools icon to access tools needed to work with the active
application.

Ã Work area. Shows the current page of the active (selected) document. Lets you
perform calculations, add applications and add problems and pages. Only one



document at a time is active. Multiple documents appear as tabs.

Ä Status bar. Provides information about the active document.

Understanding the Status Bar

The status bar provides information about the current document, and provides options
that enable you to toggle between Handheld and Computer view and adjust how the
document appears in the work area.

À Page Size. Shows the document's page size as Handheld or Computer. You can
use the TI-Nspire™ Filemenu to convert a document from one page size to the
other.

Á Problem/Page counter. The first value represents the problem number of the
active page, and the second value tells you the page number within the
problem. In the example, the counter reads 1.2, indicating Problem 1, Page 2.

Â Settings. Double-click to view or change the Document Settings for the active
document or to change the default Document Settings.

Ã Mode. Shows the angle mode (RAD, DEG, GRAD) for the current page of the
document, or for the active Math Box in a Notes application.

Ä Zoom. Enabled in Handheld preview only (click Document Preview on the toolbar
and select Handheld). Click▼ and select a magnification value for the preview.

Å Boldness. Enabled in Computer preview only (click Document Preview on the
toolbar and select Computer). Click▼ and select a value to increase or decrease
the boldness of text and other items.

Changing Language
Use this option to select a preferred language. You must restart the software for the
language to take effect.

1. Click File > Settings > Change Language.

The Choose a Language dialogue box opens.

Getting Started with TI-Nspire™ CX Student Software 3



4 Getting Started with TI-Nspire™ CX Student Software

2. Click¤ to open the Choose language drop-down list.

3. Select the desired language.

4. Click Quit Now to close the software immediately. You will be prompted to save any
open documents. When you restart the software, the language change is effective.

—or—

Click Quit Later to continue your work. The language change is not applied until you
close and restart the software at a later time.

Using Software Menu Shortcuts
Use the following software menu shortcuts to perform common functions.

Note:Mac® users should substitute “ (Cmd) anywhere Ctrl is used.

Getting Help

Help F1

Online Help F2

Editing Text

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V

Undo Ctrl+Z
Ctrl+Esc

Redo Ctrl+Y
Shift+Esc

Toggle approximate and exact results

Python Editor and Shell: Add a new line after the
current line.

Ctrl+Enter

Inserting Characters and Symbols in a document

Manual data capture point Ctrl+.

Equals symbol =

Insert variable Ctrl+L



Managing Documents

Display Document Tools menu Ctrl+Shift+M

Open document Ctrl+O

Close document Ctrl+W

Create new document Ctrl+N

Insert new page Ctrl+I

Select application Ctrl+K

Save current document Ctrl+S

Navigation

Top of page

Python Editor and Shell:Moves cursor to the beginning
of the first line in the program.

Ctrl+7

End of page

Python Editor and Shell:Moves cursor to the end of the
last line in the program.

Ctrl+1

Page Up Ctrl+9

Page Down Ctrl+3

Up a level in the hierarchy Ctrl+£

Down a level in the hierarchy Ctrl+¤

Extends selection in direction of arrow Shift+Any arrow

Python Editor and Shell: Indents text on the current
line or selected lines or navigates between inline
prompts

Tab

Navigating in Documents

Displays previous page Ctrl+¡

Displays next page Ctrl+¢
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6 Getting Started with TI-Nspire™ CX Student Software

Displays Page Sorter Ctrl+£

Exits Page Sorter Ctrl+6

Moves focus backward within page

Python Editor and Shell: Dedents text on the current
line or selected lines or navigates backwards between
inline prompts

Shift+Tab

Wizards and Templates

Add a column to a matrix after the current column Shift+Enter

Add a row to a matrix after the current row

Python Editor and Shell: Add a new line after the
current line.

Enter

Application-Specific Shortcuts

Notes/Program Editor/Python Editor: Select all

Press-to-Test: Select all items in the dialog

Ctrl+A

Program Editor/Python Editor: Check syntax and store Ctrl+B

Program Editor/Python Editor: Find Ctrl+F

Geometry/Graph: Hide/Show Entry Line

Lists & Spreadsheet/Program Editor/Python Editor: Go
To

Ctrl+G

Program Editor/Python Editor: Find and Replace Ctrl+H

Calculator/Program Editor/Python Editor and Shell:
Beginning of line

Ctrl+8

Calculator/Program Editor/Python Editor and Shell: End
of line

Ctrl+2

Notes: Insert math expression box Ctrl+M

Notes: Insert chemical equation box Ctrl+E

Lists & Spreadsheet: Recalculate Ctrl+R



Program Editor: Check syntax, store program and paste
program name in Calculator (after clearing current line
in Calculator)

Python Editor: Check syntax, save program and execute
in Python Shell

Python Shell: Rerun last program

Geometry/Graphs/Lists & Spreadsheet: Add Function
Table

Program Editor/Python Editor and Shell: Add/remove
comment symbol

Ctrl+T

Group/Ungroup applications on a page Ctrl+4 / Ctrl+6

Miscellaneous

Handheld Preview Alt+Shift+H

Computer Preview Alt+Shift+C

Transfer Tool (Teacher Software only) Ctrl+Shift+T

Quick Poll (Teacher Software only) Ctrl+Alt+Q

Capture Class (Teacher Software only) Ctrl+Shift+R

Capture Page Ctrl+J

Rename (Content Workspace only) F2

Print Ctrl+P

Exit Software Alt+F4

Using Handheld Keyboard Shortcuts
Use the following handheld emulator keyboard shortcuts to perform common
functions.

Getting Help

Open Hints /µ
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8 Getting Started with TI-Nspire™ CX Student Software

Editing Text

Cut /X

Copy /C

Paste /V

Undo /Z

/d

Redo /Y

gd

Toggle approximate and exact results

Python Editor and Shell: Add a new line after the
current line.

/·

English: Change key to include appropriate accent
Chinese: Insert character

;

Inserting Characters and Symbols in a document

Display character/symbol palette /k

Underscore /_

Display math template palette t

Backslash ( \ ) gp

Manual data capture point /^

Clear /.

Caps Lock /g

Store /h

Square brackets /(



Curly brackets /)

Display Trig symbol palette µ

Equals symbol =

Display pi symbols palette
(p, à, q, and so on)

¹

Display equality/inequality palette
(>, <, ≠, ≤, ≥, and | )

/=

Display marks and letter symbols palette
(? ! $ ¡ ' % " : ; _ \)

º

Square root /q

log /s

ln /u

ans /v

Managing Documents

Open document menu ~

Open document /O

Close document /W

Create new document /N

Insert new page /I

Select application /K

Save current document /S

/»

Navigation

Top of page /7
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10 Getting Started with TI-Nspire™ CX Student Software

Python Editor and Shell:Moves cursor to the beginning
of the first line in the program.

End of page

Python Editor and Shell:Moves cursor to the end of the
last line in the program.

/1

Page Up /9

Page Down /3

Up a level in the hierarchy /£

Down a level in the hierarchy /¤

Context menu for selection b

Extends selection in direction of arrow g Any arrow

Python Editor and Shell: Indents text on the current line
or selected lines or navigates between inline prompts

e

Navigating in Documents

Displays previous page /¡

Displays next page /¢

Displays Page Sorter /£

Exits Page Sorter / 6

Switch between applications on a split page /e

Moves focus backward within page

Python Editor and Shell: Dedents text on the current
line or selected lines or navigates backwards between
inline prompts

ge

Wizards and Templates

Add a column to a matrix after the current column g@



Add a row to a matrix after the current row

Python Editor and Shell: Add a new line after the
current line.

@

Integration template g+

Derivative template g-

Math template palette t or/;

Fraction template /p

Modifying Display

Increase contrast /+

Decrease contrast /-

Power off /c

Application-Specific Shortcuts

Notes/Program Editor/Python Editor: Select all

Press-to-Test: Select all items in the dialog

/A

Program Editor/Python Editor: Check syntax and store /B

Program Editor/Python Editor: Find /F

Geometry/Graph: Hide/Show Entry Line

Lists & Spreadsheet/Program Editor/Python Editor: Go
To

/G

Program Editor/Python Editor: Find and Replace /H

Calculator/Program Editor/Python Editor and Shell:
Beginning of line

/8

Calculator/Program Editor/Python Editor and Shell: End
of line

/2
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Notes: Insert math expression box /M

Notes: Insert chemical equation box /E

Open the Scratchpad »

Lists & Spreadsheet: Recalculate

Program Editor: Check syntax, store program and paste
program name in Calculator (after clearing current line
in Calculator)

Python Editor: Check syntax, save program and execute
in Python Shell

Python Shell: Rerun last program

/R

Geometry/Graphs/Lists & Spreadsheet: Add Function
Table

Program Editor/Python Editor and Shell: Add/remove
comment symbol

/T

Group/Ungroup applications on a page /4 //6



Using the Documents Workspace
Use this workspace to create, modify, and view TI-Nspire™ documents, and to
demonstrate mathematical concepts.

Exploring the Documents Workspace

À Documents Toolbox. Contains tools such as the Document Tools menu, Page
Sorter, TI-SmartView™ emulator, Utilities, and Content Explorer. Click each icon
to access the available tools. When you are working in a TI-Nspire™ document,
the tools available are specific to that document.

Á Toolbox pane. Options for the selected tool are displayed in this area. For
example, click the Document Tools icon to access tools needed to work with the
active application.
Note: In the TI-Nspire™ CX Premium Teacher Software, the tool for configuring
questions opens in this space when you insert a question. For more information,
see Using Question in the Teacher Software.

Â Work area. Shows the current document and enables you to perform
calculations, add applications and add pages and problems. Only one document
at a time is active (selected). Multiple documents appear as tabs.

Ã Document information. Shows the names of all open documents. When there are
too many open documents to list, click the forward and backward arrows to
scroll through the open documents.

Using the Documents Toolbox
The Documents Toolbox, located on the left side of the workspace, contains tools
needed for working with TI-Nspire™ documents. When you click a toolbox icon, the
associated tools appear in the Toolbox pane.

Using the Documents Workspace 13



14 Using the Documents Workspace

Exploring Document Tools
In the following example, the Document Tools menu is open showing the options for
the Calculator application. In TI-Nspire™ documents, the Document Tools menu
contains tools available for working with an application. The tools are specific to the
active application.

À The Documents Toolbox menu.

Á Tools available for the Calculator application. Click ¢ to open the submenu for
each option.

Â
Click to close and click to open Document Tools.

Exploring the Page Sorter
The following example shows the Documents Toolbox with the Page Sorter open. Use
the Page Sorter to:

• See the number of problems in your document and where you are.

• Move from one page to another by clicking on the page you want.

• Add, cut, copy, and paste pages and problems within the same document or
between documents.



À The Documents Toolbox menu.

Á Click the minus sign to collapse the view. Click the + sign to open the view and
show pages in the document.

Â Scroll bar. The scroll bar is only active when there are too many pages to show in
the pane.

Exploring the TI-SmartView™ Feature
The TI-SmartView™ feature emulates how a handheld works. In the teacher software,
the emulated handheld facilitates classroom presentations. In the student software,
the emulated keypad gives students the ability to drive the software as if using a
handheld.

Note: Content is displayed on the TI-SmartView™ small screen only when the document
is in Handheld view.

Note: The following illustration shows the TI-SmartView™ panel in the teacher
software. In the Student Software, only the keypad is shown. For more information, see
Using the TI-SmartView™ Emulator.
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16 Using the Documents Workspace

À The Documents Toolbox menu.

Á Keypad Options. Click¤ to select how to show the handheld:

• Dark

• Light

• Outline
Â View selector. In the teacher software, click¤ to select the handheld view:

• Handheld Only



• Keypad + SideScreen

• Handheld + SideScreen

Note: You can also change these options in the TI-SmartView™ Options window.
Click File > Settings > TI-Smartview™ Options to open the window.
Note: The view selector is not available in the student software.
When the Handheld Only display is active, select Always in Front to keep the
display in front of all other open applications. (Teacher software only.)

Exploring Content Explorer
Use Content Explorer to:

• See a list of files on your computer.

• Create and manage lesson bundles.

• If using software that supports connected handhelds, you can:

- See a list of files on any connected handheld.
- Update the OS on connected handhelds.
- Transfer files between a computer and connected handhelds.

Note: If you are using TI-Nspire™ software that does not support connected handhelds,
the Connected Handheld heading is not shown in the Content Explorer pane.
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18 Using the Documents Workspace

À The Documents Toolbox menu.

Á Shows files on your computer and the name of the folder where the files are located.
Click¤ to navigate to another folder on the computer.

Â The list of folders and files within the folder named in the Look In: field. Right-click on
a highlighted file or folder to open the context menu listing available actions for that
file or folder.

Ã
Click to close the list of files. Click to open the list of files.

Ä Options menu. Click¤ to open the menu of actions you can perform on a selected
file:

• Open an existing file or folder.

• Move (navigate) up one level in the folder hierarchy.

• Create a new folder.

• Create a new lesson bundle.

• Rename a file or folder.

• Copy selected file or folder.

• Paste file or folder copied to Clipboard.

• Delete selected file or folder.

• Select all files in a folder.

• Package lesson bundles.

• Refresh the view.

• Install OS.
Å Connected handhelds. Lists the connected handhelds. Multiple handhelds are listed if

more than one handheld is connected to the computer or when using the TI-Nspire™
Docking Stations.

Æ The name of the connected handheld. To show the folders and files on a handheld,
double-click the name.

Click¤ to navigate to another folder on the handheld.

Exploring Utilities
Utilities provides access to the math templates and operators, special symbols,
catalogue items, and libraries that you need when working with documents. In the
following example, the Math templates tab is open.



À The Documents Toolbox menu.

Á Math Templates are open. Double-click a template to add it to a document. Click
the Math Template tab to close the template view.
To open the Symbols, Catalogue, Math Operators, and Libraries, click the tab.

Â Wizards On check box. Select this option to use a wizard to enter function
arguments.

Ã Tabs for opening views where you can select and add symbols, catalogue items,
math operators, and library items to a document. Click the tab to open the view.

Using the Work Area
The space on the right side of the workspace provides an area for creating and working
with TI-Nspire™ documents. This work area provides a view of the document so that
you can add pages, add applications, and perform all work. Only one document at a
time is active.

When you create a document, you specify its page size as Handheld or Computer. This
is how the page is displayed in the work area.

• Handheld page size is optimized for the smaller screen of a handheld. This page size
can be viewed on handhelds, computer screens, and tablets. The content is scaled
when viewed on a larger screen.
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20 Using the Documents Workspace

• Computer page size takes advantage of the larger space of a computer screen.
These documents can show details with less scrolling required. The content is not
scaled when viewed on a handheld.

You can change the page preview to see how the document will look in a different page
size.

▶ To change the page preview, click Document Preview on the toolbar, and then click
Handheld or Computer.

For more information on page size and document preview, seeWorking with TI-
Nspire™ Documents.

Changing Document Settings
Document settings control how all numbers, including elements or matrices and lists,
are displayed in TI-Nspire™ documents. You can change the default settings at anytime
and you can specify settings for a specific document.

Changing Document Settings

1. Create a new document or open an existing document.

2. From the TI-Nspire™ Filemenu, select Settings > Document Settings.

The Document Settings dialogue box opens.

When you open Document Settings the first time, the default settings are
displayed.

3. Press Tab or use your mouse to move through the list of settings. Click¤ to open
the drop-down list to view the available values for each setting.

Field Values

Display Digits • Float
• Float1 - Float12
• Fix0 - Fix12

Angle • Radian
• Degree
• Gradian

Exponential
Format

• Normal
• Scientific
• Engineering



Field Values

Real or
Complex

• Real
• Rectangular
• Polar

Calculation
Mode

• Auto
• Exact
• Approximate

Note: Auto mode shows an answer that is not a whole number as a
fraction except when a decimal is used in the problem. Exact mode
(CAS only) shows an answer that is not a whole number as a
fraction or in symbolic form, except when a decimal is used in the
problem.

Exact
Arithmetic

• On
• Off

Note: This option is only available on Exact Arithmetic handhelds.

CAS Mode • On
• Exact Arithmetic
• Off

Note: This option is only available on CAS handhelds and software.

Vector Format • Rectangular
• Cylindrical
• Spherical

Base • Decimal
• Hex
• Binary

Unit System • SI
• Eng/US

Note: This option is only available on CAS handhelds and software.

4. Click the desired setting.

5. Choose one of the following options:

• To apply the settings to the open document and to Scratchpad, and to make
default for new applications, click OK.

• Click Cancel to close the dialogue box without making changes.
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22 Using the Documents Workspace

Changing Graphs & Geometry Settings
Graphs & Geometry settings control how information is displayed in open problems
and in subsequent new problems. When you change the Graphs & Geometry settings,
the selections become the default settings for all work in these applications.

Complete the following steps to customise the application settings for graphs and
geometry.

1. Create a new graphs and geometry document or open an existing document.

2. In the Documents Toolbox, click to open the Graphs & Geometry application
menu.

3. Click Settings > Settings.

The Graphs & Geometry Settings dialogue box opens.

4. Press Tab or use your mouse to move through the list of settings. Click ¢ to open
the drop-down list to view the available values for each setting.

Field Values
Display Digits • Auto

• Float
• Float1 -

Float12
• Fix0 - Fix12

Graphing Angle • Auto
• Radian
• Degree
• Gradian

Geometry Angle • Auto
• Radian
• Degree
• Gradian



5. Select the desired setting.

6. Select a checkbox to enable an option or clear a checkbox to disable an option.

Check box Operation when selected

Automatically hide
plot labels

Plot labels are displayed only when selected, grabbed or
hovered.

Show axis end values A numeric label is displayed at the least and greatest
values visible on an axis

Show tool tips for
function manipulation

Shows helpful information as you manipulate function
graphs

Automatically find a
point of interest

Shows zeros, minima and maxima for graphed functions
and objects while tracing function graphs.

7. Choose one of the following options:

• To apply the settings to the open document and to Scratchpad, and to make
default for new Graphs and Geometry applications, click OK.

• Click Cancel to close the dialogue box without making changes.
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Working with Connected Handhelds
The TI-Nspire™ software enables you to view content, manage files, and install
operating system updates on handhelds connected to the computer.

To use the features described in this chapter, handhelds must be turned on and
connected by one of these means:

• TI-Nspire™ Docking Station or TI-Nspire™ CX Docking Station

• TI-Nspire™ Navigator™ Cradle and access point

• TI-Nspire™ CX Wireless Network Adapter and access point

• TI-Nspire™ CX Wireless Network Adapter - v2 and access point

• A direct connection through a standard USB cable

For web-based connectivity using your TI-Nspire™ CX II with a Chromebook, Windows®
computer, or Mac® computer, go to TI-Nspire™ CX II Connect.

Note: The tasks in this section can only be performed using TI-Nspire™ handhelds. In
order to enable wireless connectivity, the TI-Nspire™ Premium Teacher Software and
the OS installed on the TI-Nspire™ CX II handhelds must be version 5.0 or later. For TI-
Nspire™ CX handhelds, the OS must be version 4.0 or later.

Managing Files on a Connected Handheld
When working with files on connected handhelds in the Content Workspace, use the

Options menu or the context menu to manage files.

Option How it Works

Open Open a file on a connected handheld:

• Click the file you want to open.

• Click Open. The document opens in the Documents Workspace.

Save to
Computer

Save a copy of the selected file on your computer.

• Click the file you want to save.

• Click Save to Computer. The Save Select File dialogue box
opens.

• Navigate to the folder where you want to save the file.

• Click Save.

Copy/Paste Create a copy of a file:
• Click the file you want to copy.
• Click Options > Copy to copy the file to the Clipboard.
• To paste the file in another location, navigate to the new location

and then click Options > Paste.

Note: If you don’t select a new location, the copied file is

https://nspireconnect.ti.com/


Option How it Works

pasted with a new name "Copy of ..."

Delete Delete a file on a connected handheld:
• Click the file you want to delete.
• Click Delete.
• Click Yes when the Warning dialogue box opens. Click No to cancel.

Refresh To refresh the list of files, click Options > Refresh.

Rename To rename a file on a connected handheld:
• Click the file you want to rename.
• Click Rename.
• Type the new name and press Enter.

Up a Level Go up a level in the folder hierarchy. This option is available when you
select a file inside a folder.

New Folder Create a new folder:

• Click New Folder.

• Type a name for the new folder.

• Press Enter.

Opening Documents on Connected Handhelds

To open a document on a connected handheld in the TI-Nspire™ software:

1. Ensure the handheld is connected to your computer.

2. Click to open Content Explorer.

The connected handheld name is listed in the Connected Handhelds pane.

3. Double-click the handheld name.

The folders and documents on the handheld are listed.

4. Navigate to the document you want to open, and then double-click the file name.

The document opens in the Documents Workspace work area.

Saving Files to a Connected Handheld

When you save a file from your computer to a handheld, files are converted to TI-
Nspire™ documents (.tns files). To save a file on your computer to a connected
handheld:

1. Ensure the handheld is connected to your computer.

2. Click to open Content Explorer.

The folders and files on your computer are listed in the Computer pane.
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3. Navigate to the folder or file you want to save to the handheld.

4. Click the file to select it.

5. Drag the file to a connected handheld listed in the Connected Handheld pane.

The file is saved to the connected handheld.

Note: To save the file in a folder on the handheld, double-click the handheld name
to list the folders and files, and then drag the file to a folder on the handheld.

If the file already exists on the handheld, a dialogue box opens asking if you want to
replace the file. Click Replace to overwrite the existing file. Click No or Cancel to
abandon the save.

Checking for an OS Update
When handhelds are connected, you can check for OS updates from the Content
Workspace or from the Documents Workspace.

1. Show all connected handhelds.

• In the Content Workspace, click Connected Handhelds in the Resources pane.
• In the Documents Workspace, open the Content Explorer and click Connected

Handhelds.

2. Click the handheld you want to check, and then right-click and select Check for OS
Update.

• If the operating system is current, the Check for Handheld OS Update dialogue
box opens indicating that the operating system on the handheld is current.

• If the operating system is not current, the TI-Nspire™ software prompts you to
install the latest OS now, with the option to download the OS to your
computer.



3. Click Close to close the dialogue box, or click Continue and follow the prompts to
install the OS on the handheld.

Installing an OS Update
Note: To avoid losing unsaved data, close all documents on the handheld before
updating its operating system (OS). Updating the OS does not replace or remove
previously saved documents.

The OS on a new handheld comes bundled with the installer, which places the OS in a
default location such as: C:\mydocuments\TI-Nspire\downloads.

Go to education.ti.com/latest to download the latest OS files.

Note: You can install OS updates on connected handhelds from the Content Workspace
at any time.

Updating the OS on a Single Handheld

1. Ensure that your computer is connected to the internet.

2. Show all connected handhelds by clicking the arrow next to TI-Nspire™ Connected
Handhelds in the Resources pane.

Note: An attention symbol next to a

handheld name means:

The handheld needs an OS update.
—or—
The handheld has a newer OS than the
teacher's.

3. Hover your mouse over the TI-Nspire™ handheld you want to update, and then
right-click.

4. Click Check for OS Update.

The Check for OS Update dialogue box opens.
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5. Click Close to cancel the installation, or click Continue and follow the prompts to
install the OS on the handheld.

When the update is complete, the handheld restarts automatically.

Updating the OS on Multiple Handhelds 

Note: To avoid losing unsaved data, close all documents on the handheld before
updating its operating system (OS). Updating the OS does not replace or remove
previously saved documents.

1. Click TI-Nspire™ Connected Handhelds in the Resources pane.

2. Select all handhelds you want to update in the Content Pane.

3. Click Tools > Install OS.

The OS Installation dialogue box opens.



4. Click Add OS file.

The Add to Transfer List dialogue box opens.

5. Select the applicable OS files.

• To upgrade a TI-Nspire™ CX handheld, select TI-Nspire.tco.

• To upgrade a TI-Nspire™ CX CAS handheld, select TI-Nspire.tcc.

• To upgrade a TI-Nspire™ CX II handheld, select TI-Nspire.tco2.
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• To upgrade a TI-Nspire™ CX II CAS handheld, select TI-Nspire.tcc2.

• To upgrade a TI-Nspire™ CX II-T handheld, select TI-Nspire.tct2.

6. Click Select.

The OS Installation redisplays with your selected OS files.

7. Click Install OS.

The OS version information updates, and the Select OS Handheld File dialogue
redisplays for further selection.



Working with TI-Nspire™ Documents
All work that you create and save using TI-Nspire™ applications is stored as a document
(.tns file), which you can share with others using TI-Nspire™ software and with those
using handhelds.

TI-Nspire™ Documents

A TI-Nspire™ document consists of one or more problems. Each problem can contain
one or more pages. A single page is displayed in the work area. All work occurs in the
applications within pages.

Because the TI-Nspire™ software and handhelds share the same functionality, you can
transfer TI-Nspire™ documents between computers and handhelds. When you create a
document, you select one of two page sizes.

• Handheld. Size: 320 × 217 pixels. This size allows documents to be viewed on all
platforms. The content will be scaled when viewed on a tablet or larger screen.

• Computer. Size: 640 × 434 pixels. The content will not be scaled when viewed on
smaller platforms. Some content may not be visible on a handheld device.

You can convert a document from one page size to the other any time.

Creating a New TI-Nspire™ Document
When you open the software, the Documents Workspace opens with a blank document
containing one problem. You can add applications and content to this problem to
create a document.

Note: The Welcome Screen is displayed when you open the software if the "always
show this at startup" option is selected. Click an application icon to add a problem with
an active application to a new document.

To create a new document, complete the following steps:

1. On the TI-Nspire™ File menu,

• Select New TI-Nspire™ Document - Handheld Page Size.

-or-

• Select New TI-Nspire™ Document - Computer Page Size.

The new document opens in the Documents Workspace, and you are prompted to
select an application.
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2. Select an application to add a problem to the document.

The problem is added to the document.

Opening an Existing Document
To open an existing document:

1. Click File > Open Document.

—or—

Click .

The Open dialogue box opens.



2. Use the file browser to locate the file you want to open and click the file to select it.

3. Click Open.

The document opens in the work area.

Note: To select from your 10 most recent documents, click File > Recent Documents and
select a document from the drop-down list.

Saving TI-Nspire™ Documents
To save a new document:

1. Click File > Save Document or click .

The Save TI-Nspire™ Document dialogue box opens.
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2. Navigate to the folder where you want to save the document or create a folder in
which to store the document.

3. Type a name for the new document.

4. Click Save to save the document.

The document closes and is saved with the extension .tns.

Note:When you save a file, the software looks in the same folder the next time you
open a file.

Saving a Document with a New Name

To save a previously saved document in a new folder and/or with a new name:

1. Click File > Save As.

The Save TI-Nspire™ Document dialogue box opens.

2. Navigate to the folder where you want to save the document or create a folder in
which to store the document.

3. Type a new name for the document.

4. Click Save to save the document with a new name.

Deleting Documents
File deletions on your computer are sent to the Recycle bin and can be retrieved if the
Recycle bin has not been emptied.

Note: File deletions on the handheld are permanent and cannot be undone, so be sure
that you want to delete the file that you select.

1. Select the document you want to delete.

2. Click Edit > Delete or press Delete.

The Warning dialogue box opens.

3. Click Yes to confirm the delete.

The document is deleted.

Closing Documents
▶ To close a document, click File > Close or click the Close icon on the document tab at

the bottom of the document.

▶ If working in tiled view, click the Close icon in the upper right corner of the
document window.



Formatting Text in Documents
Use the text formatting tools to format text in TI-Nspire™ applications that allow text
input. By default, the text formatting toolbar opens in the area above an active
document. Options on the toolbar are enabled or disabled depending on the active
application.

Option Function

Click¤ to open the menu for the active
application. This tool enables you to open an
application menu regardless of the option
selected in the Documents Toolbox.

Click¤ to select a background colour for
highlighting text or choose a fill colour for a
selected cell.

Click¤ to select the line colour for an object.
For example, in Graphs & Geometry, you can
choose a colour for a selected shape.

Click¤ to select a colour for selected text.

Use these tools to choose a font and set the size
of the font.

• Click¤ to select a different font from the
drop-down box.

• To select as specific font size, click¤ to
select a size from the drop-down box.

• Click to increase the font size or click

to decrease the font size
incrementally.

Click the appropriate tool to apply bold, italics
or underlining; apply superscript or subscript; or
strike out text.

Hiding and Showing the Formatting Toolbar

▶ When the formatting toolbar is visible, click£ (located under the toolbar) to hide
the toolbar.
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▶ Click¤ to show the toolbar when the formatting toolbar is hidden.

Using Colours in Documents
In the TI-Nspire™ applications that allow formatting, you can use colour in filled areas
of an object, or in lines or text, depending on the application you are using and how
you have selected the item. If the icon or menu item that you want to use is not
available (dimmed) after you have selected an item, colour is not an option for the
selected item.

Colours appear in documents opened on your computer and on the TI-Nspire™ CX
handheld.

Note: For more information about using colour in a TI-Nspire™ application, see the
chapter for that application.

Adding Colour from a List

To add colour to a fill area, line or text, complete the following steps:

1. Select the item.

2. Click Edit > Colour or select where you want to add colour (fill, line or text).

3. Select the colour from the list.

Adding Colour from a Palette

To add colour using the palette, complete the following steps:

1. Select the object.

2. Click the appropriate toolbar icon.

3. Select the colour from the palette.

Setting Page Size and Document Preview
When you create a document, you specify its page size as Handheld or Computer,
depending on how you expect the document to be used. Documents of both page sizes
can be opened on either platform, and you can convert the page size any time.

• Handheld. Size: 320 × 217 pixels, fixed. Handheld documents can be viewed on all
platforms. You can magnify (zoom) the content when viewing it on a tablet or
larger screen.

• Computer. Size: 640 × 434 pixels, minimum. Computer documents scale up
automatically to take advantage of higher resolution screens. The minimum size is
640 × 434, so some content may be clipped on handheld devices.

Note: You can view documents of either page size using Handheld or Computer
preview.

Converting the Current Document's Page Size

▶ On the main TI-Nspire™ Filemenu, select Convert to, and then select the page size.



The software saves the current document and creates a copy that uses the
requested page size.

Viewing the Document in Handheld Preview

1. On the application toolbar, click Document Preview, and select Handheld.

The preview changes. This does not change the document's underlying page size.

2. (Optional) Adjust the viewing magnification:

- (Optional) Click the Zoom tool beneath the work area, and select a
magnification value for the preview.

—or—

- Click the Zoom to Fit button to make the handheld preview adjust
automatically to the window size.

Viewing the Document in Computer Preview

1. On the application toolbar, click Document Preview, and select Computer.

The preview changes. This does not change the document's underlying page size.

2. (Optional) Click the Boldness tool beneath the work area, and select a value to
increase or decrease the boldness of text and other items.

Setting a Default Preview

By default, when you open a document, it is automatically displayed using the preview
that matches its page size. You can override the rule and specify a preview that you
prefer.

1. On the main TI-Nspire™ Filemenu, select Settings > Preview Settings.

2. Select the preview that you want documents to use when you open them.

Working with Multiple Documents
When multiple documents are open, document names are listed in tabs at the bottom
of the work area. Only one document is active at a time, and only the active document
is affected by commands from menus or tools.

To switch between documents:
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À Click the tab to show a document in the work area. This document
becomes the active document. If the Show Documents in Tiles view is
open, these tabs are not shown.

Á Use the right and left arrows to scroll through the list of documents.
These arrows are active only when there are too many documents to fit
in the window.

Â Click the Show List icon to list all open documents. This is useful when
you have a large number of documents open and documents names on
the tabs may be truncated.

Working with Multiple Documents in Tiled View

When multiple documents are open, you can view thumbnails of the documents in the
work area. To change the view:

▶ ClickWindow > Show Documents in Tiles.

Open documents are shown as thumbnails in the work area, and the scroll bar
becomes active.

The status bar remains available; however, document names now appear in the
thumbnail view. Click Select Window > Show Documents in Tabs to view one document
at a time in the work area.

Working with Applications
When you first open a new document or add a new problem to a document, you select
an application from a menu.



The following illustration shows how a document containing the Lists & Spreadsheet
application appears in the work area.

À Document name. Tabs show the names of open documents. Click a name to make it
the active document.

Á Page Size. Shows the document's page size as Handheld or Computer. You can use
the TI-Nspire™ Filemenu to convert a document from one page size to the other.

Â Problem/Page counter. Labels the problem number and page number of the active
page. For example, a label of 1.2 identifies Problem 1, Page 2.

Ã Settings. Double-click to view or change the Document Settings for the active
document or to change the default Document Settings.

Ä Angle Mode. Shows an abbreviation of the angle mode (Degrees, Radians or
Gradians) in effect. Hover the pointer over the indicator to see the full name.

Å Zoom. Enabled in Handheld preview only (click Document Preview on the toolbar and
select Handheld). Click▼ and select a magnification value, or click the zoom-to-fit
button to make the preview adapt automatically to window size.

Æ Boldness. Enabled in Computer preview only (click Document Preview on the toolbar
and select Computer). Click▼ and select a value to increase or decrease the boldness
of text and other items.
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Working with Multiple Applications on a Page

You can add up to four applications to a page. When you have multiple applications on
a page, the menu for the active application is displayed in the Documents Toolbox.
Using multiple applications involves two steps:

• Changing the page layout to accommodate multiple applications.

• Adding the applications.

You can add multiple applications to a page even if an application is already active.

Adding Multiple Applications to a Page

By default, each page contains space to add one application. To add additional
applications to the page, complete the following steps.

1. Click Edit > Page Layout > Select Layout.

—or—

Click .

The page layout menu opens.

There are eight page layout options available. If an option is already selected, it is
dimmed.

2. Highlight the layout you want to add to the problem or page, then click to select it.

The new layout is displayed with the first application active.



3. In Handheld preview, click Press menu to select an application for each new section
in the problem or page. In Computer view, select Click here to add an application.

Swapping Applications

To change the position of applications on a page with multiple applications, “swap“ the
positions of two applications.

1. Click Edit > Page Layout > Swap Application.

Note: The last active application you worked on is automatically selected as the first
application to be swapped.

2. Click the second application to swap.

This action performs the swap.

Note:When there are only two work areas, the selected application automatically
swaps position with the other application in the work area.

To cancel a swap, press Esc.

Selecting and Moving Pages
As you add problems and pages to a document, you can take advantage of features for
managing the parts.
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À Page Sorter. Lists the problems you have inserted in your document and shows
thumbnail images of the pages in each problem. The Page Sorter lets you rearrange,
copy and move both problems and pages. It also lets you rename problems.

Á Active page. Indicates the current page by highlighting its thumbnail image.
Thumbnails let you easily scan the pages in a document and select a specific page to
work with.

Â Problem/Page counter. Displays the problem number and page number of the
currently selected page.

Selecting Pages

Use any of these methods to move from page to page.

▶ On the Viewmenu, select Previous Page or Next Page.

▶ On the keyboard, press Ctrl+PgUp or Ctrl+PgDn.
(Mac®: Press Fn+Up Arrow or Fn+Down Arrow).

▶ Click the Previous Page or Next Page button on the main toolbar.

▶ Click the Page Sorter tool in the Documents Toolbox, and then click the
thumbnail of the page you want to work with.

Tip: To expand or collapse the list of thumbnails for a problem, double-click the
name of the problem.

Rearranging Pages with the Page Sorter

The Page Sorter makes it easy to reorder pages within a problem.



1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. In the Page Sorter, drag the thumbnail image of the page to the desired position.

Copying a Page

You can copy a page within the same problem or copy it to a different problem or
document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Select the thumbnail of the page to be copied.

3. On the Editmenu, click Copy.

4. Click the location at which you want to insert the copy.

5. On the Editmenu, click Paste.

Moving a Page

You can move a page within the same problem or move it to a different problem or
document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Select the thumbnail of the page to be moved.

3. On the Editmenu, click Cut.

4. Click the new location of the page.

5. On the Editmenu, click Paste.

Deleting a Page

1. Select the page in the work area or in the Page Sorter.

2. Click Edit > Delete.

Grouping Applications on a Page

You can combine as many as four consecutive application pages into a single page.

1. Select the first page in the series.

2. Click Edit > Page Layout > Group.

The next page is grouped with the first page. The page layout automatically adjusts
to display all the pages in the group.
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Ungrouping Applications into Separate Pages

1. Select the grouped page.

2. Click Edit > Page Layout > Ungroup.

The applications are divided into individual pages.

Deleting an Application from a Page

1. Click the application to be deleted.

2. Click Edit > Page Layout > Delete Application.

Tip: To undo the delete, press Ctrl + Z (Mac®: “+ Z).

Working with Problems and Pages
When you create a new document, it consists of a single problem with a single page.
You can insert new problems and add pages to each problem.

Adding a Problem to a Document

A document can contain up to 30 problems. Each problem's variables are unaffected by
the variables in other problems.

▶ On the Insertmenu, select Problem.
—or—
Click the Insert tool on the main toolbar, and select Problem.

A new problem with an empty page is added to your document.

Adding a Page to the Current Problem

Each problem can contain up to 50 pages. Each page has a work area, where you can
perform calculations, create graphs, collect and plot data, or add notes and
instructions.

1. Click Insert > Page.
—or—
Click the Insert tool on the main toolbar, and select Page.

An empty page is added to the current problem, and you are prompted to choose
an application for the page.

2. Select an application to add to the page.



Renaming a Problem

New problems are named automatically as Problem 1, Problem 2, and so on. To
rename a problem:

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.

3. On the Editmenu, click Rename.

4. Type the new name.

Rearranging Problems with the Page Sorter

The Page Sorter lets you reorder problems within a document. If you move a problem
that you have not renamed, the numeric part of the default name changes to reflect
the new position.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. In the Page Sorter, arrange the problems by dragging each problem name to its
new position.

Tip: To collapse a problem's list of page thumbnails, double-click the name of the
problem.

Copying a Problem

You can copy a problem within the same document or copy it to a different document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.

3. On the Editmenu, click Copy.

4. Click the location at which you want to insert the copy.

5. On the Editmenu, click Paste.

Moving a Problem

You can move a problem within the same document or move it to a different
document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.

3. On the Editmenu, click Cut.
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4. Click the new location of the problem.

5. On the Editmenu, click Paste.

Deleting a Problem

To delete a problem and its pages from the document:

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.

3. On the Editmenu, click Delete.

Printing Documents
1. Click File > Print.

The Print dialogue box opens.

2. Set options for the print job.

• Printer — Select from your list of available printers
• Print What:

- Print All — prints each page on a separate sheet
- Viewable Screen — prints selected pages with additional layout options

(see Layout, below)
• Print Range — Click All Pages, or click Page range and set the starting and

ending pages.
• Layout:

- Orientation (portrait or landscape)
- The number of TI-Nspire™ pages (1, 2, 4 or 8) to be printed on each sheet

(available in Viewable Screen option only). The default is 2 pages per sheet.
- Whether to allow space below each printed TI-Nspire™ page for comments

(available in Viewable Screen option only)
- Margins (from .25 inches to 2 inches) The default margin is .5 inches on all

edges.
• Documentation information to include:

- Problem name, including the option to group the pages physically by
problem

- Page label (such as 1.1 or 1.2) under each page
- Page header (up to two lines)
- Document name in the footer

3. Click Print, or click Save As PDF.

Note: To restore the Print defaults, click Reset.



Using Print Preview

• Click the Preview tickbox to toggle the preview pane.

• Click the arrows at the bottom of the preview pane to page through the preview.

Viewing Document Properties and Copyright Information
Note:Most of these instructions apply only to the Teacher Software.

Checking Page Size

1. In the Teacher Software, go to the TI-Nspire™ Filemenu and select Document
Properties.

2. Click the Page Size tab.

3. A tick indicates the document's current page size.

Viewing Copyright Information

The Teacher Software and Student Software let you view copyright information that
has been added to a document.

1. On the TI-Nspire™ Filemenu, select View Copyright Information.

The Copyright Information dialogue box opens.

2. Click OK to close the dialogue box.

Adding Copyright Information to a Document

Using the Teacher Software, you can add copyright information to individual
documents that you create, or you can apply the same copyright information to all new
documents.

1. Open the document.
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2. On the TI-Nspire™ Filemenu, select Document Properties.

3. Click the Copyright tab.

4. Edit the following fields to define the copyright details:

• Author

• Copyright (select Public Domain or Copyright).

• Year (disabled if you selected Public Domain)

• Owner (disabled if you selected Public Domain)

• Comments

5. To add the supplied information to all new documents from this point forward,
select Apply this copyright to all new documents.

6. Click OK to apply the copyright information to the document.

Protecting a Document (making a document read-only)

Teachers can protect documents to create a document for distribution to your students
or for other use. A student who receives a read-only document and makes changes to it
will be prompted to save the document as a new file.

1. Open the document.

2. On the TI-Nspire™ Filemenu, select Document Properties.

3. Click the Protection tab.

4. Select theMake this document Read Only checkbox.

5. Click OK.



Working with Lesson Bundles
Many lessons or activities contain multiple files. For example, teachers usually have a
teacher version of a file, a student version, assessments and sometimes supporting
files. A lesson bundle is a container that enables teachers to group all files needed for a
lesson together. Lesson bundles are used to:

• Add any type of file (.tns, .doc, .pdf, .ppt) to a lesson bundle.

• Send lesson bundles to connected handhelds or laptops; however, only the .tns
files are sent to the handheld.

• View all the files in a lesson bundle using the TI-Nspire™ software.

• Group all files associated with one lesson in one place.

• Email one lesson bundle file to teachers or students instead of looking for and
attaching multiple files.

Creating a New Lesson Bundle
Teachers and students can create new lesson bundles in the Documents Workspace.
Teachers can also create new lesson bundles in the Content Workspace.

Creating a Lesson Bundle in the Documents Workspace

Complete the following steps to create a new lesson bundle. By default, the new lesson
bundle does not contain files.

1. Click in the Documents Toolbox to open the Content Explorer.
2. Navigate to the folder where you want to save the lesson bundle file.

3. Click to open the menu, and then click New Lesson Bundle.

The new lesson bundle file is created with a default name and placed in your list of
files.

4. Type a name for your lesson bundle.

5. Press Enter to save the file.

Creating Lesson Bundles in the Content Workspace

In the Content Workspace, teachers have two options for creating lesson bundles:

• When files needed for a lesson bundle are located in different folders, create an
empty lesson bundle and then add files to the lesson bundle.

• If all needed files are located in the same folder, create a lesson bundle with
selected files.

Creating an Empty Lesson Bundle

Complete the following steps to create a lesson bundle that does not contain files.

1. Navigate to the folder on your computer where you want to save the lesson
bundle.
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Note: If you are using the software for the first time, you may need to create a
folder on your computer before creating a lesson bundle.

2. Click or click File > New Lesson Bundle.

The new lesson bundle file is created with a default name and placed in the list of
files.

3. Type a name for the lesson bundle and press Enter.

The lesson bundle is saved with the new name and details are shown in the Preview
pane.

Creating a Lesson Bundle Containing Files

You can select multiple files within a folder, and then create the lesson bundle. You
cannot add a folder to a lesson bundle.

1. Navigate to the folder that contains the files you want to bundle.

2. Select the files. To select multiple files, select the first file then hold down Shift and
click the last file in the list. To select random files, select the first file and then hold
down Ctrl and click the other files to select them.

3. Click , and then click Lesson Bundles > Create New Lesson Bundle from selected.

A new lesson bundle is created and placed in the open folder. The lesson bundle
contains copies of the selected files.

4. Type a name for the lesson bundle and press Enter.

The lesson bundle is saved in the open folder and the details are shown in the
Preview pane.

Adding Files to a Lesson Bundle
Use any of the following methods to add files to a lesson bundle:

• Drag any file into a selected lesson bundle. This method moves the file to the lesson
bundle. If you delete the lesson bundle, the file is deleted from your computer. You
can recover the file from the Recycle Bin.

• Copy and paste any file into a selected lesson bundle.

• Use the “Add files to lesson bundle” option. This method copies the selected files
into the lesson bundle. The file is not moved from its original location.

Using the Add Files to Lesson Bundle Option

Use this option to add files to an empty lesson bundle or add more files to an existing
lesson bundle.

1. Use one of the following options to select the lesson bundle file.

• When working in the Documents Workspace, open the Content Explorer and
then double-click the lesson bundle file name.



• When working in the Content Workspace, double-click the lesson bundle name.

Note: In the Content Workspace, you can also click the lesson bundle name to
open the Files dialogue box in the Preview pane. The Add Files to Lesson Bundle
option is available from the Files dialogue box. If the lesson bundle already
contains files, the first file in bundle is shown in the Files dialogue box.

The lesson bundle dialogue box opens. The name reflects the name of the lesson
bundle.

2. Click Add Files to Lesson Bundle.

The Add dialogue box opens.

3. Navigate to and select the file you want to add to the lesson bundle.

• You can select multiple files at one time if they are located in the same folder.
• If files are located in different folders, you can add them one at a time.
• You cannot create a folder within a lesson bundle or add a folder to a lesson

bundle.

4. Click Add to add the file to the bundle.

The file is added to the bundle and is now listed in the lesson bundle dialogue box.

5. Repeat this process until all needed files are added to the lesson bundle.
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Opening a Lesson Bundle
To view and work with files within a lesson bundle, complete one of the following steps
to open the lesson bundle file.

▶ Double-click the lesson bundle name.

▶ Select the lesson bundle, and then right-click and click Open.

▶ Select the lesson bundle, click , and then click Open.

▶ Select the lesson bundle, and then press Ctrl + O. (Mac®: “ + O).

When you open a lesson bundle, the files in the bundle are displayed in a separate
dialogue box.

Note: You cannot open a lesson bundle outside of the TI-Nspire™ software. For
example, if you open the folder using the file manager on your computer and double-
click the lesson bundle name, it does not automatically launch the TI-Nspire™ software.

Opening Files Within a Lesson Bundle

You can open any file within a lesson bundle on your computer if you have the
programme associated with the file type.

• When you open a .tns file, the file opens in the Documents Workspace in the TI-
Nspire™ software.

• When you open another file type, it launches the application or programme
associated with that file. For example, if you open a .doc file, it opens in Microsoft®
Word.

Use one of the following options to open a file within a lesson bundle:

▶ Double-click the lesson bundle, and then double-click a file within the lesson
bundle.

▶ Within a lesson bundle, select the file and then click ¢ or right-click the file name
and select Open.

Managing Files in a Lesson Bundle
You can open, copy/paste, delete and rename files in an existing lesson bundle. To
locate and work with files in an existing lesson bundle:

1. Choose one of the following options to locate an existing lesson bundle.



• When working in the Documents Workspace, open the Content Explorer (click
in the Documents Toolbox), and then navigate to the folder where the

lesson bundle is located.
• When working in the Content Workspace, navigate to the folder where the

lesson bundle is located in Content pane.

Note: When you click a lesson bundle name in the Content pane, the Files
dialogue box opens in the Preview pane. Select a file and right-click to open the
context menu.

2. Double-click the lesson bundle name to open the Lesson Bundle dialogue box.

3. Select the file you want to work with and click ¢ to open the context menu.
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4. Click the action you want to perform:

• Click Open. TI-Nspire™ documents open in the Documents Workspace. When
you open another file type, it launches the application or programme
associated with that file.

• Click Copy to place the file in the Clipboard.
• Navigate to a folder on your computer or select a connected handheld or

laptop, and then right-click and click Paste to place the copied file in a new
location.

• Click Delete to delete a file from the lesson bundle. Use caution when deleting a
file from a lesson bundle. You should ensure files contained in the bundle are
backed up if you need the files for future use.

• Click Rename to give the file a new name. To cancel this action, press Esc.
• Click Add Files to Lesson Bundle to select and add files to the bundle.
• Click Refresh to update the list of files in the bundle.
• Click Package Lesson Bundle to create a .tilb file
• Click Send to Connected Handhelds to open the Transfer Tool and send the

selected file to connected handhelds. You can send .tns files and OS files.

5. When finished, click Close to close the dialogue box.

Managing Lesson Bundles
Use the options menu or the context menu to copy, delete, rename or send a lesson
bundle to connected handhelds or laptops. You cannot add a folder to a lesson bundle.

Managing Lesson Bundles in the Documents Workspace

1. Open the Content Explorer, and then right-click the lesson bundle name or click
to open the context menu.



2. Click the action you want to perform. If an action is not available, it is dimmed.

• Click Open to open the lesson bundle.
• Click Up One Level to navigate up a level in the folder hierarchy.
• You cannot add a folder to a lesson bundle. If you click New Folder, a new folder

is added to the folder where the lesson bundle is stored.
• Click New Lesson Bundle to create a new lesson bundle. The new lesson bundle

is not added to the existing lesson bundle—it is created in the same folder as
the existing lesson bundle.

• Click Rename to change the name of the lesson bundle. Press Esc to cancel this
action.

• Click Copy to copy the lesson bundle to the Clipboard.
• Navigate to another folder, and then click Paste to copy the lesson bundle in

another location.
• Click Delete to delete the lesson bundle. Use caution when deleting a lesson

bundle. You should ensure files contained in the bundle are backed up if you
need the files for future use.

• Select All highlights all files in the open folder. This action does not apply to
lesson bundles.

• Click Package Lesson to create a .tilb file.
• Click Refresh to update the list of files in the open folder.

Managing Lesson Bundles in the Content Workspace

1. Click Local Content in the Resources pane.

2. In the Content pane, navigate to the lesson bundle you want to work with, and

then right-click to open the context menu or click to open the menu of options.
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3. Select the action you want to perform:

• Click Open to open the lesson bundle.
• Click Copy to place the lesson bundle file in the Clipboard.
• Navigate to a folder on your computer or select a connected handheld, and

then right-click and click Paste to place the copied file in a new location.
• Click Delete to delete the lesson bundle. Use caution when deleting a lesson

bundle. You should ensure files contained in the bundle are backed up if you
need the files for future use.

• Click Refresh to update the list of files in the bundle.
• Click Rename to give the lesson bundle a new name. To cancel this action, press

Esc.
• To move up a level in the folder hierarchy, click Up a Level.
• To add the lesson bundle to the list of shortcuts in Local Content, click Create

Shortcut.
• To add more files to the lesson bundle, click Lesson Bundles > Add Files to

Lesson Bundle.
• Click Lesson Bundles > Package Lesson Bundle to create a .tilb file.
• Click Send to Connected Handhelds to open Transfer Tool and send the lesson

bundle to connected handhelds.

Packaging Lesson Bundles
Packaging lesson bundles creates a “package” folder with a .tilb file. This file contains
all files contained in the lesson bundle. You must package the lesson before you can
email the lesson bundle (.tilb file) to colleagues or students. By default, the lesson
bundle is saved in the following folder:
...\TI-Nspire\New Lesson Bundle1.tilb\package\...

Packaging a Lesson in the Documents Workspace

1. Open the Content Explorer.

2. Navigate to the folder where the lesson bundle is saved.



3. Select the lesson bundle you want to package.

4. Right-click to open the context menu, and then click Package Lesson.

The Lesson Bundle dialogue box opens confirming that the .tilb file was created and
the lesson bundle was successfully packaged.

5. Click Yes to open the folder where the lesson package is stored. Click No to close
the dialogue box.

Packaging a Lesson in the Contents Workspace

1. In Computer Content, navigate to the folder that contains the lesson bundle you
want to package.

2. Click the lesson bundle in the Content pane. The Lesson Bundle details are
displayed in the Preview pane.

3. Use one of the following methods to create the package:

• From the Preview pane, click ¢ in the Files dialogue box, and then click Package
Lesson Bundle.

• From the Content pane, right-click the lesson bundle name, and then click
Lesson Bundles > Package Lesson Bundle.

The Lesson Bundle dialogue box opens confirming that the lesson bundle was
created.

4. Click Yes to open the folder where the lesson package is stored. Click No to close
the dialogue box.

Emailing a Lesson Bundle
After a lesson bundle is packaged, you can email the .tilb file to other teachers or
students. To attach the lesson bundle to an email:

1. In your email client, select the option needed to attach a file, and then navigate to
the .tilb folder.

2. Make sure you open the folder and select the .tilb file to attach to the email. You
cannot email the .tilb folder.

Sending Lesson Bundles to Connected Handhelds
1. Complete one of the following actions to select a lesson bundle:

• In the Documents Workspace, open the Content Explorer, and then select the
lesson bundle you want to send.

• In the Content Workspace, navigate to the lesson you want to send in the
Content pane.
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2. Drag the lesson bundle file to a connected handheld. You can also copy the lesson
bundle, and then paste it to a connected handheld.

The lesson bundle is transferred to the handheld as a folder with the same name. Only
.tns files are transferred to the handheld.



Capturing Screens
Screen Capture enables you to:

• Capture Page

- Capture the active page in a TI-Nspire™ document from the software or from
the TI-SmartView™ emulator as an image.

- Save captured images as .jpg, .gif, .png or .tif files, which can be inserted into TI-
Nspire™ applications that allow images.

- Copy and paste images into another application such as Microsoft® Word.

• Capture Selected Handheld

- Capture the current screen on a connected handheld as an image.
- Save captured images as .jpg, .gif, .png or .tif files, which can be inserted into TI-

Nspire™ applications that allow images.
- Copy and paste images into another application such as Microsoft® Word.

• Capturing Images in Handheld Mode

- In the Documents Workspace, use the DragScreen feature to capture the
emulator screen or side screen when the TI-SmartView™ Emulator is active.

- Teachers can use this feature to drag and paste an image to presentation tools
such as SMART® Notebook, Promethean’s Flipchart and Microsoft® Office
applications including Word and PowerPoint®.

For web-based connectivity using your TI-Nspire™ CX II with a Chromebook, Windows®
computer, or Mac® computer, go to TI-Nspire™ CX II Connect.

Accessing Screen Capture
The Screen Capture tool is available from all workspaces. To access Screen Capture:

▶ From the menu bar, click Tools > Screen Capture.

▶ From the toolbar, click .

Using Capture Page
Use the Capture Page option to capture an image of an active page in a TI-Nspire™
document. You can save images in the following file formats: .jpg, .gif, .png and .tif.
Saved images can be inserted into TI-Nspire™ applications that allow images. The image
is also copied to the Clipboard and can be pasted into other applications such as
Microsoft® Word or PowerPoint®.

Capturing a Page

Complete the following steps to capture an image of an active page.

1. In the Documents Workspace, open a document and navigate to the page you want
to capture to make it active.
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2. Click , and then click Capture Page.

The image of the active page is copied to the Clipboard and to the Screen Capture

window. The dialogue box opens in the lower right corner
of your desktop when the screen capture is complete.

3. Click View it.

The Screen Capture window opens.

You can also clickWindow > Screen Capture Window to open the Screen Capture
window.

4. To capture additional pages, move to another page in the current document or
open a new document to select a page.

As you capture additional pages, the images are copied to the Screen Capture
window, which holds multiple images. The last page captured replaces the contents
of the Clipboard.

Using Capture Selected Handheld
Use the Capture Selected Handheld option to capture the active screen on a connected
handheld.

1. On a connected handheld, navigate to the menu or to a page in a document you
want to capture.

2. In the software, select the connected handheld:



• In the Content Workspace, select the handheld from the list of Connected
Handhelds in the Resources pane.

• In the Documents Workspace, open Content Explorer from the Documents
Toolbox, and then select the handheld from the list of Connected Handhelds.

• In the Class Workspace, select a logged in student.

3. Click , and then click Capture Selected Handheld.

—or—

Click , and then click Capture Selected Handheld.

The screen is copied to the Clipboard and to the TI-Nspire™ Screen Capture

window. The dialogue box opens in the lower right corner
of your desktop when the screen capture is complete.

4. Click View it.

The Screen Capture window opens.

You can capture additional screens from an open document on a connected
handheld or open another document on a connected handheld to capture screens
from that document.

As you capture additional screens, the images are copied to the Screen Capture
window, which holds multiple images. The last screen captured replaces the
contents of the Clipboard.

Viewing Captured Screens
When you capture a page or screen, it is copied to the Screen Capture window.
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Zooming the View of Captured Screens

In the Screen Capture window, use the zoom in and zoom out options to increase or
decrease the size of the captured screens.

▶ From the toolbar, click to increase the size of the screens in the view. You can
also click View > Zoom In from the menu.

▶ From the toolbar, click to decrease the size of the screens in the view. You can
also click View > Zoom Out from the menu.

Saving Captured Pages and Screens
You can save captured pages and screens captured as images for use in other TI-
Nspire™ documents that allow images or for use in other applications such as
Microsoft® Word. You can save one image at a time, select multiple images to save or
save all captured images.

Saving Selected Screens

1. In the Screen Capture window, select the screen image you want to save.

2. Click File > Save Selected Screen(s).

Note: From the Screen Capture window, you can also click .

The Save as dialogue box opens.



3. Navigate to the folder on your computer where you want to save the file.

4. Type a name for the file.

Note: The default file name isMM-DD-YYYY Image ###.

5. Select the file type for the image file. The default format is .jpg. Click ¤ to select
another format: .gif, .tif or .png.

6. Click Save.

The file is saved in the designated folder.

Saving Multiple Screens

1. In the Screen Capture window, select the screens you want to save.

To select multiple consecutive screens, click the first image, and then hold down
the Shift key and click the additional images. To select screens in random order,
press Ctrl (Mac®: “) and click each image you want to save.

2. Click or select File > Save Selected Screen(s). To save all captured screens, select
File > Save All Screens.

Note: The "Save All Screens" option is not available when using Capture Class.

The Save as dialogue box opens.

3. In the Save In field, navigate to the folder where you want to save the images.

4. In the File Name field, type a new folder name. The default folder name isMM-DD-
YYYY Image, whereMM-DD-YYYY is the current date.

5. Select the file type for the image files. The default format is .jpg. Click ¤ to select
another format: .gif, .tif, or .png.

6. Click Save.
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The images are saved in the specified folder with system-assigned names reflecting
the current date and a sequence number. For example,MM-DD-YYYY Image
001.jpg,MM-DD-YYYY Image 002.jpg and so on.

Copying and Pasting a Screen
You can select a captured screen and copy it to the Clipboard for inclusion into other
documents or applications. You can also print copied screens. Copied screens are
captured at 100% zoom level, and they are copied in the order of selection.

Copying a Screen

1. Select the screen to copy.

2. Click or Edit > Copy.

The selected screen is copied to the Clipboard.

Pasting a Screen

Depending on the application you are pasting to, click Edit > Paste.

Note: You can also drag a screen capture to another application. This functions as a
copy and paste.

Capturing Images in Handheld Mode
In the Documents Workspace, use the DragScreen feature to capture the emulator
screen or side screen when the TI-SmartView™ Emulator is active.

Teachers can use this feature to drag and paste an image to presentation tools such as
SMART® Notebook, Promethean’s Flipchart and Microsoft® Office applications
including Word and PowerPoint®.

Capturing Images Using the DragScreen Feature

Complete the following steps to capture an image and copy it to a third-party
application.

1. From the Documents Workspace, click , which is located in the Documents
Toolbox.

The TI-SmartView™ Emulator opens.

• If the display selected is Handheld + SideScreen, the current document is shown
in the emulator and in the side screen.

• If the display selected is Keypad + SideScreen, the current document is shown in
the side screen.



2. To start the screen capture, click the area above the emulator screen or above the
keypad. In the Handheld + SideScreen display, you can also click the area around the
emulator screen.

Do not release the mouse button. If the cursor is active or if you click inside the
emulator window, the screen capture is not started.

In Handheld + SideScreen view, click
the area above the emulator, click the
area around the emulator or click the
border of the emulator screen to start
the screen capture.

In Keypad + SideScreen view, click the
area above the keypad to start the
screen capture.

3. Without releasing the mouse, drag the image.

A ghost image of the captured screen opens. The ghost image remains visible until
you release the mouse button.

The in the corner of the ghost image indicates you cannot paste the image in
that location.
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4. Drag the image to an open third-party application. When the image is on top of the

third-party application, the indicates you can drop the image.
5. Release the mouse button to drop the image into the selected application.

The image is also copied to the Clipboard and to the TI-Nspire™ Screen Capture
window.

To view captured images in the Screen Capture window, clickWindow > Screen
Capture Window.

You can capture additional screens as needed. As you capture additional screens,
the images are copied to the Screen Capture window, which holds multiple images.
The last screen captured replaces the contents of the Clipboard.



Working with Images
Images can be used in TI-Nspire™ applications for reference, assessment and
instructional purposes. You can add images to the following TI-Nspire™ applications:

• Graphs & Geometry

• Data & Statistics

• Notes

• Question, including Quick Poll

In the Graphs & Geometry and Data & Statistics applications, images are set in the
background behind the axis and other objects. In the Notes and Question applications,
the image is set at the cursor location in-line with the text (in the foreground).

You can insert the following image file types: .jpg, .png or .bmp.

Note: The transparency feature of a .png file type is not supported. Transparent
backgrounds are displayed as white.

Working with Images in the Software
When working in the TI-Nspire™ software, you can insert, copy, move and delete
images.

Inserting Images

In the Notes and Question applications, and in Quick Poll, you can insert more than one
image on a page. You can only insert one image on a page in the Graphs & Geometry
and Data & Statistics applications.

1. Open the document where you want to add an image.

2. Click Insert > Image.

The Insert Image dialogue box opens.
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3. Navigate to the folder where the image is located and select the image.

4. Click Open.

• In the Graphs & Geometry and Data & Statistics applications, the image is
inserted in the background behind the axis.

• In Notes, Question and Quick Poll, the image is inserted at the cursor location.
You can type text above or below the image, and you can move the image up or
down on the page.

Note: You can also insert images by copying an image to the Clipboard and pasting it
into the application.

Moving Images

In applications such as Notes and Question where the image is set at the cursor
location, you can reposition the image by moving the image to a new line or blank
space, or by placing the image within a line of text. In the Graphs & Geometry and Data
& Statistics applications, images can be moved to any position on the page.

1. Select the image.

• In the Notes and Question applications, click the image to select it.
• In the Graphs & Geometry and Data & Statistics applications, right-click the

image and then click Select > Image.

2. Click the selected image and hold the mouse button.

• If an image is in the foreground, the cursor changes to .

• If an image is in the background, the cursor changes to .



3. Drag the image to the new location and release the mouse button to place the
image.

If an image is in the foreground, the cursor changes to when you hover your
mouse pointer over a location where there is a new line or space. Images in the
background can be moved and placed anywhere on the page.

Resizing Images

To retain the aspect ratio of an image, resize by grabbing the image at one of the four
corners.

1. Select the image.

• In the Notes and Question applications, click the image to select it.
• In the Graphs & Geometry and Data & Statistics applications, right-click the

image and then click Select > Image.

2. Move the cursor to one of the corners of the image.

The cursor changes to (a four-sided directional arrow).

Note: If you drag the cursor to an edge of the image, the cursor changes to (a
two-sided directional arrow). If you drag an image from one of its edges to resize it,
the image becomes distorted.

3. Click the corner or edge of the image.

The tool is enabled.

4. Drag in to make the image smaller or drag out to make the image larger.

5. Release the mouse when the image size is correct.

Deleting Images

To delete an image from an open document, complete the following steps.

1. Select the image.

• If an image is in the foreground, click the image to select it.
• If an image is in the background, right-click the image and then click Select >

Image.

2. Press Delete.

The image is removed.
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Responding to Questions
The teacher may send you a question in a variety of format types. This section shows
you how to answer the different question types.

Understanding the Question Toolbar
When you open a document with a question, a toolbar is available with four options.
Access the toolbar using the following method.

▶ In the Documents Toolbox, click .

Handheld, pressb.

Tool name Tool function

Clear
Answers

Lets you clear the answers in the current question or in
the document.

Check
Answer

If your document is in Self-Check mode, click here to
view the correct answer. You cannot check answers to
exam-type questions.

Insert Lets you insert an expression box in your answer.

Format Click this tool to format the selected text in your
answer as subscript or superscript.

Types of Questions
There are several types of questions you may be asked. There may be variations in a
type but how you answer the question is basically the same for each type.

• Multiple choice

- Custom
- ABCD
- True/False
- Yes/No
- Always/Sometimes/Never
- Agree/Disagree
- Strongly Agree…Strongly Disagree

• Open response

- Explanation
- Text match

• Equation



- y=
- f(x)=

• Coordinate points and list

- (x,y) numerical input
- Drop point(s)
- List(s)

Responding to Quick Poll Questions
When teachers send quick polls during class, the question opens as a new document on
top of any document you may currently have open. You can access other applications
to perform calculations, and check or clear answers before submitting your answer to
the question or quick poll.

Note: On TI-Nspire™ CX or TI-Nspire™ CX CAS handhelds, questions appear in colour if
the teacher applied colour when writing the question. Although you can see colour in
the questions you receive, you cannot add colour to the responses you submit.

Accessing Other Applications

If the teacher gives permission, the Quick Poll tool allows you to temporarily exit the
question to perform calculations or access other documents to determine the answer
to the question. For example, you can access the Scratchpad to perform a calculation,
or you can access the Lists & Spreadsheet application and copy data from there to a List
question type. In a List question, you can link to variables from the Vernier DataQuest™
or Lists & Spreadsheet applications.

To access other applications while in the Quick Poll screen:

1. Open a new document.

Handheld: Pressc to open the Home screen.

2. Choose an application.

Handheld: To return to the Quick Poll without accessing any documents, choose
C: Quick Poll.

3. When you are finished, click the Quick Poll icon.

When you respond to a poll, your response is immediately sent to the teacher’s
computer and teachers can track student responses in real time.

Showing Your Work

The teacher may request you to show work for your response. If so, the response area
has sections for you to write your starting point, your steps, and the final answer.

Responding to Different Question Types

▶ For Multiple Choice questions, press Tab to navigate to a response. Press Enter to
mark a response.

▶ For Open Response questions, type a response.
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▶ For Equation questions, type a response. If a graph is included in a question, the
graph updates when you press Enter. Any functions entered show up on the graph,
and the cursor remains in the answer box. You cannot manipulate the graph itself.

▶ For Expression questions, type a response. If the response type is Number, your
response must be in the form of a number. If the response type is Expression, your
response must be in the form of an expression. For example, x+1.

▶ For Coordinate Points: (x,y) questions, type an answer in the x-field box, and press
Tab to move to the y-field box. Type an answer.

If a graph is included with the question, the graph is updated when you enter a
function and press Enter.

You can access the Window and Zoom functions while you are working on the
graph.

▶ For Coordinate Points: Drop Points questions, press Tab to move the cursor to a
point on the graph. Press Enter to drop a point at that location.

To delete a point, press Ctrl + Z to undo the action.

▶ For Lists questions, press Tab if necessary to move the cursor to the first cell of the
list. Type an answer, and press Tab to move to the next cell. Type an answer.

To link a column to an existing variable, select the column and then click var. Click
Link To, and then click the variable you want to link to.

The behaviour in a Lists question closely matches the behaviour of the Lists &
Spreadsheet application, with the following exceptions. In a Lists question, you
cannot:

• Add, insert, or delete columns.
• Change the header row.
• Enter formulas.
• Switch to Table.
• Create plots.

▶ For Chemistry questions, type a response.

▶ For Image: Label questions, press Tab to move the cursor to a label on the image.
Type a response in the label field.

▶ For Image: Point on questions, press Tab to move the cursor to a point on the
image. Press Enter to mark a response.

Checking Answers

If the teacher enables self-check on the question, the Check Answer option is available.

1. Click .

Handheld: Pressb.



2. Click Check Answer.

Clearing Answers

After you answer a quick poll, you may decide you want to change the answer before
you submit it.

▶ ClickMenu > Clear Answers > Current Question or Document.

• Current Question clears answers for the active question.
• Document clears answers for all questions contained in the active document.

—or—

If you answered the question, you still have time to clear the answer before you submit
it to your teacher.

▶ Click Clear Answer to clear your answer and try again.

Handheld: Press~ and choose Clear Answer.

Submitting Responses
To send a final answer to the teacher:

▶ Click Submit Response.

Handheld: Press~ and choose Submit.

The response is sent to the teacher and the last screen you used is displayed.

Your response appears on the teacher’s computer. Your teacher may have set the poll
to allow you to submit more than one answer. If so, you can continue to respond to the
poll and submit answers until the teacher stops the poll.

Responding to Questions 73



74 Calculator Application

Calculator Application
The Calculator application lets you:

• Enter and evaluate maths expressions

• Define variables, functions, and programmes that become available to any TI-
Nspire™ application—such as the Graphs application—residing in the same
problem.

• Define library objects, such as variables, functions, and programmes, which are
accessible from any problem of any document. For information on creating library
objects, see Libraries.

Adding a Calculator Page

▶ To start a new document with a blank Calculator page:

From the main Filemenu, click New Document, and then click Add Calculator.

Handheld: Pressc, and select Calculator .

▶ To add a Calculator page in the current problem of an existing document:

From the toolbar, click Insert > Calculator.

Handheld: Press~ and select Insert > Calculator.

À Calculator menu. This menu is available anytime you are in the Calculator work area
using the Normal view mode. The menu in this screen snapshot may not exactly match
the menu on your screen.

Á Calculator work area

• Enter a maths expression on the entry line, and then press Enter to evaluate
the expression.

• Expressions are displayed in standard mathematical notation as you enter
them.

• Entered expressions and results show in the Calculator history.
Â Example of Calculator variables used in another application.



Entering and Evaluating Maths Expressions

Entering Simple Maths Expressions

Note: To enter a negative number on the handheld, pressv. To enter a negative
number on a computer keyboard, press the hyphen key (-).

Suppose you want to evaluate

1. Select the entry line in the Calculator work area.

2. Type 2^8 to begin the expression.

3. Press► to return the cursor to the baseline.

4. Complete the expression:

Type *43/12.

Handheld: Typer 43p 12.

5. Press Enter to evaluate the expression.

The expression is displayed in standard mathematical notation, and the result is
displayed on the right side of the Calculator.

Note: If a result does not fit on the same line with the expression, it is displayed on the
next line.

Controlling the Form of a Result

You might expect to see a decimal result instead of 2752 ⁄ 3 in the preceding example.
A close decimal equivalent is 917.33333..., but that’s only an approximation.

By default, Calculator retains the more precise form: 2752 ⁄ 3. Any result that is not a
whole number is shown in a fractional or exact (Exact Arithmetic and CAS) form, or
symbolic form (CAS). This reduces rounding errors that could be introduced by
intermediate results in chained calculations.
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You can force a decimal approximation in a result:

• By pressing shortcut keys.

Windows®: Press Ctrl+Enter to evaluate the expression.

Mac®: Press “+Enter to evaluate the expression.

Handheld: Press/· instead of· to evaluate the expression.

Pressing/· forces the approximate result.

• By including a decimal in the expression (for example, 43. instead of 43).

• By wrapping the expression in the approx() function.

• By changing the document’s Auto or Approximatemode setting to Approximate.

From the Filemenu, click Settings > Document Settings.

Handheld: Press~ to display the Filemenu.

Note that this method forces all results in all of the document’s problems to
approximate.

Inserting Items from the Catalogue

You can use the Catalogue to insert system functions and commands, symbols, and
expression templates into the Calculator entry line.

1. Click the Utilities tab, and then click to open the Catalogue.

Handheld: Pressk 1.



Note: Some functions have a wizard that prompts you for each argument. Those
functions are shown with an indicator. To receive the prompts, select Wizards On.

2. If the item you are inserting is visible in the list, select it and press Enter to insert it.

3. If the item is not visible:

a) Click inside the list of functions, and then press a letter key to jump to the
entries that begin with that letter.

b) Press▲ or ▼ as necessary to highlight the item you are inserting.

Help, such as syntax information or a short description of the selected item,
appears at the bottom of the Catalogue.

c) Press Enter to insert the item into the entry line.

Using an Expression Template

The Calculator has templates for entering matrices, piecewise functions, systems of
equations, integrals, derivatives, products, and other maths expressions.

For example, suppose you want to evaluate

1. On the Utilities tab, click to open the templates.
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Handheld: Presst.

2. Double-click to insert the algebraic sum template.

The template appears on the entry line with small blocks representing elements
that you can enter. A cursor appears next to one of the elements to show that you
can type a value for that element.

3. Use the arrow keys to move the cursor to each element’s position, and type a value
or expression for each element.

4. Press Enter to evaluate the expression.

Creating Matrices

1. On the Utilities tab, click to open the templates.

Handheld: Presst.

2. Double-click .

The Create a Matrix dialogue box opens.

3. Type the Number of rows.



4. Type the Number of columns, and then click OK.

Calculator opens a template with spaces for the rows and columns.

Note: If you create a matrix with a large number of rows and columns, it may take a
few moments to appear.

5. Type the matrix values into the template, and then press Enter to define the matrix.

Inserting a Row or Column into a Matrix

▶ To insert a new row, hold down Alt and press Enter.

▶ To insert a new column, hold down Shift and press Enter.

Handheld:

▶ To insert a new row, press@.

▶ To insert a new column, press Shift+Enter.

Inserting Expressions Using a Wizard

You can use a wizard to simplify entering some expressions. The wizard contains
labelled boxes to help you enter the arguments in the expression.

For example, suppose you want to fit a y = mx + b linear regression model to the
following two lists:

{1,2,3,4,5}
{5,8,11,14,17}

1. On the Utilities tab, click to open the Catalogue.

Handheld: Pressk 1.

2. Click an entry in the Catalogue, and then press L to jump to the entries that begin
with “L.”

3. Press▼ as necessary to highlight LinRegMx.

4. Select theWizards On option, if it is not already selected:

Handheld: Press Tab Tab to highlightWizards On, press Enter to change the setting,
and then press Tab Tab to highlight LinRegMx again.

5. Press Enter.

A wizard opens, giving you a labelled box to type each argument.
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6. Type {1,2,3,4,5} as X List.

7. Press Tab to move to the Y List box.

8. Type {5,8,11,14,17} as Y List.

9. If you want to store the regression equation in a specific variable, press Tab, and
then replace Save RegEqn To with the name of the variable.

10. Click OK to close the wizard and insert the expression into the entry line.

Calculator inserts the expression and adds statements to copy the regression
equation and show the variable stat.results, which will contain the results.

LinRegMx {1,2,3,4,5},{5,8,11,14,17},1: CopyVar stat.RegEqn,f2: stat.results

Calculator then shows the stat.results variables.

Note: You can copy values from the stat.results variables and paste them into the
entry line.

Creating a Piecewise Function

1. Begin the function definition. For example, type the following expression:



Define f(x,y)=

2. On the Utilities tab, click to open the templates.

Handheld: Presst.

3. Double-click .

The Create Piecewise Function dialogue box opens.

4. Type the Number of Function Pieces, and click OK.

Calculator opens a template with spaces for the pieces.

5. Type the expressions into the template, and press Enter to define the function.

6. Enter an expression to evaluate or graph the function. For example, type the
expression f(1,2) on the Calculator entry line.

Creating a System of Equations

1. On the Utilities tab, click to open the templates.

Handheld: Presst.

2. Double-click .

The Create a System of Equations dialogue box opens.

3. Type the Number of Equations, and click OK.

Calculator opens a template with spaces for the equations.

4. Type the equations into the template, and press Enter to define the system of
equations.
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Entering Multiple Statements on the Entry Line

To enter several statements on a single line, separate them with a colon (“:”). Only the
result of the last expression is shown.

CAS: Working with Measurement Units
A list of pre-defined constants and measurement units is available in the Catalogue.
You can also create your own units.

Note: If you know a unit’s name, you can type the unit directly. For example, you can
type _qt to specify quarts. To type the underscore symbol on the handheld, press
/_.

CAS: Converting Between Measurement Units

You can convert a value between any two units within the same category (such as
length).

Example: Using the Catalogue, convert 12 metres to feet. The desired expression is
12•_m►_ft.

1. Type 12 on the entry line.

2. On the Utilities tab, click to show the unit conversions.

Handheld: Pressk 3.



3. Click the Length category to expand the list of pre-defined length units.

Handheld: Scroll to the Length category, and press Enter.

4. Scroll tometre.

Handheld: Scroll to _m (noting themetre hint in the Help window).

5. Press Enter to paste _m to the entry line.

6. Click the Conversion Operator (►) at the top of the Units list, and press Enter to
paste it to the entry line.

7. Select _ft from the Length category, and press Enter.

8. Press Enter to evaluate the expression.

CAS: Creating a User-defined Unit

As with the pre-defined units, user-defined unit names must begin with an underscore
symbol.

Example: Using the pre-defined units _ft and _min, define a unit named _fpm that lets
you enter velocity values in feet per minute and convert velocity results to feet per
minute.
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Now you can use the new velocity unit _fpm.

Using the Unit Conversion Assistant
In any application where maths input is allowed, you can generate unit conversions
using the Unit Conversion Assistant. This can help reduce syntax errors by automatically
entering the units for you.

Example: Convert 528 minutes to hours. The desired expression is 528•_min►_hr.

1. Type 528 on the entry line.

2. On the Utilities tab, click the Unit Conversions bar.

Handheld: Pressk3.

3. Click the Open button next to Conversion Assistant.

Handheld: Press·.

The Unit Conversion Assistant dialogue box displays:



4. Click the Category list and select Time.

Handheld: Scroll to the Time category and press·.

5. Click the From list and selectmin (minute).

Handheld: Scroll tomin (minute) and press·.

Note: You can select Use existing unit at the bottom of the list if you have already
entered a unit. In this example, you might have already entered 528•_min.

6. Click the To list and select hr (hour).

Handheld: Scroll to hr (hour) and press·.
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7. Click OK to paste _min►_hr to the entry line.

8. Press Enter to evaluate the expression.

Handheld: Press·.

Note:

• The last Category, From, and To selections will be retained until:

- the software is closed and re-opened (Desktop)
- the device is reset (Handheld)
- the language is changed, or the app is uninstalled or upgraded (iPad)

• Inserting a conversion into a Notes text field will automatically create a Maths Box.

• Inserting a conversion into an empty line in the Calculator will automatically insert
Ans before the conversion.

Working with Variables
When you first store a value in a variable, you give the variable a name.

• If the variable does not already exist, Calculator creates it.

• If the variable already exists, Calculator updates it.

Variables within a problem are shared by TI-Nspire™ maths and science learning
technology applications. For example, you can create a variable in Calculator and then
use or modify it in Graphs & Geometry or Lists & Spreadsheet within the same
problem.

For more information, see Using Variables.



Creating User-defined Functions and Programmes
You can use the Define command to create your own functions and programmes. You
can create them in the Calculator application or in the Programme Editor and then use
them in other TI-Nspire™ applications.

For more information, see Overview of the Programme Editor and Libraries.

Defining a Single-line Function

Suppose you want to define a function named cube() that calculates the cube of a
number or variable.

1. On the Calculator entry line, type Define cube(x)=x^3 and press Enter.

The message “Done” confirms that the function has been defined.

2. Type cube(2) and press Enter to test the function.

Defining a Multiple-line Function Using Templates

You can define a function consisting of multiple statements entered on separate lines.
A multiple-line function may be easier to read than one with multiple statements
separated by colons.

Note: You can create multiple-line functions only by using the Define command. You
cannot use the := or→ operators to create multiple-line definitions. The Func...EndFunc
template serves as a container for the statements.

As an example, define a function named g(x,y) that compares two arguments x and y. If
argument x > argument y, the function should return the value of x. Otherwise, it
should return the value of y.

1. On the Calculator entry line, type Define g(x,y)=. Do not press Enter yet.

2. Insert the Func...EndFunc template.

From the Functions & Programmesmenu, select Func...EndFunc.

Calculator inserts the template.
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3. Insert the If...Then...Else...EndIf template.

From the Functions & Programmesmenu, select Control, and then select
If...Then...Else...EndIf.

Calculator inserts the template.

4. Type the remaining parts of the function, using the arrow keys to move the cursor
from line to line.

5. Press Enter to complete the definition.

6. Evaluate g(3,-7) to test the function.

Defining a Multiple-line Function Manually

Within a multi-line template such as Func...EndFunc or If...EndIf, you can start a new
line without completing the definition.

• Handheld: Press@ instead of·.

• Windows®: Hold Alt and press Enter.



• Macintosh®: Hold Option and press Enter.

As an example, define a function sumIntegers(x) that calculates the cumulative sum of
integers from 1 to x.

1. On the Calculator entry line, type Define sumIntegers(x)=. Do not press
Enter yet.

2. Insert the Func...EndFunc template.

From the Functions & Programmesmenu, select Func...EndFunc.

Calculator inserts the template.

3. Type the following lines, pressing@ or Alt+Enter at the end of each line.

4. After typing Return tmpsum, press Enter to complete the definition.

5. Evaluate sumIntegers(5) to test the function.

Defining a Programme

Defining a programme is similar to defining a multiple-line function. The
Prgm...EndPrgm template serves as a container for the programme statements.
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As an example, create a programme named g(x,y) that compares two arguments. Based
on the comparison, the programme should show the text “x>y” or “x≤y” (showing the
values of x and y in the text).

1. On the Calculator entry line, type Define prog1(x,y)=. Do not press Enter
yet.

2. Insert the Prgm...EndPrgm template.

From the Functions & Programmesmenu, select Prgm...EndPrgm.

3. Insert the If...Then...Else...EndIf template.

From the Functions & Programmesmenu, select Control, and then select
If...Then...Else...EndIf.

4. Type the remaining parts of the function, using the arrow keys to move the cursor
from line to line. Use the Symbol Palette to select the "≤“ symbol.

5. Press Enter to complete the definition.

6. Execute prog1(3,-7)to test the programme.



Recalling a Function or Programme Definition

You might want to reuse or modify a function or programme that you have defined.

1. Show the list of defined functions.

From the Actionsmenu, select Recall Definition.

2. Select the name from the list.

The definition (for example, Define f(x)=1/x+3) is pasted into the entry line
for editing.

Editing Calculator Expressions
Although you cannot edit an expression in the Calculator history, you can copy all or
part of an expression from the history and paste it to the entry line. You can then edit
the entry line.

Positioning the Cursor in an Expression

▶ Presse, ¡, ¢,£ or¤ to move the cursor through the expression. The cursor
moves to the closest valid position in the direction that you press.

Note: An expression template may force the cursor to move through its parameters,
even though some parameters may not be exactly in the path of the cursor movement.
For example, moving upward from the main argument of an integral always moves the
cursor to the top limit.

Inserting into an Expression in the Entry Line

1. Position the cursor at the point where you want to insert additional elements.

2. Type the elements that you want to insert.

Note:When you insert an open parenthesis, Calculator adds a temporary close
parenthesis, displayed in gray. You can override the temporary parenthesis by typing
the same parenthesis manually or by entering something past the temporary
parenthesis (thereby implicitly validating its position in the expression). After you
override the temporary gray parenthesis, it is replaced with a black parenthesis.

Selecting Part of an Expression

1. Position the cursor at the starting point in the expression.

Handheld: Press ¡, ¢,£ or¤ to move the cursor.
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2. Press and holdg, and then press ¡, ¢,£ or¤ to select.

Deleting all or part of an expression on the entry line

1. Select the part of the expression to delete.

2. Press..

Financial Calculations
Several TI-Nspire™ functions provide financial calculations, such as time value of
money, amortisation calculations, and return on investment calculations.

The Calculator application also includes a Finance Solver. It lets you dynamically solve
several types of problems, such as loans and investments.

Using the Finance Solver

1. Open the Finance Solver.

From the Financemenu, click Finance Solver.

The Finance Solver displays its default values (or previous values, if you have
already used the solver in the current problem).

2. Enter each known value, usinge to cycle through the items.

• The help information at the bottom of the Finance Solver describes each item.
• You might need to temporarily skip the value that you want to calculate.
• Make sure to set PpY, CpY and PmtAt to the correct settings (12, 12 and END in

this example).

3. Presse as necessary to select the item that you want to calculate, and then
press·.

The Finance Solver calculates the value and stores all the values in “tvm.” variables,
such as tvm.n and tvm.pmt. These variables are accessible to all TI-Nspire™
applications within the same problem.



Finance Functions Included

In addition to the Finance Solver, TI-Nspire™ built-in finance functions include:

• TVM functions for calculating future value, present value, number of payments,
interest rate and payment amount.

• Amortisation information such as amortisation tables, balance, sum of interest
payments and sum of principal payments.

• Net present value, internal rate of return and modified rate of return.

• Conversions between nominal and effective interest rates, and calculation of days
between dates.

Notes:

• Finance functions do not automatically store their argument values or results to the
TVM variables.

• For a complete list of TI-Nspire™ functions, see the Reference Guide.

Working with the Calculator History
As you enter and evaluate expressions in the Calculator application, each entry/result
pair is saved in the Calculator history. The history gives you a way to review your
calculations, repeat a set of calculations, and copy expressions for reuse in other pages
or documents.

Viewing the Calculator History

Note: You may notice a processing slowdown when the history contains a large number
of entries.

▶ Press▲ or▼ to scroll through the history.
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Copying a Calculator History Item to the Entry Line

You can quickly copy an expression, subexpression, or result from the history into the
entry line.

1. Press▲ or▼ to move through the history and select the item that you want to
copy.

—or—

Select part of the expression or result by using Shift in combination with the arrow
keys.

Note: The float setting for the current document may limit the number of decimal
places displayed in a result. To capture the result in its full precision, select it either
by scrolling with the up and down arrow keys or by triple-clicking it.

2. Press Enter to copy the selection and insert it into the entry line.



Copying a History Item to Another Application

1. Press▲ or▼ to move through the history and select the item that you want to
copy.

2. Optionally, select part of the expression or result by pressing Shift in combination
with the arrow keys.

3. Use the standard key shortcut for copying a selection.

Windows®: Press Ctrl+C.

Mac®: Press “+C.

Handheld: Press/C.

4. Place the cursor at the location where you want the copy.

5. Paste the copy.

Windows®: Press Ctrl+V.

Mac®: Press “+V.

Handheld: Press/V.

Note: If you copy an expression that uses variables into a different problem, the values
of those variables are not copied. You must define the variables in the problem where
you paste the expression.

Deleting an Expression from the History

When you delete an expression, all variables and functions defined in the expression
retain their current values.

1. Drag or use the arrow keys to select the expression.

Handheld: Use the arrow keys.

2. Press Del.

The expression and its result are removed.
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Clearing the Calculator History

When you clear the history, all variables and functions defined in the history retain
their current values. If you clear the history by mistake, use the undo feature.

▶ From the Actionsmenu, select Clear History.

All expressions and results are removed from the history.



Using Variables
A variable is a defined value that can be used multiple times in a problem. You can
define a value or function as a variable within each application. Within a problem,
variables are shared by TI-Nspire™ applications. For example, you can create a variable
in Calculator, and then use or modify it in Graphs & Geometry or Lists & Spreadsheet
within the same problem.

Each variable has a name and a definition and the definition can be changed. When you
change the definition, all occurrences of the variable in the problem are updated to use
the new definition. In the TI-Nspire™ software, a variable has four attributes:

• Name - User-defined name assigned when the variable is created.

• Location - Variables are stored in memory.

• Value - Number, text, mathematical expression or function.

• Type - Type of data that can be stored as a variable.

Note: Variables created with the Local command within a user-defined function or
programme are not accessible outside that function or programme.

Linking Values on Pages
Values and functions created or defined in one application can interact with other
applications (within the same problem) to share data.

When using linked items, keep in mind:

• Values can be linked between applications on one page or between different pages
of the same problem.

• All applications are linked to the same data.

• If the linked value is changed in the original application, the change is reflected in
all linked usages.

Defining a variable is the first step in linking values.

Creating Variables
Any portion or attribute of an object or function created within an application can be
stored as a variable. Examples of attributes that can become variables are the area of a
rectangle, the radius of a circle, the value contained in a spreadsheet cell or the
contents of a row or column or a function expression. When you create a variable, it is
stored in memory.

Types of Variables

You can store the following data types as variables:
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Data type Examples

Expression

2.54    1.25E6    2p    xmin/10    2+3i    (xN2)

2

List {2, 4, 6, 8}    {1, 1, 2}    {"red", "blue", "green"}

Matrix

This can be entered as: [1,2,3;3,6,9]

Character string “Hello”    “xmin/10”    “The answer is:”

Function, programme myfunc( arg )    ellipse( x, y, r1, r2 )

Measurement area, perimeter, length, slope, angle

When you click or pressh on a handheld to open the list of stored variables, a
symbol indicates the type.

Creating a Variable from a Calculator Value

This example shows how to create a variable using a handheld. Complete the following
steps to create a variable named num and store the result of the expression 5+83 in
that variable.

1. On the Calculator entry line, type the expression 5+8^3.

2. Press ¢ to expand the cursor to the baseline.

3. Press/h and then type the variable name num.

This means: Calculate 5+83 and store the result as a variable named num.

4. Press·.

Calculator creates the variable num and stores the result there.



Creating a Variable in the Computer Software

When creating a variable in the computer software, use the following conventions. As
alternatives to using & (store), you can use “:=” or the Define command. All of the
following statements are equivalent.

5+83 & num

num := 5+83

Define num=5+83

Checking a Variable’s Value

You can check the value of an existing variable by entering its name on the Calculator
entry line. When you type the name of a stored variable, it appears in bold type.

▶ On the Calculator entry line, type the variable name num and press·.

The value most recently stored in num is displayed as the result.

Automatically Creating Variables in Graphs & Geometry

In the Graphs and Geometry applications, functions defined on the entry line are
automatically stored as variables.

In this example, f1(x)=x3 is a variable definition, which allows it to be displayed in other
applications including a table in the Lists & Spreadsheet application.

Creating a Variable from a Graphs & Geometry Value

1. Click the value to store as a variable.

2. Click .
Handheld: Pressh.
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The Variables options are displayed with Store Var highlighted.

3. Press·. VAR := appears before the selected value. This is the default name.

4. Replace the default name VAR with the variable name you want to give the value.

5. When the variable name is typed, press·.

The value is saved to that variable name and the stored value or its name appears
in bold text to indicate it is a stored value.



Note: You can also share a Graphs & Geometry axis end value with other applications. If
necessary, click Actions, Show/Hide Axes End Values to display the end values on the
horizontal and vertical axes. Click the number for an end value to highlight it in the
entry field. Name the variable and store it for use with other applications by using any
method described in Step 2.

Automatically Creating Variables in Lists & Spreadsheet

Naming a list at the top of a Lists & Spreadsheet column automatically stores that value
as a list variable. This variable can be used in other applications including Data &
Statistics.

Creating a Variable from a Lists & Spreadsheet Cell Value

You can share a cell value with other applications. When defining or referring to a
shared cell in Lists & Spreadsheet, precede the name with an apostrophe (‘).

1. Click the cell that you want to share.

2. Click to open the Variables menu.
Handheld: Pressh.

3. Click Store Var.

A formula is inserted into the cell with var as a placeholder for a variable name.

4. Replace the letters “var” with a name for the variable and press·.
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The value is now available as a variable to other applications within the same
problem.

Note: If a variable with the name you specified already exists in the current problem
space, Lists & Spreadsheet displays an error message.

Using (Linking) Variables
Sharing, or linking, the variables you create is a powerful tool for maths exploration.
The display of linked variables is automatically updated when the variable’s value
changes.

Linking to Shared Variables

To use a stored variable:

1. Display the page and select the location or object to which you want to link a
variable.

2. Select the Variables toolh.

The Variables options are displayed. The software knows which types of variables
will work in the location or with the object selected and will only display those
variables.

3. Use 9 and : to scroll the list.

—or—

Type part of the variable name.

As you type, the system displays a list of variables that begin with the letters you
typed. Typing part of the name enables you to locate a variable more quickly if the
list is long.

4. When you locate and highlight the name of the variable you want to use, click the
name.

—or—

Press·.

The selected variable value is linked.

Linking a Lists & Spreadsheet Cell to a Variable

When you link a cell to a variable, Lists & Spreadsheet keeps the cell value updated to
reflect the current value of the variable. The variable can be any variable in the current
problem and can be defined in Graphs & Geometry, Calculator or any instance of Lists
& Spreadsheet.

Note: Do not link to a system variable. Doing so could prevent the variable from being
updated by the system. System variables include ans, StatMatrix and statistics results
(such as RegEqn, dfError and Resid).

1. Click the cell that you want to link to the variable.



2. Open the VarLink menu:

- Click , and then click Cell.
- Handheld: Pressh.

The VarLink menu is displayed.

3. Under Link To, scroll to the name of the variable and click it.

The cell shows the value of the variable.

Using a Variable in a Calculation

After storing a value in a variable, you can use the variable name in an expression as a
substitute for the stored value.

1. Enter the expression:

- Type 4*25*num^2 on the entry line and press Enter.

- Handheld: Type 4r 25r num^2 on the entry line and press·.

Calculator substitutes 517, the value currently assigned to num and evaluates the
expression.

2. Enter the expression:

- Type 4*25*nonum^2 and press Enter.

- Handheld: Type 4r 25r nonum^2 on the entry line and press·.

CAS: Because the variable nonum has not been defined, it is treated algebraically in
the result.

Because the variable nonum has not been defined, the expression returns an error
message.
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Naming Variables
Variable and function names that you create must meet the following naming rules.

Note: In the unlikely event that you create a variable with the same name as one used
for statistical analysis or by the Finance Solver, an error condition could occur. If you
begin entering a variable name that is already in use in the current problem, the
software shows the entry in bold to let you know.

• Variable names must be in one of the forms xxx or xxx.yyy. The xxx part can have 1
to 16 characters. The yyy part, if used, can have 1 to 15 characters. If you use the
xxx.yyy form, both xxx and yyy are required; you cannot start or end a variable
name with a period “.”.

• Characters can consist of letters, digits and the underscore character (_). Letters
can be U.S. or Greek letters (but not Π or p), accented letters and international
letters.

• Do not use c or n from the symbol palette to construct a variable name such as c1
or n12. These may appear to be letters, but they are treated internally as special
symbols.

• You can use uppercase or lowercase letters. The names AB22, Ab22, aB22 and
ab22 all refer to the same variable.

• You cannot use a digit as the first character of xxx or yyy.
• You can use digits 0 through 9, U.S. letters, a - z, Latin and Greek letters (but not p)

as subscripts (for example, a2, qa, or h2o). To enter a subscript while typing a

variable name, select in the Math Templates or on the formatting toolbar.
• Do not use spaces.

• If you want a variable to be treated as a complex number, use an underscore as the
last character of the name.

• CAS: If you want a variable to be treated as a type of unit (such as _m or _ft), use an
underscore as the first character of the name. You cannot use subsequent
underscores in the name.

• You cannot use an underscore as the first character of the name.

• You cannot use a preassigned variable, function or command name, such as Ans,
min or tan.

Note: For more information about TI-Nspire™ functions, see the Reference Guide.

• Library documents and library objects are subject to additional naming restrictions.
For more information, see Libraries.

Here are some examples:

Variable names Valid?

Myvar, my.var Yes



Variable names Valid?

My var, list 1 No. Contains a space.

a, b, b12, b12, c, d Yes. Note that variables b12 and b12 are distinct.

Log, Ans No. Preassigned to a system function or variable.

Log1, list1.a, list1.b Yes

3rdTotal, list1.1 No. xxx or yyy starts with a digit.

Adjusting Variable Values with a Slider
A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes and Data & Statistics
applications.

Horizontal slider for adjusting variable v1.

Minimised vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a maths box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.
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2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, click an empty
space in the work area. You can show the handles any time by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimised slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The colour of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.

1. Display the slider's context menu.

2. Click an option to select it.



Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations or sequences that refer to undefined variables.

Locking and Unlocking Variables
Locking lets you protect variables from modification or deletion. Locking prevents
unintended changes to a variable.

Time and altitude lists can be locked to ensure
problem fidelity

Reference function f1 can be locked to
prevent unintended change

Variables you Cannot Lock

• System variable Ans
• stat. and tvm. variable groups
Important Information About Locked Variables

• To lock variables, use the Lock command.

• To modify or delete a locked variable, you must first unlock the item.

• Locked variables display a lock icon on the variable menu list.
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• The Lock command clears the Redo/Undo history when applied to unlocked
variables.

Examples of Locking

Lock a,b,c Locks variables a, b and c from the Calculator application.

Lock mystats. Locks all members of variable groupmystats.

UnLock func2 Unlocks variable func2.

lm:=getLockInfo
(var2)

Retrieves the current lock status of var2 and assigns that
value to lm in the Calculator application.

For more information, see the Reference Guide.

Updating a Variable

If you want to update a variable with the result of a calculation, you must store the
result explicitly.

Entry Result Comment
a := 2 2

a3 8 Result not stored in
variable a.

a 2

a := a3 8 Variable a updated
with result.

a 8

a2 & a 64 Variable a updated
with result.

a 64

Reusing the Last Answer

Each instance of Calculator automatically stores the last calculated result as a variable
named Ans. You can use Ans to create a chain of calculations.

Note: Do not link to Ans or any system variable. Doing so could prevent the variable
from being updated by the system. System variables include statistics results (such as
Stat.RegEqn, Stat.dfError and Stat.Resid) and Finance Solver variables (such as tvm.n,
tvm.pmt and tvm.fv).

As an example of using Ans, calculate the area of a garden plot that is 1.7 meters by 4.2
meters. Then use the area to calculate the yield per square meter if the plot produces a
total of 147 tomatoes.

1. Calculate the area:

- On the Calculator entry line, type 1.7*4.2 and press Enter.

- Handheld: On the Calculator entry line, type 1.7r 4.2 and press·.



2. Reuse the last answer to calculate the yield per square meter:

- Type 147/ans and press Enter to find the yield.

- Handheld: Type 147p ans and press· to find the yield.

3. As a second example, calculate and then add 2*log(45).
- Type 3.76/(-7.9+sqrt(5)) and press Enter.

- Handheld: Type 3.76p (v7.9+sqrt(5)) and press·.

4. Reuse the last answer:

- Type ans+2*log(45) and press Enter.

- Handheld: Type ans+2r log(45) and press·.

Temporarily Substituting a Value for a Variable

Use the “|” (such that) operator to assign a value to a variable for just a single
execution of the expression.

Removing a Linked Variable
1. Select the linked variable.

2. Pressh.

The Variables options are displayed.

3. Select Unlink.
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The link is removed from the value and the value is displayed without any bold
formatting.



Graphs Application
The Graphs application lets you:

• Graph and explore functions and other relations, such as inequalities, parametrics,
polars, sequences, differential equation solutions, and conics.

• Animate points on objects or graphs and explore their behaviour.

• Link to data created by other applications.

Adding a Graphs Page

▶ To start a new document with a blank Graphs page:

From the main Filemenu, click New Document, and then click Add Graphs.

Handheld: Pressc, and select Graphs .

▶ To add a Graphs page in the current problem of an existing document:

From the toolbar, click Insert > Graphs.

Handheld: Press~ and select Insert > Graphs.

Graphs & Geometry menu. Contains tools for defining, viewing, and investigating
relations.

Entry line. Lets you define the relations that you want to graph. The default graph
type is Function, so the form f1(x)= is displayed initially. You can define multiple
relations for each of several graph types.
Graphs Work Area

• Shows graphs of relations that you define on the entry line.

• Shows points, lines, and shapes that you create with geometry tools.

• Drag the area to pan (affects only those objects created in the Graphs
application).
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What You Must Know

Changing the Graphs and Geometry Settings

1. From the Settingsmenu in the Documents Toolbox, select Settings.

2. Select the settings that you want to use.

- Display Digits. Sets the display format for numbers as Floating or Fixed decimal.

- Graphing Angle. Sets the angle unit for all Graphs and 3D Graphing applications
in the current document. The default setting is Radian. Set this to Auto if you
want graphing angles to follow the Angle setting in the main File > Settings
menu. An angle mode indicator shows the resulting mode in Graphs and 3D
Graphing applications.

- Geometry Angle. Sets the angle unit for all Geometry applications in the current
document. The default setting is Degree. Set this to Auto if you want geometry
angles to follow the Angle setting in the main File > Settingsmenu. An angle
mode indicator shows the resulting mode in Geometry applications.

- Grid. Sets the grid display in the Graphs application. The default setting is No
Grid. Dot Grid and Lined Grid are also available.

- Automatically hide plot labels. In the Graphs application, hides the label that
normally appears next to a graphed relation.

- Show axis end values. Applies only in the Graphs application.

- Show tool tips for function manipulation. Applies only in the Graphs application.

- Automatically find points of interest. In the Graphs application, shows zeros,
minima and maxima while tracing function graphs.

- Force Geometric Triangle Angles to Integers. Restricts the angles of a triangle to
integer values as you create or edit the triangle. This setting applies only in the
Geometry View with the Geometry Angle unit set to Degree or Gradian. It does
not apply to analytic triangles in Graphing View or to analytic triangles in the
Analytic Window of the Geometry View. This setting does not affect existing
angles, and it does not apply when constructing a triangle based on previously
inserted points. By default, this setting is deselected.

- Automatically Label Points. Applies labels (A, B, ..., Z, A1, B1, and so on) to
points, lines, and vertices of geometric shapes as you draw them. The labelling
sequence starts at A for each page in a document. By default, this setting is
deselected.

Note: If you create a new object that uses existing un-labelled points, those
point are not automatically labelled in the completed object.



- Click Restore to restore all settings to their factory defaults.

- ClickMake Default to apply the current settings to the open document and save
them as the default for new Graphs and Geometry documents.

Using Context Menus

Context menus provide quick access to commonly used commands and tools that apply
to a specific object. For example, you can use a context menu to change an object's line
colour or to group a set of selected objects.

▶ Display the context menu for an object in one of the following ways.

- Windows®: Right-click the object.

- Mac®: Hold “ and click the object.

- Handheld: Move the pointer to the object, and then press/b.

Finding Hidden Objects in the Graphs or Geometry Application

You can hide and show individual graphs, geometric objects, text, labels,
measurements and axis end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects:

1. From the Actionsmenu, select Hide/Show.

The Hide/Show tool appears in the work area, and all hidden objects become
visible in dimmed colours.

2. Click a graph or object to toggle its Hide/Show state.

3. To apply the changes and close the Hide/Show tool, press ESC.

Inserting a Background Image

You can insert an image as a background for a Graphs or Geometry page. The file
format of the image can be .bmp, .jpg or .png.

1. From the Insertmenu, click Image.

2. Navigate to the image you want to insert, select it and then click Open.

For information on moving, resizing, and deleting a background image, seeWorking
with Images in the Software.

Adding Text to the Graphs or Geometry Work Area

1. From the Actionsmenu, select Text.
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The Text tool appears in the work area.

2. Click the location for the text.

3. Type the text in the box that appears, and then press Enter.

4. To close the Text tool, press ESC.

5. To edit the text, double-click it.

Deleting a Relation and its Graph

1. Select the relation by clicking its graph.

2. Press Backspace or DEL.

The graph is removed from both the work area and the graph history.

Graphing Functions
1. From the Graph Entry/Editmenu, select Function.

2. Type an expression for the function.

3. Press Enter to graph the function.



Note: For information about path plots, see Exploring Graphs with Path Plot.

Exploring Graphs with Path Plot
Path Plot lets you animate function, parametric, and polar equation plots in real time to
analyse how they are plotted and not just the final plot.

Changing the Path Plot Settings

1. From the Tracemenu, select Path Plot > Path Set-up.

2. Select the settings you want to use.

- Graph Type: Selects Function, Parametric, or Polar as the graph type.
- Path Step: Sets the increment of the independent variable at which values are

plotted.
- Show Future Path: Toggles the display of all future points for each function past

the starting or current point of the graph. You can also toggle this when viewing
the graph with the Up/Down arrow keys.

- Show Point Coordinates: Toggles the display of the coordinates for recorded
trace points.

Enabling Path Plot

1. Enter your equation(s).

2. From the Tracemenu, select Path Plot > Function/Parametric/Polar.

3. Navigate through the animation by:
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- using the Play/Pause/Reset Animation icons
- using the Left/Right arrow keys
- entering a number to jump to that point

4. Press the Esc key to exit the animation.

Manipulating Functions by Dragging
Some types of functions can be translated, stretched, and/or rotated by dragging parts
of the graph. As you drag, the expression for the graph updates to reflect the change.

Drag graph from the ends to rotate.

Drag graph near the middle to translate.

Manipulating a Linear Function

▶ To translate, grab near the middle of the graph, and then drag.



▶ To rotate, grab near the ends of the graph, and then drag.

Manipulating a Quadratic Function

▶ To translate, grab near the vertex of the graph, and then drag.

▶ To stretch, grab away from the vertex of the graph, and then drag.
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Manipulating a Sine or Cosine Function

▶ To translate, grab near the axis of vertical symmetry of the graph, and then drag.

▶ To stretch, grab away from the axis of vertical symmetry of the graph, and then
drag.

Specifying a Function with Domain Restrictions
You can use the entry line or the Calculator application to specify a function with
domain restrictions. For multiple domain restrictions on a function, use the piecewise()
function.

In the following example, a function with a domain that is less than 2 and greater than -
2 is specified on the entry line:

1. From the Graph Entry/Editmenu, select Function.



2. Type the following on the entry line, using spaces to separate the "and" operator:

piecewise(3,x>-2 and x<2)

3. Tap Enter to graph the function.

Finding Points of Interest on a Function Graph
The Graphs application helps you find zeros, minimums, maximums, intersections,
derivatives (dy/dx), or integrals. For Graphs defined as conic sections, you can also find
foci, directrix, and other points.

(CAS): You can also find the point of inflection.

Identifying Points of Interest by Dragging a Point

▶ To quickly identify maximums, minimums, and zeros, create a point on the graph
and then drag the point.

Temporary signposts appear as you drag through points of interest.

Identifying Points of Interest with Analysis Tools

This example illustrates using the Minimum tool. Other analysis tools operate similarly.
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1. From the Analyse Graphmenu, selectMinimum.

The Minimum icon is displayed at the top left on the work area, and a graph?
prompt appears in the work area.

2. Click the graph on which you want to find the minimum.

A dotted line appears, representing the lower bound of the range to search.

3. Drag the line or click a location to set the lower bound and display a proposed
upper bound.



4. Drag the line representing the upper bound, or click a location to set it.

The minimum is displayed, along with a text object showing its coordinates.

Graphing a Family of Functions
In a family of functions, each member has its own value for one or more of the
parameters. By entering the parameters as lists, you can use a single expression to
graph a family of up to 16 functions.

For example, the expression f1(x) = {-1,0,1,2} • x + {2,4,6,8} denotes the following four
functions:
f1_1(x) = -1 • x + 2
f1_2(x) = 0 • x + 4
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f1_3(x) = 1 • x + 6
f1_4(x) = 2 • x + 8

To Graph a Family of Functions

1. From the Graph Entry/Editmenu, select Function.

2. Type the expression, using lists to represent the members of the family.

3. Press Enter to graph the functions.

Each member is labelled separately (f1_1, f1_2, and so on) to indicate its sequence
in the expression.

Note: You cannot edit a single function graph to change it to a family of functions.

Graphing Equations
1. From the Graph Entry/Editmenu, select Equation.

2. Click the type of equation (Line, Parabola, Circle, Ellipse, Hyperbola, or Conic).

3. Click the specific template for the equation. For example, tap y=a•x2+b•x+c to
define a parabola.

The entry line includes a symbol to indicate the type of equation.

4. Type the coefficients into the equation template.



5. Press Enter.

Graphing Conic Sections
The Graphing view lets you graph and explore linear and conic equations analytically in
a two-dimensional coordinate system. You can create and analyse lines, circles, ellipses,
parabolas, hyperbolas, and general conic equations.

The entry line makes it easy to enter the equation by displaying a template for the type
of equation you choose.

Example: Creating a conic ellipse

1. From the Graph Entry/Editmenu, select Equation > Ellipse, and tap the equation
type.

2. Type initial values for the coefficients in the provided spaces. Use the arrow keys to
move among the coefficients.

3. Press Enter to graph the equation.
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Exploring the sample ellipse

1. Drag the ellipse from its centre to explore the effect of translation on the equation.



2. Use the analysis tools, such as Analyse Graph > Analyse Conics > Foci to further
explore the graph.

Note: The type of conic determines which analysis tools you can use. In the case of
the ellipse, you can obtain its centre, vertices, foci, axes of symmetry, directrices,
eccentricity, and latera recta.
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3. To explore translation and dilation interactively, define a conic ellipse that uses
variables for the h, k, a, and b coefficients. Insert sliders to vary the parameters.

Graphing Relations
Relation graphing is available on Graphs pages and in the Analytic Window of Geometry
pages.



You can define relations using ≤, <, =, > or ≥. The inequality operator (≠) is not
supported in relation graphing.

Relation type Examples

Equations and inequalities
equivalent to y = f(x)

• y = sqrt(x)
• y-sqrt(x) = 1/2
• -2*y-sqrt(x) = 1/2
• y-sqrt(x) ≥ 1/2
• -2*y-sqrt(x) ≥ 1/2

Equations and inequalities
equivalent to x = g(y)

• x = sin(y)
• x-sin(y) = 1/2
• x-sin(y) ≥ 1/2

Polynomial equations and
inequalities

• x^2+y^2 = 5
• x^2-y^2 ≥ 1/2+y
• x3+y3-6*x*y=0

The above relations on domains
restricted by rectangles

• y=sin(x) and -2π<x≤2π
• y≤x2|y≥-2 and 0≤x≤3
• {x2+y2≤3, y≥0 and x≤0

Note: Restrictions imposed by an active Press-to-Test session may limit the types of
relations you can graph.

To Graph a Relation:

1. From the Graph Entry/Editmenu, select Relation.

2. Type an expression for the relation.

3. Press Enter to graph the relation.
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Tips for Graphing Relations

▶ You can quickly define a relation from the Function entry line. Position the cursor to
the immediate right of the = sign, and then press the Backspace key. A small menu
appears with the relation operators and a Relation option. Choosing from the menu
places the cursor in the Relation entry line.

▶ You can type a relation as text on a Graphs page and then drag the text object over
either axis. The relation is graphed and added to the relation history.

Warning and Error Message

Error Condition Additional Information

Relation input not supported Relation input not supported
Note: The following relation inputs are
supported:
• Relations using ≤, <, =, >, or ≥.
• Polynomial relations in x and y
• Relations equivalent to y=f(x) or x=g(y)

or corresponding inequalities
• The above relations on domains

restricted by rectangles

Domain Restrictions not supported
for certain classes of relations
equivalent to y=f(x) or x=g(y) or
corresponding inequalities.

• Relations equivalent to y=f(x) and
corresponding inequalities can only have
constraints on x

• For example: y=√(x) and 0≤x≤1 will work
but y=√(x) and 0≤y≤1 will not

• Relations equivalent to x=g(y) and
corresponding inequalities can only have
constraints on y

• For example: x=sin(y)|−1≤y≤1 will work
but x=sin(y)|−1≤x≤1 will not



Graphing Parametric Equations
1. From the Graph Entry/Editmenu, select Parametric.

Use the up and down arrow keys to move among the fields in the Parametric entry
line.

2. Type expressions for xn(t) and yn(t).

3. (Optional) Edit the default values for tmin, tmax, and tstep.
4. Press Enter.

Note: For information about path plots, see Exploring Graphs with Path Plot.

Graphing Polar Equations
1. From the Graph Entry/Editmenu, select Polar.

2. Type an expression for rn(θ).
3. (Optional) Edit the default values for θmin, θmax, and θstep.
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4. Press Enter.

Note: For information about path plots, see Exploring Graphs with Path Plot.

Graphing Scatter Plots
1. (Optional) Create two predefined list variables containing the x and y values to plot.

You can use the Lists & Spreadsheet, Calculator, or Notes application to create the
lists.

2. From the Graph Entry/Editmenu, select Scatter Plot.

Use the up and down arrow keys to move between the x and y fields.



3. Use one of the following methods to specify lists to plot as x and y.

- Click to select names of the predefined list variables.

- Type the names of the variables, such as v1.
- Type lists as comma-separated elements enclosed within brackets, for example:

{1,2,3}.

4. Press Enter to plot the data, and then zoom the work area to view the plotted data.

Plotting Sequences
The Graphs application lets you plot two types of sequences. Each type has a separate
template for defining the sequence.

Defining a Sequence

1. From the Graph Entry/Editmenu, select Sequence > Sequence.

2. Type the expression to define the sequence. Update the independent variable field
to m+1, m+2, etc., if necessary.

3. Type an initial term. If the sequence expression references more than one prior
term, such as u1(n-1) and u1(n-2), (or u1(n) and u1(n+1)), separate the terms
with commas.
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4. Press Enter.

Defining a Custom Sequence

A custom sequence plot shows the relationship between two sequences by plotting
one on the x axis and the other on the y axis.

This example simulates the Predator-Prey model from biology.

1. Use the relations shown here to define two sequences: one for a rabbit population,
and another for a fox population. Replace the default sequence names with rabbit
and fox.

.05 = the growth rate of rabbits if there are no foxes

.001 = the rate at which foxes can kill rabbits

.0002 = the growth rate of foxes if there are rabbits

.03 = the death rate of foxes if there are no rabbits

Note: If you want to see the plots of the two sequences, zoom the window to the
Zoom - Fit setting.

2. From the Graph Entry/Editmenu, select Sequence > Custom.

3. Specify the rabbit and fox sequences to plot on the x and y axes, respectively.



4. Press Enter to create the custom plot.

5. Zoom the window to the Zoom - Fit setting.

6. Explore the custom plot by dragging the point that represents the initial term.

Graphing Differential Equations
You can study linear and non-linear differential equations and systems of ordinary
differential equations (ODEs), including logistic models and Lotka-Volterra equations
(predator-prey models). You can also plot slope and direction fields with interactive
implementations of Euler and Runge-Kutta methods.
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ODE entry line:
• y1 ODE identifier
• Expression k·y1 defines the relation
• Fields (1,1) for specifying initial condition
• Buttons for adding initial conditions and setting plot parameters

Slider to vary coefficient k of the ODE

Slope field

A solution curve passing through the initial condition

To Graph a Differential Equation:

1. From the Graph Entry/Editmenu, select Diff Eq.

The ODE is automatically assigned an identifier, such as “y1.”

2. Move to the relation field and enter the expression that defines the relation. For
example, you might enter -y1+0.1*y1*y2.

3. Enter the initial condition for the independent value x0 and for y10.

Note: The x0 value(s) are common to all the ODEs in a problem but can be entered
or modified only in the first ODE.

4. (Optional) To study multiple initial conditions for the current ODE, click Add Initial

Conditions and enter the conditions.



5. Tap Edit Parameters to set the plot parameters. Select a numerical Solution
Method, and then set any additional parameters. You can change these parameters
anytime.

6. Click OK.

7. To enter additional ODEs, press the down arrow to display the next ODE edit field.

As you move among defined ODEs, the graph is updated to reflect any changes.
One solution to the ODE is graphed for each IC specified for each shown ODE
(selected by check box).

Summary of Differential Equation Settings

Solution
Method

Selects Euler or Runge-Kutta as the numerical solution method.

Iterations
Between Plot
Step

Computational accuracy for Euler solution method only. Must be an
integer value >0. To restore the default, select the down-arrow and
select Default.

Error
Tolerance

Computational accuracy for Runge-Kutta solution method only. Must be
a floating-point value |1×10-14. To restore the default, select the down-
arrow and select Default.
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Field None - No field is plotted. Available for any number of ODEs, but
required if three or more 1st-order ODEs are active. Graphs a
combination of the solution and/or values of one or more ODEs
(according to user-configured Axes settings).
Slope - Plots a field representing the family of solutions to a single 1st-
order ODE. Exactly one ODE must be active. Sets Axes to Default 
(x and y). Sets Horizontal axis to x (the independent variable). Sets
Vertical axis to y (the solution to the ODE).
Direction - Graphs a field in the phase plane representing the
relationship between a solution and/or values of a system of two 1st-
order ODEs (as specified by the CustomAxes setting). Exactly two ODEs
must be active.

Axes Default (x and y) - Plots x on the x axis and y (the solutions to the active
differential equations) on the y axis.
Custom - Lets you select the values to be plotted on the x and y axes
respectively. Valid entries include:
• x (the independent variable)
• y1, y2, and any identifiers defined in the ODE editor
• y1’, y2’, and any derivatives defined in the ODE editor

Plot Start Sets the independent variable value at which the solution plot starts.

Plot End Sets the independent variable value at which the solution plot stops.

Plot Step Sets the increment of the independent variable at which values are
plotted.

Field
Resolution

Sets the number of columns of field rendering elements (line segments)
used to draw a slope or direction field. You can change this parameter
only if Field = Direction or Slope.

Direction
Field at x=

Sets the independent variable value at which a direction field is drawn
when plotting non-autonomous equations (those that refer to x).
Ignored when plotting autonomous equations. You can change this
parameter only if Field = Direction.

Viewing Tables from the Graphs Application
You can show a table of values for any relation defined in the current problem.

Note: For details about using tables and instructions for accessing tables from the
Lists & Spreadsheet application, see Working with Tables.

Showing a Table

▶ From the Tablemenu, select Split-screen Table.

The table is displayed with columns of values for the currently defined relations.



To change which relation is displayed in a column, click the arrow in the top cell of
the column, and then select the relation name.

Hiding the Table

▶ From the Tablemenu, select Remove Table.

Editing Relations
1. Double-click the graph to show its expression in the entry line.

—or—
Display the graph’s context menu, and then click Edit Relation.

2. Modify the expression as needed.

3. Press· to graph the revised function.
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Renaming a Relation

Each relation type has a default naming convention. For example, the default name for
functions is fn(x). (The number represented by n increases as you create more
functions.) You can replace the default name with a name of your choice.

Note: If you want to use a custom name as a convention, you must enter it manually for
each function.

1. In the entry line, delete the existing name. For example, delete the "f1" from "f1
(x)". You can use the right and left arrow keys to position the cursor.

2. Type the replacement name.

3. If you are defining a new relation, position the cursor after the = sign and type the
expression.

4. Press Enter to graph the relation with its new name.

Accessing the Graph History
For each problem, the software stores a history of relations defined in the Graphs
application and 3D Graphing view, such as function graphs f1 through f99 and 3D



function graphs z1 through z99. You can view and edit these items using a button on
the entry line.

Viewing the History

1. Press Ctrl+G to show the entry line.

2. Click the History Menu button   on the entry line.

The menu is displayed. As you point to the name of each item, its expression
appears in the entry line.

3. Select the name of the relation you want to view or edit.

4. (Optional) From the entry line, use the up and down arrow keys to scroll through
the defined relations of the same type.

Viewing the History of Specific Relation Types

Use this method if you want to view or edit a defined relation that does not appear in
the History menu.

1. On the Graph Entry/Editmenu, click the relation type. For example, click Polar to
show the entry line for the next available Polar relation.

2. Click the History Menu button  , or use the up and down arrow keys to scroll
through the defined relations of the same type.

Zooming/Rescaling the Graphs Work Area
Rescaling in the Graphs application affects only the graphs, plots and objects that
reside in the Graphing view. It has no effect on objects in the underlying Plane
Geometry view.

Rescaling by Dragging Along an Axis

▶ To rescale the x and y axes proportionally, drag a k mark on either axis.

▶ To rescale only one axis, hold down Shift and drag a k mark on the axis.

Zooming Using a Zoom Tool

▶ From theWindow / Zoommenu, select one of the tools.

- Zoom - Box (Click two corners of a box to define the area to show.)
- Zoom - In

- Zoom - Out

Zooming to Predefined Settings

▶ From theWindow / Zoommenu, select one of the predefined Zoom settings.
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- Zoom - Standard

- Zoom - Quadrant 1

- Zoom - Standard User

- Zoom - Standard Trig

- Zoom - Standard Data

- Zoom - Fit

Entering Custom Window Settings

1. From theWindow / Zoommenu, selectWindow Settings.

2. Enter a value for each setting. You can use expressions for exact input, as shown
below.

On TI-Nspire™ products, fractional input is preserved as-is. Other exact inputs are replaced
with the evaluated result.

On TI-Nspire™ Exact Arithmetic and CAS products, fractional and other exact inputs are
preserved.



Customising the Graphs Work Area
Inserting a Background Image

You can insert an image as a background for any Graphs or Geometry page.

1. From the Insertmenu, click Image.

2. Navigate to the image you want to insert, select it and then click Open.

Adding a Text Object to the Work Area

Use the Text tool to add numeric values, formulas, observations or other explanatory
information to the Graphs work area. You can graph an equation entered as text (such
as "x=3").

1. From the Actionsmenu, select Text.

2. Click the location for the text.

3. Type the text in the box that appears, and then press Enter.

To move a text object, drag it. To edit the text, double-click it. To delete a text object,
display its context menu, and select Delete.

Changing the Attributes of Numeric Text

If you enter a numeric value as text, you can lock it or set its format and displayed
precision.

1. From the Actionsmenu, select Attributes.

2. Click the numeric text to display its list of attributes.

3. Press▲ and ▼ to move through the list.

4. At each attribute icon, press◄ or ► to move through the options. For example,
select 0 through 9 as the precision.

5. Press Enter to apply the changes.

6. Press Esc to close the Attributes tool.

Displaying the Grid

By default, the grid is not displayed. You can choose to display it as dots or lines.

▶ From the Viewmenu, select Grid, and then select Dot Grid, Lined Grid, or No Grid.
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Changing the Grid Colour

1. From the Actionsmenu, choose Select > Grid (available only when the grid is
displayed).

The grid flashes to show it is selected.

2. Click the down arrow next to the Colour button, and select a colour for the grid.

Changing the Appearance of the Graph Axes

1. From the Actionsmenu, click Attributes.

2. Click either axis.

3. Press▲ and ▼ to move to the desired attribute, and then press◄ and ► to
choose the option to apply.

Note: To hide the axes or selectively hide or show an individual axis end-value, use the
Hide/Show tool.

To display multiple tick mark labels, select theMultiple Labels option.



Multiple labels are only displayed if they fit both horizontally and vertically on the axes.
If necessary, adjust the values in theWindow / Zoom > Window Settings dialogue.

Exact Arithmetic and CAS Only: You can change the tick mark labels to display multiples
of Pi, radical numbers, and other exact values by editing the XScale or YScale values in
theWindow / Zoom > Window Settings dialogue. See the following example.

Note: pi/2 will be converted to p/2 after clicking OK.
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Note: For information about path plots, see Exploring Graphs with Path Plot.

Hiding and Showing Items in the Graphs Application
The Hide/Show tool reveals objects you have previously selected as hidden and lets you
select which objects to show or hide.

Note: If you hide a graph, its expression is automatically marked as hidden in the graph
history.

1. From the Actionsmenu, select Hide/Show.

The Hide/Show tool appears at the top of the work area, and currently hidden
items (if any) are shown dimmed.

2. Click objects to toggle their hide/show status. You can hide graphs, geometric
objects, text, labels, measurements, and individual axis end-values.

3. Press Esc to complete your selections and close the tool.

All objects you selected as hidden objects disappear.



4. To view the hidden objects temporarily or restore them as shown objects, open the
Hide/Show tool.

Conditional Attributes
You can cause objects to hide, show, and change colour dynamically, based on specified
conditions such as "r1<r2" or "sin(a1)>=cos(a2)."

For example, you might want to hide an object based on a changing measurement that
you have assigned to a variable, or you might want an object’s colour to change based
on a "Calculate" result assigned to a variable.

Conditional behaviours can be assigned to objects or groups in the Graphing, Plane
Geometry, and 3D Graphing views.

Setting Conditional Attributes of an Object

You can set conditions of a selected object either by using its context menu or by
activating the Set Conditions tool from the Actionsmenu and then selecting the object.
These instructions describe using the context menu.

1. Select the object or group.

2. Display the object’s context menu, and click Conditions.

The conditional attributes are displayed.
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For 2D objects For 3D objects

3. (Optional) In the Show When field, enter an expression specifying the conditions
during which the object will be shown. Anytime the condition is not satisfied, the
object will be hidden.

You can specify tolerance by using compound conditionals in the Show When input
field. For example, area>=4 and area<=6.

Note: If you need to see conditionally hidden objects temporarily, click
Actions > Hide/Show. To return to normal viewing, press ESC.

4. (Optional) Enter numbers or expressions that evaluate to numbers in the applicable
colour fields, such as Line Colour orMesh Colour. To see a map of colour values,
click the Coors button.

Map of conditional colour values

5. Click OK in the Conditional Attributes dialogue box to apply the conditions.

Calculating a Bounded Area
Note: To avoid unexpected results when using this feature, make sure the
document setting for "Real or Complex Format" is set to Real.

When you calculate the area between curves, each curve must be:



• A function with respect to x.

- or -

• An equation in the form y=, including y= equations defined through a text box or a
conic equation template.

Defining and Shading the Area

1. From the Analyse Graphmenu, select Bounded Area.

If exactly two appropriate curves are available, they are selected automatically, and
you can skip to step 3. Otherwise, you are prompted to select two curves.

2. Click two curves to select them.
– or –
Click one curve and the x axis.

You are prompted to set the lower and upper bounds.

3. Click two points to define the bounds. Optionally, you can type numeric values.

The area becomes shaded, and the area value is displayed. The value is always non-
negative, regardless of the interval direction.
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Working with Shaded Areas

As you change the bounds or redefine the curves, the shading and the area value are
updated.

• To change the lower or upper bound, drag it or type new coordinates for it. You
cannot move a bound that resides on an intersection. However, the point moves
automatically as you edit or manipulate the curves.

• To redefine a curve, either manipulate it by dragging or edit its expression in the
entry line.

If an endpoint resided originally on an intersection, and the redefined functions no
longer intersect, the shading and area value disappear. If you redefine the function
(s) so that there is an intersection point, the shading and area value reappear.

• To delete or hide the shaded area, or to change its colour and other attributes,
display its context menu.

- Windows®: Right-click the shaded area.
- Mac®: Hold “ and click the shaded area.

- Handheld: Move the pointer to the shaded area and press/x.

Tracing Graphs or Plots
Graph Trace lets you move a trace cursor over the points of a graph or plot and displays
value information.

Tracing Specific Graphs

1. From the Tracemenu, select Graph Trace.

The Graph Trace tool appears at the top of the work area, the trace cursor appears,
and the cursor coordinates are displayed in the lower right corner.



2. Explore a graph or plot:

- Point to a position on a graph or plot to move the trace cursor to that point.

- Press◄ or► to step the cursor along the current graph or plot. The screen
pans automatically to keep the cursor in view.

- Press▲ or▼ to cycle among the displayed graphs.

- Click the trace cursor to create a persistent point. Optionally, enter a specific
independent value to move the trace cursor to that value.

3. To stop tracing, press Esc.

Tracing All Graphs

The Trace All tool allows tracing multiple functions simultaneously. With several
functions graphed on the work area, perform the following steps:

Note: The Trace All tool traces only function graphs, not plots of other relations (polar,
parametric, scatter, sequence).

1. From the Tracemenu, select Trace All.

The Trace All tool appears in the work area, a vertical line indicates the x value of
the trace, and the coordinates for each traced point are displayed in the lower right
corner.
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2. Explore the graphs:

- Click a point on the x axis to move all the trace points to that x value.

- Press◄ or► to step the trace points along all the graphs.

3. To stop tracing, press Esc.

Changing the Trace Step

1. From the Tracemenu, select Trace Step.

2. Choose Automatic or enter a specific step size for tracing.

Introduction to Geometric Objects
Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines, and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure, and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.



Objects Created in the Graphs Application

Points, lines, and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape, or geometric conic
created in the Graphs application.

The circle arc and polygon were created in the Geometry application. The sine wave and
conic were created in the Graphs application.

Objects Created in the Geometry Application

Points, lines, and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application
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Creating Points and Lines
As you create an object, a tool appears in the work area (for example, Segment ). To
cancel, press ESC. To enable automatic labelling of certain objects, seeWhat You Must
Know in this chapter.

Creating a Point on the Work Area

1. From the Points and Linesmenu, select Point. (In the Graphs application, click
Geometry > Points and Lines > Point.)

2. Click a location to create the point.

3. (Optional) Label the point.

4. To move a point, drag it.

Creating a Point on a Graph or Object

You can create a point on a line, segment, ray, axis, vector, circle, graph or axis.

1. From the Points and Linesmenu, select Point On. (In the Graphs application, click
Geometry > Points and Lines > Point On.)

2. Click the graph or object on which you want to create the point.

3. Click a location on the object to place the point.



Creating a Dynamic Point on a Graph

You can create a dynamic point on a graph with Point by Coordinates.

1. From the Points and Linesmenu, select Point by Coordinates. (In the Graphs
application, click Geometry > Points and Lines > Point by Coordinates or press P and
select Point by Coordinates).

2. Enter the variables or expressions for one or both of the coordinates.

3. Use the slider that is created to move the point on the graph.
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The point will display the actual coordinates. If you hover the cursor over a coordinate,
it will display the variable or expression.

To edit the point, double-click the coordinate on the label. Any variable or expression
that was entered before is retained.

Identifying Points of Intersection

1. From the Points and Linesmenu, select Intersection Points. (In the Graphs
application, click Geometry > Points and Lines > Intersection Points.)

2. Click two intersecting objects to add points at their intersections.

Creating a Line

1. From the Points and Linesmenu, select Line. (In the Graphs application, click
Geometry > Points and Lines > Line.)

2. Click a location to define one point on the line.

3. Click a second location to define the direction of the line and the length of its visible
portion.



4. To move a line, drag its identifying point. To rotate it, drag any point except the
identifying point or ends. To extend its visible portion, drag from either end.

Creating a Segment

1. From the Points and Linesmenu, select Segment. (In the Graphs application, click
Geometry > Points and Lines > Segment.)

2. Click two locations to define the endpoints of the segment.

3. To move a segment, drag any point other than an endpoint. To manipulate the
direction or length, drag either endpoint.

Creating a Ray

1. From the Points and Linesmenu, select Ray. (In the Graphs application, click
Geometry > Points and Lines > Ray.)

2. Click a location to define the endpoint of the ray.

3. Click a second location to define the direction.
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To move a ray, drag its identifying point. To rotate it, drag any point except the
identifying point or end. To extend its visible portion, drag from the end.

Creating a Tangent

You can create a tangent line at a specific point on a geometric object or function
graph.

1. From the Points and Linesmenu, select Tangent. (In the Graphs application, click
Geometry > Points and Lines > Tangent.)

2. Click the object to select it.

3. Click a location on the object to create the tangent.

4. To move a tangent, drag it. It remains attached to the object or graph.

Creating a Vector

1. From the Points and Linesmenu, select Vector. (In the Graphs application, click
Geometry > Points and Lines > Vector.)



2. Click a location to establish the vector's initial point.

3. Click a second location to specify direction and magnitude and complete the vector.

4. To move a vector, drag any point other than the endpoints. To manipulate the
magnitude and/or direction, drag either end point.

Note: If you create an endpoint on an axis or another object, you can move the
endpoint only along that object.

Creating a Circle Arc

1. From the Points and Linesmenu, select Circle Arc. (In the Graphs application, click
Geometry > Points and Lines > Circle Arc.)

2. Click a location or point to establish the starting point of the arc.

3. Click a second point to establish an intermediate point through which the arc will
pass.

4. Click a third point to set the ending point and complete the arc.

5. To move an arc, drag its perimeter. To manipulate it, drag any of its three defining
points.

Creating Geometric Shapes
The Shape tools let you explore circles, polygons, conics and other geometric objects.
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As you create a shape, a tool appears in the work area (for example, Circle ). To
cancel the shape, press ESC. To enable automatic labelling of certain objects, seeWhat
You Must Know, in this chapter.

Creating a Circle

1. From the Shapesmenu, select Circle. (In the Graphs application, click Geometry >
Shapes > Circle.)

2. Click a location or point to position the circle’s centre point.

3. Click a location or point to establish the radius and complete the circle.

4. To resize a circle, drag its perimeter. To move it, drag its centre point.

Creating a Triangle

Note: To ensure that the total of the angles of a triangle equals 180° or 200 gradians,
you can force integer angles in the Geometry view. Refer toWhat You Must Know, in
this chapter.

1. From the Shapesmenu, select Triangle. (In the Graphs application, click Geometry >
Shapes > Triangle.)

2. Click three locations to establish the vertices of the triangle.



3. To manipulate a triangle, drag any point. To move it, drag any side.

Creating a Rectangle

1. From the Shapesmenu, select Rectangle. (In the Graphs application, click Geometry
> Shapes > Rectangle.)

2. Click a location or point to establish the first corner of the rectangle.

3. Click a location for the second corner.

One side of the rectangle is displayed.

4. Click to establish the distance to the opposite side and complete the rectangle.

5. To rotate a rectangle, drag one of its first two points. To extend it, drag one of the
last two points. To move it, drag any side.

Creating a Polygon

1. From the Shapesmenu, select Polygon. (In the Graphs application, click Geometry >
Shapes > Polygon.)

2. Click a location or point to establish the first vertex of the polygon.

3. Click to establish each additional vertex.

4. To complete the polygon, click the first vertex.

5. To manipulate a polygon, drag any vertex. To move it, drag any side.
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Creating a Regular Polygon

1. From the Shapesmenu, select Regular Polygon. (In the Graphs application, click
Geometry > Shapes > Regular Polygon.)

2. Click once on the work area to establish the centre point.

3. Click a second location to establish the first vertex and radius.

A 16-sided regular polygon is formed. The number of sides is displayed in brackets;
for example, {16}.

4. Drag any vertex in a circular motion to set the number of sides.

- Drag clockwise to reduce the number of sides.

- Drag counter-clockwise to add diagonals.

5. To resize or rotate a regular polygon, drag any of its points. To move it, drag any
side.

Creating an Ellipse

1. From the Shapesmenu, select Ellipse. (In the Graphs application, click Geometry >
Shapes > Ellipse.)

2. Click two locations or points to establish the foci.

3. Click to establish a point on the ellipse and complete the shape.



4. To manipulate an ellipse, drag any of its three defining points. To move it, drag its
perimeter.

Creating a Parabola (from focus and vertex)

1. From the Shapesmenu, select Parabola. (In the Graphs application, click Geometry >
Shapes > Parabola.)

2. Click a location to establish the focus.

3. Click a location to establish the vertex and complete the parabola.

4. To manipulate a parabola, drag its focus or its vertex. To move it, drag it from any
other point.

Creating a Parabola (from focus and directrix)

1. Create a line to serve as the directrix.

2. From the Shapesmenu, select Parabola. (In the Graphs application, click Geometry >
Shapes > Parabola.)

3. Click a location to establish the focus.

4. Click the line to establish it as the directrix.
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5. To manipulate a parabola, rotate or move its directrix or drag its focus. To move it,
select both the directrix and the focus, and then drag either object.

Creating a Hyperbola

1. From the Shapesmenu, select Hyperbola. (In the Graphs application, click Geometry
> Shapes > Hyperbola.)

2. Click two locations to establish the foci.

3. Click a third location to complete the hyperbola.

4. To manipulate a hyperbola, drag any of its three defining points. To move it, drag it
from any other place on the shape.

Creating a Conic by Five Points

1. From the Shapesmenu, select Conic by Five Points. (In the Graphs application, click
Geometry > Shapes > Conic by Five Points.)

2. Click five locations to establish the five points on the shape.

Depending on the pattern of the points, the conic can be a hyperbola or an ellipse.



3. To manipulate a conic, drag any of its five defining points. To move it, drag it from
any other place on the shape.

Creating Shapes Using Gestures (MathDraw)
The MathDraw tool lets you use touchscreen or mouse gestures to create points, lines,
circles and other shapes.

MathDraw is available in:

• Geometry view without the analytic window displayed.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

MathDraw is not available in the 3D Graphing view or in the Geometry view with the
analytic window displayed.

Activating MathDraw

1. If using the Geometry view with the analytic window visible, use the Viewmenu to
hide the window.

2. On the Actionsmenu, selectMathDraw.

The MathDraw icon appears. You can begin using the tool.

Cancelling MathDraw

▶ When you have finished using the MathDraw tool, press Esc.

The tool also closes if you select a different tool or change views.

Creating Points

To create a labelled point, tap or click in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles) or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.
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• If the point is close to a visible grid location in a Graphs view or the analytic window
of a Geometry view, it snaps to the grid.

Drawing Lines and Segments

To create a line or segment, touch or click the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment or
side of a polygon, it aligns to that object.

Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named
ti_gg_fd.angle_tol. You can change the tolerance in the current problem by setting
this variable in the calculator app to a value in the range 0 through 45 (0=no
parallel/perpendicular detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen or mouse to draw the approximate
shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual centre of the drawn shape is near an existing point, the circle or ellipse
is centred on that point.

Drawing Triangles

To create a triangle, draw a triangle-like shape.

• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen or mouse to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.

• If the centre of a square is close to an existing point, the square snaps to that point.



Drawing Polygons

To create a polygon, tap or click a succession of existing points, ending on the first point
you tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognise certain gestures as functions for
analytic parabolas.

Note: The default step value for quantisation of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen or mouse to
draw a circle arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labelled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap or click point 1, point 2, and then
point 1 again.

Using MathDraw to Erase

To erase objects, use the touchscreen or mouse to drag left and right, similar to the
motion of erasing a whiteboard.

• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.

Basics of Working with Objects

Selecting and Deselecting Objects

You can select an individual object or multiple objects. Select multiple objects when
you want to quickly move, colour, or delete them together.

1. Click an object or graph to select it.
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The object flashes to indicate selection.

2. Click any additional objects to add them to the selection.

3. Perform the operation (such as moving or setting colour).

4. To deselect all objects, click an empty space in the work area.

Grouping and Ungrouping Geometric Objects

Grouping objects gives you a way to reselect them as a set, even after you have
deselected them to work with other objects.

1. Click each object to add it to the current selection.

The selected objects flash.

2. Display a context menu of the selected object or objects.

3. Click Group. You can now select all the items in the group by clicking any of its
members.

4. To split a group into individual objects, display a context menu of any of its member
objects, and click Ungroup.

Deleting Objects

1. Display the context menu of the object or objects.

2. Click Delete.

You cannot delete the origin, the axes, or points representing locked variables,
even if those items are included in the selection.

Moving Objects

You can move an object, group, or combination of selected objects and groups.

Note: If an immovable object (such as the graph axes or a point with locked
coordinates) is included in a selection or group, you cannot move any of the objects.
You must cancel the selection and then select only movable items.

To move this... Drag this

A multiple-object
selection or group

Any of its objects



To move this... Drag this

A point The point

A segment or
vector

Any point other than an endpoint

A line or ray The identifying point

A circle The centre point

Other geometric
shapes

Any position on the object except one of its defining points. For
example, move a polygon by dragging any of its sides.

Constraining Object Movement

Holding down the SHIFT key before dragging lets you constrain how certain objects are
drawn, moved, or manipulated.

Use the constraint feature to:

• Rescale only a single axis in the Graphs application.

• Pan the work area horizontally or vertically, depending on which direction you drag
initially.

• Limit object movement to horizontal or vertical.

• Limit point placement to 15° increments as you draw a triangle, rectangle, or
polygon.

• Limit angle manipulations to 15° increments.

• Limit the radius of a resized circle to integer values.

Pinning Objects

Pinning objects prevents accidental changes as you move or manipulate other objects.

You can pin graphed functions, geometric objects, text objects, the graph axes, and the
background.

1. Select the object or objects to pin, or click an empty area if you are pinning the
background.

2. Display the context menu, and select Pin.

A pinned object displays a pin icon when you point to it.
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3. To unpin an object, display its context menu, and select Unpin.

Notes:

• Although you cannot drag a pinned point, you can reposition it by editing its x and y
coordinates.

• You cannot pan the work area while the background is pinned.

Changing the Line or Fill Colour of an Object

Colour changes made in the software are displayed in shades of grey when you work on
documents using a TI-Nspire™ CX handheld that does not support colour. Colour is
preserved when you move documents back to the software.

1. Select the object or objects.

2. Display the object’s context menu, click Colour, and then click Line Colour or
Fill Colour.

3. Select the colour to apply to the objects.

Changing the Appearance of an Object

1. From the Actionsmenu, select Attributes.

2. Click the object that you want to change. You can change shapes, lines, graphs, or
graph axes.

The list of the attributes for the selected object are displayed.

3. Press 9 and : to move through the list of attributes.

4. At each attribute icon, press 7 or 8 to move through the options. For example,
select Thick, Thin, or Medium for the Line Weight attribute.

5. Press Enter to apply the changes.

6. Press ESC to close the Attributes tool.

Labelling Points, Geometric Lines, and Shapes

1. Display the context menu of the object.

2. Click Label.

3. Type the text of the label, and then press Enter.

The label attaches itself to the object and follows the object as you move it. The
label's colour matches the object's colour.



Measuring Objects
Measurement values update automatically as you manipulate the measured object.

Note: Measurements of objects created in the Graphs application are displayed in
generic units named u. Measurements of objects created in the Geometry application
are displayed in centimetres (cm).

Measuring Length of a Segment, Circle Arc or Vector

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its length.

Measuring Distance Between Two Points, a Point and a Line, or a Point and a Circle

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the first point.

3. Click the second point or a point on the line or circle.
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In this example, length is measured from the centre of the
circle to the upper left vertex of the polygon.

Measuring Circumference of a Circle or Ellipse or the Perimeter of a Polygon,
Rectangle or Triangle

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its circumference or perimeter.

Measuring a Side of a Triangle, Rectangle or Polygon

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click two points on the object that form the side you want to measure.

Note: You must click two points to measure a side. Clicking the side measures the
entire length of the object's perimeter.



Measuring Area of a Circle, Ellipse, Polygon, Rectangle or Triangle

Note: You cannot measure the area of a polygon constructed using the Segment tool.

1. From theMeasurementmenu, select Area. (In the Graphs application, click
Geometry > Measurement > Area.)

2. Click the object to display its area.

Measuring Slope of a Line, Ray, Segment or Vector

1. From theMeasurementmenu, select Slope. (In the Graphs application, click
Geometry > Measurement > Slope.)

2. Click the object to display its slope.

The value is updated automatically when you manipulate the object.
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Measuring Angles

Measured angles in the Geometry application range from 0° to 180°. Measured angles
in the Graphs application range from 0 radians to π radians. To change the angle unit,
use the Settingsmenu.

1. From theMeasurementmenu, select Angle. (In the Graphs application, click
Geometry > Measurement > Angle.)

2. Click three locations or points to define the angle. The second click defines the
vertex.

Measuring Angles using the Directed Angle Tool

1. From theMeasurementmenu, select Directed Angle. (In the Graphs application,
click Geometry > Measurement > Directed Angle.)

2. Click three locations or existing points to define the angle. The second click defines
the vertex.

3. To reverse the measurement orientation,



a) On the Actionsmenu, select Attributes.

b) Click the angle text. For example, click 300°.

c) Select the orientation attribute, and use the right or left arrow key to change it.

d) Press Esc to close the Attributes tool.

Moving a Measured Value

▶ Drag the measurement to the desired location.

Note: If you move a measurement too far from its object, it stops following the
object. However, its value continues to be updated as you manipulate the object.

Editing a Measured Length

You can set the length of a side of a Triangle, Rectangle or Polygon by editing its
measured value.

▶ Double-click the measurement, and then enter the new value.

Storing a Measured Value as a Variable

Use this method to create a variable and assign a measured value to it.

1. Display the item's context menu, and select Store.

2. Type a variable name for the stored measurement.

Linking a Measured Length to an Existing Variable

Use this method to assign a measured length value to an existing variable.

1. Display the measurement's context menu, and select Variables > Link to.

The menu shows the list of currently defined variables.

2. Click the name of the variable you want to link to.
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Deleting a Measurement

▶ Display the measurement's context menu, and select Delete.

Locking or Unlocking a Measurement

1. Display the measurement's context menu, and select Attributes.

2. Use the up/down arrow keys to highlight the Lock attribute.

3. Use the left/right arrow keys to close or open the lock.

As long as the value remains locked, manipulations are not allowed that would
require the measurement to change.

Transforming Objects
You can apply transformations to drawn objects in both the Graphs and Geometry
applications. If the object's points are labelled, the corresponding points in the
transformed object are labelled using prime notation (A→ A'). To enable automatic
labelling of certain objects, seeWhat You Must Know in this chapter.

Exploring Symmetry

1. From the Transformationmenu, select Symmetry. (In the Graphs application, click
Geometry > Transformation > Symmetry.)

2. Click the object whose symmetry you want to explore.

3. Click a location or existing point to establish the point of symmetry.

A symmetrical image of the object is displayed.

4. Manipulate the original object or the point of symmetry to explore the symmetry.

Exploring Reflection

1. Create a line or segment to predefine the line about which the object will be
reflected.



2. From the Transformationmenu, select Reflection. (In the Graphs application, click
Geometry > Transformation > Reflection.)

3. Click the object whose reflection you want to explore.

4. Click the predefined reflection line or segment.

A reflected image of the object is displayed.

5. Manipulate the original object or the line of symmetry to explore the reflection.

Exploring Translation

1. (Optional) Create a vector to predefine the distance and direction of translation.

2. From the Transformationmenu, select Translation. (In the Graphs application, click
Geometry > Transformation > Translation.)

3. Click the object whose translation you want to explore.

4. Click the predefined vector.
—or—
Click two locations on the work area to indicate the direction and distance of
translation.

A translated image of the object is displayed.

5. Manipulate the original object or the vector to explore the translation.
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Exploring Rotation

1. (Optional) Create an angle measurement to serve as a predefined angle of rotation.

2. From the Transformationmenu, select Rotation. (In the Graphs application, click
Geometry > Transformation > Rotation.)

3. Click the object whose rotation you want to explore.

4. Click a location or point to define the point of rotation.

5. Click the points of the predefined angle.
—or—
Click three locations to define an angle of rotation.

A rotated image of the object is displayed.

6. Manipulate the original object or the point of rotation to explore the rotation.

Exploring Dilation

1. Create a Text object containing a numeric value to serve as a predefined dilation
factor.

Note: You can also use a measured length value as the dilation factor. Keep in mind
that if you use a large value, you may have to pan the display to view the dilated
object.

2. From the Transformationmenu, select Dilation. (In the Graphs application, click
Geometry > Transformation > Dilation.)

3. Click the object whose dilation you want to explore.

4. Click a location or existing point to define the centre point of dilation.

5. Click the Text object or measurement that defines the dilation factor.

A dilated image of the object is displayed.



6. Manipulate the original object or the centre point of dilation to explore the
dilation. You can also edit the dilation factor.

Exploring with Geometric Construction Tools
You can investigate scenarios by adding objects from the Construction tools. The
constructions are dynamic. The midpoint of a line segment, for example, is updated
automatically when you manipulate the endpoints.

While a construction is in progress, a tool appears in the work area (for example,
Parallel ). To cancel, press ESC.

Creating a Midpoint

This tool lets you bisect a segment or define a midpoint between any two points. The
points can be on a single object, on separate objects, or on the work area.

1. From the Constructionmenu, selectMidpoint. (In the Graphs application, click
Geometry > Construction > Midpoint.)

2. Click a point or location to define the first point.

3. Click a second point or location to complete the midpoint.
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Creating a Parallel Line

This tool creates a parallel line with respect to any existing line. The existing line can be
a Graphs axis or any side of a triangle, square, rectangle, or polygon.

1. From the Constructionmenu, select Parallel. (In the Graphs application, click
Geometry > Construction > Parallel.)

2. Click the object that will serve as the reference line.

3. Click a location to create the parallel line.

You can drag the parallel line to move it. If you manipulate the reference object,
the line remains parallel.

Creating a Perpendicular Line

You can create a line that is perpendicular to a reference line. The reference can be an
axis, an existing line, a segment, or one side of a triangle, rectangle, or polygon.

1. From the Constructionmenu, select Perpendicular. (In the Graphs application, click
Geometry > Construction > Perpendicular.)

2. Click a location or existing point through which the perpendicular line should pass.

3. Click the item that will serve as the reference line.



You can drag the intersection point to move the perpendicular. If you manipulate
the reference object, the line remains perpendicular.

Creating a Perpendicular Bisector

You can create a perpendicular bisector on a segment, on one side of a triangle,
rectangle, or polygon, or between any two points.

1. From the Constructionmenu, select Perpendicular Bisector. (In the Graphs
application, click Geometry > Construction > Perpendicular Bisector.)

2. Click the item that will serve as the reference line.
—or—
Click two points to create a perpendicular bisector between them.

Bisecting an Angle

This tool creates an angle bisector. The points of the angle can be on existing objects,
or they can be locations on the work area.

1. From the Constructionmenu, select Angle Bisector. (In the Graphs application, click
Geometry > Construction > Angle Bisector.)

2. Click three locations or points to define the angle. The second click defines the
vertex of the angle.
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The angle bisector adjusts automatically as you manipulate its defining points.

Creating a Locus

The Locus tool enables you to explore the range of motion of one object with respect
to another object as constrained by a shared point.

1. Create a segment, line, or circle.

2. Create a point on the segment, line, or circle.

3. Create another object that uses the point created in the previous step.



Circle created to use the defined point
on the segment.

4. From the Constructionmenu, select Locus. (In the Graphs application, click
Geometry > Construction > Locus.)

5. Click the point shared by the objects.

6. Click the object defined to share the point (this is the object to vary).

The continuous locus is displayed.

Creating a Compass

This tool operates similarly to a geometric compass used for drawing circles on paper.

1. From the Constructionmenu, select Compass. (In the Graphs application, click
Geometry > Construction > Compass.)

2. To set the width (radius) of the compass:

Click a segment.
—or—
Click any side of a triangle, rectangle, polygon, or regular polygon.
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—or—
Click any two existing points or locations on the work area.

3. Click a location to establish the centre of the circle and complete the construction.

The radius adjusts automatically as you manipulate the original segment, side, or
points used to define the radius.

Animating Points on Objects
You can animate any point created as a point on an object or graph. Multiple points can
be animated simultaneously.

Animating a Point

1. From the Actionsmenu, select Attributes.

2. Click the point to display its attributes.

3. Press▼ to select the animation attributes.

4. Press◄ or ► to choose either unidirectional or alternating animation.

5. Type a value to set the animation speed. Any nonzero speed begins the animation.
To reverse the direction, enter a negative value.

6. Press Enter to display the animation controls  .

7. Press ESC to close the Attributes tool.

Pausing and Resuming All Animations

▶ To pause all animations on a page, click Pause .

▶ To resume all animations, click Play .



Resetting All Animations

Resetting pauses all animations and returns all animated points to the positions they
occupied when they were first animated.

▶ To reset animation, click Reset .

Changing or Stopping the Animation of a Point

1. Click Reset to stop all animation.

2. From the Actionsmenu, select Attributes.

3. Click the point to display its attributes.

4. Select the animation attribute, and type a new animation speed. To stop the point’s
animation, enter zero.

Note: If other animated points exist, the animation controls remain in the work
area.

Adjusting Variable Values with a Slider
A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes and Data & Statistics
applications.

Horizontal slider for adjusting variable v1.

Minimised vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.
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Inserting a Slider Manually

1. From a Graphs, Geometry or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a maths box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.

2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, click an empty
space in the work area. You can show the handles any time by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimised slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The colour of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.

1. Display the slider's context menu.



2. Click an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations or sequences that refer to undefined variables.

Labelling (Identifying) the Coordinates of a Point
The Graphs application can identify and label the coordinates of any existing point,
provided the point was created in the Graphs application.

1. From the Actionsmenu, select Coordinates and Equations.

The tool appears at the top of the work area

2. Tap the point whose coordinates you want to show.
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3. Press Esc to close the tool.

If you later move the point to a different location, the coordinates follow the point and
update automatically.

Displaying the Equation of a Geometric Object
You can display the equation of a line, tangent line, circle shape, or geometric conic,
provided the object was constructed in the Graphing View or within the Analytic
Window of the Plane Geometry View.

Note: Due to differences in the numerical representations of analytic and geometric
conics, the capability to convert a geometric conic to an analytic template may
sometimes be unavailable. This is done in order to avoid a situation where the
template-based conic would be different from the geometric one.

1. From the Actionsmenu, click Coordinates and Equations.

2. Move the pointer to the object.

The equation for the object appears.

Note: If you approach a defined point on the line or the centre point of a circle, the
coordinates of that point are displayed instead of the equation. Move the pointer
away from the defined point to obtain the equation of the object.

3. Click to attach the equation to the pointer.

4. Move the equation to the desired location, and click to anchor it.



5. Press Esc to exit the tool.

Using the Calculate Tool
The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a maths expression you have entered as a text object.

The following example uses the Calculate tool to calculate the measured angles of a
triangle.

1. Using the Shapesmenu, create a triangle and then measure its angles.

Tip: You can enable options to automatically label points and to force geometric
triangle angles to integers. For more information, seeWhat You Must Know, in this
chapter.

2. From the Actionsmenu, click Text.

3. Click a location for the text, and type the formula for the calculation.

In this example, the formula calculates three terms.
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4. From the Actionsmenu, click Calculate.

5. Click the formula you created.

You are prompted to select a value for each term in the formula.

6. Click each angle measurement when prompted.

Note: If you have stored a measurement as a variable, you can select it when
prompted by clicking . If the name of a stored measurement matches a term in
the formula, you can press “L” when prompted for that term.

After you have selected the third term, the calculation result attaches itself to the
pointer.

7. Position the result, and press Enter to anchor it as a new text object.



3D Graphs
The 3D Graphing view lets you create and explore three-dimensional graphs of:

• 3D functions of the form z(x,y)

• 3D parametric plots

Selecting the 3D Graphing View

The 3D Graphing View is available on any Graphs page   or Geometry page  .

▶ From the Viewmenu, select 3D Graphing.

3D Graphs Menu

Entry line. Lets you define 3D graphs. The default graph type is 3D Function, indicated
by z1(x,y)=.
3D Graphs Work Area. Shows a 3D box containing graphs that you define. Drag to
rotate the box.

Graphing 3D Functions
1. In the 3D Graphing view, select 3D Graph Entry/Edit > Function.

The entry line appears.

2. Enter the expression that defines the graph. You can type the expression or build it
using expression templates.
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3. Press Enter to create the graph and hide the entry line. You can show or hide the
entry line anytime by pressing Ctrl+G.

Graphing 3D Parametric Equations
1. In the 3D Graphing view, select 3D Graph Entry/Edit > Parametric.

The entry line appears.

2. Type the equations that define the graph.

3. Press Enter to draw the graph and hide the entry line and keyboard. You can show
or hide the entry line anytime by pressing Ctrl+G.



4. To set the graphing parameters tmin, tmax, umin, and umax, display the graph's
context menu, and select Edit Parameters.

Rotating the 3D View
Rotating Manually

1. Press R to activate the Rotation tool.

2. Press any of the four arrow keys to rotate the graph.

Rotating Automatically

Auto rotation is equivalent to holding down the right arrow key.

1. Press A.

The Auto Rotation icon appears, and the graph rotates.

2. (Optional) Use the up and down arrow keys to explore the rotating graph.

3. To stop the rotation and return to the Pointer tool, press Esc.

Viewing from Specific Orientations

1. If necessary, press Esc to return to the Pointer tool.

2. Use letter keys to select the orientation:

- Press Z, Y, or X to view along the z, y, or x axis.
- Press letter O to view from the default orientation.
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Editing a 3D Graph
1. Double-click the graph to show its expression in the entry line.

—or—
Display the graph’s context menu, and then click Edit Relation.

2. Modify the existing expression, or type a new expression in the entry line.

3. Press Enter.

Accessing the Graph History
For each problem, the software stores a history of relations defined in the Graphs
application and 3D Graphing view, such as function graphs f1 through f99 and 3D
function graphs z1 through z99. You can view and edit these items using a button on
the entry line.

Viewing the History

1. Press Ctrl+G to show the entry line.

2. Click the History Menu button   on the entry line.

The menu is displayed. As you point to the name of each item, its expression
appears in the entry line.

3. Select the name of the relation you want to view or edit.

4. (Optional) From the entry line, use the up and down arrow keys to scroll through
the defined relations of the same type.

Viewing the History of Specific Relation Types

Use this method if you want to view or edit a defined relation that does not appear in
the History menu.

1. On the Graph Entry/Editmenu, click the relation type. For example, click Polar to
show the entry line for the next available Polar relation.

2. Click the History Menu button  , or use the up and down arrow keys to scroll
through the defined relations of the same type.



Changing the Appearance of a 3D Graph

Setting Wire and Surface Colour:

1. Display the graph’s context menu, click Colour, and then click Line Colour or
Fill Colour.

2. Click a colour swatch to apply it.

Setting Custom Plot Colours:

You can assign different colours to a graph's top and bottom surfaces or choose to have
the graph coloured automatically, based on height or steepness. You can also set the
wire colour.

1. Display the graph’s context menu, and then click Colour > Custom Plot Colour.

2. Select one of the three Surface colour options: Top/bottom colour, Vary colour by
height, or Vary colour by steepness.

- If you choose Top/bottom colour, click the colour swatches to select colours for
the top and bottom surfaces.

- If you choose to vary colour by height or steepness, colours are determined
automatically.

3. To set the Wire colour, click the colour swatch and select a colour.

Setting Other Attributes of a Graph:

1. Display the graph’s context menu, and then click Attributes. You can set the
following attributes for the selected graph.

- format: surface+wire, surface only, or wire only
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- x resolution (enter a value in range 2-200*, default=21)

- y resolution (enter a value in range 2-200*, default=21)

- transparency (enter a value in range 0-100, default=30)

* Handhelds are limited to a maximum display resolution of 21, regardless of the
value entered.

2. Set the attributes as you like, and then press Enter to accept the changes.

Showing or Hiding a Graph’s Label

▶ Display the graph’s context menu, and then click Hide Label or Show Label.

Showing and Hiding 3D Graphs
1. In the 3D Graphing view, select Actions > Hide/Show.

The Hide/Show tool appears, and all hidden items are displayed in grey.

2. Tap a graph to change its hide/show state.

3. To apply the changes and dismiss the tool, press Esc.

Note: If you want to show or hide only the graph's label, see Showing or Hiding a
Graph’s Label.

Customising the 3D Viewing Environment

Setting the Background Colour

▶ Display the context menu for the work area, and then click Background Colour.

Showing or Hiding Specific View Elements

▶ From the Viewmenu, click the item to show or hide. You can choose items such as
the 3D box, axes, box end values and legend.

Changing the 3D Projection

▶ From the Viewmenu, click Orthographic Projection or Perspective View.



Orthographic Projection (default) Perspective View

Setting the Visual Attributes of the Box and Axes

1. Display the context menu for the box, and then click Attributes. You can set the
following attributes.

- Show or hide tic labels

- Show or hide end values

- Show or hide arrows on axes

- Show 3D or 2D arrow heads

2. Set the attributes as you like, and then press Enter to accept the changes.

Shrinking or Magnifying the 3D View

▶ From the Range/Zoommenu, click Shrink Box orMagnify Box.

Changing the 3D Aspect Ratio

1. From the Range/Zoommenu, click Aspect Ratio.

2. Enter values for the x, y and z axes. The default value for each axis is 1.

Changing the Range Settings

▶ On the Range/Zoommenu, click Range Settings. You can set the following
parameters.

- XMin (default=-5)
XMax (default=5)
XScale (default=Auto) You can enter a numeric value.

- YMin (default=-5)
YMax (default=5)
YScale (default=Auto) You can enter a numeric value.
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- ZMin (default=-5)
ZMax (default=5)
ZScale (default=Auto) You can enter a numeric value.

- eye q¡ (default=35)
eye f¡ (default=160)
eye distance (default=11)

Tracing in the 3D View
1. From the Tracemenu, select z Trace.

The z Trace icon and the trace plane appear, along with a text line showing the
current "z=" trace value.

2. To move the trace, hold down Shift and press the up or down arrow key.

The "z=" text is updated as you move.

3. (Optional) Use the four arrow keys to rotate the view and see how the trace plane
and the graph intersect.

4. To stop tracing and return to the Pointer tool, press Esc.

Changing the Trace Settings

1. From the Tracemenu, select Trace Setup.

The 3D Trace Setup dialogue box opens.



2. Enter or select the settings, and click OK to apply them.

3. If you are not already tracing, your new settings take effect the next time you trace.

Example: Creating an Animated 3D Graph
1. Insert a new problem and select the 3D Graphing view.

2. From the Actionsmenu, select Insert Slider, click to position it, and type time as
the variable name.

3. Display the slider’s context menu, click Settings, and enter the following values.

Value: 3.8
Minimum: 3.2
Maximum: 4.4
Step Size: 0.1

4. In the entry line, define the function shown here:

5. Drag the slider thumb to see the effect of varying time.

6. Add visual interest. For example:

3D Graphs 197



198 3D Graphs

- Change the background colour of the work area.
- Hide the box, axes, or legend.
- Automatically rotate the graph.
- Change the graph's fill colour and hide its lines.
- Change the graph’s transparency and shading.

7. To animate the graph, display the slider’s context menu, and click Animate. (To
stop, click Stop Animate from the context menu.)

You can combine manual or auto rotation with the slider animation. Experiment
with the x and y resolution to balance curve definition against animation
smoothness.



Geometry Application
The Geometry application lets you:

• Create and explore geometric objects and constructions.

• Manipulate and measure geometric objects.

• Animate points on objects and explore their behaviour.

• Explore object transformations.

Adding a Geometry Page

▶ To start a new document with a blank Geometry page:

From the main Filemenu, click New Document, and then click Add Geometry.

Handheld: Pressc, and select Geometry .

▶ To add a Geometry page in the current problem of an existing document:

From the toolbar, click Insert > Geometry.

Handheld: Press~ and select Insert > Geometry.

À Geometry menu – Available anytime you are viewing a Geometry page.

Á Geometry work area -- The area where you create and explore geometric objects.

What You Must Know

Changing the Graphs and Geometry Settings

1. From the Settingsmenu in the Documents Toolbox, select Settings.

2. Select the settings that you want to use.

- Display Digits. Sets the display format for numbers as Floating or Fixed decimal.
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- Graphing Angle. Sets the angle unit for all Graphs and 3D Graphing applications
in the current document. The default setting is Radian. Set this to Auto if you
want graphing angles to follow the Angle setting in the main File > Settings
menu. An angle mode indicator shows the resulting mode in Graphs and 3D
Graphing applications.

- Geometry Angle. Sets the angle unit for all Geometry applications in the current
document. The default setting is Degree. Set this to Auto if you want geometry
angles to follow the Angle setting in the main File > Settingsmenu. An angle
mode indicator shows the resulting mode in Geometry applications.

- Grid. Sets the grid display in the Graphs application. The default setting is No
Grid. Dot Grid and Lined Grid are also available.

- Automatically hide plot labels. In the Graphs application, hides the label that
normally appears next to a graphed relation.

- Show axis end values. Applies only in the Graphs application.

- Show tool tips for function manipulation. Applies only in the Graphs application.

- Automatically find points of interest. In the Graphs application, shows zeros,
minima and maxima while tracing function graphs.

- Force Geometric Triangle Angles to Integers. Restricts the angles of a triangle to
integer values as you create or edit the triangle. This setting applies only in the
Geometry View with the Geometry Angle unit set to Degree or Gradian. It does
not apply to analytic triangles in Graphing View or to analytic triangles in the
Analytic Window of the Geometry View. This setting does not affect existing
angles, and it does not apply when constructing a triangle based on previously
inserted points. By default, this setting is deselected.

- Automatically Label Points. Applies labels (A, B, ..., Z, A1, B1, and so on) to
points, lines, and vertices of geometric shapes as you draw them. The labelling
sequence starts at A for each page in a document. By default, this setting is
deselected.

Note: If you create a new object that uses existing un-labelled points, those
point are not automatically labelled in the completed object.

- Click Restore to restore all settings to their factory defaults.

- ClickMake Default to apply the current settings to the open document and save
them as the default for new Graphs and Geometry documents.



Using Context Menus

Context menus provide quick access to commonly used commands and tools that apply
to a specific object. For example, you can use a context menu to change an object's line
colour or to group a set of selected objects.

▶ Display the context menu for an object in one of the following ways.

- Windows®: Right-click the object.

- Mac®: Hold “ and click the object.

- Handheld: Move the pointer to the object, and then press/b.

Finding Hidden Objects in the Graphs or Geometry Application

You can hide and show individual graphs, geometric objects, text, labels,
measurements and axis end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects:

1. From the Actionsmenu, select Hide/Show.

The Hide/Show tool appears in the work area, and all hidden objects become
visible in dimmed colours.

2. Click a graph or object to toggle its Hide/Show state.

3. To apply the changes and close the Hide/Show tool, press ESC.

Inserting a Background Image

You can insert an image as a background for a Graphs or Geometry page. The file
format of the image can be .bmp, .jpg or .png.

1. From the Insertmenu, click Image.

2. Navigate to the image you want to insert, select it and then click Open.

For information on moving, resizing, and deleting a background image, seeWorking
with Images in the Software.

Adding Text to the Graphs or Geometry Work Area

1. From the Actionsmenu, select Text.

The Text tool appears in the work area.

2. Click the location for the text.
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3. Type the text in the box that appears, and then press Enter.

4. To close the Text tool, press ESC.

5. To edit the text, double-click it.

Deleting a Relation and its Graph

1. Select the relation by clicking its graph.

2. Press Backspace or DEL.

The graph is removed from both the work area and the graph history.

Introduction to Geometric Objects
Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines, and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure, and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines, and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape, or geometric conic
created in the Graphs application.



The circle arc and polygon were created in the Geometry application. The sine wave and
conic were created in the Graphs application.

Objects Created in the Geometry Application

Points, lines, and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application
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Creating Points and Lines
As you create an object, a tool appears in the work area (for example, Segment ). To
cancel, press ESC. To enable automatic labelling of certain objects, seeWhat You Must
Know in this chapter.

Creating a Point on the Work Area

1. From the Points and Linesmenu, select Point. (In the Graphs application, click
Geometry > Points and Lines > Point.)

2. Click a location to create the point.

3. (Optional) Label the point.

4. To move a point, drag it.

Creating a Point on a Graph or Object

You can create a point on a line, segment, ray, axis, vector, circle, graph or axis.

1. From the Points and Linesmenu, select Point On. (In the Graphs application, click
Geometry > Points and Lines > Point On.)

2. Click the graph or object on which you want to create the point.

3. Click a location on the object to place the point.



Creating a Dynamic Point on a Graph

You can create a dynamic point on a graph with Point by Coordinates.

1. From the Points and Linesmenu, select Point by Coordinates. (In the Graphs
application, click Geometry > Points and Lines > Point by Coordinates or press P and
select Point by Coordinates).

2. Enter the variables or expressions for one or both of the coordinates.

3. Use the slider that is created to move the point on the graph.
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The point will display the actual coordinates. If you hover the cursor over a coordinate,
it will display the variable or expression.

To edit the point, double-click the coordinate on the label. Any variable or expression
that was entered before is retained.

Identifying Points of Intersection

1. From the Points and Linesmenu, select Intersection Points. (In the Graphs
application, click Geometry > Points and Lines > Intersection Points.)

2. Click two intersecting objects to add points at their intersections.

Creating a Line

1. From the Points and Linesmenu, select Line. (In the Graphs application, click
Geometry > Points and Lines > Line.)

2. Click a location to define one point on the line.

3. Click a second location to define the direction of the line and the length of its visible
portion.



4. To move a line, drag its identifying point. To rotate it, drag any point except the
identifying point or ends. To extend its visible portion, drag from either end.

Creating a Segment

1. From the Points and Linesmenu, select Segment. (In the Graphs application, click
Geometry > Points and Lines > Segment.)

2. Click two locations to define the endpoints of the segment.

3. To move a segment, drag any point other than an endpoint. To manipulate the
direction or length, drag either endpoint.

Creating a Ray

1. From the Points and Linesmenu, select Ray. (In the Graphs application, click
Geometry > Points and Lines > Ray.)

2. Click a location to define the endpoint of the ray.

3. Click a second location to define the direction.
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To move a ray, drag its identifying point. To rotate it, drag any point except the
identifying point or end. To extend its visible portion, drag from the end.

Creating a Tangent

You can create a tangent line at a specific point on a geometric object or function
graph.

1. From the Points and Linesmenu, select Tangent. (In the Graphs application, click
Geometry > Points and Lines > Tangent.)

2. Click the object to select it.

3. Click a location on the object to create the tangent.

4. To move a tangent, drag it. It remains attached to the object or graph.

Creating a Vector

1. From the Points and Linesmenu, select Vector. (In the Graphs application, click
Geometry > Points and Lines > Vector.)



2. Click a location to establish the vector's initial point.

3. Click a second location to specify direction and magnitude and complete the vector.

4. To move a vector, drag any point other than the endpoints. To manipulate the
magnitude and/or direction, drag either end point.

Note: If you create an endpoint on an axis or another object, you can move the
endpoint only along that object.

Creating a Circle Arc

1. From the Points and Linesmenu, select Circle Arc. (In the Graphs application, click
Geometry > Points and Lines > Circle Arc.)

2. Click a location or point to establish the starting point of the arc.

3. Click a second point to establish an intermediate point through which the arc will
pass.

4. Click a third point to set the ending point and complete the arc.

5. To move an arc, drag its perimeter. To manipulate it, drag any of its three defining
points.

Creating Geometric Shapes
The Shape tools let you explore circles, polygons, conics and other geometric objects.
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As you create a shape, a tool appears in the work area (for example, Circle ). To
cancel the shape, press ESC. To enable automatic labelling of certain objects, seeWhat
You Must Know, in this chapter.

Creating a Circle

1. From the Shapesmenu, select Circle. (In the Graphs application, click Geometry >
Shapes > Circle.)

2. Click a location or point to position the circle’s centre point.

3. Click a location or point to establish the radius and complete the circle.

4. To resize a circle, drag its perimeter. To move it, drag its centre point.

Creating a Triangle

Note: To ensure that the total of the angles of a triangle equals 180° or 200 gradians,
you can force integer angles in the Geometry view. Refer toWhat You Must Know, in
this chapter.

1. From the Shapesmenu, select Triangle. (In the Graphs application, click Geometry >
Shapes > Triangle.)

2. Click three locations to establish the vertices of the triangle.



3. To manipulate a triangle, drag any point. To move it, drag any side.

Creating a Rectangle

1. From the Shapesmenu, select Rectangle. (In the Graphs application, click Geometry
> Shapes > Rectangle.)

2. Click a location or point to establish the first corner of the rectangle.

3. Click a location for the second corner.

One side of the rectangle is displayed.

4. Click to establish the distance to the opposite side and complete the rectangle.

5. To rotate a rectangle, drag one of its first two points. To extend it, drag one of the
last two points. To move it, drag any side.

Creating a Polygon

1. From the Shapesmenu, select Polygon. (In the Graphs application, click Geometry >
Shapes > Polygon.)

2. Click a location or point to establish the first vertex of the polygon.

3. Click to establish each additional vertex.

4. To complete the polygon, click the first vertex.

5. To manipulate a polygon, drag any vertex. To move it, drag any side.
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Creating a Regular Polygon

1. From the Shapesmenu, select Regular Polygon. (In the Graphs application, click
Geometry > Shapes > Regular Polygon.)

2. Click once on the work area to establish the centre point.

3. Click a second location to establish the first vertex and radius.

A 16-sided regular polygon is formed. The number of sides is displayed in brackets;
for example, {16}.

4. Drag any vertex in a circular motion to set the number of sides.

- Drag clockwise to reduce the number of sides.

- Drag counter-clockwise to add diagonals.

5. To resize or rotate a regular polygon, drag any of its points. To move it, drag any
side.

Creating an Ellipse

1. From the Shapesmenu, select Ellipse. (In the Graphs application, click Geometry >
Shapes > Ellipse.)

2. Click two locations or points to establish the foci.

3. Click to establish a point on the ellipse and complete the shape.



4. To manipulate an ellipse, drag any of its three defining points. To move it, drag its
perimeter.

Creating a Parabola (from focus and vertex)

1. From the Shapesmenu, select Parabola. (In the Graphs application, click Geometry >
Shapes > Parabola.)

2. Click a location to establish the focus.

3. Click a location to establish the vertex and complete the parabola.

4. To manipulate a parabola, drag its focus or its vertex. To move it, drag it from any
other point.

Creating a Parabola (from focus and directrix)

1. Create a line to serve as the directrix.

2. From the Shapesmenu, select Parabola. (In the Graphs application, click Geometry >
Shapes > Parabola.)

3. Click a location to establish the focus.

4. Click the line to establish it as the directrix.
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5. To manipulate a parabola, rotate or move its directrix or drag its focus. To move it,
select both the directrix and the focus, and then drag either object.

Creating a Hyperbola

1. From the Shapesmenu, select Hyperbola. (In the Graphs application, click Geometry
> Shapes > Hyperbola.)

2. Click two locations to establish the foci.

3. Click a third location to complete the hyperbola.

4. To manipulate a hyperbola, drag any of its three defining points. To move it, drag it
from any other place on the shape.

Creating a Conic by Five Points

1. From the Shapesmenu, select Conic by Five Points. (In the Graphs application, click
Geometry > Shapes > Conic by Five Points.)

2. Click five locations to establish the five points on the shape.

Depending on the pattern of the points, the conic can be a hyperbola or an ellipse.



3. To manipulate a conic, drag any of its five defining points. To move it, drag it from
any other place on the shape.

Creating Shapes Using Gestures (MathDraw)
The MathDraw tool lets you use touchscreen or mouse gestures to create points, lines,
circles and other shapes.

MathDraw is available in:

• Geometry view without the analytic window displayed.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

MathDraw is not available in the 3D Graphing view or in the Geometry view with the
analytic window displayed.

Activating MathDraw

1. If using the Geometry view with the analytic window visible, use the Viewmenu to
hide the window.

2. On the Actionsmenu, selectMathDraw.

The MathDraw icon appears. You can begin using the tool.

Cancelling MathDraw

▶ When you have finished using the MathDraw tool, press Esc.

The tool also closes if you select a different tool or change views.

Creating Points

To create a labelled point, tap or click in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles) or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.
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• If the point is close to a visible grid location in a Graphs view or the analytic window
of a Geometry view, it snaps to the grid.

Drawing Lines and Segments

To create a line or segment, touch or click the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment or
side of a polygon, it aligns to that object.

Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named
ti_gg_fd.angle_tol. You can change the tolerance in the current problem by setting
this variable in the calculator app to a value in the range 0 through 45 (0=no
parallel/perpendicular detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen or mouse to draw the approximate
shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual centre of the drawn shape is near an existing point, the circle or ellipse
is centred on that point.

Drawing Triangles

To create a triangle, draw a triangle-like shape.

• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen or mouse to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.

• If the centre of a square is close to an existing point, the square snaps to that point.



Drawing Polygons

To create a polygon, tap or click a succession of existing points, ending on the first point
you tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognise certain gestures as functions for
analytic parabolas.

Note: The default step value for quantisation of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen or mouse to
draw a circle arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labelled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap or click point 1, point 2, and then
point 1 again.

Using MathDraw to Erase

To erase objects, use the touchscreen or mouse to drag left and right, similar to the
motion of erasing a whiteboard.

• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.

Basics of Working with Objects

Selecting and Deselecting Objects

You can select an individual object or multiple objects. Select multiple objects when
you want to quickly move, colour, or delete them together.

1. Click an object or graph to select it.
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The object flashes to indicate selection.

2. Click any additional objects to add them to the selection.

3. Perform the operation (such as moving or setting colour).

4. To deselect all objects, click an empty space in the work area.

Grouping and Ungrouping Geometric Objects

Grouping objects gives you a way to reselect them as a set, even after you have
deselected them to work with other objects.

1. Click each object to add it to the current selection.

The selected objects flash.

2. Display a context menu of the selected object or objects.

3. Click Group. You can now select all the items in the group by clicking any of its
members.

4. To split a group into individual objects, display a context menu of any of its member
objects, and click Ungroup.

Deleting Objects

1. Display the context menu of the object or objects.

2. Click Delete.

You cannot delete the origin, the axes, or points representing locked variables,
even if those items are included in the selection.

Moving Objects

You can move an object, group, or combination of selected objects and groups.

Note: If an immovable object (such as the graph axes or a point with locked
coordinates) is included in a selection or group, you cannot move any of the objects.
You must cancel the selection and then select only movable items.

To move this... Drag this

A multiple-object
selection or group

Any of its objects



To move this... Drag this

A point The point

A segment or
vector

Any point other than an endpoint

A line or ray The identifying point

A circle The centre point

Other geometric
shapes

Any position on the object except one of its defining points. For
example, move a polygon by dragging any of its sides.

Constraining Object Movement

Holding down the SHIFT key before dragging lets you constrain how certain objects are
drawn, moved, or manipulated.

Use the constraint feature to:

• Rescale only a single axis in the Graphs application.

• Pan the work area horizontally or vertically, depending on which direction you drag
initially.

• Limit object movement to horizontal or vertical.

• Limit point placement to 15° increments as you draw a triangle, rectangle, or
polygon.

• Limit angle manipulations to 15° increments.

• Limit the radius of a resized circle to integer values.

Pinning Objects

Pinning objects prevents accidental changes as you move or manipulate other objects.

You can pin graphed functions, geometric objects, text objects, the graph axes, and the
background.

1. Select the object or objects to pin, or click an empty area if you are pinning the
background.

2. Display the context menu, and select Pin.

A pinned object displays a pin icon when you point to it.
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3. To unpin an object, display its context menu, and select Unpin.

Notes:

• Although you cannot drag a pinned point, you can reposition it by editing its x and y
coordinates.

• You cannot pan the work area while the background is pinned.

Changing the Line or Fill Colour of an Object

Colour changes made in the software are displayed in shades of grey when you work on
documents using a TI-Nspire™ CX handheld that does not support colour. Colour is
preserved when you move documents back to the software.

1. Select the object or objects.

2. Display the object’s context menu, click Colour, and then click Line Colour or
Fill Colour.

3. Select the colour to apply to the objects.

Changing the Appearance of an Object

1. From the Actionsmenu, select Attributes.

2. Click the object that you want to change. You can change shapes, lines, graphs, or
graph axes.

The list of the attributes for the selected object are displayed.

3. Press 9 and : to move through the list of attributes.

4. At each attribute icon, press 7 or 8 to move through the options. For example,
select Thick, Thin, or Medium for the Line Weight attribute.

5. Press Enter to apply the changes.

6. Press ESC to close the Attributes tool.

Labelling Points, Geometric Lines, and Shapes

1. Display the context menu of the object.

2. Click Label.

3. Type the text of the label, and then press Enter.

The label attaches itself to the object and follows the object as you move it. The
label's colour matches the object's colour.



Measuring Objects
Measurement values update automatically as you manipulate the measured object.

Note: Measurements of objects created in the Graphs application are displayed in
generic units named u. Measurements of objects created in the Geometry application
are displayed in centimetres (cm).

Measuring Length of a Segment, Circle Arc or Vector

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its length.

Measuring Distance Between Two Points, a Point and a Line, or a Point and a Circle

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the first point.

3. Click the second point or a point on the line or circle.
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In this example, length is measured from the centre of the
circle to the upper left vertex of the polygon.

Measuring Circumference of a Circle or Ellipse or the Perimeter of a Polygon,
Rectangle or Triangle

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its circumference or perimeter.

Measuring a Side of a Triangle, Rectangle or Polygon

1. From theMeasurementmenu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click two points on the object that form the side you want to measure.

Note: You must click two points to measure a side. Clicking the side measures the
entire length of the object's perimeter.



Measuring Area of a Circle, Ellipse, Polygon, Rectangle or Triangle

Note: You cannot measure the area of a polygon constructed using the Segment tool.

1. From theMeasurementmenu, select Area. (In the Graphs application, click
Geometry > Measurement > Area.)

2. Click the object to display its area.

Measuring Slope of a Line, Ray, Segment or Vector

1. From theMeasurementmenu, select Slope. (In the Graphs application, click
Geometry > Measurement > Slope.)

2. Click the object to display its slope.

The value is updated automatically when you manipulate the object.
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Measuring Angles

Measured angles in the Geometry application range from 0° to 180°. Measured angles
in the Graphs application range from 0 radians to π radians. To change the angle unit,
use the Settingsmenu.

1. From theMeasurementmenu, select Angle. (In the Graphs application, click
Geometry > Measurement > Angle.)

2. Click three locations or points to define the angle. The second click defines the
vertex.

Measuring Angles using the Directed Angle Tool

1. From theMeasurementmenu, select Directed Angle. (In the Graphs application,
click Geometry > Measurement > Directed Angle.)

2. Click three locations or existing points to define the angle. The second click defines
the vertex.

3. To reverse the measurement orientation,



a) On the Actionsmenu, select Attributes.

b) Click the angle text. For example, click 300°.

c) Select the orientation attribute, and use the right or left arrow key to change it.

d) Press Esc to close the Attributes tool.

Moving a Measured Value

▶ Drag the measurement to the desired location.

Note: If you move a measurement too far from its object, it stops following the
object. However, its value continues to be updated as you manipulate the object.

Editing a Measured Length

You can set the length of a side of a Triangle, Rectangle or Polygon by editing its
measured value.

▶ Double-click the measurement, and then enter the new value.

Storing a Measured Value as a Variable

Use this method to create a variable and assign a measured value to it.

1. Display the item's context menu, and select Store.

2. Type a variable name for the stored measurement.

Linking a Measured Length to an Existing Variable

Use this method to assign a measured length value to an existing variable.

1. Display the measurement's context menu, and select Variables > Link to.

The menu shows the list of currently defined variables.

2. Click the name of the variable you want to link to.
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Deleting a Measurement

▶ Display the measurement's context menu, and select Delete.

Locking or Unlocking a Measurement

1. Display the measurement's context menu, and select Attributes.

2. Use the up/down arrow keys to highlight the Lock attribute.

3. Use the left/right arrow keys to close or open the lock.

As long as the value remains locked, manipulations are not allowed that would
require the measurement to change.

Transforming Objects
You can apply transformations to drawn objects in both the Graphs and Geometry
applications. If the object's points are labelled, the corresponding points in the
transformed object are labelled using prime notation (A→ A'). To enable automatic
labelling of certain objects, seeWhat You Must Know in this chapter.

Exploring Symmetry

1. From the Transformationmenu, select Symmetry. (In the Graphs application, click
Geometry > Transformation > Symmetry.)

2. Click the object whose symmetry you want to explore.

3. Click a location or existing point to establish the point of symmetry.

A symmetrical image of the object is displayed.

4. Manipulate the original object or the point of symmetry to explore the symmetry.

Exploring Reflection

1. Create a line or segment to predefine the line about which the object will be
reflected.



2. From the Transformationmenu, select Reflection. (In the Graphs application, click
Geometry > Transformation > Reflection.)

3. Click the object whose reflection you want to explore.

4. Click the predefined reflection line or segment.

A reflected image of the object is displayed.

5. Manipulate the original object or the line of symmetry to explore the reflection.

Exploring Translation

1. (Optional) Create a vector to predefine the distance and direction of translation.

2. From the Transformationmenu, select Translation. (In the Graphs application, click
Geometry > Transformation > Translation.)

3. Click the object whose translation you want to explore.

4. Click the predefined vector.
—or—
Click two locations on the work area to indicate the direction and distance of
translation.

A translated image of the object is displayed.

5. Manipulate the original object or the vector to explore the translation.
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Exploring Rotation

1. (Optional) Create an angle measurement to serve as a predefined angle of rotation.

2. From the Transformationmenu, select Rotation. (In the Graphs application, click
Geometry > Transformation > Rotation.)

3. Click the object whose rotation you want to explore.

4. Click a location or point to define the point of rotation.

5. Click the points of the predefined angle.
—or—
Click three locations to define an angle of rotation.

A rotated image of the object is displayed.

6. Manipulate the original object or the point of rotation to explore the rotation.

Exploring Dilation

1. Create a Text object containing a numeric value to serve as a predefined dilation
factor.

Note: You can also use a measured length value as the dilation factor. Keep in mind
that if you use a large value, you may have to pan the display to view the dilated
object.

2. From the Transformationmenu, select Dilation. (In the Graphs application, click
Geometry > Transformation > Dilation.)

3. Click the object whose dilation you want to explore.

4. Click a location or existing point to define the centre point of dilation.

5. Click the Text object or measurement that defines the dilation factor.

A dilated image of the object is displayed.



6. Manipulate the original object or the centre point of dilation to explore the
dilation. You can also edit the dilation factor.

Exploring with Geometric Construction Tools
You can investigate scenarios by adding objects from the Construction tools. The
constructions are dynamic. The midpoint of a line segment, for example, is updated
automatically when you manipulate the endpoints.

While a construction is in progress, a tool appears in the work area (for example,
Parallel ). To cancel, press ESC.

Creating a Midpoint

This tool lets you bisect a segment or define a midpoint between any two points. The
points can be on a single object, on separate objects, or on the work area.

1. From the Constructionmenu, selectMidpoint. (In the Graphs application, click
Geometry > Construction > Midpoint.)

2. Click a point or location to define the first point.

3. Click a second point or location to complete the midpoint.
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Creating a Parallel Line

This tool creates a parallel line with respect to any existing line. The existing line can be
a Graphs axis or any side of a triangle, square, rectangle, or polygon.

1. From the Constructionmenu, select Parallel. (In the Graphs application, click
Geometry > Construction > Parallel.)

2. Click the object that will serve as the reference line.

3. Click a location to create the parallel line.

You can drag the parallel line to move it. If you manipulate the reference object,
the line remains parallel.

Creating a Perpendicular Line

You can create a line that is perpendicular to a reference line. The reference can be an
axis, an existing line, a segment, or one side of a triangle, rectangle, or polygon.

1. From the Constructionmenu, select Perpendicular. (In the Graphs application, click
Geometry > Construction > Perpendicular.)

2. Click a location or existing point through which the perpendicular line should pass.

3. Click the item that will serve as the reference line.



You can drag the intersection point to move the perpendicular. If you manipulate
the reference object, the line remains perpendicular.

Creating a Perpendicular Bisector

You can create a perpendicular bisector on a segment, on one side of a triangle,
rectangle, or polygon, or between any two points.

1. From the Constructionmenu, select Perpendicular Bisector. (In the Graphs
application, click Geometry > Construction > Perpendicular Bisector.)

2. Click the item that will serve as the reference line.
—or—
Click two points to create a perpendicular bisector between them.

Bisecting an Angle

This tool creates an angle bisector. The points of the angle can be on existing objects,
or they can be locations on the work area.

1. From the Constructionmenu, select Angle Bisector. (In the Graphs application, click
Geometry > Construction > Angle Bisector.)

2. Click three locations or points to define the angle. The second click defines the
vertex of the angle.
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The angle bisector adjusts automatically as you manipulate its defining points.

Creating a Locus

The Locus tool enables you to explore the range of motion of one object with respect
to another object as constrained by a shared point.

1. Create a segment, line, or circle.

2. Create a point on the segment, line, or circle.

3. Create another object that uses the point created in the previous step.



Circle created to use the defined point
on the segment.

4. From the Constructionmenu, select Locus. (In the Graphs application, click
Geometry > Construction > Locus.)

5. Click the point shared by the objects.

6. Click the object defined to share the point (this is the object to vary).

The continuous locus is displayed.

Creating a Compass

This tool operates similarly to a geometric compass used for drawing circles on paper.

1. From the Constructionmenu, select Compass. (In the Graphs application, click
Geometry > Construction > Compass.)

2. To set the width (radius) of the compass:

Click a segment.
—or—
Click any side of a triangle, rectangle, polygon, or regular polygon.
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—or—
Click any two existing points or locations on the work area.

3. Click a location to establish the centre of the circle and complete the construction.

The radius adjusts automatically as you manipulate the original segment, side, or
points used to define the radius.

Using Geometry Trace
The Geometry Trace tool leaves a visible trail of a geometric object or function graph as
it is moved or manipulated. The movement can be done manually or by using
animation. This tool is accessible in both the Graphs and Geometry applications.

1. From the Tracemenu, select Geometry Trace.

The Geometry Trace tool appears.

2. Click the object or function that you want to trace to select it.

3. Drag the object, or play the animation.

This example shows traces of a graphed function manipulated by dragging and a
triangle manipulated by animation.



Note: You cannot select or manipulate the trace trail.

4. To erase all trails, select Erase Geometry Trace from the Tracemenu.

5. To stop tracing, press Esc.

Conditional Attributes
You can cause objects to hide, show, and change colour dynamically, based on specified
conditions such as "r1<r2" or "sin(a1)>=cos(a2)."

For example, you might want to hide an object based on a changing measurement that
you have assigned to a variable, or you might want an object’s colour to change based
on a "Calculate" result assigned to a variable.

Conditional behaviours can be assigned to objects or groups in the Graphing, Plane
Geometry, and 3D Graphing views.

Setting Conditional Attributes of an Object

You can set conditions of a selected object either by using its context menu or by
activating the Set Conditions tool from the Actionsmenu and then selecting the object.
These instructions describe using the context menu.

1. Select the object or group.

2. Display the object’s context menu, and click Conditions.

The conditional attributes are displayed.
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For 2D objects For 3D objects

3. (Optional) In the Show When field, enter an expression specifying the conditions
during which the object will be shown. Anytime the condition is not satisfied, the
object will be hidden.

You can specify tolerance by using compound conditionals in the Show When input
field. For example, area>=4 and area<=6.

Note: If you need to see conditionally hidden objects temporarily, click
Actions > Hide/Show. To return to normal viewing, press ESC.

4. (Optional) Enter numbers or expressions that evaluate to numbers in the applicable
colour fields, such as Line Colour orMesh Colour. To see a map of colour values,
click the Coors button.

Map of conditional colour values

5. Click OK in the Conditional Attributes dialogue box to apply the conditions.

Hiding Objects in the Geometry Application
The Hide/Show tool reveals objects you have previously selected as hidden and lets you
select which objects to show or hide.

1. From the Actionsmenu, select Hide/Show.



The Hide/Show tool appears, and currently hidden items (if any) are shown
dimmed.

2. Click objects to toggle their hide/show status.

3. Press Esc to complete your selections and close the tool.

All objects you selected as hidden objects disappear.

4. To view the hidden objects temporarily or restore them as shown objects, open the
Hide/Show tool.

Customizing the Geometry Work Area
Inserting a Background Image

You can insert an image as a background for any Graphs or Geometry page.

1. From the Insertmenu, click Image.

2. Navigate to the image you want to insert, select it, and then click Open.

Adding a Text Object to the Work Area

Use the Text tool to add numeric values, formulas, observations, or other explanatory
information to the Geometry work area.

1. From the Actionsmenu, select Text.

2. Click the location for the text.

3. Type the text in the box that appears, and then press Enter.
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To move a text object, drag it. To edit the text, double-click it. To delete a text object,
display its context menu, and select Delete.

Changing the Attributes of Numeric Text

If you enter a numeric value as text, you can lock it or set its format and displayed
precision.

1. From the Actionsmenu, select Attributes.

2. Click the numeric text to display its list of attributes.

3. Press 9 and : to move through the list.

4. At each attribute icon, press 7 or 8 to move through the options. For example,
select 0 through 9 as the precision.

5. Press Enter to apply the changes.

6. Press Esc to close the Attributes tool.

Animating Points on Objects
You can animate any point created as a point on an object or graph. Multiple points can
be animated simultaneously.

Animating a Point

1. From the Actionsmenu, select Attributes.

2. Click the point to display its attributes.

3. Press▼ to select the animation attributes.

4. Press◄ or ► to choose either unidirectional or alternating animation.

5. Type a value to set the animation speed. Any nonzero speed begins the animation.
To reverse the direction, enter a negative value.

6. Press Enter to display the animation controls  .

7. Press ESC to close the Attributes tool.



Pausing and Resuming All Animations

▶ To pause all animations on a page, click Pause .

▶ To resume all animations, click Play .

Resetting All Animations

Resetting pauses all animations and returns all animated points to the positions they
occupied when they were first animated.

▶ To reset animation, click Reset .

Changing or Stopping the Animation of a Point

1. Click Reset to stop all animation.

2. From the Actionsmenu, select Attributes.

3. Click the point to display its attributes.

4. Select the animation attribute, and type a new animation speed. To stop the point’s
animation, enter zero.

Note: If other animated points exist, the animation controls remain in the work
area.

Adjusting Variable Values with a Slider
A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes and Data & Statistics
applications.
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Horizontal slider for adjusting variable v1.

Minimised vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a maths box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.

2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, click an empty
space in the work area. You can show the handles any time by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimised slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The colour of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.

1. Display the slider's context menu.



2. Click an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations or sequences that refer to undefined variables.

Using the Calculate Tool
The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a maths expression you have entered as a text object.

The following example uses the Calculate tool to calculate the measured angles of a
triangle.

1. Using the Shapesmenu, create a triangle and then measure its angles.

Tip: You can enable options to automatically label points and to force geometric
triangle angles to integers. For more information, seeWhat You Must Know, in this
chapter.
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2. From the Actionsmenu, click Text.

3. Click a location for the text, and type the formula for the calculation.

In this example, the formula calculates three terms.

4. From the Actionsmenu, click Calculate.

5. Click the formula you created.

You are prompted to select a value for each term in the formula.

6. Click each angle measurement when prompted.

Note: If you have stored a measurement as a variable, you can select it when
prompted by clicking . If the name of a stored measurement matches a term in
the formula, you can press “L” when prompted for that term.

After you have selected the third term, the calculation result attaches itself to the
pointer.



7. Position the result, and press Enter to anchor it as a new text object.
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Lists & Spreadsheet Application
The Lists & Spreadsheet application gives you a place to work with tabular data. It lets
you:

• Store numeric data, text or maths expressions.

• Define a table cell in terms of the contents of other cells.

• Define an entire column based on the contents of another column.

• Share columns of data as list variables with other TI-Nspire™ applications. Also
share individual cells as variables.

• Work with variables created in the Graphs & Geometry and Calculator applications.

• Collect tables of real-world data from sensors.

• Generate columns of data-based sequences that you define.

• Plot table data using the Data & Statistics application.

• Generate a table of values for a function.

• Copy and paste table data from the Lists & Spreadsheet application to other
computer applications, such as TI Connect™ software and Excel® spreadsheet
software.

• Perform statistical analysis on lists of data.

Adding a Lists & Spreadsheet Page

▶ To start a new document with a blank Lists & Spreadsheet page:

From the main Filemenu, click New Document and then click Lists & Spreadsheet.

Handheld: Pressc, and select Lists & Spreadsheet .

▶ To add a Lists & Spreadsheet page in the current problem of an existing document:

From the toolbar, click Insert > Lists & Spreadsheet.

Handheld: Press~ and select Insert >Lists & Spreadsheet.



À Lists & Spreadsheet tools (available when a Lists & Spreadsheet work area is
active)

Á Sample Lists & Spreadsheet work area

Â Lists & Spreadsheet entry line

Ã Lists & Spreadsheet data plotted in the Data & Statistics application

Creating and Sharing Spreadsheet Data as Lists
You can define a column as a named list of elements of the same type of data. After
defining a list, you can link to it from the Graphs & Geometry, Calculator or
Data & Statistics applications, and from other instances of the Lists & Spreadsheet
application within the current problem.

Note: Lists & Spreadsheet can display a maximum of 2500 elements in a list.

Sharing a Spreadsheet Column as a List Variable

You share a column of data by naming it as a list variable.

Note: Avoid defining variables that use the same names as those used for statistical
analysis. In some cases, an error condition could occur.

Variable names used for statistical analysis are listed in the TI-Nspire™ Reference Guide,
under the stat.results entry.

1. Click the cell to move to the column’s name cell (the top cell of the column).

—or—

Press▲ as necessary.
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2. Type a name for the list variable, and press Enter.

The column is now available as a list variable to other TI-Nspire™ applications.

3. Create elements in the list the same as you would create data in spreadsheet cells.
For example, you can type the data into each cell or use a formula to generate a
column of data.

Notes:

• If a variable with the name you specified already exists in the current problem,
Lists & Spreadsheet displays an error message.

• When you select the column formula cell of a list, it displays the list name in an
expression similar to width:=.

• Lists can contain empty elements (denoted by “_”) .

• You can refer to a specific element in a named list from the Calculator application.
Use the list name and the element’s position within the list. In a list named Heights,
for example, refer to the first element as Heights[1]. The expression Heights[2]
refers to the second element, and so on.

Linking to an Existing List Variable

Linking a column to an existing list variable lets you easily view and edit the values in
the list. The list can be any shared list in the current problem and can be defined in
Graphs & Geometry, Calculator or any instance of Lists & Spreadsheet.

After you link a column to a list, Lists & Spreadsheet automatically shows any changes
that you make to the list with other TI-Nspire™ applications.

1. Click the column formula cell (the second cell from the top) of the column that you
want to link to the variable.

2. Type the name of the list variable you want to link to.

—or—

Click on the toolbar (pressh on the handheld), click Link To and click the
variable you want to link to.

3. Press Enter.

The column shows the list elements.

Notes:

• You cannot link to the same variable multiple times on the same page.



• Use caution if you link to a system variable. Doing so could prevent the variable
from being updated by the system. System variables include ans and statistics
results (such as stat.results, stat.RegEqn and stat.Resid).

Inserting an Element in a List

When you insert an element in a list, the remaining elements shift downward to create
space. No other columns are affected.

▶ Click Insert > Insert Cell.

Deleting an Element from a List

When you delete an element, the remaining list elements shift upward to close the
gap. The upward shift affects only the selected column.

1. Click the cell of the element to delete.

2. Open the context menu for the cell, and click Delete Cell.

Note: If you press Del or Backspace to clear the contents of the cell instead of
deleting the list element, the element is assigned a value of 0 (zero). The remaining
list elements do not shift.

Creating Spreadsheet Data
You can type numeric values, text or formulas into body cells. Column formula cells can
contain formulas only. (For more information, see Generating Columns of Data.)

Data Examples

Entry Remarks

1.234 Simple numeric entry

“Green” Text - Enclose categorical data (such as the names of colours used in a
study) within quotes to distinguish them from variable names.

Handheld: Press/r to enter quoted data.

=a3*length Formula - Consists of an “=” symbol followed by an expression.
You can type the expression or use the Catalogue and expression
templates to build it. For more information, see the Calculator
section.
To ensure a decimal result instead of a fraction, type one of the
integers in the expression as a decimal. For example, type 1.0 instead
of 1.
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Typing a Maths Expression, Text or Spreadsheet Formula

1. Double-click the cell to select it and put it in edit mode.

Note: If the cell is already selected, you can press Enter or click the entry line.

2. Type the expression, text or formula. Be sure to enclose text entries in quotes and
start formula entries with an “=” symbol.

As you type the data, it appears in the cell and on the entry line simultaneously.

3. Press Enter to complete the entry and move down to the next cell.

—or—

Press Tab to complete the entry and move right to the next cell.

The Lists & Spreadsheet application automatically recalculates any cells that are
dependent on the cell you entered. If you have shared the cell, and other TI-
Nspire™ applications are linked to the cell, the other applications are also updated.

Note: Empty cells in a spreadsheet display as a void represented by an underscore
(_). The underscore is automatically added to empty cells when a list is named or
when an empty cell is referenced in a formula. When you plan to perform
calculations on a range of cells, be sure to notice the location of void cells. Cells
without a value can affect calculations. For example, if you include a void cell in the
range for a sum such as “=b2+c2,” the result of the calculation is void (_).

Inserting a Cell Range into a Formula

The Select Range feature lets you insert a cell range (such as a1:b3) into a formula by
selecting the range instead of typing cell addresses into an argument.

Suppose you want to calculate the mean of a range of cells.

1. Select the cell that will contain the result.

2. From the Datamenu, click List Maths > Mean.

An editable formula appears in the cell.



3. Click Actions > Select > Select Formula Range.

4. Drag a selection rectangle around the range of values for which you want to
calculate the mean.

Handheld: Move to the first cell in the range, holdg, and press the arrow keys.

The formula is updated as you select the cells.

5. Press Enter to complete the formula and display the result.
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Navigating in a Spreadsheet
A spreadsheet includes a column letter at the top of each column and a row number on
the left of each row. The top two rows and the row numbers remain in place as you
scroll. You can name a column of data to make it available as a list variable in TI-
Nspire™ applications.

À Column reference letter

Á Column name cell for defining a column as a list variable

Â Column formula cell for generating a column of data

Ã Row reference number

Ä Body Cells - Any empty (void) element in a list is displayed as an underscore (“_”).
Any value that cannot fit in a cell’s width is truncated (143489...). Hover over the cell
to display the complete value.

Å Entry line (includes cell reference for current cell)

You can select any cell to view or edit its contents. When a spreadsheet is larger than
the Lists & Spreadsheet work area, you can move to different parts of the spreadsheet
by using the Tab key and by pressing short-cut keys.

▶ Press Tab to move between the body of the spreadsheet (data zone) and the
column names and formulas (naming zone).

▶ Press◄,►,▲ and▼ to move through the spreadsheet one cell at a time (move
between cells within a zone). The arrow keys move the cursor from cell to cell and
scroll as necessary to keep the selected cell in view.

▶ Move across several cells at a time by pressing Page up, Page Dn, Home and End.



Handheld: Press/9(Page up),/3 (Page Dn),/7 (Home) and/1
(End) keys.

▶ Use the Go To command on the Actionsmenu to select a specific cell. Type the
cell’s column letter and row number (such as G16).

▶ Press Enter to put the selected cell in Edit mode.

▶ Drag the scroll bar to move vertically without changing the cell or block of cells
selected.

Working with Cells

Working with Colour

The Lists & Spreadsheet application displays black text and cells with a white
background by default. You can change the colour of cells and text to emphasize or
distinguish data. The colours and the order in which colour is assigned is based on the
TI-Nspire™ colour palette.

Changing the Fill Colour of Cells

1. Select the cells to fill with colour. You can choose one or more cells in any adjacent
cells, columns or rows.

2. Access the context menu and click Colour > Fill Colour.

3. Click the colour to apply to the cells.

Note: If you combine colour text and colour cells, choose colours carefully to ensure
visibility as you work with documents in the software and on the handheld.

Changing the Colour of Text

1. Select the cells that contain the text to change. You can choose one or more cells in
any adjacent cells, columns or rows.

2. Access the context menu and click Colour > Text Colour.

3. Click the colour to apply to the text. Empty cells in the selection area show the
colour change when text is added.

Understanding Cell References in Formulas

Use a cell reference to use data from a cell or range of cells in a formula. The
calculation results update automatically when values in cells change.
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Relative references include only the cell’s column letter and row number (for example,
E7). A relative reference describes where a cell is in relation to other cells of the
spreadsheet. The Lists & Spreadsheet application keeps track of relative cell references
and adjusts the reference automatically when surrounding cells shift (because of
actions you perform, such as column deletions or cell insertions).

Follow these guidelines to specify cell references:

• Include a column letter and row number in a relative reference.

• Include the $ symbol before both the column letter and the row number to specify
an absolute reference.

• Include a colon (:) between a two cell reference to specify a range of cells.

Absolute references include the $ symbol before the column letter and before the row
number (for example, $B$16). Absolute references always refer to the cell in a specific
position in the spreadsheet. The application does not automatically adjust the cell
reference when cell positions change.

Typing a Cell Reference in a Formula

1. Double-click the cell and type the formula. For more information, see the Calculator
section.

2. Move to the appropriate position in the formula and type the cell reference. Use
the format for a relative reference (B3), absolute reference ($B$2) or range of cells
(A1:A4).

Note: You can click Recalculate on the Actionsmenu to update all references and
formula results in a spreadsheet.

Deleting the Contents of Cells

1. Click a cell to select it.

—or—

Use the arrow keys to move to the cell.

Note: If you are deleting a range of cells, select a cell at one end or corner of the
range, and then use Shift with the arrow keys to select the remaining cells in the
range.

2. Press Del.



Note: Any cell that uses a formula with an absolute reference to deleted data
shows an error. A cell that uses a formula with a relative reference to deleted data
is updated to use the data currently in the referenced position.

Copying Cells

When you copy cells, any formulas in the original cells are copied to the destination
cells.

1. Click the cell to copy.

—or—

Use the arrow keys to move to the cell.

Note: If you are copying a range of cells, select a cell at one end or corner of the
range, and then use Shift with the arrow keys to select the remaining cells in the
range.

2. Use the standard key short-cut for copying a selection.

Windows®: Press Ctrl+C.

Mac®: Press “+C.

Handheld: Press/C.

3. Click the cell where you want to duplicate the copied cell. If you are copying a block
of data, click the cell that will become the upper left corner of the copied block.

4. Paste the selected cells:

Windows®: Press Ctrl+V.

Mac®: Press “+V.

Handheld: Press/V.

Important: Paste copied data into a cell that is in the same mode as the cell from
which the data was originally copied. Otherwise, a formula could paste as a string
enclosed in quotes instead of a formula.

Filling Adjacent Cells

You can repeat a cell’s formula or value throughout adjacent cells within the row or
column. You can also repeat a range of cells horizontally or vertically. If you fill from a
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range that contains a simple sequence (such as 2, 4, 6), the sequence continues in the
filled cells.

1. Click the cell that contains the value or formula to repeat.

Note: If you are repeating a range of cells, drag to select the range, or select a cell
at one end of the range, and then use Shift with the arrow keys to select the
remaining cells.

2. Click Data > Fill.

3. Use the arrow keys, or drag to select the range that will hold the repetitions.

4. Press Enter.

The value, formula or pattern that you selected for duplication is repeated over the
selected range.

Sharing a Cell Value as a Variable

You can share the value of a cell with other TI-Nspire™ applications by storing it as a
variable. When you define or refer to a shared cell or variable in Lists & Spreadsheet,
the name is preceded with an apostrophe (‘).

1. Click the cell that you want to share.

2. Click on the toolbar, and click Store Var to store the cell’s value.

Handheld: Press/h or pressh and select Store Var).

A formula is inserted into the cell with var as a placeholder for a variable name.

3. Type over the letters “var” with a name for the variable, and press Enter. Use a
variable name that does not exist in the current problem.

The value is shown in bold to indicate that it is now available as a variable to other
TI-Nspire™ applications.

Linking a Cell to a Variable

When you link a cell to a variable, Lists & Spreadsheet keeps the cell value updated to
reflect the current value of the variable. The variable can be any variable in the current
problem and can be defined in Graphs & Geometry, Calculator, Data & Statistics or any
instance of Lists & Spreadsheet.

1. Click the cell that you want to link to a variable.

2. Click on the toolbar, and click Link to.



Handheld: Press/h or pressh and select Link to.

The VarLink menu opens.

3. Under Link To, press▲, and▼ to scroll to the name of the variable.

4. Press Enter.

The cell shows the value of the variable.

Note: Use caution if you link to a system variable. Linking could prevent the variable
from being updated by the system. System variables include statistics results (such as
Stat.RegEqn, Stat.dfError and Stat.Resid) and finance-solver variables (such as tvm.n,
tvm.pmt and tvm.fv).

Working with Rows and Columns of Data

Selecting a row or column

▶ To select a column, move to the top of the column and click the column reference
letter. To select a row, move to the leftmost cell of the row and click the row
reference number. Press Esc to cancel the selection.

Handheld: Hold down▲ to move past the top cell, or hold down◄ to move past
the leftmost cell.

▶ To extend a selection to adjacent rows or columns, hold down Shift and press◄,
►,▲ or▼.

Resizing a Row or Column

1. Click the row or column that you want to resize.

2. From the Actionsmenu, select Resize and then select an option.

3. Choose a resizing option for a column or row.

- For a column, choose Resize Column Width,Maximize Column Width or
Minimise Column Width.

- For a row, you can choose Resize Row Height.

The tools that minimise and maximise the column width work automatically. You
must manually adjust the size to use the Resize Column Width and Resize Row
Height tools.

4. To resize manually, use◄ and► to resize the column, or use▲ and▼ to resize
the row, and then press Enter.
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Inserting an Empty Row or Column

1. Click a column or row where you want to insert the new data.

2. From the Insertmenu, select either Row or Column.

- If you are inserting a row, the remaining rows shift down to create space for the
new row.

- If you are inserting a column, the remaining columns shift right to create space.

Note: If other cells contain formulas with relative references to a displaced row or
column, those references adjust accordingly.

Deleting Entire Rows or Columns

You can delete a row, column, group of rows or group of columns. When you delete a
row or column, the remaining rows or columns move up or left to fill the gap.

1. Click the column or row that you want to delete.

2. (Optional) To select adjacent rows or columns to delete, hold down Shift and press
◄,►,▲ or▼.

3. Display the context menu.

- Windows®: Right-click the selected row.

- Mac®: Hold the “ key, and click the selected row.

- Handheld: Press/b.

4. On the context menu, select Delete Row.

The selected rows or columns are deleted.

Note: If other cells contain formulas that refer to the deleted row or column, those
cells show an error. Relative references to cells whose positions have changed
because of a deletion adjust accordingly.

Copying Rows or Columns

1. Click the row number to copy a row, or click the column letter to copy a column.

2. (Optional) To select adjacent rows or columns to copy, hold down Shift and press
◄,►,▲ or▼.

3. Copy the row or column:

Windows®: Press Ctrl+C.

Mac®: Press “+C.



Handheld: Press/C.

4. Move to any cell in the row or column where you want to place the copied items.

5. Paste the row or column:

Windows®: Press Ctrl+V.

Mac®: Press “+V.

Handheld: Press/V.

The copied row or column is pasted in place, replacing the previous contents.

Note: If you copy a named column, it is pasted with the name removed to prevent a
variable conflict.

Moving a Column

1. Click the column that you want to move.

2. From the Actionsmenu, selectMove Column.

An insertion bar appears.

3. Press◄ and► to place the insertion bar at the column’s new position, and then
press Enter.

Note: Relative references to any cell in a position is affected by the move adjust
accordingly.

Displaying Results as Exact or Approximate

You can choose to display a column’s calculated results in Exact (fraction) or
Approximate (decimal) form. This affects only the values calculated from a formula.

1. Select the column by clicking the reference letter at the top of the column.

Handheld: Hold down▲ to move past the top cell.

2. Display the context menu for the column.

3. On the context menu, click either Data > Exact or Data > Approximate.

Note: To restore the column results to the document’s default setting, select the
column and click Data > Restore Document Setting.

Lists & Spreadsheet Application 257



258 Lists & Spreadsheet Application

Clearing Column Data

The Clear Data command lets you remove the data from selected columns. Clear Data
does not delete the column, and it does not clear a column’s name or formula.

After clearing the data, Lists & Spreadsheet recalculates column formulas for the
selected columns. This makes Clear Data useful for capturing a fresh set of data from
another application or selectively generating a fresh column of random numbers.

1. Click the column or columns that you want to clear.

2. From the Datamenu, select Clear Data.

Note: If a recalculated formula produces the same data as before, it may appear
that the Clear Data command has failed.

Sorting Data
You can sort a selected area of the spreadsheet in ascending or descending order. You
select which column in the selected area will be used as the key for the sort. When the
sort moves data up or down in the key column, the corresponding data in the other
selected columns is also moved up or down. This preserves the integrity of each row.

Note: Sorting is based on numeric values. If you select a key column that contains text,
you could get unexpected results.

1. Select the range of cells.

2. From the Actionsmenu, select Sort.

The Sort dialogue box opens.

3. Click the column letter to use for ordering.

4. Click Descending or Ascending as the sort method, and then click OK.



Note: Sorting a column that is defined by a formula will remove the formula, because it
may not be valid after the sort.

Generating Columns of Data
You can create a column of values based on the contents of another column. You can
also create a column based on any of several types of sequential data.

Entering a formula in a column’s formula cell tells the Lists & Spreadsheet application
that you want to apply the formula to all cells in the column, not just to a single cell.

À Column formula based on a variable

Á Column formula based on another column (column A)

Â Column formula that generates a sequence

Notes:

• If you generate data in a column that already contains one or more cell values,
Lists & Spreadsheet asks for confirmation before replacing the existing values.
Proceeding removes all of the existing values in the column.

• If you edit a cell manually in a column of generated data, Lists & Spreadsheet asks
for confirmation before replacing the generated data. Proceeding removes the
generated data for the entire column.

Lists & Spreadsheet Application 259



260 Lists & Spreadsheet Application

Creating Column Values Based on Another Column

1. Click the column formula cell (the second cell from the top) of the column where
you want to use a formula.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. If the column
is a named list, Lists & Spreadsheet inserts listname:= followed by the cursor.

2. Type the expression for the formula after the = and press Enter Use brackets ([])
after any column letter you include in the formula. For example, type =a[]^2 to
create a column of values in which each cell is the square of the corresponding cell
of column A.

Lists & Spreadsheet shows the formula in the formula cell and fills the column with
the results.

Generating a Column of Random Numbers

This example generates a column of 20 random integers in the range 1 to 6.

1. Click the column formula cell (the second cell from the top) of the column.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. If the column
is a named list, Lists & Spreadsheet inserts listname:= followed by the cursor.

2. After the equal sign, type RandInt(1,6,20).

Note: You can also use the Catalogue or click Data > Random > Integer to insert the
RandInt() function.

3. Press Enter to generate the numbers.



4. Generate (Recalculate) a new set of random numbers:

Windows®: Press Ctrl+R.

Mac®: Press “+R.

Handheld: Press/R.

Generating a Numerical Sequence

1. Click any cell in the column in which you want to generate the sequence.

2. From the Datamenu, select Generate Sequence.

The Sequence dialogue box opens.

3. Type the Formula that will be applied to the column values.

4. Type any Initial Terms required by the sequence. Separate them with commas.

5. Type a starting value for the independent variable (n0).

6. Type a maximum number of values to be generated (nMax).

7. Type the step value (nStep).
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8. (Optional) Type a maximum value for the sequence in the Ceiling Value field.

9. Click OK.

Lists & Spreadsheet shows the formula in the formula cell and fills the column with
the results.

Graphing Spreadsheet Data
You can graph the data in a spreadsheet using Quick Graph or Summary Plot.
Lists & Spreadsheet cells that contain no data are not represented by data points on
graphs.

Using Quick Graph

You can easily create a dot plot of the data in one column or a scatter plot of two
adjacent columns by using the Quick Graph feature. This feature displays the graphed
data using the Data & Statistics application.

To create a scatter plot:

1. Name both of the columns to declare them as lists.

2. Select both columns.



3. From the Datamenu, select Quick Graph.

A Data & Statistics application is added to the page with the plotted data. The
leftmost of the two lists is plotted on the x axis, and the other list is plotted on the y
axis.

4. (Optional) Use the Data & Statistics features to analyse or visually enhance the
graph.

Note: For more information, see Using Data and Statistics.
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Creating a Summary Plot from a Summary Table

In this example, you create a summary table from raw data, and then use the table to
generate a summary plot. For more information, see Using Data & Statistics.

raw data summary table for eye colour based on raw
data

A summary table contains an X (or Y) List and a Summary List.

• The X (or Y) List contains numeric or string values (such as 1999 or “colour”).
Numeric values result in a histogram. String values identify the categories for a bar
chart.

• The Summary List contains numeric values (such as count, frequency, or
probability) for each element in the other list.



To Create a Summary Plot:

Note: For situations in which you already have a summary table, you can skip the first
two steps.

1. Create a list that holds the category identifiers. For this example, name the list
“colour” and type strings for eye colour. Enclose category names in quotes to
prevent them from being interpreted as variables.

2. Create the summary list. For this example, name the list “counts” and type the total
count for each of the eye colours.

3. Select either list by clicking the top cell of the column and pressing ▲.

4. From the Datamenu, select Summary Plot.

The Summary Plot dialogue box opens.

5. If necessary, use Tab and the arrow keys to select the correct lists for X List and
Summary List.
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6. In the Display On field, select how to display the summary plot in the
Data & Statistics application.

• Select Split Page to place the chart on half of the current page.

• Select New Page to add the chart on a new page.

The summary plot is displayed with the list names along the axes and a summary
plot symbol in the lower left corner of the chart window.

Note: In this example, the X List contains string data, so the summary plot displays
as a bar chart. The category strings from the list display beneath the bars.

Exchanging Data with Other Computer Software
You can use the TI-Nspire™ desktop software to copy table data to and from software
outside the TI-Nspire™ applications, such as TI DataEditor (in the TI Connect™ software)
and Excel® spreadsheet software.

For example, you can copy:

• The values of individual cells, a range of cells or an entire list from TI DataEditor.

• The values (not the underlying formulas) of individual cells, a range of cells or an
entire column from an Excel® spreadsheet.

• A number from TI DataEditor.

• The value of a matrix from TI DataEditor.

Example - Copying Data from TI DataEditor

1. Open the TI Connect™ software.



2. Display the TI DataEditor.

3. If necessary, open the file containing the number, list or matrix that you want to
copy.

4. Drag to select the values that you want to copy. To copy an entire list, click the top
cell in the list.

5. Click Edit > Copy.

6. In Lists & Spreadsheet, click the cell where you want the data to be pasted.

If you have copied a range of cells, they will be pasted so that the upper-left corner
of the range is positioned at the selected cell. Any data in those cells will be
overwritten.

7. Click Edit > Paste.
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Copying Cells from an Excel® Spreadsheet

You can copy up to 26 columns and 2500 rows from an Excel® spreadsheet to a
Lists & Spreadsheet application.

1. Drag to select the values that you want to copy from the Excel® spreadsheet. To
copy an entire column, click the column identifier at the top of the column.

Note: If you select non-contiguous columns in the Excel® spreadsheet, they will be
pasted as contiguous columns in Lists & Spreadsheet.

2. Use the standard key short-cut for copying a selection.

Windows®: Press Ctrl+C.

Mac®: Press “+C.

3. In Lists & Spreadsheet, click the cells where you want the data to be pasted.

If you are copying a range of cells, they will be pasted so that the upper-left corner
of the range is positioned at the selected cell. Any data in those cells in will be
overwritten.

4. Paste the data.

Windows®: Press Ctrl+V.

Mac®: Press “+V.

Handheld: Press/V.

Note: Categorical data must be enclosed in quotes (“ “) after the data is pasted.



Capturing Data from Graphs & Geometry
You can use Lists & Spreadsheet application to capture information about objects in the
Graphs & Geometry application. For example, you could track changes in the area of a
triangle as you change the length of a side in the Graphs & Geometry application.

Captured values replace values in the column. If you prefer, you can remove all data
from a column before starting a new capture by clicking Clear Data on the Datamenu.

Capturing Data Manually

1. Make sure the data value that you want to capture is linked to a variable name.

2. Click the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

Note: Captured values replace values in the column.

3. Click Data > Data Capture > Manual.

A capture expression is inserted into the column formula cell with var as a
placeholder for the name of the variable you are capturing.

4. Replace the letters “var” with the name of the variable to capture from
Graphs & Geometry. For example, type area.

The formula cell now contains an expression similar to =capture(area,0).

Note: The argument “0” tells Lists & Spreadsheet that you want to trigger each
capture manually.

5. Press Enter.
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6. From the Graphs & Geometry application, change the object with a measured value
stored as the variable (area, in this example) referenced in the data capture
expression.

7. Each time you are ready to capture the current value of area, press the capture
keys.

Windows®: Press Ctrl+. (the full stop key).

Mac®: Hold down “ and press . (the full stop key).

Handheld: Press/^.

The current area value is added to the end of the list as a list element.

Capturing Data Automatically

When you capture data automatically, you can specify that you want the captures to be
triggered by:

• Changes in the captured variable only.

• Changes in the captured variable or additional variables.

This lets you set up multiple columns of synchronised captures, such as the x and y
coordinates of a moving object.

1. Clear all columns that you will be using for the captured data.

2. Make sure any data values that you want to capture are linked to variable names.

3. Click the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

4. Click Data > Data Capture > Automatic.

A capture expression is inserted into the column formula cell with var as a
placeholder for the name of the variable you are capturing.



5. Replace the letters “var” with the name of the variable to capture. For example,
type objpathX. Alternatively, you can select the variable name from the Variables
menu.

The formula cell now contains an expression similar to =capture(objpathX,1).

Note: The argument “1” tells Lists & Spreadsheet that you want the captures to be
triggered by the variable change.

6. If you want the capture to also be triggered by changes in an additional variable or
variables, type a comma after the 1, and then type the variable name or the name
of a list that itemises the variables.

The formula cell will contain an expression similar to =capture
(objpathX,1,objpathY).

7. Press Enter to complete the formula.

8. If you are capturing multiple columns of synchronised data, set up the additional
columns. For example, you might set up a second capture variable using
=capture(objpathY,1,objpathX).

9. When you are ready to capture the values, begin moving the object or start the
animation that affects it in Graphs & Geometry.

Each captured value is added to the end of the list.

Synchronising Captured Data for a Point

To ensure that both coordinate values for a point are captured even if only one
coordinate changes, you can add {'a,'b} in the third argument of the capture
expression.
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1. In a Graphs & Geometry application, create a point with variables (a,b).

2. Add a Lists & Spreadsheets application to the problem.

3. Enter the capture expressions for both variables.

Column A: =capture('a,1,{'a,'b})

Column B: =capture('b,1,{'a,'b})

4. Move the slider for variable a.



The data captured for b synchronises accordingly.

5. Move the slider for variable b.

The data captured for a synchronises accordingly.
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Using Table Data for Statistical Analysis
Tools on the Statistics menu provide access to wizards that help you perform statistical
analyses on the data in table columns. You specify the location of the data, and
Lists & Spreadsheet stores the results in two columns: one for the result names, and
one for the corresponding values.

Plotting Statistical Data

Some statistics wizards include a Draw box. By default, the box is not selected.
Selecting this box creates a Data & Statistics work area on the page, displays the
calculated results in Lists & Spreadsheet, and draws the results of the statistical analysis
in the Data & Statistics work area.

Note: For functions that support the Draw option, the option is available only if you
type the function in a column formula cell.

Draw box (as shown in the z Test wizard).

Statistics Input Descriptions
The following table describes the different inputs used in Lists & Spreadsheet wizards.

Input Description

m0 Hypothesized value of the population mean that you are testing.

s The known population standard deviation; must be a real
number > 0.

List The name of the list containing the data you are testing.

Frequency List The name of the list containing the frequency values for the data
in List. Default=1. All elements must be integers | 0. The
frequency values can also be typed as a list, in the format {1, 1, 3,



Input Description

2}.

v, Sx, n Summary statistics (mean, standard deviation and sample size)
for the one-sample tests and intervals.

s1 The known population standard deviation from the first
population for the two-sample tests and intervals. Must be a real
number > 0.

s2 The known population standard deviation from the second
population for the two-sample tests and intervals. Must be a real
number > 0.

List 1, List 2 The names of the lists containing the data you are testing for the
two-sample tests and intervals.

Frequency 1,
Frequency 2

The names of the lists containing the frequencies for the data in
List 1 and List 2 for the two-sample tests and intervals.
Defaults=1. All elements must be integers | 0.

v1, Sx1, n1,
v2, Sx2, n2

Summary statistics (mean, standard deviation, and sample size)
for sample one and sample two in two-sample tests and
intervals.

Pooled Specifies whether variances are to be pooled for 2-Sample t Test
and 2-Sample t Interval.

p0 The expected sample proportion for 1-Prop z Test. Must be a real
number, such that 0 < p0 < 1.

x The count of successes in the sample for the 1-Prop z Test and 1-
Prop z Interval.Must be an integer | 0.

n The count of observations in the sample for the 1-Prop z Test and
1-Prop z Interval. Must be an integer > 0.

x1 The count of successes from sample one for the 2-Prop z Test and
2-Prop z Interval. Must be an integer | 0.

x2 The count of successes from sample two for the 2-Prop z Test and
2-Prop z Interval. Must be an integer | 0.

n1 The count of observations in sample one for the 2-Prop z Test and
2-Prop z Interval. Must be an integer > 0.

n2 The count of observations in sample two for the 2-Prop z Test and
2-Prop z Interval. Must be an integer > 0.
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Input Description

C-Level The confidence level for the interval instructions. Must be | 0
and < 100. If it is | 1, it is assumed to be given as a percent and is
divided by 100. Default=0.95.

RegEQ The prompt for the name of the function where the calculated
regression equation is to be stored.

Statistical Calculations

Performing a Statistical Calculation

You can perform statistical calculations to analyse data. The following example fits a
y=mx+b linear regression model to the two lists in columns A and B.

1. From the Statisticsmenu, select Stat Calculation > LinearRegression (mx+b) to
choose the regression model.

The Linear Regression (mx+b) dialogue box opens.

2. Type a[] as the column for the X List.

3. Type b[] as the column for the Y List.

4. To store the regression equation in a specified variable, replace Save RegEqn To
with the name of the variable.

5. Type c[] as the column for the 1st Result.

6. Click OK.



Lists & Spreadsheet inserts two columns: one containing the names of the results,
and one containing the corresponding values.

Note: The results are linked to the source data. For example, if you change a value
in column A, the regression equation is updated automatically.

Storing Statistical Results

Lists & Spreadsheet stores statistical results using a variable-group name with the
format stat.nnn, where nnn is the result name (for example, stat.RegEqn and
stat.Resid). The use of standard names for variables makes it easier to identify and use
the statistical variables later. If you want to use a custom variable group instead of the
standard name, you can edit the formula in the column formula cell.

You could use the following formula to store the results in the variable groupMystatsB.

=LinRegMx(a[],b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression in the Calculator
application or in another column of the Lists & Spreadsheet application:

MystatsB.results

Supported Statistical Calculations

The Stat Calculationsmenu lets you select from the calculations described below. For
more information, see the TI-Nspire™ Reference Guide.
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One-Variable Statistics (OneVar)

Analyses data with one measured variable. You can specify an optional frequency list.
The statistical data returned using this analysis technique are:

• Sample mean, x

• Sum of the data, Gx

• Sum of the squared data, Gx2

• Sample standard deviation, sx

• Population standard deviation, sx

• Sample size, n

• X-min

• First quartile, Q1

• Median

• Third quartile, Q3

• X-max

• Sum of squared deviations, SSx = G(x Nx)2

Two-Variable Statistics (TwoVar)

Analyses paired data. List 1 is the independent variable. List 2 is the dependent
variable. You can specify an optional frequency list. The statistical data returned using
this analysis technique are:

For each list:

• Sample mean, x or y

• Sum of the data, Gx or Gy

• Sum of the squared data, Gx2 or Gy2

• Sample standard deviation, sx = sn-1x or sy = sn-1y

• Population standard deviation, sx = snx or sy = sny

• X-min or Y-min

• First quartile, Q1X or Q1Y

• Median

• Third quartile, Q3X or Q3Y



• X-max or Y-max

• Sum of squared deviations, SSx = G(x Nx)2 or SSy = G(y Ny)2

Additional data:

• Sample size for each data set, n

• Gxy

• Correlation coefficient, R.

Linear Regression (mx+b) (LinRegMx)

Fits the model equation y=ax+b to the data using a least-squares fit. It displays values
form (slope) and b (y-intercept).

Linear Regression (a+bx) (LinRegBx)

Fits the model equation y=a+bx to the data using a least-squares fit. It displays values
for a (y-intercept), b (slope), r2, and r.

Median-Median Line (MedMed)

Fits the model equation y=mx+b to the data using the median-median line (resistant
line) technique, calculating the summary points x1, y1, x2, y2, x3 and y3.Median-
Median Line displays values form (slope) and b (y-intercept).

Quadratic Regression (QuadReg)

Fits the second-degree polynomial y=ax2+bx+c to the data. It displays values for a, b, c,
and R2. For three data points, the equation is a polynomial fit; for four or more, it is a
polynomial regression. At least three data points are required.

Cubic Regression (CubicReg)

Fits the third-degree polynomial y=ax3+bx2+cx+d to the data. It displays values for a, b,
c, d, and R2. For four points, the equation is a polynomial fit; for five or more, it is a
polynomial regression. At least four points are required.

Quartic Regression (QuartReg)

Fits the fourth-degree polynomial y=ax4+bx3+cx2+dx+e to the data. It displays values
for a, b, c, d, e and R2. For five points, the equation is a polynomial fit; for six or more, it
is a polynomial regression. At least five points are required.
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Power Regression (PowerReg)

Fits the model equation y=axb to the data using a least-squares fit on transformed
values ln(x) and ln(y). It displays values for a, b, r2 and r.

Exponential Regression (ExpReg)

Fits the model equation y=abx to the data using a least-squares fit on transformed
values x and ln(y). It displays values for a, b, r2 and r.

Logarithmic Regression (LogReg)

Fits the model equation y=a+b ln(x) to the data using a least-squares fit on transformed
values ln(x) and y. It displays values for a, b, r2 and r.

Sinusoidal Regression (SinReg)

Fits the model equation y=a sin(bx+c)+d to the data using an iterative least-squares fit.
It displays values for a, b, c and d. At least four data points are required. At least two
data points per cycle are required to avoid aliased frequency estimates.

Note: The output of SinReg is always in radians, regardless of the Radian/Degree mode
setting.

Logistic Regression (d=0) (Logistic)

Fits the model equation y=c/(1+a*e-bx) to the data using an iterative least-squares fit.
It displays values for a, b and c.

Logistic Regression (dƒ0) (LogisticD)

Fits the model equation y=c(1+a*e(-bx))+d to the data using an iterative least-squares
fit. It displays values for a, b, c and d.

Multiple Linear Regression (MultReg)

Calculates multiple linear regression of list Y on lists X1, X2, …, X10.

Distributions

Calculating a Distribution

Example: Calculate a distribution to fit the Normal Pdf distribution model.

1. Click the column formula cell (second cell from the top) in column A.

2. Click Statistics > Distributions > Normal Pdf to choose the Distribution model.



The Normal Pdf dialogue box opens and displays fields for typing or selecting the
arguments for the calculation.

3. Press Tab as necessary to move from field to field and provide each argument. You
can type values, or select them from the drop-down list:

- X Value: Click the drop-down arrow to choose any list in the problem to provide
the x values for the calculation.

- Mean: Type a value for the mean or click the drop-down arrow to choose a
variable that contains the mean.

- Standard Deviation: Type a value for the standard deviation or choose a variable
that contains the standard deviation.

4. Click the Draw tick box to see the distribution plotted in Data & Statistics.

Note: The Draw option is not available for all distributions.

5. Click OK.

Lists & Spreadsheet inserts two columns: one containing the names of the results,
and one containing the corresponding values. The results are plotted in Data &
Statistics.

Note: The results are linked to the source data. For example, you can change a
value in Column A, and the equation updates automatically.

Supported Distribution Functions

The following distributions are available from the Lists & Spreadsheet application. For
more information regarding these functions, see the TI-Nspire™ Reference Guide.

• To return a single distribution result based on a single value, type the function in a
single cell.
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• To return a list of distribution results based on a list of values, type the function in a
column formula cell. In this case, you specify a list (column) that contains the
values. For each value in the list, the distribution returns a corresponding result.

Note: For distribution functions that support the draw option (normPdf, t Pdf,
χ² Pdf, and F Pdf), the option is available only if you type the distribution function in
a formula cell.

Normal Pdf (normPdf)

Computes the probability density function (Pdf) for the normal distribution at a
specified x value. The defaults are mean μ=0 and standard deviation σ=1. The
probability density function (Pdf) is:

This distribution is used to determine the probability of the occurrence of a certain
value in a normal distribution. The draw option is available when Normal Pdf is invoked
from a formula cell.

When you access distributions from the formula cell, you must select a valid list from
the drop-down list to avoid unexpected results. If accessed from a cell, you must
specify a number for the x-value. The distribution returns the probability that the value
you specify will occur.

Normal Cdf (normCdf)

Computes the normal distribution probability between Lower Bound and
Upper Bound for the specified mean, μ (default=0) and the standard deviation, s

(default=1). You can click the Draw (Shade area) box to shade the area between the
lower and upper bounds. Changes to the initial Lower Bound and Upper Bound
automatically update the distribution.

This distribution is useful in determining the probability of an occurrence of any value
between the lower and upper bounds in the normal distribution. It is equivalent to
finding the area under the specified normal curve between the bounds.

Inverse Normal (invNorm)

Computes the inverse cumulative normal distribution function for a given area under
the normal distribution curve specified by mean, μ and standard deviation, s.

This distribution is useful in determining the x-value of data in the area from 0 to x<1
when the percentile is known.



t Pdf (tPdf)

Computes the probability density function (Pdf) for the tdistribution at a specified x
value. df (degrees of freedom) must be 0. The probability density function (Pdf) is:

This distribution is useful in determining the probability of the occurrence of a value
when the population standard deviation is not known and the sample size is small. The
draw option is available when tPdf is invoked from a formula cell.

t Cdf (tCdf)

Computes the Student-t distribution probability between Lower Bound and
Upper Bound for the specified df (degrees of freedom). You can click the Draw (Shade
area) box to shade the area between the bounds. Changes to the initial Lower Bound
and Upper Bound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of a value
within an interval defined by the lower and upper bound for a normally distributed
population when the population standard deviation is not known.

Inverse t (invt)

Computes the inverse cumulative t-distribution probability function specified by
Degrees of Freedom, df, for a given area under the curve.

This distribution is useful in determining the probability of an occurrence of data in the
area from 0 to x<1. This function is used when the population mean and/or population
standard deviation is not known.

c2 Pdf (c2 Pdf())

Computes the probability density function (Pdf) for the c2 (chi-square) distribution at a
specified x value. df (degrees of freedom) must be an integer > 0. The probability
density function (Pdf) is:

This distribution is useful in determining the probability of the occurrence of a given
value from a population with a c2 distribution. The draw option is available when c2

Pdf is invoked from a formula cell.
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c2 Cdf (c2 Cdf())

Computes the c2 (chi-square) distribution probability between lowBound and
upBound for the specified df (degrees of freedom). You can click the Draw Shade area
box to shade the area between the lower and upper bounds. Changes to the initial
lowBound and upBound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of value
within given boundaries of a population with a c2 distribution.

F Pdf (F Pdf())

Computes the probability density function (Pdf) for the F distribution at a specified x
value. numerator df (degrees of freedom) and denominator df must be integers > 0.
The probability density function (Pdf) is:

where n = numerator degrees of freedom
d = denominator degrees of freedom

This distribution is useful in determining the probability that two samples have the
same variance. The draw option is available when F Pdf is invoked from a formula cell.

F Cdf (F Cdf())

Computes the F distribution probability between lowBound and upBound for the
specified dfnumer (degrees of freedom) and dfDenom. You can click the Draw (Shade
area) box to shade the area between the lower and upper bounds. Changes to the
initial lowBound and upBound automatically update the distribution.

This distribution is useful in determining the probability that a single observation falls
within the range between the lower bound and upper bound.

Binomial Pdf (binomPdf())

Computes a probability at x for the discrete binomial distribution with the specified
numtrials and probability of success (p) on each trial. The x parameter can be an
integer or a list of integers. 0{p{1 must be true. numtrialsmust be an integer > 0. If
you do not specify x, a list of probabilities from 0 to numtrials is returned. The
probability density function (Pdf) is:

where n = numtrials



This distribution is useful in determining the probability of success in a success/failure
trial, at trial n. For example, you could use this distribution to predict the probability of
getting heads in a coin toss on the fifth toss.

Binomial Cdf (binomCdf())

Computes a cumulative probability for the discrete binomial distribution with n number
of trials and probability p of success on each trial.

This distribution is useful in determining the probability of a success on one trial before
all trials are completed. For example, if heads is a successful coin toss and you plan to
toss the coin 10 times, this distribution would predict the chance of obtaining heads at
least once in the 10 tosses.

Inverse Binomial (invBinom())

Given the number of trials (NumTrials) and the probability of success of each trial
(Prob), this function returns the minimum number of successes, k, such that the
cumulative probability of k successes is greater than or equal to the given cumulative
probability (CumulativeProb).

Inverse Binomial with respect to N (invBinomN())

Given the probability of success of each trial (Prob), and the number of successes
(NumSuccess), this function returns the minimum number of trials, N, such that the
cumulative probability of x successes is less than or equal to the given cumulative
probability (CumulativeProb).

Poisson Pdf (poissPdf())

Computes a probability at x for the discrete Poisson distribution with the specified
mean, μ, which must be a real number > 0. x can be an integer or a list of integers. The
probability density function (Pdf) is:

This distribution is useful in determining the probability of obtaining a certain number
of successes before a trial begins. For example, you could use this calculation to predict
the number of heads that would occur in eight tosses of a coin.

Poisson Cdf (poissCdf())

Computes a cumulative probability for the discrete Poisson distribution with specified
mean, x.
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This distribution is useful in determining the probability that a certain number of
successes occur between the upper and lower bounds of a trial. For example, you could
use this calculation to predict the number of heads displayed between coin toss No.3
and toss No.8.

Geometric Pdf (geomPdf())

Computes a probability at x, the number of the trial on which the first success occurs,
for the discrete geometric distribution with the specified probability of success p. 0{p
{1 must be true. x can be an integer or a list of integers. The probability density
function (Pdf) is:

This distribution is useful in determining the likeliest number of trials before a success
is obtained. For example, you could use this calculation to predict the number of coin
tosses that would be made before a heads resulted.

Geometric Cdf (geomCdf())

Computes a cumulative geometric probability from lowBound to upBound with the
specified probability of success, p.

This distribution is useful in determining the probability associated with the first
success occurring during trials 1 through n. For example, you could use this calculation
to determine the probability that heads display on toss No.1, No.2, No.3, ..., No.n.

Confidence Intervals
Supported Confidence Intervals

The following confidence intervals are available from the Lists & Spreadsheets
application. For more information regarding these functions, see the TI-Nspire™
Reference Guide.

z Interval (zInterval)

Computes a confidence interval for an unknown population mean, m, when the
population standard deviation, s, is known. The computed confidence interval depends
on the user-specified confidence level.

This test is useful in determining how far from a population mean a sample mean can
get before indicating a significant deviation.

t Interval (tInterval)

Computes a confidence interval for an unknown population mean, m, when the
population standard deviation, s, is unknown. The computed confidence interval
depends on the user-specified confidence level.



This test is useful in examining whether the confidence interval associated with a
confidence level contains the value assumed in the hypothesis. Like the z Interval, this
test helps you determine how far from a population mean a sample mean can get
before indicating a significant deviation when the population mean is unknown.

2-Sample z Interval (zInterval_2Samp)

Computes a confidence interval for the difference between two population means
(m1Nm2) when both population standard deviations (s1 and s2) are known. The
computed confidence interval depends on the user-specified confidence level.

This test is useful in determining if there is statistical significance between the means of
two samples from the same population. For example, this test could determine
whether there is significance between the mean college entrance test score of female
students and the mean of college entrance test score of male students at the same
school.

2-Sample t Interval (tInterval_2Samp)

Computes a confidence interval for the difference between two population means
(m1Nm2) when both population standard deviations (s1 and s2) are unknown. The
computed confidence interval depends on the user-specified confidence level.

This test is useful in determining if there is statistical significance between the means of
two samples from the same population. It is used instead of the 2-sample z confidence
interval in situations where the population is too large to measure to determine the
standard deviation.

1-Prop z Interval (zInterval_1Prop)

Computes a confidence interval for an unknown proportion of successes. It takes as
input the count of successes in the sample x and the count of observations in the
sample n. The computed confidence interval depends on the user-specified confidence
level.

This test is useful in determining the probability of a given number of successes that
can be expected for a given number of trials. For instance, casino examiners would use
this test to determine if observed payouts for one slot machine demonstrate a
consistent pay out rate.

2-Prop z Interval (zInterval_2Prop)

Computes a confidence interval for the difference between the proportion of successes
in two populations (p1-p2). It takes as input the count of successes in each sample
(x1 and x2) and the count of observations in each sample (n1 and n2). The computed
confidence interval depends on the user-specified confidence level.

This test is useful in determining if two rates of success differ because of something
other than sampling error and standard deviation. For example, a gambler could use
this test to determine if there is an advantage in the long run by playing one game or
machine versus playing another game or machine.
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Linear Reg t Intervals (LinRegtIntervals)

Computes a linear regression t confidence interval for the slope coefficient b. If the
confidence interval contains 0, this is insufficient evidence to indicate that the data
exhibits a linear relationship.

Multiple Reg Intervals (MultRegIntervals)

Computes multiple regression prediction confidence interval for the calculated y and a
confidence for y.

Stat Tests
Supported Statistical Tests

Hypothesis tests are available from the Lists & Spreadsheets application. For more
information regarding these functions, see the TI-Nspire™ Reference Guide.

Some of the wizards for Stat Tests display a Draw box. By default, the box is not
selected. Selecting the box creates a Data & Statistics work area on the page and plots
the results in that work area.

z test (zTest)

Performs a hypothesis test for a single unknown population mean, m, when the
population standard deviation, s, is known. It tests the null hypothesis H0: m=m0 against
one of the alternatives below.

• Ha: mƒm0

• Ha: m<m0

• Ha: m>m0

This test is used for large populations that are normally distributed. The standard
deviation must be known.

This test is useful in determining if the difference between a sample mean and a
population mean is statistically significant when you know the true deviation for a
population.

t test (tTest)

Performs a hypothesis test for a single unknown population mean, m, when the
population standard deviation, s, is unknown. It tests the null hypothesis H0: m=m0
against one of the alternatives below.

• Ha: mƒm0

• Ha: m<m0

• Ha: m>m0



This test is similar to a z-test, but is used when the population is small and normally
distributed. This test is used more frequently than the z-test because small sample
populations are more frequently encountered in statistics than are large populations.

This test is useful in determining if two normally distributed populations have equal
means, or when you need to determine if a sample mean differs from a population
mean significantly and the population standard deviation is unknown.

2-Sample z Test (zTest_2Samp)

Tests the equality of the means of two populations (m1 and m2) based on independent
samples when both population standard deviations (s1 and s2) are known. The null
hypothesis H0: m1=m2 is tested against one of the alternatives below.

• Ha: m1ƒm2

• Ha: m1<m2

• Ha: m1>m2

2-Sample t Test (tTest_2Samp)

Tests the equality of the means of two populations (m1 and m2) based on independent
samples when neither population standard deviation (s1 or s2) is known. The null
hypothesis H0: m1=m2 is tested against one of the alternatives below.

• Ha: m1ƒm2

• Ha: m1<m2

• Ha: m1>m2

1-Prop z Test (zTest_1Prop)

Computes a test for an unknown proportion of successes (prop). It takes as input the
count of successes in the sample x and the count of observations in the sample n. 1-
Prop z Test tests the null hypothesis H0: prop=p0 against one of the alternatives below.

• Ha: propƒp0

• Ha: prop<p0

• Ha: prop>p0

This test is useful in determining if the probability of the success seen in a sample is
significantly different from the probability of the population or if it is due to sampling
error, deviation or other factors.

2-Prop z Test (zTest_2Prop)

Computes a test to compare the proportion of successes (p1 and p2) from two
populations. It takes as input the count of successes in each sample (x1 and x2) and the
count of observations in each sample (n1 and n2). 2-Prop z Test tests the null hypothesis
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H0: p1=p2 (using the pooled sample proportionÇ) against one of the alternatives
below.

• Ha: p1ƒp2

• Ha: p1<p2

• Ha: p1>p2

This test is useful in determining if the probability of success seen in two samples is
equal.

c2GOF (c2GOF)

Performs a test to confirm that sample data is from a population that conforms to a
specified distribution. For example, c2 GOF can confirm that the sample data came
from a normal distribution.

c2 2-way Test (c22way)

Computes a chi-square test for association on the two-way table of counts in the
specified Observedmatrix. The null hypothesis H0 for a two-way table is: no association
exists between row variables and column variables. The alternative hypothesis is: the
variables are related.

2-Sample FTest (FTest_2Samp)

Computes an F-test to compare two normal population standard deviations (s1 and
s2). The population means and standard deviations are all unknown. 2-Sample FTest,
which uses the ratio of sample variances Sx12/Sx22, tests the null hypothesis H0: s1=s2
against one of the alternatives below.

• Ha: s1ƒs2

• Ha: s1<s2

• Ha: s1>s2

Below is the definition for the 2-Sample FTest.

Sx1, Sx2 = Sample standard deviations having n1N1 and n2N1 degrees of
freedom df, respectively.

F =
F-statistic =

df(x, n1N1,
n2N1)

= Fpdf( ) with degrees of freedom df, n1N1, and n2N1

p = reported p value

2-Sample FTest for the alternative hypothesis s1 > s2.



2-Sample FTest for the alternative hypothesis s1 < s2.

2-Sample FTest for the alternative hypothesis s1ƒs2. Limits must satisfy the following:

where: [Lbnd,Ubnd]=lower and upper limits

The F-statistic is used as the bound producing the smallest integral. The remaining
bound is selected to achieve the preceding integral’s equality relationship.

Linear Reg t Test (LinRegtTest)

Computes a linear regression on the given data and a t test on the value of slope b and
the correlation coefficient r for the equation y=a+bx. It tests the null hypothesis
H0: b=0 (equivalently, r=0) against one of the alternatives below.

• Ha: bƒ0 and rƒ0

• Ha: b<0 and r<0

• Ha: b>0 and r>0

Multiple Reg Tests (MultRegTest)

Computes a linear regression on the given data, and provides the F test statistic for
linearity.

For more information, see the TI-Nspire™ Reference Guide.

ANOVA (ANOVA)

Computes a one-way analysis of variance for comparing the means of 2 to 20
populations. The ANOVA procedure for comparing these means involves analysis of the
variation in the sample data. The null hypothesis H0: m1=m2=...=mk is tested against the
alternative Ha: not all m1...mk are equal.

The ANOVA test is a method of determining if there is a significant difference between
the groups as compared to the difference occurring within each group.

This test is useful in determining if the variation of data from sample-to-sample shows
a statistically significant influence of some factor other than the variation within the
data sets themselves. For example, a box buyer for a shipping firm wants to evaluate
three different box manufacturers. He obtains sample boxes from all three suppliers.
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ANOVA can help him determine if the differences between each sample group are
significant as compared to the differences within each sample group.

ANOVA 2-Way (ANOVA2way)

Computes a two-way analysis of variance for comparing the means of two to 20
populations. A summary of results is stored in the stat.results variable.

The two-way ANOVA analysis of variance examines the effects of two independent
variables and helps to determine if these interact with respect to the dependent
variable. (In other words, if the two independent variables do interact, their combined
effect can be greater than or less than the impact of either independent variable
additively.)

This test is useful in evaluating differences similar to the ANOVA analysis but with the
addition of another potential influence. To continue with the ANOVA box example, the
two-way ANOVA might examine the influence of box material on the differences seen.

Selecting an Alternative Hypothesis (ƒ < >)

Most of the inferential stat editors for the hypothesis tests prompt you to select one of
three alternative hypotheses.

• The first is a ƒ alternative hypothesis, such as mƒm0 for the z Test.

• The second is a < alternative hypothesis, such as m1<m2 for the 2-Sample t Test.

• The third is a > alternative hypothesis, such as p1>p2 for the 2-Prop z Test.

To select an alternative hypothesis, move the cursor to the appropriate alternative, and
then press Enter.

Selecting the Pooled Option

Pooled (2-Sample t Test and 2-Sample t Interval only) specifies whether the variances
are to be pooled for the calculation.

• Select No if you do not want the variances pooled. Population variances can be
unequal.

• Select Yes if you want the variances pooled. Population variances are assumed to
be equal.

To select the Pooled option, select Yes from the drop-down list.

Working with Function Tables
The Lists & Spreadsheet application lets you show a table of function values for any
function in the current problem. You can change the settings for the table, delete
columns, add values for multiple functions, and edit the expression that defines a
function without leaving the Lists & Spreadsheet application.

Switching to a Table

1. While working in the Lists & Spreadsheet application:



Windows®: Press Ctrl+T.

Mac®: Press “+T.

Handheld: Press/T.

The Lists & Spreadsheet application disappears and an empty table is displayed
with a list of the functions that are available in the problem.

Note: If you have previously shown a table for a function from the
Lists & Spreadsheet application, the table includes that function by default.

2. Choose the name of the function for which you want to display values.

Values for the function you selected are displayed in the first column of the table.

3. To move through adjacent cells of the table, press▲ or▼. Press Tab to move from
the body of the table (cells) to the top two rows (cells for column names and
formulas).

4. To hide the table of values and return to the Lists & Spreadsheet application,
repeat Step 1.

Making Changes from a Table

You can change the table of function values using the tools on the Tablemenu.

▶ To remove a column from the table, click any cell and click Delete Column.

▶ To display the list of functions, click a cell in a column and click Choose. Select a cell
in an empty column unless you are replacing values already displayed. Click a
function in the list to add its values to the column.

Note: You can also click the drop-down arrow on the top cell of a column to display
the list of functions in the problem.

▶ To change the expression that defines a function, click Edit Expression. You can also
edit the expression directly on the entry line beneath the table.

Note:When you edit the expression for a function, that function automatically
changes in the application used to define the function. For example, if you edit a
Graphs & Geometry function in the table, the table values and graph of the
function are both updated.

▶ To change the default table settings, choose Edit Table Settings.
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The Table dialogue box opens. Press Tab to move from field to field and type or
select new values for the default table settings:

- Table Start: Type the value to use as the first value in the table of values.

- Table Step: Type a value for the interval between values.

- Independent and Dependent: Click the drop-down arrow to choose Auto or Ask
as the method for populating a column with the values of the independent and
dependent variables. Auto populates the table starting at the defined table
start value and displays an independent and dependent value for each step. Ask
lets you select a cell and press Enter to generate a value for a cell.



Data & Statistics Application
The Data & Statistics application provides tools to:

• Visualise sets of data in different types of plots.

• Directly manipulate variables to explore and visualise data relationships. Data
changes in one application are dynamically applied to all linked applications.

• Explore central tendency and other statistical summary techniques.

• Fit functions to data.

• Create regression lines for scatter plots.

• Graph hypothesis tests and results (z- and t-tests) based on summary statistics
definitions or data.

Adding a Data & Statistics Page

▶ To start a new document with a blank Data & Statistics page:

From the main Filemenu, click New Document, and then click Add Data & Statistics.

Handheld: Pressc, and select Data & Statistics .

▶ To add a Data & Statistics page in the current problem of an existing document:

From the toolbar, click Insert > Data & Statistics.

Handheld: Press~ and select Insert > Data & Statistics.

À Data & Statistics menu

Á Work area

Â Add Variable regions on x-axis and y-axis
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Ã Linear Regression Plot with expression

Ä Data point with coordinates

Basic Operations in Data & Statistics
The Data & Statistics application lets you explore and visualise data and graph
inferential statistics. The Lists & Spreadsheet application can work in conjunction with
the Data & Statistics application. The Lists & Spreadsheet Summary Plot and Quick
Graph tools automatically add a Data & Statistics application to show plots. A list that
you create in a problem (using the Lists & Spreadsheet or Calculator applications) can
be accessed as a variable in any TI-Nspire™ application in that problem.

Changing Data & Statistics Settings

1. From the Settingsmenu, select Settings.

2. Select the settings that you want to use.

• Display Digits. Lets you select the display format for numeric labels in the
current document. Select Auto to automatically follow the setting in the
Document Settings dialogue box.

• Diagnostics. Displays the value of the r2 or R2 statistic (when available) under
certain regression equations.

- r2 is displayed for Linear (mx+b), Linear (a+bx), Power, Exponential and
Logarithmic regressions.

- R2 is displayed for Quadratic, Cubic and Quartic regressions.

Using the Default Caseplot

The Data & Statistics application plots numeric and string (categorical) data from
variables. When you add a Data & Statistics application to a problem that includes lists,
a default caseplot displays on the work area.

The caseplot is like having a stack of cards with information on them and scattering the
cards randomly on a table. You can click a dot to see the information on that “card”.
You can drag a dot to “group” the “cards” by the caption variable.



▶ Click the variable name displayed after Caption to use the caseplot.

- Choose <None> to remove the default caseplot.

- Choose the name of a variable to have it replace the current caseplot variable.

- Hover over any data point to see the summary information.

- Drag any data point toward an axis to see how the points group.

- Activate the Graph Trace tool and press◄ or ► to move across points.

When you add a variable to either axis, the plot for that variable replaces the default
caseplot. The default caseplot redisplays if you remove the plotted variable from each
axis.

Using the Context Menu

The context menu provides access to the tools most commonly used with the selected
object. The context menu displays different options depending on the active object and
the task you are performing.

▶ To open the context menu for an object.

Windows®: Right-click the object.

Mac®: Hold “ and click the object.

Handheld: Point to the object and press/b.

The context menu includes the Colour option. You can use the Colour option to change
the data to the colour of your choice.

Data & Statistics Application 297



298 Data & Statistics Application

Other options that are appropriate for various plots also appear on the context menu.

Selecting Data and Displaying Summary Information

When you hover over part of a plot, the Data & Statistics application displays summary
information for the data it represents.

1. Hover at an area of interest in a plot to display data values or summary
information. For example, you can hover over the centre of a box plot to display
the median summary data.

2. Click once to select a representation of data in a plot.

Data points are shown with a bold outline to indicate selection. You can click a
point a second time to deselect it, or click additional points to add to the selection.

Plotting Variables

To plot variables, start with a problem that includes a Data & Statistics application and
lists created in the Lists & Spreadsheet application or the Calculator application.

1. Click the Add Variable region near the centre of an axis.

If no variable is plotted on the axis, the tooltip Click or Enter to add variable
displays.

2. Click the tooltip Click or Enter to add variable.

A list displays the names of available variables.

3. Click the name of the variable to plot.

Note: By convention, the independent variable is shown on the x-axis.

The default plot for one variable is a dot chart. The data points in the default
caseplot reposition to represent the elements of the selected variable in a dot
chart.

4. (Optional) Click the Add Variable region near the centre of the remaining axis to
plot a second variable.



The default plot for two variables is a scatter plot. The data points shift to represent
the elements of both variables as a scatter plot.

5. (Optional) Repeat Steps 1-3 to choose additional variables to plot on the vertical
axis.

The name of each variable that you add is appended to the label on the axis. The
default data point shape changes to help you distinguish data, and a legend is
displayed to identify the shapes.

6. Change, analyse or explore the plotted data.

- Remove or change the variable on an axis by clicking the Add Variable region
again.

- View the plotted data in another supported plot type by selecting a tool from
the Plot Types menu.

- Choose the Graph Trace tool on the Analysemenu and press◄ or ► to move
across the data points in the plot.

- The lists that you plot as variables can include incomplete or missing cases. (A
case is the data contained in a row of cells in the Lists & Spreadsheet
application.) The Lists & Spreadsheet application displays a void as an
underscore (“_”), and Data & Statistics plots no data point for a void cell.

Manipulating Plotted Data

You can manipulate data points on the Data & Statistics work area to explore their
effects. For example, you could explore how a specific group of values affects the
median.
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You can move a data point only in directions allowed by its definition. If a list is defined
with a formula in Lists & Spreadsheet, the points in Data & Statistics may not move
because of the formula’s restrictions. For example, you can manipulate a plot that
represents the result of y=x, but you can only move along a line.

You cannot move points that represent data in a locked variable or data that represents
a categorical value.

1. On the Data & Statistics work area, click a representation of data—such as a
histogram bin or a whisker of a box plot—that is not locked or restricted by a
formula.

The pointer changes to an open hand to show that the data can be moved.

2. Drag the selection to explore how different values of the point affect the plot.

Handheld: Press/a to grab, and then swipe or use the arrow keys to drag.

As you drag, the changing value displays on the work area.

Overview of Raw and Summary Data
You can create plots directly from raw data or from a summary table.



Raw data Summary table for eye colour based on raw data

• Raw data consists of a single list, such as a list of eye colours. When you create a
plot of raw data, Data & Statistics counts the occurrences for you. Plotting raw data
directly gives you flexibility in analysing it.

• A summary table consists of two lists, such as eye colours (the X or Y List) and
counts of eye-colour occurrences (the Summary List). For more information, see
Using Lists & Spreadsheet chapter.

Working with Numeric Plot Types
Plots can represent the data from a variable in a variety of ways. Choosing the
appropriate plot can help you visualise the data. For example, you may be able to
observe the shape and spread of the data in one plot type and another type may be
useful for determining the best method for statistically evaluating data.

Creating Dot Plots

Dot plots, also known as dot-frequency plots, represent one-variable data. Dot plots
are the default plot type for numeric data. When you plot a variable as a dot plot, one
dot represents each value in the list. Each dot displays on the axis at a point that
correspond to the value.

1. To create a dot plot, click the Add Variable region in the center of an axis and click
the name of a numeric variable. For more information, see Plotting Variables.

2. (Optional) To split a dot plot by category, click the Add Variable region on the other
axis and choose the list that contains the corresponding category data.

3. (Optional) To plot multiple dot plots, choose Add X Variable on the Plot Properties
menu and click a numeric variable from the list that displays.

A second dot plot appears on the work area and the name of the plotted variable is
added to both axis labels.

4. Explore the plotted data.

- Hover over a data point to display data values.
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- Drag a dot to move it. As you move a point, the values associated with it change
on the work area display and in the list for the variable.

- Activate the Graph Trace tool and press◄ or ► to move across the data points
in the plot in list order. Points enlarge and display a bold outline as you move
across them in Trace mode.

Creating Box Plots

The Box Plot Tool plots one-variable data in a modified box plot. “Whiskers” extend
from each end of the box, either to 1.5 times the interquartile range or to the end of
the data, whichever comes first. Points that are a width of 1.5 * Interquartile Range
past the quartiles plot individually, beyond the whiskers. These points are the potential
outliers. When no outliers exist, x-min and x-max are the prompt for the end of each
whisker.

Box plots are useful for comparing two or more sets of data that use the same scale. If
a dataset is large, a box plot can also be useful in exploring data distribution.

1. Click the Add Variable region in the centre of an axis. The default plot for one
numeric variable is a dot plot. For more information, see Plotting Variables.

Note: If two variables are plotted in the work area, you can create a dot plot by
removing one variable. Choose Remove X Variable or Remove Y Variable from the
Plot Typesmenu.

2. On the Plot Typesmenu, click Box Plot.



A modified box plot displays on the Data & Statistics work area.

Note: You can split a box plot by category by adding a list that contains
corresponding categorical data to the y-axis.

3. (Optional) To add additional variables for comparing box plots on the same axis,
click Add X Variable on the Plot Propertiesmenu.

For example, you can use multiple box plots to compare the distributions of sample
proportions. In the example, true proportion is .5 and sample size varies from n=20
to n=40 to n=90.

Notes:

- You can create a box plot with frequency by choosing Add X Variable or Add Y
Variable on the Plot Propertiesmenu.

- You can specify a variable multiple times as you choose variables to plot as box
plots.

- The variable used to provide frequency information is added to the label on the
horizontal axis in the format: x_variablename{frequencylist_name}.
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4. Point and click the regions of the box plot to explore and analyse the data it
represents.

- Hover over a region or over a whisker to display the details for the portion of
the plot that interests you. The label for the quartile that corresponds to your
selection is displayed.

- Click a region of the box plot to select the data points or whiskers. Click again to
remove the selection.

- You can select any box plot that does not include frequency data and choose
Dot Plot on the context menu to change the plot type.

- Drag a selection to move it and explore other possibilities for the data.

- Use the arrow keys to move a data point one pixel at a time.

- Activate the Graph Trace tool and press◄ or ► to move across dots and
regions of the plot. As the trace cursor moves, the values for Q1, the median,
Q3 and whisker ends/outliers are displayed.

5. Change the plot from a modified box plot to a standard box plot by choosing Extend
Box Plot Whiskers on the Plot Propertiesmenu.

The box plot is redrawn as a standard box plot with extended whiskers.

The standard box plot’s whiskers use the minimum and maximum points in the
variable and outliers are not identified. The whiskers on the plot extend from the
minimum data point in the set (x-min) to the first quartile (Q1) and from the third
quartile (Q3) to the maximum point (x-max). The box is defined by Q1, Med
(median), and Q3.

Note: You can click Show Box Plot Outliers on the Plot Propertiesmenu to return to
the modified box plot.

Plotting Histograms

A histogram plots one-variable data and depicts the distribution of data. The number of
bins displayed depends on the number of data points and the distribution of these
points. A value that occurs on the edge of a bin is counted in the bin to the right.

Creating a Histogram from Raw Data

1. Create the list that you want to plot as a histogram. For example, you can enter or
collect data as a named list on a Lists & Spreadsheet page.



2. On a Data & Statistics page, click the x or y axis, and select your list as the data to
plot.

3. From the Plot Typesmenu, click Histogram.

The data forms the bins of a histogram, with Frequency plotted by default on the
unselected axis.

4. Explore the data.

- Hover over a bin to see the information for that bin.

- Click a bin to select it. Click the bin again to deselect it.

- Drag the side of a bin to adjust bin width and number of bins.

Note: The bins are not adjustable in categorical plots or plots in which you
choose variable bin widths.
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- On the Analysemenu, click Graph Trace and press◄ or ► to cycle through the
bins and display their values.

Adjusting the Histogram Scale of Raw Data

1. On the Plot Propertiesmenu, click Histogram Properties and choose Histogram Scale.

2. Choose the format for the scale of the histogram.

- Frequency - displays data based upon the number of values that occur within
each bin. This is the default data representation.

- Percent - displays data in the histogram by each group’s percent value of the
whole data set.

- Density - displays data based upon the density of each group within the data
set.

Creating a Histogram with Frequency or Summary Data

1. On a Lists & Spreadsheet page, create two lists: one containing the “bins”, such as
heights in a population (ht), and the other containing the frequencies of those
heights (freq).

2. On a Data & Statistics page, access the context menu on the x axis, and click Add X
Variable with Summary List.

3. Select ht as the X List and freq as the Summary List.



Note: It is up to you to set the data and bins in a meaningful way when using
summary data.

Setting Equal Bin Widths

By default, bin widths are set to equal. You can specify the width and alignment of
equal-width bins.

1. On the Plot Propertiesmenu, click Histogram Properties > Bin Settings and choose
Equal Bin Width.

The Equal Bin Width Settings dialogueue box opens.

2. Type values to setWidth and Alignment of the bins.

3. Click OK to apply the changes and redraw the bins.

Both the data represented by the bins and the value you type for the alignment
affect the placement of bins on the scale.

Setting Variable Bin Widths

You can set variable bin widths based on a list of bin boundaries.

1. Create a named list containing boundary values.
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For example, a boundary list defined as {60,70,100,110} will create bins at 60 to 70,
70 to 100 and 100 to 110.

Note: The data must fall within the specified bin widths. For example, a data point
of 115 would be outside the bins in the above list, and you would receive a
Data/Bin Location Mismatch error.

2. On the Plot Propertiesmenu, click Histogram Properties > Bin Settings and choose
Variable Bin Width.

The Variable Bin Width Settings dialogue box opens.

3. Select your boundary list as the List of Bin Boundaries.

4. Click OK to apply the changes and redraw the bins.

Note: You cannot change variable bin widths by dragging their boundaries; you
must edit the list of boundaries or restore equal-width bins.

Creating a Normal Probability Plot

A normal probability plot shows one set of data against the corresponding quartile (z)
of the standard normal distribution. You can use normal probability plots to judge the
appropriateness of the normal model for your data.

1. Choose or create the data you want to use for a normal probability plot. Use a
named list from Lists & Spreadsheet or Calculator.

2. Plot the data in one of the following ways:

- Create a dot plot by selecting a column and choosing Quick Graph.

- Add a Data & Statistics work area. Click the Add Variable region on an axis and
click the data list name to plot the variable.

3. On the Plot Typesmenu, click Normal Probability Plot.



The data graphs in the Data & Statistics work area. You can examine the graph to
compare the normal variable against the quartile.

4. Explore the data represented in the normal probability plot.

- Hover over a data point to display its value.

- Click to select a data point. Click again to deselect it.

- Click multiple data points to select them.

- Activate the Graph Trace tool and press◄ or ► to move across the data points
and display values.

Creating a Scatter Plot

A scatter plot shows the relationship between two sets of data. You can also plot a
scatter plot by using the Quick Graph tool in the Lists & Spreadsheet application.

1. In the Data & Statistics work area, click the Add Variable region and select the
variable that contains the data you want to see represented on an axis.

The plot of the selected variable displays on the axis.

2. Click the Add Variable region of the other axis and select the variable containing the
data you want to plot.

The data points shift to represent the data in the selected variable.

3. Analyse and explore the data in the plot.

- Click a point to select it.

- Hover over a data point to view the summary data.

- Work with the data using the available tools on the Analysemenu. For example,
choose the Graph Trace tool and press◄ or ► to move across the plot.
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4. Optional: To plot additional lists against the x-axis, right-click the y-axis and click
Add Variable.

Creating an X-Y Line Plot

An X-Y line plot is a scatter plot in which the data points are plotted and connected in
order of appearance in the two variables. Like scatter plots, these plots depict the
relationship between two sets of data.

By convention, the left-most column of data is represented on the horizontal axis.

1. Create a scatter plot. For more information, see Creating a Scatter Plot.

2. On the Plot Typesmenu, click the XY Line Plot tool.

The data points within each set are connected to each other by a line.

Note: The dots are connected in the order that they appear in the list variable on
the horizontal axis. To change the order, use the sort tool in Lists & Spreadsheet.

3. Analyse and explore the data in the plot.

- Hover over a data point to view the summary data.

- Work with the data using the available tools on the Analysemenu. For example,
choose the Graph Trace tool and press the arrow keys to move across the dots
in the plot and view the values.

Working with Categorical Plot Types
You can sort and group data using the categorical plot types:

• Dot Chart

• Bar Chart

• Pie Chart



The categorical plot types can be used to compare the representations of data across
different plots. When the same variable (list) is used for a dot chart and a bar chart or
pie chart in a problem, selecting a data point or segment in one of the plots selects the
corresponding data point, segment or bar in all other plots that include the variable.

Creating a Dot Chart

The default plot type for categorical data is the dot chart.

When one variable is plotted, the value of each cell is represented as one dot, and the
dots are stacked at the point on the axis that corresponds to the cell value.

1. In Lists & Spreadsheet, create a spreadsheet that includes at least one column of
string values that can be used as categories for data.

Note: To type a string in Lists & Spreadsheet, enclose the characters in quotes.

2. Add a Data & Statistics page to the problem.

Notes:

- You can also use the Lists & Spreadsheet Quick Graph tool to automatically add
a Data & Statistics page and plot the selected column.

- The new Data & Statistic work area displays a default caseplot with a caption,
variable name and unplotted data points for the variable. You can click the
variable name in the caption to choose another variable for previewing, or drag
a default data point toward an axis to plot the current variable.

3. Move near the centre of either axis and click the Add List region. The list of
variables displays.
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4. Click the list that contains the categories you want to use for sorting data.

A dot chart plots in the work area. The application labels the axis with the variable
name and shows a dot for each instance of a category.

5. Explore the plotted data.

- Hover over a dot in the plot to display data values.

- Click a dot to select it. Click the dot a second time to deselect it or remove it
from a selection of multiple dots.

- Activate the Graph Trace tool and press◄ or► to move across the points in
list order. Dots display a bold outline as you move across them in Trace mode.

Creating a Bar Chart

Like dot charts, bar charts display categorical data. The length of a bar represents the
number of cases in the category.

1. Click the Add Variable region of either axis and choose the name of a categorical
variable. For more information, see Creating a Dot Chart.

2. On the Plot Typesmenu, click Bar Chart.

The dot chart changes to a bar representation of the data.



3. Explore the data in the plot.

- Hover over a bar to see a category summary (the number of cases and
percentage among all categories).

- Activate the Graph Trace tool and press◄ or►move across the bars and view
summary information.

Creating a Bar Chart from a Frequency Table or Summary Data

1. On a new Data & Statistics page, create a bar chart with frequency or summary
data by choosing Add X Variable on the Plot Propertiesmenu.

Note: You can also create a bar chart with frequency by selecting Add Variable with
Summary List from the context menu of the Add Variable region of an axis.

2. Select the desired variable from the pop-up choices.

3. Set the height of the bars with the summary variable by selecting Add Summary List
from the Plot Propertiesmenu.

4. Select the summary list from the pop-up choices.

The bar chart plots on the work area. The icon in the lower left corner indicates
that this plot was generated from summary data.
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5. Hover over a bar to see a category summary, or use the Graph Trace tool on the
Analysemenu to move across all of the bars displaying the summaries.

6. (Optional) Add summary lists to create a comparative bar chart.

Creating a Pie Chart

A pie chart represents categorical data in a circular layout and uses an appropriately
proportioned segment for each category.

1. Create a dot chart on the work area.

2. On the Plot Typesmenu, click Pie Chart.

The dots move by category into the segments of the pie chart.

3. Hover over a segment to see the summary for the category, or use the Graph Trace
tool on the Analysemenu to move across each segment displaying all of the
summaries. The summary shows the number of cases for the category and the
percentage among all cases.

Note: You can switch to a pie chart from a bar chart generated from summary data.



Creating a Comparative Bar Chart

This might be used to explore data in a two-way table.

1. Type the raw data on a Lists & Spreadsheet page.

2. From the Insertmenu in the toolbar, click Data & Statistics.

Note: Your screen may differ, depending on the data you entered.

3. Select the Click to add variable field, and select eye colour as the variable for the x
axis.

4. On the Plot Typemenu, click Bar Chart.

The frequency of the eye colour data is plotted.
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5. To split the eye colour data by gender, click the Plot Propertiesmenu, click Split
Categories by Variable and then click gender.

Splitting a Numeric Plot by Categories

You can use a categorical split to sort the values plotted on an axis.

1. Open a problem that includes a Lists & Spreadsheet page, or create data to be
plotted in the Lists & Spreadsheet application.

In this example, lists contain dog breed and daily walk information.



2. Click column letter (B).

3. On the Lists & Spreadsheet Datamenu, click the Quick Graph tool.

The Quick Graph tool adds a Data & Statistics page. Data & Statistics plots the
variable and labels the horizontal axis.

4. To plot the numeric data for each category, hover on the Add Variable region near
the centre of the vertical axis and click the tooltip Click or Enter to add variable.

The list of available variables displays.

5. On the list of variables, click the name of the category variable.

Data & Statistics labels the vertical axis and plots the numeric data for each
category.
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Exploring Data
You can manipulate and explore plotted data.

Moving Points or Bins of Data

1. Click and hold the desired point or bin.

The pointer changes to an open hand÷.

2. Drag the point or bar to the new location and release it. Moving the point changes
the values for x and y.

If you are working with data from Lists & Spreadsheet, the data that corresponds to
the original point or bar automatically updates in the original column(s) in
Lists & Spreadsheet as you move the point.

You can also move points or bins by changing the numbers in the
Lists & Spreadsheet or Calculator applications. Data will update in all of the
representations.



Moving Multiple Points

1. Position the pointer over each data point that you want to select. When the pointer
changes to an open hand÷, click to add the point to the selection.

Alternatively, you can drag a selection rectangle around the points to select them.

2. Drag any of the selected points to move them all.

Note:When a list is defined in Lists & Spreadsheet as a formula, the movement of
points is restricted to positions that satisfy the formula.

Sorting Plotted Categories

You can sort plotted categories in list order, value order or alphabetically by category
name.

1. Click the work area that contains the plotted data.

2. On the Actions menu, click Sort and then click the type of sort.
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Months listed chronologically but sorted by value (amount of rainfall)

Note: You can customise the order of the categories by clicking a label and dragging it.

Plotting a Value

You can plot a value on an existing plot. It displays as a vertical line in the work area.

1. From the Analysemenu, click Plot Value.

A text box with a default expression opens in the work area.

2. Type the value you want to plot, and press Enter. In this example, the value is v1:=
mean(cost).



The line is drawn at that value, perpendicular to the axis. If you have multiple plots
on the work area, a plot value segment displays for each plot.

Note: If you use a frequency table to generate a histogram, reference the frequency
list in your expression. For example, type the expression "v1:= mean(List, FreqList)"
in the plot value entry box.

3. Click the line to display the value.

Note: Double-click the value to edit the expression.

Plot value with value displayed

You can use Plot value for a single number or any expression that evaluates to a
number. If the value is dependent on the data, likemean, when you drag a point or
make changes in the Lists & Spreadsheet application, the line updates to reflect the
change, allowing for investigation of the influence of points on the calculation.

Removing a Plotted Value

1. Select the plotted value line.

2. From the Actionsmenu, click Remove Plotted Value.

Changing the Plot Type

You can change the plot type, to view different representations of data.

▶ On the Plot Typemenu, click a new plot type. Only the supported plot types are
available. For example, only univariate plot types are available when a single
variable plotted on an axis.
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The data representation changes to the new plot format.

Note: Options are unavailable on the menu if the plotted data cannot be
represented by the plot type. For example, if a scatter plot is displayed in the work
area, you cannot create a box plot without first removing the variable from the y-
axis.

Rescaling a Graph

You can change the scale of the axes by using Translation and Dilation. The pointer
changes to indicate whether Translation (ö) or Dilation (ô) is available in zones on the
axes.

Translation

A translation slides a set of axes a fixed distance in a given direction. The original axes
have the same shape and size.

1. Position the pointer over a tick mark or label in the middle third of the axis. The
pointer changes toö.

2. Click to grab. The pointer changes to a grasping handù. Drag to the desired
position and release.

Dilation

Dilation retains the shape of the axes, but enlarges or reduces the size.

1. Position the pointer over a tick mark or label near the ends of the axis. The pointer
changes to ó on the vertical axis or ô on the horizontal axis.



2. Click to grab. The pointer changes to an open hand÷. Drag to the desired position
and release.

Adding a Movable Line

You can add a movable line to a plot. Moving and rotating the line on the work area
changes the function that describes it.

▶ From the Analysemenu, click Add Movable Line.

The movable line displays and is labelled with a function that describes it. For this
example, Data & Statistics stores the expression for the movable line in the variable
m1.

Rotating a Movable Line

1. Click and grab either end of the line.

The pointer changes toé.
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2. Drag to rotate and change the slope of the line.

The function m1(x) is updated for the changes in the position of the movable line.

Changing the Intercept

1. Click in the middle of the movable line.

The pointer changes toö.

2. Drag to change the intercept.

The number at the end of the equation changes to show the change in the
intercept.

Note: The movable line is stored as a function that can be used for prediction in the
Calculator application.

Locking the Intercept at Zero

You can lock the intercept of the movable line at zero.



▶ From the Analysemenu, click Lock Intercept at Zero.

You can unlock the intercept by choosing Unlock Movable Line Intercept on the
Analysemenu.

Tracing a Movable Line

You can trace a movable line to predict and analyse values.

1. Click the line.

The pointer changes.

2. From the Analysemenu, click Graph Trace to enable Trace mode for the line.
Rotation of the line is not supported in Trace mode.

3. Press◄ or ► (left or right arrow keys) to trace the movable line.

If the plotted variables change, points on the graph and the line are updated
automatically.

Showing a Line of Regression

You can show a line of regression when you have a scatter plot or an X-Y line plot on
the work area. Studying the line of regression can help you understand the relationship
between two variables.

1. With a scatter plot or X-Y line plot of two variables on the work area, click the
Analysemenu, choose Regression and view the list of regressions.

2. Click the type of regression line to show. For example, choose Show Linear (mx+b)
to plot a linear regression line as shown in the following example.

When the line of regression is selected, the expression for the line displays.
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Showing Residual Squares

You can display residual squares on a plot. Residual squares can help you assess the
appropriateness of the model for your data.

Note: This tool is only available when a regression or movable line is present in the
work area.

▶ From the Analysemenu, click Residuals > Show Residual Squares.

The sum of squares is updated as the line or data changes.

Showing a Residual Plot

You can show a residual plot to determine how well a line fits data. The work area must
include a scatter plot and one or more movable lines, regressions or plotted functions
for Show Residual Plot to be available.

▶ With a scatter plot, line of regression and/or movable line in the work area, click
the Analysemenu and click Show Residual Plot > Residuals.



Notes:

• With multiple regressions or functions and movable lines plotted, you can select
each by clicking the line to show its residual plot.

• Click and hold a dot on the residual plot to see the residual.

• The residual plot for the selected regression or function displays in the work area.

• For consistency in comparing sets of data, residual plots do not rescale when you
move from one function or regression to another.

• Select a function or regression before a showing residual plot. If no function or
regression is selected and there are several plotted, Data & Statistics arbitrarily
selects the function or regression for showing the residual plot.

• Axes can be adjusted by clicking and dragging.

Removing a Residual Plot

▶ With a scatter plot, line of regression and/or movable line in the work area, click
the Analysemenu, and click Hide Residual Plot.

Using Window/Zoom Tools
Use the Window/Zoom tools to redefine the graph to better view points of interest.
The Window/Zoom tools include:

• Window Settings: displays a Window Settings dialogue box that lets you type the x-
min, x-max, y-min, and y-max values for the axes.

• Zoom - Data: adjusts the zoom factor to display all plotted data.

• Zoom - In: lets you define the centre point of the zoom in location. The Zoom In
factor is approximately 2.

• Zoom - Out: lets you define the centre point of the zoom out location. The Zoom
Out factor is approximately 2.

Using the Window Settings Tool

1. On theWindow/Zoommenu, clickWindow Settings.

TheWindow Settings dialogue box opens. The current values for x-min, x-max, y-
min and y-max are displayed in the fields.

Note: Only the appropriate boxes are editable, depending on whether there are
one or two axes in the work area.

2. Type the new values over the old values.

3. Click OK to apply the changes and redraw the plot.

Using the Zoom Data Tool

▶ On theWindow/Zoommenu, click Zoom Data.
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The work area rescales to display all plotted data.

Using the Zoom In Tool

1. On theWindow/Zoommenu, click Zoom In.

2. In the work area, click the centre point of the area of interest. This will be the
centre of the zoom in action.

The plot redraws to focus and enlarge the portion of the plot centred about the
point you selected in the previous step.

Using the Zoom Out Tool

1. On theWindow/Zoommenu, click Zoom Out.

2. In the work area, click the centre point of the area of interest. This will be the
centre of the zoom out action.

The plot redraws to display a larger portion of the plot, centred about the point you
selected in the previous step.

Graphing Functions
You can graph functions by typing them in Data & Statistics, or you can graph functions
defined in other applications.

Graphing Functions Using the Plot Function Tool

You can use the Plot Function tool to plot functions in a work area that already includes
a plot on the axes. Plot Function lets you specify and graph a function for comparison
to an existing plot.

To use the Plot Function tool:

1. Create or open a problem that includes variables (from Lists & Spreadsheet) that
are plotted on a Data & Statistics work area. Ensure that your work area contains
both a horizontal axis and a vertical axis scale.

2. From the Analysemenu, click Plot Function.

A function entry field displays in the work area.



Note: You can edit the function’s expression typed in the entry field. However, the
function graphed in Data & Statistics cannot be manipulated or moved around the
work area. To do that, use Graphs & Geometry.

3. Type the function in the entry field, and press Enter.

Note: You can rename the function by typing over f1(x): with another name, if you
choose.

The function graphs in the work area and is saved as a variable for use in other
applications.
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Entering Functions from Other Applications

You can enter a function that has been defined as a variable in another application,
such as Lists & Spreadsheet, Graphs & Geometry or Calculator.

1. Add a variable to each axis. You can access any variables defined in a
Lists & Spreadsheet or Calculator application in your problem from the variable list.

2. From the Analysemenu, click Plot Function.

A function entry field displays in the work area.

3. Click on the toolbar.

Handheld: Pressh.

A list of variables available in the problem displays.

4. Click to select the variable containing the function you want to plot.

In the example below, the variable a contains the function f(x)=x2.

5. Press Enter.

The function plots in the work area.



Editing a Function

You can edit a function and update it in the work area.

1. You can edit a function by double-clicking the equation and then making changes as
required.

2. Press Enter after making all changes and the updates are displayed in the work
area.

Using Data & Statistics Functions in other Applications

Data & Statistics functions are stored as variables, and may be used in other
applications, in the same manner as any other variable. Support for all function types is
included.

Note: Function numbers increment to use the next available. If you have defined f1(x)
and f2(x) in Graphs & Geometry, the first function you create in Data & Statistics will be
f3(x).

Using Show Normal PDF

You can approximate data plotted in the Data & Statistics work area against the normal
probability density function. The tool overlays the normal probability density function
using the mean and the standard deviation of the data in the histogram.

To show the normal probability density function for plotted data:

1. Add a variable to the x-axis.

2. On the Plot Typesmenu, click Histogram.
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Note:Show Normal PDF is available only when histogram is the plot type.

3. From the Analysemenu, click Show Normal PDF.

The normal PDF for the graph plots in the work area. The expression used to
calculate the PDF displays when selected.

You can click Hide Normal PDF on the Analysemenu to remove the PDF.

Using Shade Under Function

Use Shade Under Function to find the area of a selected region under a function
graphed in the work area.

1. Select any function graphed in the Data & Statistics work area. For example, select
a previously graphed normal PDF.

2. From the Analysemenu, click Shade Under Function.



The pointer becomes a dotted vertical line and the boundary +/- ˆ displays when
you position the mouse near the boundary on the left or right. You can click when
ˆ displays to set it as a boundary.

3. Select a point on the curve and click to indicate where to start shading under the
function. The direction in which you move next determines whether the region
shaded is on the left, right or centre of the curve.

4. Select a point on the curve and click to indicate the end boundary of the shaded
area. A region under the function is shaded based on the points you selected.

You can work with Shade Under Function in the following ways:

• Select the region to display the values for data points in the shaded area.

• To remove the shading, right-click or Ctrl-click the shaded region and choose
Remove Shaded Region.

• To change the fill colour of the shaded area, right-click or Ctrl-click the shaded
region, choose Colour, choose Fill and click a colour.

• Use plot value to set the boundary to an exact number. When a boundary for
shading is set to a plotted value, you can change the plotted value to update
the shading.

• Edit a shaded region by clicking and dragging the edge at the starting or ending
boundary.

Using Graph Trace
Graph Trace lets you move from one point on a graph to another to analyse variations
in the data. You can use Graph Trace mode to explore the data for the following
graphs.

• Graphs from Plot Function and Show Normal PDF

• Distribution curves (created in the Lists & Spreadsheet application)

• Movable Lines
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• Regressions

• Caseplots

• Dot plots

• Scatter plots and X-Y line plots

• Box plots

• Histograms

• Bar charts

• Pie charts

To use Graph Trace

1. From the Analysemenu, click Graph Trace.

2. Press◄ or ► to move across the plot.

The data representations enlarge and appear with a bold outline as you move
across them in Trace mode.

Customising Your Workspace

Working with Colour

All data points for a plotted variable display in the same colour to distinguish them
from the data points of other variables. Data plotted by category and split plots are
automatically displayed in different colours to help you distinguish the data.

To emphasise or distinguish certain parts of your work, you can change the default
colour for a variable’s data.

• Apply fill colours to objects, such as shading, or change the colour for a variable’s
data points.

• Apply colour to plotted lines (such as lines of regression) or movable lines.

Inserting a Background Image

When using the computer software, you can insert an image as a background for a
Data & Statistics page. The file format of the image can be .bmp, .jpg or .png.

1. From the Insertmenu, click Image.

2. Navigate to the image that you want to insert.

3. Select it, and then click Open.

The image is inserted as a background.

For more information, see theWorking with Images chapter.



Working with Text

The Insert Text tool lets you type text to describe details related to plots on the work
area.

1. From the Actionsmenu, click Insert Text.

A text box opens.

2. Type notes or descriptions in the text box.

3. Customise the text to suit your needs.

• Move the pointer over the edges of the text box to drag the borders and
change the width or height.

• Click and grab the text box to move it near objects that relate to the text.

• Scroll to view additional text in a box by clicking the arrows at the top and
bottom edge.

• Click outside of the text entry box to exit the Text tool.

• Hide text by clicking the Actionsmenu and clicking Hide Text.

• Change the colour of text.

Adjusting Variable Values with a Slider
A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes and Data & Statistics
applications.
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Horizontal slider for adjusting variable v1.

Minimised vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a maths box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.

2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry or Data & Statistics page, handles
are displayed to let you move or stretch the slider.



To remove the handles and use the slider, click an empty
space in the work area. You can show the handles any time by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimised slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The colour of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.

1. Display the slider's context menu.

2. Click an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations or sequences that refer to undefined variables.
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Inferential Statistics
You can explore hypothesis tests and probability distributions in the Data & Statistics
application after entering the data on a Lists & Spreadsheet page.

Drawing Inferential Statistics Plots

The following example uses the Draw option of the normCdf() function to plot a
distribution model.

1. On a Lists & Spreadsheet page, select the column-formula cell (second cell from the
top) in column A.

2. From the Statistics menu, click Distributions, and click Normal Cdf.

3. Type the plot parameters into the Normal Cdf wizard.

4. Select the Draw box to see the distribution plotted and shaded in Data & Statistics.

Note: The Draw option is not available for all distributions.

5. Click OK.



Exploring Inferential Statistics Plots

After drawing the plot in the previous example, you can explore the effect of changing
the upper bound.

▶ On the Data & Statistics plot, drag the vertical line that represents the upper bound
toward the left or right.

As you drag, the formula is updated and the shaded area is recalculated.
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Notes Application
The Notes application lets you create and share text documents using the TI-Nspire™
handheld and computer software. Use Notes to:

• Create study notes to reinforce learning, demonstrate your understanding of
classroom concepts and review for exams.

• Edit collaboratively by assigning different roles to individuals using your document
so that any edits appear in a different text format.

• Create and evaluate maths expressions.

• Create correctly formatted chemical formulas and equations.

Adding a Notes Page

▶ To start a new document with a blank Notes page:

From the main Filemenu, click New Document and then click Add Notes.

Handheld: Pressc, and select Notes .

▶ To add a Notes page in the current problem of an existing document:

From the toolbar, click Insert > Notes.

Handheld: Press~ and select Insert > Notes.

À Notes tools – Available any time you are in the Notes work area.

Á Text formatting toolbar - Lets you change size, colour, bold and other text properties.

Â Notes work area - The area where you type and format text.



Using Templates in Notes
Use the options on the Templates menu to select a format for your Notes page.

Menu Option Function

 2: Templates

 1: Q&A
Creates a template to enter question and answer
text.

 2: Proof
Creates a template to enter statement and reason
text.

 3: Default Lets you type freeform text.

 4:Hide Answer
(Q&A)

Toggles to show or hide the Answer in a Q&A
format.

Selecting a Template

Complete the following steps to select and apply a template:

1. From the Notes menu, click .

2. From the menu, click the template you want to apply.

Handheld: From the Notes work area, pressb, and then press► to display the
menu options.

The Notes page is displayed in the format you selected.

Using the Q&A Template

Use the Q&A template to create questions and answers. You can show or hide the
answer so you can create questions for review and hide the answers. When you use the
document as a study aid, you can verify that your answers are correct.

Press Tab to move the text cursor between the Question and Answer areas of the
template.

Using the Proof Template

The proof template provides an outline structure for statements and corresponding
reasons.
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Press Tab to move the text cursor between the Statements and Reasons areas of the
template.

Formatting Text in Notes
Text formatting lets you apply visual properties, such as bold and italic, to your text.

• Ordinary text. Apply most combinations of bold, italic, underline, superscript,
subscript, and strikethrough formatting. Select font and font size for any character.

• Text in a maths expression box. Apply formatting and enter maths exponents and
maths subscripts for variable names. Select font and font size. Font size affects all
text in the box.

• Text in a chemical equation box. Apply formatting. Select font and font size. Font
size affects all text in the box. Superscript and subscript are handled automatically.

Selecting Text

▶ Drag from the starting point to the ending point to select the text.

Handheld: If you are using the Q&A or Proof template, presse to place the
cursor in the area containing the text. Use the Touchpad to place the cursor at the
start or end of the text to be selected. Hold downg, and use the Touchpad to
select the text.

Applying a Text Format

1. Select the text that you want to format.

2. On the formatting toolbar, click the formatting icons (such as for bold) to toggle
them, or click to select a font and font size.

Handheld: Clickb, and then select Format > Format Text.

The changes are applied to the text as you make selections.



Note: The toolbar shows only the icons that are applicable to the type of text
selected. For example, superscript ( ) and subscript ( ) are shown only for
ordinary text.

Using Colour in Notes

When working in the Notes application on a desktop, use the (fill colour) or the
(text colour) options on the Documents Workspace toolbar to emphasise words,
calculations and formulas.

You can also apply colour to text when working in the Notes application on the TI-
Nspire™ CX handheld.

Changing Text Colours

1. Select the text you want to change to another colour. You can select a sentence,
phrase, word or a single letter. You can also select a maths expression box, a
chemical equation box or individual characters in a calculation, formula, chemical
equation or maths template.

2. From the Documents Workspace toolbar, click .

Handheld: Press~, and then click Edit > Text Colour.

The Text Colour palette opens.

3. Click a colour to apply it to the selected text.

Applying a Background Colour

You can apply a background colour to highlight selected characters in ordinary text,
text in a maths expression or text in a chemical equation box.

1. Select the text.

2. From the Documents Workspace toolbar, click the arrow next to .

Handheld: Press~, and then press Edit > Fill Colour.
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The Fill Colour palette opens.

3. Click a colour to apply it to the selected text.

Inserting Images
When working in the Notes application on a desktop, use the Images option on the
Insert menu to add an image to a Notes page.

Note: The option for inserting an image is not available when working on a handheld.
However, you can transfer a file containing an image from your computer to a TI-
Nspire™ CX handheld and colours are retained.

1. Click Insert > Image from the Documents Toolbar.

The Insert Image window opens.

2. Navigate to the folder where the image is located.

3. Select the image, and then click Open to insert the image into the Notes work area.
Valid files types are .jpg, .png or .bmp.

4. To type text around the image, place the cursor in front of the image or after the
image, and then type the text.

Resizing an Image

Complete the following steps to resize an image.

1. Click the image to select it.

2. Move the cursor to the edge of the image.

The cursor changes to a left-right arrow symbol.

3. Click the mouse and hold to enable the{ tool, and then drag the image to make it
smaller or larger.

4. Release the mouse button when the image is sized correctly.

For more information, seeWorking with Images.

Inserting Items on a Notes Page
When working with the Notes application, open the Insert menu to insert a maths
expression, chemical equation, shape symbol, or a comment.

Menu
Name

Menu Option Function

 3: Insert

 1: Math Box
-/ M

Lets you insert a maths expression.



Menu
Name

Menu Option Function

 2: Chem box
-/ E

Lets you insert a chemical formula or equation.

 3: Shape
Marks the selected text as an angle, triangle, circle,
line, segment, ray, or vector.

 4:
Comment

Lets you type text that is italicised and prefaced with
Teacher or Reviewer.

 5: Slider Lets you insert a slider.

Inserting Comments
You can insert Teacher or Reviewer comments into a Notes application. Comments are
easy to distinguish from the original text.

1. Define the type of comments you’re inserting (Teacher or Reviewer):

- On the Insertmenu, click Comment, and then click Teacher or Reviewer.

- Handheld: While in the Notes work area, pressb to display the Notes menu.
Press Insert > Comment, and then either Teacher or Reviewer.

2. Type your text.

Text that you type appears in italics.

Inserting Geometric Shape Symbols
You can use geometric shape symbols to designate selected text as geometric objects,
such as an angle, circle or line segment.
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To insert a shape symbol, position the cursor where you want it, and then do the
following:

• On the Insertmenu, click Shapes, and then select the shape to apply.

• Handheld: Pressb to display the Notes menu. On the Insertmenu, press Shapes,
and then press the shape to apply.

Entering Maths Expressions in Notes Text
You can include maths expressions in Notes text, using the same tools as in other TI-
Nspire™ applications.

Maths expression boxes have attributes that allow you to control how the expression is
displayed.

Menu
Name

Menu Option Function

5: Maths Box

Options

 1:
Maths Box
Attributes

When a maths box is selected, this option opens a
dialogue box allowing you to customise the maths box.
You can hide or show input or output, turn off calculation
for the box, insert symbols, change display and angle
settings, and allow or disallow the wrapping of expressions
and the display of warning indicator after they have been
dismissed. You can change the attributes of multiple
selected maths boxes at the same time.

 2:
Show
Warning Info

Displays a warning indicator after the warning has been
dismissed.



Menu
Name

Menu Option Function

 3: Show
Error

Displays an error after the error has been dismissed.

Entering an Expression

1. In the Notes work area, position the cursor where you want the expression.

2. From the Insertmenu, selectMaths Box.
—or—
Press Ctrl + M (Mac®: Press “+ M).

An empty maths expression box is displayed.

3. Type the expression in the box. You can use the Catalogue, if necessary, to insert a
function, command, symbol or expression template.

4. To exit the maths box, click anywhere outside it.

Evaluating and Approximating Maths Expressions
You can evaluate or approximate one or more expressions and display the results. You
can also convert selected text and multiple maths expression boxes into a single maths
expression box. Notes automatically updates expressions and any variables used.

Menu
Name

Menu Option Function

1: Actions

1: Evaluate -· Evaluates the expression.

 2: Approximate
/·

Approximates the expression.

3: Evaluate and
replace

Replaces the selected part of the expression
with the result.

 4: Deactivate
Deactivates the current or selected item (box or
boxes)

5: Deactivate All Deactivates all boxes in the current Notes
application.
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Menu
Name

Menu Option Function

6: Activate Activates the current or selected previously
deactivated item.

 7: Activate All Activates all boxes in the current Notes
application.

Evaluating or Approximating an Expression

To evaluate or approximate an expression, place the cursor anywhere in the maths
expression box and then do the following:

• Windows®: On the Actionsmenu, click Evaluate or Approximate. You can also use
Enter to evaluate or Ctrl + Enter to approximate.

• Mac®: Press “ + Enter to approximate.

• Handheld: Pressb to display the Notes menu. On the Actionsmenu, select
Evaluate.

The result replaces the expression.

Evaluating Part of an Expression

To evaluate part of an expression, select the text or part of the maths expression. Then
do the following:

▶ On the Actionsmenu, click Evaluate and Replace.

Handheld: Pressb to open the Notes menu. Select Actions, and then select
Evaluate Selection.

The result replaces the selected part only.

Breaking Long Calculations

Some calculations may take a long time. Notes indicates that the handheld is
performing a long calculation by displaying a busy icon. If a calculation is taking more
time than you want to spend, you can end the calculation.

To stop the function or programme in progress, do the following:

• Windows®: Hold down the F12 key and press Enter repeatedly.

• Mac®: Hold down the F5 key and press Enter repeatedly.

• Handheld: Hold down thec key and press· repeatedly.



Showing Warnings and Errors

If a calculation in Notes results in a warning or error, you can view the warning or error
again even after you have dismissed the dialogue box.

To display a warning or error in Notes after you have dismissed the dialogue box, do
one of the following:

• Windows®: Right-click and select Show warning info or Show error.

• Mac®: “ + click and select Show warning info or Show error.

Note: You can change your settings so that warnings do not appear at all. The showing
of warning indicators is controlled by theMaths Box Attributes dialogue box. See
Changing the Attributes of Maths Expression Boxes.

Converting Selected Items to Maths Expression Boxes

To convert items to maths expression boxes:

1. Select the text, or combination of text and existing maths expression box, that you
want to evaluate.

2. From the Actionsmenu, click Convert to Maths Expression Box.

Using Maths Actions
Maths Actions are available on Notes, Scratchpad and Calculator pages.

When you display the context menu for a selected expression or equation, the menu
may include aMaths Actions submenu that lists the available actions. Each action might
prompt you for any needed parameters.

The specific maths actions listed depend on:

• The type of expression or relation.

• The operating system in use (Numeric, Exact Arithmetic, or CAS).

• Any restrictions imposed by an active Press-to-Test session.

Example of Maths Actions in Notes

1. Insert a maths box, and type the equation x2+3x+1=0, but don't press Enter yet.

Notes Application 349



350 Notes Application

2. Display the context menu of the equation, and selectMaths Actions.
Windows®: Right-click the equation.
Mac®: Hold “, and click the equation.
Handheld: Point to the equation, and press/b.

Numeric and Exact Arithmetic OS CAS OS

3. Select the action to perform:

- Solve Numerically for Numeric and Exact Arithmetic OS.
- Solve for CAS OS.

You are prompted to enter parameters. For example, Numeric Solve prompts for
the variable of interest, initial guess, lower bound and upper bound.

4. Type a value for each parameter. When options are available, you can click an
arrow to make a selection.

Numeric and Exact Arithmetic OS CAS OS



5. Click OK to construct the completed expression and place it in the maths box.

Numeric and Exact Arithmetic OS CAS OS

6. Press Enter to complete the action.

Numeric and Exact Arithmetic OS

CAS OS

7. As a further exploration, drag through the maths box to select x2+3·x+1. Do not
include the "=0" portion.

Numeric and Exact Arithmetic OS

CAS OS

8. Display the context menu for the selected text, selectMaths Actions >
Find Roots of Polynomial, and press Enter to complete the action.

The action and its result are shown in a new maths box.

Numeric OS

Exact Arithmetic and CAS OS

Tips for Using Maths Actions in Notes

▶ For a previously evaluated expression, click in the expression and then display its
context menu.

When you select an action, it replaces the expression.

▶ For a displayed result, click in the result and then display its context menu.

When you select an action, it appears in a new maths box.

▶ For a portion of an expression or result, select the portion and then display the
context menu.

When you select an action, it appears in a new maths box.
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Graphing from Notes and Calculator 
You can graph a function or relation directly from its context menu. This feature is
available for many functions and relations on Notes, Scratchpad and Calculator pages.

If page layout options allow, the graph appears on the same page as the function or
relation. Otherwise, the graph appears on a separate Graphs page.

The type of graph created depends on:

• The type of function or relation.

• Any restrictions imposed by an active Press-to-Test session.

Example of Graphing from Notes

This example uses a Notes page to explore a quadratic function interactively.

1. Insert a maths box on a new Notes page, and enter the following function
definition:

Define f1(x)=x2-1·x-4

2. Display the context menu of the Define statement.
Windows®: Right-click the statement.
Mac®: Hold “, and click the statement.
Handheld: Point to the statement, and press/b.



3. Select Graph from the context menu.

The graph appears. The graph and the maths box are linked so that any adjustment
to one affects the other.

4. Explore the relationship between the defined function and its graph:

- Drag the ends or centre of the graph to manipulate it, and observe the changes
to the function definition.

—or—

- Edit the defined function in the maths box, and observe the changes to the
graph.

Inserting Chemical Equations in Notes
Chemical equation boxes (chem boxes) make it easy to type chemical formulas and
equations, such as .

As you type in a chem box, most of the formatting work is handled automatically:

• Correct capitalisation of most element symbols, such as Ag and Cl, is automatic.

• Leading digits are treated as coefficients and are shown at full size. Numbers that
follow an element or a closed parenthesis are converted to subscripts.

• The equals “=” symbol is converted to a yields “&” symbol.

Notes:

• Equations in a chem box cannot be evaluated or balanced.
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• Element capitalisation may not work in every situation. For example, to enter
carbon dioxide, CO2, you must manually capitalise the O. Otherwise, typing “co”
would result in“Co”, the symbol for cobalt.

Entering a chemical equation

1. In the Notes work area, position the cursor where you want the equation.

2. From the Insertmenu, select Chem Box.
—or—
Press Ctrl + E (Mac®: Press “+ E).

An empty chemical equation box is displayed.

3. Type the equation in the box. For example, to represent sulphuric acid, type
h2sO4, capitalising the O manually.

The chem box automatically formats the text as you type:

4. If you need superscripts for ionic equations, type a caret symbol (^) and then the
text.

5. Use parentheses to indicate whether a compound is solid (s), liquid (l), gas (g), or
aqueous (aq).

6. To exit the chem box, click anywhere outside it.

Deactivating Maths Expression Boxes
Calculations are by default activated, which means that results automatically update
when you evaluate or approximate an expression. If you don’t want results to
automatically update, you can deactivate a maths expression box, group of boxes or
the entire application.

Deactivating a Box or a Group of Boxes

To deactivate a box or a group of boxes:

1. Select the box or boxes that you want to deactivate.

2. Deactivate the selected box or boxes:

• Windows®: Click Actions > Deactivate (or right-click and then click Actions >
Deactivate).

• Mac®: Click Actions > Deactivate (or “ + click and then click Actions >
Deactivate).



• Handheld: Pressb to open the Notes menu. From the Actionsmenu, select
Deactivate.

Note: You can manually update a deactivated box or boxes by selecting the box or
boxes and using the process described in Evaluating and Approximating Maths
Expressions.

Deactivating All Boxes in the Notes Application

To deactivate all boxes in the Notes application:

▶ With a document open, place your cursor in the Notes application that you want to
deactivate and select Deactivate All.

• Windows®: Click Actions > Deactivate All or right-click and click Actions >
Deactivate All.

• Mac®: Click Actions > Deactivate or “+ click and click Actions > Deactivate.

• Handheld: Pressb to display the Notes menu. On the Actionsmenu, click
Deactivate.

Note:When you use this option in Q&A and Proof templates, Deactivate All
deactivates only the maths boxes in the current work area.

Changing the Attributes of Maths Expression Boxes
You can change attributes in one or more maths expression boxes at the same time.
Controlling the attributes in maths expression boxes allows you to do the following:

• Show or hide the input or output or prevent calculation in the box.

• Select a symbol separator using Insert Symbol.

• Choose the number of digits to display in the output of a maths expression.

• Select angle settings so you can use both radian/degree and gradian angle
measures in the same Notes application.

• Select whether to allow maths expressions to wrap.

• Select whether to show or hide warning indicators.

To change the attributes of one or more boxes, do the following:

1. Select the box or boxes that you want to change.

2. On theMaths Box Optionsmenu, clickMaths Box Attributes.

3. Use the menus or selection boxes to make your selections.

4. Click OK to save or Cancel to abandon the change.

Note: Maths expression boxes recalculate automatically after you have made attribute
changes and saved the changes.
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Undoing Changes to Maths Expression Boxes

▶ To undo changes you have made to a maths expression box, click/Z.

Using Calculations in Notes
In the Notes application, the options on the Calculations menu enable you to perform
calculations. The calculations are described in the following table.

Important Information to Know

• Notes does not support editing programmes. Use Programme Editor instead.

• Notes does not support executing Lock or Unlock commands. Use Calculator
instead.

• Notes does not display intermediate results obtained via "Disp" command. Use
Calculator instead.

• Notes does not support user-defined dialogue boxes obtained via "Request,"
"RequestStr," or "Text" commands. Use Calculator instead.

• Notes does not support the execution of multiple statistics commands that produce
stat. variables.

Menu
Name

Menu Option Function

6: Calculations

 1: Define
Variables

Define a variable in a Note using the Calculator application.

 2:
Number

Use tools from the Calculator Number menu, including
Convert to Decimal, Approximate to Fraction, Factorise,
Least Common Multiple, Highest Common Factor,
Remainder, Fraction Tools, Number Tools and Complex-
Number Tools.

 3:
Algebra

Use tools from the Calculator Algebra menu, including
Numerical Solve, Solve System of Linear Equations,
Polynomial Tools.

 4:
Calculus

Use tools from the Calculus menu including Numerical
Derivative at a Point, Numerical Definite Integral, Sum,
Product, Numerical Function Minimum and Numerical
Function Maximum.

 3 (CAS):
Algebra

Use tools from the Calculator Algebra menu, including
Solve, Factorise, Expand, Zeroes, Numerical Solve, Solve
System of Equations, Polynomial Tools, Fraction Tools,
Convert Expressions, Trigonometry, Complex and Extract.

 4 (CAS):
Calculus

Use tools from the Calculus menu including Derivative,
Derivative at a Point, Integral, Limit, Sum, Product,



Menu
Name

Menu Option Function

Function Minimum, Function Maximum, Tangent Line,
Normal Line, Arc Length, Series, Differential Equation
Solver, Implicit Differentiation and Numerical Calculations

 5:
Probability

Use tools from the Calculator Probability menu, including
Factorial, Permutations, Combinations, Random and
Distributions.

 6:
Statistics

Use tools from the Calculator Statistics menu, including
Stats Calculations, Stats Results, List Maths, List Operations
and others.

 7: Matrix
& Vector

Use tools from the Calculator Matrix & Vector menu,
including Create, Transpose, Determinant, Row-Echelon
Form, Reduced Row-Echelon Form, Simultaneous, and
others.

 8:
Finance

Use tools from the Calculator Finance menu, including
Finance Solver, TVM Functions, Amortization, Cash Flows,
Interest Conversions and Days between Dates.

Note: For more information, see the Calculator documentation.

Exploring Notes with Examples
This section shows you how the Notes application works with other applications to
automatically update results.

Example #1: Using Notes to Explore Roots of a Quadratic Function

1. Open a new document and start the Notes application.

2. Define a function in a maths box, evaluate, and hide the output using the Maths
Box attributes.

3. Type some more text; for example: “Real Roots of f1(x) are:”

4. In a new maths box, type: polyRoots(f1(x),x).
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5. Press· and hide the input of this maths box by using the Maths Box attributes
dialogue box.

6. Use the Page Layout toolbar icon to select the split layout.

7. Add the Graph application and plot f1(x).

See how the roots of f1 change when the function is modified in Graph.

Example #2: Using Notes to Explore Data Sampling

In this example, we create a sampling distribution of sample means drawn from a given
population. We will be able to watch the sampling distribution take shape for a given
sample size and describe its characteristics. You can change the population and the
sample size.

1. Set up the population and the sample size.

a) Type "Create sample data:"
b) Insert a maths expression box and define the population. For example, type

"population:=seq(n,n,1,50)".



c) Press· and hide the output using the Maths Expression Box Attributes
dialogue box.

d) Insert a maths expression box and define the sample size. For example, type
"size:=5".

e) Press· and hide the output using the Maths Expression Box Attributes
dialogue box.

2. Set up the initialization.

a) Type "Start taking samples:"
b) Insert a maths expression box and set the initial values for the number of

samples (num) and the list of sample means (sampmeans). Type:

"num:=0:sampmeans:={}"

c) Press· and hide the output using the Maths Expression Box Attributes
dialogue box.

d) Deactivate the maths expression box using Actions > Deactivate. The
deactivation will prevent the content of that maths box from being overwritten
when the values for num and sampmeans change. The deactivated maths box
will be shown with the light colour background.

3. Set up Data & Statistics for the sampling.

a) Change the page layout and insert Data & Statistics.
b) Click on the horizontal axis and add sampmeans list.
c) Change the window setting: XMins=1 and XMax = 50.
d) You can also set up the plot of the mean of sample means using Analyse > Plot

Value.
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4. Enter the instructions to add data.

a) Type "Create new samples:"
b) Insert a maths expression to define the sample (sample) and update the

number of samples and the list of sample means. Type:

"num:=num+1:sample:=randsamp(population,size):
sampmeans:=augment(sampmeans,{mean(sample)})"

c) Press·, hide the output, and turn off the expression wrapping using the
Maths Expression Box Attributes dialogue box.

d) Deactivate the maths expression box using Actions > Deactivate to prevent the
content of the maths box to be overwritten when num and sampmeans values
are reinitialized.

e) Create maths expression boxes that display the current number of experiments
(num), sample (sample) and the list of sample means (sampmeans).

5. Now you are ready to explore. Add more samples by simply pressing· when
you are in the maths expression box in the "Create new samples" section.

Note: You can also automate the sampling process by using a For ... EndFor loop.



You can also change the sample size and restart the sampling.
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Data Collection
The Vernier DataQuest™ application is built into the TI-Nspire™ software and the
operating system (OS) for handhelds. The application lets you:

• Capture, view, and analyse real-world data using a TI-Nspire™ CX II handheld, a
Windows® computer, or a Mac® computer.

• Collect data from up to five connected sensors (three analogue and two digital)
using the TI-Nspire™ Lab Cradle.

Important: The TI-Nspire™ CM-C Handheld is not compatible with the Lab Cradle
and only supports the use of a single sensor at a time.

• Collect data either in the classroom or at remote locations using collection modes
such as time-based or event-based.

• Collect several data runs for comparison.

• Create a graphical hypothesis using the Draw Prediction feature.

• Play back the data set to compare the outcome to the hypothesis.

• Analyse data using functions such as interpolation, tangential rate or modelling.

• Send collected data to other TI-Nspire™ applications.

• Access sensor data from all connected sensor probes through your TI-Basic
program.

Adding a Vernier DataQuest™ Page

Note: The application is launched automatically when you connect a sensor.

Starting a new document or problem for each new experiment ensures that the Vernier
DataQuest™ application is set to its default values.

▶ To start a new document containing a data collection page:

From the main Filemenu, click New Document, and then click Add Vernier
DataQuest™.

Handheld: Pressc, and select Vernier DataQuest™ .

▶ To insert a new problem with a data collection page into an existing document:

From the toolbar, click Insert > Problem>Vernier DataQuest™.

Handheld: Press~ and select Insert > Problem > Vernier DataQuest™.



À Vernier DataQuest™ Menu. Contains menu items for set-up, collection and
analysis of sensor data.

Á Details view. Contains buttons for starting data collection  , changing
collection settings  , marking collected data  , storing data sets  , and
tabs for managing multiple data runs.
View selection buttons let you choose from Meter view  , Graph view , or
Table view .

Â Data work area. The information displayed here depends on the view.
Meter. Displays a list of sensors that are currently connected or set up in
advance.
Graph. Displays collected data in a graphical representation, or displays the
prediction before a data collection run.
Table. Displays collected data in columns and rows.

What You Must Know
Basic Steps in Performing an Experiment

These basic steps are the same no matter which type of experiment you perform.

1. Start the Vernier DataQuest™ Application.

2. Connect sensors.

3. Modify sensor settings.

4. Select the collection mode and collection parameters.

5. Collect data.

6. Stop collecting data.

7. Store the data set.

8. Save the document to save all data sets in the experiment.

9. Analyse the data.
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Sending Collected Data to Other TI-Nspire™ Applications

You can send collected data to the Graphs, Lists & Spreadsheet, and Data & Statistics
applications.

▶ From the Send Tomenu, click the name of the application.

A new page showing the data is added to the current problem.

About Collection Devices
You can select from a variety of sensors and interfaces to collect data while running the
Vernier DataQuest™ application with TI-Nspire™ software.

Multi-Channel Sensor Interfaces

Multi-channel sensor interfaces let you connect more than one sensor at a time.

Sensor Interface Description

Texas Instruments TI-
Nspire™ Lab Cradle

This sensor can be used with a handheld, a computer, or as a
stand-alone sensor.
The sensor interface allows you to connect and use one to five
sensors at the same time. It can be used in the lab or at a
remote collection location.
The Lab Cradle supports two digital sensors and three
analogue sensors.
The Lab Cradle also supports high-sample data collection
sensors, such as a hand-grip heart rate or a blood pressure
monitor.
After using the Lab Cradle as a remote sensor, you can
download data to either a handheld or computer.

Single-Channel Sensor Interfaces

Single-channel sensor interfaces can only connect to one sensor at a time. These
sensors have either a mini-USB connector for a handheld or a standard USB connector
for a computer. For a complete list of compatible sensors, see Compatible Sensors.

Sensor Interface Description

This sensor interface is used with handhelds. It has a
mini-USB connector so it can be plugged directly into
the handheld.
Connect sensors to Vernier EasyLink® to:

• Measure barometric pressure.



Sensor Interface Description
Vernier EasyLink® • Measure the salinity of a solution.

• Investigate the relationship between pressure
and volume (Boyles’ Law).

Vernier Go!Link®

This sensor interface is used with computers. It has a
standard connector so it can be plugged into a
Windows® or Mac® computer.
Connect sensors to Vernier GoLink® to:

• Measure the acidity or alkalinity of a solution.

• Monitor greenhouse gases.

• Measure sound level in decibels.

Types of Sensors

• Analogue sensors. Temperature, light, pH and voltage sensors are analogue sensors
and require a sensor interface.

• Digital sensors. Photogates, radiation monitors and drop counters are digital
sensors. These sensors can only be used with the TI-Nspire™ Lab Cradle.

• Direct-connect USB sensors. These sensors connect directly to a handheld or
computer and do not require a sensor interface.

Sensors for Handhelds

The following lists some sensors you can use with a handheld.

Sensor Description

Texas Instruments CBR 2™

This analogue sensor connects directly to TI-Nspire™ CX II
handhelds through the mini-USB port. It is used to
explore and graph motion.
This sensor automatically launches the Vernier
DataQuest™ application when you connect it to a
handheld. Data collection begins when you select the
Motion Match function.
This sensor collects up to 200 samples per second.
Use this sensor to:

• Measure position and speed of a person or object.

• Measure the acceleration of an object.
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Sensor Description

Vernier EasyTemp®
temperature sensor

This analogue sensor connects directly to TI-Nspire™ CX II
handhelds through the mini-USB port and is used to
collect temperature ranges. You can design experiments
to:

• Collect weather data.

• Record temperature changes due to chemical
reactions.

• Perform heat fusion studies.

Sensors for Computers

The following table lists some sensors you can use with a computer.

Sensor Description

Vernier Go!Temp® temperature
sensor

This analogue sensor connects to the computer’s
USB port and is used to collect temperature ranges.
You can use this sensor to:

• Collect weather data.

• Record temperature changes due to
chemical reactions.

• Perform heat fusion studies.

Vernier Go!Motion® motion
detector

This analogue sensor connects to the computer’s
USB port and is used to measure acceleration,
speed and velocity.
Use this sensor to:
• Measure position and speed of a person or

object.
• Measure the acceleration of an object.

Compatible Sensors

The following sensors can be used with the Vernier DataQuest™ application.

• 25-g Accelerometer

• 30-Volt Voltage Probe

• 3-Axis Accelerometer



• Low-g Accelerometer

• CBR 2™ - Connects directly to handheld USB port

• Go!Motion® - Connects directly to computer USB port

• Extra Long Temperature Probe

• Stainless Steel Temperature Probe

• Surface Temperature Sensor

• Ammonium Ion-Selective Electrode

• Anemometer

• Barometer

• Blood Pressure Sensor

• C02 Gas Sensor

• Calcium Ion-Selective Electrode

• Charge Sensor

• Chloride Ion-Selective Electrode

• Colorimeter

• Conductivity Probe

• High Current Sensor

• Current Probe

• Differential Voltage Probe

• Digital Radiation Monitor

• Dissolved Oxygen Sensor

• Dual-Range Force Sensor

• EasyTemp® - Connects directly to handheld USB port

• EKG Sensor

• Electrode Amplifier

• Flow Rate Sensor

• Force Plate

• Gas Pressure Sensor

• Go!Temp® - Connects directly to computer USB port

• Hand Dynamometer

• Hand-Grip Heart Rate Monitor

• Instrumentation Amplifier

• Light Sensor

• Magnetic Field Sensor

• Melt Station
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• Microphone

• Nitrate Ion-Selective Electrode

• O2 Gas Sensor

• ORP Sensor

• pH Sensor

• Relative Humidity Sensor

• Respiration Monitor Belt (Requires Gas Pressure Sensor)

• Rotary Motion Sensor

• Salinity Sensor

• Soil Moisture Sensor

• Sound Level Meter

• Spirometer

• Thermocouple

• TI-Light - Sold only with the CBL 2™

• TI-Temp - Sold only with the CBL 2™

• TI-Voltage - Sold only with the CBL 2™

• Tris-Compatible Flat pH Sensor

• Turbidity Sensor

• UVA Sensor

• UVB Sensor

• Vernier Constant Current System

• Vernier Drop Counter

• Vernier Infrared Thermometer

• Vernier Motion Detector

• Vernier Photogate

• Voltage Probe

• Wide-Range Temperature Probe

Connecting Sensors
Direct-connect USB sensors, such as the Vernier Go!Temp® temperature sensor (for
computers) or the Vernier EasyLink® temperature sensor (for handhelds), connect
directly to the computer or handheld and do not need a sensor interface.

Other sensors require a sensor interface such as the TI-Nspire™ Lab Cradle.



Connecting Directly

▶ Attach the cable on the sensor directly to the computer's USB port or to an
appropriate port on the handheld.

Connecting through a Sensor Interface

1. Attach the sensor to the sensor interface using either the mini-USB, USB or BT
connector and the appropriate cable.

2. Attach the interface to a computer or handheld using the appropriate connector
and cable.

Note: To attach a handheld to a TI-Nspire™ Lab Cradle, slide the handheld into the
connector at the bottom of the Lab Cradle.

Setting Up an Offline Sensor
You can pre-define meter settings for a sensor that is not currently attached to a
computer or handheld.

You cannot use the sensor offline, but you can prepare the experiment for it and then
attach it when ready to collect the data. This option makes it faster to share a sensor
during a lesson or lab in which there are not enough sensors for everyone.

1. From the Experimentmenu, select Advanced Set Up > Configure Sensor > Add Offline
Sensor.

The Select Sensor dialogue box opens.

2. Select a sensor from the list.

3. Click theMeter View tab .

4. Click the sensor you have added, and modify its settings.

The settings will be applied when you attach the sensor.

Removing an offline sensor

1. From the Experimentmenu, select Advanced Setup > Configure Sensor.

2. Select the name of the offline sensor to remove.
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3. Click Remove.

Modifying Sensor Settings
You can modify how the sensor values are displayed and stored. For example, when
using a temperature sensor, you can change the unit of measure from Centigrade to
Fahrenheit.

Changing Sensor Measurement Units

Measurement units depend on the selected sensor. For example, units for the Vernier
Go!Temp® Temperature sensor are Fahrenheit, Celsius and Kelvin. Units for the Vernier
Hand Dynamometer (a specialised force sensor) are Newton, Pound and Kilogramme.

You can change the units before or after you collect data. The collected data reflects
the new measurement unit.

1. Click Meter view  to display the connected and offline sensors.

2. Click the sensor whose units you want to change.

3. In the Meter Settings dialogue box, select the unit type from theMeasurement
Unitsmenu.



Calibrating a Sensor

When the software or handheld detects a sensor, the calibration for that sensor
automatically loads. You can calibrate some sensors manually. Other sensors, such as
the Colorimeter and the Dissolved Oxygen Sensor, must be calibrated to provide useful
data.

There are three options for calibrating a sensor:

• Manual Entry

• Two Point

• Single Point

Refer to the sensor’s documentation for specific calibration values and procedures.

Setting a Sensor to Zero

You can set the standing value of some sensors to zero. You cannot set sensors in
which relative measurements such as force, motion and pressure are common to zero.
Sensors designed to measure specific environmental conditions, such as Temperature,
pH and CO2 also cannot be set to zero.

1. Click Meter view  to display the connected and offline sensors.

2. Click the sensor that you want to set to zero.

3. In the Meter Settings dialogue box, click Zero.

Reversing a Sensor's Readings

By default, pulling with a force sensor produces a positive force and pushing produces a
negative force. Reversing the sensor allows you to display pushing as a positive force.

1. Click Meter view  to display the connected and offline sensors.

2. Click the sensor that you want to reverse.

3. In the Meter Settings dialogue box, click Reverse Readings.

The sensor display is now reversed. In Meter View, the reverse indicator appears
after the sensor name.
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Collecting Data

Collecting Time-Based Data

The Time Based collection mode captures sensor data automatically at regular time
intervals.

1. Connect the sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experimentmenu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experimentmenu, select Collection Mode > Time Based.

a) Select Rate or Interval from the drop-down list, and then type the Rate
(samples/second) or Interval (seconds/sample).

b) Type the Duration of the collection.

The Number of points is calculated and displayed, based on rate and duration.
Note that collecting too many data points can slow system performance.

c) Select Strip Chart if you want to collect samples continuously, retaining only the
last n samples. (where “n” is the number shown in the Number of points field.)

4. Modify sensor settings as necessary.

5. Click Start Collection .

6. After the data has been collected, click Stop Collection .

The data set run is complete.

Collecting Selected Events

Use the Selected Events collection mode to capture samples manually. In this mode,
each sample is automatically assigned an event number.



1. Connect the sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experimentmenu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experimentmenu, select Collection Mode > Selected Events.

The Selected Events Set-up dialogue box opens.

- Name. This text is visible in the Meter View. Its first letter is displayed as the
independent variable in the Graph view.

- Units. This text is displayed in Graph view alongside the Name.

- Average over 10 s. This option averages ten seconds of data for each point.

4. Modify sensor settings as necessary.

5. Click Start Collection .

The Keep Current Reading icon becomes active. The current sensor value

appears in the centre of the graph.

6. Click Keep Current Reading to capture each sample.

The data point is plotted, and the current sensor value appears in the centre of the
graph.

Note: If you selected the Averaging option, a countdown timer appears. When the
counter reaches zero, the system plots the average.

7. Continue capturing until you collect all of the desired data points.

8. Click Stop Collection .

The data set run is complete.

Collecting Events with Entry

Use the Events with Entry collection mode to capture samples manually. In this mode,
you define the independent value for each point you collect.

1. Connect the sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experimentmenu, select New Experiment.
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This removes all data and restores all meter settings to their defaults.

3. From the Experimentmenu, select Collection Mode > Events with Entry.

The Events with Entry Set-up dialogue box opens.

- Name. This text is visible in the Meter View. Its first letter is displayed as the
independent variable in the Graph view.

- Units. This text is displayed in Graph view alongside the Name.

- Average over 10 s. This option averages ten seconds of data for each point.

4. Modify sensor settings as necessary.

5. Click Start Collection .

The Keep Current Reading icon becomes active. The current sensor value

appears in the centre of the graph.

6. Click Keep Current Reading to capture a sample.

The Events with Entry dialogue box opens.

7. Type a value for the independent variable.

8. Click OK.

The data point is plotted, and the current sensor value appears in the centre of the
graph.

Note: If you selected the Averaging option, a countdown timer appears. When the
counter reaches zero, the system plots the average.

9. Repeat steps 6 to 8 until you collect all of the desired data points.

10. Click Stop Collection .

The data set run is complete.



Collecting Photogate Timing Data

The Photogate Timing collection mode is available only when using the Vernier
Photogate sensor. This sensor can time objects that pass through the gates or objects
that pass outside of the gates.

1. Connect the Photogate sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experimentmenu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experimentmenu, select Collection Mode > Photogate Timing.

4. Set the collection options.

5. Modify sensor settings as necessary.

6. Click Start Collection .

7. After the data has been collected, click Stop Collection .

The data set run is complete.

Collecting Drop Counter Data

The Drop Counting collection mode is available only when using the Vernier Drop
Counter optical sensor. This sensor can count the number of drops or record the
amount of liquid added during an experiment.

1. Connect the Drop Counter sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experimentmenu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experimentmenu, select Collection Mode > Drop Counting.

4. Set the collection options.

5. Modify sensor settings as necessary.

6. Click Start Collection .

7. After the data has been collected, click Stop Collection .

The data set run is complete.
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Using Data Markers to Annotate Data
Data markers give you a way to emphasise specific data points, such as when you
change a condition. For example, you might mark a point at which a chemical is added
to a solution or when heat is applied or removed. You can add a marker with or without
a comment, and you can hide a comment.

Two data markers, one with a comment displayed

Marker shown as red triangle in Table view

Adding a Marker During Data Collection

▶ Click Add Data Marker to place a marker at the current data point.

Adding a Marker After Collecting Data

1. In Graph or Table view, click the point at which you want a marker.

2. Click Add Data Marker .



3. Complete the items in the dialogue box.

Adding a Comment to an Existing Marker

1. In the Detail view, click to expand the list of markers for the data set.

2. Click the entry for the marker that you want to change, and complete the items in
the dialogue box.

Repositioning a Data Marker

1. Click to expand the list of markers in the Detail view.
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2. Click the entry for the marker that you want to change.

3. In the dialogue box, type a new value forMark Value at.

Moving a Data Marker's Comment in the Graph View

▶ Drag the comment to move it. The connecting line remains attached to the data
point.

Hiding/Showing a Data Marker's Comment

▶ Hide a comment by clicking the X at the end of the comment.

▶ To restore a hidden comment:

a) Click to expand the list of markers in the Detail view.

b) Click the entry for the marker that you want to change, and tick
Show Comment on Graph.

Removing a Data Marker

1. Click to expand the list of markers in the Detail view.

2. In the dialogue box, click Remove.

Collecting Data Using a Remote Collection Unit
To collect information from a sensor while it is disconnected, you can set it up as a
remote sensor. Only the TI-Nspire™ Lab Cradle, TI CBR 2™, and Vernier Go!Motion®
support remote data collection.

You can set up a remote collection unit to start collecting:

• When you press a manual trigger on the unit, as on the TI-Nspire™ Lab Cradle

• When a delay countdown expires on a unit that supports a delayed start



Setting Up for Remote Collection

1. Save and close any open documents, and start with a new document.

2. Connect the remote collection unit to the computer or handheld.

3. Modify the sensor settings.

4. Click the Collection Setup button .

5. On the Collection Setup screen, click Enable Remote Collection.

6. Select the remote collection unit from the Devices list.

7. Specify the method for starting the collection:

• To start automatically after a specified delay (on supported units), type the
delay value.

• To start when you press the manual trigger (on supported units), type a delay
value of 0. When you use a delay, the manual trigger button on the TI-Nspire™
Lab Cradle has no effect on the start of the collection.

8. Click OK.

A message confirms that the unit is ready.
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9. Disconnect the unit.

Depending on the device, LED lights may indicate its status.

Red. The system is not ready.

Amber. The system is ready but not collecting data.

Green. The system is collecting data.

10. If you are starting collection manually, press the trigger when ready. If you are
starting based on a delay, the collection will start automatically when the
countdown is complete.

Retrieving the Remote Data

After collecting data remotely, you transfer it to the computer or handheld for analysis.

1. Open the Vernier DataQuest™ application.

2. Attach the TI-Nspire™ Lab Cradle to the handheld or computer.

The Remote Data Detected dialogue box opens.

3. Click Import.

The data transfers to the Vernier DataQuest™ application.

Setting Up the Sensor for Triggering
To start data collection based on a specific sensor reading, the TI-Nspire™ Lab Cradle
and sensor must be connected.

1. Connect the sensor.



2. Click Experiment > Advanced Set up > Triggering > Set Up.

The Configure Trigger dialogue box opens.

3. Select the sensor from the Select the sensor to use as trigger drop-down list.

Note: The menu displays the sensors connected to the TI-Nspire™ Lab Cradle.

4. Select one of the following from the Select the type of trigger to use drop-down list.

• Increasing through threshold. Use to trigger on increasing values.
• Decreasing through threshold. Use to trigger on decreasing values.

5. Type the appropriate value in the Enter the trigger threshold in units of the selected
sensor field.

When entering the trigger value, enter a value within the range of the sensor.

If you change the unit type after setting the threshold, the value automatically
updates.

For example, if you use the Vernier Gas Pressure sensor with the units set as atm
and you later change the units to kPa, the settings are updated.

6. Type the number of data points to keep before the trigger value occurs.

7. Click OK.

The trigger is now set and enabled if values were entered.

8. (Optional) Select Experiment > Advanced Set up > Triggering to verify the active
indicator is set to Enabled.
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Important:When the trigger is enabled, it stays active until it is disabled or you start
a new experiment.

Enabling a Disabled Trigger

If you set the trigger values in the current experiment, and then disable them, you can
enable the triggers again.

To enable a trigger:

▶ Click Experiment > Advanced Set Up > Triggering > Enable.

Disabling an Enabled Trigger

To disable the active trigger.

▶ Click Experiment > Advanced Set Up > Triggering > Disable.

Collecting and Managing Data Sets

By default, the Start Collection button  overwrites collected data with data from
the next run. To preserve each run, you can store it as a data set. After collecting
multiple data sets, you can superimpose any combination of them on the Graph View.

Important: Stored data sets are lost if you close the document without saving it. If you
want stored data to be available later, make sure to save the document.

Storing Data as Sets

1. Collect the data from the first run. (See Collecting Data.)

2. Click the Store Data Set button .

The data is stored as run1. A new data set, run2, is created for collecting the next
run.

3. Click Start Collection to collect data for run2.



Comparing Data Sets

1. Click the Graph View icon to show the graph.

2. Click the Data Set Selector (near the top of the Detail View) to expand the list of
data sets.

À Data Set Selector lets you expand or collapse the list.

Á Expanded list shows available data sets. Scroll buttons appear as necessary
to let you scroll the list.

3. Choose which data sets to view by selecting or clearing the tickboxes.

The graph is rescaled as necessary to show all selected data.
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Tip: To quickly select a single data set, hold down Shift while clicking its name in the
list. The graph shows only the selected set, and the list is collapsed automatically to
help you view details of the data.

Renaming a Data Set

By default, data sets are named run1, run2 and so on. The name of each data set is
displayed in the Table view.

1. Click the Table View icon to show the table.

2. Display the context menu for the table view, and select Data Set Options > [current
name].

3. Type the new Name.

Note: The maximum character limit is 30. The name cannot contain commas.

4. (Optional) Type Notes about the data.

Deleting a Data Set

1. Click the Graph View icon to show the graph.

2. Click the Data Set Selector (near the top of the Detail View) to expand the list of
data sets.

3. Scroll the list as necessary, and then click the Delete symbol (X) next to the name of
the data set.



4. Click OK on the confirmation message.

Expanding the View Details Area

▶ Drag the boundary at the right edge of the Details area to increase or decrease its
width.

Using Sensor Data in Programmes
You can access sensor data from all connected sensor probes through your TI-Basic
programme by using this command:

RefreshProbeVars statusVar
• You must first launch the Vernier DataQuest™ application, or you will receive an

error.

Note: The Vernier DataQuest™ application will auto-launch when you connect a
sensor or a lab cradle to the TI-Nspire™ software or handheld.

• The RefreshProbeVars command will be valid only when Vernier DataQuest™ is in

'meter' mode.
• statusVar is an optional parameter that indicates the status of the command.

These are the statusVar values:

StatusVar Value Status

statusVar=0 Normal (continue with the programme)

statusVar=1 The Vernier DataQuest™ application is in data
collection mode.
Note: The Vernier DataQuest™ application
must be in meter mode for this command to

work.

statusVar=2 The Vernier DataQuest™ application is not
launched.
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StatusVar Value Status

statusVar=3 The Vernier DataQuest™ application is
launched, but you have not connected any
probes.
Note: The RefreshProbeVars command
will almost always return statusVar=3 in the
iOS, even if you have already launched the
Vernier DataQuest™ application

• Your TI-Basic programme will read directly from Vernier DataQuest™ variables in
the symbol table.

• The meter.time variable shows the last value of the variable; it does not update
automatically. If no data collection has occurred, meter.time will be 0 (zero).

• Use of variable names without corresponding probes being physically attached will
result in a "Variable not defined" error.

• The RefreshProbeVars command will be a NOP (null command) on iOS.

Collecting Sensor Data using RefreshProbeVars
1. Launch the Vernier DataQuest™ application.

2. Connect the sensor(s) you need to collect the data.

3. Run the programme you wish to use to collect data in the calculator application.

4. Manipulate the sensors and collect the data.

Note: You may create a programme to interact with the TI-Innovator™ Hub usingb>
Hub > Send. (See Example 2, below.) This is optional.

Example 1
Define temp()=
Prgm
© Check if system is ready
RefreshProbeVars status
If status=0 Then
Disp "ready"
For n,1,50
RefreshProbeVars status
temperature:=meter.temperature
Disp "Temperature: ",temperature
If temperature>30 Then
Disp "Too hot"
EndIf
© Wait for 1 second between samples
Wait 1
EndFor
Else
Disp "Not ready. Try again later"
EndIf
EndPrgm



Example 2- with TI-Innovator™ Hub
Define tempwithhub()=
Prgm
© Check if system is ready
RefreshProbeVars status
If status=0 Then
Disp "ready"
For n,1,50
RefreshProbeVars status
temperature:=meter.temperature
Disp "Temperature: ",temperature
If temperature>30 Then
Disp "Too hot"
© Play a tone on the Hub
Send "SET SOUND 440 TIME 2"
EndIf
© Wait for 1 second between samples
Wait 1
EndFor
Else
Disp "Not ready. Try again later"
EndIf
EndPrgm

Analysing Collected Data
In the Vernier DataQuest™ application, use Graph View to analyse data. Start by setting
up graphs, and then use analysis tools such as integral, statistics and curve fit to
investigate the mathematical nature of the data.

Important: The Graph menu and Analyse menu items are only available when working
in Graph View.

Finding the Area Under a Data Plot

Use Integral to determine the area under a data plot. You can find the area under all of
the data or a selected region of the data.

To find the area under a data plot:

1. Leave the graph unselected to examine all the data, or select a range to examine a
specific area.

2. Click Analyse > Integral.

3. Select the plotted column name if you have more than a single column.

The data plot area is displayed in the View Details area.
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Finding the Slope

Tangent displays a measure of the rate at which the data is changing at the point you
are examining. The value is labelled “Slope”.

To find the slope:

1. Click Analyse > Tangent.

A check mark appears in the menu next to the option.

2. Click the graph.

The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View details area and the All Details
for Graph dialogue box.

You can move the examine line by dragging, clicking another point or using the
arrow keys.

Interpolating the Value Between Two Data Points

Use Interpolate to estimate the value between two data points and to determine the
value of a Curve Fit between and beyond these data points.

The examine line moves from data point to data point. When Interpolate is on, the
examine line moves between and beyond data points.

To use Interpolate:

1. Click Analyse > Interpolate.

A check mark appears in the menu next to the option.

2. Click the graph.

The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View Details area.

You can shift the examine line by moving the cursor with the arrow keys or by
clicking on another data point.



Generating Statistics

You can generate statistics (minimum, maximum, mean, standard deviation and
number of samples) for all the collected data or for a selected region. You can also
generate a curve fit based on one of several standard models or on a model that you
define.

1. Leave the graph unselected to examine all the data, or select a range to examine a
specific area.

2. Click Analyse > Statistics.

3. Select the plotted column name if you have more than a single column. For
example, run1.Pressure.

The Stats dialogue box opens.

4. Review the data.

5. Click OK.

For information on clearing the Statistics analysis, see Removing Analysis Options.

Generating a Curve Fit

Use Curve Fit to find the best curve fit to match the data. Select all of the data or a
selected region of data. The curve is drawn on the graph.

1. Leave the graph unselected to examine all the data, or select a range to examine a
specific area.

2. Click Analyse > Curve Fit.

3. Select a curve fit option.
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Curve Fit option Calculated in the form:

Linear y = m*x + b

Quadratic y = a*x^2 + b*x + c

Cubic y = a*x^3 + b*x^2 + c*x + d

Quartic y = a*x^4 + b*x^3 + c*x^2 + d*x + e

Power (ax^b) y = a*x^b

Exponential (ab^x) y =  a*b^x

Logarithmic y = a + b*ln(x)

Sinusoidal y = a*sin(b*x + c) + d

Logistic (d 0) y = c/(1 + a*e^(-bx)) + d

Natural Exponential y = a*e^(-c*x)

Proportional y = a*x

The Fit Linear dialogue box opens.

4. Click OK.

5. Review the data.

For information on clearing the Curve Fit analysis, see Removing Analysis Options.



Plotting a Standard or User-Defined Model

This option provides a manual method for plotting a function to fit data. Use one of the
predefined models or enter your own.

You can also set the spin increment to use in the View Details dialogue box. Spin
increment is the value by which the coefficient changes when you click the spin buttons
in the View Details dialogue box.

For example, if you set m1=1 as the spin increment, when you click the up spin button
the value changes to 1.1, 1.2, 1.3 and so on. If you click the down spin button, the value
changes to 0.9, 0.8, 0.7 and so on.

1. Click Analyse > Model.

The Model dialogue box opens.

2. Type your own function.

—or—

Click to select a value from the drop-down list.

3. Click OK.

The Set Coefficient Values dialogue box opens.
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4. Type the value for the variables.

5. Type the change in value in the Spin Increment fields.

6. Click OK.

Note: These values are the initial values. You can also adjust these values in the
View Details area.

The model is shown on the graph with adjustment options in the View Details area
and in the All Details for Graph dialogue box.

7. (Optional) Adjust the window setting for minimum and maximum axis values. For
more information, see Setting the Axis for One Graph.

For information on clearing the Model analysis, see Removing Analysis Options.

8. Click to make any desired adjustments to the coefficients.

—or—

Click the value in the View Details area.

This graphic is an example of a model with adjusted values.

Removing Analysis Options

1. Click Analyse > Remove.

2. Select the data display you want to remove.

The display you selected is removed from the graph and the View Details area.



Displaying Collected Data in Graph View
When you collect data, it is written in both the Graph and Table views. Use the Graph
view to examine the plotted data.

Important: The Graph menu and Analyse menu items are only active when working in
Graph View.

Selecting the Graph View

▶ Click the Graph View tab .

Viewing Multiple Graphs

Use the Show Graph menu to show separate graphs when using:

• A sensor that plots more than one column of data.

• Multiple sensors with different defined units at the same time.

In this example, two sensors (the Gas Pressure sensor and the Hand Dynamometer)
were used in the same run. The following image shows the columns Time, Force and
Pressure in the Table view to illustrate why two graphs are shown.

Displaying One of Two Graphs

When two graphs are displayed, the top graph is Graph 1 and the bottom graph is
Graph 2.

To display only Graph 1:

▶ Select Graph > Show Graph > Graph 1.

Only Graph 1 is displayed.

To display only Graph 2:

▶ Select Graph > Show Graph > Graph 2.

Only Graph 2 is displayed.

Displaying Both Graphs

To display both Graph 1 and Graph 2 together:

▶ Select Graph > Show Graph > Both.

Graph 1 and Graph 2 are displayed.
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Displaying Graphs in the Page Layout View

Use the Page layout view when Show Graph is not the appropriate solution for showing
more than one graph.

The Show Graph option is not applicable for:

• Multiple runs using a single sensor.

• Two or more of the same sensors.

• Multiple sensors that use the same column(s) of data.

To use Page Layout:

1. Open the original data set you want to see in two graph windows.

2. Click Edit > Page Layout > Select Layout.

3. Select the type of page layout you want to use.

4. Click Click here to add an application.

5. Select Add Vernier DataQuest™.

The Vernier DataQuest™ application is added to the second view.

6. To see separate views, click the view you want to change, and then select View >
Table.

The new view is displayed.

7. To show the same view, click the view to change.

8. Click View > Graph.

The new view is displayed.

Displaying Collected Data in Table View
Table view provides another way to sort and view collected data.

Selecting the Table View

▶ Click the Table View tab .

Defining Column Options

You can name columns and define the decimal points and the precision you want to
use.

1. from the Datamenu, select Column Options.



Note: You can be in the Meter, Graph or Table view and still click these menu
options. The results will still be visible.

2. Click the name of the column you want to define.

The Column Options dialogue box opens.

3. Type the long name for the column in the Name field.

4. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display the full name.

5. Type the number of units in the Units field.

6. From the Displayed Precision drop-down list, select the precision value.

Note: The default precision is related to the precision of the sensor.

7. Select Link to list to link to the symbol table and make this information available to
other TI-Nspire™ applications.

Note: Linking is the default for most sensors.
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Important: Heart rate and blood pressure sensors require a tremendous amount of
data to be useful, and the default for these sensors is to be unlinked to improve
system performance.

8. Select Apply changes to all Data Sets to apply these settings to all data sets.

9. Click OK.

The column settings are now defined with the new values.

Creating a Column of Manually Entered Values

To enter data manually, add a new column. Sensor columns cannot be modified, but
data entered manually can be edited.

1. Click Data > New Manual Column.

The Column Options dialogue box opens.

2. Type the long name for the column in the Name field.

3. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display the full name.

4. Type the units to be used.

5. From the Displayed Precision drop-down list, select the precision value.

Note: The default precision is related to the precision of the sensor.



6. (Optional) Select Apply changes to all Data Sets to apply these settings to all data
sets.

7. (Optional) Select Generate Values to automatically populate the rows.

If you select this option, complete these steps:

a) Type a starting value in the Start field.

b) Type an ending value in the End field.

c) Type the increase in value in the Increment field.

The number of points is calculated and shown in the Number of Points field.

8. Select Link from list to link to data in another TI-Nspire™ application.

Note: This list only populates when data exists in the other application and includes
a column label.

9. Select Link to list to link to the symbol table and make this information available to
other TI-Nspire™ applications.

Note: Linking is the default for most sensors.

Important: Heart rate and blood pressure sensors require a tremendous amount of
data to be useful, and the default for these sensors is to be unlinked to improve
system performance.

10. Click OK.

A new column is added to the table. This column can be edited.

Creating a Column of Calculated Values

You can add an additional column to the data set in which the values are calculated
from an expression using at least one of the existing columns.

Use a calculated column when finding the derivative for pH data. For more information,
see Adjusting Derivative Settings.

1. Click Data > New Calculated Column.

The Column Options dialogue box opens.
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2. Type the long name for the column in the Name field.

3. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display the full name.

4. Type the units to be used.

5. From the Displayed Precision drop-down list, select the precision value.

Note: The default precision is related to the precision of the sensor.

6. Type a calculation including one of the column names in the Expression field.

Note: The system-provided column names are dependent on the sensor(s) selected
and any changes made to the name field in Column Options.

Important: The Expression field is case-sensitive. (Example: “Pressure” is not the
same as “pressure”.)

7. Select Link to list to link to the symbol table and make this information available to
other TI-Nspire™ applications.

Note: Linking is the default for most sensors.

Important: Heart rate and blood pressure sensors require a tremendous amount of
data to be useful, and the default for these sensors is to be unlinked to improve
system performance.



8. Click OK.

The new calculated column is created.

Customising the Graph of Collected Data
You can customise the Graph view by adding a title, changing colours and setting
ranges for the axis.

Adding a Title

When you add a title to a graph, the title is displayed in the View Details area. When
you print the graph, the title prints on the graph.

1. Click Graph > Graph Title.

The Graph Title dialogue box opens.

If there are two graphs in the work area, the dialogue box has two title options.

2. Type the name of the graph in the Title field.

—or—

a) Type the name of the first graph in the Graph 1 field.

b) Type the name of the second graph in the Graph 2 field.

3. Select Enable to show the title.

Note: Use the Enable option to hide or show the graph title as needed.
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4. Click OK.

The title is shown.

Setting Axis Ranges

Setting Axis Ranges for One Graph

To modify the minimum and maximum range for the x and y axis:

1. Click Graph > Window Settings.

The Window Settings dialogue box opens.

2. Type the new values in one or more of these fields:

- X Min

- X Max

- Y Min

- Y Max

3. Click OK.

The application uses the new values for the graph visual range until you modify the
range or change data sets.

Setting Axis Ranges for Two Graphs

When working with two graphs, enter two y axis minimum and maximum values, but
only one set of minimum and maximum values for the x axis.

1. Click Graph > Window Setting.

The Window Setting dialogue box opens.



2. Type the new values in one or more of these fields:

- X Min

- X Max

- Graph 1: Y Min

- Y Max

- Graph 2: Y Min

- Y Max

3. Click OK.

The application uses the new values for the graph visual range until you modify the
range or change data sets.

Setting the Axis Range on the Graph Screen

You can modify the minimum and maximum range for the x and y axes directly on the
graph screen.

▶ Select the axis value that you want to change, and type a new value.

The graph is redrawn to reflect the change.

Selecting which Data Sets to Plot

1. In the Detail view on the left, click the tab immediately below the view selection
buttons.
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2. The Detail view shows a list of available data sets.

3. Use the tick boxes to select the data sets to plot.

Autoscaling a Graph

Use the autoscale option to show all the points plotted. Autoscale Now is useful after
you change the x and y axis range or zoom in or out of a graph. You can also define the
automatic autoscale setting to use during and after a collection.

Autoscale Now Using the Application Menu

▶ Click Graph > Autoscale Now.

The graph now displays all the points plotted.

Autoscale Now Using the Context Menu

1. Open the context menu in the graph area.

2. ClickWindow/Zoom > Autoscale Now.

The graph now displays all the points plotted.



Defining Autoscale During a Collection

There are two options for using the automatic autoscaling that occurs during a
collection. To choose an option:

1. Click Options > Autoscale Settings.

The Autoscale Settings dialogue box opens.

2. Click► to open the During Collection drop-down list.

3. Select one of these options:

• Autoscale Larger - Expands the graph as needed to show all points as you collect
them.

• Do Not Autoscale - The graph is not changed during a collection.

4. Click OK to save the setting.

Defining Autoscale After a Collection

You have three options for setting the automatic autoscaling that occurs after a
collection. To set your choice:

1. Click Options > Autoscale Settings.

The Autoscale Settings dialogue box opens.

2. Click► to open the After Collection drop-down list.

3. Select one of these options:

• Autoscale to Data. Expands the graph to show all data points. This option is the
default mode.

• Autoscale From Zero.Modifies the graph so all data points including the origin
point are displayed.

• Do Not Autoscale. The graph settings are not changed.
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4. Click OK to save the setting.

Selecting a Range of Data

Selecting a range of data on the graph is useful in several situations, such as when
zooming in or out, striking and un-striking data and examining settings.

To select a range:

1. Drag across the graph.

The selected area is indicated by grey shading.

2. Perform one of these actions.

• Zoom in or out

• Strike or un-strike data

• Examine settings

To deselect a range:

▶ Press the Esc key as necessary to remove the shading and the vertical trace line.

Zooming In on a Graph

You can zoom in on a subset of the collected points. You can also zoom out from a
previous zoom or expand the graph window beyond the data points collected.

To zoom in on a graph:

1. Select the area you want to zoom into, or use the current view.

2. Click Graph > Zoom In.

The graph adjusts to display only the area you selected.

The x range selected is used as the new x range. The y range autoscales to show all
graphed data points in the selected range.

Zooming Out of a Graph

▶ Select Graph > Zoom Out.

The graph is now expanded.

If a Zoom In precedes a Zoom Out, the graph displays the original settings prior to
the Zoom In.



For example, if you Zoomed In twice, the first Zoom Out would display the window
of the first Zoom In. To display the full graph with all data points from multiple
zoom ins, use Autoscale Now.

Setting Point Options

To indicate how often marks show on the graph and whether to use a connecting line:

1. Click Options > Point Options.

The Point Options dialogue box opens.

2. Select aMark option from the drop-down list.

• None. No point protectors.

• Regional. Periodic point protectors.

• All. Every data point as a point protector.

3. Select Connect Data Points to display a line between points.

—or—

Clear Connect Data Points to remove the line between points.

The following graphics show examples of some of the Point Mark options.
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Changing a Graph's Colour

1. Click the point indicator for the graph whose colour you want to change.

2. In the Column Options dialogue box, select the new Colour.

Selecting Point Markers

1. Right-click in the graph to open the menu.

2. Click Point Marker.

Note: If there is only one dependent variable column, the Point Marker option is
preceded by the data set name and column name. Otherwise, the Point Marker
option has a menu.

3. Select the column variable to change.

4. Select the point marker to set.

The Point Marker changes to the option selected.

Selecting an Independent Variable Column

Use the option Select X-axis Column to select the column used as the independent
variable when graphing the data. This column is used for all graphs.

1. Click Graph > Select X-axis Column.

2. Select the variable you want to change.

The x-axis label on the graph changes and the graph is reordered using the new
independent variable for graphing the data.

Selecting a Dependent Variable Column

Use the option Select Y-axis Column to select which dependent variable columns to plot
on the displayed graph(s).

1. Click Graph > Select Y-axis Column.



2. Select one of the following:

• A variable from the list. The list is a combination of dependent variables and the
number of data sets.

• More. Selecting More opens the Select dialogue box. Use this when you want to
select a combination of data set variables to graph.

Showing and Hiding Details

You can hide or show the Details view on the left side of the screen.

▶ Click Options > Hide Details or Options > Show Details.

Showing and Hiding Axes Tick Labels

You can hide or show the axes tick labels on a graph.

▶ Click Options > Hide tick labels or Options > Show tick labels.
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Notes:

• When a Vernier DataQuest™ application is added to a document, the tick labels will
default to being displayed.

• Tick labels may not be displayed if there is a lack of available space. Minimum and
maximum values will always be displayed.

• Tick labels cannot be edited, but they will recalculate as needed if the minimum or
maximum values are edited or the window settings are changed.

Striking and Restoring Data
Striking data omits it temporarily from the Graph view and from the analysis tools.

1. Open the data run that contains the data to be struck.

2. Click Table View .

3. Select the region by dragging from the starting row to the ending point.

The screen scrolls so you can see the selection.

4. Click Data > Strike Data.

5. Select one of the following:

• In Selected Region. Strike the data from the area you selected.
• Outside Selected Region. Strike all data except the area you selected.

The selected data is marked as struck in the table and is removed from the graph
view.

Restoring Struck Data

1. Select the range of data to restore or if restoring all struck data, start at step two.

2. Click Data > Restore Data.

3. Select one of the following:

• In Selected Region - Restore data in the selected area.
• Outside Selected Region - Restore data outside the selected area.
• All Data - Restore all data. No data selection necessary.

The data is restored.

Replaying the Data Collection
Use the Replay option to playback the data collection. This option lets you:

• Select the data set you want to replay.

• Pause the playback.

• Advance the playback by one point at a time.

• Adjust the playback rate.



• Repeat the playback.

Selecting the Data Set to Replay

You can replay one data set at a time. By default, the latest data set plays using the first
column as the base column (example: time reference).

If you have multiple data sets, and want a different data set or base column than the
default, you can select the data set to replay and the base column.

To select the data set to replay:

1. Click Experiment > Replay > Advanced Settings.

The Advanced Replay Settings dialogue box opens.

2. Select the data set to replay from the Data Set drop-down list.

Note: Changing the run in the Data Set selection tool does not affect the playback
choice. You must specify which data set in Experiment > Replay > Advance Settings.

3. (Optional) Select a new value from the Base Column drop-down list.

The selected column acts as the “Time” column for the replay.

Note: The base column should be a strictly increasing list of numbers.

4. Click Start to start the playback and save the settings.

Note: Data Set and Base Column options are based on the number of stored runs
and the sensor type used.

Starting and Controlling the Playback

▶ Select Experiment > Replay > Start Playback.

Playback begins, and the Data Collection Control buttons change to:

Pause
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Resume

Stop

Advance by One Point (enabled only during pause)

Adjusting the Playback Rate

To adjust the playback rate:

1. Select Experiment > Replay > Playback Rate.

The Playback Rate dialogue box opens.

2. In the Playback Rate field, click▼ to open the drop-down list.

3. Select the rate at which the playback will play.

Normal speed is 1.00. A higher value is faster and a lower value is slower.

4. Select one of the following options:

• Click Start to start the playback and save the settings.

• Click OK to save the settings for use on the next playback.

Repeating the Playback

1. Select Experiment > Replay > Start Playback.

2. Click Start to start the playback and save the settings.

Adjusting Derivative Settings
Use this option to select the number of points to use in derivative calculations. This
value affects the tangent tool, velocity and acceleration values.

Find pH derivative settings using a calculated column.

The Vernier DataQuest™ application can determine a numeric derivative from a list of
data with respect to another list of data. The data can be collected using sensors, input



manually, or linked with other applications. The numerical derivative is found using a
calculated column.

To determine the numerical 1st derivative of List B with respect to List A, enter the
following expression in the Column Options dialogue:

derivative(B,A,1,0) or derivative(B,A,1,1)

To determine the numerical 2nd derivative of List B with respect to List A, enter the
following expression:

derivative(B,A,2,0) or derivative (B,A,2,1)

The last parameter is either 0 or 1 depending on the method you are using. When it is
0, a weighted average is used. When it is 1, a time shifted derivative method is used.

Note: The first derivative calculation (weighted average) is what the Tangent tool uses
to display the slope at a data point when examining data. (Analyse > Tangent).

Note: The derivative calculation is completely row based. It is recommended that your
List A data be sorted in ascending order.

1. Click Options > Derivative Settings.

The Settings dialogue box opens.

2. Select the number of points from the drop-down list.

3. Click OK.

Drawing a Predictive Plot
Use this option to add points to the graph to predict the outcome of an experiment.

1. Click the Graph View tab .

2. From the Analysemenu, select Draw Prediction > Draw.

3. Click each area in which you want to place a point.

4. Press Esc to release the drawing tool.
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5. To clear the drawn prediction, click Analyse > Draw Prediction > Clear.

Using Motion Match
Use this option to create a randomly generated plot when creating position-versus-time or
velocity-versus-time graphs.
This feature is only available when using a motion detector such as the CBR 2™ sensor or
the Go!Motion® sensor.

Generating a Motion Match Plot

To generate a plot:

1. Attach the motion detector.

2. Click View > Graph.

3. Click Analyse > Motion Match.

4. Select one of the following options:

• New Position Match. Generates a random position plot.
• New Velocity Match. Generates a random velocity plot.

Note: Continue selecting a new position or a new velocity match to generate a new
random plot without removing the existing plot.

Removing a Motion Match Plot

To remove the generated plot:

▶ Click Analyse > Motion Match > Remove Match.

Printing Collected Data
You can only print from the computer. You can print any single displayed active view, or
with the Print All option:

• One data view.

• All of the data views.



• A combination of the data views.

The Print All option has no effect on applications outside of the Vernier DataQuest™
application.

Printing Data Views

To print a data view:

1. On the main menu (top of the window), click File > Print.

The Print dialogue box opens.

2. Select Print All from the Print what drop-down list.

3. Select additional options, if needed.

4. Click Print to send the document to the printer.

Setting Options for the Print All Feature

1. Click Options > Print All Settings.

The Print All Settings dialogue box opens.

Data Collection 413



414 Data Collection

2. Select the views you want to print.

• Print Current View. The current view is sent to the printer.

• Print All Views. All three views (Meter, Graph and Table) are sent to the printer.

• More. Only the views you select are sent to the printer.

3. Click OK.

The Print All Settings are now complete and can be used when printing.



Widgets
All work that you create and save using TI-Nspire™ applications is stored as a
document, which you can share with others using TI-Nspire™ software, a TI-Nspire™ CX
II handheld, or the TI-Nspire™ App for iPad®. You save these TI-Nspire™ documents as
.tns files.

A Widget is a .tns document that is stored in your MyWidgets folder.

You can use Widgets to:

• Easily access text files

• Insert and run scripts (such as the pre-loaded widget example: Stopwatch.tns)

• Quickly insert a saved problem into a document

When you add a Widget, TI-Inspire™ CX extracts only the first page of the selected .tns
file, and inserts it into your open document.

Creating a Widget
A document is regarded as a Widget when it is saved or copied to the designated
MyWidgets folder. The default location is:

• Windows®: My Documents\TI-Nspire\MyWidgets.

• Mac®: Documents/TI-Nspire/MyWidgets.

• Handheld: MyWidgets

• TI-Nspire™ App for iPad® and TI-Nspire™ CAS App for iPad®: MyWidgets

If the MyWidget folder has been inadvertently deleted, you must create it before
attempting to use a Widget.

Note:When you add a Widget, TI-Inspire™ CX extracts only the first page of the
selected .tns file, and inserts it into your open document.

Adding a Widget
Adding a Widget to a New Document

1. Open a new document.
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2. Click Add Widget.

3. Scroll to select a .tns file from the box.

4. Click Add.

Note: Stopwatch is a preloaded .tns file. Any saved .tns file will show up in this list.



Adding a Widget to an Existing Document

1. Click Doc > Insert >Widget.

2. Click Add.

Note: You can also add a Widget to a new or existing document using the Insertmenu.
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Saving a Widget

1. Click .
2. Navigate to MyDocuments > MyWidgets.

3. Type in a name for your Widget.

4. Click Save.



Libraries
What is a Library?
A library is a TI-Nspire™ document that contains a collection of variables, functions
and/or programmes that have been defined as library objects.

Unlike ordinary variables, functions and programmes, which can be used only within a
single problem (the problem in which they are defined), library objects are accessible
from any document. You can even create public library objects that appear in the TI-
Nspire™ Catalogue.

For example, suppose you have created library documentmatrix containing public
library function diagwithtrace() and a private library function errmsg().

Function diagwithtrace() displays the diagonal of a square matrix and calculates the
trace of the matrix. If its input is not a square matrix, the function calls errmsg(), which
should then return an appropriate error string.

You could then use the following syntax to display the diagonal and calculate the trace
of matrix m defined in the current problem:

matrix\diagwithtrace(m)

Creating Libraries and Library Objects
A document is regarded as a library when it is saved or copied to the designated library
folder. The default location is:

• Windows®: My Documents\TI-Nspire\MyLib.

• Mac®: Documents/TI-Nspire/MyLib.

• Handheld: MyLib
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If the folder has been inadvertently deleted, you must create it before attempting to
use libraries.

You can define library objects using either the Programme Editor or the Calculator
application. Library objects must be defined with a Define command and must reside in
the first problem of a library document.

Note: If you use the Programme Editor to define a library function or programme, you
must store the object and also save the document. Saving the document does not
automatically store the object. For more information, see Programming.

Naming restrictions apply to library documents and library objects.

• A library document name must be a valid variable name between 1 and 16
characters long, and it must not contain a period or begin with an underscore.

• A library object name must be a valid variable name between 1 and 15 characters
long. It must not contain a period and must not begin with an underscore.

Private and Public Library Objects
When you define a library object, you designate it as private (LibPriv) or public (LibPub).

Define a=5
    a is not a library object.

Define LibPriv b={1,2,3}
    b is a private library object.

Define LibPub func1(x)=x^2 - 1
    func1 is a public library object.

A Private library object does not appear in the Catalogue, but you can access it by
typing its name. Private objects serve well as building blocks that perform basic, low-
level tasks. Typically, private library objects are called upon by the public functions and
programmes.

A Public library object appears in the Catalogue’s library tab after you refresh the
libraries. You can access a public library object through the Catalogue or by typing its
name.

Mac® only: In version 1.4 of the software, a library document name cannot contain
extended characters, such as Ö, á or ñ.

Note: In library programmes and functions defined as public, a comment line (©)
immediately following the Prgm or Func line is automatically displayed as help in the
Catalogue. You could, for example, show a syntax reminder there.



Using Short and Long Names

Anytime you are in the same problem where an object is defined, you can access it by
entering its short name (the name given in the object’s Define command). This is the
case for all defined objects, including private, public and non-library objects.

You can access a library object from any document by typing the object’s long name. A
long name consists of the name of the object’s library document followed by a
backslash “\” followed by the name of the object. For example, the long name of the
object defined as func1 in the library document lib1 is lib1\func1. To type the “\”
character on the handheld, pressgp.

Note: If you cannot remember the exact name or the order of arguments required for a
private library object, you can open the library document or use the Programme Editor
to view the object. You also can use getVarInfo to view a list of objects in a library.

Using Library Objects
Before using a library variable, function or programme, make sure that these steps
have been followed:

• The object has been defined with the Define command, and the command specifies
either the LibPriv or LibPub attribute.

• The object resides in the first problem of a library document. The document must
reside in the designated library folder and must meet the naming requirements.

• If you defined the object using the Programme Editor, it has been stored using
Check Syntax & Store from the Programme Editor menu.

• The libraries have been refreshed.

Refreshing the Libraries

▶ Refresh libraries to make the library objects available to your documents.

- From the Toolsmenu, click Refresh Libraries.

Handheld: Press/b and click Refresh Libraries.

Using a Public Library Object

1. Refresh the libraries.

2. Open the TI-Nspire™ application in which you want to use the variable, function or
programme.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programmes.

3. Open the Catalogue and use the library tab to find and insert the object.

4. If arguments are required, type them inside the parentheses.

Using a Private Library Object

1. Refresh the libraries.
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2. Open the TI-Nspire™ application in which you want to use the variable, function or
programme.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programmes.

3. Type the name of the object, such as lib1\func1().

In case of a function or programme, always follow the name with parentheses. To
type the “\” character on the handheld, pressgp.

4. If arguments are required, type them inside the parentheses.

Creating Shortcuts to Library Objects
You can make the objects in a library more easily accessible by using libShortcut() to
create shortcuts to them. This creates a variable group in the current problem that
contains references to all the objects in the specified library document. You can choose
to include or exclude the private library objects.

For example, suppose the library document linalg contains functions named clearmat,
cofactor, gausstep, help, inversestep, kernelbasis, rank and simultstep. Executing
libShortcut(“linalg”,“la”) would create a variable group containing the following
members:

la.clearmat
la.cofactor
la.gausstep
la.help
la.inversestep
la.kernelbasis
la.rank
la.simultstep

You can refer to those library objects from within the current problem by typing their
variable names or by selecting them from the Variables menu.

For more details about using libShortcut(), see the Reference Guide.

Included Libraries
To help you get started with libraries, the TI-Nspire™ Software installation includes a
library document with useful Linear Algebra functions. The library is named linalg or
linalgCAS and is installed in the designated library folder.

Note: Updating the handheld’s operating system or reinstalling the computer software
places all included libraries in the default folder. If you have edited an object in an
included library or replaced an included library with your own document of the same
name, updating or reinstalling will overwrite your changes. This could also happen after
batteries are replaced or the handheld system is reset.



Restoring an Included Library
If you inadvertently delete or overwrite an included library, you can restore it from the
installation DVD.

1. Open the DVD, and navigate to the libs folder.

2. Identify the library file to restore, such as linalg.tns or linalgCAS.tns for the linear
algebra library.

3. Copy the file.

- Windows®: Copy the file to your designated library folder. The default location
isMy Documents\TI-Nspire\MyLib.

- Mac®: Copy the file to your designated library folder. The default location is
Documents/TI-Nspire/MyLib.

- Handheld: Connect the handheld to your computer, open the TI-Nspire™
software, and copy the library file to the handheld’sMyLib folder.

4. Activate the new library objects.

- From the TI-Nspire™ Software Toolsmenu, click Refresh Libraries.

Handheld: Press/b, and click Refresh Libraries.
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Using the TI-SmartView™ Emulator
With three layout options to choose from, teachers will find that the emulator
facilitates classroom presentations. In the teacher software, layout options are:

• Handheld Only

• Keypad + SideScreen

• Handheld + SideScreen

In the student software, the TI-SmartView™ emulates the keypad, which along with the
handheld view, gives students the ability to drive the software as if using a handheld.

Opening the TI-SmartView™ Emulator
The TI-SmartView™ emulator is located in the Documents Workspace. To open the
emulator view:

1. Open the Documents Workspace.

2. Click , which is located in the Documents Toolbox.

In the teacher software, the handheld is displayed with Handheld and SideScreen
panels open in computer mode as shown in the following illustration. You can use
the keypad on the emulated handheld, but the document won’t appear on the
emulated handheld screen until you switch to Handheld mode.

In the student software, the TI-Nspire™ CX II keypad is displayed with the side
screen open in computer mode. You can use the keypad on the emulated handheld
to work with the document in the side screen in either computer mode or handheld
mode.



3. Click View > Handheld.

—or—

Click in the status bar to switch to handheld mode.

Choosing Display Options
In the teacher software, use this option to choose how to display the emulator in the
software window.

1. In the emulator panel, click .
—or—
Click File > Settings > TI-SmartView™ Options.

2. Select one of the following options:

• Handheld Only. Displays the emulated handheld and hides the workspace and
other panels.

Note: To keep the Handheld Only display in front of other application windows,
click Always in Front at the top right of the TI-SmartView™ panel.

• Keypad + SideScreen. Opens a larger view of the keypad along with the side
screen.

• Handheld + SideScreen. Opens the entire emulated handheld along with the
side screen.

Changing the Faceplate

To select a faceplate option:

1. In the emulator panel, click to open the menu.

—or—
Click File > Settings > TI-SmartView™ Options.
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2. Select one of the following options:

• Dark
• Light
• Outline

Changing the Width of the TI-SmartView™ Panel

To change the width of the TI-SmartView™ emulator panel:

▶ Click the right edge of the panel and drag it until it is the width you want.

Changing the Size of the Screen in the Workspace

When in handheld mode, use the Scale to change the size of the screen.

▶ Drag the slider to the appropriate scale percentage. The scale slider is located on
the far right side of the status bar, at the bottom of the TI-Nspire™ window. Scale
percentages range from 100% to 200%. The default scale is 150%.

Note: If computer mode is selected, you cannot change the size of the workspace.

Working with the Emulated Handheld
To input data and work with files on the emulator, you can use the computer keyboard,
TI-SmartView™ keypad, TI-Nspire™ menus and icons or any combination of these.

Note:Within one command, you cannot use a combination of both the keypad and the
keyboard. For example, you cannot press Ctrl on the keyboard and clickb on the
emulator to open a context menu.

For the most part, you can perform any function in the TI-SmartView™ emulator that
you can perform on the handheld. Keys and applications operate the same way.

Note: If you switch to Computer mode, you can still use most of the keys on the
emulated handheld or keypad and all keystrokes are reflected in the workspace.
However, some key combinations may only work in Handheld mode.

As you click keys on the emulator or press keys on the keyboard that activate keys on
the emulator, those keys change colour, making it easy for your audience to follow
along. The last key selected stays highlighted.

In the teacher software, the emulator screen and the side screen are both interactive.
You can click on icons and menu items on both screens. You can also right-click to
display menus on both screens.

All handheld shortcuts and arrow functionality work from the computer keyboard. For
example, to save a document, you can click/S on the emulator keypad or you can
press Ctrl + S on the computer keyboard. When using a Mac®, press “ + S.



Using the Touchpad
You can operate the Touchpad on the TI-Nspire™ Touchpad keypad using either the
touchpad on a laptop or by using the mouse to click the Touchpad. Areas of the
Touchpad are highlighted as you click the arrow zones.

An arrow is highlighted when you press or tap it.

• Clicking the ¡, ¢,£, or¤ keys on the Touchpad moves through menus one item at
a time.

• Clicking and holding down an arrow on the Touchpad causes continual movement
in the selected direction.

• Clicking and sliding the mouse across the Touchpad area enables you to move the
mouse pointer.

• Clicking the middle of the Touchpad selects the highlighted menu option.

Using Settings and Status
When working with the TI-SmartView™ emulator, you can change General Settings and
Document Settings. For more information, see Using the Documents Workspace.

You can view all other settings, but you cannot change them in the TI-SmartView™
emulator. However, the ability to view these options provides teachers with an
instructional tool when they need to show students how to set up a handheld.

To view settings and status:

1. Clickc to access the Home screen.

2. Click Settings.

Setting or
Settings

Description

Language You can open the languages menu and select a language, but you
cannot save changes. To change the language, use the TI-Nspire™
menu File > Settings > Change Language option.

Handheld
Setup

You can open the menus and select items to demonstrate which
items to choose, but you cannot save any changes.

Handheld You can access the screen. The # symbol replaces any numeric
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Setting or
Settings

Description

Status values that would be displayed on the handheld.

About You can open the About screen and view the software version.
Other information that pertains only to the handheld hardware is
marked as "Not Applicable".

Login You can display the Login to Class screen and type in the User
Name and Password fields. Login is not available.

Changing TI-SmartView™ Options
You can change the emulator options, even when the emulator panel is closed.

1. In the teacher software, click File > Settings > TI-SmartView™ Options.

The TI-SmartView™ Options dialogue box opens.

In the student software, click File > Settings > Keypad Options.

The Keypad Options dialogue box opens.

2. Click Browse to change the folder where documents are saved and accessed in the
My Documents folder when using the emulator.

Important: If you change the TI-SmartView™ location, you must also copy or move
the MyLib folder and paste it to the new location to see library objects.

The default location of MyLib is:

• Windows®: Documents\TI-Nspire\MyLib.
• Mac®: Documents/TI-Nspire/MyLib.

Note: Close and reopen the TI-Nspire™ application for the libraries to reflect the
change.



3. Click¤ to open the menu and select a faceplate.

4. In the teacher software, click¤ to open the menu and select a view. If selecting
Handheld Only, select Always in Front to keep this window on top of all other open
applications.

5. Click OK to save the settings.

Working with Documents
You can open multiple documents in the workspace by selecting File > Open Document
from the menu or using keyboard shortcuts. When you switch between these
documents, the emulated handheld shows only the current document. You can insert
pages and problems using either the TI-Nspire™ menus or icons, keyboard shortcuts or
TI-SmartView™ menus or shortcuts.

Opening a Document

You can open a document by navigating to it on the emulator, the same way you open
a document on the handheld, or you click File > Open Document.

When you open a document using the emulator, you can only open documents that are
in the folder displayed on the emulator (usually the My Documents folder, unless you
specified a different folder in your TI-SmartView™ settings). When you open a
document using the menu path, you can browse to find any TI-Nspire™ document on
your computer or network. If you open a document using the emulated handheld, it
replaces the document that was previously open.

Note: If the number of characters in the document’s file path name exceeds 256
characters, the document cannot be opened and an error message is displayed. To
avoid this error, keep file and folder names short or move files up in the file path.

Saving a Document

When you save a document using the File > Save Documentmenu or icon, keyboard
shortcuts, keypad shortcuts or emulator menus, the document is saved in the same
location where the file was opened. To save the file in another location or with a
different name, click File > Save As.

Using Screen Capture
To capture the current page, press Ctrl + J (Mac®: ì“ + J) on your keyboard or on the
emulated handheld. The image is automatically placed in the Clipboard and in the TI-
Nspire™ Screen Capture window. You can paste the image into another application
without having to take additional steps. This feature is only available when the TI-
SmartView™ panel is active and the workspace is in Handheld mode.

All other screen capture features work the same way they do in other areas of TI-
Nspire™ software. For more information, see Capturing Screens.
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Using the Help Menu
Use the Help menu to find useful information to help you use the software more
productively. You can:

• Open the PDF help file (press F1 or click Help).

• Open the web-based help file (press F2 or click Online Help).

• Activate your software license.

• Register your TI product.

• Explore TI resources such as Activities Exchange, where you can find lessons,
quizzes and other instructive activities shared by teachers.

• Explore online troubleshooting.

• Check for updates to the software or updates to operating systems for TI-Nspire™
handhelds and the TI-Nspire™ Lab Cradle.

• Check to see which version of the software you are using.

Activating Your Software Licence
1. Ensure that your computer is connected to the Internet.

2. From the Helpmenu, select Activate to open the Texas Instruments Activation
Wizard.

3. Click Activate your Licence, and then click Next.

The Complete Software Activation dialogue box opens.

4. Complete the name and email fields, and then select the region where you live if
different from the default entry. If you want to receive emails from TI about
updates, support and promotions, ensure the tick box is selected.

5. Click Next.

The Activate your software dialogue box opens.



6. Type the licence number.

7. Click Next.

The Licence Agreement dialogue box opens.

8. In the Country field, select your country from the drop-down list if it is different
from the default entry.

9. Review the licence agreement, and then select to accept the agreement.

10. Click Activate. The licence number is validated against the TI database to ensure it is
valid.

If the licence number is valid, the Successful Activation dialogue box opens. If the
licence number is not valid, check to make sure the numbers are entered correctly.
If the problem persists, contact TI Support.
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11. Click Next to continue, or select Finish to complete the installation with default
settings.

12. When prompted, click OK to accept the default location for your TI-Nspire™ folder.
If needed, navigate to the location on your computer where you want to store your
TI-Nspire™ documents and files.

13. Select whether or not to replace any documents that have the same name.

The software launches and theWelcome Screen opens.

Registering Your Product
1. Ensure that your computer is connected to the Internet.

2. From the Helpmenu, select Register to access the TI Product Registration site.

3. Follow the instructions on the website.

Downloading the Latest Guidebook
1. Ensure that your computer is connected to the Internet.

2. From the Helpmenu, select Download latest Guidebook.

The Education Technology website opens with the Guidebooks tab active.

3. Click the title of the Guidebook that you want to download.

A PDF version of the Guidebook opens on your desktop.

Exploring TI Resources
The Help menu also provides links to TI resources and websites.

▶ Select Help > Visit education.ti.com to access the Texas Instruments Education
Technology website.



▶ Select Help > Visit Activities Exchange to access the Texas Instruments Activities
Exchange, site, a forum where you can browse by subject to find ready-to-use
maths and science learning activities appropriate for secondary school to college.

Note: Activities available for download may vary depending on your geographical
region.

▶ Select Help > Explore Online Troubleshooting to access the TI Knowledge Base
where you can find general information, troubleshooting help, product usage tips
and information specific to TI products.

Updating the TI-Nspire™ Software
Update the Software

1. Ensure that your computer is connected to the Internet.

2. Close any open documents.

3. From the Helpmenu, select Check for Upgrades and Notifications.

• If your software is current, a confirmation message appears.
• If your software is not current, you are prompted to update.

4. Click Update to download and install the update, or click Close to cancel.

A progress indicator shows the download progress. If you receive a connection
error, check your Internet connection and try again.

Note for users updating TI-Nspire™ Navigator™ Teacher Software: Your portfolio and
class records reside on your computer as a database. Because the new software might
have features that are not supported in the old database structure, the old data might
need to be converted. When conversion is necessary, a Database Update tool helps you
make a backup of the old database. The tool appears during the first startup of the
updated software.

Manage Automatic Checking

Automatic checking uses the Internet to check for upgrades each time you open the TI-
Nspire™ software. If your system is not up-to-date, you receive a notification. You can
turn automatic checking on or off.

1. From the Helpmenu, select Check for Upgrades and Notifications.

2. Tick or clear the Automatically check for updates tickbox.

3. Click Close.

Updating the OS on a Connected Handheld
Note: To avoid losing unsaved data, close all documents on the handheld before
updating its operating system.

1. Ensure that your computer is connected to the Internet.

2. In the Documents Toolbox, click the Content Explorer tab to show connected
handhelds.

3. Select the handheld that you are updating.

Using the Help Menu 433



434 Using the Help Menu

4. From the Helpmenu, select Check for OS Updates.

• If the operating system is current, a confirmation message appears.

• If the operating system is not current, the TI-Nspire™ software prompts you to
install the latest OS now. If the updated OS file is not already available on your
computer, you can choose a location for it.

5. Click Continue and follow the prompts to install the OS on the handheld, or click
Close to cancel.

When the update is complete, the handheld restarts automatically.

Viewing Software Version and Legal Information
1. From the Help menu, select About TI-Nspire™ <Product Name>Software.

Note: You do not need an Internet connection to open this screen.



2. Click OK to close the window.

Helping Improve the Product
This product includes a feature that can help TI improve the product by automatically
collecting anonymous information about product usage and reliability.

Note: Depending on how your software was installed, you might see the following
screen the first time you start the software. You also can access the feature manually.

1. From the Helpmenu, select Product Improvements.

2. Read the information on the screen, and click one of the buttons:

- To allow information to be collected, click Yes, I want to help.
- To prevent collection, click No thanks.
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Using Test Mode
The guidelines for many international, national, and state assessments allow or require
students to use TI-Nspire™ Student Software when taking an exam. Test Mode enables
you to quickly prepare the software for exams where use of applications, programmes,
and other files is restricted.

Test Mode can be configured by using either the Choose Test Mode Restrictions or Enter
Test Code option. When the software is in Test Mode, students cannot access pre-
existing folders, documents, or Scratchpad data. After the exam, these documents and
features can be easily restored for classroom use.

The Test Mode feature is available on Windows® computers only at this time in the
following versions:

• TI-Nspire™ CX Student Software version 5.3 or higher

• TI-Nspire™ CX CAS Student Software version 5.3 or higher

Note: To find out if your state allows TI-Nspire™ technology, see the State/Province
Information website at education.ti.com/go/testprep.

Entering Test Mode by Choosing Restrictions
Note: This applies to TI-Nspire™ CX and TI-Nspire™ CX CAS software except where
noted. If you already have a test code, you can use the Enter Test Code method.

1. Select File > Test Mode > Choose Test Mode Restrictions.

This will open the Test Mode Configuration dialogue box.

2. On the Default angle list, select the angle unit you wish to use. Available units are
Degree and Radian.

3. Select the CAS Mode you wish to use. (TI-Nspire™ CX CAS Student Software only)

https://education.ti.com/go/testprep


• On enables CAS functions and symbol manipulation.
• Exact Arithmetic enables exact results in terms of stacked fractions, p, and

radicals ‡.
• Off disables CAS and exact results.

4. Select the Exact Arithmeticmode you wish to use. (TI-Nspire™ CX Student Software
only with the TI-Nspire™ CX II-T handheld type selected)

• On enables exact results in terms of stacked fractions, p, and radicals ‡.
• Off disables exact results.

5. Click the tick box for each restriction to select or deselect it.

Click the Select / Unselect All box to quickly select or clear all restrictions.

In the Test Mode Code section, the code will automatically update based on your
selections.

Note: For a detailed list of restrictions, refer to Understanding Test Mode
Restrictions.

6. (Optional) To save the current settings as a named configuration:

a) Click Save.
b) Type a Name into the Save Configuration dialogue box.
c) Click Save.

7. Click Enter Test Mode.

• If there are any open documents or screenshots, you will be prompted to save
them.

• The software window will maximise to the full size of your display and open a
new document.

• Pre-existing clipboard and TI-Nspire™ Scratchpad data is deleted.
• A green title bar indicates that the software is in Test Mode. It displays the

Configuration Name (if any), Test Code, the CAS or Exact Arithmetic mode
status (when appropriate), time elapsed while in the test session, the
information icon, and the Exit button.
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Entering Test Mode with a Test Code
Note: This applies to TI-Nspire™ CX and TI-Nspire™ CX CAS software except where
noted. If you do not know the test code, you can obtain it by using the Choose
Restrictions method.

1. Select File > Test Mode > Enter Test Code.

This will open the Test Mode Configuration dialogue box.

2. Enter your eight-digit test code.

If the code is valid, a green tickmark will display. The following example uses the TI
Factory Default Code 0001-6382.

When the code is validated, it is stored and will be displayed when the Enter Test
Mode Code dialogue is invoked again.

The same test codes are used for both TI-Nspire™ Student Software and TI-Nspire™
CAS Student Software. The CAS and Exact Arithmetic Mode settings are ignored
when appropriate.

3. Click Next.

The Summary screen displays so you can review the restrictions. Click Back if you
need to enter a different code.



4. Click Enter Test Mode.

• If there are any open documents or screenshots, you will be prompted to save
them.

• The software window will maximise to the full size of your display and open a
new document.

• Pre-existing clipboard and TI-Nspire™ Scratchpad data is deleted.
• A green title bar indicates that the software is in Test Mode. It displays the

Configuration Name (if any), Test Code, the CAS or Exact Arithmetic mode
status (when appropriate), time elapsed while in the test session, the
information icon, and the Exit button.

Test Code Examples

TI Factory Default Restrictions

• Default Angle = Degree

• CAS Mode = Off
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• Numerical Solver enabled

Minimum Restrictions

• Default Angle = Degree

• CAS Mode = On

• All restrictions off

Maximum Restrictions

• Default Angle = Degree

• CAS Mode = Off

• All restrictions on



Note:Maximum restrictions Test Code will change if additional restrictions are added in
the future.

Reviewing Test Mode Restrictions
You can review the restrictions in effect when the software is in Test Mode. You cannot
change the restrictions while in the testing session. You must exit Test Mode and re-
enter it with new restrictions.

To review the current restrictions:

1. Click the information icon in the Test Mode bar.

The Test Mode Information dialogue opens which displays the following:

• Press-to-Test code
• Time in Test Mode
• Default Angle
• CAS Mode (TI-Nspire™ CX CAS Student Software only)
• Exact Arithmetic (TI-Nspire™ CX Student Software only with the TI-Nspire™ CX

II-T handheld type selected)
• Restrictions
• Log of timestamps for various events
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2. Click OK to return to the current test session, or click Exit Test Mode to end the
session.

Working with a Document in Test Mode
While in Test Mode, you will only see documents you have created during the test
session. You cannot open documents that were created before entering Test Mode.

Creating a New Document

1. On the TI-Nspire™ File menu,

• Select New TI-Nspire™ Document - Handheld Page Size.

—or—

• Select New TI-Nspire™ Document - Computer Page Size.

The new document opens in the Documents Workspace, and you are prompted to
select an application.

2. Select an application to add a problem to the document.

The problem is added to the document.



Losing Software Focus in Test Mode

The TI-Nspire™ CX Student Software is designed to keep the user in Test Mode without
access to other applications for the duration of the test. If the focus shifts away from
the software, the title bar will turn red.

This activity is recorded as "Left Test Mode" on the Test Mode Summary dialogue
(below) and in the TestLog PDF file that is available after exiting the Test Mode.
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Note: To avoid any unintentional shifts away from Test Mode, it is recommended that
other applications be closed or disabled beforehand, especially screen capture,
accessibility, or other others that run in the background.

Exiting Test Mode
When you exit Test Mode, any document created during the session is deleted and
system settings are restored to their state before you entered Test Mode.

To exit Test Mode:

1. Click the Exit button on the Test Mode title bar.

2. On the Exit Test Mode prompt, click Yes.

The Test Mode Summary dialogue opens which displays the following:

• Press-to-Test code
• Date
• Time in Test Mode
• Start Time and End Time
• Log of timestamps for various events

3. Click Done.

The Save as PDF dialogue opens. This allows you to save the TestLog PDF file that
contains the information from the Test Mode Summary dialogue.

4. Select a location on your computer to save the TestLog and click Save.

The software is restored to a state as if it were just launched.

Understanding Test Mode Restrictions
By default, all restrictions are selected when you enter Test Mode, with the exception
of Numerical Solver.



• Selecting a restriction disables or limits its associated features during the Test
Mode session.

• Clearing a restriction allows its associated features to be used during the session.

Restricting Geometry Functions

When you choose to limit geometry functions, all items on theMeasurement,
Construction and Transformationmenus are disabled.

Restricting Graphs Functions

On the Graphs menu, the following items are disabled:

• Actions > Coordinates and Equations

• Geometry > Measurement, Construction, and Transformation

Disabling Function and Conic Grab and Move

• You cannot move any function or conic in Graphs, Geometry, or Scratchpad. For
example, if you have graphed y=x3, you can select the function but you cannot
move or manipulate it by dragging.

• You cannot access the attribute that toggles the displayed form of a conic equation
between Standard and Expanded.

• Disabling function and conic grab and move does not apply to lines and functions in
Data & Statistics.

• Disabling function grab and move does not restrict sliders in the Graphs and
Geometry applications.

• You can still grab the coordinate plane and move it around.

Disabling Vector Functions

When vector functions are disabled, students cannot calculate the following functions:

• Unit vector [unitV(]

• Cross product [crossP(]

• Dot product [dotP(]

• Eigenvector [eigVc(]

• Eigenvalue [eigVl(]
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Disabling the “isPrime” Function

The isPrime( function determines if a number is a prime number (a whole number
greater than two that is evenly divisible only by itself and one). Disabling this function
prevents students from selecting the isPrime( command in the Catalogue and from
selecting Test > IsPrime in Maths Operators. If a student manually enters the isPrime(
function, submitting the expression results in an error message.

Disabling Differential Equation Functionality

The Differential Equation graph type is disabled in the Graphs and Geometry
applications. Users cannot manually type and graph a differential equation.

Related maths functions rk23(, euler(, and deSolve( are also disabled.

Disabling Inequality Graphing

When inequality graphing is disabled, students cannot graph inequalities with <, >, ≤
and ≥ or grab and drag inequalities to a graph in the Graphs, Geometry and Scratchpad
applications.

Disabling 3D Graphing

When this feature is disabled, students cannot use the 3D Graphing view.

Disabling Implicit Graphing, Conic Templates, Conic Analysis, and Geometric Conics

When these features are disabled, students cannot graph equations in terms of
x = ay + c or ax + by = c. Conic templates are not available, and students cannot
analyse conics or graph the geometric conic of an ellipse, parabola, hyperbola or conic
by five points.

Disabling Trigonometric Functions

Disabling trigonometric functions prevents students from using the following functions
in calculations and graphing.

csc sec cot

csc-1, arccsc sec-1, arcsec cot-1, arccot

csch sech coth

csch-1, arccsch sech-1, arcsech coth-1, arccoth

• Attempting to evaluate any of these functions results in an error message.



• Students cannot select the csc, sec, cot, csc-1, sec-1, and cot-1 functions by pressing
µ on the software.

• Students cannot select the disabled functions from the Catalog.

Disabling the logbx Template

Students cannot use the logbx (convert to logbase) and log(a, b) commands and
templates, including logbx templates.

• When a students pressesÖ on the software, only calculations in log10 format are
accepted.

• If a student manually enters log(a,b) or >logbase( into an expression, attempting to
evaluate the expression results in an error message.

• Students are allowed to enter log(a), log(a,10) and log(a,10.).

Disabling Summation Functions and Templates

Students are prevented from using summation functions and templates. The ∑( and
sumSeq( functions are disabled.

Disabling Polynomial Root Finder

The polyRoots(, cPolyRoots(, solve(, simult(, zeros(, and cZeros( functions are disabled.
Attempting to evaluate any of these functions results in an error message.

Note:When the polynomial tools are disabled, students cannot use Find Roots of
Polynomial, Real Roots of Polynomial or Complex Roots of Polynomial.

Disabling Simultaneous Equation Solver

The linSolve( and simult( functions are disabled in menus and in the Catalogue.
Attempting to evaluate either of these functions results in an error message.

Disabling Numerical Solver

The nSolve( is disabled in menus and in the Catalogue. Attempting to evaluate either of
these functions results in an error message.

Disabling Sliders

When this feature is disabled, students cannot insert or create sliders in the Graphs,
Geometry, Data & Statistics, and Notes applications.
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Appendix A: Conversion Categories and Units
The following table lists categories and their respective units that are available in the
Unit Conversion Assistant. When the units are pasted to the entry line, underscores (_)
are added before the name of each unit to differentiate them from other variables. For
example:

• _cm►_m

• _km/_hr►_m/_s

• _¡C►_¡F

Category Units

Length Å (Angstrom)
au (astronomical unit)
cm (centimetre)
dm (decimetre)
fath (fathom)
fm (fermi)
ft (foot)
in (inch)
km (kilometre)
ltyr (light-year)
m (metre)
mm (micron)
mi (mile)
mil (1/1000 inch)
mm (millimetre)
nm (nanometre)
Nmi (nautical mile)
pc (parsec)
rod (rod)
yd (yard)

Area acre (acre)
cm2

dm2

ft2

ha (hectare)
in2

km2



Category Units

m2

mi2

mm2

yd2

Volume cm3

cup (cup)
dm3

ft3

floz (US fluid ounce)
flozUK (British fluid ounce)
gal (US gallon)
galUK (British gallon)
in3

l (litre)
m3

ml (millilitre)
pt (pint)
qt (quart)
tbsp (tablespoon)
tsp (teaspoon)
yd3

Time day (day)
hr (hour)
min (minute)
ms (millisecond)
ms (microsecond)
ns (nanosecond)
s (second)
week (week)
yr (year)

Velocity ft/min
ft/s
knot (knot)
km/h
km/min
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Category Units

km/s
m/s
mi/h
mi/min
mi/s

Temperature ¡C (Celsius)
¡F (Fahrenheit)
K (kelvin)
¡R (Rankine)

Mass amu (atomic mass unit)
gm (gram)
kg (kilogram)
lb (pound)
mg (milligram)
mton (metric ton)
oz (ounce)
slug (slug)
ton (ton)
tonUK (long ton)

Force dyne (dyne)
kgf (kilogram force)
lbf (pound force)
N (newton)
tonf (ton force)

Energy BTU (British thermal unit)
cal (calorie)
erg (erg)
eV (electron volt)
ftlb (foot-pound)
J (joule)
kcal (kilocalorie)
kJ (kilojoule)
kgf*m
kWh (kilowatt-hour)
latm (liter-atmosphere)

Power hp (horsepower)
kW (kilowatt)



Category Units

PS (metric horsepower)
W (watt)

Pressure atm (atmosphere)
bar (bar)
inH2O (inches of water)

inHg (inches of mercury)
kPa (kilopascal)
kgf/cm2

lbf/in2

mbar (millibar)
mmH2O (millimetres of water)

mmHg (millimetres of mercury)
N/m2

Pa (pascal)
psi (pounds per square inch)
torr (millimetres of mercury)
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452 General Information

General Information
Online Help
education.ti.com/eguide

Select your country for more product information.

Contact TI Support
education.ti.com/ti-cares

Select your country for technical and other support resources.

Service and Warranty Information
education.ti.com/warranty

Select your country for information about the length and terms of the warranty or
about product service.

Limited Warranty. This warranty does not affect your statutory rights.

Texas Instruments Incorporated

12500 TI Blvd.

Dallas, TX 75243

https://education.ti.com/eguide
https://education.ti.com/ti-cares
https://education.ti.com/warranty
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.tilb file 56

3

3D aspect ratio, changing 195
3D functions

graphing 189
3D graph

changing appearance 193
3D graphing 446
3D Graphing view 189, 191
3D graphs

animating with sliders 197
editing expressions 192
plot colors 193
range settings 195
rotating 191
setting background colours 194
showing/hiding 194
shrinking/magnifying 194

3D parametric equations
graphing 190

3D projection type 194

A

activating software licences 430
add files to lesson bundle 50
adding

applications 40
colours 36
copyrights to documents (.tns) 47
pages 44
problems 44
titles to graphs 399

Adding files to a lesson bundle 50
adding images 67
alternative hypothesis 292
analysing data

integral 387
model 391
tangent 388

analysis options
removing 391

angle bisector construction 179, 231

angles
measuring 172, 224

animating
points 182, 238

animations
changing points direction 183, 239
pausing 182, 239
resetting 183, 239
resuming 182, 239

answer
using last answer 108

appearance
of 3D graph 193

application
tools menu 2

applications
adding 40
Calculator 74
Data & Statistics 295
deleting 44
Geometry 199
Graphs & Geometry 111
grouping 43
images 67
Lists & Spreadsheet 244
Notes 340
swapping 41

approximate or exact results 257
arcs, drawing 157, 209
area, bounded 146
area, measuring 171, 223
arithmetic calculations 187, 241
aspect ratio, changing in 3D

graphing 195
attributes

changing for objects 168, 220
automatic

sliders in Graphs application 105
Automatically creating variables in

Lists & Spreadsheet 101
axes

adjusting 327
changing attributes in Graphing

view 142
dilating 322
moving (translation) 322
scaling 322
setting values (Data & Statistics) 327
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axis ranges
setting in graphs 400

B

backup
of class data 433

bar charts
creating 312-313, 315

bisect a segment 177, 229
bisecting an angle 179, 231
bounded area 146
box plots 302
breaking long calculations 348

C

Calculate output option 274
calculating distributions (Lists &

Spreadsheet) 280
calculations

arithmetic 187, 241
breaking 348
derivative settings 410
types available 277

Calculator
menus 74

Calculator application 74
Calculator history

copying 94-95
deleting 96
reusing 95
viewing 93

captions, viewing variable names 296
capture page option 59
Capture Selected Handheld option 60
capturing

active pages in documents 59
data (Lists & Spreadsheet) 269
handheld current screens 59
images in hand-held mode 59
pages in active documents 59

capturing images
DragScreen 64

caseplots (default) 296
Catalogue

converting measurement units 82
inserting items from 76, 79, 252, 274

cell references
absolute and relative 251

using in formulas 252
cells

body 247
copying in tables 253
deleting contents 252
entering text 248
exact or approximate results 257
formulas 247
inserting ranges in formulas 248
linking to a variable 102
linking to variables 254
navigating in tables 250
repeating formulas 253
selecting a block of 253
selecting a range 248
sharing table cells 254

changing
General Settings 20
Graphs & Geometry settings 22
language 1, 3

Changing language 3
changing screen size 426
character strings

storing as variables 98
charts

bar 312
dot 311
pie 314
scatter 299

chemical equation boxes 353
circle arcs, creating 157, 209
circles, drawing 158, 210
class data

backup 433
closing documents (.tns) 34
collected data

deleting 384
viewing details 385

collecting and managing data sets 382
colors

changing 168, 193, 220
colour

setting grid colour in Graphs 141
colours

3D graph background 194
applying to backgrounds 343
changing 251, 333-334, 343
changing for points 406

colours, adding 36
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columns
based on other columns 260
copying 256
defining options 394
deleting 256
deleting data from 258
generating data in tables 259
inserting 79, 256
linking to list variables 246
moving 257
resizing 255
selecting 255, 406
sharing table columns as lists 245

commands
cSimult( 447
inSolve( 447
sumult( 447

comments
inserting in Notes 345

comparing
data sets 383

comparing collected data sets 382
compass construction 181, 233
confidence intervals available 286
conic analysis 446
conic by five points 162, 214
conic templates 446
conics, graphing 123
connected handhelds

opening documents 25
saving files 25

constructions
angle bisector 179, 231
compass 181, 233
locus 167, 180, 219, 232
midpoint 177, 229
parallel line 178, 230
perpendicular bisector 179, 231
perpendicular line 178, 230

Content Explorer 17
context menu

graphing from 352
context menu in Lists & Spreadsheet 256
converting

measurement units 82
page size; page size, converting;

preview, setting
document; setting

document preview 36

copying
Calculator history 94-95
cells from Excel® spreadsheets 268
handheld images 59
images 59
images in hand-held mode 59
screens 64
table cells 253
table data 266
table rows or columns 256

copyrights
adding to documents (.tns) 47

creating
bar charts 312-313, 315
histograms 306
lists from table columns 245
matrices 78
new documents 442
pie charts 314
plots 301
probability plots 308
scatter plots 309
shapes with MathDraw 163, 215
summary plots 265
system of equations 81
user-defined units 83
variables 97

Creating a new lesson bundle 49
Creating a variable from a Graphs &

Geometry value 99
Creating a variable from a Lists &

Spreadsheet cell value 101
creating documents (.tns) 31
curve fit options 390
curves, bounded area 146
customising

Graphs work area 141

D

data
backup of class data 433
capturing (Lists & Spreadsheet) 269
capturing object data (Graphs &

Geometry) 269
copying to other applications 266
deleting from columns 258
displaying values 298, 301
exact or approximate results 257
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generating columns of 259
graphing table data 262
raw and summary overview 300
retrieving remote 380
selecting ranges 404
sorting in tables 258
sorting plotted categories 319

Data & Statistics
getting started with 295
images 67
settings 296

data analysis
interpolation 388

data collections
remote sensors 378
scaling graphs 403
setting sensor parameters 369
thresholds 380

data plots
finding curve fit 389

data sets
comparing 383
deleting collected 384
renaming 384
selecting for replays 409
selecting to plot 401
storing 382

data sets, collecting and managing 382
data types

variables 97
defined functions, recalling 91
defining

functions 80, 87-88
settings 1, 3
units 83

deleting
applications 44
Calculator history 96
collected data sets 384
contents of table cells 252
data from columns 258
documents (.tns) 34
elements from lists 247
pages 43, 45
part of an expression 92
problems 43, 45
table rows and columns 256
variables 109

deleting images 69

derivative settings
adjusting 410

diagnostics, regression 296
differential equation graphing 446
differential equations, graphing 133
dilating axes 322
disabling functions

"isPrime" 446
3D graphing 446
conic analysis 446
conic templates 446
differential equation graphing 446
function and conic grab and

move 445
geometry functions 445
implicit graphing 446
inequality graphing 446
logbx template 447
numeric solver 447
polynomial root finder 447
simultaneous equation solver 447
sliders 447
summation functions and

templates 447
trigonometric functions 446
vector functions 445

displaying
data values 298, 301
Graph 1 393
graphs 393
graphs in Page Layout view 394
grid in Graphs 141
TI-SmartView™ emulator in

teacher software 425
two graphs simultaneously 393

distribution, calculating 280
documents 442
documents (.tns)

changing General Settings 20
closing 34
creating 31
deleting 34
opening 32
opening with TI-SmartView™

emulator 429
printing 46
properties 47
protecting 48
read-only 48
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saving 33-34
saving in emulator 429
switching between 37
viewing 38

documents workspace 2
Documents Workspace 13
domain restrictions 118
dot charts 311
DragScreen feature 59, 64
drawing

arcs 157, 209
rectangles 159, 211
statistics plots 338
triangles 158, 210

drawing geometric shapes 157, 209
drawing shapes

ellipse 160, 212

E

editing 137
functions 137
math expressions 91
table settings 293
values in lists 246

elements, deleting from lists 247
ellipse

as geometric shape 160, 212
Emailing a lesson bundle 57
emulator, See TI-SmartView™

emulator 15
enabling

Test Mode 436, 438
entry line

multiple statements 82
equations

differential 134
graphing 122
graphing parametric 129
graphing polar 129
Lotka-Volterra 133
of geometric objects 186
ordinary differential equations

(ODE) 133
errors

showing (Notes) 349
estimating

values between data points 388
evaluating expressions 77

exact input, for window settings 139
exact or approximate results 257
Excel® spreadsheets, copying from 268
Exit Press-to-Test mode 444
expanding view details area 385
experiments

basic steps 363
Exploring the Documents workspace 2
expressions 137

changing functions in tables 293
copying from Calculator history 94-95
deleting part of 92
editing 91, 192
entering from templates 76-77
entering in tables 248
entering with wizards 79, 274
evaluating 75, 348
selecting (Notes) 344
selecting in Calculator 91
variables 98

F

files
adding to lesson bundles 54
copying/pasting from lesson

bundles 54
deleting from lesson bundles 54
opening in lesson bundles 54
pasting from lesson bundles 54
refreshing list in lesson bundles 54
renaming in lesson bundles 54
working with files on connected

handhelds 24
finance 92
finance functions 93
finance solver 92
finding

area under collected data 387
slope of collected data 388
software version number 434

formatting
results (Calculator) 75

formatting text 35
formatting toolbar

hiding 35
showing 35

frequency plots 264
function and conic grab and move 445
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functions
changing expressions in tables 293
defining 80, 87-88
displaying history 138, 192
displaying list of in tables 293
domain restrictions 118
editing 137
graphing 114, 121, 328
hiding table of 137
hiding/showing 144
recalling definitions 91
renaming 138
rotating 116
showing values in tables 292
storing as variables 98
stretching 116
supported distributions 281
translating 116

G

generating
columns of data 260

geometric objects
equations of 186

geometric shapes
conic by five points 162, 214
hyperbola 162, 214
parabola 161, 213

Geometry
hiding objects 236

Geometry application 199
Geometry application settings 112, 199
geometry functions 445
gestures, to create shapes

(MathDraw) 163, 215
graph

changing appearance 193
graphing

3D functions 189
3D parametric equations 190
3D view 189
conic sections 123
equations 122
from context menu 352
functions 114, 121, 328
parametric equations 129
path plot 115
polar equations 129

relations 126
scatter plots 130
sequences 131
table data 262
time plots 131
web plots 131

Graphing view
changing axes attributes 142

graphs
adding titles 399
displaying 393
displaying Graph 1 393
displaying in Page Layout view 394
displaying two simultaneously 393
position versus time 412
rescaling 322
scaling 402
setting axis range 400
tracing all 149
velocity versus time 412

Graphs
rescaling work area 139

Graphs & Geometry
images 67
variables, creating 99

Graphs & Geometry application 111
Graphs & Geometry settings 22
grid

appearance in Graphs 141
displaying 141

grouping applications 43
guidebooks, downloading 432

H

handhelds
capturing current screens 59
capturing selected handhelds 60
checking for OS updates 26
copying images 59
installing OS update 27
pasting images 59
working with files on connected 24

Help, accessing 430
helping improve the product 435
hiding

3D graphs 194
functions in work areas 144
objects in Geometry 236
table of functions 137
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hiding format toolbar 35
histograms

adjusting scale 306
creating 306
exploring data in bins 305
modifying bins 307
scale formats 306

history
relation 138, 192

history, See Calculator history 93
hyperbola

as geometric shape 162, 214

I

images 67
Data & Statistics 67
deleting 69
Graphs & Geometry 67
inserting 67, 344
inserting background 113, 201, 237
moving 68
Notes 67
Question 67
Quick Poll 67
resizing 69
saving 59
selecting 68
TI-Nspire™ applications 67

implicit graphing 446
importing

remote data 380
inequality graphing 446
inferential statistics

calculating test results
(Calculate) 274

drawing plots 338
graphing test results 274
input descriptions table 274
pooled option 292

inserting
background images 113, 201, 237
cell ranges in formulas 248
chemical equations 344
comments in Notes 344
elements in lists (Lists &

Spreadsheet) 247
images 344
maths expressions 344

rows or columns in tables 256
rows or columns into matrices 79
shape symbols 344
text 335

inserting images 67
installing

software updates 433
installing a handheld OS update 27
intercept, changing 324
interfaces

multi-channel sensors 364
single-channel sensors 364

intervals 372
isPrime function 446

L

labeling
point coordinates 185

language 3
changing 1, 3

last answer
using 108

LED lights
sensors 380

lesson bundle
add files 50
adding files 50
creating 49

lesson bundles
adding files 54
copying/pasting files 54
deleting files 54
Documents workspace 49
opening 52
opening files 54
refreshing list of files 54
renaming files 54

libraries 419
library objects

using 421
lines

adding movable to plots 323
locking intercept at zero 324
rotating movable 324
tracing movable 325

lines (geometric)
creating 154, 206

lines and points, creating 152, 204
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linking
columns to symbol table 394
table cell to a variable 102
table cells to variables 254
table columns to lists 246
values 97

linking variables 102
links

removing linked variables 109
list maths in Lists & Spreadsheet 248
lists

deleting elements in tables 247
inserting elements in tables 247
sharing table columns as 245
storing as variables 98
viewing and editing 246

Lists & Spreadsheet
variables 101-102

Lists & Spreadsheet application 244
locating software updates 433
locking

intercept of movable lines at
zero 324

locus construction 167, 180, 219, 232
logbx (convert to logbase) 447
logbx template 447
losing software focus 443
Lotka-Volterra equations 133

M

managing collected data sets 382
Managing lesson bundles 54
math expression boxes

attributes 355
math expressions

editing 91
selecting in Calculator 91

MathDraw, creating shapes with
gestures 163, 215

maths actions 349
maths expression boxes 349, 354
maths expressions, See expressions 75
maths templates 76
matrices

creating 78
inserting rows or columns 79
storing as variables 98

measurement units
changing (Vernier DataQuest ™) 370

measurements
storing as variables 98

measurements, converting units 82
measuring

angles 172, 224
circumference or perimeter 170, 222
distance between objects 169, 221
length 169, 221
sides of objects 170, 222
slope of object 171, 223

measuring objects 169, 221
menus

Calculator 74
midpoint construction 177, 229
models, PDF distribution 280
motion match

options 412
removing plots 412

moving
points (Data & Statistics) 319
rows and columns (Lists &

Spreadsheet) 257
moving images 68
multiple-line functions 87-88
multiple cells, selecting 253
multiple statements on entry line 82

N

naming
table columns 245
variables (name conflicts) 255

naming columns 394
navigating in tables 250
new documents 442
normal probability, creating plots 308
Notes

adding shapes 345
formatting text 342
images 67
inserting comments 345
selecting text 342
using colours 343

numeric plots, splitting by categories 316
numeric solver 447
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O

objects
changing attributes 168, 220
changing fill colors 168, 220
dilating 176, 228
duplicating 175, 227
enlarging 176, 228
finding area 171, 223
hiding in Geometry 236
measuring 169, 221
reflecting 174, 226
rotating 176, 228
symmetrical images 174, 226
tracing geometric 234
transformation of 174, 226

opening
lesson bundles 52

Opening a lesson bundle 52
opening documents

connected handhelds 25
opening documents (.tns) 32
Opening files within a lesson bundle 52
options

capture page 59
Capture Selected Handheld 60

orthogonal 3D view 194
orthographic 3D projection 194
OS update

installing on a handheld 27

P

Page Layout view 394
Page Sorter 14, 41
pages

adding 44
deleting 43, 45
grouping 43
rearranging 42
selecting 42
ungrouping 44

parabola
creating from focus and directrix 161, 213
creating from focus and vertex 161, 213

parallel line construction 178, 230
parametric equations

graphing 129
pasting

handheld images 59

images 59
images in hand-held mode 59
screens 64
table data 266

PDF
save document as 46

perpendicular bisector construction 179, 231
perpendicular line construction 178, 230
perspective 3D view 194
pie charts, creating 314
piecewise functions 80
playbacks

adjusting rate 410
pausing 409
repeating 410
starting 409

plots
adding a value on existing plot 320
adding movable lines 323
caseplots (default) 296
changing type 321
colors in 3D graphs 193
creating 301
customising 132
dot plots 301
graphing 130-131
path plot 115
predictive 411
probability 308
removing motion match 412
scatter 309
sorting categories 319
summary 264
X-Y line 310

plotting
dot charts 311
models 391
path plot 115
statistical data 274
table data 262

points
animating 182, 238
changing colours 406
changing direction 183, 239
creating 152-153, 204-205
identifying intersections 154, 206
labeling coordinates 185
moving (Data & Statistics) 319
of interest 119
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selecting (Data & Statistics) 319
setting markers 406
setting options 405

points and lines, creating 152, 204
polar equations

graphing 129
polygons, drawing 159, 211
polynomial root finder 447
pooled variances 292
pre-defined measurement units 82
precision of results 75
predictive plots

drawing and clearing 411
preview, printed document 47
print preview 47
printing documents (.tns) 46
probability, creating plots 308
problems

adding 44
deleting 43, 45
renaming 46

product improvements 435
programmes

defining 87
Proof template 341
protecting documents (.tns) 48

Q

Q & A template 341
Question

images 67
navigating the application 70

questions
responding 71

Questions - students
accessing toolbar 70
types of 70

questions (students)
checking answers 72
toolbar options 70

Quick Graph, using 262
Quick Poll

images 67
Quick Poll questions

clearing answers 73
responding 71
types 71

R

random numbers
generating in tables 260

range of cells, inserting in formulas 248
raw data 300
raw data, adjusting histogram scale 306
rays

creating 155, 207
read-only documents (.tns) 48
reducing view details area 385
RefreshProbeVars 385
registering products 432
regression diagnostics 296
regression lines, showing 325
relations

displaying history 138, 192
graphing 126
showing table of values 136

remote data
retrieving 380

removing
variables 109

removing images 69
renaming

data sets 384
functions 138

renaming problems 46
replays

starting 409
rescaling

graphs (dilation) 322
graphs (translation) 322

resizing
table rows and columns 255

resizing images 69
restoring data 408
results

copying from Calculator history 94-95
setting decimal approximation 75
using last answer 108

reusing
last answer in Calculator 108

reviewing
restrictions 441

rotating objects 176, 228
rows

copying 256
deleting 256
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inserting 79, 256
moving 257
resizing 255
selecting 255

S

Save
document as PDF 46

saving
captured images 59
captured pages 62
documents (.tns) in emulator 429
handheld screens 62
images 59

saving documents (.tns) 33-34
saving files

to connected handhelds 25
scaling graphs 402
scaling Plane Geometry Analytic

window 139
scatter plots 309
screen capture tool 59
screen captures

copying 64
pasting 64

scrolling in tables 250
segment

bisector 177, 229
segments

creating 155, 207
selecting

a block of table cells 253
columns 406
data ranges 404
data sets for replays 409
data sets to plot 401
expressions in Calculator 91
table rows or columns 255
templates 341
text in Notes 342

selecting images 68
selecting pages 42
Sending Lesson Bundles to

connected handhelds 57
sensors

calibrating 371
changing measurement units 370
connecting 368

for computers 366
for handhelds 365
for remote data collections 378
interfaces 364
LED lights 380
reversing reading display 371
setting to zero 371
setting up offline 369
triggering 380
types 365

sequences, generating in table
columns 261

sets
renaming data sets 384

sets of data, comparing 383
sets, storing data as 382
settings

Data & Statistics application 296
defining 1, 3
in Geometry application 112, 199
language 1, 3
TI-SmartView™ emulator 427

shapes
adding in Notes 345
creating with MathDraw 163, 215
drawing geometric 157, 209
equations of 186
legends 299

showing
3D graphs 194
functions in work areas 144

showing format toolbar 35
showing screen details 407
simultaneous equation solver 447
sliders 447

animating 3D graphs 197
sliders, adjusting variable values 105
slope 388

measuring 171, 223
software

checking for updates 433
installing updates 433

software licences, activating 430
software version number 434
solving simple maths expressions 75
sorting

plotted categories 319
table data 258

splitting numeric plots by categories 316
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spreadsheets
navigating 250
sharing columns as lists 245

statistical tests, supported 288
statistics, drawing plots 338
status bar 3
stored variables

linking to 102
storing

data as sets 382
striking data 408
strings

storing as variables 98
strip charts 372
substituting a value for a variable 109
summary data 300
summary information, displaying 298
summary plots 262, 264

creating 265
summation functions and templates 447
symbol table

linking columns to 394
syntax

using to prevent naming
conflicts 255

system of equations 81

T

table data
graphing 262
sorting 258
using in statistical analysis (Lists

& Spreadsheet) 274
table of values 136
tables

changing expressions for
functions 293

copying rows or columns 256
deleting contents of cells 252
deleting list elements 247
deleting rows and columns 256
displaying list of functions 293
editing settings 293
generating column data 259
inserting list elements 247
inserting rows or columns 256
linking columns to lists 246
moving rows or columns 257

navigating in 250
restoring data 408
selecting rows or columns 255
sharing columns as lists 245
showing function values 292
striking data 408
working with cells 251

tangents, creating 156, 208
templates

maths 76-77
Notes 341
Proof 341
Q & A 341
selecting 341

Test Code Examples 439
Test Mode folder 442
Test Mode restrictions 441, 444
text

adding to work areas 113, 141, 201, 237
changing colours 343
entering 248
formatting in Notes 342
selecting in Notes 342

text formatting 35
threshold values

increasing/decreasing 380
TI-Nspire™ applications

images 67
TI-Nspire™ Screen Capture Window 61

zooming in/out 62
TI-Nspire™ SmartView Emulator

capturing images 59, 64
TI-SmartView™

capturing images 59
DragScreen feature 59

TI-SmartView™ emulator 15, 426
capturing screens 429
changing panel width 425-426
opening 424
opening documents (.tns) 429
options 428
saving documents (.tns) 429
settings 427

TI-SmartView™ Emulator 424
TI websites 432
titles, clicking to see variable names

(Data & Statistics) 296
tool palette 2
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toolbar 2
text formatting 35

tools
screen capture 59
variable

variable

tool 102

Touchpad, navigating in emulator 427
tracing

all graphs simultaneously 149
geometric objects 234

transformation of objects 174, 226
triggering

enabling 382
trigonometric functions 446
troubleshooting information 432

U

ungrouping
applications 43-44
pages 43-44

units
converting measurement

symbols 82
creating user-defined 83

V

values
assigning to variables 97

variables 86
checking in Calculator 99
creating 97
creating from table cells 254
Graphs & Geometry values 99
linking 97, 102
linking table columns to lists 246
linking to 102, 254
Lists & Spreadsheet cells 101
preventing naming conflicts 255
removing 109
sharing table columns as lists 245
sharing with other applications 97
substituting a value for 109
types 97
updating in Calculator 108
using 97

using in a calculation 103
variances, pooled 292
vector functions 445
vectors

creating 156, 208
version number, locating 434
view

3D Graphing 189
viewing

captured screens 61
documents (.tns) 38
values in lists 246

views
3D Graphing 191
Graph 363
Page Layout 394
Table 363

W

warnings, showing (Notes) 349
websites, locating troubleshooting

information 432
window settings

custom 139
windows

TI-Nspire™ Screen Capture 61
wizards

entering expressions
(Calculator) 79

entering expressions (Lists &
Spreadsheet) 274

statistics 274
work area

customising in Graphs and
Geometry 141

work areas
adding text to 113, 141, 201, 237

working with documents 442
Working with Lesson Bundles 49
workspace

Documents 2
workspaces

Documents Workspace 13

X

X-Y line plots 310
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zooming 139
handheld preview 36
in 404
in/out 62
out 404
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