1)

Transfer the Turtle module “tns” file to your TI-

Nspire CX Il family calculator(s)

After downloading the Zip and extracting files:

e Open your TI-Nspire CX desktop doftware

e Connect your TI-Nspire CX Il calculator(s) to your
computer using the computer-to-calculator USB
cable that comes with the calculator.

e Verify that your connected calculator appears in the
Connected Handheld window on the Content
Explorer tab of the desktop software.

o Transfer the Turtle “tns” file to the connected
calculator by dragging the file into the Connected
Handheld window.

e After opening the file on your calculator, go to step
3) Install the Turtle Module

This step requires use of TI-Nspire CX desktop software for

PC or Mac

0 Documenn! - T1-Nspee™ CX Saugem Softmare.
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Press menu

Alternately,

e use the free browser-based TI-Nspire CX Il
Connect app (https://nspireconnect.ti.com/) to
transfer the Turtle “tns” file to a TI-Nspire CX Il that
is connected to the computer with the computer-to-
calculator USB cable.

Note: the Turtle “tns” file may also be transferred
calculator-to-calculator via unit-to-unit USB cable
linking process prior to installation.

e Go to step 3) Install the Turtle Module

This is an online utility that works with Chromebooks
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2)

Transfer the Turtle module “tns” file to your

desktop software (PC or Mac)

After downloading the Zip and extracting files:

e Drag and drop the Turtle “tns” file onto your TI-
Nspire CX desktop software.

o After the file opens, go to step 3) Install the Turtle
Module

Press menu
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3)

Install the Turtle module

These steps install the module on the handheld
calculator. These same steps are also used to install
the module on the desktop software.

e Open the Turtle file and read instructions on page
11

e Press|[ctrl] + [P] to switch to the Python Shell on
page 1.2.

Ti-Nspire CX Il Python Turtle phi

.

Module Installation Directions:

1. Select [ctri}+[»] to switch to the Python shell on
the next page.

2, Select [menu] -> Tools -> Install as Python
Module.

3. Once installed, a message “Installation
complete” will appear, and the original file is
moved to the PyLib folder.

3 1 rewn stpoaen coon) | 2 LR
E2 2 Edit 2 Go to Python Editor
e Press [menu] and select Tools > Install as 3 Buit-in3 Run.. 03 Python Shel n
5 4 Math 4 Clear History
Python module @5 R:r:durs Reinitialize Shell Installation completed
¢ Once installed, a message “Installation completed” ;g EE‘TS’ AT import e ns nes been instaled s @ moduls
. L . | Swthon module Ok
will appear, cofirming istallation. # 8 Tl Rovés Yron S Lo
& 9 More Modules »
var A Variables »
Note: when installed, the Turtle module file is moved to
the Pylib folder.
4) Accessing the Turtle module menu selections
. . ra v
After the Turtle module completes installation, you must | & ¥ s o | ]
Scratchpad Documents —
; ; o 3 Add Geometry
create a New document in order to write a Turtle 1 New B ¢ AddLists & Spreadeheet
I 5 AddData & Statistics
program. [E] 6 Add Notes
2 7 Add Vernier DataQuest™
8 Add Widget
e From the home screen, select New gs Add Program Editor y
1A AddPython DT
e Select Add Python, New... 3 Eﬁi‘.‘"
[

e Give the Python program a name (example:
square), OK

At this point you are in a Python program Editor
page.

e Press the [menu] key then select More Modules >
Turtle Graphics

At this point you are ready to begin writing a Python
program using Turtle module selections.

Name: [ square|

Elank Program »

Type:

oK Cancel

B square.py

P 2 Run » 11
3 Edit Y
1. 4 Built-ins 4

¥ 5 Math »

MH Complex Math »

L& 7 Tl PlotLib 2 Time y

< 8 TIHub 3 Tl System 3

# 9 Tl Rover 4 Tl Draw N

& 5 TlImage 3

vr B Variables

8 Filing ’

P 2 Run » n
3 Edit »

If.. ilt-i »

2 Move »

3 Draw » Complex Math »

4 Pen control » Time »

5 Seftings » Tl System »

6 Tell Turtle’s state » Tl Draw »

7 Colors » Tllmage  »




Creating Your First Turtle Program: Let’s draw a Square

Continuing from the module menu selections above (while
in an Editor page)

[ *square.py
from turtle import *; t=TurtleQ

I, —| »

1) Select from turtle import * 2 Move ,
3 Draw » Complex Math »
4 Pen control » Time L
. . . S Settings » Tl System &
Pressing [enter] will paste the import statement and & TellTume's state » TIDraw )
constructor t=Turtle() as the first line in your program. L Coere LT

This imports the Turtle module functions and methods
into your program and defines your turtle as an object
named “t".

Note: All successive menu selections assume a turtle
object named “t”. Changing the object name will also
require changing the pasted syntax.

. . 1A % 1 Acti 1
2) Press enter once or twice to advance to line 3. m m
i i ; 3 Edit b if.. -
Note: line numbers are shown in the top-right corner of . 3 Eunctions ¢ 2 foelse..
¥ 5 Math 3 if.elif.else..
the page. @6 Random 3 Ops ’ forinde in range(start, stop):
P 4 List: » ' d
; ; Eat’:"b 5 lepse » 6 for index in range(start, stop, step):
3) Press [menu] and select Built-ins, Control, and from @®9 TIRover 610 [ forndexinst
. . . . & A More Modules » 9 elf -
index in range(size): [ Bl Varkbes 0| o
Notice the in-line prompt which highlights the word X
“r » H : Al [ *square.py 3/5 *square.py 45
index”. Pressing Tab will cycle through the in-line frorm turtle Import ™ ETUrE0 o rle Irpar =T GED
prompts. for [{EE in range(size): for sides in range(d):
block
4) Enter “sides” for the index and “4” for size




5)

With the cursor on the in-line prompt “block”, press
[menu] and select More Modules, Turtle Graphics,
Move, then the t.forward(distance) selection

% 1 Actions ’
P 2 Run »
E 3 Edit »
1. 4 Built-ins

from turtle import *; t=TurtleQ)

"AT‘.JI.-"‘.a‘-il\-'h—:!‘a ce
1 from turtle import * 2 t.backward(distance)

for sides in range(4):

3 tright(angle) tforward (EIE)
3 Draw 4 tleft(angle)
4 Pen control 5 t.goto(x,y)
H 5 Settings 6 t.setheading(angle)
6) Enter the distance you want the turtle to travel forward. SEF RO My
In this example, let’s enter 75 units o/ (el 8 Lelear)
8 Filling 9 treset)
Note: The distance unit is measured in pixels. By :
; i i ; ; *square.py 5/6
default, the grid scale is set to 25 pixels wide per grid oo o S ToR0
square. for sides in range(4):
t.forward(75)
7) Jump to the end of the line by pressing [tab], then
press [enter] for a new line.
Alternately, press [ctrl]+[enter] for a new line
8) Press [menu] and select More Modules, Turtle o1 pons - g‘:squarew -
Graphics, Move, then the t.left(angle) selection T ewarddistancey | |0 Ut mport % t=Turtie)

9)

Notice the “tool tip” which offers the hint “degrees”

Enter the angle in degrees you want the turtle to turn
left. For a square, we will enter 90 degrees

Jump to the end of the line by pressing [tab].

You are ready to run your first Turtle program!

1 from turtle import * 2 t.backward(distance) | |for sides in range(d):

3 tright(angle) t.forward(20)
3 Draw tleft (T
4 Pen control 5 tgoto(xy) SR
5 Settings 6 t.setheading(angle)
6 Tell Turtle's state 7 t.home()
7 Colors 8 t.clear()
8 Filing 9 treset(

[ *square.py 5/6

from turtle import *; t=TurtleQ

for sides in range(4):
t.forward(75)
tleft@0)




10) To run the program press [menu] then select Run,
Run (CtrlI+R)

Notice the shortcut hint Ctrl+R in the menu selection.
In the future you can simply use the shortcut Ctrl+R to
run your program.

By default, the turtle > is visible and you see it draw.

When you finish admiring your work, press [esc] to
clear the screen. You will be on page 1.2, a Python
Shell. Press [ctrl]+[«] to return to the Editor page 1.1.
From there, modify your program and run it again.

Notice the scale in the bottom-left corner

Challenges:

Change the pen thinckness

Change the pen color

Hide the turtle icon

Change the speed at which the turtle moves
Hide the grid and scale indicator

Fill the square

% 1 Actions »
3
3 Edit 2 Check Syntax & Save (Ctrl+B)
5. 4 Built-i 3 Go to Shell

V% 5 Math »

@ 6 Random »

£ 7 TIPlotLib 4

& 8 TlHub 4

“ 9 Tl Rover 4

& A More Modules »

var B Variables »

.
=B

) Python Shell 353
>>>#Running square.py

>>>from square import *

>>>|




Turtle Module Methods

Every effort has been made to align with syntax and associated
behaviors of the Python API (Application Programming
Interface) for Turtle Graphics found on the Python
documentation website. While there may be slight behaviorial
and syntax differences in implementation, please visit this site
to familiarize with syntax definitions and turtle behaviors.

https://docs.python.org/3.3/library/turtle.html?highlight=turtle

Please see the Default Settings and Known Exceptions section

@ 20 e Trba b — X

€ 5 C M docxoymonceys ity

 Pymon » 3.3 7 Documentation »

Table Of Contents
263 turtle — Tute
aragpics
2411 bducton
2412 Overiow ol

avatatio Tuthe and
Scrvan meohy
25121 Tume

24122 Munoss of
TutsScimmnScren

e

- 24132 Tel Turtex
e

- 28133 Suttgs
for measurement

24134 Pen

9

~ 201341
rawng s

~ 241342
Color contra
21343
o

-

Mt M ERgh G = turte

The Pyinon Standars Library » 24 Program Frameworks » previous.

24.1. turtle — Turtle graphics
24.1.1. Introduction

Tutte graphy 1t was part of o original Logo programiming anguage developod

v
by Wally Feurzg and Seymour Papert in 1966

Imagine & roboti: turle starting at (0, 0)in the x-y plano. Afler an feport turtle. 0o il the command turtle, foruard(15), and it
maves (on-screent) 15 pixels in the direction 4 = facing, drawng a ine 25  moves. Give it the command turtle.right(25), and it

otates in-place 25 degress dockwse

By combinng fogether these and similar commands, intrcate shapes and

Turtie star
pictures can easily bs drawn

Turtie can draw infricate shapes using programs that

The turtle module is an extended raimplementaton of the same-named
¥ yihon 25

repeat simple moves.

It nes to keep the ments of the old turtle module and to ba (nearly) 100%
‘compatible with # This means in the frst place to enable the leaming
Srogrammer 1o usa i the commands, classes and methods misractvely
‘Wwhen s the module from wihn DLE run with the -n swich

The turie module provides turle graphics prmites, in both cbjact cnented
and procedure orented ways Because ¢ Uses tkinter for the underyn
Qraphics, & noads & varsion of Python instalied wih Tk supgort

1.The Turtlescreen class defines graphics windows as & piayground
for the rawing turtles. Its consiructor needs @ tkinter.Canvas OF &

o treset()

for an overview of notes and known exceptions. S R s e

Module menu selections

. from turte import Ao R
P 2 Run » 6/7

e Draw W - .

e Pen Control 2 Move v

. 3 Draw » Complex Math »

¢ Settlngs 4 Pen control » Time 4

e Tell Turtle’s state 5 Settings » Tl System D
6 Tell Turtle’s state » Tl Draw ’

o C.o!ors 7 Colors » TlImage 4

e Filling 8 Filing ’

Move

o tforward(distance) % 1 Actions

. P 2 Run
¢ t.backward(distance) 9 3 Edit
i 1. 4 Built-ins !

° t'”ght(angle) 1 from turtle import * 2 t.backward(distance)

o tleft(angle) 3 trightangle)
3 Draw 4 tleft(angle)

° t.goto(x,y) 4 Pen control 5 tgoto(x,y)

e t.setheading(angle) 5 Settings 6 tsetheading(angle)
6 Tell Turtle’s state 7 t.home(

¢ t'home() 7 Colors 8 t.clear()

o tclear() 8 Filling 9 treset(



https://docs.python.org/3.3/library/turtle.html?highlight=turtle

Draw

t.circle(radius)
t.dot(radius)
t.stamp()
t.write(“text”)

% 1 Actions »

D 2 Run r 6/7
3 Edit Y Urte0

1. 4 Built-ins »

1 from turtle import *

2 Move 4

4 Pen control

2 t.dot(radius)

5 Settings 3 tstamp(
6 Tell Turtle’s state 4 twrite("text”)
7 Colors » Tlimage

8 Filing
Pen control
e t.pencolor(color) ; ; a‘f"s :H
e tpenup() 3 Edit Yurie0
« tpendown Fretores
e t.pensize(1,2,0r3) 2 Move ’
3 Draw

5 Settings 2 tpenupQ
6 Tell Turtle’s state 3 t.pendown()

7 Colors 4 t.pensize(1,2,0r 3)
8 Filling
Settings
. tdegreeso [T R
o tradians() E8 3 Edit » o7
_ w 4 But-ns IR
* t.speed(O 10) 1 from turtle import * 2 toradians(
o t.showturtle() 2 Move 3 tspeed©-10)
. 3 Draw 4 t.showturtle(
o t.hideturtle() 5 thideturtie0
e t.setgrid(10-100) 5 Seftings 6 t.setgrid(10-100)
: 6 Tell Turtle’s state 7 t.hidescaleQ
* thidescale() 7 Colors 8 thidegrid)
o t.hidegrid() 8 Filling 9 wversion()

version()




Tell Turtle’s state

var=t.position()
var=t.heading()
var=t.xcor()
var=t.ycor()

% 1 Actions
P 2 Run
3 Edit
i£. 4 Built-ins
1 from turtle import *

2 Move

_ 3 Draw 2 var=t.heading()
* var—t.to.wards(x,y) 4 Pen control 3 var=t.xcor()
e var=t.distance(x,y) 5 Settings 4 var=tycor()
—t _5 var=ttowards(x,y)
° var t'ISdownO 7 Colors 6 wvar=t.distance(x,y)
8 Filling 7 var=tisdown(
Colors
P 2 Run »
e green Examples: 3 Edit » L
t.pencolor("red" 1. 4 Built-ins
* blue ”Eu L (,,( 3) 1 from turtle import * 2 green
o vyellow icolor( green 2 Move 3 blue
3 Draw 4 vyelow ath »
* Ccyan 4 Pen control 5 cyan 4
e magenta 5 Settings 6 magenta 4
6 Tell Turtle’s state 7 gray 4
° gy 8 black ’
e black 8 Filing 9 white
e white
Filling
e tfillcolor(color) % 1 Actions '
o P 2 Run » 6/7
o t.begin_fill() E8 3 Edit Y urie0
; i£. 4 Built-ins 4
* t.end_flll() 1 from turtle import"ll
2 Move 4
3 Draw » Complex Math »
4 Pen control » Time ’
5 Settings » Tl System ’
6 Tell Turtle’s state

7 Colors 2 t.begin_filly
3 t.end=fillo




Default Settings and Exceptions

When these methods are not specified programatically, the following defaults are applied

Turtle

Default on. Use t.hideturtle() to hide the turtle icon.
When the turtle icon is visible
e Pensizeis fixed at 1 and cannot be changed even if a different pensize() is specified in
the program
e Speed can be adjusted only with arguments 1 through 10
o Use of speed(0) will automatically hide the turtle icon
e The turtle icon may increasingly slow down when executing long or complex programs.
In these instances it is best to apply t.hideturtle().

Grid

Default on. Use t.hidegrid() to hide the grid.

Scale

Default 25 pixels.
Use t.setgrid() to change the scale of the grid. Valid arguments are 10 to 100.
Use t.hidescale() to hide the scale indiicator.

Speed

Defaults setting is t.speed(5)

Use t.speed() to change the speed. Valid arguments are 0 to 10.

While values 1 through 10 range from slow to fast, speed(0) is the fastest (per the Turtle
Graphics API).

Default pen size is 1. To adjust the pen size, use t.pensize() with valid arguments 1, 2, and 3.
Note: Pen size is always 1 when turtle is visible.

Default pen color is black. Use t.pencolor(color) to change pen color. RGB (Red, Green, Blue)
values are valid arguments for pen color with values in the range of 0 through 255. Alternately,
populate the t.pencolor(color) argument with selections from the Color menu.

Default pen down. To move the turtle to a location without drawing a line, use the penup()
method. The pendow() method will subsequently need to be applied to continue drawing.

Fill

Default color is black. Use t.fillcolor(color) to specify other colors. RGB (Red, Green, Blue) values
are valid arguments for fill color with values in the range of 0 through 255. Alternately, populate
the t.fillcolor(color) argument with selections from the Color menu.




Example Programs:

Example 1: My First Star

and filled with a random color.

Green, Blue), with values in the range of 0 to 255.

from turtle import *; t=Turtle()
from random import randint
t.speed(10)
t.penup()
t.goto(-80,14)
t.pendown()
t.pencolor(randint(0,255),randint(0,255),randint(0,255))
t.fillcolor(randint(0,255),randint(0,255),randint(0,255))
t.begin_fill()
while True:

t.forward(160)

t.right(160)

if t.heading() < 1:

break

t.end_fill()

Built-ins, Ops.

Draw a single star. The star is drawn with a random line color

Notice that t.pencolor() can be defined with R,G,B values (Red,

Note: The “break” function is currently not in a menu selection
and needs to be hand-typed. “True” is found under [menu],

Challenges:

e Change the t.right() angle to create stars of
different shapes. What happns when the angle is
small. Large.

e Change the t.forward() distance for smaller and
larger stars.

Example file name: random_stars.tns
Program name: MyFirstStar.py




Example 2: PhiX 177 Super Nova

Build on the prior program by automatically re-generating a new

star every second until you press [esc]

from turtle import *; t=Turtle()
from time import sleep
from random import randint
t.speed(10)
t.hideturtle()
t.pensize(2)
while get_key() !="esc":
t.penup()
t.goto(-80,14)
t.pendown()
t.pencolor(randint(0,255),randint(0,255),randint(0,255))
t.fillcolor(randint(0,255),randint(0,255),randint(0,255))
t.begin_fill()
while True:
t.forward(160)
t.right(160)
if t.heading() < 1:
break
t.end_fill()
sleep(1)

Example file name: random_stars.tns
Program name: PhiX177SuperNova.py




Example 3: Zinnias in the Summer
Build on the prior programs and randomize the position of stars
on the screen.

from turtle import *; t=Turtle()
from time import *
from random import randint, uniform
t.speed(0)
t.hideturtle()
t.pensize(1)
while get_key() !="esc":
t.penup()
t.goto(randint(-200,120), randint(-100,100))
t.pendown()
t.pencolor(randint(0,255),randint(0,255),randint(0,255))
t.fillcolor(randint(0,255),randint(0,255),randint(0,255))
t.begin_fill()
while True:
t.forward(80)
t.left(162)
if t.heading() < 1:
break
t.end_fill()
sleep(uniform(.1,.4))

Finished

Challenges:
e Instead of stars, draw circles, squares or
rectangles

o Randomize the size of the circles
o Randomize the size of the squares
o Randomize the height and width of the
rectangles
e Adjust the pen and fill colors so they are shade
variations of the same color

Example file name: random_stars.tns
Program name: ZinniasinSummer.py




Example 4: Grandma’s Quilt
Builds on the prior programs but lays the stars out in an orderly
“quilt” pattern.

from turtle import *; t=Turtle()
from random import randint
t.speed(10)
t.hidegrid()
t.hideturtle()
t.pensize(1)
for j in range(112,-150,-84):
foriin range(-169,170,86):
t.penup()
t.goto(i, j)
t.pendown()
t.pencolor(randint(0,255),randint(0,255),randint(0,255))
t.fillcolor(randint(0,255),randint(0,255),randint(0,255))
t.begin_fill()
while True:
t.forward(80)
t.left(140)
if t.heading() < 1:
break
t.end_fill()

Challenges:

e Adjust the quilt pattern so that stars overlap
vertically and horizontally.

e Change the number of points on the star.

e Draw circles or squares instead of stars.

Example file name: random_stars.tns
Program name: GrandmasQuilt.py




Example 5: Stained Glass
Build a series of squares inside of squares.

from turtle import *; t=Turtle()
from random import randint
from math import sqrt
from ti_system import *
from time import sleep
t.pensize(2)
t.hideturtle()
t.speed(10)
while get_key() !="esc":
n=200
t.penup()
t.goto(-n/2,-n/2)
t.pendown()
t.setheading(0)
for i in range(10):
t.fillcolor(randint(0,255),randint(0,255),randint(0,255))
t.begin_fill()
for j in range(4):
t.forward(n)
t.1eft(90)
t.end_fill()
t.forward(n/2)
t.left(45)
n=sqrt((n**2)+(n**2))/2
sleep(.5)

Finished

Challenges:

e Decrease or increase the number of squares
drawn.

e Change the orientation angle of squares that are
draw.

o Create a “tile floor” with smaller tiles that look
like the original.

Example file name: squareloop.tns
Program name: StainedGlass.py




Example 6: Centroid
Build a triangle, midpoints, median
segments and centroid.

from turtle import *; t=Turtle()

# calculate the midpoint of line
segment
def midpoint(pt1,pt2):

return ((pt1[0] + pt2[0])/2, (pt1[1] +
pt2[1])/2)

# plot point

def plot_point(pt):
t.penup()
t.goto(pt)
t.pendown()
t.dot(3)

# the triangle verticies
vl = (25,75)

v2 = (-125,-75)

v3 = (100,-50)

# calculate the centroid centroid
=((v1[0]+v2[0]+Vv3[0])/3,(v1[1]+Vv2[1]+Vv3
[1])/3)

# calculate the midpoints

mid_1_2 = midpoint(v1,v2)
mid_2_3 = midpoint(v2,v3)
mid_1_3 = midpoint(v1,v3)

# draw the triangle in black
t.penup()

t.goto(v1)

t.pendown()

t.goto(v2)

t.goto(v3)

t.goto(v1)

# draw the three median segments in
green
t.pencolor("green”)

t.penup()
t.goto(mid_1_2)
t.pendown()
t.goto(v3)

t.penup()
t.goto(mid_2_3)
t.pendown()
t.goto(v1)

t.penup()
t.goto(mid_1_3)
t.pendown()
t.goto(v2)

# draw the centroid in red
t.pencolor("red")
plot_point(centroid)

# draw the midpoints in blue
t.pencolor("blue")
plot_point(mid_1_2)
plot_point(mid_2_3)
plot_point(mid_1_3)

Finished

7
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Challenges:

e Change the coordinates of one or
more vertex and observe the
result.

Example file name: Centroid.tns
Program name: tri_centroid.py




Example 7: RhombuStarl

This deploys a familiar loop strtategy but draws a rhombus that
is rotated around the origin. It continues to regenerate every
second until you press [esc].

From turtle import *; t=Turtle()
from time import sleep
from random import randint
t.speed(10)
t.hideturtle()
t.pensize(2)
while get_key() != “esc”:
t.pencolor(randint(0,255),randint(0,255),randint(0,255))
t.fillcolor(randint(0,255),randint(0,255),randint(0,255))
t.begin_fill()
for I in range(10):
for j in range (2):
t.forward(50)
t.right(60)
t.forward(50)
t.right(120)
t.right(36)
t.end_fill()
sleep(1)

Challenges:

e Rotate a square instead of a rhombus.

e Rotate a circle instead of a rhombus.

e Change the number of rhombus, squares or
circles that are rotated around the origin.

Example file name: geo_stars.tns
Program name: RhombuStarl.py




Example 8: Threadbare
Deploy a familiar loop strtategy and draw a random array of
rectangles. It continues until you press [esc].

from turtle import *; t=Turtle()
from ti_system import *
from random import randint
t.hidegrid()
t.speed(10)
t.hideturtle()
t.pensize(1)
while get_key() !="esc":
t.penup()
t.goto(randint(-200,150), randint(-120,100))
t.pendown()
t.pencolor(randint(0,255), randint(0,255), randint(0,255))
b=randint(5,60)
h=randint(5,60)
for i in range(2):
t.forward(b)
t.1eft(90)
t.forward(h)
t.1eft(90)

Challenges:
e Fill the rectangles.
e Make squares instead of rectangles.

Example file name: random_rectangles.tns
Program name: Threadbarel.py
Program name: Threadbare3.py




Example 9: Buffon's Needle
Simulate Buffon’s needle experiment.

from ti_system import *
from random import *

# use shell before entering turtle
environment

clear_history()
length=int(input("Length of needle or
[enter] for 50 ?") or '50")
spacing=int(input("Spacing among
lines or [enter] for 50 ?") or '50")
needles=int(input("How many needles
or [enter] for 1000 ?") or '1000")
the_pies=[]

the_count=[]

# set up turtle environment

from turtle import *; t=Turtle()
t.hidegrid()

t.speed(0)

w,h=get_screen_dim()

the_lines=[] # list of all x-coordinate of
all lines
n_lines=int((w/spacing)/2)+2 # number
of lines
crossing = 0 # needles crossing a line
estimate = 0 # calculated estimate of
pi
# draw all of the lines and append
the_lines
for x in range(-
n_lines*spacing,(n_lines+1)*spacing,s
pacing):

the_lines.append(x)

t.penup()

t.goto(x,-h/2)

t.pendown()

t.goto(x,h/2)

# draw the needles
for i in range(needles):
x1=randint(0,w)-w//2
yl=randint(0,h)-h//2
angle=random()*360
t.penup()
t.goto(x1,y1)
t.setheading(angle)
t.forward(length)
x2=t.xcor()
y2=t.ycor()
t.pencolor("red")
# check if needle touches or crosses a
line
for n in range(len(the_lines)):
if((x1<=the_lines[n] and
x2>=the_lines[n]) or (x2<=the_lines[n]
and x1>=the_lines[n))):
t.pencolor("green")
crossing+=1
t.pendown()
t.goto(x1,y1)
# Buffon's formula
try:
estimate =(
2*length*i)/(crossing*spacing)
except:
# all fun and games until somone
divides by zero
pass
the_pies.append(estimate)
the_count.append(i)
store_list("n",the_count)
store_list("pie",the_pies)
error=(pi-estimate)*100/pi
print("Estimate of Pi =",
estimate,"\nError = ",error,"%")
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>>>[ ength of needle or [enter] for 50 ?
Spacing among lines or [enter] for 50 ?
How many needles or [enter] for 1000 ?
Estimate of Pi = 3.161392405063291
Error = -0.6302456637996489 %

>>>

.84y

100 20 1000

Challenges:

e Run the simulation specifying
different needle lengths and
spacing between lines.

Example file: buffon's needle.tns
Program name: buffon.py




