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Getting Started
Features
•

Key Press History — Review recently pressed keys from the key
press history pane or on the large screen pane.

•

Adjustable Screen Size — Use the small, medium, and large
screen sizes or customize the screen size.

Overview of TI-SmartView™ Emulator for the TI-73
Explorer™ graphing calculator
The TI-SmartView™ Emulator for the TI-73 Explorer™ software gives you
a TI-73 Explorer™ calculator on your computer. The functionality of the
TI-73 Explorer™ calculator is at your disposal, including the ability to load
and use calculator files such as applications (Apps), lists, programs, and so
on.
TI-SmartView™ lets you show the TI-73 Explorer™ calculator to an
audience without using calculator-specific projection equipment and
gives you additional functionality that aids in presentations and
demonstrations.
•

Supplement the current TI-73 Explorer™ screen by using the View3™
pane to show three extra screens simultaneously. You can select any
three of the following calculator screens: Y= editor, table, graph, stat
plot, list, and window.

•

Repeat demonstrations quickly and easily by using scripts to play
back a series of keystrokes.

•

View the history of your calculator entries as well as a large version
of the current calculator screen, and open scripts by displaying the
key press history window.

•

Capture screen images that you can save and use in other
documents.
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System requirements
The computer that you use to run the TI-SmartView™ Emulator for the
TI-73 Explorer™ software must meet the following hardware and
software requirements.
Windows®:
•

Windows Vista® (Home Premium/Ultimate/Business), Windows® XP
(Home or Professional edition) with Service Pack 2; or Windows®
2000 Professional edition with Service Pack 4.

•

900 MHz Pentium-compatible CPU

•

512 MB RAM

•

125 MB of available hard-disk space

•

CD-ROM drive or active Internet connection for installation

•

Internet Explorer 6.0 or later;
Netscape® 5.0 or later;
Opera 7.0 or later;
or Mozilla™ Firefox 1.0

Macintosh®:
•
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Mac® OS X 10.4 or 10.5
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•

G3 CPU or later (900 MHz)

•

512 MB RAM

•

40 MB of available hard-disk space

•

CD-ROM drive or internet connection for installation

•

Supported Internet browser:
–

Safari™ 2.0 or later;
Mozilla™ Firefox 1.0 or later;
AOL® Browser 1.0;
Microsoft Internet Explorer 6.0 or later;
or Netscape® 5.0 or later

Installing TI-SmartView™ Emulator for the TI-73
Explorer™ graphing calculator
If you are installing a full version of the TI-SmartView™ software (as
opposed to a trial version), find the CD key located on the CD case or CD.
You need to enter the CD key during a full-version installation.

Before you begin
To install the software on your computer, you must have the appropriate
privileges. You will need Administrator privileges on Windows. During
installation, you may need to specify your Macintosh password.
If you do not have the necessary privileges, contact your network
administrator.

Installing the software
1.

Close any applications that are open.

2.

Insert the TI-SmartView™ CD into the CD-ROM drive.
The CD should launch automatically. If the CD does not launch,
double-click the appropriate launch file on the CD.
Macintosh®: A message informs you that the installation package
will determine whether the software can be installed on the
computer. Click Continue to go to the next screen.

3.

Click Next at the bottom of the Welcome screen, and click Next
again on the Features screen.
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The Destination screen displays.

4.
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Click Next on the Destination screen to accept the default
installation location, or click Browse to navigate to a different
folder for application installation. Click Next to start the installation.
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Macintosh®: If prompted, enter your password on the
Authentication screen. A progress bar displays during installation. A
message informs you that a restart is required after installation;
press Continue to complete installation.
5.

Windows®: Click Finish on the screen that confirms successful
installation. Double-click the TI-SmartView™ icon to start the
application and activate the software.
Macintosh®: Click Restart and then start the TI-SmartView™
software to activate it.
If you have already purchased the software, you should activate it.
Activating the software allows to you continue using it past the 30day evaluation period. It prevents unauthorized copying of the
product onto more computers than the license agreement allows.

Activating the software
1.

To begin the activation process, start TI-SmartView™ software by
double-clicking the icon. On the Activate Software screen, click
Activate this software, and then click Next.

2.

Review the options displayed to determine which activation method
you should use. Regardless of which activation method you prefer,
you will need to supply the Serial Number and License Number
included with the installation CD.

Getting Started
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•

Internet— This method uses your Internet connection to
activate your software. You provide the Serial Number and
License Number.

•

Web Portal— This alternative method takes you to a Web page
where you can retrieve an Activation ID. The ID is displayed on
the Web page. If you provide your e-mail address, the ID is also
sent to you by e-mail.

•

Phone— You provide a TI representative with the Serial
Number and License Number as well as an Installation ID
displayed on your screen. The representative then provides an
Activation ID.

•

3.

I already have an Activation ID — After accepting a license
agreement, you fill out a screen with the Serial Number, License
Number, and the Activation ID.

Click an activation method, then click Next and follow the
instructions to type the Serial Number, License Number, and
Activation ID.

Note: When entering the License Number, be careful to not enter a
zero for the letter O or a letter O for a zero. Similarly, do not confuse
the number one with a lowercase letter L.
4.
5.

Type contact information and click Next.
Provide information to create a user profile (optional), and then click

Next to complete software activation.
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Opening the software on your computer
f Double-click the TI-SmartView™ icon. The application starts.

Things you need to know
The mouse pointer takes the place of your finger pressing keys
on the calculator.
When you use the mouse, remember that the pointer takes the place of
your finger. You must click the keys on the on-screen calculator like you
would press the keys on the TI-73 Explorer™ calculator. The
TI-SmartView™ Emulator calculator screen is not interactive. For
example, when you change mode settings, you might be tempted to click
the mode setting on the calculator screen to select it. However, clicking
on the screen does nothing. You must click the arrow keys to move the
cursor to the desired setting and then click b to select it.

Hold down an arrow key to scroll the cursor continuously.
When you use an arrow key to move the cursor, you can hold down the
key to scroll the cursor continuously, instead of having to press the key
repeatedly. In the key press history and in a script, the icon for a
repeating arrow key has a clock symbol attached to it. For example:
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When you record a script, you record only calculator key
presses. These key presses can be difficult to interpret, viewed
by themselves.
Because you record key presses, editing a script can be a little tricky. For
example, if you change the mode to radian, the script records . # #
" b. The script doesn’t overtly tell you that you changed the mode
to radian. For this reason, it can be quite helpful to step through a script
one key press at a time, or to play the script back at a slower speed so
that you can see exactly where an edit needs to be made.

Choosing a display option
By default, the TI-SmartView™ Emulator software displays the calculator
and two optional panes of additional information. You can show or hide
these optional panes, or change the type of information displayed in
each one.

The View3™ pane initially shows the Y= editor, table, and graph screens.
However, you can select which calculator screen you want to show for
each of the three displays. (The stat plot, list, and window screens are
also available.) The screens are updated each time you press one of the
graphing keys (', (, ), *), change the Window or
Zoom settings, or press b.
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The third pane includes tabs that you can click to see either the key press
history, a large screen display of what the device image is displaying, or
any open scripts. When you display the large screen in the third pane,
you can hide or show the key press history information at the bottom of
the pane.
Display Option

Click:

View3™ pane
View > Show/Hide View3 or
the pane.

to show or hide

View > View3 Options to select a calculator screen
for each display.
Key press history,
large screen, and
script pane

View > Show/Hide Key Press History or
show or hide the pane.

to

Scripts
File > Open or
File > New Script or
script.

to open an existing script.
to open a new, blank

The close button on the script’s tab
close a script.

to

Notes:
•

Hiding the key press history does not clear it.

•

Hiding the key press history does not delete or close open scripts.

•

You can record a script without displaying the key press history.

Changing the size of the TI-SmartView™ emulator
When you first use the TI-SmartView™ Emulator software, a full-screen
image for 1024 x 768 screen resolution is displayed. You can use
whichever size you want, but the small, medium, and large versions are
optimized for the following screen resolutions.
If your screen resolution is:

Click:

800 x 600

View > Size > Small Emulator

1024 x 768

View > Size > Medium Emulator

1280 x 1024

View > Size > Large Emulator

Getting Started
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Changing the face plate
You can change the face plate on the TI-SmartView™ emulator.

f Click View > Color and then click an option.

Saving and loading an emulator state
When you save the emulator state, a file is created that stores the
calculator with all of the changes that you have made to its setup. Think
of the emulator state file as representing a single TI-73 Explorer™
calculator that you have used and then set aside. When you load an
emulator state, you pick up that same TI-73 Explorer™ calculator to use
again. All of the changes that you made to the calculator are intact.
For example, you might want to set up a class demonstration by entering
functions in the Y= editor and changing Window and Zoom settings.
When you save your changes in an emulator state file, you simply load
the file to show your demonstration. If you want to create different
demonstrations for different classes, you can create multiple emulator
state files. There is no limit on the number of emulator states that you
can save.

Note: The key press history, screen capture images, open scripts, and the
face plate color are not saved in the emulator state file.

Saving the emulator state
1.

Click File > Save Emulator State.

2.

In the dialog box:
a)

Navigate to the folder in which you want to store the
emulator state file.

b)

Type a file name. Use a name that describes the emulator
state.

c)

Click Save.

Loading an emulator state
1.

Click File > Load File.

2.

In the dialog box:
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a)

Navigate to the folder that contains the emulator state file.

b)

Click the emulator state name to highlight it.

c)

Click Open.
Getting Started

Resetting the emulator state
Resetting the emulator state returns the TI-SmartView™ Emulator
software to the TI-73 Explorer™ factory-default settings. The optional
View3™ pane (center) and the right pane are shown. The key press
history is cleared. Any open scripts are stopped, but remain open.
1.

Click Tools > Restore Default State.

2.

In the dialog box, click Yes to confirm that you want to reset the
emulator state.

Saving calculator data to the computer
By saving data (lists, programs, and so forth) from the TI-SmartView™
calculator to files on the computer, you can make backup copies of that
data. If you delete the data from the TI-SmartView™ Emulator, you can
load the calculator files from the computer at any time.
1.

Click File > Save Calculator File.
The Device Contents dialog box lists the data items on the
TI-SmartView™ calculator, which may take several seconds.

2.

Click an item to highlight it.
•

To select multiple items, click an item and then press and hold

Ctrl on a PC keyboard or Cmd on a Macintosh keyboard as you
click each additional item.
•

To select a range of items, click the first item in the range. Then
hold down Shift and click the last item in the range.

3.

Click Save Selected Item(s).

4.

In the dialog box, navigate to the folder in which you want to store
the files.

5.

•

Be sure to either open the folder or click the folder to highlight
it. The folder name must be shown in the File name box at the
bottom of the dialog box.

•

If necessary, click

New Folder to create a new folder.

Click Save.
Each selected item is saved as a separate file on the computer. File
names are assigned automatically. The file name’s extension
identifies the data type.
If the folder already contains a file with the assigned name, you are
prompted whether to overwrite the existing file.

Getting Started
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The Device Contents dialog box stays open so you can select and save
additional data items.
6.

When you’re finished, click Close.

Note: In the Device Contents dialog box, you can sort the list by clicking
a heading. For example, click Name to sort by name and switch between
ascending (a-z) and descending (z-a) order.

Loading a calculator file from the computer
If you previously stored calculator files containing lists, programs,
applications, etc., on your computer, you can load them into the
TI-SmartView™ software.
1.

Click File > Load File.

2.

In the dialog box:
a)

Navigate to the folder that contains the file you want to
load.

b)

Click the file name to highlight it.

c)

Click Open.

If TI-SmartView™ Emulator already contains a data item with that
name, you’re prompted whether to overwrite the existing item.

Calculator file names on the computer
Calculator file names have the form:

filename.73?
where filename is as close as possible to the data item’s name on the
calculator, 73 indicates the file was created by the TI-SmartView™
Emulator or a TI-73 Explorer™ graphing calculator, and ? is a letter that
identifies the type of data. Common data types are:
If ? is:

Type of data

c

constant
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If ? is:

Type of data

y

function

i

picture

k

Flash application

l

list (real or categorical)

n

number (real or fraction)

p

program

t

table setup

v

application variable

w

window range

Note: If you load a Flash application file, TI-SmartView™ Emulator
automatically installs the application.

Updating the software from the Internet
Visit education.ti.com for free software updates that are periodically
available for downloading.

Getting Started
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Working with images
Capturing calculator screens
You can capture the current calculator screen image using the
TI-SmartView™ Emulator screen capture tool. When you capture a
screen, the Screen Capture window is displayed. In this window, you can
view, manipulate, and save screen images.

f Click Tools > Take Screenshot or click

.

With a border, the image size is 100 pixels wide by 68 pixels high.
Without a border, the image size is 96 pixels wide by 64 pixels high. A
border is automatically added to each image when you capture it, but
you can remove it.
The number of screen images you can capture is limited only by the
available memory on your computer. Each unsaved screen image is stored
in memory until you close the main TI-SmartView™ window. Closing the
Screen Capture window does not discard unsaved screen images.

Adding or removing a border
The toolbar button for adding or removing a border toggles between
add
and remove
image contains a border.

depending on whether or not the selected

Adding or removing a border on a single screen image
1.

Click the screen capture image to select it.

2.

Click Edit > Remove Border or click

to remove the border.

—or—
Click Edit > Add Border or click

to add a border.

Adding or removing a border from a group of screen
images
1.

Switch to thumbnail view.

2.

Select the group of images. You can either:

Working with images
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3.

•

Click the first image you want to select, and then as you click
each additional image, hold down Ctrl on a Windows®
keyboard or Cmd on a Macintosh® keyboard .

•

Select a range of images by clicking the first image in the range,
holding down Shift, and clicking the last image in the range.

Click Edit > Remove Border or click

to remove the border

—or—
Click Edit > Add Border or click

to add a border.

Note: To select all of the images, click Edit > Select All.

Saving a screen image
You can save screen images in TIF, GIF, or JPEG formats. The images are
saved in your My Documents folder unless you specify a different
location to save them. All images are saved at the size they are currently
displayed.
1.

Click the screen image you want to save.

2.

Click File > Save Screen or click

3.

In the dialog box:

.

a)

Navigate to the folder in which you want to store the screen
image file.

b)

Select the file type for the appropriate image format.

c)

Type a file name. Use a name that describes the screen
image.

d)

Click Save.

Note:
•

If you have previously saved the selected screen image, clicking File >

Save Screen or

overwrites the previous file. To save the file in a
different location, with a different name, or as a different file format,
you must click File > Save Screen As.
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•

To save all the images at once, click File > Save All Screens. When
you do this, you select the location to save the files in the Save All
window, but do not specify file names. Each screen image is saved
with its default file name. If that name already exists, you’re
prompted whether to overwrite the existing file.

Viewing screen images
When you capture a screen image, that image opens in the Screen
Capture window. You can view the images individually or as a group of
images, called thumbnails. A reference name is displayed under each
image.

Working with images
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f To view screen image thumbnails, click View > Thumbnails or
click

.

f To view individual screen images, click View > Single Screen
or click

.

Navigating among screen images
f To view the previous screen image, click View > Previous
Screen or click

.

f To view the next screen image, click View > Next Screen or
click

.

Zooming in or zooming out
You can zoom in or out on any single image to view a larger or smaller
version of it.
You can save a larger or smaller version of a screen image by zooming in
or out before you save it. For example, to save an image that is larger
than the standard 96 x 64 size, zoom in until the image is the size you
want and then save it.

f To display a larger screen image, click View > Zoom In or click
.
f To display a smaller screen image, click View > Zoom Out or
click

.

Dragging and dropping an image to another
application
You can drag and drop any TI-SmartView™ screen image to paste it into
another application. These images include the following:
•

Saved or unsaved screen capture images

•

View3™ pane screens

•

The Large Screen image
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Note: In the Screen Capture window, the selected image has a red
border. However, the borders on the Large Screen image and the View3™
screens do not change color when you select them.
To drag and drop a screen image into another application:
1.

Adjust the sizes of the windows of the two applications so that both
of them fit on the computer screen.

2.

To drag-and-drop the image:
a)

Click the screen image to select it.

b)

Drag the screen image from the TI-SmartView™ Emulator
and then drop it into the other application.

Working with images
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Using the key press history
What is the key press history?
Each key you click on the emulator is recorded automatically in the key
press history. You can see the key press history from the key press history
pane and the large screen pane. Using the key press history to see a
listing of all the keys you’ve used has several benefits, including:
•

If a calculation gives unexpected results, you can view the key press
history to see if you entered the correct data.

•

If you perform a calculation and then find you need to perform it
repeatedly, you can copy those keys from the key press history and
paste them into a script. When you need to repeat the calculation,
you can play the script instead of re-entering all the key presses.

The key press history shows some key sequences in a different form than
they’re shown in the user guide for the TI-73 Explorer™ calculator. For
example, suppose you display the calculator’s MEMORY menu.
•

•

The user guide shows the key sequence as -[MEM], where [MEM]
is the 2nd function of the _ key.
The key press history shows the key sequence as
because those are the actual keys you click.

Similarly, suppose you select the round( function from the MATH NUM
menu.
•

The user’s guide shows the function as round(.

•

The key press history shows
the keys you click.

because those are

Showing or hiding the key press history
f Click View > Show/Hide Key Press History or click

.

When the TI-SmartView™ right pane is showing, you may need to
click the Key Press History tab to activate it. The right pane also
shows tabs for Large Screen and any open scripts. The active tab has
a colored line across its top.
You can also view and clear the key press history from the large
screen pane. Click Show Key Press History or Hide Key Press
History to show or hide the list of keys pressed.
Using the key press history
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Key Press History off

Key Press History displayed

When the key press history is shown on the large screen pane, you
can click Clear Key Press History to clear the list of keys pressed.
Hiding the right pane does not clear the contents of the key press
history or any open scripts.
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Clearing the key press history
f Click Edit > Clear Key Press History, or click Clear Key Press
History on the key press history or large screen pane.
Clearing the key press history does not affect the contents of any open
scripts in the TI-SmartView™ right pane.

Copying the key press history to another
application
You can copy all or only a selected portion of the key press history to
another application such as a word processor. The procedure is the same
as used to copy scripts.

Using the key press history
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Using scripts
What is a script?
A script is a series of calculator key presses that can be stored and played
repeatedly. By saving the script, you can open it at a later time and play it
again without having to re-enter all the key presses.

Overview of using a script
Create,
record,
and save
the script

Play
the
script

You can also:
•

Insert text points.

•

Insert pauses and delays.

•

Insert a Go To Home
command.

You can:
•

Play the script normally.

•

Step-through one key at a
time.

•

Manually pause the script.

Close
the script

Suppose, after performing one or more calculations, you decide to create
a script that performs those same calculations. Instead of repeating the
key presses while recording a new script, you can:
•

Copy keys from the key press history and paste them into the script.

•

Edit the script as necessary so the keys work properly in the context
of that script.

Showing or hiding the script pane
Any open scripts are shown in the TI-SmartView™ Emulator right pane,
which is also used to show the key press history. To toggle the right pane
on and off:

Using scripts
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f Click View > Show/Hide Key Press History or click

.

The right pane shows tabs for the Key Press History, Large Screen, and
any open scripts. The active tab has a colored line across its top. Click the
appropriate tab to show its contents.
Hiding the right pane does not clear the contents of any open scripts or
the key press history.

Recording a new script
You can begin recording a new script at any time.
1.

Click File > New Script or click

.

The TI-SmartView™ right pane opens automatically if it’s not already
open, and a new blank script appears in the pane. The new script has
a tab at the top of the pane, with a colored line across its top to
indicate it’s active. The tab shows the script’s default name, which is
Script 1, Script 2, etc.
2.

Click Scripts > Record or click

3.

Click the keys on the emulator to record the key presses for your
script.

4.

When you’re finished, click Scripts > Stop or click

on the script’s toolbar.

.

Note:
•

You can also insert Go To Home commands, text points, delays, and
pauses in a script.

•

You can help ensure that your script plays properly under various
conditions by following a few simple guidelines. (See “Tips for
recording a script” on page 27.)

•

You can reuse key sequences that you previously entered. Copy the
keys from the key press history and paste them into the script. The
procedure is the same as used to copy scripts. (See “Copying a script
to another application” on page 37.)
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Tips for recording a script
If you record a script assuming that the emulator will always have the
current settings, you may have problems later if you play the script with
different calculator settings. Therefore, it’s a good practice to add the
necessary settings directly into the script. The following tips can help you
create scripts that play correctly in a variety of situations.
At the beginning of a script:
•

•

Insert a Go To Home command to ensure the script starts on the
home screen. This lets your script begin at a known starting point,
regardless of the screen shown when you play the script.
Press - Ÿ 7 2 2 to reset the memory to its defaults.

When graphing:
•

Press : before entering an equation into the Y= editor.

•

Insert a Pause command after graphing a function.

When using variables, lists, and statistical data:
•

Clear a variable before storing to it.

•

Press - Ÿ 6 b to clear all lists before storing to them.

When selecting an item from a menu:
•

Press the number or letter for that item. Suppose you need Solver...
from the MATH menu. The script runs faster if you use 1 6 (two
key presses) instead of 1 # # # # # b (seven key
presses).

When starting an application from within a script:
•

•

If you share the script with other people using TI-SmartView™
software on different computers, remember that their
APPLICATIONS menus may not list the same applications in the same
order. Pressing 9 4 to start an application on your
TI-SmartView™ Emulator screen may not start the same application
on theirs.
Instead, have your script press 9 to display the APPLICATIONS
menu and then use a text point telling the user to select the
appropriate application from the list.

At the end of a script:
•

Insert a Pause command. This is particularly useful if a script displays
text points that you want the user to see after the script finishes.
Otherwise, text points are closed automatically at the end of a script.

Using scripts
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Note: When resetting the memory, clear only the applicable portion of
the memory. Using - Ÿ 7 1 2 to reset all RAM is not required in
most situations.

Playing a script
After recording a new script or opening an existing one, you can play it.
You cannot play a script while you’re recording it.
1.

Select the tab for the appropriate script. The active tab has a colored
line across its top.

2.

Click Scripts > Play or click

.

Adjusting the script speed
You can vary the speed at which each key press in a script is executed,
from Slow (approximately one key press every 5 seconds) to Fast
(approximately one every 1/2 second).
1.

Click Scripts > Adjust Script Speed.

2.

In the submenu, click a speed in the displayed range.

Note:
•

You can also use the slider in the script’s toolbar. Drag the slider to the
appropriate position.

•

The speed setting affects every key press in the script, which may not
be what you want. Suppose the script enters numbers such as
425,237,234. Setting the speed to one key press every 2 seconds takes
18 seconds to enter the number. Instead, you may want to use a faster
speed and insert pauses or delays at certain points in the script.

Saving a script
After recording a new script or editing an existing one, save the script so
you can use it again later.
1.

Select the tab for the appropriate script. The active tab has a colored
line across its top.

2.

Click File > Save Script or click
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For an existing script that was saved previously, the new version
automatically overwrites the existing one. For a new script, the Save
As dialog box opens.
3.

If you see the dialog box:
a)

Navigate to the folder in which you want to store the script
file.

b)

Type a file name. Use a name that indicates the purpose of
the script.

c)

Click Save.

Note: If you do not want to save the changes you made to an existing
script, close the script instead of saving it. Click the X in the script tab to
close the script. When prompted whether to save the changes, click No.

Saving a copy of a script
Sometimes you may need a script that is similar to an existing one but
with some changes. Instead of recording a new script, it may be easier to
copy the existing script and edit it.
1.

Open the script you want to copy, and select its tab. The active tab
has a colored line across its top.

2.

Click File > Save Script As.

Note: Do not click
3.

.

In the dialog box:
a)

Navigate to the folder in which you want to store the copy.

b)

Type a file name. Use a name that indicates the purpose of
the script.

c)

Click Save.

Note: If you change a script and want to keep those changes in the
before selecting Save
existing script, click File > Save Script or
Script As. Otherwise, the changes are saved in the copy but not in the
original script.

Opening an existing script
After a script is recorded and saved, you can open it later and play the
script again, edit it, or save a copy of it.
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1.

Click File > Open Script or click

2.

In the dialog box:

.

a)

Navigate to the folder that contains the script file.

b)

Click the script name to highlight it.

c)

Click Open.

The script opens in the TI-SmartView™ right pane. A tab with that script
name appears at the top of the pane along with tabs for Key Press
History, Large Screen, and any other open scripts. You can click any of
those tabs to jump from one to the other. The active tab has a colored
line across its top.

Note:
•

The most recently used scripts are listed at the bottom of the File
menu. Click a script name to open it.

•

When several scripts are open at the same time, there may be too
many tabs to fit across the right pane. If so, left and right arrows
appear on the right of the tab area. Click these arrows to scroll left
and right along the available tabs. You may also want to close scripts
when you’re not using them.

Closing a script
When you’re finished using a script, you may want to close it. This
removes the script tab from the right pane. If the script is not saved, you
are prompted whether to save it.

f Click File > Close Script or click the X on the script tab.
Click to close the script.

Stepping through a script
You can step through a script one key press at a time. This is the same
effect as if you had used pause commands to halt the script between
every key press. Depending on the length of the script, you may want to
step through all or only parts of it.

Stepping through a script from the beginning
In the script pane, instead of playing the script:
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1.

Click Scripts > Step Through or click

Note: Do not click Scripts > Play or

to start the script.
.

The script pauses automatically after every key press.
2.

Click

repeatedly to step through each key press.

3.

After stepping through a series of key presses, you can click
play the remaining key presses continuously.

to

Stepping through part of a script
In the script pane:
1.

Click Scripts > Play or click

2.

Click Scripts > Pause or click
to pause at a location before
you want to start stepping through.

3.

Click Scripts > Step Through or click
through each key press.

4.

After stepping through a series of key presses, you can click
play the remaining key presses continuously.

.

repeatedly to step

to

You can repeat steps 2 - 4 as often as necessary to step through different
parts of the script.

Stopping a script while stepping through it
While you are stepping through a script, Scripts > Stop or
not be available. If not, you can:
1.

Click

2.

Then click
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to play the script.
.
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Stopping a script
When you finish recording a script, you need to stop recording. When
you play a script, you may want to stop the script manually at some time
before it would normally end.

f Click Scripts > Stop or click

.

Unlike when you pause a script, you cannot continue playing the script
from the location where it stopped. You can only replay the script from
the beginning.

Pausing a script
At various times while a script is running, you may want to halt it
temporarily. For example, you may want to view an intermediate result
or graph before continuing with another operation that changes the
calculator screen or graph. You can either pause the script manually or
insert a pause command directly into the script.

Pausing the script manually
In the script pane, while the script is playing:

f Click Scripts > Pause or click

.

The Play
button changes to Pause
when you play the script.
After you pause the script, the button changes back to Play. Click Play
again when you’re ready to continue the script.

Inserting a pause command in the script
In the script pane:
1.

Click the location where you want to insert the pause.
The cursor appears at that position.

2.

Click Scripts > Insert Pause or click
script pane.

at the bottom of the

appears in the script to mark the location of the pause. When you
play the script, it always halts at this pause command.
To continue, click Scripts > Play or click
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Deleting an existing pause command
Delete the
in the script.

icon the same way you would delete any other key press

Inserting a delay into a script
In some cases, you may want to delay the script a specified period of time
before it continues to the next key press. For example, you may want to
display a result or graph for a few extra seconds before the script
executes the next key press.

Inserting a delay
In the script pane:
1.

Click the location where you want to insert the delay.
The cursor appears at that position.

2.

Click Scripts > Insert Delay or click
script pane.

at the bottom of the

appears in the script to mark the delay.
A delay has the same effect as a blank key press. It lasts as long as a single
key press (as determined by the script’s speed setting) and has no other
effect on the script.
For a longer delay, insert more than one. For example, suppose the script
speed is set for one key press every second. To delay five seconds, insert
five delays.

Note: If you don’t know how long to delay the script, consider inserting
a pause instead. After the script pauses, it does not start again until you
click Scripts > Play or click

to continue.

Deleting an existing delay
Delete the
icon the same way you would delete any other key
press in the script.
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Inserting a text point into a script
If you use a script to show a presentation, you may want to display a text
screen at certain locations to explain a result or describe what the script
will be doing next.

Inserting a new text point
In the script pane:
1.

Click the location where you want to insert the text point.
The cursor appears at that position.

2.

Click Scripts > Insert Text or click
pane.

3.

In the dialog box:

at the bottom of the script

a)

Type the text using on the computer keyboard.

b)

Click Enter.

appears in the script to mark the text point.

Note:
•

When you run the script, the text is displayed in a separate text pane
that opens below the script. That text pane closes automatically when
the script stops. To leave the text pane open for a longer time, insert a
pause or delay immediately after the text point or at an appropriate
location before the end of the script.

•

The text from all text points in the script is placed one after another
in the text pane. As necessary, you may need to scroll to see all the
text.

•

You can change the size of the displayed text by dragging the slider
located in the area between the script pane and the text pane.

Editing an existing text point
In the script pane:
1.

Double-click the

marker.

The Text Point Dialog box opens.
2.

Edit the text as necessary.

3.

Click Enter.
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Deleting an existing text point
Delete the
marker the same way you would delete any other key
press in the script.

Inserting a Go to Home command
A script executes each key press in sequence. However, these key presses
may have different effects depending on the screen (Home, Graph, Table,
etc.) shown when you play the script. By using a Go To Home command
at the beginning of a script, you can ensure that it begins on the Home
screen.

Inserting a new Go To Home
In the script pane:
1.

Place the cursor at the beginning of the script.

2.

Click Scripts > Insert Go To Home Screen or click
bottom of the script pane.

at the

appears in the script to mark the location of the command.

Note: You can insert a Go To Home command at any location in your
script. While you’re recording key presses inside a script, however, it’s
usually better to record the actual key presses used to display the Home
screen.

Deleting an existing Go To Home command
Delete the
in the script.

icon the same way you would delete any other key press

Editing a script
Editing a script is similar to editing a text document. For example, you
can drag the mouse to highlight a series of keys the same as you would
drag to highlight text in a word processor. (You can also hold down Shift
and use the arrow keys on your computer keyboard.)

Inserting key presses or script elements (pauses, delays,
etc.)
With the script shown in the right pane:
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1.

Click Scripts > Record or click

2.

Click the location where you want to insert the keys or script
elements.

.

Note: Be sure to position the cursor after you start recording. If you
position the cursor first, it automatically jumps to the beginning of
the script when you start recording.
3.

You can:
•

Click the keys you want to insert.
– or –

•

4.

Use the buttons at the bottom of the script pane to insert a text
point, delay, pause, or Go To Home command.

When you’re finished, click Scripts > Stop or click

.

Deleting key presses or script elements
With the script shown in the right pane, either:
•

Place the cursor immediately to the left of the items you want to
delete. Then press Delete on your computer keyboard.
– or –

•

Place the cursor immediately to the right of the items you want to
delete. Then press Backspace on your computer keyboard.
– or –

•

To delete multiple items at one time, highlight the items. Then click

Edit > Cut or click

on the script’s toolbar.

Moving items to a different location
With the script shown in the right pane:
1.

Highlight the items you want to move.

2.

Click Edit > Cut or click

3.

Click the location where you want to insert the items.

4.

Click Edit > Paste or click
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Note: You can also use the mouse to drag the highlighted items to the
new location.

Copying items to a different location
With the script shown in the right pane:
1.

Highlight the items you want to copy.

2.

Click Edit > Copy or click

3.

Click the location where you want to insert the copy.

4.

Click Edit > Paste or click

.

.

Note: You can also hold down Ctrl on your computer keyboard and use
the mouse to drag a copy of the highlighted items to the new location.

Copying a script to another application
You can copy all or only a selected portion of a script to another
application such as a word processor. You can copy the key graphics as
they are shown in the script pane, or you can copy the key presses as font
text characters.

Note: When you copy as font text characters, those characters use the
TI73EmuKeys font. This font is installed on your computer automatically
when you install the TI-SmartView™ software.

Copying keys as graphics
1.
2.

Open the appropriate script.
Select the keys you want to copy. To select all the keys, click Edit >

Select All.
3.

Click Edit > Copy, switch to the other application, and paste the
keys at the appropriate location.

Note: You can also drag the selected keys to the new application.
Copying keys as font text characters
1.
2.

Open the appropriate script.
Select the keys you want to copy. To select all the keys, click Edit >

Select All.
3.

Click Edit > Copy As Font.
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4.

Switch to the other application, and paste the characters at the
appropriate location.
In some applications, the pasted characters may be shown in the font
that is in effect at that location. So they may not look anything like
calculator keys.

5.

If necessary, apply the TI73EmuKeys font to the characters.

Note: The script icons for text points, delays, pauses, and Go To Home
commands cannot be copied as font text characters. They are ignored
when you paste the copied characters into the other application.

Locating common scripts
If you have access to scripts written by other people, you can open and
play those scripts on your own computer. Texas Instruments provides a
number of scripts that perform commonly used operations.
•

Run the TI-SmartView™ installation CD, which runs automatically
when you insert it into the CD drive. Click the activities and
tutorials tab on the displayed screen. Most of the listed items are
scripts that you can save to your computer.

•

Check the Texas Instruments web site at education.ti.com.

By using available scripts and viewing their content, you can get ideas
about how to create additional scripts for automating your own
operations.
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FAQs and keyboard shortcuts
Frequently asked questions
I clicked on the calculator screen to select an option, but nothing
happened. Why?
On the calculator image in the TI-SmartView™ Emulator, use the mouse
to click keys the same as you would use your finger to press keys on a real
TI-73 Explorer™ calculator. And just like on a real calculator, you can’t
press the screen to select an option, even though it’s very tempting on a
computer. You must click the same keys you would press on the
calculator.
I’m having trouble editing a script. How do I figure out where I
need to be in the script to make a change?
Because scripts record key presses, it might be easier to step through the
script by clicking
on the script toolbar or to change the script’s
playback speed so that you can see exactly where you need to make the
change.
The TI-SmartView™ Emulator calculator is too big for my
computer screen. How do I change the size?
Click View > Size and then select a smaller size.
Some keys show a
does that mean?

in the key press history or in a script. What

When you hold down an arrow key for more than a certain amount of
time, the cursor begins to scroll. The key that starts this scrolling feature
has a clock icon attached to it. For example:

The amount of scrolling represented by this single key icon is equivalent
to clicking the key multiple times. If you run a script that contains one of
these keys, TI-SmartView™ Emulator reproduces the equivalent number
of key presses.

FAQs and keyboard shortcuts
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Using the computer keyboard
You can use the computer keyboard to enter data into the
TI-SmartView™ for the TI-73 Explorer™ emulator software. However, the
keyboard does not work the same as using the TI Keyboard with a
calculator. You cannot simply use the keys like a QWERTY keyboard to
type A through Z.
Press F6 on the computer keyboard to access second functions on the
emulator software. For example, to access MODE on the emulator, press
F6 Shift+M on the keyboard.
To enter text, press F6 Shift+T. The TI-73 Explorer™ text menu displays.
Use the arrow keys to highlight a letter, and press Enter to choose the
letter. When you are finished, highlight Done and press Enter.

Shortcut mode
The TI-SmartView™ for the TI-73 Explorer™ emulator software has the
following keyboard shortcuts.
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Legal information
Texas Instruments Support and Service
For general information
Home Page:

education.ti.com

KnowledgeBase
and e-mail
inquiries:

education.ti.com/support

Phone:

(800) TI-CARES / (800) 842-2737
For U.S., Canada, Mexico, Puerto Rico, and
Virgin Islands only

International
information:

education.ti.com/international

For technical support
KnowledgeBase
and support by
e-mail:

education.ti.com/support

Phone
(not toll-free):

(972) 917-8324

For product (hardware) service
Customers in the U.S., Canada, Mexico, Puerto Rico and Virgin
Islands: Always contact Texas Instruments Customer Support before
returning a product for service.
All other customers: Refer to the leaflet enclosed with this product
(hardware) or contact your local Texas Instruments retailer/distributor.

License
Your right to use this product is governed by the license you accepted
when you installed the software.
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