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Important Information
Except as otherwise expressly stated in the License that accompanies a program, Texas
Instruments makes no warranty, either express or implied, including but not limited to
any implied warranties of merchantability and fitness for a particular purpose,
regarding any programs or book materials and makes such materials available solely
on an "as-is" basis. In no event shall Texas Instruments be liable to anyone for special,
collateral, incidental, or consequential damages in connection with or arising out of the
purchase or use of these materials, and the sole and exclusive liability of Texas
Instruments, regardless of the form of action, shall not exceed the amount set forth in
the license for the program. Moreover, Texas Instruments shall not be liable for any
claim of any kind whatsoever against the use of these materials by any other party.

Learning More with the TI-Innovator™ Technology eGuide

Parts of this document refer you to the TI-Innovator™ Technology eGuide for more
details. The eGuide is a Web-based source of TI-Innovator™ information, including:

• Programming with the TI CE Family of Graphing Calculators and
TI-Nspire™ Technology, including sample programs.

• Available I/O Modules and their commands.

• Available breadboard components and their commands.

• Available TI-Innovator™ Rover and its commands.

• Link to update the TI-Innovator™ Sketch software.

• Free classroom activities for TI-Innovator™ Hub.

https://education.ti.com/go/eguide/hub/EN

Apple®, Chrome®, Excel®, Google®, Firefox®, Internet Explorer®, Mac®, Microsoft®,
Mozilla®, Safari®, and Windows® are registered trademarks of their respective owners.

QR Codeë is a registered trademark of DENSO WAVE INCORPORATED.

Select images were created with Fritzing.

© 2011 - 2018 Texas Instruments Incorporated.

Actual products may vary slightly from provided images.
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TI-Innovator™ Hub Overview
The TI-Innovator™ Hub lets you use your compatible TI graphing calculator or
TI-Nspire™ CX computer software to control components, read sensors, and create
powerful learning experiences.

• You communicate with the Hub through TI Basic programming commands.

• Hosts that are compatible with TI-Innovator™ Hub include:

- TI CE Family of Graphing Calculators (TI-83 Premium CE, TI-84 Plus CE, and
TI-84 Plus CE-T) with operating system version 5.3 or later installed. You also
need to install or update the Hub App, which contains the Hub menu.

- TI Nspire™ CX or TI Nspire™ CX CAS handheld with operating system version 4.5
or later installed

- TI Nspire™ computer software version 4.5 or later

• TI-Innovator™ Hub. Communicates with the host, the Hub on-board components,
and connected external components. It also distributes power to external
components.

• TI-Innovator™ Components. These components, sold separately, include sensors,
motors, and LEDs that connect to the Hub through its I/O ports and breadboard
connector.

Learn More

For a list of precautions to take while using the Hub and its components, refer to
General Precautions (page 27).

To find information on accessories, external modules, and breadboard components,
visit education.ti.com/go/innovator.
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What's in the Box

TI-Innovator™ Hub with On-Board
Components

À  A Light Brightness Sensor at the bottom
of the Hub can be read as
"BRIGHTNESS" in Hub command strings.

Á  Red LED is addressable as "LIGHT" in
Hub command strings.

Â  Speaker (at back of Hub, not shown) is
addressable as "SOUND" in Hub
command strings.

Ã  Red-Green-Blue LED is addressable as
"COLOR" in Hub command strings.

Also visible on the face of the Hub are:

A Green auxiliary power LED

B Green power LED,

C Red error LED.

Built-in Ports

Left side - Three ports for collecting data or
status from input modules:
• IN 1 and IN 2 provide 3.3V power.
• IN 3 provides 5V power.

Right side - Three ports for controlling output
modules:
• OUT 1 and OUT 2 provide 3.3V power.
• OUT 3 provides 5V power.

Bottom - Light Brightness Sensor (described
earlier) and two ports:
• I2C port connects to peripherals that use the

I2C communication protocol.
• DATA Mini-B port, used with the appropriate

cable, connects to a compatible graphing
calculator or computer for data and power.



Top - Two connectors:
• USB-Micro connector (PWR) for auxiliary

power required by some components. Also
used for updating the Hub internal software.

• Breadboard Connector with 20 labeled pins
for communication with connected
components. A breadboard and jumper
cables are included with the TI-Innovator™
Breadboard Pack, sold separately.

USB Cables

À  USB Unit-to-Unit (Mini-A to Mini-B) - Connects the Hub to a TI CE Graphing
Calculator or a TI-Nspire™ CX Handheld.

Á  USB Standard A to Mini-B - Connects the Hub to a computer running
TI-Nspire™ CX Software.

Â  USB Standard A to Micro - Connects the PWR port of the Hub to a TI approved
power source required by some peripherals.

Auxiliary Power

TI Wall Charger - Supplies power through the
TI-Innovator™ Hub for components, such as motors, that
require additional power.
The optional External Battery Pack can also provide auxiliary
power.
Note: An auxiliary power LED on the Hub indicates when the
Hub is receiving auxiliary power.
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Connecting TI-Innovator™ Hub
The TI-Innovator™ Hub connects by a USB cable to a graphing calculator or computer.
The connection lets the Hub receive power and exchange data with the host.

Note: Some peripherals, such as motors, may require auxiliary power. For more
information, see Using an Auxiliary Power Source (page 23).

Connecting to a Graphing Calculator

1. Identify the "B" connector on the USB Unit-to-Unit
(Mini-A to Mini-B) cable. Each end of this cable is
embossed with a letter.

2. Insert the "B" connector into the DATA port at the
bottom of the TI-Innovator™ Hub.

3. Insert the free end of the cable (the "A" connector) into the USB port on the
calculator.

Hub connected to
TI CE Graphing Calculator

Hub connected to
TI-Nspire™ CXHandheld



4. Turn on the calculator if it is not already on.

The power LED on the Hub glows green to show that it is receiving power.

Connecting to a Computer Running TI-Nspire™ CX Software

1. Identify the "B" connector on
the USB Standard A to Mini-B
cable for Windows®/Mac®.
Each end of this cable is
embossed with a letter.

2. Insert the "B" connector into
the DATA port at the bottom
of the TI-Innovator™ Hub.

3. Insert the free end of the
cable (the "A" connector) into
a USB port on the computer.

The power LED on the Hub
glows green to show that it is
receiving power.
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Updating the Hub Software
The TI-Innovator™ Hub contains software, TI-Innovator™ Sketch, that interprets Hub
commands and communicates with on-board devices and connected modules. A Web-
based tool lets you update the Sketch. Updated versions contain bug fixes and ensure
that your TI-Innovator™ Hub can communicate with the latest components.

To obtain the latest version of the TI-Innovator™ Sketch go to the following site:

https://education.ti.com/en/us/hubsw

https://education.ti.com/en/product-resources/sketch-update


Hub Programming on TI CE Graphing Calculator
Note: These instructions apply to TI CE graphing calculator. For similar instructions for
TI-Nspire™ CX technology, refer to Hub Programming on TI-Nspire™ CX Technology
(page 12).

The TI-Innovator™ Hub responds to TI Basic programming commands such as Send and
Get.

• Send - Sends command strings to the Hub to control devices or request
information.

• Get - Retrieves information requested from the Hub.

• eval - Supplies the result of an expression as a character string. Especially useful
within the Hub command string in Send commands.

• Wait - Pauses program execution for a specified number of seconds.

Code Examples: TI CE Graphing Calculator

Desired Action Program Code

Turn on the on-board Red LED ("LIGHT"). Send("SET LIGHT ON")

Play a 440Hz tone on the on-board
speaker ("SOUND") for 2 seconds.

Send("SET SOUND 440 TIME 2")

Turn on blue element of on-board RGB
LED ("COLOR") at 100% brightness.

Send("SET COLOR.BLUE 255")

Read and display the current value of the
on-board light sensor ("BRIGHTNESS").
Range is 0% to 100%.

Send("READ BRIGHTNESS")
Get(A):Disp A

Sample Program to Blink an On-Board LED

The following TI CE graphing calculator program uses the Send andWait commands to
blink the on-board red LED in the Hub. The commands are contained in a "For...End"
loop that repeats the ON/OFF blink cycle for 10 iterations.
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PRGM: BLINK
For(N,1,10)
Send("SET LIGHT ON")
Wait 1
Send("SET LIGHT OFF")
Wait 1
End

How to Create and Execute a Program

Note: These are abbreviated instructions. For detailed instructions on creating and
executing programs, refer to TI-Basic Programming for the TI CE Graphing Calculator.
The guide is available through the TI-Innovator™ Technology eGuide (page ii).

Before You Begin

▶ Refer to System Requirements (page 1), and update your calculator's OS
(Operating System) and Hub App, as needed. You can update from TI Connect™ CE
software or from another updated calculator.

To Create a New Program on TI CE Graphing Calculator:

1. On the Home Screen, press¼, select New, and pressÍ.

2. Type a name for your program, such as "SOUNDTST," and then pressÍ.

The Program Editor opens, displaying a template for your program code.

3. Enter the lines of code that make up your program.

- You must use the Hub Menu to enter TI-Basic commands, such as Send and
Get. (Press¼ and select Hub.)

- You can enter Hub command strinSetgs and parameters such as
"SET LIGHT ON" by using the menu or by typing. If you type the strings,
make sure to use the correct case.

- At the end of each line, pressÍ. Each new line is automatically preceded by
a colon (:).

- Use the arrow keys to move through a program. Press{ to delete, or press
y6 to insert.

To Close the Program Editor

▶ Pressy5 to return to the Home Screen.

https://education.ti.com/html/webhelp/EG_TI84PlusCECode/EN/index.html


The program remains available through the¼ key.

To Run the Program:

1. Ensure that the TI-Innovator™ Hub is connected to your calculator.

2. Ensure that any needed I/O Modules or Breadboard components are connected to
the Hub.

3. From the Home Screen, press¼, select your program name from the displayed
list, and pressÍ.

The program name is pasted to the Home Screen.

4. PressÍ again to run the program.

To Edit an Existing Program:

1. On the Home Screen, press¼, select Edit.

2. Select the program name from the displayed list, and pressÍ.

The program opens in the Program Editor.

Using the Hub Menu to Build Commands

The Hub menu is available on the TI CE graphing calculator anytime you are creating or
editing a program. It can save you time building commands and help you with correct
command spelling and syntax.

Note: To build a command from the Hub menu, you need to know:

• The unique name of the component that you are addressing, such as "SOUND" for
the on-board speaker.

• The command parameters that apply to the component, such as sound frequency
and duration. Some parameters are optional, and you might need to know the
value range of a parameter.

Example of Using the Hub Menu:

This TI CE graphing calculator example builds the command Send 
("SET SOUND 440 TIME 2") to sound a 440Hz tone for 2 seconds on the on-board
speaker.

1. Open (or create) the program that you will use to communicate with the Hub.
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2. Position the cursor where you want to place the command.

3. Press¼ and select Hub.

The Hub menu appears.

4. Select Send "SET and pressÍ, and
then select SOUND and pressÍ.

5. Type 440 as the sound frequency.

6. On the Hub menu, select Settings >
TIME.

7. Type 2 as the TIME value.

8. To complete the command, type closing
quotes (press ƒÃ), and then
press ¤.

9. To return to the Home Screen and test the command, pressy5 and then
follow the previous instructions for running a program.

Tips for Coding with TI CE Graphing Calculator

• Make sure your code is free of unnecessary spaces that can cause syntax errors.
This includes repeated spaces within the line and one or more spaces at the end of
a line.

• Code from an external source might show "curly" quotation marks (“...”) in places
that require straight quotes ("..."). To type straight quotes, pressƒ and thenÃ.

• To clear the current line of code, press‘.

• To type relational operators such as =, <, and ≤, pressy:.

• To type a space, pressƒ and then Ê.

• If your program becomes unresponsive while running, press theÉ key.

• Note: If a command syntax does not include an opening left parenthesis, such as
"Wait ", using a pair of parentheses in an argument may be interpreted as the full
argument and give an unexpected syntax error. When entering long expressions
with parentheses, enclose the entire expression with paired parentheses to avoid
syntax errors of this nature.



Valid: Wait ((X+4)*5)
Valid: Wait X+4*5
Syntax Error: Wait (X+4)*5

Learn More

To find sample programs and details about programming the TI-Innovator™ Hub, see
the TI-Innovator™ Technology eGuide (page ii).
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Hub Programming on TI-Nspire™ CX Technology
Note: These instructions apply to TI-Nspire™ CX technology. For similar instructions for
TI CE graphing calculator, refer to Hub Programming on TI CE Graphing Calculator
(page 7).

The TI-Innovator™ Hub responds to TI Basic programming commands such as Send and
Get.

• Send - Sends command strings to the Hub to control devices or request
information.

• Get and GetStr - Retrieve information requested from the Hub.

• eval() - Supplies the result of an expression as a character string. Valid only within
Send, Get, and GetStr commands.

• Wait - Pauses program execution for a specified number of seconds.

Code Examples: TI-Nspire™ CX Technology

Desired Action Program Code

Turn on the on-board Red LED ("LIGHT"). Send "SET LIGHT ON"

Play a 440Hz tone on the on-board
speaker ("SOUND") for 2 seconds.

Send "SET SOUND 440 TIME 2"

Turn on blue element of on-board RGB
LED ("COLOR") at 100% brightness.

Send "SET COLOR.BLUE 255"

Read and display the current value of the
on-board light sensor ("BRIGHTNESS").
Range is 0% to 100%.

Send "READ BRIGHTNESS"
Get a: Disp a

Sample Program to Blink an On-Board LED

The following TI-Nspire™ CX program uses the Send andWait commands to blink the
on-board red LED in the Hub. The commands are contained in a "For...EndFor" loop that
repeats the ON/OFF blink cycle for 10 iterations.



Define blink()=
Prgm
For n,1,10
Send "SET LIGHT ON"
Wait 1
Send "SET LIGHT OFF"
Wait 1

EndFor
EndPrgm

How to Create and Execute a Program

Note: These are abbreviated instructions. For detailed instructions, refer to the
TI-Nspire™ CX Program Editor, accessible through the TI-Innovator™ Technology eGuide
(page ii).

Before You Begin:

▶ Refer to System Requirements (page 1), and update your software as needed.

- On TI-Nspire™ CX handhelds, use TI-Nspire™ computer software to update the
Operating System.

- On computers running TI-Nspire™ CX software, use the Help menu to update
the software.

To Create a New Program in a TI-Nspire CX Document:

1. On the handheld, press~ and select Insert > Program Editor > New.
From the computer software, click Insert > Program Editor > New.

2. Type a name for your program, such as "soundtst," select Program as the Type, and
then click OK.

The Program Editor opens, displaying a template for your program code.

3. Between the Prgm and EndPrgm lines, type the lines of code that make up your
program.

- You can either type command names or insert them from the Program Editor
menu.

- After typing each line, press Enter to type additional code.
- Use the arrow keys to scroll through the program.

To Store the Program:

You must store your program before you can run it.
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▶ On the handheld, pressb and select Check Syntax & Store > Check Syntax &
Store.
On the Program Editor menu, click Check Syntax & Store > Check Syntax & Store.

To Close the Program Editor

▶ On the handheld, pressb and select Actions > Close.
On the Program Editor menu, click Actions > Close.

If you have made changes since storing the program, you are prompted to Check
Syntax & Store.

To Run the Program:

1. Ensure that the TI-Innovator™ Hub is connected to your handheld or computer.

2. Ensure that any needed I/O Modules or Breadboard components are connected to
the Hub.

3. Open the document that contains the program.

4. On a Calculator page, type the program name and parentheses. If the program
requires arguments, enclose them in the parentheses, separated by commas.

The program runs.

To Edit an Existing Program:

1. If necessary, open the document that contains the program.

2. Go to a Calculator page.

3. On the handheld, pressb and select Functions & Programs > Program Editor >
Open.
On the Calculator menu, click Functions & Programs > Program Editor > Open.

4. Select the program name name from the displayed list.

The program appears in a Program Editor page.

Using the Hub Menu to Build Commands

The Hub menu is available on the TI-Nspire™ CX technology anytime you are creating or
editing a program. It can save you time building commands and help you with correct
command spelling and syntax.

Note: To build a command from the Hub menu, you need to know:

• The unique name of the component that you are addressing, such as "SOUND" for
the on-board speaker.

• The command parameters that apply to the component, such as sound frequency
and duration. Some parameters are optional, and you might need to know the
value range of a parameter.



Example of Using the Hub Menu:

This TI-Nspire™ CX example builds the command Send "SET SOUND 440 TIME 2" to
sound a 440Hz tone for 2 seconds on the on-board speaker.

1. Open (or create) the program that you will use to communicate with the Hub.

2. Position the cursor where you want to place the command.

3. On the handheld, pressb and select
Hub.
In the Program Editor menu, select Hub.

The Hub menu appears.

4. Select Send "SET, and then select
SOUND to insert the first part of the
command.

5. Type 440 as the frequency value.

6. On the Hub menu, select Settings >
TIME.

7. To complete the command, Type 2 as
the TIME value.

8. To test the command, follow the previous instructions for running a program.

15
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Tips for Coding with TI-Nspire™ CX Technology

• Code from an external source might contain "curly" quotation marks (“...”) in
places that require straight quotes ("..."). To type straight quotes, press /r.

• To clear the current line of code, press /Ì.

• To type relational operators such as =, <, and ≤, press /=.

• To type a space, press _.

• If your program becomes unresponsive while running:

TI-Nspire™ CX Handheld: Hold down thec key and press · repeatedly.
Windows®: Hold down the F12 key and press Enter repeatedly.
Mac®: Hold down the F5 key and press Enter repeatedly.

Learn More

To find sample programs and details about programming the TI-Innovator™ Hub, see
the TI-Innovator™ Technology eGuide (page ii).



TI-Innovator™ I/O Modules
These Input/Output modules (purchased separately) include cables for connecting the
modules to the TI-Innovator™ Hub.

Module Ports Image Sample code for TI CE Graphing Calculator

White
LED
*

OUT 
1
OUT 
2
OUT 
3

Turn on the White LED module connected
to OUT 1:
Send("CONNECT LED 1 TO OUT 1")
Send("SET LED 1 ON")

Servo
Motor
**

OUT 
3

Rotate the shaft of the Servo Motor
connected to OUT 3 counter clockwise by
90°:
Send("CONNECT SERVO 1 TO OUT 3")
Send("SET SERVO 1 TO -90")

Equivalent code using a variable with eval():
angdeg:=-90
Send("CONNECT SERVO 1 TO OUT 3")
Send("SET SERVO 1 TO eval(angdeg)")

Analog
Light
Sensor

IN 1
IN 2
IN 3

Read and display ambient light level from
the sensor connected to IN 2:
Send("CONNECT LIGHTLEVEL 1 TO IN2")
Send("READ LIGHTLEVEL 1")
Get(L):Disp(L)

Ultrasoni
c Ranger

IN 1
IN 2

Read and display measured distance from
the ranger connected to IN 2:
Send("CONNECT RANGER 1 TO IN2")
Send("READ RANGER 1")
Get(R):Disp(R)

Vibration
Motor

OUT 
1
OUT 
2
OUT 
3

Turn on the Vibration Motor connected to
OUT 1:
Send("CONNECT VIB.MOTOR 1 TO OUT
1")
Send("SET VIB.MOTOR 1 TO ON")

*The White Led module requires some assembly.

**The Servo Motor requires auxiliary power and some assembly. For details, refer to
the TI-Innovator™ Technology eGuide (page ii).

Connecting an I/O Module

You use the I/O cable included with the module to connect it to a Hub Input or Output
port.

17
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1. Check the above table to ensure that you know which I/O ports support the module
that you are connecting.

2. Connect either end of the I/O cable to the white connector on the module.

3. Connect the free end of the I/O cable to the Hub port you have decided to use.

4. If the module requires auxiliary power, connect the power source (page 23),

Sample Program to Blink an LED Module

The following TI CE graphing calculator program uses Send andWait commands to
blink an LED module connected to an I/O port.

Note: This program operates correctly only if the calculator is connected to the Hub and
an LED module is physically connected to port OUT 1.

PRGM: BLINKIO
Send("CONNECT LED 1 TO
OUT1")
For(N,1,10)
Send("SET LED 1 ON")
Wait 1
Send("SET LED 1 OFF")
Wait 1
End
Send("DISCONNECT LED 1")

Note: If you are using
TI-Nspire™ CX technology, omit
the parentheses, and change End
to EndFor.

The Hub command string "CONNECT LED 1 TO OUT1" tells the Hub that an LED module
is connected to port OUT 1 on the Hub. After sending this command, the code can
address the LED as "LED 1." The CONNECT command is required only for I/O Modules
and Breadboard components. It is not necessary with the on-board components such as
the built-in speaker.

Learn More

For a list of precautions to take while using the I/O Modules, refer to General
Precautions (page 27).

To find sample programs, a list of additional I/O Modules, and details about
programming I/O Modules, see the TI-Innovator™ Technology eGuide (page ii).



TI-Innovator™ Breadboard Pack
The breadboard and its components (purchased separately) let you build breadboard
projects and connect them to the TI-Innovator™ Hub through its Breadboard Connector
pins.

The breadboard components include:

• A breadboard and jumper cables for creating electrical connections.

• Addressable components, such as LEDs and sensors, that respond to Hub
commands. These are listed in the table below.

• Passive components, such as resistors, capacitors, and manual switches that are
not directly addressable by the Hub but are required in many breadboard projects.

• A Battery Holder that holds four AA batteries. Batteries are not included.

Addressable Components

Component Image Used with
pins

Description

Red LEDs BB 1-10 Light-emitting diode that
emits light when current
passes through it.

Green LEDs BB 1-10 Light-emitting diode that
emits light when current
passes through it.

RGB (Red-
Green-Blue)
LEDs

BB 8-10 Light-emitting diode
with independently
adjustable red, green
and blue elements. Can
produce a wide variety
of colors.

Thermistor BB 5,6,7
(analog
input
required)

Resistor whose
resistance changes based
on temperature. Used
for measurement and
control.

7-segment
Display

BB 1-10 Array of LEDs arranged to
display numbers and
some alphabetic
characters. Also has an
LED for a decimal point.

Small DC
Motor

BB 1-10
(uses digital
to generate
software
PWM)

Motor that converts
direct current electrical
power into mechanical
power.

19



20

TTL Power
MOSFET

BB 1-10 Transistor used for
amplifying or switching
electronic signals.

TI Analog
Temperature
Sensor

BB 5,6,7
(analog
input
required)

Sensor that reports a
voltage proportional to
the ambient
temperature within a
range of −55°C to 130°C.

Visible Light
Sensor

BB 5,6,7
(analog
input
required)

Sensor that reports the
level of ambient light.

Infrared
Transmitter
LTE-302,
yellow dot

BB 1-10
(digital
output)

Side emitting Infrared
LED, designed to be
paired with the LTR-301
Photo-Transistor.

Infrared
Receiver
LTR-301,
red dot

BB 1-10
(digital
input)

Side sensing Infrared
photo transistor,
designed to be paired
with the LTE-302
Infrared Emitter.

Sample Code to Blink a Breadboard LED

The following TI CE graphing calculator(s) program uses Send andWait commands to
blink a specific LED on the breadboard.

Note: This program operates correctly only if the calculator is connected to the Hub and
the LED is physically connected to BB1 (breadboard pin 1) on the Hub.



PRGM: BLINKBB
Send("CONNECT LED 1 TO BB1")
For(N,1,10)
Send("SET LED 1 ON")
Wait 1
Send("SET LED 1 OFF")
Wait 1
End
Send("DISCONNECT LED 1")

Note: If you are using
TI-Nspire™ CX technology, omit
the parentheses, and change End
to EndFor.

The Hub command string "CONNECT LED 1 TO BB1" tells the Hub that an LED on the
breadboard is connected to pin 1 on the Hub. After sending this command, your code
can address the LED as "LED 1." The CONNECT command is required only for I/O
Modules and breadboard components. It does not apply to on-board components such
as the built-in speaker.

Breadboard Basics

The breadboard makes it easy to connect the electronic components of a project by
inserting component leads and jumper cables into pins on the breadboard.

The pins are arranged in groups of 5. The 5 pins in each group are electrically
connected to each other at the back of the board. You connect leads and cables
together by inserting them into pins within the same group.

• Power rails at the top and bottom are marked with red (+) and blue (–) stripes. The
groups in each rail are electrically connected along the entire length of the stripe.

• The remaining 5-pin groups on the board are labeled with numbers and letters.
Each group is electrically isolated from the others.

21
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Front of board showing power rails and connection
pins

Interconnections at back of board (normally
hidden). The 5-pin groups in each power rail are
interconnected. All other 5-pin groups are
isolated.

The gap at the center of the breadboard allows easy connection of electronic
components provided as dual-inline packages.

You use jumper cables between the Hub and the breadboard to power breadboard
components and to control or monitor them through program code. The Hub has 20
labeled pins, including 10 signal pins, 8 ground pins, one 3.3V power pin, and one 5.0V
power pin.

Learn More

For a list of precautions to take while using the breadboard and its components, refer
to General Precautions (page 27).

To find sample programs and details about programming breadboard components on
the TI-Innovator™ Hub, see the TI-Innovator™ Technology eGuide (page ii).



Using an Auxiliary Power Source
Normally, the TI-Innovator™ Hub and its connected components draw power from the
host calculator or computer, through the DATA connector. Certain components, such as
the optional Servo Motor, require more power than a calculator can provide reliably.

The PWR connector on the Hub lets you connect an auxiliary power source. You can use
the TI Wall Charger or the External Battery Pack.

TI Wall Charger (included with the Hub)
• Plugs into a wall outlet.
• Does not use batteries.

External Battery Pack (sold separately)
• Rechargeable.
• Has On/Off button with a row of LEDs that

momentarily indicate the battery charge
when you turn the battery on.

• Turns itself off after being disconnected
from the Hub for about 3 minutes.

Note: To recharge the External Battery Pack,
disconnect it from the Hub and then connect
it to the TI Wall Charger using the USB
Standard A to Micro cable. Do not use the
External Battery Pack as an auxiliary power
source while it is being charged.

Connecting the Power Source

1. Identify the Micro connector on the USB
Standard A to Micro auxiliary power cable.

2. Insert the Micro connector into the PWR
connector at the top of the Hub.

3. Insert the free end of the cable (the "A" connector) into the USB port on the power
source.
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4. Turn on the power source:

- If using the TI Wall Charger, plug it into a wall socket.
- If using the External Battery Pack, press the power button.

An auxiliary power LED on the Hub glows to show that the Hub is receiving auxiliary
power.

5. Connect the TI-Innovator™ Hub to the host calculator, using the USB Standard A to
Mini-B cable.

6. Connect the I/O Module or breadboard component to the Hub.



Troubleshooting
I don't see the green LED when I connect TI-Innovator™ Hub.

• Make sure that the calculator is turned on.

• If you are using a USB Unit-to-Unit (Mini-A to Mini-B) cable to connect to a
calculator, make sure to connect the "B" end of the cable to the DATA connector at
the bottom of the Hub. Reversing this cable prevents the Hub from receiving
power.

• Make sure your calculator or computer meets the System Requirements (page 1).

• Make sure the end of the USB cable connected to the calculator is inserted
completely.

How do I turn the Hub off?

1. Turn off the host calculator or computer.
– OR –
Disconnect the USB cable.

2. Disconnect any auxiliary power source connected to the PWR port on the Hub.

Why does my program give me a syntax error?

• If you have pasted code from an external source or text editor, it might contain
"curly" quotation marks (“...”) in places that require straight quotes ("..."). You
may need to replace some or all of the curly quotes.

• The syntax rules are slightly different between the TI CE graphing calculator and
TI-Nspire™ CX technology. Code originally created for one platform may need to be
modified to work on the other.

• On the TI CE graphing calculator, make sure you don't have a space character at the
end of a line of code. To find these trailing spaces in a line, move the cursor to the
line and pressy~. Adjacent spaces in code can also cause a syntax error.

How do I stop a program that becomes unresponsive?

• TI CE graphing calculator: Press theÉ key.

• TI-Nspire™ CX Handheld: Hold down thec key and press· repeatedly.

• Windows®: Hold down the F12 key and press Enter repeatedly.

• Mac®: Hold down the F5 key and press Enter repeatedly.

Why do I get an error when I try to update the TI-Innovator™ Sketch?

• For sketch updating, make sure you are using the USB Standard A to Micro cable,
not the USB Standard A to Mini-B cable. Connect the micro end of the cable to the
PWR connector at the top of the Hub.

• Make sure you are using one of the Web browsers required for updating. See
Updating the Hub Software (page 6).
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Learn More

To find more troubleshooting information, see the TI-Innovator™ Technology eGuide
(page ii).



General Precautions
TI-Innovator™ Hub

• Do not expose the Hub to temperatures above 140˚F (60˚C).
• Do not disassemble or mistreat the Hub.

• Do not chain together multiple Hubs through the I/O ports or the Breadboard
Connector.

• Use only the USB cables provided with the Hub.

• Use only the TI provided power supplies:

- TI Wall Charger included with the TI-Innovator™ Hub
- Optional External Battery Pack
- 4AA battery holder included in the TI-Innovator™ Breadboard Pack

• Ensure that the components receiving power from the Hub do not exceed the Hub's
1-amp power limit.

• Avoid using the Hub to control AC electricity.

Breadboard Connector on the Hub

• Do not insert the leads of LEDs and other components directly into the Hub’s
Breadboard Connector. Assemble the components on the breadboard and use the
provided jumper cables to connect the breadboard to the Hub.

• Do not connect the 5V receptacle pin on the Hub's Breadboard Connector to any of
the other pins, especially the ground pins. Doing so could damage the Hub.

• Connecting the top row of receptacle pins (BB1-10) to the bottom row (grounding
and power pins) is not recommended.

• No pin on the Hub's Breadboard Connector can sink or source greater than 4 mA.

Breadboard

• Do not connect the positive and negative leads of a power source to the same
group of 5 pins on the breadboard. Doing so could damage the breadboard and the
power source.

• Observe the correct polarity:

- When connecting the breadboard to the Hub.
- When connecting components that are sensitive to polarity, such as LEDS and

the TTL Power MOSFET.

I/O Modules

• Use the correct Input or Output port as required for each module.

- Vibration Motor – supported on OUT 1, OUT 2, and OUT 3.
- Servo Motor – use OUT 3 only.
- White LED – supported on OUT 1, OUT 2, and OUT 3.
- Analog Light Sensor – supported on IN 1, In 2, and IN 3.
- Ultrasonic Ranger – supported on IN 1, IN 2.
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• Use an Auxiliary Power Source for modules that require more than 50 mA,
including:

- Vibration Motor
- Servo Motor

• Do not hold the Servo Motor’s shaft while it is rotating. Also, do not rotate the
Servo Motor by hand.

• White LED:

- Do not bend the leads repeatedly; this will weaken the wires and may cause
them to break.

- The LED requires the correct polarity when inserted into its socket. For details,
refer to the instructions for assembling the LED in the TI-Innovator™
Technology eGuide (page ii).

- The LED requires the correct polarity when inserted into its socket. For details,
refer to the instructions for assembling the LED (here).

• No I/O module can sink or source greater than 4 mA.

TI-Innovator™ Rover

• Do not expose the Rover to temperatures above 140˚F (60˚C).
• Do not disassemble or mistreat the Rover.

• Do not put anything heavier than 1 Kg or 2.2 lbs on the Rover platform.

• Use only the USB cables provided with the TI-Innovator™ Hub.

• Use only the Ribbon cables provided with the Rover.

• Use only the TI provided wall charger included with the Hub.

• The front-mounted Ultrasonic Ranger will detect objects within 4 meters of the
Rover. For best results make sure the object's surface is bigger than a folder. If
used to detect small objects, such as a cup, place the Rover within 1 meter of the
object.

• For best results, leave the Slide Case off of your graphing calculator.

• For best performance, use Rover on the floor, not on tables. Damage may occur
from Rover falling off a table.

• For best performance, use Rover on a hard surface. Carpet may cause the Rover
wheels to catch or drag.

• Do not turn the Holder pegs on the Calculator Platform without lifting them first.
They could break.

• Do not use the marker as a lever to pull or push the Rover.

• Do not unscrew the case enclosure on the bottom of the Rover. Encoders have
sharp edges that should not be exposed.

• Do not move Rover after executing a program. The internal gyroscope may
unintentionally try to get the Rover back on track using the initial location.



• When inserting the Breadboard Ribbon Cable into the Hub Breadboard Connector, it
is critical that you insert the cable correctly. Make sure the red (dark) wire pin is
inserted into the 5v hole on the Hub's Breadboard Connector.

Caution: If you dislodge or disconnect any of the cables, use this image as a reference
for correct hookups.

Reference to Bottom View
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General Information
Texas Instruments Support and Service
General Information: North and South America

Home Page: education.ti.com
KnowledgeBase and e-mail inquiries: education.ti.com/support
Phone: (800) TI-CARES / (800) 842-2737

For North and South America and U.S.
Territories

International contact information: education.ti.com/support/worldwide

For Technical Support

Knowledge Base and support by e-mail: education.ti.com/support or
ti-cares@ti.com

Phone: (866) 846-2844

For Product (Hardware) Service

Customers in the U.S., Canada, Mexico, and U.S. territories: Always contact Texas
Instruments Customer Support before returning a product for service.

For All Other Countries:

For general information

For more information about TI products and services, contact TI by e-mail or visit the
TI Internet address.

E-mail inquiries: ti-cares@ti.com
Home Page: education.ti.com

Service and Warranty Information
For information about the length and terms of the warranty or about product service,
refer to the warranty statement enclosed with this product or contact your local Texas
Instruments retailer/distributor.

https://education.ti.com/
https://education.ti.com/support
https://education.ti.com/support/worldwide
https://education.ti.com/support
mailto:ti-cares@ti.com
mailto:ti-cares@ti.com
https://education.ti.com/
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