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Important Information
Texas Instruments makes no warranty, either express or implied, 
including but not limited to any implied warranties of merchantability 
and fitness for a particular purpose, regarding any programs or book 
materials and makes such materials available solely on an "as-is" basis. In 
no event shall Texas Instruments be liable to anyone for special, 
collateral, incidental, or consequential damages in connection with or 
arising out of the purchase or use of these materials, and the sole and 
exclusive liability of Texas Instruments, regardless of the form of action, 
shall not exceed the purchase price of this product. Moreover, Texas 
Instruments shall not be liable for any claim of any kind whatsoever 
against the use of these materials by any other party.

Graphing product applications (Apps) are licensed. See the terms of the 
license agreement for this product.

Copyright © 2008-2009 Texas Instruments Incorporated.

Internet Explorer, Microsoft, Mozilla, Firefox, Windows, Windows Vista, 
Mac, Macintosh, and Safari are trademarks of their respective owners.
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Getting Started
Features

• Key Press History— Review recently pressed keys from the key 
press history pane or on the large screen pane.

• Additional Color Capabilities— Change the handheld image to 
use a different face plate option. The variety lets you increase 
visibility for the visually challenged. 

• Three Handheld Display Options— Select from three different 
handhelds to use as the interactive image: TI-83 Plus.fr, 
TI-84 Plus Silver Edition, or the TI-84 Plus mode of the 
TI-Nspire™ handheld. All three options use the TI-84 Plus Silver 
Edition operating system.

• Adjustable Screen Size— Use the small, medium, and large 
screen sizes or customize the screen size. When you size the 
screen by dragging the window border, the size of the device 
image is sized automatically.

Overview of the TI-SmartView™ software

The TI-SmartView™ software gives you the functionality of a 
TI-84 Plus Silver Edition handheld on your computer along with three 
interactive emulator images: the TI-83 Plus.fr, TI-84 Plus, and the 
TI-84 Plus mode of the TI-Nspire™ handheld. The entire functionality 
of the TI-84 Plus handheld is at your disposal, including the ability to 
load and use files such as applications (Apps), lists, programs, and so 
on. Several of the Apps that come already loaded on the TI-83 Plus.fr 
are also included with the TI-SmartView™ software.

TI-SmartView™ software lets you show the handhelds to an audience 
without using handheld-specific projection equipment and gives you 
additional functionality that aids in presentations and demonstrations.

• Supplement the current handheld screen by using the View3™ 
pane to show three additional screens simultaneously. You can 
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select any three of the following handheld screens: Y= editor, 
table, graph, stat plot, list, and window. 

• Repeat demonstrations quickly and easily by using scripts to play 
back a series of keystrokes.

• View the history of your entries as well as a large version of the 
current handheld screen, and open a script by displaying the key 
press history window.

• Capture screen images that you can save and use in other 
documents.

TI-84 Plus users can control the TI-SmartView™ software using a 
handheld that is connected via a USB cable and is running the 
SmartPad™ App. When you press keys and perform calculations on 
the handheld, those actions are repeated automatically on the 
emulator in the TI-SmartView™ software. The connected handheld 
acts as a remote keypad. 

The TI-83 Plus.fr and the TI-84 Plus mode of the TI-Nspire™ 
handheld are implemented as interactive images operating using the 

Emulator 
(Pane 1)

View3™ 
(Pane 2)

Key Press History tab 
(Pane 3)
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TI-84 Plus Silver Edition software emulation. The memory and 
functionality of the software emulator is greater than the memory and 
functionality of the TI-83 Plus.fr. 

System requirements

The computer that you use to run the TI-SmartView™ software must 
meet the following hardware and software requirements.

Windows®:

• Windows Vista® (Home Premium/Ultimate/Business), Windows® 
XP (Home or Professional edition) with Service Pack 2; or 
Windows® 2000 Professional edition with Service Pack 4.

• 900 MHz Pentium-compatible CPU 

• 512 MB RAM

• 180 MB of available hard-disk space

• CD-ROM drive or active Internet connection for installation

• Microsoft Internet Explorer 6.0 or higher, Apple Safari® 3.0 or 
higher, or Mozilla® Firefox® 3.0 or higher

Macintosh®:

• Mac® OS X 10.4 or 10.5 

• G3 CPU or later (900 MHz)

• 512 MB RAM

• 61 MB of available hard-disk space

• CD-ROM drive or Internet connection for installation

• Apple Safari® 3.0 or higher or Mozilla® Firefox® 3.0 or higher
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Installing the TI-SmartView™ software

If you are installing a full version of the TI-SmartView™ software (as 
opposed to a trial version), find the serial number and license number 
located on the CD case or CD. You need to enter these numbers 
during a full-version installation.

Before you begin

To install the software on your computer, you must have the 
appropriate privileges. On Windows®, you will need Administrator 
privileges. On Macintosh, you may need to specify your password 
during installation. If you do not have the necessary privileges, 
contact your network administrator.

Installing the software

1. Close any applications that are open.

2. Insert the TI-SmartView™ CD into the CD-ROM drive.

The CD should launch automatically. If the CD does not launch, 
double-click the appropriate launch file on the CD. 

Macintosh®: A message informs you that the installation package 
will determine whether the software can be installed on the 
computer. Click Continue to go to the next screen.

3. Click Next at the bottom of the Welcome screen.
The Destination screen displays.
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4. Click Next on the Destination screen to accept the default 
installation location, or click Browse to navigate to a different 
folder for application installation. Click Install to start the 
installation.

Macintosh®: If prompted, enter your password on the 
Authentication screen. A progress bar displays during installation. 
A message informs you that a restart is required after installation; 
press Continue to complete installation.

5. Windows®: Click Finish on the screen that confirms successful 
installation. Double-click the TI-SmartView icon to start the 
application and activate the software.

Macintosh®: Click Restart and then start the TI-SmartView 
software to activate it.

If you have already purchased the software, you should activate 
it. Activating the software allows to you continue using it past the 
30-day evaluation period. It prevents unauthorized copying of the 
product onto more computers than the license agreement allows.
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Activating the software

1. To begin the activation process, start the TI-SmartView™ 
program by double-clicking the icon. On the Activate Software 
screen, click Enter License Information, and then click Next.

2. Review the options displayed to determine which activation 
method you should use. Regardless of which activation method 
you prefer, you will need to supply the Serial Number and License 
Number included with the installation CD. You will also need to 
supply an Activation ID that is generated by the computer on 
which the software will be activated.
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• Internet— This method uses your Internet connection to 
activate your software. You provide the Serial Number and 
License Number.

• Web Portal— This method takes you to a Web page where 
you enter the Serial Number, License Number, and 
Installation ID to retrieve an Activation ID. The Activation ID is 
displayed on the Web page. If you provide your e-mail 
address, the Activation ID is also sent to you by e-mail.

• Phone— You provide a TI representative with the Serial 
Number and License Number as well as an Installation ID 
displayed on your screen. The representative then provides 
an Activation ID.

• I already have an Activation ID — After accepting a license 
agreement, you fill out a screen with the Serial Number, 
License Number, and the Activation ID.
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3. Click an activation method, then click Next and follow the 
instructions to type the Serial Number, License Number, and 
Activation ID.

Note: Be careful to not enter a zero for the letter O or a letter O 
for a zero. Similarly, do not confuse the number one with a 
lowercase letter L.

4. Type contact information and click Next.

5. Provide information to create a user profile (optional), and then 
click Next to complete software activation.

Opening the software on your computer

 Double-click the TI-SmartView™ icon. The application starts.
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Things you need to know

The mouse pointer takes the place of your finger pressing keys 
on the handheld.

You must click the keys on the TI-SmartView™ emulator as you 
would press the keys on the handheld. The handheld image in the 
TI-SmartView™ software is not fully interactive. For example, when 
you change mode settings, you might be tempted to click the mode 
setting on the handheld screen to select it. However, clicking on the 
screen does nothing. You must click the arrow keys to move the 
cursor to the desired setting and then click  to select it. 

Typing text using the computer keyboard does not work unless 
you first place the keyboard in its alpha typing mode.

By default, the handheld keyboard is in its normal mode, in which 
keys are simply shortcuts to handheld keys. For example, pressing 
[ A ] on your computer keyboard is the same as clicking on the 
handheld. In this mode, you cannot enter the letters A through Z on 
the handheld screen by typing these letters on your computer 
keyboard.

To enter a letter or other alpha character, first click  on the 
handheld keyboard (or press [ F7 ] on your computer keyboard) to 
put the handheld in alpha mode. For example, typing [ F7 ] [ A ] on 
your computer keyboard enters an A on the handheld screen. If you 
only type [ A ], the  menu is displayed. After you type the 
character, the keyboard returns to its normal mode.

To lock the alpha key so you can type more than one character at a 
time, click   on the handheld keyboard or press [ F6 ] [ F7 ] 
on your computer keyboard. To return to the normal mode, click  
or press [ F7 ].

In alpha typing mode, pressing [ 0 ] through [ 9 ] on your computer 
keyboard act as shortcuts to the alpha functions associated with 
these keys on the handheld keyboard. Pressing [ 1 ] enters Y (the 
alpha character associated with ) on the handheld screen. To type a 
number, be sure the keyboard is not in the alpha typing mode. These 
keys do enter the digits 0 through 9 in the normal mode.
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Hold down an arrow key to scroll the cursor continuously.

When you use an arrow key to move the cursor, you can hold down 
the key to scroll the cursor continuously, instead of having to press 
the key repeatedly. In the key press history and in a script, the icon for 
a repeating arrow key has a clock symbol attached to it. For example:

Pressing an arrow key multiple times in a row displays an arrow 
with a repeat counter.

When you press an arrow key multiple times in a row, one arrow key 
is displayed in the key press history. This arrow key has a number 
attached to it that shows the number of times the arrow key was 
pressed. For example:

When you record a script, you record only key presses on the 
handheld. These key presses can be difficult to interpret, viewed 
by themselves.

Because you record key presses, editing a script can be a little tricky. 
For example, if you change the mode to parametric, the script records 

   . The script does not explicitly tell you 
that you changed the mode to parametric. For this reason, it can be 
quite helpful to step through a script one key press at a time, or to 
play the script back at a slower speed so that you can see exactly 
where an edit needs to be made.
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Choosing a display option

By default, the TI-SmartView™ software displays the handheld and 
two optional panes of additional information. You can show or hide 
these optional panes, or change the type of information displayed in 
each one.

The View3™ pane initially shows the Y= editor, table, and graph 
screens. However, you can select which handheld screen you want to 
show for each of the three displays. (The stat plot, list, and window 
screens are also available.) The screens automatically update to 
reflect tasks you complete on the handheld.

The third pane includes tabs that you can click to see either the key 
press history, a large screen display of what the device image is 
displaying, or an open script. When you display the large screen in 
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the third pane, you can hide or show the key press history information 
at the bottom of the pane.

Note:

• Hiding the key press history pane does not clear the key press 
history.

• Hiding the key press history pane does not delete or close an 
open script.

• You can record a script without displaying the key press history 
pane.

Display Option Click:

View3™ pane

View > Show/Hide View3 or  to show or hide 
the pane.

View > View3 Options to select a handheld screen 
for each display.

Key press history, 
large screen, and 
script pane

View > Show/Hide Key Press History or  to 
show or hide the pane.

Scripts

File > Open or  to open an existing script.

File > New Script or  to open a new, blank script.

The close button on the script’s tab  to close 
a script.
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Changing the size of the TI-SmartView™ 
screen

When you first use the TI-SmartView™ software, a full-screen image 
for 1024 x 768 screen resolution is displayed. You can use whichever 
size you want, but the small, medium, and large versions are 
optimized for the following screen resolutions. 

The handheld images in the TI-SmartView™ program are freely 
scalable. In addition to choosing small, medium, and large emulator 
sizes, you can click and drag the TI-SmartView™ window borders to 
display the application in a window that is a custom size.

Changing the color of the face plate

You can change the face plate on the TI-SmartView™ handheld to 
improve visibility in the classroom. Options include Standard, 
Contrast, and Outline. 

 Click View > Color and then click a color option.

Changing handheld models

The default handheld displayed in the TI-SmartView™ software is the 
TI-83 Plus.fr handheld. The software also includes views of the 
TI-84 Plus Silver Edition handheld and the TI-84 Plus mode of the 
TI-Nspire™ handheld.

 Click View > Calculator Model and then click a handheld model.

If your screen resolution is: Click:

800 x 600 View > Size > Small Emulator

1024 x 768 View > Size > Medium Emulator

1280 x 1024 View > Size > Large Emulator
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Note: All three handheld model options use the TI-84 Plus Silver 
Edition operating system. The TI-83 Plus.fr and the TI-84 Plus mode 
of the TI-Nspire™ handheld are implemented as interactive images 
operating using the TI-84 Plus Silver Edition software emulation. The 
memory and functionality of the software emulator is greater than the 
memory and functionality of the TI-83 Plus.fr. 

Saving and loading an emulator state

When you save the emulator state, a file is created that stores the 
handheld settings with all of the changes that you have made to its 
setup. Think of the emulator state file as representing a single 
TI-83 Plus.fr that you have used and then set aside. When you load 
an emulator state, you pick up that same TI-83 Plus.fr to use again. 
All of the changes that you made to the handheld are intact.

For example, you might want to set up a class demonstration by 
entering functions in the Y= editor and changing Window and Zoom 
settings. When you save your changes in an emulator state file, you 
simply load the file to show your demonstration. If you want to create 
different demonstrations for different classes, you can create multiple 
emulator state files. There is no limit on the number of emulator states 
that you can save. 

Note: The key press history, screen capture images, any open script, 
the face plate color, and the emulator size are not saved in the 
emulator state file.

Saving the emulator state

1. Click File > Save Emulator State.

2. In the dialog box:

a) Navigate to the folder in which you want to store the emulator 
state file.

b) Type a file name. Use a name that describes the emulator 
state.
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c) Click Save.

For all three TI-SmartView™ handheld models, emulator 
state names will have the form filename.84state where 
filename is the name you gave the file and 84state indicates 
that the file is an emulator state created by the 
TI-SmartView™ program.

Loading an emulator state

1. Click File > Load File.

2. In the dialog box:

a) Navigate to the folder that contains the emulator state file.

b) Click the emulator state name to highlight it.

c) Click Open.

Resetting the emulator state

Resetting the emulator state returns the TI-SmartView™ software to 

the TI-83 Plus.fr factory-default settings. The optional View3™ pane 
(center) and the right pane are shown. The key press history is 
cleared. If a script is open, it is stopped, but remains open. 

1. Click Tools > Restore Default State.

2. In the dialog box, click Yes to confirm that you want to reset the 
emulator state.

Saving handheld data to the computer

By saving data (lists, matrices, programs, etc.) from the 
TI-SmartView™ emulator to files on the computer, you can make 
backup copies of that data. If you delete the data from the 
TI-SmartView™ emulator, you can load the handheld files from the 
computer at any time.
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1. Click File > Save Calculator File.

The Device Contents dialog box lists the data items on the 
TI-SmartView™ handheld, which may take several seconds.

2. Click an item to highlight it.

• To select multiple items, hold down Ctrl on a PC keyboard or 
Cmd on a Macintosh® keyboard as you click each additional 
item.

• To select a range of items, click the first item in the range. 
Then hold down Shift and click the last item in the range.

3. Click Save Selected Item(s).

4. In the dialog box, navigate to the folder in which you want to store 
the files.

• Be sure to either open the folder or click the folder to highlight 
it. The folder name must be shown in the File name box at 
the bottom of the dialog box.

• If necessary, create a new folder.

5. Click Save.

Each selected item is saved as a separate file on the computer. 
File names are assigned automatically. The file name’s extension 
identifies the data type.

If the folder already contains a file with the assigned name, you 
are prompted whether to overwrite the existing file.

The Device Contents dialog box stays open so you can select 
and save additional data items.

6. When you are finished, click Close.

Note: In the Device Contents dialog box, you can sort the list by 
clicking a heading. For example, click Name to sort by name and 
switch between ascending (a-z) and descending (z-a) order.
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Transferring files to supported handhelds

You can transfer files to the following handhelds: TI-83 Plus.fr, 
TI-83 Plus, TI-83 Plus Silver Edition, TI-84 Plus, and TI-84 Plus Silver 
Edition.

To transfer handheld files from the computer, use TI Connect™ 
software and an appropriate TI Connectivity Cable available from 
education.ti.com. Some handhelds come with a TI Connectivity 
Cable, which lets you connect the to the computer.

You can also transfer data directly between the TI-SmartView™ 
program and a connected handheld, much the same way you can 
connect two handhelds and transfer data between them.

Loading a handheld file from the computer

If you previously stored handheld files containing lists, programs, 
applications, etc., on your computer, you can load them into the 
TI-SmartView™ software. The files may be backups saved by the 
TI-SmartView™ program or files transferred to the computer from a 
handheld.

1. Click File > Load File.

2. In the dialog box:

a) Navigate to the folder that contains the file you want to load.

b) Click the file name to highlight it.

c) Click Open.

If the TI-SmartView™ program already contains a data item with 
that name, you are prompted whether to overwrite the existing 
item.

http://education.ti.com
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Handheld file names on the computer

Handheld file names have the form:

filename.8x?

where filename is as close as possible to the data item’s name on the 
handheld, 8x indicates the file was created by the TI-SmartView™ 
program or a supported handheld, and ? is a letter that identifies the 
type of data. Common data types are:

Note: If you load a Flash application file, the TI-SmartView™ program 
automatically installs the application.

If ? is: Type of data

c complex variable

d GDB (graph database)

g group

i picture

k Flash application

l list (real or complex)

m matrix

n real number

p program

s string variable

t table setup

v application variable

w window range

y equation

z user zoom window
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Transferring files from supported handhelds

The TI-SmartView™ program can load files transferred to your 
computer from the following handhelds: TI-83 Plus.fr, TI-83 Plus, 
TI-83 Plus Silver Edition, TI-84 Plus, and TI-84 Plus Silver Edition.

To transfer files from a handheld to the computer, use TI Connect™ 
software and an appropriate TI Connectivity Cable available from 
education.ti.com. Some handhelds come with a TI Connectivity 
Cable, which lets you connect the handheld to the computer.

You can also transfer data directly between the TI-SmartView™ 
program and a connected handheld, much the same way you can 
connect two handhelds and transfer data between them.

Updating the software from the Internet

Visit education.ti.com for free software updates that are periodically 
available for downloading. This implementation of the 
TI-SmartView™ software operates using the TI-84 Plus Silver Edition 
software emulation. If you update the operating system software, you 
must update it with the latest TI-84 Plus family operating system 
software.

http://education.ti.com
http://education.ti.com
http://education.ti.com
http://education.ti.com
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Working with images
Capturing handheld screens

You can capture the current handheld screen image using the 
TI-SmartView™ screen capture tool. When you capture a screen, the 
Screen Capture window is displayed. In this window, you can view, 
manipulate, and save screen images.

 Click Tools > Take Screenshot or click . 

A border is automatically added to each image when you capture it, 
but you can remove it.

You can capture up to 44 screens at a time. Each unsaved screen 
image is stored in memory until you close the main TI-SmartView™ 
window. Closing the Screen Capture window does not discard 
unsaved screen images. To capture additional images, delete images 
from the Screen Capture window.

Adding or removing a border

The toolbar button for adding or removing a border toggles between 

add  and remove  depending on whether or not the selected 
image contains a border. 

Adding or removing a border on a single screen image

1. Click the screen capture image to select it.

2. Click Edit > Remove Border or click  to remove the border.

—or—

Click Edit > Add Border or click  to add a border.
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Adding or removing a border from a group of screen images

1. Switch to thumbnail view.

2. Select the group of images. You can either:

• Click the first image you want to select, and then hold down 
Ctrl on the computer keyboard as you click each additional 
image.

• Select a range of images by clicking the first image in the 
range, holding down Shift, and clicking the last image in the 
range.

3. Click Edit > Remove Border or click  to remove the border

—or—

Click Edit > Add Border or click  to add a border.

Note: To select all of the images, click Edit > Select All. 

Saving a screen image

You can save screen images in TIF, GIF, or JPEG formats. The 
images are saved in your My Documents folder unless you specify a 
different location to save them. All images are saved at the size they 
are currently displayed.

1. Click the screen image you want to save.

2. Click File > Save Screen or click .

3. In the dialog box:

a) Navigate to the folder in which you want to store the screen 
image file.

b) Select the file type for the appropriate image format.

c) Type a file name. Use a name that describes the screen 
image.

d) Click Save.



Working with images 22

Note:

• If you have previously saved the selected screen image, clicking 

File > Save Screen or  overwrites the previous file. To save the 
file in a different location, with a different name, or as a different 
file format, you must click File > Save Screen As.

• To save all the images at once, click File > Save All Screens. 
When you do this, you select the location to save the files in the 
Save All window, but do not specify file names. Each screen 
image is saved with its default file name. If that name already 
exists, you are prompted whether to overwrite the existing file.

Viewing screen images

When you capture a screen image, that image opens in the Screen 
Capture window. You can view the images individually or as a group 
of images, called thumbnails. A reference name is displayed under 
each image.
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 To view screen image thumbnails, click View > Thumbnails or 

click .

 To view individual screen images, click View > Single Screen or 

click .

Navigating among screen images

 To view the previous screen image, click View > Previous Screen 

or click .

 To view the next screen image, click View > Next Screen or 

click .

Zooming in or zooming out

You can zoom in or out on any single image to view a larger or 
smaller version of it. 

You can save a larger or smaller version of a screen image by 
zooming in or out before you save it. For example, to save an image 
that is larger than the standard size, zoom in until the image is the 
size you want and then save it.

 To display a larger screen image, click View > Zoom In or 

click .

 To display a smaller screen image, click View > Zoom Out or 

click .
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Dragging and dropping an image to another 
application

You can drag and drop any TI-SmartView™ screen image to paste it 
into another application. These images include the following:

• Saved or unsaved screen capture images

• View3™ pane screens

• The Large Screen image

Note: In the Screen Capture window, the selected image has a red 
border. However, the borders on the Large Screen image and the 

View3™ screens do not change color when you select them.

To drag and drop a screen image into another application:

1. Adjust the sizes of the windows of the two applications so that 
both of them fit on the computer screen.

2. To drag-and-drop the image:

a) Click the screen image to select it.

b) Drag the screen image from the TI-SmartView™ program 
and then drop it into the other application.
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Using key press history

What is the key press history?

Each key you click on the handheld is recorded automatically in the 
key press history. You can see the key press history from the key 
press history pane and the large screen pane. Using the key press 
history to see a listing of all the keys you’ve used has several 
benefits, including:

• If a calculation gives unexpected results, you can view the key 
press history to see if you entered the correct data.

• If you perform a calculation and then find you need to perform it 
repeatedly, you can copy those keys from the key press history 
and paste them into a script. When you need to repeat the 
calculation, you can play the script instead of re-entering all the 
key presses.

The key press history shows some key sequences in a different form 
than they are shown in the user’s guide for the TI-83 Plus.fr 
handheld. For example, suppose you display the handheld’s 
MEMORY menu.

• The user’s guide shows the key sequence as , where 

 is the 2nd function of the  key.

• The key press history shows the key sequence as  

, the actual keys you click.

Similarly, suppose you select the round( function from the MATH 
NUM menu.

• The user’s guide shows the function as round(.
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• The key press history shows    because 
those are the keys you click.

Showing or hiding the key press history

 Click View > Show/Hide Key Press History or click .

When the TI-SmartView™ right pane is showing, you may need to 
click the Key Press History tab to activate it. The right pane also 
shows tabs for Large Screen and any open scripts. The active tab has 
a colored line across its top.

You can also view and clear the key press history from the large 
screen pane. Click Show Key Press History or Hide Key Press 
History to show or hide the list of keys pressed. 
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When the key press history is shown on the large screen pane, you 
can click Clear Key Press History to clear the list of keys pressed.

Hiding the right pane does not clear the contents of the key press 
history or an open script.

Clearing the key press history

 Click Edit > Clear Key Press History, or click Clear Key Press 
History on the key press history or large screen pane. 

Clearing the key press history does not affect the contents of an open 
script in the TI-SmartView™ right pane.

Copying the key press history to another 
application

You can copy all or only a selected portion of the key press history to 
another application such as a word processor. You can copy the key 
graphics as they are shown in the key press history pane, or you can 
copy the key presses as font text characters.

Note: When you copy as font text characters, those characters use 
the TI84EmuKeys font or the TI83EMUFrenchKeys font. These fonts 
are installed on your computer automatically when you install the 
TI-SmartView™ software.

Copying keys as graphics

1. Select the keys you want to copy. To select all the keys, click 
Edit > Select All.

2. Click Edit > Copy, switch to the other application, and paste the 
keys at the appropriate location.

Note: 
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• You can also drag the selected keys to the new application.

• You can resize the keys after you copy or drag them to a new 
application.

Copying keys as font text characters

1. Select the keys you want to copy. To select all the keys, click 
Edit > Select All.

2. Click Edit > Copy As Font.

3. Switch to the other application, and paste the characters at the 
appropriate location.

In some applications, the pasted characters may be shown in the 
font that is in effect at that location, so they may not look anything 
like handheld keys.

4. If necessary, apply the TI84EmuKeys font or the 
TI83EMUFrenchKeys font to the characters. See the help file for 
the application you are using for details on how to apply a font to 
the characters.

Note: The script icons for text points, delays, pauses, and Go To 
Home commands cannot be copied as font text characters. They are 
ignored when you paste the copied characters into the other 
application.
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Using a script

What is a script?

A script is a series of key presses on the handheld that can be stored 
and played later. When you save a script, you can open it later and 
play it without having to re-enter all of the key presses.

Overview of using a script

After performing one or more calculations on the handheld, you can 
create a script that performs those same calculations without 
repeating the key presses to record a new script. You can:

• Copy keys from the key press history and paste them into the 
script.

You can:

• Play the script normally.

• Step-through one key at a time.

• Manually pause the script.

• Adjust the playing speed.

Create,
record,

and save
the script

Play
the

script

Close
the script

You can also:

• Insert text points.

• Insert pauses and delays.

• Insert a Go To Home command.

• Edit a script to make changes.
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• Edit the script as necessary so the keys work properly in the 
context of that script.

Showing or hiding the script pane

The open script is shown in the TI-SmartView™ right pane, which is 
also used to show the key press history. To toggle the right pane on 
and off:

 Click View > Show/Hide Key Press History or click .

The right pane shows tabs for the Key Press History, Large Screen, 
and an open script. The active tab has a colored line across its top. 
Click the appropriate tab to show its contents.

Hiding the right pane does not clear the contents of the open script or 
the key press history.

Recording a new script

1. Click File > New Script or click .

The TI-SmartView™ right pane opens automatically if it is not 
already open, and a new blank script appears in the pane. The 
new script has a tab at the top of the pane, with a colored line 
across its top to indicate it is active. The tab shows the script’s 
default name, which is Script 1, Script 2, etc.

Note: Only one script can be open at a time. If a script is already 
open, you must close it before you can record a new script.

2. Click Scripts > Record or click  on the script’s toolbar.

3. Click the keys on the handheld to record the key presses for your 
script.
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4. When you are finished, click Scripts > Stop or click .

Note:

• You can also insert Go To Home commands, text points, delays, 
and pauses in a script.

• You can help ensure that your script plays properly under various 
conditions by following a few simple guidelines explained below 
in “Tips for recording a script.” 

• You can reuse key sequences that you previously entered in the 
handheld. Copy the keys from the key press history and paste 
them into the script. 

Tips for recording a script

If you record a script assuming the handheld will always have its 
current settings, you may have problems later if you play the script 
with different handheld settings. Therefore, it is a good practice to add 
the necessary settings directly into the script. The following tips can 
help you create scripts that play correctly in a variety of situations.

At the beginning of a script:

• Insert a Go To Home command to ensure the script starts on the 
handheld’s home screen. This lets your script begin at a known 
starting point, regardless of what screen is shown on the 
handheld when you play the script.

• Press   7 2 2 to reset the memory to its defaults.

When graphing:

• Press  before entering an equation into the Y= editor.

• Insert a Pause command after graphing a function.
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When using variables, lists, and statistical data:

• Clear a variable before storing to it.

• Press   4  to clear all lists before storing to them.

• Press  5  to execute SetUpEditor, which clears the 
stat editor. This command removes all list names from the stat 
editor and then restores list names L1 through L6 to columns 1 
through 6.

When selecting an item from a menu:

• Press the number or letter for that item. Suppose you need fMax( 
from the MATH menu. The script runs faster if you use  7 

(two key presses) instead of         
(eight key presses). 

When starting an application from within a script:

• If you share the script with other people using TI-SmartView™ 
software on different computers, remember that their 
APPLICATIONS menus may not list the same applications in the 
same order. Pressing  4 to start an application on your 
TI-SmartView™ may not start the same application on theirs.

• Instead, your script should press  to display the 
APPLICATIONS menu and then display a text point telling the 
user to select the appropriate application from the list.

At the end of a script:

• Insert a Pause command. This is particularly useful if a script 
displays text points that you want the user to see after the script 
finishes. Otherwise, text points are closed automatically at the 
end of a script.

Note: When resetting the memory, clear only the applicable portion of 
the memory. Using   7 1 2 to reset all RAM is not required in 
most situations.
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Playing a script

After recording a new script or opening an existing one, you can play 
it. You cannot play a script while you are recording it.

1. Select the tab for the appropriate script. The active tab has a 
colored line across its top.

2. Click Scripts > Play or click .

Adjusting the script speed

You can vary the speed at which each key press in a script is 
executed, from Slow (approximately one key press every 5 seconds) 
to Fast (approximately one every 1/2 second).

1. Click Scripts > Adjust Script Speed.

2. In the submenu, click a speed in the displayed range.

Note:

• You can also use the slider in the script’s toolbar. Drag the slider 
to the appropriate position.

• The speed setting affects every key press in the script, which may 
not be what you want. Suppose the script enters numbers such 
as 425,237,234. Setting the speed to one key press every 2 
seconds takes 18 seconds to enter the number. Instead, you may 
want to use a faster speed and insert pauses or delays at certain 
points in the script.
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Saving a script

After recording a new script or editing an existing one, save the script 
so you can use it again later.

1. Select the tab for the appropriate script. The active tab has a 
colored line across its top.

2. Click File > Save Script or click .

For an existing script that was saved previously, the new version 
automatically overwrites the existing one. For a new script, the 
Save As dialog box opens.

3. If you see the dialog box:

a) Navigate to the folder in which you want to store the script 
file.

b) Type a file name. Use a name that indicates the purpose of 
the script.

c) Click Save.

For all three TI-SmartView™ handheld models, scripts 
names will have the form filename.84script where filename is 
the name you gave the file and 84script indicates that the file 
is a script created by the TI-SmartView™ software.

Note: If you do not want to save the changes you made to an existing 
script, close the script instead of saving it. Click the X in the script tab 
to close the script. When prompted whether to save the changes, 
click No.

Saving a copy of a script

Sometimes you may need a script that is similar to an existing one but 
with some changes. Instead of recording a new script, it may be 
easier to copy the existing script, edit it, and save it with a new name.
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1. Open the script you want to copy. The active tab has a colored 
line across its top.

2. Click File > Save Script As. 

Note: Do not click .

3. In the dialog box:

a) Navigate to the folder in which you want to store the copy.

b) Type a file name. Use a name that indicates the purpose of 
the script.

c) Click Save.

Note: If you change a script and want to keep those changes in the 

existing script, click File > Save Script or  before selecting Save 
Script As. Otherwise, the changes are saved in the copy but not in 
the original script.

Opening an existing script

After a script is recorded and saved, you can open it later and play the 
script again, edit it, or save a copy of it.

1. Click File > Open Script or click .
Note: If a script is already open, you must close it before you can 
open another one.

2. In the dialog box:

a) Navigate to the folder that contains the script file.

b) Click the script name to highlight it.

c) Click Open.

The script opens in the TI-SmartView™ right pane. A tab with the 
script name appears at the top of the pane along with tabs for Key 
Press History and Large Screen. You can click any of those tabs to 
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jump from one to the other. The active tab has a colored line across 
its top.

Note: The most recently used scripts are listed at the bottom of the 
File menu. Click a script name to open it. If another script is already 
open, you must first close it before you can open a new script.

Because you can adjust the size of the TI-SmartView™ window, the 
right pane may not always be fully visible. When this happens, left 
and right arrows appear on the right of the tab area. Click these 
arrows to scroll left and right along the available tabs. 

Closing a script

When you are finished using a script, you may want to close it. This 
removes the script tab from the right pane. If the script is not saved, 
you are prompted whether to save it.

Note: Since only one script can be open at a time, you must close the 
open script before you can record a new script or open an existing 
script.

 Click File > Close Script or click the X on the script tab.

Stepping through a script

You can step through a script one key press at a time. This is the 
same effect as if you had used pause commands to halt the script 
between every key press. Depending on the length of the script, you 
may want to step through all or only parts of it.

Click to close the script.
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Stepping through a script from the beginning

In the script pane, instead of playing the script:

1. Click Scripts > Step Through or click  to start the script.

Note: Do not click Scripts > Play or .

The script pauses automatically after every key press.

2. Click  repeatedly to step through each key press.

3. After stepping through a series of key presses, you can click  
to play the remaining key presses continuously.

Stepping through part of a script

In the script pane:

1. Click Scripts > Play or click .

2. Click Scripts > Pause or click  to pause at a location before 
you want to start stepping through.

3. Click Scripts > Step Through or click  repeatedly to step 
through each key press.

4. After stepping through a series of key presses, you can click  
to play the remaining key presses continuously.

You can repeat steps 2 - 4 as often as necessary to step through 
different parts of the script.
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Stopping a script while stepping through it

While you are stepping through a script, Scripts > Stop or  may 
not be available. If not, you can:

1. Click  to play the script.

2. Then click .

Stopping a script

When you finish recording a script, you need to stop recording. When 
you play a script, you may want to stop the script manually at some 
time before it would normally end.

 Click Scripts > Stop or click .

Unlike when you pause a script, you cannot continue playing the 
script from the location where it stopped. You can only replay the 
script from the beginning.

Pausing a script

At various times while a script is running, you may want to halt it 
temporarily. For example, you may want to view an intermediate 
result or graph before continuing with another operation that changes 
the handheld screen or graph. You can either pause the script 
manually or insert a pause command directly into the script.
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Pausing the script manually

In the script pane, while the script is playing:

 Click Scripts > Pause or click .

The Play  button changes to Pause  when you play the 
script. After you pause the script, the button changes back to Play. 
Click Play again when you are ready to continue the script.

Inserting a pause command in the script

In the script pane:

1. Click the location where you want to insert the pause.

The cursor appears at that position.

2. Click Scripts > Insert Pause or click  at the bottom of the 
script pane.

 appears in the script to mark the location of the pause. When 
you play the script, it always halts at this pause command.

To continue, click Scripts > Play or click .

Deleting an existing pause command

Delete the  icon the same way you would delete any other key 
press in the script.
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Inserting a delay into a script

In some cases, you may want to delay the script a specified period of 
time before it continues to the next key press. For example, you may 
want to display a result or graph for a few extra seconds before the 
script executes the next key press.

Inserting a delay

In the script pane:

1. Click the location where you want to insert the delay.

The cursor appears at that position.

2. Click Scripts > Insert Delay or click  at the bottom of the 
script pane.

 appears in the script to mark the delay.

A delay has the same effect as a blank key press. It lasts as long as a 
single key press (as determined by the script’s speed setting) and has 
no other effect on the script.

For a longer delay, insert more than one. For example, suppose the 
script speed is set for one key press every second. To delay five 
seconds, insert five delays.

Note: If you do not know how long to delay the script, consider 
inserting a pause instead. After the script pauses, it does not start 

again until you click Scripts > Play or click  to continue.

Deleting an existing delay

Delete the  icon the same way you would delete any other key 
press in the script.
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Inserting a text point into a script

If you use a script to show a presentation, you may want to display a 
text screen at certain locations to explain a result or describe what the 
script will be doing next.

Inserting a new text point

In the script pane:

1. Click the location where you want to insert the text point.

The cursor appears at that position.

2. Click Scripts > Insert Text or click  at the bottom of the script 
pane.

3. In the dialog box:

a) Type the text using your computer’s keyboard. You cannot 
use the handheld to enter text in this dialog box.

b) Click Enter.

 appears in the script to mark the text point.

Note: 

• When you run the script, the text is displayed in a separate text 
pane that opens below the script. That text pane closes 
automatically when the script stops. To leave the text pane open 
for a longer time, insert a pause or delay immediately after the 
text point or at an appropriate location before the end of the 
script.

• The text from all text points in the script is placed one after 
another in the text pane. As necessary, you may need to scroll to 
see all the text.

• You can change the size of the displayed text by dragging the 
slider located in the area between the script pane and the text 
pane.
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Editing an existing text point

In the script pane:

1. Double-click the  marker.

The Text Point Dialog box opens.

2. Edit the text as necessary.

3. Click Enter.

Deleting an existing text point

Delete the  marker the same way you would delete any other key 
press in the script.

Inserting a Go to Home command

A script executes each key press in sequence. However, these key 
presses may have different effects depending on what screen (Home, 
Graph, Table, etc.) is shown on the handheld when you play the 
script. By using a Go To Home command at the beginning of a script, 
you can ensure that it begins on the Home screen.

Inserting a new Go To Home

In the script pane:

1. Place the cursor at the beginning of the script.

2. Click Scripts > Insert Go To Home Screen or click  at the 
bottom of the script pane.

 appears in the script to mark the location of the command.
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Note: You can insert a Go To Home command at any location in your 
script. While you are recording key presses inside a script, however, it 
is usually better to record the actual key presses used to display the 
Home screen.

Deleting an existing Go To Home command

Delete the  icon the same way you would delete any other key 
press in the script.

Editing a script

Editing a script is similar to editing a text document. For example, you 
can drag the mouse to highlight a series of keys the same as you 
would drag to highlight text in a word processor. (You can also hold 
down Shift and use the arrow keys on your computer keyboard.)

Inserting key presses or script elements (pauses, delays, etc.)

With the script shown in the right pane:

1. Click Scripts > Record or click .

2. Click the location where you want to insert the keys or script 
elements.

Note: Be sure to position the cursor after you start recording. If 
you position the cursor first, it automatically jumps to the 
beginning of the script when you start recording.

3. You can:

• Click the keys you want to insert.

– or –

• Use the buttons at the bottom of the script pane to insert a 
text point, delay, pause, or Go To Home command.



Using a script 44

4. When you are finished, click Scripts > Stop or click .

Deleting key presses or script elements

With the script shown in the right pane, either:

• Place the cursor immediately to the left of the items you want to 
delete. Then press Delete on your computer keyboard.

– or –

• Place the cursor immediately to the right of the items you want to 
delete. Then press Backspace on your computer keyboard.

– or –

• To delete multiple items at one time, highlight the items. Then 

click Edit > Cut or click  on the script’s toolbar.

Moving items to a different location

With the script shown in the right pane:

1. Highlight the items you want to move.

2. Click Edit > Cut or click .

3. Click the location where you want to insert the items.

4. Click Edit > Paste or click .

Note: You can also use the mouse to drag the highlighted items to 
the new location.

Copying items to a different location

With the script shown in the right pane:

1. Highlight the items you want to copy.
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2. Click Edit > Copy or click .

3. Click the location where you want to insert the copy.

4. Click Edit > Paste or click .

Note: You can also hold down Ctrl on your computer keyboard and 
use the mouse to drag a copy of the highlighted items to the new 
location.

Copying a script to another application

You can copy all or only a selected portion of a script to another 
application such as a word processor. You can copy the key graphics 
as they are shown in the script pane, or you can copy the key presses 
as font text characters.

Note: When you copy as font text characters, those characters use 
the TI84EmuKeys font or the TI83EMUFrenchKeys font. These fonts 
are installed on your computer automatically when you install the 
TI-SmartView™ software.

Copying keys as graphics

1. Open the appropriate script.

2. Select the keys you want to copy. To select all the keys, click 
Edit > Select All.

3. Click Edit > Copy, switch to the other application, and paste the 
keys at the appropriate location.

Copying keys as font text characters

1. Open the appropriate script.

2. Select the keys you want to copy. To select all the keys, click Edit 
> Select All.
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3. Click Edit > Copy As Font.

4. Switch to the other application, and paste the characters at the 
appropriate location.

In some applications, the pasted characters may be shown in the 
font that is in effect at that location, so they may not look anything 
like handheld keys.

5. If necessary, apply the TI84EmuKeys font or 
TI83EMUFrenchKeys font to the characters.

Note: The script icons for text points, delays, pauses, and Go To 
Home commands cannot be copied as font text characters. They are 
ignored when you paste the copied characters into the other 
application.

Locating common scripts

If you have access to scripts written by other people, you can open 
and play those scripts on your own computer. Texas Instruments 
provides a number of scripts that perform commonly used operations. 
Check the Texas Instruments web site at education.ti.com. 

By using available scripts and viewing their content, you can get 
ideas about how to create additional scripts for automating your own 
operations.

http://education.ti.com
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Connecting a calculator 
Using a connected handheld to control 
TI-SmartView™ software

You can connect a TI-84 Plus or TI-84 Plus Silver Edition handheld to 
your computer via a USB cable, run the SmartPad™ application, and 
use the handheld as a remote keyboard for the TI-SmartView™ 
software. If you press a series of keys on the handheld, those same 
key presses are repeated on the handheld image in the 
TI-SmartView™ software. This is useful if you feel more comfortable 
pressing real keys on a handheld but want to see the results on the 
computer.

Notes: 

• The SmartPad™ App must be installed on a TI-84 Plus or 
TI-84 Plus Silver Edition handheld.

• The TI-84 Plus family calculator must have an operating system 
version that supports the SmartPad™ App. 

• The SmartPad™ App is not compatible wtih the TI-83 Plus.fr 
handheld or the TI-84 Plus mode of the TI-Nspire™ handheld. 
However, you can use a TI-84 Plus or TI-84 Plus Silver Edition 
handheld as a remote keyboard for all three TI-SmartView™ 
handheld modes.

Checking the handheld’s operating system

Not all TI-84 Plus or TI-84 Plus Silver Edition graphing handhelds 
have an operating system that can control the TI-SmartView™ 
software using the SmartPad™ App. To check your handheld:

 Press y L and then select 1:About.
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The operating system number, immediately below the handheld 
name, must be 2.40 or later. For example:

If you need to upgrade your operating system, go to education.ti.com.

Connecting the handheld to the computer

You must use the Standard-A to Mini-B USB Cable that comes with 
your TI-84 Plus handheld. Other TI Connectivity Cables are not 
supported. If you need to purchase a cable, go to education.ti.com.

http://education.ti.com
http://education.ti.com
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1. Firmly insert the cable’s standard USB connector into a USB port 
on the computer.

2. Insert the cable’s mini USB connector into the handheld’s USB 
port. The TI-84 Plus port is at the top right edge of the handheld. 

3. Turn on the handheld.

The first time you turn on the handheld, the computer may detect 
it as new hardware and display a wizard or dialog box that 
prompts you to install a driver for the handheld.

If you are prompted for a driver, cancel the wizard or dialog box 
and return to the desktop. The handheld will use the computer’s 
default USB driver.
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Controlling TI-SmartView

1. Connect the handheld to your computer and start the 
TI-SmartView™ software.
On the connected handheld, press  and run the SmartPad™ 
App. (The application will not run if the handheld is not 
connected.)

The SmartPad™ title screen appears.

Note: The handheld shows this title screen as long as the 
SmartPad™ App is running. All key presses and results appear 
on the computer only.

2. Press keys on the connected handheld to control the 
TI-SmartView™ software.

3. When you are finished, either:

• Press y  on the connected handheld.

– or –

• Disconnect the USB cable.

Notes

• While a handheld is connected, you can continue to perform 
operations by clicking keys on the TI-SmartView™ handheld 
image. You can also run applications (such as Cabri® Jr., 
Inequality Graphing, or Transformation Graphing) or any 
programs stored in the TI-SmartView™ emulator state.

• All calculations use the TI-SmartView™ emulator state, not the 
connected handheld. If the connected handheld contains data, 
applications, or programs that are not in TI-SmartView™ 
emulator state, you cannot access those items.

- Suppose the variable a equals 20 on the handheld but is not 
defined in the TI-SmartView™ emulator state. If you calculate 
5a, the answer will not be 100 as you may expect.

- Even if the TI-SmartView™ emulator state contains the same 
application or program as the handheld, it may be in a 
different location on the menu. For example, an application 
may be item 3 on the APPLICATIONS menu on 
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TI-SmartView™ and item 2 on the connected handheld. So 
pressing  2 may give unexpected results.

• The connected handheld turns off automatically if not used for 
about five minutes. To continue using it, turn the handheld on.

• You do not need TI Connect™ software on your computer to 
control the TI-SmartView™ software.

Transferring data to and from a connected 
handheld

With a TI-83 Plus.fr, TI-84 Plus, or the TI-84 Plus mode of the 
TI-Nspire™ handheld, you can connect it to another compatible 
handheld and transfer data between them. Likewise, you can transfer 
data between TI-SmartView™ software and a connected handheld. 
Compatible handhelds are the TI-83 Plus.fr, TI-83 Plus, TI-83 Plus 
Silver Edition, TI-84 Plus, TI-84 Plus Silver Edition, and the 
TI-84 Plus mode of TI-Nspire™.

Note: To connect the handheld, you must use the USB Silver Edition 
cable available from education.ti.com. Other TI Connectivity Cables 
are not supported for this type of connection.

1. Plug the cable’s USB connector into any USB port on the 
computer, and plug the other end of the cable into the handheld’s 
I/O link port.

2. Click Tools > Establish Connection.

A dialog box lists all devices connected to the computer with a 
USB Silver Edition cable.

If the device is not listed, check both ends of the cable and make 
sure they are connected properly. Then click Refresh to update 
the list.

3. Click the applicable device to highlight it, and then click Select.

The TI-SmartView™ software connects the device and displays 
Device Connected on the title bar. Also, the Establish 
Connection menu item changes to Disconnect.

http://education.ti.com
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4. Use   to transfer the data by using the detailed 
instructions given in the Communication Link chapter of the 
TI-83 Plus.fr guidebook. The general steps are:

a) Set the receiving unit to receive.

b) On the sending unit, select the applicable data items and 
transmit them.

The TI-83 Plus.fr guidebook is available on the TI-SmartView™ 
installation CD, or you can download it from 
education.ti.com/guides.

5. When you are finished transferring data, click 
Tools > Disconnect.

You can use the TI-SmartView™ software when the handheld is 
connected, but it is a good practice to use the disconnect tool when 
you are done. Do not just unplug the cable.

Note: For TI-84 Plus family handhelds, if you unplug the USB 
connector from the computer while the handheld connection is active, 
the computer may lock up and need to be rebooted.

http://education.ti.com/guides
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FAQs and keyboard 
shortcuts

Frequently asked questions

I clicked on the handheld screen to select an option, but nothing 
happened. Why?

On the handheld image in the TI-SmartView™ software, use the 
mouse to click keys the same as you would use your finger to press 
keys on a real handheld. And just like on a real handheld, you cannot 
press the screen to select an option, even though it is very tempting 
on a computer. You must click the same keys you would press on the 
handheld.

I typed a name and got an error message. Why?

You probably typed the name on your computer keyboard. By default, 
the keyboard is in its normal shortcut mode, where [ A ] is a shortcut 
to . To put the keyboard in its alpha typing mode, click on 
the handheld keyboard or press [ F7 ] on your computer keyboard. 
After you type the alpha character, the keyboard returns to its normal 
mode.

To lock the alpha key, click   on the handheld keyboard or 
press [ F6 ] [ F7 ] on your computer keyboard. To return to the normal 
mode, click  or press [ F7 ].

I am having trouble editing a script. How do I figure out where I 
need to be in the script to make a change?

Because scripts record key presses, it might be easier to step through 

the script by clicking  on the script toolbar or to change the 
script’s playback speed so that you can see exactly where you need 
to make the change.
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The TI-SmartView™ handheld is too big for my computer screen. 
How do I change the size?

Click View > Size and then select a smaller size. In addition to 
choosing small, medium, and large sizes, you can click and drag the 
TI-SmartView™ window borders to display the application in a 
window that is a custom size.

Some keys show a  in the key press history or in a script. 
What does that mean?

When you hold down an arrow key for more than a certain amount of 
time, the cursor begins to scroll. The key that starts this scrolling 

feature has a clock icon attached to it. For example: 

The amount of scrolling represented by this single key icon is 
equivalent to pressing the key and holding it down. If you run a script 
that contains one of these keys, the TI-SmartView™ software 
reproduces the equivalent number of key presses. 

Some of the keys show a  in the key press history or in a 
script. What does that mean?

When you press an arrow key multiple times in a row, the key press 
history or script displays one arrow with a counter in the corner. The 
counter indicates the number of times the arrow key was pressed. 
This feature makes it much easier to see how many times the arrow 

key was pressed. For example, it is much easier to read  than 

it is to read        

.
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Using the computer keyboard

You can use the computer keyboard to enter data into the 
TI-SmartView™ software. However, the keyboard does not work the 
same as using the TI Keyboard with a handheld. You cannot simply 
use the keys like a QWERTY keyboard to type A through Z. By 
default, the keys are shortcuts to a corresponding key on the 
handheld.

Note: You can use the keyboard to access second functions and 
alpha characters, but you must use  and the same as you would 
on the handheld.

Where possible, shortcut keys correspond to alpha characters on the 

handheld. For example, the handheld has keys such as  

   , where labels above the keys 
indicate second functions and alpha characters.

Keys such as  and  do not have associated alpha 
characters. Refer to the table later in this topic to find the shortcut to 
those keys. For example, [ Shift ]+[ V ] is the shortcut to .

Alpha typing mode for A through Z and other characters

When you use , the handheld keyboard switches automatically 
to its alpha typing mode, where pressing [ A ] gives you an A, not the 
 key.

On the computer keyboard, press: To do this:

[ A ] Shortcut to .

[ F6 ] A,where [ F6 ] is the shortcut to  Show the TEST menu.

[ F7 ] A,where [ F7 ] is the shortcut to  Type the letter A.
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1. Click  on the TI-SmartView™ screen or press [ F7 ] on the 
computer keyboard.

The cursor changes to .

2. Press the applicable key on the computer keyboard.

Keys without an associated alpha character act the same as they do 
in the normal mode. For example, [ F1 ] is still a shortcut to .

After you type the alpha character, the handheld keyboard returns to 
its normal mode.

Note:

• To lock the alpha key so you can type multiple alpha characters, 
click   or press [ F6 ] [ F7 ] on the computer keyboard. 

To unlock the alpha key, click  or press [ F7 ] on the 
computer keyboard.

• In alpha typing mode, pressing [ 0 ] through [ 9 ] produces the 
same results as pressing  through  on the handheld. 

Pressing [ 1 ] types Y (the alpha character for ), not 1. To type 
a number, be sure the keyboard is not in the alpha typing mode. 
For example, to type TEST1, press either:

- [ F7 ] [ T ] [ F7 ] [ E ] [ F7 ] [ S ] [ F7 ] [ T ] [ 1 ]

- or [ F6 ] [ F7 ] [ T ] [ E ] [ S ] [ T ] [ F7 ] [ 1 ].

To type: Press:

A through Z [ A ] through [ Z ]

space [ space bar ]

: (colon) [ Shift ]+[ : ]

" (double quote) [ Shift ]+[ " ]

? (question mark) [ Shift ]+[ ? ]

q (theta) [ 3 ]
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• When you are prompted to enter a name for a program or group, 
the handheld locks the alpha key automatically.

• Alpha characters are used to enter text characters only. You 
cannot use alpha characters to enter function names. For 
example, typing COS or FMIN does not calculate that function. 
You must press the appropriate function key or select the function 
from a menu.

Note: Some handheld keys have more than one shortcut, but the 
table shows only the most straightforward ones. For example, you 
can also type 1 by pressing [ Y ] (because Y is the alpha character for 
 on the handheld). However, it is much easier to press [ 1 ].
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Computer keyboard shortcuts

Using your computer keyboard, you can press the key(s) listed below 
the handheld key icons instead of clicking those keys on the 
TI-SmartView™ handheld image. For example, you can press F1 on 

your computer keyboard instead of clicking  on the handheld 
image to display the Y= editor.

Note: Some handheld keys have more than one shortcut, but the 
table shows only the most straightforward ones. For example, you 
can also type 1 by pressing [ Y ] (because Y is the alpha character for 
 on the handheld). However, it is much easier to press [ 1 ].


[ F1 ]


[ F2 ]


[ F3 ]


[ F4 ]


[ F5 ]


[ F6 ]


[Shift]+[M]


[Delete]


[ ]


[ ]


[ F7 ]


[Shift]+[X]


[Shift]+[S]


[ ]


[ ]


[ A ]


[ B ]


[ C ]


[Shift]+[V]


[Backspace]


[ D ]


[ E ]


[ F ]


[ G ]


[Shift]+[ ^ ]


[ I ]


[ , ]


[Shift]+[ ( ]


[Shift]+[ ) ]


[ / ]


[ N ]


[ 7 ]


[ 8 ]


[ 9 ]


[Shift]+[ * ]


[ S ]


[ 4 ]


[ 5 ]


[ 6 ]


[ - ]


[ X ]


[ 1 ]


[ 2 ]


[ 3 ]


[Shift]+[ + ]


[Shift]+[~]


[ 0 ]


[ . ]


[Shift]+[ - ]


[Enter]
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Legal Information
Texas Instruments (TI) Support and Service

 

TI Product and 
Services Information

For more information about TI products and 
services, contact TI by e-mail or visit the TI 
Internet address.

E-mail: ti-cares@ti.com
Internet: education.ti.com

Service and Warranty 
Information

For information about the length and terms of the 
warranty or about product service, refer to the 
warranty statement enclosed with this product or 
contact your local Texas Instruments 
retailer/distributor.

mailto:ti-cares@ti.com
http://education.ti.com
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saving handheld data 15
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viewing 22, 23
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