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Introduction to GPS I - Two Dimensional Preliminaries

NOTE:  While working with this lesson, we recommend that you open a 2D-Plot Window and 
then choose the option Window > Tile > Vertically.  Later in this lesson, you will be asked to 
modify the range of the window using the Plot Window options Set > Plot Range.  Using this 
screen format, you will be able to follow the lesson and view the corresponding graphics 
displays that you will generate.

Acknowledgement: This activity was inspired by a talk given by Mr. Ralph Irons of Central 
Shenandoah Valley Regional Governor's School at the 2001 T3 International Conference in 
Colombus, OH.  His presentation can be found in the Proceedings of that Confence call "2001 a 
Technological Odyssey."  The presentation given here is distinctly different from that of Mr. 
Irons, but his excitement and exposition were the inspiration. 
 

Background - Step 1:

The classical definition of a circle is: the locus of all points equidistant from a fixed point.  The 
measure of the distance from the fixed point is called the radius of the circle and the fixed point 
itself is called the center of the circle.  In the cartesian coordinate system a point is designated by 
a pair of real numbers, say (c1, c2).  Thus, we need three parameters to completely describe a 
circle: c1, the x-coordinate of the center; c2, the y-coordinate of the center; and r, the radius of 
the circle.  Analytically, this tells us that the definition of a circle is the set of all points, (x, y) 
that satisfy the following equation based on the distance formula:     

#1:
        2           2    2
(x - c1)  + (y - c2)  = r 

Derive allows you to plot expressions such as #1 provided the values of the parameters are 
defined.  For example, if you wished to see the graph of a circle with center at (-1, 2) and radius 
3, you simply highlight expression #1,  click on the SUB toolbar button and type in the 
respective new values for c1, c2, and r variables (parameters).  Click on OK to replace the 
parameters with your values. Switch to the plot window and click on the plot toolbar button or 
click Insert > Plot.  If you receive a message that says "Unable to Plot Highlighted Expression", 
open a 2D-plot window and click on Window > Approximate Before Plotting and try again.  The 
resulting plot is the set of points, (x, y), satisfying the new values substituted in expression #1.

What if you know some points on a circle and want to find the equation of the circle?  This is the 
reverse of our previous example.  We need to find the values of the parameters c1, c2, and r.  
Once again, expression #1 is our road to success.  The first question we need to address is, how 
many points uniquely determine a circle?  Since we have three parameters to determine, it is 
sensible to guess that three points should do the job.  Of course, the points can not be co-linear.  
Let's give it a try.  

Suppose we wish to find a circle passing through the three points (1, 1), (-2, 0), and (-1. -1).  
First we copy expression #1 into the Derive Command Entry Line by highlighting it and pressing 
the F3 key.  Substitute 1 for x and 1 for y.  Press the Enter key.  The expression will remain in 
the Command Entry Line.  Alter the expression to reflect entering -2 for x and 0 for y.  Press 
enter again.  Repeat the process for the point (-1, -1).   This results in the following three 
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equations.  

#2:
        2           2    2
(1 - c1)  + (1 - c2)  = r 

#3:
         2           2    2
(-2 - c1)  + (0 - c2)  = r 

#4:
         2            2    2
(-1 - c1)  + (-1 - c2)  = r 

Derive has a very powerful solver for systems of polynomial equations.  Press Solve > System.  
An inquiry box will ask you how many equations you wish to solve.  Indicate 3.  A display 
similar to the one shown below appears.  Since you have the equations as part of your Derive 
worksheet, you need only enter the numbers of the expressions that have the three equations as 
shown below.     Click on the blank space in the Solution Variables area and then click Solve.

The following two expressions are displayed on your Derive worksheet.  Note that in expression 
#6 there are two answers.  Why? 

#5:
      ⎡        2           2    2           2           2    2      
SOLVE(⎣(1 - c1)  + (1 - c2)  = r , (-2 - c1)  + (0 - c2)  = r , (-1 

     2            2    2⎤              
- c1)  + (-1 - c2)  = r ⎦, [c1, c2, r])

#6:
⎡        1          1         √10           1          1          
⎢c1 = - ⎯ ∧ c2 = ⎯ ∧ r = ⎯⎯⎯, c1 = - ⎯ ∧ c2 = ⎯ ∧ r = - 
⎣        2          2          2            2          2          
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 √10 ⎤
⎯⎯⎯⎥
  2  ⎦

At this point we enter the solution for c1, c2, and r into expression #1 and plot the circle.

#7:
⎛       1 ⎞2   ⎛     1 ⎞2   ⎛ √10 ⎞2
⎜x - - ⎯⎟  + ⎜y - ⎯⎟  = ⎜⎯⎯⎯⎟ 
⎝       2 ⎠    ⎝     2 ⎠    ⎝  2  ⎠ 

Exercise
     1.  Choose three arbitrary non colinear points on the plane and determine the equation of a 
circle through these three points.  Graph the resulting circle.

Background - Step 2

Now that we have done a brief study of circles, we will consider how they may be applied to 
GPS System.  Let's suppose that you are in a flat plane located at the point having grid 
coordinates (-1, 2), but you don't know that fact.  Suppose there are transmitters located at grid 
coordinates, (3, 0), (-3, 1), and (0, 1).  What you do know is that you are located at distances of 
the square root of 20, the square root of 5, and the square root of 2, respectively from these three 
points.    You will use that fact to locate your position on the plane.

The first thing that you do is write the equations for the three circles centered at the transmitters 
and having radii equal to their distance from your position on the plane.

#8:
       2          2      2
(x - 3)  + (y - 0)  = √20 

#9:
        2          2     2
(x - -3)  + (y - 1)  = √5 

#10:
       2          2     2
(x - 0)  + (y - 1)  = √2 

Once we have the equations, it is natural to look at their graphs and find the intersection point(s). 
Highlight each of the expressions in the algebra window and plot them.   Note that even though 
there are only two independent variables, you need to plot all three of the expressions to find 
your position.  Why?

You can solve the equations exactly using the Derive Solve > System command as we did 
before.  The result of this command is shown below.  Note that even though we had only two 
unknowns, we entered three equations.   

#11:
      ⎡       2          2      2          2          2     2       
SOLVE(⎣(x - 3)  + (y - 0)  = √20 , (x - -3)  + (y - 1)  = √5 , (x - 

  2          2     2⎤         
0)  + (y - 1)  = √2 ⎦, [x, y])
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#12: [x = -1 ∧ y = 2]

At this point, let's review what you know about circles.  In the following exercises draw a graph 
to illustrate that your answer is correct.

Exercises:
    2. Is it possible to find c1, c2, and r so that expression #1 has exactly one point, (x, y) that will 
satisfy the equation.
    3. Is it possible for two distinct circles to intersect at no point?  one point?
two points?
    4. Is it possible for three distinct circles to intersect at no point? one point?  two points?
   5. Why is it not possible to find three or more distinct circles that intersect in exactly three 
points?

A "2 Dimensional" GPS

NOTE:  The velocity given for the signal sent from the transmitters has no relation to the actual 
speed with which signals are sent from GPS sattelites or radio transmitters.  We are using this 
velocity only to keep the magnitude of the numbers we are dealing with more manageable so that 
the numbers do not get in the way of the exposition.  In part II we will deal with a more realistic 
situation.

Prior to beginning this unit, resize your graphics screen so that the range on the x-axis is (-300, 
900) with 4 intervals, and the range on the y-axis is (-200 , 800) with 5 intervals.  Also,because 
accuracy is important in GPS calculations set the decimal accuracy to 10 digits.  Use the Algebra 
Window's Declare >  Simplification Settings to set the Precision Digits to 10.

You know that you are located at a point somewhere in this plane region.  Assume that scale on 
the graphics screen is in miles.  You activate your GPS to locate your position.  It receives 
signals from three transmitters that have been placed in the plane at locations of loc1=(75, 150), 
loc2=(510, 110), and loc3=(150,20).  The transmitters all know their own position and the exact 
time as determined by an atomic clock  in the transmitter.  The transmitter clocks are 
synchronized on a regular basis so that the time at each transmitter is absolutely accurate.  Each 
transmitter broadcasts its coordinates and the time.  The broadcast signal travels at 200 miles per 
second.  

Your GPS is able to receive the signals and record the time that each signal is received.  
However, your GPS does not have a clock that is synchronized with the transmitters.  Thus, there 
is a time time discrepency, say d,  between the time recorded by your GPS receiver and the the 
actual time as determined by the synchronized atomic clocks in the transmitters.  The GPS 
records the signals that it received.  The times for each transmitter are subtracted from the time 
your GPS received them.  These are recorded as t1, t2, and t3.   The numbers correspond to the 
times from the respective transmitter locations. .

#13: t1 ≔ -0.8139056099

#14: t2 ≔ 0.7980845608
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#15: t3 ≔ -0.4685532484

The actual times that it took to travel from the trasmitters to your GPS are t1+d,  t2+d, and t3+d, 
where d is the time discrepency of your GPS.  Thus, we have three unknown values: the x and y 
coordinates of your position and d, the time discrepency of your GPS.

Your distance from each of the transmitters is the velocity of the signal multiplied by the time 
that it took to travel to the GPS.  

#16: d1 ≔ 200·(t1 + d)

#17: d2 ≔ 200·(t2 + d)

#18: d3 ≔ 200·(t3 + d)

But these distances are the radii of circles centered at each transmitter and passing through your 
position on the plane.  We are now in the situation of Step 2 above.  The one difference is that 
we now have three unknowns: x, y, and d.  However we have three equations to solve.  It may 
work out.  

#19:
        2            2     2
(x - 75)  + (y - 150)  = d1 

#20:
         2            2     2
(x - 510)  + (y - 110)  = d2 

#21:
         2           2     2
(x - 150)  + (y - 20)  = d3 

We simply use the Solve > System option as shown above and then approximate the result to 
obtain the following result.  NOTE: the first result is not shown here.  It is the exact symbollic 
solution to the system.  It is rather messy since it involves expressions with sums of radicals and 
fractions of VERY large numbers.  We want numbers that we can recognize.  However, this will 
be a decimal approximation and we may loose some accuracy.

#22:
      ⎡        2            2     2           2            2     2  
SOLVE(⎣(x - 75)  + (y - 150)  = d1 , (x - 510)  + (y - 110)  = d2 , 

         2           2     2⎤            
(x - 150)  + (y - 20)  = d3 ⎦, [x, y, d])

#23: [x = 452.5761121 ∧ y = 96.9671036 ∧ d = -1.092505996, x = 132 ∧ y = 

145 ∧ d = 1.1]

Because we have three unknowns, we, once again, have two possible solutions to the system of 
equations.  In this case we can rather easily eliminate one of them.  Note that if d = -
1.092505996 then each of the distances, d1, d2, and d3 will be negative.  This is nonsense.  We 
would have received the signals before they were sent.  Thus, you can conclude that your 
position is at (132, 145) and the time discrepency is 1.1 second.  Define d := 1.1 and graph 
expressions #19, #20, and #21.  NOTE: This can be done by holding down the <Ctrl> key and 
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highlighting all three expressions followed by switching to the 2D-plot window and clicking on 
the plot button.

#24:  define d:=1.1 by editing this line

After viewing the graph clear the value for d by typing d :=  .  This action frees the symbol d so 
that it can be a variable.

#25: clear d by editing this line to read d := 

It is time to try one on your own.  First clear the graphics screen by choosing the Edit > Delete 
All Plots from the 2D-plot menu.  Assume that you are working with a different GPS receiver, so 
you have no idea of the time difference between the transmitter clocks and your GPS clock.  You 
are still in the same region of the plane as in the example.   Here we go!

Exercise
    6.  Your GPS receives signals from three transmitters located at positions in the plane given as 
(320, 190), (50, 100), and  (570, 50), respectively.  The time differences recorded by your GPS 
receivers and the three transmitters are given as t1 := 3.113941029 seconds, t2 := 3.113941029 
seconds, and t3 := 4.102775637 seconds, respectively.  Enter these times by editing the lines 
below.

#26: enter t1 by editing this line

#27: enter t2 by editing this line

#28: enter t3 by editing this line

Edit the next three lines to give the formulas for the distance from each of the three transmitters.  
Don't forget that you need to include the time discrepency between the transmitters and your 
GPS in these formulas.

#29: enter the distance to transmitter #1 by editing this line

#30: enter the distance to transmitter #2 by editing this line

#31: enter the distance to transmitter #3 by editing this line
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Now that you have the distances, you can enter the three equations that you will need to solve in 
order to determine your position.on the plane.  Edit the three expressions below so that they 
contain the equations.

#32: equation 1

#33: equation 2

#34: equation 3

After editing the above lines, solve the equations you entered using the Solve>Equations option.  
In this case, the distances for either of the answers are positive.  However, we can eliminate one 
of the aswers rather easily.  It lies outside of the region of the plane where we know we are 
located.  Write the value for d, the time discrepancy, and plot the three circles. 

#35: value for d here

As a final exercise, you will demonstrate your understanding of the process by constructing a 
problem on your own for others to solve.

Exercise
    7.  Choose a set of 4 points that lie within the 2-D plot region of the plane that you have laid 
out and write down their coordinates. One of these points will be your position on the plane.  The 
other three will be the locations of the three transmitters.  Determine the distance of your point 
from each of the transmitters.  Finally decide on a value for the variable, d, which is the time 
discrepency between the transmitters clocks and the clock on your GPS.
         a. Determine the time that it takes for each of the signals sent from the
             transmitters to reach your GPS.
         b. Using d, determine the values for t1, t2, and t3, the differences 
             between the time sent by each transmitter and the time the signal 
             is received.
         c. Write out your problem in a manner similar to the example and 
             problem given above.
         d. Solve the problem and compare the answer with the coordinates
             for your position.  This is a check that you correctly constructed
             the problem.

Carl Leinbach: leinbach@gettysburg.edu 

#36: InputMode ≔ Word


