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Copyright © 2005, 2007, 2008 Texas Instruments Incorporated.
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their respective owners.



Contents

Contents iii

Important Information................................................................... ii

Getting Started....................................................................1
What's new in version 3.1.............................................................. 1
Overview of the TI-SmartView™ software ................................... 1
System requirements...................................................................... 2
Installing the TI-SmartView software............................................ 3
Things you need to know .............................................................. 7
Choosing a display option ............................................................ 9
Changing the size of the TI-SmartView screen........................... 10
Changing the color of the face plate.......................................... 10
Saving and loading an emulator state........................................ 11
Resetting the emulator state....................................................... 11
Saving calculator data to the computer ..................................... 12
Loading a calculator file from the computer ............................. 13
Updating the software from the Internet .................................. 15

Working with images ........................................................17
Capturing calculator screens........................................................ 17
Adding or removing a border ..................................................... 17
Saving a screen image.................................................................. 18
Viewing screen images................................................................. 19
Dragging and dropping an image to another application........ 20

Using the key press history...............................................23
What is the key press history? ..................................................... 23
Showing or hiding the key press history..................................... 23
Clearing the key press history...................................................... 24
Copying the key press history to another application ............... 24

Using scripts.......................................................................25
What is a script? ........................................................................... 25
Showing or hiding the script pane.............................................. 26
Recording a new script................................................................. 26
Tips for recording a script ............................................................ 27
Playing a script.............................................................................. 28
Adjusting the script speed ........................................................... 28
Saving a script............................................................................... 28
Saving a copy of a script .............................................................. 29
Opening an existing script ........................................................... 30
Closing a script.............................................................................. 30
Stepping through a script ............................................................ 30



iv Contents

Stopping a script ........................................................................... 32
Pausing a script .............................................................................32
Inserting a delay into a script....................................................... 33
Inserting a text point into a script ............................................... 34
Inserting a Go to Home command ..............................................35
Editing a script .............................................................................. 35
Copying a script to another application...................................... 37
Locating common scripts.............................................................. 38

Connecting a calculator or CBL 2/CBR 2 ........................... 39
Using a connected calculator to control Dissimilarities.............. 39
Transferring data to and from a connected calculator .............. 42
Using a connected CBL 2 or CBR 2 device ................................... 43

FAQs and keyboard shortcuts........................................... 47
Frequently asked questions.......................................................... 47
Using the computer keyboard ..................................................... 48

Legal information ............................................................. 53
Texas Instruments Support and Service ....................................... 53

Index .................................................................................. 55



Getting Started 1

Getting Started

What's new in version 3.1
• Key Press History— Review recently pressed keys from the key 

press history pane or on the large screen pane.

• Additional Color Capabilities— Change the TI-84 Plus image to 
use a different face plate option. The variety lets you create a custom 
look, or increase visibility for the visually challenged.

• Adjustable Screen Size— Use the small, medium, and large screen 
sizes or customize the screen size. When you size the screen by 
dragging the window border, the size of the freely scalable TI-84 Plus 
device image is sized automatically.

Overview of the TI-SmartView™ software
The TI-SmartView™ software gives you a TI-84 Plus calculator on your 
computer. The entire functionality of the TI-84 Plus is at your disposal, 
including the ability to load and use calculator files such as applications 
(Apps), lists, matrices, programs, and so on. The Apps that come already 
loaded on the TI-84 Plus Silver Edition are also included with the 
TI-SmartView™ software.

TI-SmartView™ software lets you show the TI-84 Plus to an audience 
without using calculator-specific projection equipment and gives you 
additional functionality that aids in presentations and demonstrations.

• Control the TI-SmartView™ software using a connected calculator. 
You can connect a TI-84 Plus or TI-84 Plus Silver Edition graphing 
calculator to the computer. When you press keys and perform 
calculations on the calculator, those actions are repeated 
automatically on the emulator in the TI-SmartView™ software. The 
connected calculator acts as a remote keypad.

• Supplement the current TI-84 Plus screen by using the View3™ pane 
to show three extra screens simultaneously. You can select any three 
of the following calculator screens: Y= editor, table, graph, stat plot, 
list, and window.

• Repeat demonstrations quickly and easily by using scripts to play 
back a series of keystrokes.

• View the history of your calculator entries as well as a large version 
of the current calculator screen, and open scripts by displaying the 
key press history window.
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• Capture screen images that you can save and use in other 
documents.

System requirements
The computer that you use to run the TI-SmartView™ software must 
meet the following hardware and software requirements.

• Windows Vista® (Home Premium/Ultimate/Business), Windows® XP 
(Home or Professional edition) with Service Pack 2; or Windows® 
2000 Professional edition with Service Pack 4.

• 900 MHz Pentium-compatible CPU 

• 512 MB RAM

• 125 MB of available hard-disk space

• CD-ROM drive or active Internet connection for installation

• Microsoft Internet Explorer 6.0 or later
Netscape® 5.0 or later
Opera 7.0 or later
Mozilla™ Firefox 1.0

Emulator 
(Pane 1)

View3™ 
(Pane 2)

Key Press History tab 
(Pane 3)
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Installing the TI-SmartView software
If you are installing a full version of the TI-SmartView™ software (as 
opposed to a trial version), find the CD key located on the CD case or CD. 
You need to enter the CD key during a full-version installation.

Before you begin
To install the software on your computer, you must have the appropriate 
privileges. You will need Administrator privileges on Windows®.  If you 
do not have the necessary privileges, contact your network administrator.

Installing the software
1. Close any applications that are open.

2. Insert the TI-SmartView™ CD into the CD-ROM drive.

The CD should launch automatically. If the CD does not launch, 
double-click the appropriate launch file on the CD. 

3. Click Next at the bottom of the Welcome screen, and click Next 
again on the Features screen.

The Destination screen displays.
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4. Click Next on the Destination screen to accept the default 
installation location, or click Browse to navigate to a different folder 
for application installation. 

A progress bar displays during installation. 

5. Click Finish on the screen that confirms successful installation. 
Double-click the TI-SmartView icon to start the application and 
activate the software.

If you have already purchased the software, you should activate it. 
Activating the software allows to you continue using it past the 30-
day evaluation period. It prevents unauthorized copying of the 
product onto more computers than the license agreement allows.

Activating the software
1. To begin the activation process, start the TI-SmartView™ program by 

double-clicking the icon. On the Activate Software screen, click 
Activate this software, and then click Next.
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2. Review the options displayed to determine which activation method 
you should use. Regardless of which activation method you prefer, 
you will need to supply the Serial Number and License Number 
included with the installation CD.
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• Internet— This method uses your Internet connection to 
activate your software. You provide the Serial Number and 
License Number.

• Web Portal— This alternative method takes you to a Web page 
where you can retrieve an Activation ID. The ID is displayed on 
the Web page. If you provide your e-mail address, the ID is also 
sent to you by e-mail.

• Phone— You provide a TI representative with the Serial Number 
and License Number as well as an Installation ID displayed on 
your screen. The representative then provides an Activation ID.

• I already have an Activation ID — After accepting a license 
agreement, you fill out a screen with the Serial Number, License 
Number, and the Activation ID.

3. Click an activation method, then click Next and follow the 
instructions to type the Serial Number, License Number, and 
Activation ID.

Note: When entering the CD key, be careful to not enter a zero for 
the letter O or a letter O for a zero. Similarly, do not confuse the 
number one with a lowercase letter L.

4. Type contact information and click Next.

5. Provide information to create a user profile (optional), and then click 
Next to complete software activation.

Opening the software on your computer

Double-click the TI-SmartView™ icon. The application starts.
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Things you need to know
The mouse pointer takes the place of your finger pressing keys 
on the calculator.

When you use the mouse, remember that the pointer takes the place of 
your finger. You must click the keys on the TI-SmartView™ emulator as 
you would press the keys on the TI-84 Plus. The calculator image in the 
TI-SmartView™ software is not fully interactive. For example, when you 
change mode settings, you might be tempted to click the mode setting 
on the calculator screen to select it. However, clicking on the screen does 
nothing. You must click the arrow keys to move the cursor to the desired 
setting and then click Í to select it.

Typing text using the computer keyboard doesn’t work unless 
you first place the keyboard in its alpha typing mode.

By default, the TI-84 Plus keyboard is in its normal shortcut mode, in 
which keys are simply shortcuts to calculator keys. For example, pressing 
[ A ] is the same as clicking  on the calculator. In this mode, you 
cannot directly type the letters A through Z.

To type a letter or other alpha character, click ƒ or press [ F7 ] first. 
For example, [ F7 ] [ A ] gives you an A, not the  key and not a B (the 
alpha character associated with Œ). After you type the character, the 
keyboard returns to its normal shortcut mode.
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To lock the alpha key so you can type more than one character at a time, 
click y 7 or press [ F6 ] [ F7 ]. To return to the normal shortcut 
mode, click ƒ or press [ F7 ].

In alpha typing mode, [ 0 ] through [ 9 ] still act as shortcuts. Pressing 
[ 1 ] types Y (the alpha character associated with À). To type a number, 
be sure the keyboard is not in the alpha typing mode. These keys do type 
the digits 0 through 9 in the normal shortcut mode.

Hold down an arrow key to scroll the cursor continuously.

When you use an arrow key to move the cursor, you can hold down the 
key to scroll the cursor continuously, instead of having to press the key 
repeatedly. In the key press history and in a script, the icon for a 
repeating arrow key has a clock symbol attached to it. For example:

When you record a script, you record only calculator key presses. 
These key presses can be difficult to interpret, viewed by 
themselves.

Because you record key presses, editing a script can be a little tricky. For 
example, if you change the mode to parametric, the script records z 
† † † ~ Í. The script doesn’t overtly tell you that you changed the 
mode to parametric. For this reason, it can be quite helpful to step 
through a script one key press at a time, or to play the script back at a 
slower speed so that you can see exactly where an edit needs to be made.
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Choosing a display option
By default, the TI-SmartView™ software displays the calculator and two 
optional panes of additional information. You can show or hide these 
optional panes, or change the type of information displayed in each one.

The View3™ pane initially shows the Y= editor, table, and graph screens. 
However, you can select which calculator screen you want to show for 
each of the three displays. (The stat plot, list, and window screens are 
also available.) The screens are updated each time you press one of the 
graphing keys (p, q, r, s), change the Window or 
Zoom settings, or press Í.

The third pane includes tabs that you can click to see either the key press 
history, a large screen display of what the device image is displaying, or 
any open scripts. When you display the large screen in the third pane, 
you can hide or show the key press history information at the bottom of 
the pane.

Display Option Click:

View3™ pane

View > Show/Hide View3 or  to show or 
hide the pane.

View > View3 Options to select a calculator screen 
for each display.
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Notes:

• Hiding the key press history does not clear it.

• Hiding the key press history does not delete or close open scripts.

• You can record a script without displaying the key press history.

Changing the size of the TI-SmartView screen
When you first use the TI-SmartView™ software, a full-screen image for 
1024 x 768 screen resolution is displayed. You can use whichever size you 
want, but the small, medium, and large versions are optimized for the 
following screen resolutions. 

The TI-84 Plus image in the TI-SmartView™ program is freely scalable. In 
addition to choosing small, medium, and large emulator sizes, you can 
click and drag the TI-SmartView™ window borders to display the 
application in a window that is a custom size.

Changing the color of the face plate
Just like with the TI-84 Plus graphing calculator, you can change the color 
of the face plate on the TI-SmartView™ calculator. You can choose from 
six face plate options. The default face plate color is silver.

Click View > Color and then click a color.

Key press history, 
large screen, and 
script pane

View > Show/Hide Key Press History or  to 
show or hide the pane.

Scripts
File > Open or  to open an existing script.

File > New Script or  to open a new, blank 
script.

The close button on the script’s tab  to 
close a script.

If your screen resolution is: Click:

800 x 600 View > Size > Small Emulator

1024 x 768 View > Size > Medium Emulator

1280 x 1024 View > Size > Large Emulator

Display Option Click:
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Saving and loading an emulator state
When you save the emulator state, a file is created that stores the 
calculator with all of the changes that you have made to its setup. Think 
of the emulator state file as representing a single TI-84 Plus that you have 
used and then set aside. When you load an emulator state, you pick up 
that same TI-84 Plus to use again. All of the changes that you made to 
the calculator are intact.

For example, you might want to set up a class demonstration by entering 
functions in the Y= editor and changing Window and Zoom settings. 
When you save your changes in an emulator state file, you simply load 
the file to show your demonstration. If you want to create different 
demonstrations for different classes, you can create multiple emulator 
state files. There is no limit on the number of emulator states that you 
can save. 

Note: The key press history, screen capture images, open scripts, and the 
face plate color are not saved in the emulator state file.

Saving the emulator state
1. Click File > Save Emulator State.

2. In the dialog box:

a) Navigate to the folder in which you want to store the 
emulator state file.

b) Type a file name. Use a name that describes the emulator 
state.

c) Click Save.

Loading an emulator state
1. Click File > Load File.

2. In the dialog box:

a) Navigate to the folder that contains the emulator state file.

b) Click the emulator state name to highlight it.

c) Click Open.

Resetting the emulator state
Resetting the emulator state returns the TI-SmartView™ software to the 

TI-84 Plus Silver Edition factory-default settings. The optional View3™ 
pane (center) and the right pane are shown. The key press history is 
cleared. Any open scripts are stopped, but remain open. 
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1. Click Tools > Restore Default State.

2. In the dialog box, click Yes to confirm that you want to reset the 
emulator state.

Saving calculator data to the computer
By saving data (lists, matrices, programs, etc.) from the TI-SmartView™ 
emulator to files on the computer, you can make backup copies of that 
data. If you delete the data from the TI-SmartView™ emulator, you can 
load the calculator files from the computer at any time.

1. Click File > Save Calculator File.

The Device Contents dialog box lists the data items on the 
TI-SmartView™ calculator, which may take several seconds.

2. Click an item to highlight it.

• To select multiple items, hold down Ctrl on the computer 
keyboard as you click each additional item.

• To select a range of items, click the first item in the range. Then 
hold down Shift and click the last item in the range.

3. Click Save Selected Item(s).

4. In the dialog box, navigate to the folder in which you want to store 
the files.

• Be sure to either open the folder or click the folder to highlight 
it. The folder name must be shown in the File name box at the 
bottom of the dialog box.

• If necessary, click  New Folder to create a new folder.

5. Click Save.

Each selected item is saved as a separate file on the computer. File 
names are assigned automatically. The file name’s extension 
identifies the data type.

If the folder already contains a file with the assigned name, you’re 
prompted whether to overwrite the existing file.

The Device Contents dialog box stays open so you can select and save 
additional data items.

6. When you’re finished, click Close.

Note: In the Device Contents dialog box, you can sort the list by clicking 
a heading. For example, click Name to sort by name and switch between 
ascending (a-z) and descending (z-a) order.
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Transferring files to supported graphing calculators
You can transfer files to the following calculators: TI-83 Plus, TI-83 Plus 
Silver Edition, TI-84 Plus, and TI-84 Plus Silver Edition.

To transfer calculator files from the computer, use TI Connect™ software 
and an appropriate TI Connectivity Cable available from 
education.ti.com. Some calculators come with a TI Connectivity Cable, 
which lets you connect the calculator to the computer.

You can also transfer data directly between the TI-SmartView™ program 
and a connected calculator, much the same way you can connect two 
calculators and transfer data between them.

Loading a calculator file from the computer
If you previously stored calculator files containing lists, programs, 
applications, etc., on your computer, you can load them into the 
TI-SmartView™ software. The files may be backups saved by the 
TI-SmartView™ program or files transferred to the computer from a 
calculator. See “Transferring files from supported graphing calculators. 

1. Click File > Load File.

2. In the dialog box:

a) Navigate to the folder that contains the file you want to 
load.

b) Click the file name to highlight it.

c) Click Open.

If the TI-SmartView™ program already contains a data item with 
that name, you’re prompted whether to overwrite the existing item.

Calculator file names on the computer
Calculator file names have the form:

filename.8x?

http://education.ti.com
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where filename is as close as possible to the data item’s name on the 
calculator, 8x indicates the file was created by the TI-SmartView™ 
program or a supported graphing calculator, and ? is a letter that 
identifies the type of data. Common data types are:

Note: If you load a Flash application file, the TI-SmartView™ program 
automatically installs the application.

Transferring files from supported graphing calculators
The TI-SmartView™ program can load files transferred to your computer 
from the following calculators: TI-83 Plus, TI-83 Plus Silver Edition, TI-84 
Plus, and TI-84 Plus Silver Edition.

To transfer files from a calculator to the computer, use TI Connect™ 
software and an appropriate TI Connectivity Cable available from 
education.ti.com. Some calculators come with a TI Connectivity Cable, 
which lets you connect the calculator to the computer.

If ? is: Type of data

c complex variable

d GDB (graph database)

e equation

f function

g group

i picture

k Flash application

l list (real or complex)

m matrix

n real number

p program

s string variable

t table setup

v application variable

w window range

z user zoom window

http://education.ti.com


Getting Started 15

You can also transfer data directly between the TI-SmartView™ program 
and a connected calculator, much the same way you can connect two 
calculators and transfer data between them.

Updating the software from the Internet
Visit education.ti.com for free software updates that are periodically 
available for downloading.

http://education.ti.com
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Working with images

Capturing calculator screens
You can capture the current calculator screen image using the 
TI-SmartView™ screen capture tool. When you capture a screen, the 
Screen Capture window is displayed. In this window, you can view, 
manipulate, and save screen images.

Click Tools > Take Screenshot or click . 

With a border, the image size is 100 pixels wide by 68 pixels high. 
Without a border, the image size is 96 pixels wide by 64 pixels high. A 
border is automatically added to each image when you capture it, but 
you can remove it.

The number of screen images you can capture is limited only by the 
available memory on your computer. Each unsaved screen image is stored 
in memory until you close the main TI-SmartView™ window. Closing the 
Screen Capture window does not discard unsaved screen images.

Adding or removing a border
The toolbar button for adding or removing a border toggles between 

add  and remove  depending on whether or not the selected 
image contains a border. 

Adding or removing a border on a single screen image
1. Click the screen capture image to select it.

2. Click Edit > Remove Border or click  to remove the border.

—or—

Click Edit > Add Border or click  to add a border.

Adding or removing a border from a group of screen 
images
1. Switch to thumbnail view.

2. Select the group of images. You can either:

• Click the first image you want to select, and then hold down Ctrl 
on the computer keyboard as you click each additional image.
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• Select a range of images by clicking the first image in the range, 
holding down Shift, and clicking the last image in the range.

3. Click Edit > Remove Border or click  to remove the border

—or—

Click Edit > Add Border or click  to add a border.

Note: To select all of the images, click Edit > Select All. 

Saving a screen image
You can save screen images in TIF, GIF, or JPEG formats. The images are 
saved in your My Documents folder unless you specify a different 
location to save them. All images are saved at the size they are currently 
displayed.

1. Click the screen image you want to save.

2. Click File > Save Screen or click .

3. In the dialog box:

a) Navigate to the folder in which you want to store the screen 
image file.

b) Select the file type for the appropriate image format.

c) Type a file name. Use a name that describes the screen 
image.

d) Click Save.

Note:

• If you have previously saved the selected screen image, clicking File > 

Save Screen or  overwrites the previous file. To save the file in a 
different location, with a different name, or as a different file format, 
you must click File > Save Screen As.

• To save all the images at once, click File > Save All Screens. When 
you do this, you select the location to save the files in the Save All 
window, but do not specify file names. Each screen image is saved 
with its default file name. If that name already exists, you’re 
prompted whether to overwrite the existing file.
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Viewing screen images
When you capture a screen image, that image opens in the Screen 
Capture window. You can view the images individually or as a group of 
images, called thumbnails. A reference name is displayed under each 
image.

To view screen image thumbnails, click View > Thumbnails or 

click .

To view individual screen images, click View > Single Screen or 

click .



20 Working with images

Navigating among screen images

To view the previous screen image, click View > Previous Screen 

or click .

To view the next screen image, click View > Next Screen or click 

.

Zooming in or zooming out
You can zoom in or out on any single image to view a larger or smaller 
version of it. 

You can save a larger or smaller version of a screen image by zooming in 
or out before you save it. For example, to save an image that is larger 
than the standard 96 x 64 size, zoom in until the image is the size you 
want and then save it.

To display a larger screen image, click View > Zoom In or click 

.

To display a smaller screen image, click View > Zoom Out or 

click .

Dragging and dropping an image to another 
application
You can drag and drop any TI-SmartView™ screen image to paste it into 
another application. These images include the following:

• Saved or unsaved screen capture images

• View3™ pane screens

• The Large Screen image

Note: In the Screen Capture window, the selected image has a red 

border. However, the borders on the Large Screen image and the View3™ 

screens do not change color when you select them.

To drag and drop a screen image into another application:

1. Adjust the sizes of the windows of the two applications so that both 
of them fit on the computer screen.

2. To drag-and-drop the image:
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a) Click the screen image to select it.

b) Drag the screen image from the TI-SmartView™ program 
and then drop it into the other application.
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Using the key press history

What is the key press history?
Each key you click on the calculator is recorded automatically in the key 
press history. You can see the key press history from the key press history 
pane and the large screen pane. Using the key press history to see a 
listing of all the keys you’ve used has several benefits, including:

• If a calculation gives unexpected results, you can view the key press 
history to see if you entered the correct data.

• If you perform a calculation and then find you need to perform it 
repeatedly, you can copy those keys from the key press history and 
paste them into a script. When you need to repeat the calculation, 
you can play the script instead of re-entering all the key presses.

The key press history shows some key sequences in a different form than 
they’re shown in the user’s guide for the TI-84 Plus calculator. For 
example, suppose you display the calculator’s MEMORY menu.

• The user’s guide shows the key sequence as y L, where L is 
the 2nd function of the Ã key.

• The key press history shows the key sequence as  
because those are the actual keys you click.

Similarly, suppose you select the round( function from the MATH NUM 
menu.

• The user’s guide shows the function as round(.

• The key press history shows  because those are 
the keys you click.

Showing or hiding the key press history

Click View > Show/Hide Key Press History or click .

When the TI-SmartView™ right pane is showing, you may need to 
click the Key Press History tab to activate it. The right pane also 
shows tabs for Large Screen and any open scripts. The active tab has 
a colored line across its top.

You can also view and clear the key press history from the large 
screen pane. Click Show Key Press History or Hide Key Press 
History to show or hide the list of keys pressed. 
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When the key press history is shown on the large screen pane, you can 
click Clear Key Press History to clear the list of keys pressed.

Hiding the right pane does not clear the contents of the key press history 
or any open scripts.

Clearing the key press history
Click Edit > Clear Key Press History, or click Clear Key Press 
History on the key press history or large screen pane. 

Clearing the key press history does not affect the contents of any open 
scripts in the TI-SmartView™ right pane.

Copying the key press history to another 
application
You can copy all or only a selected portion of the key press history to 
another application such as a word processor. The procedure is the same 
as used to copy scripts. 
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Using scripts

What is a script?
A script is a series of calculator key presses that can be stored and played 
repeatedly. By saving the script, you can open it at a later time and play it 
again without having to re-enter all the key presses.

Overview of using a script

Suppose, after performing one or more calculations on the calculator, 
you decide to create a script that performs those same calculations. 
Instead of repeating the key presses while recording a new script, you 
can:

• Copy keys from the key press history and paste them into the script.

• Edit the script as necessary so the keys work properly in the context 
of that script.

You can:

• Play the script normally.

• Step-through one key at a 
time.

• Manually pause the script.

Create,
record,

and save
the script

Play
the

script

Close
the script

You can also:

• Insert text points.

• Insert pauses and delays.

• Insert a Go To Home 
command.
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Showing or hiding the script pane
Any open scripts are shown in the TI-SmartView™ right pane, which is 
also used to show the key press history. To toggle the right pane on and 
off:

Click View > Show/Hide Key Press History or click .

The right pane shows tabs for the Key Press History, Large Screen, and 
any open scripts. The active tab has a colored line across its top. Click the 
appropriate tab to show its contents.

Hiding the right pane does not clear the contents of any open scripts or 
the key press history.

Recording a new script
You can begin recording a new script at any time.

1. Click File > New Script or click .

The TI-SmartView™ right pane opens automatically if it’s not already 
open, and a new blank script appears in the pane. The new script has 
a tab at the top of the pane, with a colored line across its top to 
indicate it’s active. The tab shows the script’s default name, which is 
Script 1, Script 2, etc.

2. Click Scripts > Record or click  on the script’s toolbar.

3. Click the keys on the calculator to record the key presses for your 
script.

4. When you’re finished, click Scripts > Stop or click .

Note:

• You can also insert Go To Home commands, text points, delays, and 
pauses in a script.

• You can help ensure that your script plays properly under various 
conditions by following a few simple guidelines. (See “Tips for 
recording a script” on page 27.)

• You can reuse key sequences that you previously entered in the 
calculator. Copy the keys from the key press history and paste them 
into the script. The procedure is the same as used to copy scripts. (See 
“Copying a script to another application” on page 37.)
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Tips for recording a script
If you record a script assuming the calculator will always have its current 
settings, you may have problems later if you play the script with different 
calculator settings. Therefore, it’s a good practice to add the necessary 
settings directly into the script. The following tips can help you create 
scripts that play correctly in a variety of situations.

At the beginning of a script:

• Insert a Go To Home command to ensure the script starts on the 
calculator’s home screen. This lets your script begin at a known 
starting point, regardless of what screen is shown on the calculator 
when you play the script.

• Press y L 7 2 2 to reset the memory to its defaults.

When graphing:

• Press u before entering an equation into the Y= editor.

• Insert a Pause command after graphing a function.

When using variables, lists, and statistical data:

• Clear a variable before storing to it.

• Press y L 4 Í to clear all lists before storing to them.

• Press … 5 Í to execute SetUpEditor, which clears the stat 
editor. This command removes all list names from the stat editor and 
then restores list names L1 through L6 to columns 1 through 6.

When selecting an item from a menu:

• Press the number or letter for that item. Suppose you need fMax( 
from the MATH menu. The script runs faster if you use  7 (two 
key presses) instead of  † † † † † † Í (eight key 
presses).

When starting an application from within a script:

• If you share the script with other people using TI-SmartView™ 
software on different computers, remember that their 
APPLICATIONS menus may not list the same applications in the same 
order. Pressing Œ 4 to start an application on your TI-SmartView™ 
may not start the same application on theirs.

• Instead, have your script press Œ to display the APPLICATIONS 
menu and then use a text point telling the user to select the 
appropriate application from the list.
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At the end of a script:

• Insert a Pause command. This is particularly useful if a script displays 
text points that you want the user to see after the script finishes. 
Otherwise, text points are closed automatically at the end of a script.

Note: When resetting the memory, clear only the applicable portion of 
the memory. Using y L 7 1 2 to reset all RAM is not required in most 
situations.

Playing a script
After recording a new script or opening an existing one, you can play it. 
You cannot play a script while you’re recording it.

1. Select the tab for the appropriate script. The active tab has a colored 
line across its top.

2. Click Scripts > Play or click .

Adjusting the script speed
You can vary the speed at which each key press in a script is executed, 
from Slow (approximately one key press every 5 seconds) to Fast 
(approximately one every 1/2 second).

1. Click Scripts > Adjust Script Speed.

2. In the submenu, click a speed in the displayed range.

Note:

• You can also use the slider in the script’s toolbar. Drag the slider to the 
appropriate position.

• The speed setting affects every key press in the script, which may not 
be what you want. Suppose the script enters numbers such as 
425,237,234. Setting the speed to one key press every 2 seconds takes 
18 seconds to enter the number. Instead, you may want to use a faster 
speed and insert pauses or delays at certain points in the script.

Saving a script
After recording a new script or editing an existing one, save the script so 
you can use it again later.
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1. Select the tab for the appropriate script. The active tab has a colored 
line across its top.

2. Click File > Save Script or click .

For an existing script that was saved previously, the new version 
automatically overwrites the existing one. For a new script, the Save 
As dialog box opens.

3. If you see the dialog box:

a) Navigate to the folder in which you want to store the script 
file.

b) Type a file name. Use a name that indicates the purpose of 
the script.

c) Click Save.

Note: If you do not want to save the changes you made to an existing 
script, close the script instead of saving it. Click the X in the script tab to 
close the script. When prompted whether to save the changes, click No.

Saving a copy of a script
Sometimes you may need a script that is similar to an existing one but 
with some changes. Instead of recording a new script, it may be easier to 
copy the existing script and edit it.

1. Open the script you want to copy, and select its tab. The active tab 
has a colored line across its top.

2. Click File > Save Script As. 

Note: Do not click .

3. In the dialog box:

a) Navigate to the folder in which you want to store the copy.

b) Type a file name. Use a name that indicates the purpose of 
the script.

c) Click Save.

Note: If you change a script and want to keep those changes in the 

existing script, click File > Save Script or  before selecting Save 
Script As. Otherwise, the changes are saved in the copy but not in the 
original script.
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Opening an existing script
After a script is recorded and saved, you can open it later and play the 
script again, edit it, or save a copy of it.

1. Click File > Open Script or click .

2. In the dialog box:

a) Navigate to the folder that contains the script file.

b) Click the script name to highlight it.

c) Click Open.

The script opens in the TI-SmartView™ right pane. A tab with that script 
name appears at the top of the pane along with tabs for Key Press 
History, Large Screen, and any other open scripts. You can click any of 
those tabs to jump from one to the other. The active tab has a colored 
line across its top.

Note:

• The most recently used scripts are listed at the bottom of the File 
menu. Click a script name to open it.

• When several scripts are open at the same time, there may be too 
many tabs to fit across the right pane. If so, left and right arrows 
appear on the right of the tab area. Click these arrows to scroll left 
and right along the available tabs. You may also want to close scripts 
when you’re not using them.

Closing a script
When you’re finished using a script, you may want to close it. This 
removes the script tab from the right pane. If the script is not saved, you 
are prompted whether to save it.

Click File > Close Script or click the X on the script tab.

Stepping through a script
You can step through a script one key press at a time. This is the same 
effect as if you had used pause commands to halt the script between 
every key press. Depending on the length of the script, you may want to 
step through all or only parts of it.

Click to close the script.
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Stepping through a script from the beginning
In the script pane, instead of playing the script:

1. Click Scripts > Step Through or click  to start the script.

Note: Do not click Scripts > Play or .

The script pauses automatically after every key press.

2. Click  repeatedly to step through each key press.

3. After stepping through a series of key presses, you can click  to 
play the remaining key presses continuously.

Stepping through part of a script
In the script pane:

1. Click Scripts > Play or click .

2. Click Scripts > Pause or click  to pause at a location before you 
want to start stepping through.

3. Click Scripts > Step Through or click  repeatedly to step 
through each key press.

4. After stepping through a series of key presses, you can click  to 
play the remaining key presses continuously.

You can repeat steps 2 - 4 as often as necessary to step through different 
parts of the script.

Stopping a script while stepping through it

While you are stepping through a script, Scripts > Stop or  may not 
be available. If not, you can:

1. Click  to play the script.

2. Then click .
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Stopping a script
When you finish recording a script, you need to stop recording. When 
you play a script, you may want to stop the script manually at some time 
before it would normally end.

Click Scripts > Stop or click .

Unlike when you pause a script, you cannot continue playing the script 
from the location where it stopped. You can only replay the script from 
the beginning.

Pausing a script
At various times while a script is running, you may want to halt it 
temporarily. For example, you may want to view an intermediate result 
or graph before continuing with another operation that changes the 
calculator screen or graph. You can either pause the script manually or 
insert a pause command directly into the script.

Pausing the script manually
In the script pane, while the script is playing:

Click Scripts > Pause or click .

The Play  button changes to Pause  when you play the script. 
After you pause the script, the button changes back to Play. Click Play 
again when you’re ready to continue the script.

Inserting a pause command in the script
In the script pane:

1. Click the location where you want to insert the pause.

The cursor appears at that position.

2. Click Scripts > Insert Pause or click  at the bottom of the script 
pane.

 appears in the script to mark the location of the pause. When you 
play the script, it always halts at this pause command.

To continue, click Scripts > Play or click .
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Deleting an existing pause command

Delete the  icon the same way you would delete any other key press 
in the script.

Inserting a delay into a script
In some cases, you may want to delay the script a specified period of time 
before it continues to the next key press. For example, you may want to 
display a result or graph for a few extra seconds before the script 
executes the next key press.

Inserting a delay
In the script pane:

1. Click the location where you want to insert the delay.

The cursor appears at that position.

2. Click Scripts > Insert Delay or click  at the bottom of the script 
pane.

 appears in the script to mark the delay.

A delay has the same effect as a blank key press. It lasts as long as a single 
key press (as determined by the script’s speed setting) and has no other 
effect on the script.

For a longer delay, insert more than one. For example, suppose the script 
speed is set for one key press every second. To delay five seconds, insert 
five delays.

Note: If you don’t know how long to delay the script, consider inserting 
a pause instead. After the script pauses, it does not start again until you 

click Scripts > Play or click  to continue.

Deleting an existing delay

Delete the  icon the same way you would delete any other key 
press in the script.
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Inserting a text point into a script
If you use a script to show a presentation, you may want to display a text 
screen at certain locations to explain a result or describe what the script 
will be doing next.

Inserting a new text point
In the script pane:

1. Click the location where you want to insert the text point.

The cursor appears at that position.

2. Click Scripts > Insert Text or click  at the bottom of the script 
pane.

3. In the dialog box:

a) Type the text using your computer’s keyboard. You cannot 
use the calculator to enter text in this dialog box.

b) Click Enter.

 appears in the script to mark the text point.

Note: 

• When you run the script, the text is displayed in a separate text pane 
that opens below the script. That text pane closes automatically when 
the script stops. To leave the text pane open for a longer time, insert a 
pause or delay immediately after the text point or at an appropriate 
location before the end of the script.

• The text from all text points in the script is placed one after another 
in the text pane. As necessary, you may need to scroll to see all the 
text.

• You can change the size of the displayed text by dragging the slider 
located in the area between the script pane and the text pane.

Editing an existing text point
In the script pane:

1. Double-click the  marker.

The Text Point Dialog box opens.

2. Edit the text as necessary.

3. Click Enter.
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Deleting an existing text point

Delete the  marker the same way you would delete any other key 
press in the script.

Inserting a Go to Home command
A script executes each key press in sequence. However, these key presses 
may have different effects depending on what screen (Home, Graph, 
Table, etc.) is shown on the calculator when you play the script. By using 
a Go To Home command at the beginning of a script, you can ensure that 
it begins on the Home screen.

Inserting a new Go To Home
In the script pane:

1. Place the cursor at the beginning of the script.

2. Click Scripts > Insert Go To Home Screen or click  at the bottom 
of the script pane.

 appears in the script to mark the location of the command.

Note: You can insert a Go To Home command at any location in your 
script. While you’re recording key presses inside a script, however, it’s 
usually better to record the actual key presses used to display the Home 
screen.

Deleting an existing Go To Home command

Delete the  icon the same way you would delete any other key press 
in the script.

Editing a script
Editing a script is similar to editing a text document. For example, you 
can drag the mouse to highlight a series of keys the same as you would 
drag to highlight text in a word processor. (You can also hold down Shift 
and use the arrow keys on your computer keyboard.)
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Inserting key presses or script elements (pauses, delays, 
etc.)
With the script shown in the right pane:

1. Click Scripts > Record or click .

2. Click the location where you want to insert the keys or script 
elements.

Note: Be sure to position the cursor after you start recording. If you 
position the cursor first, it automatically jumps to the beginning of 
the script when you start recording.

3. You can:

• Click the calculator keys you want to insert.

– or –

• Use the buttons at the bottom of the script pane to insert a text 
point, delay, pause, or Go To Home command.

4. When you’re finished, click Scripts > Stop or click .

Deleting key presses or script elements
With the script shown in the right pane, either:

• Place the cursor immediately to the left of the items you want to 
delete. Then press Delete on your computer keyboard.

– or –

• Place the cursor immediately to the right of the items you want to 
delete. Then press Backspace on your computer keyboard.

– or –

• To delete multiple items at one time, highlight the items. Then click 

Edit > Cut or click  on the script’s toolbar.

Moving items to a different location
With the script shown in the right pane:

1. Highlight the items you want to move.

2. Click Edit > Cut or click .

3. Click the location where you want to insert the items.



Using scripts 37

4. Click Edit > Paste or click .

Note: You can also use the mouse to drag the highlighted items to the 
new location.

Copying items to a different location
With the script shown in the right pane:

1. Highlight the items you want to copy.

2. Click Edit > Copy or click .

3. Click the location where you want to insert the copy.

4. Click Edit > Paste or click .

Note: You can also hold down Ctrl on your computer keyboard and use 
the mouse to drag a copy of the highlighted items to the new location.

Copying a script to another application
You can copy all or only a selected portion of a script to another 
application such as a word processor. You can copy the key graphics as 
they are shown in the script pane, or you can copy the key presses as font 
text characters.

Note: When you copy as font text characters, those characters use the 
TI84EmuKeys font. This font is installed on your computer automatically 
when you install the TI-SmartView™ software.

Copying keys as graphics
1. Open the appropriate script.

2. Select the keys you want to copy. To select all the keys, click Edit > 
Select All.

3. Click Edit > Copy, switch to the other application, and paste the keys 
at the appropriate location.

Note: You can also drag the selected keys to the new application.

Copying keys as font text characters
1. Open the appropriate script.

2. Select the keys you want to copy. To select all the keys, click Edit > 
Select All.

3. Click Edit > Copy As Font.
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4. Switch to the other application, and paste the characters at the 
appropriate location.

In some applications, the pasted characters may be shown in the font 
that is in effect at that location. So they may not look anything like 
calculator keys.

5. If necessary, apply the TI84EmuKeys font to the characters.

Note: The script icons for text points, delays, pauses, and Go To Home 
commands cannot be copied as font text characters. They are ignored 
when you paste the copied characters into the other application.

Locating common scripts
If you have access to scripts written by other people, you can open and 
play those scripts on your own computer. Texas Instruments provides a 
number of scripts that perform commonly used operations.

• Run the TI-SmartView™ installation CD, which runs automatically 
when you insert it into the CD drive. Click the activities and 
tutorials tab on the displayed screen. Most of the listed items are 
scripts that you can save to your computer.

• Check the Texas Instruments web site at education.ti.com.

By using available scripts and viewing their content, you can get ideas 
about how to create additional scripts for automating your own 
operations.

http://education.ti.com
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Connecting a calculator or CBL 2/CBR 2

Using a connected calculator to control 
Dissimilarities
You can connect a TI-84 Plus or TI-84 Plus Silver Edition graphing 
calculator to your computer and use it as a remote keyboard for the 
TI-SmartView™ software. If you press a series of keys on the calculator, 
those same key presses are repeated on the calculator image in the 
TI-SmartView™ program. This is useful if you feel more comfortable 
pressing real keys on a calculator but want to see the results on the 
computer.

Note: The calculator must have a supported operating system. (See 
“Checking the calculator’s operating system” on page 41.) Also, the 
SmartPad™ application must be installed on the calculator.

Controlling TI-SmartView
1. Connect the calculator (See “Connecting the calculator to the 

computer” on page 39.) and start the TI-SmartView™ program.

2. On the connected calculator, press Œ and run the SmartPad™ 
application. (The application will not run if the calculator is not 
connected.)

The SmartPad™ title screen appears.

Note: The calculator shows this title screen as long as SmartPad™ is 
running. All key presses and results appear on the computer only.

3. Press keys on the connected calculator to control TI-SmartView™.

4. When you’re finished, either:

• Press y M on the connected calculator.

– or –

• Disconnect the USB cable.

Connecting the calculator to the computer
You must use the Standard-A to Mini-B USB Cable that comes with your 
TI-84 Plus calculator. Other TI Connectivity Cables are not supported. If 
you need to purchase a cable, go to education.ti.com.

http://education.ti.com
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1. Firmly insert the cable’s standard USB connector into a USB port on 
the computer.

2. Insert the cable’s mini USB connector into the calculator’s USB port. 
The TI-84 Plus port is at the top right edge of the calculator.

3. Turn on the calculator.

The first time you turn on the calculator, the computer may detect it 
as new hardware and display a wizard or dialog box that prompts 
you to install a driver for the calculator.

4. If you’re prompted for a driver, cancel the wizard or dialog box and 
return to the desktop. The calculator will use the computer’s default 
USB driver.
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Checking the calculator’s operating system
Not all TI-84 Plus or TI-84 Plus Silver Edition graphing calculators have an 
operating system that can control TI-SmartView™. To check your 
calculator:

Press y L and then select 1:About.

The operating system number, immediately below the calculator name, 
must be 2.40 or later. For example:

If you need to upgrade your operating system, go to education.ti.com.

Note
• While a calculator is connected, you can continue to perform 

operations by clicking keys on TI-SmartView™. You can also run 
applications (such as Cabri® Jr., Inequality Graphing, or 
Transformation Graphing) or any programs stored on 
TI-SmartView™.

• All calculations use the TI-SmartView™ emulator state, not the 
connected calculator’s. If the connected calculator contains data, 
applications, or programs that are not on TI-SmartView™, you 
cannot access those items.

– Suppose the variable a equals 20 on the calculator but is not 
defined on TI-SmartView™. If you calculate 5a, the answer will 
not be 100 as you may expect.

– Even if TI-SmartView™ contains the same application or 
program as the calculator, it may be in a different location on 
the menu. For example, an application may be item 3 on the 
APPLICATIONS menu on TI-SmartView™ and item 2 on the 
connected calculator. So pressing Œ 2 may give unexpected 
results.

• The connected calculator turns off automatically if not used for 
about five minutes. To continue using it, turn the calculator on.

http://education.ti.com
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• You do not need TI Connect™ software on your computer to control 
TI-SmartView™.

Transferring data to and from a connected 
calculator
With a TI-84 Plus calculator, you can connect it to another compatible 
calculator and transfer data between them. Likewise, you can transfer 
data between TI-SmartView™ software and a connected calculator. 
Compatible calculators are the TI-83 Plus, TI-83 Plus Silver Edition, TI-84 
Plus, and TI-84 Plus Silver Edition.

Note: To connect the calculator, you must use the USB Silver Edition 
cable available from education.ti.com. Other TI Connectivity Cables are 
not supported for this type of connection.

1. Plug the cable’s USB connector into any USB port on the computer, 
and plug the other end of the cable into the calculator’s I/O link port.

2. Click Tools > Establish Connection.

A dialog box lists all devices connected to the computer with a USB 
Silver Edition cable, such as a CBL 2™or CBR 2™data collection 
device and a calculator.

If the device is not listed, check both ends of the cable and make sure 
they’re connected properly. Then click Refresh to update the list.

3. Click the applicable device to highlight it, and then click Select.

the TI-SmartView™ program connects the device and displays 
Device Connected on the title bar. Also, the Establish Connection 
menu item changes to Disconnect.

4. Use y 8 to transfer the data by using the detailed instructions 
given in the Communication Link chapter of the TI-84 Plus 
Guidebook. The general steps are:

a) Set the receiving unit to receive.

b) On the sending unit, select the applicable data items and 
transmit them.

The TI-84 Plus Guidebook is available on the TI-SmartView™ 
installation CD, or you can download it from 
education.ti.com/guides.

5. When you’re finished transferring data, click Tools > Disconnect.

You can use the TI-SmartView™ program when the calculator is 
connected, but it’s a good practice to use the disconnect tool when 
you’re done. Do not just unplug the cable.

http://education.ti.com
http://education.ti.com/guides
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Note: If you unplug the USB connector from the computer while the 
calculator connection is active, the computer may lock up and need to be 
rebooted.

Using a connected CBL 2 or CBR 2 device
You can connect a Calculator-Based Laboratory™ 2 (CBL 2™) or 
Calculator-Based Ranger™ 2 (CBR 2™) data collection device to your 
computer. By using one of the following applications on the 
TI-SmartView™ emulator, you can then collect and analyze real-world 
data.

• DataMate™ — Used for a CBL 2 device. This application comes with 
the CBL 2 device and needs to be transferred to the TI-SmartView™ 
application before you can use it.

• EasyData® — Used for both the CBL 2 and CBR 2 devices. This 
application is standard on TI-84 Plus calculators and is included with 
the TI-SmartView™ program. (On a TI-84 Plus, EasyData® launches 
automatically when you plug in a USB sensor. With the 
TI-SmartView™ program, however, EasyData® does not autolaunch.)

• CBL/CBR — Used for both CBL 2 and CBR 2 devices. This application is 
standard on TI-83 Plus calculators and is included with the 
TI-SmartView™ program.

Note: To connect a CBL 2 or CBR 2 device, you must use the USB Silver 
Edition cable available from education.ti.com. Other TI Connectivity 
Cables are not supported for this type of connection.

Connecting the device and running the application
If you want to use the DataMate application, check that the application 
is already installed on the TI-SmartView™ program. (See “Transferring 
DataMate to TI-SmartView” on page 44.) Then:

1. Plug the cable’s USB connector into any USB port on the computer, 
and plug the other end of the cable into the device’s I/O port.

2. Click Tools > Establish Connection.

A dialog box lists all devices connected to the computer with a USB 
Silver Edition cable, such as a CBL 2 or CBR 2 device and a calculator.

If the device is not listed, check both ends of the cable and make sure 
they’re connected properly. Then click Refresh to update the list.

3. Click the applicable device to highlight it, and then click Select.

The TI-SmartView™ program connects the device and displays 
Device Connected on the title bar. Also, the Establish Connection 
menu item changes to Disconnect.

http://education.ti.com
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4. Click Œ, and then run DataMate, EasyData, or CBL/CBR.

5. Use the application to collect data. For information about using:

– DataMate™application, refer to the guidebook that came with 
the CBL 2™ device.

– EasyData® application, refer to the Applications chapter of the 
TI-84 Plus Guidebook, available on the TI-SmartView™ program 
installation CD or at education.ti.com/guides.

– CBL/CBR application, refer to the Applications chapter of the 
TI-83 Plus Guidebook, available at education.ti.com/guides.

6. When you’re finished, click Tools > Disconnect.

You can use the TI-SmartView™ program when the CBL 2 or CBR 2 device 
is connected, but it’s a good practice to disconnect it when you’re done. 
Don’t simply unplug the cable.

Note:

• If you unplug the USB connector from the computer while the 
connection is active, the computer may lock up and need to be 
rebooted.

• After a device is connected, you can switch the cable’s plug to 
another device without reconnecting. Suppose you first use a CBR 2 
device and then want to switch to a CBL 2 device. Unplug the cable 
from the CBR 2 device and plug it into the CBL 2 device.

• Other than a CBR 2 device, you can only use probes connected to a 
CBL 2 device. The TI-SmartView™ program does not use direct-
connect probes.

• You can also collect data with a CBR 2 device separately, and then 
transfer that data to the TI-SmartView™ program for analysis.

• For complete information about using the CBL 2 or CBR 2 devices, 
refer to the guidebook that comes with the device.

Transferring DataMate to TI-SmartView
If you use a CBL 2 device, you should use the DataMate™ application 
that comes with the device. You only need to transfer it once.

1. Attach the CBL 2 to the computer using the USB Silver Edition cable, 
and then establish a connection as previously described.

2. Click y 8 ~ Í to put the TI-SmartView™ program in Receive 
mode.

3. Push TRANSFER on the CBL 2 device.

The application and any supporting programs are transferred.

http://education.ti.com/guides
http://education.ti.com/guides
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4. When the transfer is complete, press y 5 on the TI-SmartView™ 
program.

DataMate™ is now available from the TI-SmartView™ APPLICATIONS 
menu.
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FAQs and keyboard shortcuts

Frequently asked questions
I clicked on the calculator screen to select an option, but nothing 
happened. Why?

On the TI-SmartView™ calculator, use the mouse to click keys the same as 
you would use your finger to press keys on a real TI-84 Plus calculator. 
And just like on a real calculator, you can’t press the screen to select an 
option, even though it’s very tempting on a computer. You must click the 
same keys you would press on the calculator.

I typed a name and got an error message. Why?

You probably typed the name on your computer keyboard. By default, 
the keyboard is in its normal shortcut mode, where [ A ] is a shortcut to 
. To put the keyboard in its alpha typing mode, click ƒ or press 
[ F7 ]. After you type the alpha character, the keyboard returns to its 
normal shortcut mode.

To lock the alpha key, click y 7 or press [ F6 ] [ F7 ]. To return to 
the normal shortcut mode, click ƒ or press [ F7 ].

I’m having trouble editing a script. How do I figure out where I 
need to be in the script to make a change?

Because scripts record key presses, it might be easier to step through the 

script by clicking  on the script toolbar or to change the script’s 
playback speed so that you can see exactly where you need to make the 
change.

The TI-SmartView™ calculator is too big for my computer screen. 
How do I change the size?

Click View > Size and then select a smaller size. In addition to choosing 
small, medium, and large sizes, you can click and drag the 
TI-SmartView™ window borders to display the application in a window 
that is a custom size.

Some keys show a  in the key press history or in a script. What 
does that mean?

When you hold down an arrow key for more than a certain amount of 
time, the cursor begins to scroll. The key that starts this scrolling feature 
has a clock icon attached to it. For example:
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The amount of scrolling represented by this single key icon is equivalent 
to clicking the key multiple times. If you run a script that contains one of 
these keys, TI-SmartView™ reproduces the equivalent number of key 
presses.

Using the computer keyboard
You can use the computer keyboard to enter data into the 
TI-SmartView™ software. However, the keyboard does not work the 
same as using the TI Keyboard with a calculator. You cannot simply use 
the keys like a QWERTY keyboard to type A through Z. By default, the 
keys are shortcuts to a corresponding key on the calculator.

Note: You can use the keyboard to access second functions and alpha 
characters, but you must use y and ƒ the same as you would on 
the calculator.

Where possible, shortcut keys correspond to alpha characters on the 
calculator. For example, the calculator has keys such as:

where labels above the keys indicate second functions and alpha 
characters.

Keys such as  and u do not have associated alpha characters. 
Refer to the table later in this topic to find the shortcut to those keys. For 
example, [ Shift ]+[ V ] is the shortcut to .

On the keyboard, press: To do this:

[ A ] Shortcut to .

[ F6 ] A,
where [ F6 ] is the shortcut to y

Show the TEST menu.

[ F7 ] A,
where [ F7 ] is the shortcut to ƒ

Type the letter A.
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Normal shortcut mode
The calculator keys have the following shortcuts.

[ F1 ] [ F2 ] [ F3 ] [ F4 ] [ F5 ]

[ F6 ] [Shift]+[M] [Delete]
[ ] [ ]

[ F7 ] [Shift]+[X] [Shift]+[S]
[ ] [ ]

[ A ] [ B ] [ C ] [Shift]+[V] [Backspace]

[ D ] [ E ] [ F ] [ G ] [Shift]+[ ^ ]

[ I ] [ , ] [Shift]+[ ( ] [Shift]+[ ) ] [ / ]

[ N ] [ 7 ] [ 8 ] [ 9 ] [Shift]+[ * ]

[ S ]
[ 4 ] [ 5 ] [ 6 ] [ - ]

[ X ] [ 1 ] [ 2 ] [ 3 ] [Shift]+[ + ]

[Shift]+[~] [ 0 ] [ . ] [Shift]+[ - ]
[Enter]
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Note: Some calculators keys have more than one shortcut, but the table 
shows only the most straightforward ones. For example, you can also 
type 1 by pressing [ Y ] (because Y is the alpha character for À on the 
calculator). However, it’s much easier to press [ 1 ].

Alpha typing mode for A through Z and other characters
When you use ƒ, the keyboard switches automatically to its alpha 
typing mode, where pressing [ A ] gives you an A, not the  key.

1. Click ƒ on the TI-SmartView™ screen or press [ F7 ] on the 
keyboard.

The cursor changes to .

2. Press the applicable key.

Keys without an associated alpha character act the same as they do in the 
normal shortcut mode. For example, [ F1 ] is still a shortcut to o.

After you type the alpha character, the keyboard returns to its normal 
shortcut mode.

Note:

• To lock the alpha key so you can type multiple alpha characters, click 
y 7 or press [ F6 ] [ F7 ]. To unlock the alpha key, click ƒ or 
press [ F7 ].

• In alpha typing mode, [ 0 ] through [ 9 ] act the same as Ê through ® 
on the calculator. Pressing [ 1 ] types Y (the alpha character for À), 
not 1. To type a number, be sure the keyboard is not in the alpha 
typing mode. For example, to type TEST1, press either:

– [ F7 ] [ T ] [ F7 ] [ E ] [ F7 ] [ S ] [ F7 ] [ T ] [ 1 ]

– or [ F6 ] [ F7 ] [ T ] [ E ] [ S ] [ T ] [ F7 ] [ 1 ].

• When you are prompted to enter a name for a program or group, the 
calculator locks the alpha key automatically.

To type: Press:

A through Z [ A ] through [ Z ]

space [ space bar ]

: (colon) [ Shift ]+[ : ]

" (double quote) [ Shift ]+[ " ]

? (question mark) [ Shift ]+[ ? ]

q (theta) [ 3 ]
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• Alpha characters are used to enter text characters only. You cannot 
use alpha characters to enter function names. For example, typing 
COS or FMIN does not calculate that function. You must press the 
appropriate function key or select the function from a menu.
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Legal information

Texas Instruments Support and Service

For general information 

For technical support

For product (hardware) service
Customers in the U.S., Canada, Mexico, Puerto Rico and Virgin 
Islands: Always contact Texas Instruments Customer Support before 
returning a product for service.

All other customers: Refer to the leaflet enclosed with this product 
(hardware) or contact your local Texas Instruments retailer/distributor.

License
Your right to use this product is governed by the license you accepted 
when you installed the software.

Home Page: education.ti.com

KnowledgeBase 
and e-mail 
inquiries:

education.ti.com/support

Phone: (800) TI-CARES / (800) 842-2737
For U.S., Canada, Mexico, Puerto Rico, and 
Virgin Islands only

International 
information:

education.ti.com/international

KnowledgeBase 
and support by 
e-mail:

education.ti.com/support

Phone 
(not toll-free):

(972) 917-8324

http://education.ti.com
http://education.ti.com/support
http://education.ti.com/international
http://education.ti.com/support
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