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Important Information
Except as otherwise expressly stated in the License that accompanies a 
program, Texas Instruments makes no warranty, either express or 
implied, including but not limited to any implied warranties of 
merchantability and fitness for a particular purpose, regarding any 
programs or book materials and makes such materials available solely on 
an "as-is" basis. In no event shall Texas Instruments be liable to anyone 
for special, collateral, incidental, or consequential damages in connection 
with or arising out of the purchase or use of these materials, and the sole 
and exclusive liability of Texas Instruments, regardless of the form of 
action, shall not exceed the amount set forth in the license for the 
program. Moreover, Texas Instruments shall not be liable for any claim of 
any kind whatsoever against the use of these materials by any other 
party.

License
Please see the complete license installed in C:\Program Files\TI 
Education\TI-Nspire.

© 2008 Texas Instruments Incorporated

Microsoft®, Windows®, Apple®, and Macintosh® are trademarks of 
their respective owners.



Contents

iii

Important Information................................................................... 2

Using the TI-Nspire™ Computer Link Software ....................5
Exploring handheld contents ....................................................... 7
Capturing screens from a handheld ........................................... 12
Backing up handheld documents on the computer .................. 17
Viewing handheld details ........................................................... 19
Updating the software and handheld OS .................................. 19
Texas Instruments Support and Service ...................................... 31

Index......................................................................................33



iv



Using the TI-Nspire™ Computer Link Software 1

Using the TI-Nspire™ Computer Link 
Software

The TI-Nspire™ Computer Link Software lets you:

• Transfer documents between your computer and a TI-Nspire™ 
handheld.

• Capture images from a TI-Nspire™ handheld screen and use them in 
TI-Nspire™ documents and computer documents.

• Make a backup of a handheld’s documents as a single file on your 
computer and later restore the documents.

• Update the operating system (OS) software on a TI-Nspire™ 
handheld.

Opening the TI-Nspire™ Computer Link Software
1. Make sure you have connected a TI-Nspire™ handheld to your 

computer.

Note: The TI-Nspire™ Computer Link Software works with the 
TI-Nspire™ handheld only. You cannot use it to communicate with 
other TI handhelds, such as a TI-92 Plus. To communicate with those 
handhelds, use the TI Connect™ software (version 1.6 or later) 
instead of TI-Nspire™ Computer Link Software.

2. Double-click the TI-Nspire™ Computer Link Software icon  on 
the desktop.

The software displays a list of connected handhelds and lets you 
select one.

Note: You can communicate with only one handheld at a time.



2 Using the TI-Nspire™ Computer Link Software

3. If multiple handhelds are connected, click the handheld to which you 
want to connect.

4. Click Select.

TI-Nspire™ Computer Link Software displays the Explorer tab.

Selecting among multiple handhelds
You can switch to a different handheld anytime you are using TI-Nspire™ 
Computer Link Software.

1. Connect the handheld to the computer.
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2. Click  at the lower right corner of the TI-Nspire™ Computer Link 
Software window.

3. Click the handheld name, and then click Select.

Exploring handheld contents
The Explorer tab in the TI-Nspire™ Computer Link Software lets you view 
the contents of a connected handheld and transfer (copy) documents 
between your computer and the handheld. You can also rename and 
delete handheld documents.

À

Â

Á

Ã
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À Column headings – In the detail view, click a heading to sort the list. 
Click again to reverse the order.

Á Files residing in the selected computer folder

Â Split bar – Drag up and down to show more or fewer files.

Ã Documents residing in the selected handheld folder

Selecting the view format

Note: You can click the Refresh button  anytime to refresh the file 
and folder lists.

Click View > Detail View or click  to view details of the files and 
to sort the list.

Click View > List View or click  to view a list of only the file 
names.

Click View > Show Folder View to show the structure of computer 
and handheld folders in a separate pane on the left.

Click View > Hide Folder View to hide the folder structure.

Viewing the contents of a handheld
1. If the Explorer is not visible, click the Explorer tab.

2. In the folder view, click any folder to show its contents in the right 
list.

Before copying documents or folders to a handheld
• With the exception of .fig files created with Cabri II Plus and .edc files 

created with LearningCheck™ Creator, TI-Nspire™ Computer Link 
Software allows only TI-Nspire™ handheld documents to be copied to 
a handheld. If you inadvertently try to copy other types of files, or a 
folder containing other types of files, TI-Nspire™ Computer Link 
Software notifies you and cancels the copy operation.

• When you copy a Cabri II Plus .fig file to the handheld, the file is 
converted to a two-page TI-Nspire™ (.tns) document:

– The first page is a Graphs & Geometry page with converted 
objects.

– The second page is a Notes page to let you know which 
elements were not converted successfully. 
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• Only subfolders can reside within the Documents folder on the 
handheld. You can copy files into those subfolders but not directly 
into the Documents folder.

• When you copy a folder to the handheld, you must copy it to the 
Documents folder. You cannot copy it to a subfolder.

• You can drag handheld files and folders only to locations within the 
TI-Nspire™ Computer Link Software application window. You cannot 
drag them outside the window.

Copying documents by dragging
You can drag the mouse to copy documents between a handheld and the 
computer or between two folders on the computer.

1. Click the document that you want to copy.

Note: You can select multiple documents by holding down the 
Ctrl key (“ key on the Macintosh®) and clicking each document.

2. Drag the selection, and drop it on the desired destination.

The selected items are copied to the destination.

Note: If a document of the same name already exists at the 
destination, you are asked if you want to replace it.

Copying folders by dragging
You can drag to copy folders between a handheld and the computer.

1. Click the folder that you want to copy.

Note: You can select multiple folders by holding down Ctrl key 
(“ key on the Macintosh®) and clicking each folder.

2. Drag the selection, and drop it on the desired destination.

The selected items are copied to the destination.

Note: If a folder or document of the same name already exists at the 
destination, you are asked if you want to replace it.
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Copying documents and folders by pasting
You can use the clipboard to copy documents and folders. If you want to 
move an item instead, copy it and then delete the original.

1. Click the document or folder to be copied.

Note: You can select multiple items by holding down the Ctrl key 
(“ key on the Macintosh®) and clicking each item.

2. Click Edit > Copy to copy the selected items to the clipboard.

3. Click a folder to select it as the destination.

4. Click Edit > Paste.

Explorer copies the items to the destination folder.

Note: If the destination already contains a document with the same 
name as the one you are copying, you can choose to either replace the 
existing document or cancel.

Canceling a transfer in progress
As long as the File Transfer window is displayed, you can cancel a 
transfer. Only the files that have not already been transferred are 
canceled.

In the File Transfer window, click Cancel.

Creating a new folder on the handheld
You can create a new folder within the Documents folder on the 
handheld. You cannot create a folder within a subfolder on the 
handheld.

1. Click the handheld name in the TI-Nspire™ File Browser.

2. Click File > New folder.

TI-Nspire™ Computer Link Software creates a folder named New 
Folder and selects the name so you can edit it.
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3. Type a name for the new folder and press Enter.

Renaming documents and folders on a handheld
Note: TI-Nspire™ Computer Link Software does not let you change a 
document’s file name extension.

1. Click the document or folder name and then click File > Rename.

A border appears around the name to show that you can edit it.

2. Type the new name and press Enter.

Deleting documents on a handheld
When you delete a document, it is permanently deleted and cannot be 
recovered.

Click the document name and then click File > Delete.

Before deleting the document, Explorer asks you to confirm that you 
want to delete it.

Notes:

• You can select multiple documents to delete by holding down the 
Ctrl key (“ key on the Macintosh®) and clicking each document. 
When you click Delete, Explorer deletes all the selected documents.

• You cannot delete files on the computer.

Deleting a folder on a handheld
When you delete a folder, the folder and all documents within it are 
permanently deleted and cannot be recovered.

Click the folder name and then click File > Delete.

Before deleting the folder, Explorer asks you to confirm that you 
want to delete it.

Notes:

• You can select multiple folders to delete by holding down the 
Ctrl key (“ key on the Macintosh®) and clicking each folder. When 
you click Delete, Explorer deletes all the selected folders.
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• You cannot delete the Documents folder on the handheld.

• You cannot delete folders on the computer.

Capturing screens from a handheld
The Screen Capture tab lets you capture images of the screen from a 
connected TI-Nspire™ handheld. You can then resize the images, add or 
remove a border, copy them into documents, or save them as image files 
on your computer.

À Screen Capture tab

Á Screen Capture toolbar

Â Captured handheld screens (in thumbnail view)

A border is automatically added to each screen, but you can remove it. 
The size of a captured screen is 326 pixels wide by 246 pixels high, with or 
without a border.

Capturing a screen
1. Make sure the handheld is turned on and properly connected to your 

computer.

2. On the handheld, display the screen that you want to capture.

3. Click the Screen Capture tab in the TI-Nspire™ Computer Link 
Software window.

À ÂÁ
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4. Click File > Take screenshot or click .

The Screen Capture window shows the captured image.

Note: If you most recently removed the border from a screen, new 
screens appear without a border. If you most recently added a border to 
a screen, new screens appear with a border.

Viewing thumbnails of captured screens
You can view screens individually or as a group of images, called 
thumbnails. A reference name is displayed under each image. The 
thumbnail view also lets you select multiple screen images for copying, 
saving, and so on.
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To view screens as thumbnails, click View > Thumbnails or click 

.

To view screens individually, click View > Single Screen or click .

Selecting multiple screens
Selecting multiple screens lets you quickly apply a modification to all of 
them. For example, you can select several screens and then resize them or 
remove their borders.

1. If necessary, click  to display the thumbnail view.

2. Use one of the following methods to select the screens.

• Click Edit > Select All or press Ctrl+A (“+A on the Macintosh®) 
to select all the captured screens.

• Click the first image that you want to select, and then hold 
down Ctrl (“ on the Macintosh®) as you click each additional 
image.

• Select a range of images by clicking the first image in the range, 
holding down Shift, and clicking the last image in the range.

Resizing screens
You can save a larger or smaller version of a screen image by zooming in 
or out before you save it.
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To display a larger screen image, click View > Zoom In or click .

To display a smaller screen image, click View > Zoom Out or click 

.

Adding or removing a border
The toolbar button for adding or removing a border toggles between 

add  and remove  depending on whether the selected image 
contains a border.

Note: If you most recently removed the border from a screen, new 
screens appear without a border. If you most recently added a border to 
a screen, new screens appear with a border.

1. Click the screen capture image to select it.

2. Click Edit > Remove Border or click  to remove the border.

– or –

Click Edit > Add Border or click  to add a border.

Adding or removing a border from a group of images

1. Click View > Thumbnails or click .

2. Select the group of images. You can either:

• Click the first image you want to select, and then hold down Ctrl 
(“ on the Macintosh®) as you click each additional image.

• Select a range of images by clicking the first image in the range, 
holding down Shift, and clicking the last image in the range.

3. Click Edit > Remove Border or click  to remove the border.

– or –

Click Edit > Add Border or click  to add a border.

Navigating among screen images
To view the previous screen image, click View > Previous Screen or 

click .
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To view the next screen image, click View > Next Screen or click 

.

Saving captured screens as computer files
You can save captured screens on your computer in TIF, GIF, or JPEG 
formats. The screens are saved in your My Documents folder unless you 
specify a different location to save them. All screens are saved at the size 
they are currently displayed.

1. Select the captured screen or screens that you want to save.

2. Click File > Save Screen or click .

3. In the dialog box:

a) Navigate to the folder in which you want to store the screen 
capture file.

b) Select the file type for the appropriate image format.

c) Type a file name. Use a name that describes the screen 
image.

d) Click Save.

Notes:

• If you have previously saved the selected screen image, clicking File > 

Save Screen or  replaces the previous file. To save the file in a 
different location, with a different name, or as a different file format, 
you must click File > Save Screen As.

• To save all the images at once, click File > Save All Screens. When 
you do this, you select the location to save the files in the Save All 
window, but you do not specify file names. Each screen image is saved 
with its default file name. If that name already exists, you’re 
prompted whether to replace the existing file.

• If you have unsaved screen images when you exit the TI-Nspire™ 
Computer Link Software, you are prompted to save them. If you 
choose to save the images, they are saved in your TI-Nspire/Screen 
Captures folder.

Copying a screen image to a computer application by 
dragging
1. Adjust the size of the TI-Nspire™ Computer Link Software window 

and the window of the other application so that you can see both 
windows on the computer screen.
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2. In the TI-Nspire™ Computer Link Software window, click the 
captured screen to select it.

3. Drag the screen from TI-Nspire™ Computer Link Software and then 
drop it into the other application.

Copying a screen image by pasting
You can copy and paste a captured screen into an application that allows 
pasting images.

1. Click the captured screen to select it.

2. Press Ctrl+C (“+C on the Macintosh®) to copy the image to the 
clipboard.

3. Click the other application at the point where you want to image to 
appear.

4. Press Ctrl+V (“+V on the Macintosh®) to paste the image into the 
application.

Backing up handheld documents on the computer
TI-Nspire™ Computer Link Software lets you save all of a handheld’s 
documents as a single backup file on your computer. You can create as 
many backups as you like. You can later restore the documents to the 
handheld.

Creating a one-click backup
When you use the one-click backup feature, TI-Nspire™ Computer Link 
Software creates a backup file on the computer in your TI-Nspire/Backups 
folder. The file name includes the year, month, day, hour, minute, and 
seconds of the backup.

Click Tools > One Click Backup.

A progress message is displayed during the backup process.

Creating a backup in a specified folder
Use this method if you want to specify the folder and file to be used for a 
backup.

1. Click Tools > Backup.

A dialog box is displayed to let you specify a backup file.
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2. Browse to the folder where you want to create the backup file.

3. Type a name for the file, or click an existing backup file to replace it.

4. Click Save.

A progress message is displayed during the backup process.

Restoring handheld documents from a backup
1. Click Tools > Restore.

A dialog box is displayed to let you select a backup file.

2. Browse to the folder that contains the backup file.

3. Click the backup file.

4. Click Restore.
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A message is displayed to warn you that restoring replaces all 
documents on the handheld.

5. Click OK to proceed with the restoration.

A progress message is displayed during the restoration.

If you cannot restore from a backup
In some cases, the device may not have enough memory for the restored 
files. TI-Nspire™ Computer Link Software detects this and gives you the 
option of expanding the backup file into individual documents on your 
computer. You can then selectively transfer documents to the device by 
using ordinary copy and move options.

Viewing handheld details
TI-Nspire™ Computer Link Software can display the following 
information about your handheld:

• Handheld type and ID

• Operating System (OS) version

• Device ID

• Boot version

• Total storage capacity

• Space used

• Free space

• Battery status

To view handheld details:

1. Connect the handheld you want to view.

2. Open the TI-Nspire™ Computer Link Software.

3. Click Tools > Device Information.

The device information displays. You can use your mouse to 
highlight and copy text.

Note: If you receive an error that says “Device is not responding,” check 
to make sure the handheld is connected firmly and try again.

Updating the software and handheld OS
From your Help menu, you can perform a number of important tasks and 
get useful information to help you use the product more productively. 
You can:
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• Register your product

• Check for updates to the software and OS (handheld OS updates are 
available only in Connect-to-Class™ software and TI-Nspire™ 
Computer Link software)

• Download the latest guidebooks

• Visit knowledge sites on the Internet to improve your proficiency 
with the product

• Check the current software version you’re using

You can download the latest TI-Nspire™ software or OS for the handheld 
or for the desktop software. You can download software in any 
TI-Nspire™ software. You can download the OS updates only in Connect-
to-Class™ software or TI-Nspire™ Computer Link software.

Note: Aside from viewing your current software version, you must be 
connected to the Internet to perform any of these tasks. You do not need 
to be connected to the Internet to view your current version of software 
as shown in the About command.

The images shown in this section are representative of Help menus 
available. They may vary, depending on the TI-Nspire™ software you use.

Registering your product
To register your product:

1. Start the desktop software. Make sure you have access to the 
Internet.

2. Click Help > Register.
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The Internet browser opens to the link for registering your software.

Downloading guidebooks
Downloading your product guidebook can help you:

• Find information easily and quickly

• Learn how to perform new tasks more easily and efficiently

• Improve your proficiency with the TI-Nspire™ applications

• Eliminate frustration and the need to keep track of a printed book

To download guidebooks:

1. Start the desktop software. Make sure you have access to the 
Internet.

2. Click Help > Download latest Guidebook ...

The Internet browser opens to a web page that will direct you in 
downloading the latest guidebook.

Accessing knowledge sites on the Internet
Your software contains quick links to the following sites. On these sites, 
you can find information about how to use TI products as well as lessons, 
quizzes, and other instructive activities shared by educators.

• The TI Education Technology site at http://education.ti.com

• The Activities Exchange, a forum where you can browse by subject 
matter the learning activities shared by educators

• The Knowledge Base, an online troubleshooting forum

Visiting the TI Education Technology site
1. Start the desktop software. Make sure you have access to the 

Internet.
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2. Click Help > Visit education.ti.com.

The Internet browser opens to the Education Technology home 
page. 

Visiting the Activities Exchange
1. Start the desktop software. Make sure you have access to the 

Internet.

2. Click Help > Visit Activities Exchange.

The Internet browser opens to a web page where you can select a 
language and country setting. Based on your selection, the Activities 
Exchange page will open.

Note: Activities may vary depending on the participants of the Activities 
Exchange in the language you select.

Visiting the Knowledge Base
1. Start the desktop software. Make sure you have access to the 

Internet.

2. Click Help > Visit Knowledge Base.
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The Internet browser opens to the home page for the Knowledge 
Base.

Updating your handheld OS

Preparing to update
Warning: Updating the operating system will delete all TI-84 
applications and files. Before installing an OS update, you should use 
TI Connect to back up all TI-84 applications and files to a computer. You 
can copy them back to the handheld when the OS update is complete.

If there is not enough room on the receiving handheld for the update, 
the sending handheld is notified. The only time documents can be 
affected by an OS installation is if the receiving handheld has a corrupted 
OS. In this situation, documents may be affected by OS restoration. It is a 
good practice to back up your important documents and folders before 
installing an updated operating system.

See the important information below concerning batteries before 
performing an OS update.

Important download information
You should always install new batteries before downloading a software 
or OS update.

When in OS download mode, the Automatic Power Down™ (APD) 
feature does not function. If you leave your handheld in download mode 
for an extended time before you begin the downloading process, your 
batteries may become depleted. You will then need to install new 
batteries before downloading.

Downloading handheld OS updates automatically
Here are some important notes to remember about updating your OS:
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• You must have a TI-Nspire™ Computer Link session active for your 
system to automatically notify you when a newer OS is available. 
However, you can use TI-Nspire™ Computer Link or Connect-to-
Class™ software to check for OS updates manually.

• If you are connected to the Internet, your system will automatically 
notify you of any TI-Nspire™ software updates when you connect 
your handheld to the desktop software.

• The automatic check occurs once during any TI-Nspire™ Computer 
Link session when a handheld is first connected. If you disconnect the 
handheld and then reconnect it during the same session, the check is 
not performed.

• If your system is up-to-date, you will receive no notification.

• You can turn off this feature if you don’t want to receive 
notifications automatically.

After the system has checked for an OS update, it displays the following 
dialog box if a newer version is available:

To install the OS update and manage your update notifications:

1. Check to make sure you’re connected to the Internet.

2. Select the options you want. You can do any combination of the 
following:

• Install the OS

• Save a copy of the OS for later installation or for your own use

• Change your Automatic Notification setting
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3. To turn off automatic notifications, de-select Automatically check 
for updates.

4. Click Browse if you want to change the location for saving a copy of 
the OS. Use the file browser to select a new location.

5. Click Continue to save the settings and begin the download.

A progress message box opens to show the download progress.

Note: If you receive a connection error, check your Internet connection 
and try again.

Downloading OS updates manually
To check for handheld OS updates:

1. Check to make sure you’re connected to the Internet.

2. Connect the handheld you want to update.

3. Open the TI-Nspire™ Computer Link or Connect-to-Class™ software.

4. Select the handheld you want to update.

5. Click Help > Check for Handheld OS Updates.

The software checks for updates. If the system is up-to-date, the 
following dialog box displays.

6. Click OK to close the box.
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7. If a new version is available, the following dialog box displays.

8. Select the options you want. You can do any combination of the 
following:

• Install the OS

• Save a copy of the OS for later installation or for your own use

• Change your Automatic Notification setting

9. To turn off automatic notifications, de-select Automatically check 
for updates.

10. Click Browse to change the location for saving a copy of the OS. Use 
the file browser to select a new location.

11. Click Continue to save the settings and begin the download.

A progress message box opens to show the download progress.

Note: If you receive a connection error, check your Internet connection 
and try again.

Downloading software updates automatically
Here are some important notes to remember about updating your 
software:

• If you are connected to the Internet and you have automatic 
notification enabled, your system will notify you of any TI-Nspire™ 
software updates when you open the desktop software. You can also 
check for updates manually.

• The automatic check occurs once each time you open the software.

• If your system is up-to-date, you will receive no notification.
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• You can turn off this feature if you don’t want to receive 
notifications automatically.

After the system has checked for an update, it displays the following 
dialog box if a newer version is available:

To install the software update and manage your update notifications:

1. Check to make sure you’re connected to the Internet.

2. To turn off automatic notifications, de-select Automatically check 
for updates.

3. Click Update to save the settings and begin the download.

A progress message box opens to show the download progress.

Note: If you receive a connection error, check your Internet connection 
and try again.

Downloading software updates manually
To check for software updates:

1. Check to make sure you’re connected to the Internet.

2. Open the TI-Nspire™, TI-Nspire™ Computer Link, or Connect-to-
Class™ software.

3. Click Help > Check for Software Updates.
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The software checks for updates. If the software is up-to-date, the 
following dialog box displays.

4. Click OK to close the box.

5. If a new version is available, the following dialog box displays.
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6. To turn off automatic notifications, de-select Automatically check 
for updates.

7. Click Update to begin the download, or Close to abandon the 
update.

A progress message box opens to show the download progress.

Note: If you receive a connection error, check your Internet connection 
and try again.
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Texas Instruments Support and Service

For general information 

For more information about TI products and services, contact TI by e-
mail or visit the TI Internet address.

Service and warranty information

For information about the length and terms of the warranty or about 
product service, refer to the warranty statement enclosed with this 
product or contact your local Texas Instruments retailer/distributor.

E-mail inquiries:  ti-cares@ti.com

Home Page: education.ti.com

mailto:ti-cares@ti.com
http://education.ti.com
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