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What's New

What's New in Version 3.10.0

* i0S 7 support

+  Show screen touches setting for presenters
*  Bug fixes and improvements

To reportissues and help us improve our apps, please email us at ti-

cares@ti.com.
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Getting Started

The TI-Nspire™ App for iPad® enables you to use the TI-Nspire™ Student
Software or TI-Nspire™ CAS Student Software on an iPad®.

What You Can Do

You can use the TI-Nspire™ App for iPad© and TI-Nspire™ CAS App for iPad®
to:

*  Perform calculations

*  Work with variables

* Importimages (photos)

* Respond to questions

*  Perform graphing and geometry functions
* Create lists and spreadsheets

* Analyse data

What You Must Know

Accessing Online Help

The TI-Nspire™ App for iPad® includes online help, which opens in the Safari
browser.

&

» To access the online help from within the app, tap Settings ,and then

tap Online Help.

Using the TI-Nspire™ Home Screen

By default, the TI-Nspire™ Home screen contains two pre-loaded folders (Maths
and Simulations), and three Getting Started documents: Getting Started with
the TI-Nspire™ App, Getting Started with Data and Statistics, and Getting
Started with Graphs. All folders and documents that you create are added to
the TI-Nspire™ Home screen.
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Gettig Stared with Graphs

Data - Getting St... Graphs - Getting ... Getting Started

Note: TI-Nspire™ App for iPad® supports only TI-Nspire™ documents.
To return to the TI-Nspire™ Home screen from any other screen within the

application, tap Home for .

About Folders

The default Maths and Science folders and any folder you create are yellow.
You can:

+ Change folder names
+ Add documents to these folders or delete documents from these folders
* Delete the folders

Folders that have been synchronised with Dropbox are blue. Once a folder is
synchronised with drop box, you cannot delete it. You can, however,
synchronise them with your Dropbox account, add or delete documents, and
select to show or hide them on the Home screen.

Accessing Settings

{‘é} .

1. From the TI-Nspire™ Home screen, tap Settings
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2. Tap the option names to:
*  Online Help. Open the TI-Nspire™ online help.
*  Show MyLib Folder. Select to show or hide the MyLib folder.
*  Show Touch. Select to show or hide touches to the screen.

*  Dropbox Account. Synchronise folders and documents to your
Dropbox account.

+  Export to PDF - Header Title. Change the default title for exported
PDFs.

*  About. Read information about the app, and check the version of the
app.
*  Privacy Policy. Open the Texas Instruments Online Privacy Policy.

3. Tap Done to return to the TI-Nspire™ Home screen.

Managing Folders

In the TI-Nspire™ App for iPad®, management of folders is completed on the
Home screen.

Opening Folders

» Tap the folder icon to open a folder.
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*  When you open a folder, all documents within the folder are
displayed.

+ Tap adocumenticon to open a document within the folder.

+ Tap the folder to close the folder without opening any of the
documents.

Adding New Folders

1. Tap Add + , and then tap Folder.

Add New Document

Make a Selection to Begin
Calculator

\&/ Graphs

Geometry

=_= Lists & Spreadsheet
m Data & Statistics

Notes

Add New Folder

l _| Folder

2. To name the folder, tap the default name assigned to the folder.
3. Type a new name and tap return.

Note: Folders can contain documents, but cannot contain sub-folders.

Creating a Folder with Existing Documents

You can also create a new folder by dragging one document onto another
document.

1. Tap Edit.

2. Drag one document onto another document to create a new folder that
contains both documents.

3. Tap Done.

(o)
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4. Rename the folder if needed.

Renaming Folders
1. Tap the default name under the folder.
The keyboard opens.
2. Type a new name, and then tap return.
The new name is displayed and the keyboard closes.
Note: To return to the TI-Nspire™ Home screen without renaming the item, tap a

blank area on the screen.

Deleting Folders

Before you delete a folder, remember that folders may contain several
documents. You may want to verify the folder contents before you delete it.

1. Tap Edit.
2. Tap ® on the folder you want to delete.
+ Tap Delete to delete the folder.

+  Tap Cancel to cancel the delete.

3. Tap Done.

Managing Documents

In the TI-Nspire™ App for iPad®, organizing and managing documents is
completed on the Home screen.

Opening a Document
» Tap the documenticon.

The document opens to the last problem and page you were working on.

Adding New Documents

1. Tap Add +.
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Add Document

Calculator

Graphs

Lists & Spreadsheet
Data & Statistics

Geometry
Il

Notes

Add Folder

L Folder

2. Tap an application name.
A new document opens with the selected application as the first page. The
new documentis assigned a default name.

Renaming Documents

1. Tap the default name under the document to open the keyboard.

2. Type a new name, and then tap return.

The new name is displayed and the keyboard closes.

Moving Documents to an Existing Folder
1. Tap Edit.
2. Drag the documenton top of the folder.

3. Tap Done.

Deleting Documents

Before you delete a document, remember that the document may contain
several problems and pages. You may want to verify all the contents before
you delete the document.

1. Tap Edit.

2. Tap ® on the document you want to delete.

3. When the Alert message is displayed:
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*  Tap Delete to delete the document.
+  Tap Cancel to cancel the delete.

4. Tap Done.

Selecting a Preferred Language

The TI-Nspire™ App for iPad® is available in several languages. To select a
preferred language:

1. From the iPad® Home screen, tap Settings > International >

Language.
2. Tap alanguage name to select it.
The app changes to the selected language.

Note: The TI-Nspire™ App for iPad® is not available in all languages listed
in the iPad® settings. If you select a language that is not supported, the
keyboard supports the text, but the TI-Nspire™ app runs in English.

Selecting an International Keyboard

International keyboards can be used in the TI-Nspire™ App for iPad®. To select
an another keyboard:

» From the iPad® Home screen, tap Settings > International >

Keyboards.

After you select an additional keyboard from the iPad® settings, the Native

iPad® Keyboard displays a Globe key @ to enable you to choose from the
different keyboards.

Using TI-Nspire™ App for iPad® Keyboards

The TI-Nspire™ App for iPad® has two keyboards: the TI-Nspire™ Keyboard
and the Native iPad® Keyboard.

To insert common functions, templates, and other maths expressions into
documents, tap S50 to show the TI-Nspire™ Keyboard.
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To type text and numbers, tap e to show the Native iPad®

Keyboard., which is the standard alpha-numeric keyboard.
Note: This keyboard changes when you select language options.
Jx [oo] Tl
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2123 2123

Accessing Alternate Functions
On the TI-Nspire™ Keyboard, many keys have an alternate function. Alternate

functions provide related options for the selected key. Keys with alternate
functions are shown with a coloured stripe on top.

Example of alternate
functions.

sin’’ CSC C8G"
Stripe indicates an

alternate function is
available.

0,0 -
{DD sin cos
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» To access an alternate function, touch and hold the key, and then slide your
finger to the desired function.
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Working with Documents

All work created using TI-Nspire™ applications is stored in a TI-Nspire™
document (.tns file), which you can share with others.

A document consists of one or more problems and each problem contains one
or more pages. A single page is displayed in the work area. All work occurs in
the applications within pages.

When you add a new document, the selected application is the first page of the
document.

2:03 PM

Document 1

3

The TI-Nspire™ Toolbar.
Page sorter.

Document toolbar.

© ©®© 0 ¢

Document work area. This example shows the Lists & Spreadsheet
work area.

What You Must Know

You add, rename, duplicate and delete documents from the TI-Nspire™ Home
screen. See Getting Started with the TI-Nspire™ App for iPad® for information
about adding, renaming and deleting documents.
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Documents can reside on the TI-Nspire™ Home screen as a single document,
or reside in folders with other documents. There are different types of folders:

+ Dropbox folders - These are folders that have been synchronised with
Dropbox. You cannot delete these folders. You can, however, synchronise
them with your Dropbox account, add or delete documents and select to
show or hide them from the TI-Nspire™ Home screen.

» Created folders - These are folders you create. You can edit and delete
these folders, and add or delete documents.

* MyLib folder - The MyLib folder contains library documents. This folder is
shown if you have chosen to show itin the Settings > Preferences menu.

Note: In the TI-Nspire™ App for iPad®, folders can contain documents, but
cannot contain sub-folders.

Exploring the TI-Nspire™ Toolbar

The TI-Nspire™ Toolbar contains tools available for use in open documents.

3:22PM

Document 1

0 Home. Return to the TI-Nspire™ Home screen.
n

Add. Add a new page or problem to a document.

+

Settings. Apply document settings for the active document or to all

documents.

= Share. Share the active document using iTunes® or email.

m Utilities. Access utilities for the active application (symbols,
catalogue and so forth).

e Undo/Redo. Undo or redo the last action. Tap to Undo. Touch and

hold to display Redo option.

Name | Document Name. The name of the active document.
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Camera. Take a photo or insert an existing photo in a document.

Note: You can insert photos in the Graphs, Geometry, Data &
Statistics and Notes applications.

Open In. Show all apps that can open a TI-Nspire™ document.

? Help. Access Online Help or the PDF Guidebook.

Exploring the Document Work Area

The document work area consists of the application toolbar, the open
document and the page sorter.

From open documents on the work area, you can add, delete and rearrange
pages in documents, and you can rename problems.
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Modelling Page Sorter. Displays thumbnail sketches of all pages in all
problems in the current document. Swipe up or down to
view pages off the screen.

Problem 2

Application. Icon indicates which application is active in
the work area.

X =
m Calculator

= Lists & Spreadsheet

llu] Data & Statistics

—= Notes

1.2 Problem/Page Number. Displays the problem number
followed by the page number.

P Tools. Opens the tools menu for the active application.
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134 Inspector. Tap to change the properties of a selected item.

) Settings. Tap to change the Graphs & Geometry settings.

= History. In the Graphs application, shows the history of the
defined functions.

@ Show/Hide. In the Graphs application, shows or hides the
keyboard.

Opening a New Document

1. On the TI-Nspire™ Home screen, tap Add + .
The New menu opens.
2. Tap an application name.

A new document opens with the selected application as the first page. The
new document is assigned a default name.

Saving Changes to Documents

When you tap Home ol from an active document, the TI-Nspire™ App gives
the following options:
* Ifyou added a new document:
- Tap Keep Changes to save and name the document.
-  Tap Discard Changes to close the document without saving it.
+ Ifyou are working on an existing document and make changes:
- Tap Keep Changes to save as a new document.

- Tap Discard Changes to close the document without keeping any
changes you made. The name of the document is also unchanged.

» Ifyou open an existing document but do not make any changes, the app
does not ask you to keep any changes.
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Adding Pages to Documents

1. Inthe page sorter, tap the page in the problem where you want to add
another page.

2. TapAdd ® .
The New Page menu opens.
3. Tap the type of application you want to add to the document.
A new page is added to the document beneath the current page.

Note: To move a page, touch and hold the page, and then drag it to
another position.

Adding Problems to Documents

1. From an active document, tap Add D .

Add Page to Document

Calculator

& Graphs

Geometry

Lists & Spreadsheet

m Data & Statistics
E| Notes

Add New Problem to Document

(m ,

™

2. Tap Problem.
3. Tap the type of problem you want to add to the document.
A new problem is added beneath the current problem in the page sorter.

Note: To rename the problem, double-tap the problem name, type the new
name, and then tap return.
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Deleting Pages from Documents

1. Inthe page sorter, tap the page you want to delete to select it.
2. Tap the page again to open the context menu.
3. Tap Delete.

+ To delete the page, tap Delete Problem Page.

+ To cancel the delete, tap anywhere outside of the Confirm Delete box.

Copying and Pasting Pages in Documents

You can cut, copy, and paste pages from documents to other places in the
active document or in another document.

Copying or Cutting Pages

1. Inthe page sorter, tap the page you want to cut or copy.

2. Tap again to open the context menu.

3. Tap cutor copy.

Pasting Pages to Another Location
1. Tap the page in the page sorter where you want to paste.

2. Tap again to open the context menu, and then tap paste.

The page is pasted beneath the selected page in the problem.

Changing Document Settings

Document settings control how all numbers, including elements or matrices
and lists, are displayed in TI-Nspire™ documents. You can change the default
settings at any time, and you can specify settings for a specific document.

Complete the following steps to customize the settings that are applied to your
document.

1. Create a new document or open an existing document.

2. Tap Settings @.

When you open Document Settings the first time, the default settings are
displayed.
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3. Tap the menu name to open the menu and view the available values for

each setting.
Field Value
Display Digits *  Float
*  Float1 - Float12
*  Fix0-Fix12
Angle * Radian
+ Degree
+ Gradian
Exponential Format * Normal

+  Scientific
* Engineering

Real or Complex
Format

* Real
* Rectangular

. Polar
Calculation Mode « Auto
e CAS: Exact

*  Approximate

Note: Auto mode shows an answer that is not a
whole number as a fraction except when a
decimal is used in the problem. Exact mode
(CAS) shows an answer thatis nota whole
number as a fraction or in symbolic form, except
when a decimal is used in the problem.

Vector Format

* Rectangular

*  Cylindrical
*  Spherical
Base + Decimal
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Field Value

*  Hex

* Binary
Unit System (CAS) « S

« Eng/US.

4. Selectthe desired settings.

5. Choose one of the following options:
» To apply the customized settings to ALL documents, tap Make Default.
+ To apply the settings to the open document only, tap Done.

+  To restore default settings, tap Restore.

Sharing Documents

Sharing Documents Using Dropbox

You can synchronise documents to your Dropbox account and share those
documents on your iPad® mobile digital device, computer and other devices.

1. On the TI-Nspire™ Home screen, tap Settings @ .

2. Login to the Dropbox account, or if you already logged in, tap Dropbox
Account.

The Dropbox Home folder is automatically synchronised when you log in.
To synchronise other folders, you must add them first. After folders are
added, they are automatically synchronised the next time you log in.

Note: To perform a manual synchronisation at any time, tap Re-sync Folders.
Sharing Documents Using iTunes®

%

» To share documents with iTunes®, tap Share
+  Tap Copy from iTunes to receive documents from iTunes®.
+ Tap Send to iTunes to send documents to iTunes®.

Note: When you send a single document, the active document is sent, including
all problems and all pages within the problems.
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Sending Documents Using Email

To send a document using email, you must have an email account set up on
your iPad®.

1.  Open the document you want to send.

=
2. Tap Share = .

3. Tap Email Document.

The app opens your default email client, with the document as an
attachment.

4. Enter the email address and tap Send.
Exporting a Document as a PDF

%__) .

To export a document as a PDF, tap Share

1. Tap Export As PDF.

The app opens a screen showing the PDF.

2. TapOpenin = .

The toolbar may hide after a few seconds. Tap the screen to show the
toolbar.

3. Tap any of the icons to indicate where you want to export the PDF.

Receiving Documents

If you have an email account set up on your iPad®, you can receive documents

that the teacher sends, work on those documents and send them back to the
teacher.

To receive a document by email:
1. Tap the icon of the attached document in the email.

2. Depending on which app you installed, tap Open In TI-Nspire™ or tap
Open In TI-Nspire™ CAS.

The document opens in the TI-Nspire™ App for iPad®.
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Working with Photos in Documents

Photos can be used in the TI-Nspire™ App for iPad® for reference, assessment
and instructional purposes.

What You Can Do
Add photos to the following TI-Nspire™ applications:

Graphs
Geometry
Data & Statistics

Notes

What You Must Know

In the Graphs, Geometry and Data & Statistics applications, photos are set
in the background behind the axis and other objects. In the Notes
application, the photo is set at the cursor location inline with the text (in the
foreground).

You can take a photo and add it to your document, or you can use a photo
that is already stored in the photo albums. The TI-Nspire™ software
automatically creates a photo album named TI-Nspire™ Photos and stores
itin the iPad® photo albums. You can also use other photo albums that
you create on the iPad®.

Taking Photos

1.

2
3.
4

Open the document to the page where you want to add a photo.
Tap Camera ©.

Aim the iPad® viewfinder at the object you want to capture.

Tap Take Photo.

When you take the photo, a preview is displayed.

» Todiscard the photo and take a different one, tap Retake.

+ Toinsertthe photo in the document, tap Use.

The photo is inserted into the active document and added to the Camera
Roll album.
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Adding Existing Photos to Documents

1. Open the document to the page where you want to add a photo.
2. TapCamera ©.

3. Tap Add Photo.

4. Tap the album where the photo resides.

5. Tap a thumbnail of the photo you want to insert.

The photo is inserted into the active document.

Resizing Photos

You can resize photos in all applications that use photos.
1. Selectthe photo.

* Inthe Graphs, Geometry and Data & Statistics applications, tap the
Tools icon ¢ and go to Actions > Select Photo.

+ Inthe Notes application, tap the photo to select it.

2. Drag a corner of the photo to resize it.

Deleting Photos

Delete photos from within the open document.
1. Selectthe photo.

* Inthe Graphs, Geometry and Data & Statistics applications, tap Tools
# and go to Actions > Select Photo.

* Inthe Notes application, tap the photo to selectit.
2. Tap the photo to open the context menu.

3. Tap Delete.

Capturing Screens

You can capture a page instead of the whole App screen.

=’

1. Tap Share
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w
2. Tap Send Page to Photos ==

The screen will turn white for a second.

The image is saved to the Photos App.
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Calculator Application

The Calculator application enables you to enter and evaluate maths
expressions. You can define variables, functions and programs in Calculator.
When you define or edit a variable, function or program, it becomes available
to other applications—such as Graphs or Geometry—that are part of the same
problem.

What You Can Do

The Calculator Tools

P

menu provides the tools you need to:
Complete actions.
Work with numbers.

Work with maths functions such as algebraic expressions, calculus
problems, probability and statistics.

Work with matrices and vectors.
Create and solve financial equations.

Define and edit functions, variables and programs.

What You Must Know

Deferring Evaluation

You don't have to complete and evaluate an expression as soon as you enter
it. You can enter part of an expression, leave the page to check work on
another page, and then come back to the page to the complete the expression
ata later time.

Forcing a Decimal Approximation

To force a decimal approximation in a result, complete one of the following
actions:

Touch and hold ENTER, and then slide to select H to evaluate the
expression.

Include a decimal in the expression.

Wrap the expression in the approx() function.
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Accessing Calculator History ltems

You cannot edit an expression if the result has been calculated. However, you

can copy the expression from the history and paste it into the entry line.

Copying History ltems

1. Drag the work area up or down to find the expression or result you want to
copy.

2. Tap the expression to selectit and open the context menu.

3. Tap Paste History to copy the expression into the active entry line.

Copying Part of an Expression

1. Tap the expression to selectit.

2. Drag the handles to highlight the part of the expression you want to copy.

3. Tap Paste History or tap ENTER to copy the selected item to the active
entry line.

Clearing Calculator History

When you clear the history, all variables and functions defined in the history
retain their current values. To clear all items in the Calculator history:

Ve

1. Tap Tools and go to Actions.

2. Tap Clear History to remove all expressions and results from the history.

Note: If you clear the history by mistake, touch and hold o ,and then tap Undo
to restore the history items.

Adding a Calculator Page

To open a new document or add a page to an existing document with the
Calculator application active:

1. From the TI-Nspire™ Toolbar, tap + .

+ Ifthisis a new document, the Add Document menu opens.

+ Ifadding a page to an existing document, the Add Page to Document
menu opens.
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2. Tap Calculator !

The Calculator application is added to the document. By default, the
TI-Nspire™ Keyboard is shown and the cursor is in the entry line.

Problem 1

E_ E x a n r o ovar [ 0 . (=)

o Entry line. Type or insert a maths expression in the entry line. Tap
ENTER to evaluate the expression.

2752

2843
3

12
You can also insert functions, symbols, templates or expressions from
Utilities = .
Note: If the keyboard is hidden, tap the entry line to show it.
@ Calculator work area. As you evaluate expressions, both the
expression and result are saved in Calculator history. To distinguish
between each saved expression and result, every other entry line is

shaded. To view entry lines that are hidden, drag the work area up or
down to scroll.

Entering Simple Maths Expressions

Note: To enter a negative number, tap instead of the minus sign.
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28.43

Suppose you wantto evaluate 12

1. Tap an entry line in the Calculator work area.

2] 2] [¢]
2. Tap to begin the expression.

3. Tap J’ to return the cursor to the baseline.

4. To complete the expression:

e
Tap .

|
28.43/12

5. Tap ENTER to evaluate the expression.

The expression is displayed in standard mathematical notation and result
is displayed on the right side of the entry line. If a result does not fit on the
same line with the expression, itis displayed on the nextline.

28.43 2752
12 3

The expression and the result are added to the Calculator history.

Inserting Symbols, Functions, Commands and Templates

System functions and commands, symbols and expression templates are
stored in Utilities. To access Utilities, tap ™.
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Symbols >

Catalog >
Math Operators >
Libraries >

Utilities menus open to the last menu used. For example, if Symbols was the
last menu accessed, it opens by default the next time you tap ™.

To insert a symbol

1. Tap Symbols to open the Symbols palette.
2. Tap asymbol to insertitinto the entry line.

Note: Drag the list of symbols up and down to view all available symbols.

To insert an item from the catalogue

1. Tap Catalogue to view the list of available functions and commands.

2. Tap a function name to select it and then tap Done to insertit into the entry
line.

*  Flick the list of Catalogue items up or down to view all items in the list.

+  Type the first letter(s) of a function name in the search field to jump to
entries that begin with that letter. To return to the top of the list, clear
the search field.

~

+ To access the Tools Wizard, tap to hide keyboard.
+ Ifa Catalogue function requires a defined variable, you must define
the variable before you can insert the Catalogue item.
To insert a maths operator
1. Tap Maths Operators to view the list of operator types.
2. Tap a category hame to open the list of available operators.

3. Tap an operator name, and then tap Done to insert itinto the entry line.
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Using Wizards

Some functions in the Catalogue have a wizard that prompts you for each
argument. Functions that have wizard support are identified with the wand

symbol f .

To enable wizards

v

1. Tap to hide the TI-Nspire™ keyboard if it is showing.

2. Tap Utilites ™, and then go to Catalogue. By default, the Tools Wizard is
OFF.

Utilities Catalog

abs(
amortThl(

and

beres—sneoep

angle(
ANOVA /

ANOVA2way #

® Tools Wizard

angle(Value)
angle(List)
angle(Matrix)

Slide the button to the right to enable the Tools Wizard.

Select the function you want to insert. (The function must have wizard
support.)

5. Tap Done.
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The wizard opens and prompts for each argument before the function is
inserted into the entry line.

= son xm

Data Input Method: Data

Number of Groups: E 2

6. Enter the arguments needed for the selected function.

Note: If the keyboard is needed to complete an entry, it opens when you
tap the field.

7. Tap OK as needed to complete entries in each prompt for the selected
function.

The selected function is inserted into the Calculator entry line.

Note: If a Catalogue function requires a defined variable, you must define
the variable before you can insert the Catalogue item.

Using an Expression Template
7

> b

Suppose you want to evaluate n=3

1. Tap the entry line to show the keyboard.

2. Tap “—.

The algebraic sum template is inserted into the entry line. Small blocks
represent elements that you can enter.

Note: The blue line on the top of this key indicates this key has alternate
functions. Touch and hold the key to access the alternate function.
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3. Use the arrow keys (or tap each element) to move the cursor to each
element's position and enter a value or expression in each position.

32 Calculator Application



Variables Overview

A variable is a defined value that can be used multiple times in a problem. You
can define a value or function as a variable within each application. Within a
problem, variables are shared by TI-Nspire™ applications. For example, you
can create a variable in Calculator, and then use or modify that variable in
Graphs, Geometry or Lists & Spreadsheet within the same problem.

Each variable has a name and definition. The definition can be changed, and
when you change the definition, all occurrences of the variable in the problem
are updated to use the new definition. In the TI-Nspire™ software, a variable
has four attributes:

* Name - User-defined name assigned when the variable is created.
* Location - Variables are stored in memory.

+  Value - Number, text, mathematical expression or function.

+ Type - Type of data that can be stored as a variable.

Variables created with the Local command within a user-defined function or
program are not accessible outside of that function or program.

Using Variables in a Problem

*  When first created, a variable is available only to the problem where itis
defined.

» Avariable can be used multiple times in applications that are part of the
same problem.

» Ifthe value of the variable is changed in the original application, the
change is reflected in all applications where the variable is used.

* Avariable is not available to other problems or documents until you define
the variable as a library object and copy it to a library folder. See Libraries
for more information.

Defining Variables

Any portion or attribute of an object or function created within an application
can be stored as a variable. Examples of attributes that can become variables
include the:

* Area of arectangle

. Radius of a circle

Variables Overview 33



»  Value contained in a spreadsheet cell
*  Contents of a row or column in a spreadsheet
+  Function expression

When you create a variable, it is stored in memory.

Types of Variables
You can store the data types listed in the following table as variables.

Data type Examples

Expression 2.54 1.25e6 2n xmin/10  2+3i (x-

2)
2
List {2,4,6, {1,1,2} "red", "blue", "green"}
8}
Matrix 123 This can be entered as: {1, 2, 3, 3, 6, 9}
369
Character "Hello"  "xmin/10" "The answer is:"
string
Function, myfunc( arg ) ellipse(x,y, r1,r2)
program
Measurement area perimeter length slope angle

Naming Variables and Functions

Names for variables and functions that you create must meet the following
naming rules.

Note: If you create a variable with the same name as one used for statistical
analysis or by the Finance functions, an error condition could occur. When you
enter the name of a variable that is already in use in the current problem, the
entry is shown in bold.

+ Variable names must be in one of the forms xxx or xxx.yyy. The xxx part
can have 1 to 16 characters. The yyy part, if used, can have 1to 15
characters. You cannot start or end the variable name with a period (.).
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Characters can consist of letters, digits and the underscore character (_).
Letters can be U.S. or Greek letters (but not [ or n), accented letters and
international characters.

Do not use ¢ or n from the symbol palette to construct a variable name
such as c/ ornl2. These may appear to be letters, but they are treated
internally as special symbols.

You can use uppercase or lowercase letters. The names AB22, Ab22,
aB22 and ab2?2 all refer to the same variable.

You cannot use a digit as the first character of xxx or yyy.

When entering a subscript, you can use digits zero through 9, U.S. letters,
a through z, Latin and Greek letters (but not 7) as subscripts (for example,
a, q,or h20). To enter a subscript while typing a variable name, touch and

var []
hold , and then slide to select

Do not use spaces.

If you want a variable to be treated as a complex nhumber, use an
underscore as the last character of the name.

CAS: If you want a variable to be treated as a type of unit (such as _m or _
f1), use an underscore as the first character of the name. You cannot use
any other underscores in the name.

You cannot use an underscore as the first character of a name.

You cannot use a pre-assigned variable, function or command name, such
as Ans, min or tan.

Library documents and library objects are subject to additional naming
restrictions. For more information, see Libraries.

Creating Variables in Calculator

When creating a variable, use the following conventions. As alternatives to
using — (store), you can use ":=" or the Define command. All of the following
statements are equivalent.

5+83num
num:=5+83

Define num=5+83
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To Create a Variable in the Calculator Application
1. Tap the Calculator entry line to show the keyboard.

var
2. Touch and hold to show the alternate functions, and then slide to the

desired function.

ABC %3 Txas INSTRUMENTS T
O {88 s s o & Ol F 7 8 9 ()
BlEMN ="l =1> NENERER < | - |
3 4 1 28 S + || EE
S0 [Bao n &
[i=i) o
= sto-»
r var T

3. Enterthe value for the variable (a number, text, mathematical expression
or function).
4. Tap ENTER.

Note: Use the right, left, up, and down arrows to move the cursor within the
expression or function. Make sure the cursor is positioned correctly in the
entry line before tapping ENTER to create the variable.

Entering Multiple Variables on the Entry Line

To enter several variables on a single line, separate them with a colon (). Only
the result of the last expression is shown.

a:=5: b:=2: E-1. 2.5
b

Creating Variables in Graphs

In the Graphs application, functions defined on the entry line are automatically
stored as variables.
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In this example, f1(x)=x3 is automatically stored as a variable definition named
f1, which you can use in other applications in the problem, including a table in
the Lists & Spreadsheet application.

\

f)‘(x)=x3‘

When you tap ENTER, the equation is graphed, and the variable is defined.

var

Tap to see the list of defined variables.

ﬂx) f1

012 num

Creating a Variable from a Geometry Value

In this example, the area of the triangle will be the value for a variable named
"triangle".

1. Tap the value you want to store to select it, and then tap it again to open
the context menu.

P SRR,
Delete Store Link

2. Tap Store.

var := appears before the selected value. This is the default name.
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Tvari:* 32.1 cm?

3. Replace the default name var with the variable name you want to give the
value.

4. Tap ENTER.

The value is saved to that variable name, and the stored value or its name
appears in bold text to indicate that it is a stored value.

triangle=32.1 cm

Creating Variables in Lists & Spreadsheet

Naming a list at the top of a Lists & Spreadsheet column or creating a variable
from a cell value automatically stores that value as a list variable. After defining
the variable, you can link to it from the Graphs, Geometry, Calculator and Data
& Statistics applications as well as from other Lists & Spreadsheet pages within
the current problem.

Note: When naming variables, use a nhame that does not exist in the current
problem.

Creating a Variable from a Column Name
1. Tap the column's name cell (the top cell of the column).

2. Type a name for the list variable, and then tap return.
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\A | multiply
[~ multiply ]r: b E F [ H

A | multiply

o
i
| A a
i multiply
|

7

9

10

3. Create elements in the list. For example, type data into each cell or use a
formula to generate a column of data.

Notes:

+ Lists can contain empty elements (denoted by an underscore ("_").

*  You can refer to a specific elementin a named list from the Calculator
application. Use the list name and the element's position within the list. In a
list named Heights, for example, refer to the first element as Heights[1].
The expression Heights[2] refers to the second elements, and so on.

Creating a Variable from a Cell Value

You can share a cell value with other TI-Nspire™ applications. When defining

or referring to a shared cell in Lists & Spreadsheet, precede the name with an

apostrophe ().

1. Tap the cell that contains the value you want to share, and then tap again
to open the context menu.

. A multiply B C
*
| 1 8
— I,J\ .....
f 2 9
—7_ 4 16
\/ ;
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2. Tap Store.
A formula is inserted into the cell with var as a placeholder for the variable
name.

@©®

\ 44 | Varj=product(azza3)|
|A muttiply |8 €] ~p E F G H

2 9
B[ \ 3

LLE A4 kar£=product(a1 :03)

’Amultiply B . @ a
———— .| oEn
&8 3 -] G
4 k'a.li=pro> 5 @ ENTER

Replace the letters "var" with a name for the variable.

w

Tap return.

The value is now available as a variable in other applications within the
same problem.

Adjusting Variable Values with a Slider

In the Graphs, Geometry and Data & Statistics applications, a slider control lets
you adjust or animate the value of a numeric variable.
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f1 (x) =24yl

; + + + + + + + + + + + A# + +
y \_/ \/fz(\) sm(xﬂ‘Z)\/l

Y=

v2=9.

o Horizontal slider for adjusting variable v1.

@ Minimised vertical slider for adjusting variable v2.

Inserting a Slider
1. Startin a Graphs, Geometry or Data & Statistics page.

2. TapTools # and go to Actions > Insert Slider.

The Slider Settings screen opens.

Variables Overview 41



E Slider Settings

HE

Variable: vi
Value: 5
Minimum: 0
Maximum: 10
Step Size: Automatic .
Style: Horizontal .
Display Digits: Float 3 .
Minimized D

Show Variable @
Show Scale @

Enter desired values.
4. Tap OK.

The slider is displayed in the work area. Handles on the slider let you
move or stretch it. To remove the handles, tap the work area.

5. To adjust the variable, slide the pointer (or tap the arrows on a minimised
slider).

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or
stop its animation. You can also change the slider's settings. To open the
context menu:

1. Touch and hold the slider.

The context menu opens.
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Animate Settings... Move Delete

2. Tap an option to select it.

Linking a Lists & Spreadsheet Cell or Column to a Variable

When you link a cell or column to a variable, Lists & Spreadsheet updates the
values to reflect the current value of the variable. The variable can be any
variable in the current problem and can be defined in Graphs, Geometry,
Calculator or any instance of Lists & Spreadsheet.

Notes:

*  You cannot link to the same variable multiple times on the same page.

* Do notlink a cell to a system variable. Doing so could prevent the variable
from being updated by the system. System variables include ans,
StatMatrix and statistics results (such as RegEqn, dfError and Resid).

Linking a Cell Value to an Existing Variable

1. InaLists & Spreadsheet page, tap the cell that you wantto link to a
variable. This should be an empty cell and the cell cannotbe in a list thatis
already defined as a variable.

2. Tap the cell again to open the context menu.
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A multiply [B c D E F e H

Y

3. Tap Link.

0
12 num

012 triangle

4. Tap the name of the variable to insertitinto the cell.

The value of the variable is displayed in the cell.

Linking a Column to an Existing List Variable

To view or edit values in a list variable, link a column to the list variable. The list
can be any shared listin the current problem and can be defined in Graphs,
Geometry, Calculator or any instance of Lists & Spreadsheet.

After you link a column to a list, changes you make to the listin other
applications are automatically updated in Lists & Spreadsheet.

1. Tap the column formula cell (the second cell from the top) that you want to
link to a variable.

2. Type the name of the list variable that you want to link to, and then tap
return.

—OR-
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To view the list of available variables:

» Tap on the TI-Nspire™ Keyboard, and then tap a variable name.

{=} age

# |A weight B age C ge

1 125 22|f {___}
2 150 35|f

3 140 seff f 01,
4 185 34|m

The column shows the list elements.

Locking and Unlocking Variables

Variables

Locking a variable protects it from modification or deletion, and prevents
unintended changes to a defined variable. For example, you may want to lock

variables that define time or altitude to ensure integrity.

You cannot lock the following variables:

+  System variable ans

* stat. and tvm. variable groups

Locking Variables

1. Go to the Calculator application, and tap the entry line to show the

keyboard.

2. TapTools ~.
3. Go to Actions, and then tap Lock.
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Lock Variable

Unlock Variable

Get Lock Info

4. Tap Lock Variable to select the function and insertitinto the entry line.

5. Tap , and then tap the variable name you want to lock.
Note: You can also type the variable name in the entry line.
6. Tap ENTER.
The result Dorne indicates the variable is locked.

Locked variables display a lock icon on the variable menu list.

Variables

ﬂ num

Note: The Lock command clears the Redo/Undo history when applied to
unlocked variables.

Unlocking Variables

To modify or delete a locked variable, you must unlock the variable.

1. Tap Tools ¥ and go to Actions > Lock.

2. Tap Unlock Variable to enter the function into the entry line.

var
3. Tap , and then tap the locked variable name.

4. Press ENTER to remove the locked status.

The result Done indicates the variable is now unlocked.
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Graphs Application

The Geometry application lets you create, manipulate, analyse and trace
graphs of mathematical relations.

What You Can Do

+ Define and explore functions and other relations, such as inequalities,
parametrics, polars, sequences and differential equation solutions.

*  Graph and explore linear and conic equations analytically in a two-
dimensional coordinate system. Analyse lines, circles, ellipses, parabolas,
hyperbolas and general conic equations.

*  Animate points on objects or graphs and explore their behaviour.

+ Define relations to share with other applications, such as Calculator or
Notes.

* Link to data created by other applications.

What You Must Know

Finding Hidden Objects in the Graphs or Geometry Application

You can hide graphs, geometric objects, text, labels, measurements and
individual axis end-values.

To temporarily view hidden graphs or objects or to restore them as shown

objects, tap Tools ¥ and go to Actions > Hide/Show. Tap a graph or object to
toggle its Hide/Show state.

Changing the Appearance of a Graph or Object
1. Tap the graph or object that you want to change.

2. Tap the Inspector ! to display a list of the object's attributes.

Line Color [ ] >
Fill Color ] >
Line Weight / /7
Line Style S
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Note: The list of attributes is different for different types of objects.

3. Selectthe items to change. Changes are applied as you select them.

Animating a Point on a Graph or Object
1. Tap the point.

2. Tap Inspector ** to display the point's attributes.

o T

Line Color

Animation
Speed

Alternate Direction E
Shape E‘ >

3. Drag the Animation Speed slider to set the speed and start the animation.

0

Inserting a Background Photo

The Insert Photo © tool lets you insert a photo as a background for any
Graphs or Geometry page.

Adding Text to the Graphs or Geometry Work Area

1. Tap Tools # and go to Actions > Text.

The Text tool % appears in the application Toolbar.
2. Tap the location for the text.

3. Type the textin the box that appears, and then tap return.

0.296

Slope of a Line|

4. To editthe text, double-tap it.
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Adding a Graphs Page

To get started with the Graphs application, add a Graphs page to an existing
document.
+ v

Tap ,and then tap

A new Graphs page appears, showing the Graphs Toolbar, entry line, and work
area.

L1l 7.; o E L

= A

Ik + 4 + 4 4 4 4 4 4 " + 4 + 4 + + + +
'10' + + + + + + + + 1' + + + + + + + 11

6.74

0 Graphs Toolbar
+  TapTools ¥ to create and explore graphs.
+  Tap Inspector ! to change the appearance of a graph.

«  Tap ¥ to change the settings used by the Geometry and
Graphs applications.

+ Tap — toview or editan expression from the graph history.

«  Tap @ to hide or show the keyboard and the entry line.

@ Entry line. Lets you define the relations that you want to graph.
The default graph type is Function, so the form f1(x)= is displayed
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initially. You can define 99 relations of each type.

@ Graphs Work Area
»  Shows graphs of relations that you define on the entry line.

+  Shows points, lines, and shapes that you create with
geometry tools.

+ Pinch to zoom, drag to pan (affects only those objects
created in the Graphs application).

Graphing Functions

1. In the Graphing view, tap Tools ¢ and go to Graph Entry/Edit > Function.

7104

2. Type an expression for the function.

fl)=x2+1.5)

3. Tap ENTER to graph the function.

6.74

£1(x)=x2+1.5

+—

Manipulating a Function by Dragging

Linear * Totranslate, grab near the middle of the graph, and then
Function drag.
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» Torotate, grab near the ends of the graph, and then drag.

Quadratic | © To translate, grab near the vertex of the graph, and then
Function drag.

* To stretch, grab away from the vertex of the graph, and

then drag.
Sine or + Totranslate, grab near the axis of vertical symmetry of the
Cosine graph, and then drag.

Function «  To stretch, grab away from the axis of vertical symmetry of
the graph, and then drag.

Finding Points of Interest on a Function Graph

» Create a point on the graph, and then drag the point to quickly identify
maximums, minimums, and zeroes.

Temporary signposts appear as you drag through the points of interest.

minimum

(-7.85,-3)

» For other points of interest, tap Tools ¢, select Analyse Graph, and select
the type of analysis, such as Integral. The application prompts you to
choose a graph and define the boundaries.

Graphing Linear and Conic Equations

1. In the Graphing view, tap Tools ¢ and go to Graph Entry/Edit > Equation.

2. Tap the type of equation (Line, Parabola, Circle, Ellipse, Hyperbola or
Conic).
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Tap the specific template for the equation. For example, tap y=a-x2+b-x+c
to define a parabola.

The entry line includes a symbol to indicate the type of equation.

el W |yl el

Type the coefficients into the equation template.

el M | y=1-x2+2:x+3

Tap ENTER.

6.24 Ay

=x242- x+3

Graphing Parametric Equations

1. In the Graphing view, tap Tools ¢ and go to Graph Entry/Edit >
Parametric.
x1(2)
1(t)=
0=¢<6.28 tstep=0.13
2. Type expressions for xn(f) and yn(t).
xI(t)=sinlz)- 4
1(t)=cos(1)- 3
0=¢<6.28 tstep=0.13
3. (Optional) Edit the default values for tmin, tmax and tstep.
4. Tap ENTER.
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4.41 Ay

{xl (¢)=sin(z)- 4
vl (¢)=cos(z)- 3

Graphing Polar Equations

1. In the Graphing view, tap Tools ¢ and go to Graph Entry/Edit > Polar.

ri(6)-
0=60<=6.28 Ostep=0.13

2. Type an expression for rn(6).
3. (Optional) Edit the default values for Omin, Omax and Ostep.

ri(g)=.2-0
0<8=(n- 10) Bstep=0.13

4. Tap ENTER.
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Using the Text Tool to Graph Equations

In the Graphs application, tap Tools # and go to Actions > Text.

2. Tap the work area to place the text box and display the keyboard.
3. Type an "x="or"y="equation, such as x=sin (y) *2, or type an inequality,
such as x<2*sin(y), and tap ENTER.
4. Drag the text object to either axis to graph the equation.
6.74 Ay
x<2-sin(y}
1 :
i
Graphing a Scatter Plot
1. In the Graphs application, tap Tools ¢ and go to Graph Entry/Edit >
Scatter Plot.
s1 {j::
2. Use one of the following methods to specify two lists to plotas x and y.
var
- Tap to select a list variable that you have defined in the current
problem.
- Type the name of an existing list variable, such as v1.
- Type the list elements directly (for example, type {1,2,3}.
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s1 x+<vl
“v2

3. Tap ENTERto plot the data, and then zoom the work area to view the
plotted data.
Plotting Sequences

Defining a Sequence

1.

In the Graphing view, tap Tools ¥ and go to Graph Entry/Edit > Sequence
> Sequence.

ul(n)=
Initial Terms:=
1=n=99 nstep=1

Type the expression to define the sequence.

Type an initial term. If the sequence expression references more than one
prior term, such as u1(n-1) and u1(n-2), separate the terms with commas.

{ui[u}—l.] culln—1)+1

Initial Terms:=1
1=n=99 nstep=1

Tap ENTER.
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@ ul(z)=1.1-ulln—1)+1
2 I.
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*9‘8”12”"“”‘

Defining a Custom Sequence

A custom sequence plot shows the relationship between two sequences by
plotting one on the x axis and the other on the y axis.

This example simulates the Predator-Prey model from biology.

1. Use the relations shown here to define two sequences: one for a rabbit
population, and another for a fox population. Replace the default
sequence names with rabbit and fox.

rabbit(n)=rabbit(n—1)- (14+0.05-0.001- fox(n—1)]
Initial Terms:=200
1=n=400 nstep=1

fox(n)=fox(n—1)- (1+2.€-4- rabbit(n—1)-0.03)
Initial Terms:=50
1=n=400 nstep=1

.05 = the growth rate of rabbits if there are no foxes
.001 =the rate at which foxes can kill rabbits

.0002 = the growth rate of foxes if there are rabbits
.03 = the death rate of foxes if there are no rabbits

Note: If you want to see the plots of the two sequences, zoom the window
to the Zoom - Fit setting.

2. TapTools ¥ and go to Graph Entry/Edit > Sequence > Custom.

3. Specify the rabbit and fox sequences to plot on the x and y axes,
respectively.
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x < rabbit(n)
p1 «~fox(n)

1=n=400 nstep=1

4. Tap ENTER to create the custom plot.

5. Zoom the window to the Zoom - Fit setting.

70.07 ¥

................

pl: (rabbil(n] fox [n))

X
85.57 227.35

6. Explore the custom plot by dragging the point that represents the initial
term.
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Graphing Differential Equations

y1 '=| kel
d1:

(xo,yTo): (1 L1 ) o2

\ -+
\ . \ * \ \ \ \ \ \ \ \ \
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\ \ \ \ \ \ \
\ \
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o ODE entry line:
* y1 ODE identifier
»  Expression k'y1 defines the relation

+ Fields (1,1) for specifying initial condition

Buttons for adding initial conditions and setting plot parameters

@ Slider added for adjusting coefficient k of the ODE

© Slope field

0 A solution curve passing through the initial condition

To Graph a Differential Equation:

1. In the Graphing view, tap Tools ¢ and go to Graph Entry/Edit > Diff Eq.

The ODE is automatically assigned an identifier, such as “y1.”

y1 =
di:

Goyla): : )| o

2. Move to the relation field and enter the expression that defines the relation.
For example, you might enter -y1+0.1*y1*y2.
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y1 = yi+0.1y1y2

d1:
(Xo,¥10):  (

y [P

3. Enter the initial condition for the independent value x, and for y10.

Note: The x, value(s) are common to all the ODEs in a problem but can be
entered or modified only in the first ODE.

4. Tap Edit Parameters |""I to set the plot parameters. Select a numerical
Solution Method, and then set any additional parameters. You can change
these parameters anytime.

E Differential Equation “
Solution Method Euler
Iterations Between Plot Step 1
Field Slope
Axes
X«

y«

Plot Start: -10
Plot End: 10
Plot Step: 0.1
Field Resolution: 14

Direction Field at x=

5. Tap OK.

6. Zoom the window as necesssary to view the graph.

Viewing Tables in the Graphs Application

Tap Tools ¢ and go to Table > Split-screen Table.
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The table is displayed with columns of values for the currently defined
relations.

100 Ay b £1(x):=10- sin(x)

xn|f1x):=  Yjul(ny= ¥ A

10*sin(x) |2*ul(n-1)..

lll(u) 2-ul(n—l)+l 0. 0. #ERR

1 8.41471 2.

2 9.09297 5.

3. 1.4112 1915

4. -7.56802 23.

5 -9.58924 47.

6 -2.79415 95.

1(x)=10- sin(x) 7 6.56987 191.

8 9.89358 383.

Q 412118 767

To remove the table, tap Tools ¢ and go to Table > Remove Table.

Note: For details about using tables, see Working with Tables.

Accessing the Graph History

For each problem, the Graphs application automatically stores a history of
defined relations, such as functions f1 through f99 and sequences u1 through
u99. You can view and edit these items.

Viewing the History of the Current Relation Type

1. Tap History = atthe right end of the Graphs toolbar to show the history of
the current relation type (for example, f for Functions).

History Done

2. Inthe History list, tap the name of the relation, and then tap Done to show
the relation in the entry line.
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3. Use the up and down arrow keys to scroll through the defined relations.

Viewing the History of other Relation Types

1. In the Graphing view, tap Tools ¢, go to Graph Entry/Edit, and tap the
relation type. For example, tap Polar to show an entry line for the next
available Polar relation.

2. Use the up and down arrow keys to scroll through the defined relations.

Customising the Graphs Work Area

Note: Rescaling in the Graphs application affects only the graphs, plots and
objects that reside in the Graphing view. It has no effect on objects in the
underlying Plane Geometry view.

Zooming/Rescaling Manually
» To rescale the x and y axes proportionally, pinch the work area.

» To rescale only one axis, tap Tools #, select Actions > Constrained
Movement and then drag along the axis.

Zooming to predefined settings

» Tap Tools ¢, select Window/Zoom and select one of the predefined Zoom
settings. The initial setting is Zoom - Standard.

Displaying the Grid

1. In the Graphs application, tap Tools ¢ and go to View > Grid.
2. Tap Dot Grid, Lined Grid or (if the grid is already displayed) No Grid.

Changing the Appearance of the Grid

1. In the Graphs application, tap Tools ¢ and go to Actions > Select Grid.
The grid will flash.

2. Tap the Inspector ! to show a list of attributes that you can change.

Changing the Appearance of the Graph Axes

1. Tap either axis to select the axes.

Graphs Application 61



2. Tap the Inspector ** to show a list of attributes that you can change.

Show Tic Labels M ]
Show End Values M ]

Line Color - >
End Arrows + -+

3. Select the items to change. Changes are applied as you select them.

Tracing Graphs or Plots

1. In the Graphing view, tap Tools ¢ and go to Trace > Graph Trace.

The Graph Trace tool appears in the Graphs toolbar, the trace cursor
appears, and the cursor coordinates are displayed in the lower right
corner.

y=0.6"x+5

-3.11 | el:(2,6.2)
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2. Explore a graph or plot:
- Tap a pointon a graph or plot to move the trace cursor to that point.
- Tap *“ or = on the Graph Trace tool to step the cursor along the

current graph or plot. The screen pans automatically to keep the
cursor in view.

- Double-tap the trace cursor to enter a specificindependent value.
- Tap and hold the trace cursor to create a persistent point.
3. To stop tracing, tap the X on the Graph Trace tool.

Introduction to Geometric Objects

Geometry tools are accessible in both the Graphs and Geometry applications.
You can use these tools to draw and investigate objects such as points, lines
and shapes.

»  The Graphing view shows the Graphs work area superimposed on the
Geometry work area. You can select, measure and alter objects in both
work areas.

* The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines and shapes created in the Graphs application are analytic objects.

+ All points that define these objects reside on the x,y graph plane. Objects
created here are visible only in the Graphs application. Changing the axes
scale affects the appearance of the objects.

*  You can display and edit the coordinates of any point on an object.

*  You can display the equation of a line, tangent line, circle shape or
geometric conic created in the Graphs application.
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f1(x)=sin(x) .

6.74 Ay

poly
5 [ ]

22.2 cnm?

conic
23.9 u*

0.073 x2%0,099- x- y+0.27- y2+

-6.74

0.56- x+2.16; y+3.43=0

The circle arc and polygon were created in the Geometry application. The
sine wave and conic were created in the Graphs application.

Objects Created in the Geometry Application

Points, lines and shapes created in the Geometry application are not analytic

objects.

Geometry application

Points that define these objects do not reside on the graph plane. Objects
created here are visible in both the Graphs and Geometry applications, but
they are unaffected by changes to the Graphs x,y axes.

You cannot obtain the coordinates of an object’s points.

You cannot display the equation of a geometric object created in the
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Creating Geometric Objects

You can create objects in both the Geometry and Graphs applications.

Creating Points and Lines

1. Tap Tools ¢, select Points and Lines, and select the type of object, such
as Segment. (In the Graphs application, go to Geometry > Points and Lines
> Segment.)

2. Tap existing points or locations on the work area to define the object. For
example, tap two objects when creating Intersection points.

As you create the object, a tool is shown in the application Toolbar (for

example, Segment = ). To cancel, tap the X on the tool.

Creating Geometric Shapes

1. Tap Tools #  select Shapes, and select the type of object, such as
Polygon. (In the Graphs application, go to Geometry > Shapes > Polygon.)

2. Tap existing points or locations on the work area to define the object. For
example, tap two locations to define the centre and radius of a circle.
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As you create a shape, a tool is shown in the application Toolbar (for

# Pol
example, Polygon a ). To cancel the shape, tap the X on the tool.

Measuring and Transforming Geometric Objects

Measuring Objects

1. Tap Tools #  select Measurement, and select the type of measurement,
such as Length. (In the Graphs application, go to Geometry >
Measurement> Length.)

2. Tap the object you want to measure.

Measurement Type Use to
Measure...

Length + Lengthofa
714 Ky segment,

circle arc or

vector

12.9 cn

Distance
Between
Two Points,
a Pointand
alineora
Pointand a
Circle

Circumferen
ce of a Circle
or Ellipse or
the
Perimeter of
a Polygon,
Rectangle or
Triangle
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Measurement Type Use to
Measure...

+ Asideofa
triangle,
rectangle or
polygon.
You must tap
two points to
measure a
side.
Tapping the
side
measures
the entire
length of the
object's
perimeter.

Area Area of a Circle,
6.74 Ay Ellipse, Polygon,

Rectangle or

Triangle

46.9 cm*

Slope Slope of a Line,
Ray, Segment or
Vector
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Measurement Type Use to
Measure...

0.296

Angle Angles in the
7.62 Ay | range from 0° to

1 180° (0 radians

to nradians in

1 the Graphs

o application)

12.80

Transforming Objects

1. Tap Tools #  select Transformation, and select the type of transformation,
such as Symmetry. (In the Graphs application, go to Geometry >
Transformation > Symmetry.)

2. Tap the object you want to transform.

3. Tap a location, existing point or other object to create the transformation.
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Exploring with Construction Tools

To add a construction, tap Tools #  select Construction, and select the type of
construction, such as Parallel. (In the Graphs application, go to Geometry >

Construction > Parallel.)

While a construction is in progress, a tool appears in the application Toolbar

/4 Parallel 'Y
(for example, Parallel - ). To cancel, tap the X on the tool.

Construction Type

Description

Midpoint

/S

Bisects a
segment or
sets a
midpoint
between any
two points.
The points
canbeona
single object,
on separate
objects or on
the work
area.

Parallel Line

7

Creates a
parallel line
with respect
to any
existing line.
The existing
line can be a
Graphs axis
or any side
of a triangle,
square,
rectangle or
polygon.
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Construction Type Description
Perpendicular Line Creates a
line thatis

+ =7

perpendicula
rtoa
reference
line. The
reference
can be an
axis, an
existing line,
a segment or
one side ofa
triangle,
rectangle or
polygon.

Perpendicular Bisector

Creates a
perpendicula
r bisector on
a segment,
on one side
of a triangle,
rectangle or
polygon or
between any
two points.

Angle Bisector

Creates an
angle
bisector. The
points of the
angle can be
on existing
objects, or
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Construction Type Description

they can be

locations on

the work
z area.

Locus Lets you
explore the
range of
motion of
one object
with respect
to another
objectas
constrained
by a shared
point.

Compass Operates
similarly to a
geometric
compass
used for

drawing
4.05 cm \ circles on

paper.
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Adjusting Variable Values with a Slider

In the Graphs, Geometry and Data & Statistics applications, a slider control lets
you adjust or animate the value of a numeric variable.

f1(x) =x2+vl

0 Horizontal slider for adjusting variable v1.

@ Minimised vertical slider for adjusting variable v2.

Inserting a Slider
1. Startin a Graphs, Geometry or Data & Statistics page.

2. TapTools ¥ and go to Actions > Insert Slider.

The Slider Settings screen opens.
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5.

E Slider Settings “
Variable: vi .
Value: 5
Minimum: 0
Maximum: 10
Step Size: Automatic .
Style: Horizontal .
Display Digits: Float 3 .
Minimized D

Show Variable

Show Scale

AR

Enter desired values.

Tap OK.

The slider is displayed in the work area. Handles on the slider let you
move or stretch it. To remove the handles, tap the work area.

To adjust the variable, slide the pointer (or tap the arrows on a minimised

slider).

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or
stop its animation. You can also change the slider's settings. To open the
context menu:

1.

Touch and hold the slider.

The context menu opens.
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Animate Settings... Move Delete

2. Tap an option to select it.

Labeling (Identifying) the Coordinates of a Point

The Graphs application can identify and label the coordinates of any existing
point, provided the point was created in the Graphs application.

1. Tap the pointto selectit, and then tap it again to show its context menu.

Delete Coordinates Label

2. Tap Coordinates.

6.7 Ay

-9.97 1
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If you move the point to a different location, the coordinates follow the point
and update automatically.

Bounded Area (Area Between Curves)

You can use the Graphs application to access the area between curves.
When you calculate the area between curves, each curve must be:
» Afunction with respectto x.
-or-
* Anequation in the form y=, including y= equations defined through a text

box or a conic equation template.

Defining Bounded Area (Area Between Curves)

1. Open a new Graphs page.
Tap sin and x, then tap ENTER.

®Tap .

B ow N

Tap cos and x, then tap ENTER.

For this example the graph now shows f1(x)=sin(x) and f2(x)=cos(x)
function(s).

o T T S

6.74 Ay

f1(x)=sin(x)

£2(x)=cosl(x)

&

6.74
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5. Tap Tools ¥ and go to Analyse Graph > Bounded Area.

The Bounded Area tool appears in the application
Toolbar. You are prompted to set the lower and upper bounds.

6. Tap ordrag two points to define the bounds.

PR

6.74 Ay

ﬂ[x) sin(x)

/
:8
\l

X\‘
5‘

2(x)=cos(x)

M .
upper bo.und7 : -6.74

The area becomes shaded, and the area value is displayed. The value is
always non-negative, regardless of the interval direction.

Working With Shaded Areas

As you change the bounds or redefine the curves, the shading and the area
value are updated.

* Tochange the lower or upper bound, drag it or type new coordinates for it.
You cannot move a bound that resides on an intersection. However, the
point moves automatically as you edit or manipulate the curves.

+ Toredefine a curve, either manipulate it by dragging or edit its expression
in the entry line.

Note: If an endpoint resided originally on an intersection, and the redefined
functions no longer intersect, the shading and area value disappear. If you
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redefine the function(s) so that there is an intersection point, the shading
and area value reappear.

. To delete or hide an area, tap to select the bounded area, then tap again
to see the context menu. From the context menu, you may delete the
bounded area.

+ To change the colour and other attributes, tap the Object Inspector once
the shaded region is selected.

Displaying the Equation of a Geometric Object

You can display the equation of a geometric line, tangent line, circle shape or
geometric conic, provided the object was constructed in the Graphs application
and can be converted faithfully to a template-based conic.

1. Tap the object to selectit, and then tap it again to show its context menu.

6.74 Ay

(]
1
——— i
L]
R S —
Delete Equation Label i

2. Tap Equation to display the equation as a Text object.

6.74 Ay

1+ x2+1.01 x+ y—0.25- y2+5,66+ x+3.31 - y+8.5=0

1
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Using the Calculate Tool

The Calculate tool is available in the Graphs and Geometry applications. It lets
you evaluate a maths expression you have entered as a text object. You can
edit an evaluated expression and then re-evaluate it.

Entering the Expression

1. Tap Tools # and go to Actions > Text.
Tap the work area to place the text box and display the keyboard.
Type the expression, such as (1/4)2*2, and tap ENTER.

Note: Do notinclude variables in the expression.
ol
4

2
Calculating the Result

1. Tap Tools # and go to Actions > Calculate.

2. The Calculate tool appears in the toolbar, and a prompt asks you to select
an expression to calculate.

3. Tap the text object to evaluate the expression.
1
2 -
(A] 273
4
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3D Graphing

The 3D Graphing view lets you create and explore three-dimensional graphs.

What You Can Do

» Create and edit 3D functions of the form z(x,y).
* Create and edit 3D parametric plots.

»  Show and hide selected graphs.

+  Setthe background colour and apply wire and surface colours to graphs.

Selecting the 3D Graphing View

The 3D Graphing View is available on any Graphs page 24 or Geometry

pace 1Y

» Tap Tools ¥ and go to View > 3D Graphing.

gy = [2) |

o 3D Graphs Toolbar

+  TapTools ¥ to create and explore 3D graphs.

«  Tap Inspector *!* to change the appearance of a graph or the 3D
box.
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« Tap to view or edit an expression from the 3D graph history.

«  Tap © to hide or show the keyboard and the entry line.

@ Entry line. Lets you define 3D graphs. The default graph type is 3D
Function, indicated by z/(x,y)=.

@ 3D Graphs Work Area. Shows a 3D box containing graphs that you
define. Pinch to zoom the area, drag to rotate the box.
Graphing 3D Functions

1. Inthe 3D Graphing view, tap Tools ¢ and go to 3D Graph Entry/Edit >
Function.

The keyboard and the entry line appear.

2 (xy) =1

2. Enter the expression that defines the graph. You can type the expression
or build it using expression templates.

[ 2,2
+
IZ-CGS[X Y

2 (xy) =

3+x2+y2

3. Tap ENTER to create the graph and hide the entry line and keyboard. You
can show the entry line and keyboard anytime by tapping ® on the
Graphs Toolbar.
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Graphing 3D Parametric Equations

1. Inthe 3D Graphing view, tap Tools ¢ and go to 3D Graph Entry/Edit >
Parametric.

The keyboard and the entry line appear.

wl o ) =] |

wpl  (tu)= <Lnter expression

pl (tu) = < Lnier expression

2. Type the equations that define the graph.

xpl (tu)= 4 cos(!)*sin(u)- cos(!)

ypl  (tu) = 4-sin(t)-sin(u)- sin(z)

zpl (L) =| cos(u)

3. (Optional) Tap ""lto setthe 3D plotting parameters tmin, tmax, umin and
umax.
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E 3D Plot Parameters m

tmin = 0
tmax = 2*pi
umin = 0
umax = 2*pi

4. Tap ENTER to draw the graph and hide the entry line and keyboard. You

can show the entry line and keyboard anytime by tapping ® onthe
Graphs Toolbar.

Zooming and Rotating the 3D View

Zooming

» Pinch the work area to zoom in or out.

Rotating Manually

» Dragin any direction to rotate all objects in 3D Graphing view.

Rotating Automatically

1. Tap Tools ¥ and go to Actions > Auto Rotation.

The Auto Rotation tool =5 appears, and the graph rotates
continuously around the z axis.
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2. To stop the rotation, tap X on the tool.

Editing a 3D Graph

1. Double-tap the graph or its label to display the expression in the entry line.
As an alternative, you can use the graph history to show the expression.

x24y2

12- cos

0zl (xy=

3+x2+y2

2. Modify the existing expression, or type a new expression in the entry line.
3. Tap ENTER to draw the edited graph.
Changing the Appearance of a 3D Graph

1. Tap the graph to selectit.

2. Tap Inspector **.

3D graph

Line Color - >
Fill Color [ ] >
X Resolution o1 [ = + |
Y Resolution o1 [= 7+
Transparency 30 | = + |
Shading s0 [=  + |
Display Format >

3. Selectthe items to change. Changes are applied as you select them.

Showing or Hiding a Graph’s Label

1. Tap the graph to select it, and then tap it again to show its context menu.
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Delete Hide Label Edit

2. Tap Hide Label or Show Label.

Showing and Hiding 3D Graphs

1. In the 3D Graphing view, tap Tools ¢ and go to Actions > Hide/Show.

elS

The Hide/Show tool = appears, and all hidden items are
displayed in gray.

2. Tap a graph to change its hide/show state.
3. To apply the changes, tap X on the tool.

Note: If you want to show or hide only the graph's label, see Showing or Hiding
a Graph’s Label.

Customising the 3D Viewing Environment

Changing the Background Colour
1. Tap the 3D box to select it.

Note: If the box is hidden, tap Tools ¢ and go to View > Show Box.
2. Tap Inspector **.
3. Tap Fill Colour, and then select a colour to apply it to the background.
Changing the Appearance of the 3D Box and Axes

1. Tap the 3D box to select it.
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2. Tap Inspector **.

Show Tic Labels m

Show End Values M
Line Color - >
Fill Color — >

End Arrows 1 -

3. Selectthe items to change. Changes are applied as you select them.

Showing or Hiding the Box, Axes, and Legend

1. Tap Tools ¥ and go to View.

2. Tap the name of the element to show or hide.
Changing the 3D Aspect Ratio

1. Tap Tools ¥ and go to Range/Zoom > Aspect Ratio.

2. Entervalues for the x, y, and z axes. The default value for each axis is 1.
Changing the Range of the 3D Box

» Tap Tools ¥ and go to Range/Zoom > Range Settings.

Adjusting Variable Values with a Slider

In the Graphs, Geometry and Data & Statistics applications, a slider control lets
you adjust or animate the value of a numeric variable.
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f1 (x) =24yl

; + + + + + + + + + + + A# + +
y \_/ \/fz(\) sm(xﬂ‘Z)\/l

Y=

v2=9.

o Horizontal slider for adjusting variable v1.

@ Minimised vertical slider for adjusting variable v2.

Inserting a Slider
1. Startin a Graphs, Geometry or Data & Statistics page.

2. TapTools # and go to Actions > Insert Slider.

The Slider Settings screen opens.
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5.

E Slider Settings “
Variable: vi .
Value: 5
Minimum: 0
Maximum: 10
Step Size: Automatic .
Style: Horizontal .
Display Digits: Float 3 .
Minimized D

Show Variable

Show Scale

AR

Enter desired values.

Tap OK.

The slider is displayed in the work area. Handles on the slider let you
move or stretch it. To remove the handles, tap the work area.

To adjust the variable, slide the pointer (or tap the arrows on a minimised

slider).

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or
stop its animation. You can also change the slider's settings. To open the
context menu:

1.

Touch and hold the slider.

The context menu opens.
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Animate Settings... Move Delete

2. Tap an option to select it.
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Geometry Application

The Geometry application lets you create, manipulate, measure, transform and
animate geometric objects.

What You Can Do

+ Create and explore points and lines, such as line segments, vectors and
circle arcs.

+  Create and explore geometric shapes, such as circles, ellipses, polygons
and conics.

* Animate any point created as a point on an object or graph.

+ Explore object transformations, including symmetry, reflection, translation,
rotation and dilation.

. Create geometric constructions, such as bisectors, parallels,
perpendiculars, loci and circles drawn with a compass.

* Hide an object or change its line colour, line style or fill colour.

. Measure lengths, angles, perimeters, areas and slopes.

What You Must Know

Finding Hidden Objects in the Graphs or Geometry Application

You can hide graphs, geometric objects, text, labels, measurements and
individual axis end-values.

To temporarily view hidden graphs or objects or to restore them as shown

objects, tap Tools ¢ and go to Actions > Hide/Show. Tap a graph or object to
toggle its Hide/Show state.

Changing the Appearance of a Graph or Object
1. Tap the graph or object that you want to change.

2. Tap the Inspector !t to display a list of the object's attributes.
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Line Color [ ] >
Fill Color —
Line Weight /7 /
Line Style 3 02

Note: The list of attributes is different for different types of objects.

3. Selectthe items to change. Changes are applied as you select them.
Animating a Point on a Graph or Object
1. Tap the point.

2. Tap Inspector ** to display the point's attributes.

Line Color - >
- T

Animation 0
Speed

Alternate Direction E
Shape E‘ >

3. Drag the Animation Speed slider to set the speed and start the animation.

Inserting a Background Photo

The Insert Photo © tool lets you insert a photo as a background for any
Graphs or Geometry page.

Adding Text to the Graphs or Geometry Work Area

1. Tap Tools # and go to Actions > Text.

The Text tool % appears in the application Toolbar.
2. Tap the location for the text.

3. Type the textin the box that appears, and then tap return.
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0.296

Slope of a Line|

4. To editthe text, double-tap it.

Adding a Geometry Page

To get started with the Geometry application, add a Geometry page to an
existing document.

Tap + ,and then tap .

A new Geometry page appears, showing the Geometry Toolbar and work area.

N £ £ Lo 1

1cm

0 Geometry Toolbar

+ TapTools ¥ to create and explore Geometry objects.

«  Tap Inspector ** to change the appearance of a selected
item such as a geometric shape.

«  Tap Graphs & Geometry Settings ** to change the
settings used by the Geometry and Graphs applications.

9 Geometry work area. Geometry objects that you create are
displayed here. Drag to pan the work area.

Geometry Application 91



Introduction to Geometric Objects

Geometry tools are accessible in both the Graphs and Geometry applications.
You can use these tools to draw and investigate objects such as points, lines
and shapes.

»  The Graphing view shows the Graphs work area superimposed on the

Geometry work area. You can select, measure and alter objects in both
work areas.

»  The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application
Points, lines and shapes created in the Graphs application are analytic objects.

» All points that define these objects reside on the x,y graph plane. Objects
created here are visible only in the Graphs application. Changing the axes
scale affects the appearance of the objects.

* You can display and edit the coordinates of any point on an object.

* You can display the equation of a line, tangent line, circle shape or
geometric conic created in the Graphs application.

6.74 Ay °

poly
arc g )

22.2 cm?

® 11 (_)(]*sin [x) .

conic
23.9 u?*

0.073+ x2%0,099- x- y+0.27- ,1'24 0.56- x+2.16; y+3.43=0

\

6.74

The circle arc and polygon were created in the Geometry application. The
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sine wave and conic were created in the Graphs application.

Objects Created in the Geometry Application
Points, lines and shapes created in the Geometry application are not analytic
objects.

* Points that define these objects do not reside on the graph plane. Objects
created here are visible in both the Graphs and Geometry applications, but
they are unaffected by changes to the Graphs x,y axes.

* You cannot obtain the coordinates of an object’s points.

*  You cannotdisplay the equation of a geometric object created in the
Geometry application

N Ly

\

n 68.1°

Creating Geometric Objects

You can create objects in both the Geometry and Graphs applications.

Creating Points and Lines

1. Tap Tools #  select Points and Lines, and select the type of object, such
as Segment. (In the Graphs application, go to Geometry > Points and Lines
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> Segment.)

2. Tap existing points or locations on the work area to define the object. For
example, tap two objects when creating Intersection points.

As you create the object, a tool is shown in the application Toolbar (for

example, Segment ). To cancel, tap the X on the tool.

Creating Geometric Shapes

1. Tap Tools ¢, select Shapes, and select the type of object, such as
Polygon. (In the Graphs application, go to Geometry > Shapes > Polygon.)

2. Tap existing points or locations on the work area to define the object. For
example, tap two locations to define the centre and radius of a circle.

As you create a shape, a tool is shown in the application Toolbar (for

# Pol
example, Polygon * ). To cancel the shape, tap the X on the tool.

Measuring and Transforming Geometric Objects

Measuring Objects

1. Tap Tools #  select Measurement, and select the type of measurement,
such as Length. (In the Graphs application, go to Geometry >
Measurement> Length.)

2. Tap the object you want to measure.

Measurement Type Use to
Measure...
Length *+ Lengthofa
segment,
circle arc or
vector

. Distance
Between
Two Points,
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Measurement Type Use to
Measure...

7.14 Ry a Pointand
alineora
Pointand a
Circle

12.9 cn

Circumferen
ce of a Circle
or Ellipse or
the
Perimeter of
a Polygon,
Rectangle or
Triangle

+ Asideofa
triangle,
rectangle or
polygon.
You must tap
two points to
measure a
side.
Tapping the
side
measures
the entire
length of the
object's
perimeter.

Area Area of a Circle,
Ellipse, Polygon,
Rectangle or
Triangle
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Measurement Type Use to
Measure...

6.74 Ay

46.9 cm*

Slope Slope of a Line,
Ray, Segment or
Vector
0.296
Angle Angles in the

7.62 Ay | range from 0° to
| 180° (0 radians
\ T to = radians in

1 the Graphs

[e] application)

1.05 rad

-12.89
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Transforming Objects

1. Tap Tools ¢, select Transformation, and select the type of transformation,
such as Symmetry. (In the Graphs application, go to Geometry >
Transformation > Symmetry.)

2. Tap the object you want to transform.

3. Tap a location, existing point or other object to create the transformation.

Exploring with Construction Tools

To add a construction, tap Tools #  select Construction, and select the type of
construction, such as Parallel. (In the Graphs application, go to Geometry >
Construction > Parallel.)

While a construction is in progress, a tool appears in the application Toolbar

/ Parallel Y
(for example, Parallel i). To cancel, tap the X on the tool.

Construction Type Description

Midpoint Bisects a
segment or
sets a
midpoint
between any
two points.
The points
canbeona
single object,
on separate
objects or on
the work
area.

Parallel Line Creates a
parallel line
with respect
to any
existing line.
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Construction Type

Description

7

The existing
line can be a
Graphs axis
or any side
of a triangle,
square,
rectangle or
polygon.

Perpendicular Line

+ =

Creates a
line thatis
perpendicula
rtoa
reference
line. The
reference
can be an
axis, an
existing line,
a segment or
one side of a
triangle,
rectangle or
polygon.

Perpendicular Bisector

Creates a
perpendicula
r bisector on
a segment,
on one side
of a triangle,
rectangle or
polygon or
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Construction Type Description

between any
two points.

Angle Bisector Creates an
angle
bisector. The
points of the
angle can be
on existing
objects, or
they can be
locations on
the work
area.

Locus Lets you
explore the
range of
motion of
one object
with respect
to another
objectas
constrained
by a shared
point.
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Construction Type Description

Compass Operates
similarly to a

geometric
compass
used for
drawing
4.05 cm \ circles on
paper.

Adjusting Variable Values with a Slider

In the Graphs, Geometry and Data & Statistics applications, a slider control lets
you adjust or animate the value of a numeric variable.

f1(x) =x2+vl

@ Horizontal slider for adjusting variable v/.

@ Minimised vertical slider for adjusting variable v2.
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Inserting a Slider

1.
2.

Startin a Graphs, Geometry or Data & Statistics page.

Tap Tools ¥ and go to Actions > Insert Slider.

The Slider Settings screen opens.

Cancel Slider Settings

Variable:
Value:
Minimum:
Maximum:
Step Size:
Style:

Display Digits:
Minimized
Show Variable

Show Scale

Enter desired values.

Tap OK.

oK
v

5

0

10
Automatic
Horizontal
Float 3
N0

AR

The slider is displayed in the work area. Handles on the slider let you
move or stretch it. To remove the handles, tap the work area.

To adjust the variable, slide the pointer (or tap the arrows on a minimised

slider).
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Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or
stop its animation. You can also change the slider's settings. To open the
context menu:

1. Touch and hold the slider.
The context menu opens.

Animate Settings... Move Delete

2. Tap an option to select it.

Using the Calculate Tool

The Calculate tool is available in the Graphs and Geometry applications. It lets
you evaluate a maths expression you have entered as a text object. You can
edit an evaluated expression and then re-evaluate it.

Entering the Expression

1. Tap Tools # and go to Actions > Text.
2. Tap the work area to place the text box and display the keyboard.
3. Type the expression, such as (1/4)2*2, and tap ENTER.

Note: Do notinclude variables in the expression.
ol
4

2
Calculating the Result

1. Tap Tools # and go to Actions > Calculate.

2. The Calculate tool appears in the toolbar, and a prompt asks you to select
an expression to calculate.

3. Tap the text object to evaluate the expression.
1

CRE
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Lists & Spreadsheet Application

The Lists & Spreadsheet application provides a place to work with tabular data.

What You Can Do
. Define a column based on the contents of another column.

*  Work with variables created in the Graphs & Geometry and Calculator
applications.

+ Plottable data using the Data & Statistics application.
* Generate a table of values for a function or plot.

»  Perform statistical analysis on lists of data.

What You Must Know

Typing a Cell Reference in a Formula

Absolute references include the $ symbol before the column letter and before
the row number, and always refer to the cell in a specific position in the
spreadsheet. Relative references include only the cell’s column letter and row
number, and describe where a cell is in relation to other cells of the
spreadsheet.

1. Double-tap the cell, and type the formula.

2. Move to the appropriate position in the formula, and type the cell
reference.

Use the format for a relative reference (B3), absolute reference ($B$2) or
range of cells (A1:A4).
Linking a Cell Value to a Variable

1. InaLists & Spreadsheet page, tap the cell that you wantto link to a
variable, and then tap the cell again to open the context menu.

2. Tap Link, and then tap the name of the variable to insertitinto the cell.
Linking a Column to a Variable

1. Tap the column formula cell (the second cell from the top) that you want to
link to a variable.
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2. Type the name of the list variable that you want to link to, and then tap
return.
Note: To view a list of available variables, tap var on the TI-Nspire™
Keyboard.

Adding a Lists & Spreadsheet Page

To get started with the Lists & Spreadsheet application, add a Lists &
Spreadsheet page to an existing document.

» Tap 1 and then tap .
A blank Lists & Spreadsheet page is displayed.

H 2 i

cs| @
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3
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=

Column and row reference cell

@ Column name cell for defining a column as a list variable
© Column formula cell for generating a column of data

Body cells

Working with Data

Generating Columns of Data
You can create a column of values based on the contents of another column or
on any of several types of sequential data.
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© Column formula based on a variable

a 3)
= ='xbarf2 |=a[]/2 =seqgen(n|
1 25 1/2 1
2 25 5/2 7
3 5 25 5/2 10
4 45 25 45/2 13
5 7 25 712 16

® Column formula based on another column

©® Column formula that generates a sequence

Creating Values Based on Another Column

1. Tap the column formula cell (the second cell from the top) of the column
where you want to use a formula.

2. Type the expression for the formula after the = and tap ENTER.

Note: Use brackets ([]) after any column letter you include in the formula.

Generating a Column of Random Numbers

1. Tap the column formula cell (the second cell from the top) of the column.

2. TapTools # and go to Data > Random > Integer to insert the randint()

function.

The app inserts the randint() function in the formula cell.

4. Type1,6,20,and thentap ENTER.

Note: The numbers given are for illustrative purposes only, and will
generate a column of 20 random integers in the range, 1 through 6.

Generating a Numerical Sequence:

1. Tap any cell in the column in which you want to generate the sequence.

2. TapTools ¥ and go to Data > Generate Sequence.

3. Type the Formula that will be applied to the column values.
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6.

Type any starting numbers required by the sequence in the Initial Terms
field and separate them with commas.

Type a starting value for the independent variable (n0), a maximum
number of values to be generated (nMax), and the step value (nStep).

Note: Type a maximum value for the sequence in the Ceiling Value field, if
desired.

Tap OK.

Graphing Spreadsheet Data

Creating a Scatter Plot with Quick Graph

1.

Name both of the columns to declare them as lists, and then select both
columns.

Tap Tools ¥ and go to Data > Quick Graph.
A Data & Statistics application is added to the page with the plotted data.

Creating a Summary Plot

Note: In this example, you create a summary table from raw data, and then use
the table to generate a summary plot.

1.

o o & w

Create a list that holds the category identifiers. For this example, name the
list “colour” and type strings for eye colour.

Create the summary list. For this example, name the list “counts” and type
the total count for each of the eye colours.

Select either list.
Tap Tools ¥ and go to Data > Summary Plot.
If necessary, change the lists for X Listand Summary List.

In the Display On field, select how to display the summary plotin the Data
& Statistics application, and then tap OK.

Capturing Data from Graphs or Geometry

1.
2,

Clear the columns you plan to use for the captured data.

Ensure that the data values you want to capture are linked to variable
names.
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3. Tap the column formula cell (the second cell from the top) of the column in
which you want to capture the values.

4. Tap Tools ¥ and go to Data > Data Capture > Automatic.
A capture expression is inserted.

5. Replace the letters “var” with the name of the variable to capture.

Note: You can also select the variable name from the Variables menu by
tapping var, and then tapping the desired variable.

Using Table Data for Statistical Analysis

Tools on the Statistics menu provide access to wizards that help you perform
statistical analyses on the data in table columns. You specify the location of the
data, and the Lists & Spreadsheet application stores the results in two columns:
one for the result names, and one for the corresponding values.

= o S
rs B8
o 8
List 0 8
o 1 B8
Alternate Hyp: Huprw | Bl
1st Result Column: Mo

= il =l

Statistical Calculations and Results

You can perform statistical calculations to analyse data.

Performing Statistical Calculations

Note: The following example fits a y=mx+b linear regression model to two lists.
1. Tap the column formula cell (second cell from the top) in column A.

2. TapTools  and go to Statistics > Stat Calculations > Linear Regression
(mx+b) to choose the regression model.

3. Tap next to the Y List box to display a named list. Tap the name of the
list for the Y List.

4. To store the regression equation in a specified variable, replace Save
RegEqn To with the name of the variable.
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5. Tap the 1st Result Column box and type c[] as the column letter for the
first result column.

6. Tap OK.
|D[ "Linear Regression (mx-+b)"

®|A B ylist c D t
= =LinRegM
1 55 11| Title Linear Re..|
2 23 20|RegEqn  |m*x+b
3 78 8m -0.073313
4 15 10/b 16.231
5 63 15 0.170525
6 r -0.412947
7 Resid {-1.1988...

Note: The results are linked to the source data.

Storing Statistical Results

The Lists & Spreadsheet application stores statistical results using a variable-
group name with the format stat.nnn, where nnn is the result name (for
example, stat RegEqn and stat.Resid). If you want to use a custom variable
group instead of the standard name, edit the formula in the column formula cell.
You could use the following formula to store the results in the variable group
MystatsB.

=LinRegMx(a[] ,b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression in the
Calculator application or in another column of the Lists & Spreadsheet
application:

MystatsB.results

Working with Tables
You can change the table of plots values using the tools on the Table menu.

» To remove a column from the table, click any cell, and then tap Tools »
and go to Table > Delete Column.

» To display the list of plots, tap the drop-down arrow on the top cell of a
column. Select an empty column, (unless you are replacing values already
displayed), and then tap a function in the list to add its values to the column.

» To change the expression that defines a plot, tap the formula cell and edit
the expression.
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Manual Data Capture

You can use Lists & Spreadsheet application to capture information about
objects in the TI-Nspire™ Apps for iPad®. For example, you could track
changes of the position of a point on a graph in the Graphs & Geometry
application.

The ability to capture data manually is not limited to Graphs & Geometry. This
function could work for any other application in the same problem.
Capturing Data Manually

1. Tap the column formula cell (the second cell from the top) of the column in
which you want to capture the values.

Note: Captured values replace values in the column.
2. TapTools © and goto Data > Data Capture >Manual.

A capture expression is inserted into the column formula cell with "var" as
a placeholder for the name of the variable you are capturing.

Al =caprure¢/m£0) ‘

A B IC D E F G H 1

w e Nl | v|s|lw i n|=|1|®

=]

~

13

3. Replace the letters “var’ with the name of the variable to capture from
Graphs & Geometry. For example, type a or to view a list of available
variables, tap var on the TI-Nspire™ Keyboard.

Lists & Spreadsheet Application 109



01, a

F
= 2
3

=cap£ure(a,ﬂ)

Note: The argument “0” tells Lists & Spreadsheet that you want to trigger
each capture manually.

4. Tap Enter.

From the Graphs & Geometry application, move the point to a different
location where x coordinate of the pointis stored in a variable (a, in this
example) referenced in the data capture expression.

. (-5.1,2.34)

(aa 74
=s &

6. Tap =a
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The current a value is stored in the Lists & Spreadsheet application
configured to capture the variable a.

B Fo B

A2]

A B

e

=capture('

-5.1962

See Using Variables for more information on adding and using variables.
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Data & Statistics Application

The Data & Statistics Application enables teachers and students to create
graphical displays and perform analysis on data stored in lists. Defining (or
naming) sets of data using the Lists & Spreadsheet Application is the starting
point for plotting and analyzing data.

What You Can Do

*  Work with sets of data in different types of plots.

»  Work with sets of data in different types of charts.

*  Manipulate variables to explore and visualize data relationships.

+  Explore central tendency and other statistical summary techniques.

» Fitfunctions to data.

+ Create regression lines for scatter plots.

+  Graph hypothesis tests and results (z- and t-tests) based on summary
statistics definitions or data.

What You Must Know

Plotting Variables
+ Lists created in Lists & Spreadsheet can be accessed as a variable.
*  Variables must be named before they can be used in Data & Statistics.

+ Tapthe Add Variable field located in the centre of the x-axis or y-axis to
choose a defined variable name.

+ The default plot for one variable is a dot chart. The data points in the
default caseplot reposition to represent the elements of the selected
variable.

* The default plot for two variables is a scatter plot. The data points shift to
represent the elements of both variables on a scatter plot.

Rescaling the Axes
Pinch or spread either the horizontal or vertical axis to modify its scale.

-OR-

Drag either axis to shift the axis while retaining its scale.
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To restore the original size and location of the plotted data, tap Tools >
Window/Zoom > Zoom-Data.

Plotting a Value

When you plot a value on an existing plot, itis displayed as a vertical line in the
work area. You can plot a single number or any expression that evaluates to a
number. If the value is dependent on the data, the line updates to reflect
changes made when you drag a point or make changes in the Lists

& Spreadsheet application. The plotted value must be in the domain of the axis.

To plot a value:

»

1. Tap Tools , go to Analyse, and then tap Plot Value.

2. Type the value you want to plot, and then tap ENTER.

Plotting a Function

Use Plot Function to graph a function for comparison to an existing plot. To plot
a function:

1. Create or open a problem that includes variables that are plotted in a Data
& Statistics work area. Ensure the work area contains both a horizontal
axis and a vertical axis.

#

2. Tap Tools , go to Analyse, and then tap Plot Function.

3. Type the function in the entry field and tap return.

Note: You can rename the function by typing over f1(x): with another name.

Adding a Data & Statistics Page

To get started with the Data & Statistics application, add a Data & Statistics
page to an existing document that contains a Lists & Spreadsheet page.

1. Tap T and then tap WL,

The Data & Statistics page shows the default caseplot.
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Caption: color
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Tap to add variable

2. Tap the add variable region on each axis to view defined variables.

Variables

{} class

{} handspan

{=} height

{} shoesize

3. Tap the variable name to add it to the selected axis to create a dot plot
(frequency plot).
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Working with Plots

Dot Plots

Box Plots

Histograms

Dot plots are also known as frequency plots, and
represent one-variable numerical data.

Dot plots are the default plot type for numerical
data.

One dot represents each value in the list.

Each dotis displayed on the axis at a point that
corresponds to the value.

Box plots are used to plot one-variable numerical
data in a modified box.

"Whiskers" extend from each end of the box.

Box plots are used to compare two or more sets
of data that use the same scale.

A histogram plots one-variable humerical data
and depicts the distribution of data.

The number of bins displayed depends on the
number of data points and how the points are
distributed.

A value that occurs on the edge of a bin is
counted in the bin to its right.

Shows one set of numerical data against the
corresponding quartile (z) of the standard normal
distribution.
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Scatter Plots
+  Shows the relationship between two sets of
numerical data.

* You also plot a scatter plot using the Quick Graph
tool in the Lists & Spreadsheet application.

X-Y Line Plots

+ This plotis a type of scatter plotin which data
points are plotted and connected in order of
appearance in the two variables.

L LT * An X-Y line plot depicts the relationship between
T two sets of data.

*  The left-most column of data is represented on
the horizontal axis.

Exploring and Analyzing Plotted Data
+ Drag a pointto move it. As you move a point, the values associated with
the point change in the work area and in the list of variables.

*+ To change a variable on an axis, tap the Add Variable region, and then tap
another variable name.

P

. From the Tools menu:

- Tap Plot Type to select another supported plot type.

- Tap Plot Properties to clear all variables or to modify properties such
as add and remove X and Y variables, add a summary list or force a
categorical X.

- Tap Actions to insert text or sliders. You can also select all points in
the plot.

- Tap Analyse to choose analysis options such as add a moveable line,
plot a value or function, or activate the Graph Trace tool.
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Working with Charts

Dot Charts

* The default plot type for categorical data is the
dot chart.

*  When one variable is plotted, the value of each
: ] o cell is represented as one dot.

* The dots are stacked at the point on the axis that
corresponds to the cell value.

« Barcharts display categorical data.

* The length of the bar represents the number of
cases in the category.

A pie chart represents categorical data in a circular
layout and uses a proportioned segment for each
category.

Exploring and Analyzing Data Plotted in a Chart

+ Drag a pointto move it. as you move a point, the values associated with it
change in the work area and in the list of variables.

P

. From the Tools menu:

- Tap Plot Type to choose another supported plot type.

- Tap Plot Properties to clear all variables, or to modify applicable
properties such as add and remove X and Y variables, add a
summary list, and force a categorical X.

- Tap Actions to insert text and sliders. You can also select all points in
the plot.
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- Tap Analyse to choose applicable analysis options such as adding a
moveable line, plotting a value or function, or activating the Graph
Trace tool.

Adding Colour to Plots and Charts

1. Tap a plotor chart object to selectit.

Note: To select all points in a plot, tap Tools > Actions > Select All Points.

e

2. Tap Inspector , and then tap Fill Colour.

3. Tap acolourto selectit.
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Notes Application

The Notes application enables you to create and share documents.

What You Can Do
» Create study notes to reinforce learning and review for exams.

* Share a Notes document with others and use text formatting options so
that each person's entries and comments appear in a different colour or
font.

* Create and evaluate maths expressions.

+  Create correctly formatted chemical formulas and equations.

What You Must Know

Deactivating a Selected Expression or Box

Note: You can also activate and deactivate a selected expression or box by
selecting Tools ¥ > Actions > Activate (Deactivate) All.

1. Tap the expression or box you want to select, and then tap again.

2. Tap Select.

Problem 1

—
Select Select All Paste

The selected text or item closest to the cursor is highlighted and the
handles are active.

Problem 1

I ut

3. Drag the handles to highlight the expression, maths box or chem box you
want to select.

Copy Paste Delete

4. Tap Tools ¢ and go to Actions.

5. Tap Deactivate Selection.
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Activating a Selected Item

1.
2,
3.

4.
5.

Tap the expression or box you want to select.
Tap Select.

Drag the handles to select the portion of the expression or text you want to
activate.

Tap Tools ¢ and go to Actions.

Tap Activate Selection.

Formatting Text in Notes

1.

Tap the text you want to format, and than tap it again to open the context
menu.

On the context menu, tap Select.

Drag the handles to select additional text, or tap Select All to select all of
the text.

Tap Inspector .

Font TI-Nspire Sans >

Size mpt| =+
Style B i u .
X‘ X

Fill Color

\

Select the formatting you want to apply. Changes are applied as you select
them.

select the Fexﬂ you want to format
L
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Inserting Comments, Shapes and Calculations

Inserting Comments

You can insert Teacher or Review comments into a Notes page. Comments are
labeled to make them easy to distinguish from the original text.

1.

2
3.
4

Tap the Notes work area where you want to inserta comment.

Tap Tools < and go to Insert.
Tap Comment.

Tap Teacher or Reviewer to choose the comment type.

» approxFraction(
[Teacher: ]

Type the comment text inside the comment box.

The comment text appears in bold formatting.

If needed, select the text and tap Inspector ** to apply formatting to the
comment text.

Inserting Geometric Shape Symbols

Use geometric shapes to designate selected text as a geometric object such as
an angle, circle or line segment.

1.

Tap the work area where you want to insert the shape, or select the text
that you want designate as a shape.

Tap Tools ¥ and go to Insert.

Tap Shape.
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Insert

Angle
Triangle
Circle
Line
Segment
Ray

Vector

4. Tap the shape name (such as segment or ray) to insert it before the
selected item.

/_ABC
or

AB
Inserting Calculations

1. Tap the Notes work area to place your cursor where you want to insert the
maths expression.

2. TapTools ¥ and go to Calculations.

Tools Calculations

Define Variables >
Number >
Algebra >
Calculus >
Probability >
Statistics >
Matrix & Vector >
Finance >
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3.

Tap the type of calculation you want to insert, and then tap the function
name to insert the expression.

Working with Maths Boxes

Inserting a Maths Box

1.

5.

Tap the Notes work area to place your cursor where you want to insert the
maths box.

Tap Tools ¥ and go to Insert.
Tap Maths Box.

Type the expression inside the maths box. You can also insert a function,

command, symbol or expression template by tapping Utilities ™ to access
Catalogue, Symbols, Maths Operators and Libraries.

Tap ENTER to evaluate the expression.

Converting Selected Items to Maths Boxes

1.

2.

Select the text, or combination of text and existing maths boxes, that you
want to evaluate.

ordinary text
lister(s+3)1
[ ]

Tap Tools < and go to Insert.
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Convert to Math Box

Chem Box
Shape >

Comment >
3. Tap Convertto Maths Box.

Inserting Chemical Equations

Use chemical equation boxes (chem boxes) to type chemical formulas and
equations such as:

CH, + 20, — CO, + 2H,0.Equations in a chem box cannot be evaluated or
balanced.

Entering a Chemical Equation
1. Position the cursor on the page where you want the equation.
2. TapTools ¥ and go to Insert.
3. Tap Chem Box.
An empty chemical equation box is added to the page.

4. Type the equation in the box. For example, to represent sulphuric acid,
type h2so4, capitalizing the O manually.

5. To exitthe chem box, tap outside the box.
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Question Documents Overview

The TI-Nspire™ App for iPad® enables you to receive question documents sent
by your teacher via email. The question document may contain multiple pages
and can contain any TI-Nspire™ application. When you tap question, the icon
changes to show you which application is active.

What You Can Do

When you receive a question document from your teacher, you can:
*  Open the document and answer the questions.

»  Show your work if requested by the teacher.

+  Check your answers if the teacher permits.

*  Email the document with your responses back to the teacher.

What You Must Know

Inserting Maths Boxes and Chem Boxes

You can insert a maths expression box or chemical equation box in any area of
the response that allows text. Use expression boxes to type properly formatted
maths expressions. Use chem boxes to type properly formatted chemical
formulas or equations. To insert an expression or chem box:

1. Tap the answer area to place the cursor where you want to place the box.

P

2. TapTools. ,and then tap Insert.

+ Tap Expression Box to insert a maths expression box.

+ Tap Chem Box to insert a chemical equation box.

-
1 r,

[/
< - - = |
Give the standard deviation of the distribution
of cars per household, to the nearest two
decimals.

Type the expression in the box.

Tap ENTER to complete the expression.
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Responding to Questions

Teachers may send you any of the following types of questions. Tap a question
type name to see how to respond to the question.

Note: You may need to scroll to see the entire question. All parts of the question
may not be visible on the page, and parts of a question may be hidden behind
a graph orimage.

Multiple Choice Questions

LAl .+ Tap the option or options next to the response

What is the root of x* = 9? you want to Se|eCt
9

3 . Choices with next them indicate that there is

3 only one correct answer.

-9
-3 . Choices with next to them indicate that there
may be more than one correct answer.

Open Response Questions

Type a response.

One word that describes two lines that never meet but are in the same plane:

Equation Questions

e - Type a response.

EN If a graph is included in the question,
the graph updates as you type the
, answer. Any functions entered show
' ‘ up on the graph, and the cursor
remains in the answer box.

You cannot manipulate the graph.

Expression Questions
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Coordinate Points

: (x,y) Questions

Wite the ordered pair for each given point in
order: J, N, P

Type a response.

If the teacher wants you to show
your work, the response area
has sections for you to enter the
steps and a final answer.

If the response type is Number,
your response must be in the
form of a number.

If the response type is
Expression, your response must
be in the form of an expression,
for example: x + 1.

Coordinate Points

x
0

Type an answer in the x-field box,
and then type an answer in the y-
field box.

As you enter values, the points
update on the graph work area.

: Drop Points Questions

| 2

Plot the following points on the
coordinate grid.

6,2)

0.2

0,-4)

Lists Questions

Tap a location on the graph
work area to drop a point at that
location.

To move a point, touch and hold
the point, and drag it to the new
location.
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Enter the data from today's class A list1 B list2
assignment.

1
2
3
4

Chemistry Questions

What is the chemical formula for Baking Soda?

Student: Enter chemical notation here.

Image: Label Questions

Label the Earth's layers.

A C

Image: Point on Questions

Type an answer in the desired cell.
Continue to type answers in different
cells until you are finished.

The behaviour closely matches the
behaviour of the Lists & Spreadsheet
application, with the following
exceptions. In a Lists question, you
cannot:

« Add, insert or delete columns

* Change the header row

+  Enter formulas

+  Switch to Table

*  Create plots

Type a response.

There is no need to inserta Chem
box. Chemistry response areas are
automatically formatted to accept
properly formatted chemical
formulas or equations.

—_

Tap a label on the image.

.

Type a response in the label
field.

128 Question Documents Overview



Tap the option or options next to the
answer you want to select.

The picture below shows a plant cell. Identify which organelle is responsible for
photosynthesis.

Showing Your Work, Checking Answers and Clearing
Answers

Showing Your Work

The teacher may ask you to show work for your response. If so, the teacher
provides the starting equation, and the response area has sections for entering
your steps and for the final answer.

Solve for y: x= 27y
27
==t
y
Enter step

Enter step
Enter final answer

Checking Answers

If the teacher enables self-check on a question, the Check Answer option
becomes available after you answer the question. To check your answer:

» Tap Tools 7 and go to Check Answer.
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Check Answer m

Your current answer is incorrect.

S

+ Ifyour answer is correct, a confirmation message is displayed. When you
close the message:

- Acheck mark is displayed next to the answer for multiple-choice
questions.

- The correct answer or suggested answer is displayed below the
student response for all other question types.

» Ifyouranswer is incorrect, tap Try Again or Show Correct Answer.

Clearing Answers

After you answer a question, you may decide you want to change the answer
before you submit it.

1. TapTools ¢ .

2. Tap Clear Answers.
*  Current Question clears answers for the active question.

+ Document clears answers for all questions in the active document.

Submitting Responses

When you finish answering all the questions in the document, save the
document and send it back to the teacher.

E’ .

1. From the open question document, tap Share
2. Tap Email Document.
Your default email client opens with the document as an attachment.

3. Type the email address and tap Send.
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Libraries Overview

Alibrary is a TI-Nspire™ document that contains a collection of variables,
functions and/or programs that have been defined as library objects.

What You Can Do

+  Create library documents for storing user-defined variables, functions or
programs.

* Use defined library objects in any TI-Nspire™ document.
» Add library objects to the Catalogue.
* Update orrefresh libraries so that objects are available to all documents.

» Create shortcuts to library objects.

What You Must Know

. Library documents are stored in the MyLib folder, which is located on the
TI-Nspire™ Home screen.

+ By default, the MyLib folder is shown on the TI-Nspire™ Home screen

when you install the application. To hide the folder, tap Settings @
Preferences, and then select OFF.

+  The TI-Nspire™ App installation includes a library document that contains
Linear Algebraic functions. The library is named linalg or linalgcas.

+ Ifyou delete or overwrite an installed library, you can restore it by
reinstalling the TI-Nspire™ App.

* Reinstalling the TI-Nspire™ App replaces all libraries in the default MyLib
folder. If you change an objectin an included library or replace an
included library document with your own document of the same name,
reinstalling overwrites your changes.

» Library objects are global in nature and accessible from any TI-Nspire™
document.

+ Library objects can be public or private. If designated as public, the library
object is accessible via Utilities > Libraries.

*  You can use the libshortcut() command to define shortcuts to library
objects. Defining a shortcut creates a variable group in the current problem
that contains references to all the objects in the specified library document.
You can choose to include or exclude private library objects.
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Creating Library Documents

A document is regarded as a library when itis placed in the MyLib folder on the
TI-Nspire™ Home screen.

1. Open a new TI-Nspire™ document and choose the Calculator +=
application.

2. Name the document.

+ Library document names must be a valid variable name, and they
must not contain a period or begin with an underscore.

* Alibrary document name must be between 1 and 16 characters long.
Drag the document to the MyLib folder.

4. Add library functions or programs to the document as needed.

Adding Objects to a Library Document

You can define functions or programs in the Program Editor, or by using the
Define command in Calculator to define variables, functions, or programs.
Library objects must reside in the first problem of a library document.

Defining a Function or Program Using Program Editor

1. TapTools ¢

and go to Functions & Programs.
2. Tap Program Editor > New.
3. Type the name of the library object.

+ Library object names must be a valid variable name, and they must
not contain a period or begin with an underscore.

» Alibrary object name must be between 1 and 15 characters long.
4. Selectthe type: function or program.

5. Setthe library access.

« Tap LibPriv to make the function or program accessible from any
document but not visible in the Catalogue.
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« Tap LibPub (Show in Catalogue) to make the function or
program accessible from any document and visible in the Catalogue.

6. Tap OK.

7. Type the information needed to complete the function or program in the
template.

8. Store the library object.
a) In Program Editor, tap Tools > Check Syntax & Store.
b) Tap Check Syntax & Store.

If no errors are present, the new library object is successfully stored.

"xsquare" stored successfully |

Define LibPub xsquare(}—
Func

Jf(x}—xz +3

EndFunc

9. Refresh the libraries to include the new library object in the Libraries
menu.

Defining a Library Object in the Calculator Application

1. From an open Calculator document, tap Tools 7

and go to Actions.
Tap Library.

Select Define LibPriv or Define LibPub.

B d

Type the information needed to complete the function or program in the
template.

5. Refresh the libraries to include the new library object in the Libraries
menu.

Private and Public Library Objects

When defining a new library object, you choose whether if is private (LibPriv) or
public (LibPub). Anytime you are in the same problem where an objectis
defined, you can access it by entering its short name (the name given when
using the Define command to create an object). This is true for all defined
objects, including private, public and non-library objects. For example:
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Define Command Object Short

Type Name
Define a=5 Non- a
library
Define LibPriv b=(1,2,3) Prvate b
Library
Define LibPub funcl (x) Public Juncl
==*2 + 1 Library

Private Library Objects

A Private library object does not appear in the Utilities, but you can access it by
typing its name. Typically, private library objects are used as building blocks
that perform basic, low-level tasks and are called upon by public programs or
functions.

Public Library Objects

A Public library object appears in Utilities > Libraries after you refresh the
libraries. You can access a public library object through the Utilities menu or by
typing its name.

In library programs and functions defined as public, a commentline (©)
immediately following the Prgm or Func line is automatically displayed as help
in the Catalogue. You could, for example, show a syntax reminder there.

P

» To enter a commentline, tap Tools and go to Actions > Insert Comment.

Accessing Library Objects

To use a library objectin any TI-Nspire™ document, type the object's long
name. The long name consists of the name of the object library document
followed by a backslash "\" followed by the name of the object. For example, if
the library document name is "lib1" and the object name is "func1," type
lib1\funci.

Using a Public Library Object

1. Open the TI-Nspire™ application where you want to use the variable,
function or program.
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Note: All applications can evaluate functions, but only the Calculator and
Notes applications can run programs.

2. Tap Utilites - and go to Libraries.
3. Tap the name of the object you want to use.
Note: If you do not see the object, refresh the libraries.
4. If arguments are required, type them inside the parentheses.

5. Tap return to insert the objectinto the document.

Using a Private Library Object

1. Open the TI-Nspire™ application where you want to use the variable,
function or program.

Note: All applications can evaluate functions, but only the Calculator and
Notes applications can run programs.

2. Type the name of the object, such as lib1\func1 ().

In the case of a function or program, always follow the name with
parentheses.

If arguments are required, type them inside the parentheses.

4. Tap return to insert the object into the document.

Viewing Arguments

If you cannot remember the exact name or the order of arguments required for
a private library object, you can:

» Open the library document that contains the object to view the arguments
and other information.

—OR-

» Type getVarinfo [library name string] in any open document to view a list
defined variables in an object.

—OR—
» Access the arguments and help through the Utilities menu.
a) Tap Utilities > Libraries.
b) Tap the name of the library you want to open.

c) Tap the name of the function you want to view.
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Libraries numtheory

primecount

primelist

pwrmod

randperm

real2contfrac

® Tools Wizard

primecount(a,b): #primes between a
&b

Refreshing Libraries

When you create new library objects, you must refresh the libraries so that the
objects are available to all documents.

1. Tap Utilities .
2. Tap Libraries.

3. Tap Refresh G

The Libraries are updated to include all new and edited library objects.

136 Libraries Overview



Program Editor Overview

The Program Editor enables you to define, edit and manage user-defined
functions and programs.

What You Can Do

Use programming templates and dialogue boxes to define function and
programs with the correct syntax.

Enter multiple-line programming statements without using a special key
sequence to add each line.

Create private and public library objects such as variables, functions and
programs.

What You Must Know

A program defined in the Program Editor is similar to functions builtinto the
TI-Nspire™ software, but there are some differences:

Functions must return a result, which can be graphed or entered in a table.
Programs do notreturn a result.

You can use a function, but not a program, within an expression. For
example, 3 x func1(3) is valid, but not 3 x prog1(3).

You can only run programs from the Calculator and Notes applications.
You can evaluate functions in Calculator, Notes, Lists & Spreadsheet,
Graphs, Geometry and Data & Statistics.

A function can refer to any variable; however, it can store a value to a local
variable only. Programs can store to local and global variables.

Note: Arguments used to pass values to a function are automatically
treated as local variables. If you want to store to any other variables, you
must define them as Local from within the function.

A function cannot call a program as a subroutine, but it can call another
user-defined function.

You cannot define a program within a function.

A function cannot define a global function, but it can define a local function.

Accessing the Program Editor

Program Editor is accessible from the Calculator application.
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1. Open a document with the Calculator st application active.

»

2. Tap Tools and go to Functions and Programs.

3. Tap Program Editor.

Functions & Programs Prog ram Editor

Options enable you to define a new program, open an existing program, or
import a program from the Library.

4. Tap an option, complete the required information, and then tap OK.

The Program Editor opens with the selected template active on the right
side of the screen.

[revpog @ o7
Prgm Define newprog()=
EndPrgm (1] ??”"‘
EndPrgm
o Calculator work area. Tap the left side of the screen to

return to and work in the Calculator application.

(2] Program Editor work area. This is the default work area
when Program Editor opens. If the Program Editor is not
active, tap the right side of the screen.

@ Status line. Shows the line number information and the
name of the function or program being defined or edited.
An asterisk (*) indicates that this function has been
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changed since the last time syntax was checked and the
function was stored.

Defining a New Program or Function

From the Calculator application:

1. Tap Tools s and go to Functions & Programs.

2. Tap Program Editor, and then tap New.

New Coc |
Name:
Type: Program E
Library Access: None E

3. Type a name for the new function or program.

Note: Program and function names cannot contain spaces.
4. Selectthe Type (Program or Function).

Set the Library Access:

* Choose the default None to use the function or program only in the
current document or problem.

« Tap LibPriv to make the function or program accessible from any
document but not visible in the Catalogue.

« Tap LibPub (Show in Catalogue) to make the function or
program accessible from any document and visible in the Catalogue.
6. Tap OK.

The Program Editor opens with a template matching the selections you
made.
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o T

Entering Lines into a Function or Program

The Program Editor does not execute the commands or evaluate expressions
as you type them. They are executed only when you evaluate the function or

run the program.

+  When arguments are required, type parameters in the parentheses that
follow the program name. Separate parameters with a comma.

* new

0N

Define new(a,b{)=
Prgm

EndPrgm

»  Type the lines of statements that make up your function or program
between the Func and EndFunc (or Prgm or EndPrgm) lines.

* new

313

Detine new{a,b)=
Prgm

Disp "a=",a
Disp "=".,b

Disp "arb=",aP
EndPrgm

statement.

You can either type the names of the function and commands, or insert
them from the Catalogue.

If a line is longer than the width of the screen, scroll to view the entire

After typing each line, tap return to insert a new blank line.
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+ Tap theright, left, up and down arrows to scroll through the function or
program.

Checking Syntax

To check the function or program for correct syntax:
1. Make sure the Program Editor is active.

2. Tap Tools 7

and go to Check Syntax and Store.
3. Tap Check Syntax.

If the syntax checker finds any errors, it displays an error message and
positions the cursor near the first error.

Error “

Syntax

N
Syntax |

Define synta.x{a,b}*
Prgm

disp n a_ll n
EndPrgm

La

Storing a Function or Program

You must store a function or program to make it accessible. The Program Editor
automatically checks the syntax before storing. An asterisk (*) before the
program or function name indicates that it has not been stored. To store a
function or program:

1.  From the Program Editor, tap Tools s

and go to Check Syntax and Store.
2. Tap Check Syntax & Store.

Program Editor checks for syntax errors and stores the program.
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"cube” stored successfull

Define LibPub cube(n)=

+ If no syntax errors are found, the message "stored successfully" is
displayed in the status line after the program or function name.

+ If syntax errors are found, an error message is displayed and the
cursor is positioned near the first error.

+ Ifthe function or program is defined as a library object, you must also
save the documentin the designated library folder and refresh
libraries to make the function or program accessible to other
documents.

Opening Functions or Programs for Editing

Note: You cannot modify a locked program or function. To unlock the object, go
to a Calculator page and use the Unlock command.

Opening a Function or Program in Calculator

P

1. Tap Tools and go to Functions & Programs.
2. Tap Program Editor, and then tap Open.

The list of defined functions and programs available to the current problem
opens.

Variables

ﬂ cube

f  sumintegers

3. Tap the function or program name to open itin Program Editor.
Opening a Function or Program in Program Editor

»

1. Tap Tools and go to Actions.

2. Tap Open.
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3. Tap the function or program name to open itin Program Editor.

Note: To close the function or program, tap Tools > Actions > Close. The
program or function closes and the Calculator page becomes active.

Importing Programs

You can import a function or program defined as a library object into a Program
Editor within the current problem. The imported copy is not locked, even if the
original is locked.

Importing a Program from a Library

1. From the Program Editor, tap Tools 7 and go to Actions.
2. Tap Import.
| Cancel”| Import ok
Library Name: linalg @
Name: check_type_arg a
Import As: check_type_arg
3. Inthe Library field, tap , and then tap the library name you want to
import.
4. Inthe Name field, tap , and then select the name of the object.

5. Ifyou wantthe imported object to have a different name, type the name in
the Import As field.

6. Tap OK.

Importing a Program from Calculator

#

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor, and then tap Import.
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3. Inthe Library field, tap , and then tap the library name you want to
import.

4. Inthe Name field, tap , and then select the name of the object.

5. Ifyou wantthe imported object to have a different name, type the name in
the Import As field.

6. Tap OK.

The program opens in Program Editor.
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