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Using DataQuest on a Computer 

This appendix gives an overview of using the 
Vernier DataQuest application on a computer 
running the TI-Nspire software. It includes 
information on accessing the common tools in the 
DataQuest Application. 

DataQuest is included in TI-Nspire computer 
software versions 3.0 and newer.  This appendix 
shows screenshots for TI-Nspire computer 
software version 3.6 and newer. If you have an 
older version of TI-Nspire software, you can get 
updates at education.ti.com. 

The TI-Nspire Software 

Access Menus 

DataQuest can be used to collect, display, and analyze data. Most 
features can be accessed using the application menus found in the 
Document Tools shown in the Documents Toolbox. If the Documents 
Toolbox is not displayed, you can show the menus by selecting 
Document Tools from the Window menu. 

Access Context Menus 

To access context menus on a Windows
®
 computer, right-click the 

object. To access context menus on a Macintosh
®
 computer, control-

click the object. (In this document, right-click is synonyms with 
control-click on a Mac.) 

Open a New Document 

To open a new document, choose New TI-Nspire Document from the File menu. Having 
only one TI-Nspire document opened when using DataQuest is recommended. 

Add a Page or Problem 

To add a new page or problem to your TI-Nspire document, choose Page or Problem 
from the Insert menu. 

Save a document 

To save your TI-Nspire document, choose Save Document from the File menu. 

Scratch Pad Calculator 

The Scratch Pad Calculator is a built-in calculator that can be 
used to perform calculations while you are conducting an 
experiment. To use the Scratch Pad Calculator, choose Keypad 
(student software) or TI-SmartView™ Emulator (teacher 
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software) from the Window menu. Press » on the keypad to access the Scratch Pad Calculator. 

Start DataQuest  

DataQuest should automatically start when TI-Nspire software 
is running on your computer and you connect a TI-Nspire Lab 
Cradle, Go! Link interface, Go!Temp temperature probe, or 
Go!Motion motion detector. 

Manually Launch DataQuest 

To start DataQuest manually, choose  Vernier DataQuest 
from the Insert menu. 

Views in DataQuest 

There are three views in the DataQuest application: Meter, Graph, and Table. Click a 
tab to change views or choose the desired view from the View menu. 

On the left side of the screen in each view, you will see the View details box. The 
Meter View details box shows the data-collection settings. The Graph View details 
box shows graph trace and analysis information. The Table View details box shows 
data set variable information. 

 

Data Collection Settings 

Change the Data-Collection Mode 

1. Choose the Collection Mode from the  Experiment menu or 
click Mode in the Meter Details area. 

2. Select the data-collection mode you want to use. 

 Note: Changing modes will require you to discard any collected 

data. To avoid losing data, save the current document and open a 

new document, or insert a new problem in the current document. 

3. A dialog showing the data collection settings for the mode you have selected will be displayed. 
Adjust the settings as desired for your experiment. 

4. When you are done setting up the data collection, select OK. 

 
Change Data-Collection Settings 

When you have already set up the data-collection mode and want to make 
changes to the settings, you can change the values you have entered. 

1. Choose Collection Setup from the  Experiment menu. 

2. Make the necessary changes and select OK. 
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Note: You may also make changes to the Rate and Duration of the experiment by clicking on the 
Rate or Duration box in the Meter Details area. 

Sensor Settings 

Change Units 

1. Choose Set Up Sensors ► Name of Sensor from the  Experiment menu 
or click the sensor’s meter to display the Sensor Settings dialog box. 

2. Choose the measurement units from the drop-down menu.  You can also 
choose the sensor’s precision, color and point marker from this dialog. 

Calibrate a Sensor 

Not all sensors can be calibrated. Check the sensor booklet for specific information about your 
sensor. For most experiments, the sensor’s stored calibration is recommended. In some instances, 
you may want to calibrate a sensor to get readings that are even more accurate. 

1. Choose Calibrate from the  Experiment menu or right-click 
the sensor’s meter and select Calibrate. Select the appropriate 
calibration option for your situation: 

 Manual Entry – Use Manual Entry when you know the calibration 
equation and want to enter the coefficients directly. 

 Two Point – Use Two Point for most calibrations.  

 Single Point – Use Single Point when only one known calibration value is attainable (for 
example, calibrating a Barometer to match the current atmospheric pressure). Single Point 
calibration will only affect the intercept of the calibration equation. 

 
2. Perform a live calibration (Two Point or Single Point). 

a. Place the sensor in the desired calibration environment, enter the 
reference value, wait for the voltage readings to stabilize, and 
select Keep. 

b. Two Point only – place the sensor in a second calibration 
environment, enter the reference value, wait for the voltage 
readings to stabilize, and select Keep. 

 
3. Note the updated calibration equation, modify if necessary (Manual 

Entry), and select OK. 

Zero a Sensor 

Not all sensors can be zeroed. Check the sensor booklet for specific 
information about your sensor. 

To zero a sensor, select Set Up Sensors ► Name of Sensor from the  
Experiment menu or click the sensor’s meter. If you can Zero the sensor, a 
Zero button is located in the lower left corner of the dialog box.  Note: 
When you have more than one sensor you want to zero at the same time, 
select Set Up Sensors ► Zero ► All Sensors from the  Experiment menu. 

Reverse a Sensor 

Not all sensors can be reversed. Check the sensor booklet for specific information about your sensor.  
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Choose the sensor name in Set Up Sensors from the  Experiment menu or 
click the sensor’s meter and select the Reverse Readings box. The sign of 
the sensor reading is changed as noted in the example. 

Sensors that do not Auto-ID 

The DataQuest Application supports older sensors that do 
not auto-ID. To manually set up a sensor, connect the sensor 
to the interface and the interface to your computer. Choose 
Advanced Set Up ► Configure Sensor from the  
Experiment menu, and select the interface and channel your 
sensor is connected to . Select your sensor from the drop down list and click OK. 

Sensors that do not auto-ID must be set up everytime they are used and will not be identified by the 
software when opening a saved file. 

Data Collection 

Start Data Collection 

To start data collection, click the Start Collection button or choose Start 
Collection from the  Experiment menu. 

Keep Data Points (Event Based Data Collection) 

To store a data point during Events with Entry or Selected Events experiments, click 
the Keep button or choose Keep from the  Experiment menu. 

Stop Data Collection 

To stop data collection, click the Stop Collection button or select Stop 
Collection from the  Experiment menu. 

Extend Data Collection (Time Graph Collection) 

To extend a time graph experiment duration to one and one-half times 
the current duration, choose Extend Collection from the  Experiment 
menu before or during a collection. The time listed in the menu will be 
the new duration for the experiment. 

Store Data Sets 

To store a data set, click the Store Latest Data Set button or choose Store Data Set 
from the  Experiment menu. 

Graphical Display of the Data 

By default, DataQuest will graph the most recent (latest) data 
set on the graph. When two or more of the same type of 
sensor are connected, data from those sensors will be plotted 
on the same graph. 
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When you have two different types of sensors connected, data from the different sensors will be 
plotted on two separate graphs. 

When a Motion Detector is connected, two graphs will be displayed – position and velocity. 

Show Graphs 

To change the graph displayed, select Show Graph from the  Graph 
menu. You can select Graph 1, Graph 2, or Both. The two graphs can have 
different dependent (y-axis) data with different ranges; however, they must have 
the same independent data and range. 

Change what is graphed on the axes 

To change the data columns plotted on a graph, right click the axis label, or 
select X-Axis Column or Y-Axis Columns from the  Graph menu. Select 
from the available columns. Use the More option to plot multiple columns on 
the same axes. 
 

Change which data set is graphed 

To plot a different data set or multiple data sets on the same graph, click the run 
indicator or choose Select Run from the  Graph menu. 

Select All to display all data sets. 

Select the runs to display.  You can display any combination of stored data sets. 
 
Adjust the Graph Window Settings 

To manually adjust the window settings, click the axis labels or choose 
Window Settings from the  Graph menu. 
 
Draw Prediction 

Use the draw prediction feature before data collection to predict the outcome 
of the data collection. To add a prediction to a graph, choose Draw Prediction 
from the  Analyze menu and select Draw. Click the graph in the desired 
locations. When finished press the Esc key. 

To remove a prediction, choose Draw Prediction from the  Analyze menu, 
and select Clear. 
 

Analyze Data 

You can perform multiple types of analysis on your data. For most 
analysis options, the results will apply to all data points unless a region of 
data is selected first. Choose your desired analysis option from the  Analyze 
menu. 
 
Interpolate 

Use Interpolate to examine a graph trace between and beyond the graphed data 
points. The examine line will move from pixel to pixel instead of data point to data 
point. This is recommended when examining curve fits. 
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Tangent 

Use Tangent to get a measure of the rate of change of the data at a specific point. A 
segment is drawn on the graph to help visualize the rate and the rate of change 
(labeled slope) is displayed in the Graph View details box. 

Integral 

Use Integral to get a measure of the area between your data and the x-axis. Find the 
area under all data points or under a selected region of the data. You can adjust the 
region used by clicking and dragging the brackets. The integral region is shaded on the 
graph and the area is displayed in the Graph View details box. 

Statistics 

Use Statistics to find minimum, maximum, mean, and standard deviation of your 
data. Find these values for all data points or a selected region of the data. You can 
adjust the region used by clicking and dragging the brackets. The statistical values 
are displayed in the Graph View details box. 

Curve Fits 

Use Curve Fits to find the best-fit equation of a curve fit function. 
Curve fit all data points or a selected region of the data. You can adjust the region 
used by clicking and dragging the brackets. The curve fit equation is graphed on 
the axes and the equation values are displayed in the Graph View details box. 

Model 

Use Model to manually fit a mathematical equation to your data. A model differs 
from a Curve Fit in that there are no statistical or iterative processes used to 
determine the best fit. You can define your models using any function of the 
variable x. 

To enter a model: 

1. Choose Model from the  Analyze menu. 

2. Select one of the predefined equations or enter your own. The model must 
be a function of the variable x. 

3. Enter your estimates for the coefficient values. 

4. Modify the spin increment value if desired. 

5. Select OK.  

 
You can adjust the coefficients in your model to obtain a good 
match of your data.  

 Click on the spin increment buttons ( ). 

 Click on the coefficient and type a new value. 

 Right-click the Graph View details box, then select the Modify 
Model option. 
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Remove an analysis feature from a graph 

Use the remove option to remove an analysis (integral, statistics, curve fit, or model) from a graph. 
To do this, choose Remove from the  Analyze Menu. If there are more than one, the analysis 
options will be listed in the order in which they were created. 

Select a Region on a Graph 

When you want to look more closely at a specific region of data or 
analyze only a portion of the data, you can click and drag across the 
graph to select a region. The selected region is indicated by shading. 
Once a region is selected, you can: 

  Zoom in on the region (Choose Zoom In from the  Graph 
menu) 

 Analyze the region (see above) 

 Strike the data within or outside the selected region (see below). 
 
Strike Data 

When there are data points that you wish not to have considered in the 
graphing or analysis of your data, you can “strike” that data. Striking data does 
not delete the data; rather, data is displayed in the data table with a single line 
drawn through it and calculated column cells based on struck data will be 
blank. Struck data is not displayed on the graph. 

To strike data, select a region, then choose Strike Data 
from the  Data menu. Select whether to strike through 
data inside or outside the selected region. 

Restore Data 

Use this option to restore struck data. Select a region (optional), then choose 
Restore Data from the  Data menu. Select whether to restore data In Selected 
Region, Outside Selected Region, or Restore All Data. 

Tabular Display of the Data 

DataQuest also displays data in a data table. In addition to viewing 
collected sensor data, you can enter data manually and perform 
column calculations. Use the scroll bar and scroll buttons to view 
the data. 

Data collected will populate the Latest Data Set in the table. This 
data set is identified with red, bolded text in the Table View 
Details box. Storing a Data Set will change the data set identified as 
the Latest. 
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Data Set Options 

To change the name of a run or to add notes about the data set, double-click 
the run name or right-click the table and select Data Set Options. 

Column Options 

Use the column options to change the name of the column and to modify 
the display precision of any column. Choose Column Options from the  
Data menu and select the column you wish to modify. 

Calculated Columns 

Calculated columns are used to generate data based on existing columns in a 
data set. For example, you may want to calculate gravitational potential 
energy from height measurements or you may want to linearize pressure-
volume data by plotting pressure vs. the reciprocal of the volume data. 

To add a calculated column, choose New Calculated Column from the  
Data menu. The equation you enter must use one of the data columns in the 
data set.  

Manually Entered Data 

For experiments that require hand-entered data, launch DataQuest in a 
new document or problem without any sensors connected. Use the 
default x and y columns to manually enter data values. You can use the 
Column Options to rename your columns if desired (see above). 

To add additional manual columns, choose New Manual Column from 
the  Data menu. 

DataQuest Options 

Points Options 

Use the point options to determine how the data are drawn on the graph. To 
access the Point options, choose Point Options from the  Options menu. 

Mark refers to the symbol used to distinguish the different traces on a graph. 
The Mark options are None, Regional, or All. You can also choose whether to 
have the data points drawn connected. 

Regional/Connected is the default for Time Graph data collection. All/Not 
Connected is the default for Event based data collection. 
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Autoscale Settings 

Use the Autoscale Settings to set the scaling behavior of the 
application during and after data collection. To access 
Autoscale Settings, choose Autoscale Settings from the 

 Options menu. 

 Autoscale Larger – expands the graph range when needed 
to ensure each data point appears on the graph. This is the 
default setting and only applies while collecting data. 

 Autoscale From Zero – adjusts the graph range to ensure all data points and the origin (0,0) are 
displayed with little or no extra space. This only applies after collection is complete. 

 Autoscale to Data – adjusts the graph range to show all data points with little or no extra space 
around the points. This is the default setting and only applies after data collection. 

 Do Not Auto Scale – maintains the current window range regardless of the collected data. This 
can be applied either during or after collection. 

 
Derivative Settings 

Use the derivative settings to set the number of points 
used in derivative calculation. The default value is five. 
To access this setting, choose Derivative Setting from the 

 Options menu. 

Print All Settings 

Use the Print All settings to determine which 
DataQuest views are printed when the Print All printing option is used. 
Choose from Print Current View (default), Print All Views, or select any 
one or combination of views to print. The Print All Settings are specific 
to each DataQuest App so multiple instances of the app must be set up separately. 

To access Print All Settings, choose Print All Settings from the  Options menu. 

Show/Hide Meters 

You can display (or hide) a meter for any column of data. 
This is useful for calculated columns of data. To select 
which meters to display, choose Show/Hide Meters from the 

 Options menu. Note: Meters for calculated columns will 
only show live values during data collection. 
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Hide View Details (Show View Details) 

The View details boxes, tabs, and collection buttons can be 
hidden if desired. To hide the View details, choose Hide 
View Details from the  Options menu. When the details 
are hidden, use the menus to change views and control data 
collection. 

Note: View details will automatically be hidden in some 
split screen views and when the application window gets too 
small. 

To show View details when they are hidden, choose Show 
View Details from the  Options menu. 

Print a Document 

To print a TI-Nspire document, choose Print from the File 
menu, or use Ctrl+P. When printing, you have two options, 
Print All and Viewable Screen. Viewable Screen is the 
default print option. 

Print Viewable Screen is a what-you-see-is-what-you-get 
(WISIWYG) style of printing. Each page in your TI-Nspire 
Document is printed as it appears on the screen. 

Print All will print all information for a specific application 
whether or not it appears on the screen. Print All includes 
printing a full page for each selected view along with the 
each view’s details (for example, data collection settings 
and analysis details). Which views print is determined by 
the Print All Settings (see above). 
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DataQuest Cursors 

The DataQuest application uses several different cursors to help identify when there is some special 
feature available to you through mouse interaction (click, right-click, click-and-hold, and more). The 
table below will give you a brief explanation of the different cursors used. 

 
 
Cursor 
 

 
Description 

 
 

 Pointer – The standard cursor you see when using DataQuest. 

 

 

 
Horizontal Resize Cursor – This cursor is shown when you are over the location of an object 

that can be resized in a horizontal direction. The locations where the Horizontal Resize cursor 

appears are: 
 
► The right edge of and View Details box in Meter, Graph and Table View. This will allow you 

to resize the details box. 

► The left one-third of the horizontal (x-) axis. This allows you to dynamically adjust the x-min 

window-setting value without changing the x-max value. 

► The right one-third of the horizontal (x-) axis. This allows you to dynamically adjust the x-

max window-setting value without changing the x-min value. 

► The left edge of a table cell. This allows you to adjust the width of the column to the left of 

the cursor. 
 
Click-and-hold to grab the object and resize it. After the object has been grabbed, the cursor 

changes to . Move the cursor left or right to resize the object. Release to anchor the object. 
 

 

 

 
Vertical Resize Cursor – This cursor is shown when you are over the location of an object 

that can be resized in a vertical direction. The locations where the Vertical Resize cursor 

appears are: 
 
► The space between two DataQuest graphs when both graphs are shown. This will allow you 

to resize the two graphs as desired. The default is to show both graphs the same height. 

► The top one-third of the vertical (y-) axis. This allows you to dynamically adjust the y-max 

window-setting value without changing the y-min value. 

► The bottom one-third of the vertical (y-) axis. This allows you to dynamically adjust the y-min 

window-setting value without changing the y-max value. 
 
Click-and-hold to grab the object and resize it. After the object has been grabbed, the cursor 

changes to . Move the cursor left or right to resize the object. Release to anchor the object. 
 

 

 

 
Translation Cursor – This cursor is shown when you are over the location of an object that 

can be repositioned up-and-down or left-and-right. The locations where the Translation cursor 

appears are: 
 
► The middle one-third of the horizontal (x-) axis. This allows you to dynamically adjust the  

x-min and x-max window setting values by the same amount, simultaneously. The graph will 

appear to move left or right. 

► The middle one-third of the vertical (y-) axis. This allows you to dynamically adjust the y-min 

and y-max window setting values by the same amount, simultaneously. The graph will appear 

to move up and down. 
 
Click-and-hold to grab the object and resize it. Move the cursor to resize the object. When you 

move the object, the cursor changes to . Release to anchor the object. 
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Cursor 
 

 
Description 

 
 

 

 
Text Edit Cursor – This cursor is shown when you are over the numeric graph-axis labels. 

Click to edit the value. Press Enter to save the change. Press Esc to exit without making a 

change. 
 

 

 

 
Hollow Pointer – This cursor is shown when the object underneath is selectable in some way. 

The locations where the Hollow Pointer appears are: 
 
► The graph-axes text label. Right-click to change what is graphed on the axis. 

► The analysis selected-region brackets ( [ or ] ). Right-click to grab a bracket. Move the 

cursor left or right to adjust the region used in the analysis calculation. Release to anchor the 

bracket. 
  

 

 

 
Pencil Cursor – This cursor is shown when Draw Prediction is active. Move the cursor to the 

desired location and Click to add a point. Repeat as necessary. Press Esc to end your 

prediction. 
 

 


